#!/usr/bin/make -f
#
# Modified by pts@fazekas.hu at Sat Mar 29 22:33:49 CET 2003
#
# Made with the aid of debmake, by Christoph Lameter,
# based on the sample debian/rules file for GNU hello by Ian Jackson.

package=pts-tetex-tt2001

CMD=debian/tmp/usr/share/texmf/fonts/type1/public/tt2001/tt2001.t1c
CMT=tt2001.t1c

build: t1c2pfb $(CMT)
	$(checkdir)
	$(MAKE) -f debian/rules t1c2pfb $(CMT)
	touch build

pfb2t1c: debian/pfb2t1c.c; sh $<
t1c2pfb: debian/t1c2pfb.c; sh $<
$(CMT): pfb2t1c
	mkdir -p $(dir $(CMT))
	touch $(CMT)
	(cd pfb; for F in *.pfb; do echo "$$F" >&2; ../pfb2t1c "$$F"; done) >$@

clean:
	$(checkdir)
	-rm -f build
	-$(MAKE) clean
	-rm -f `find . -name "*~"`
	-rm -rf debian/tmp debian/files* core debian/substvars
	-rm -f core DEADJOE a.out
	-rm -f config.status config.cache config.h
	-rm -f t1c2pfb pfb2t1c
	-rm -rf autom4te.cache

binary-indep: checkroot build
	$(checkdir)
# There are no architecture-independent files to be uploaded
# generated by this package.  If there were any they would be
# made here.

binary-arch: checkroot build
	$(checkdir)
	-rm -rf debian/tmp
	install -d debian/tmp
	cd debian/tmp && install -d `cat ../dirs`
	ln $(CMT) $(CMD)
# ^^^ ln occupies less space on disk than cp_r
	cp t1c2pfb debian/t1c2pfb.pl debian/tmp/usr/bin
# ^^^ conflicts (Replaces:) with pts-tetex-cm-super
	cp dvips/*.map dvips/config.tt2001 debian/tmp/etc/texmf/dvips
	cp dvipdfm/*.map debian/tmp/etc/texmf/dvipdfm
	chown 0.0 $(CMT)
# Must have debmake installed for this to work. Otherwise please copy
# /usr/bin/debstd into the debian directory and change debstd to debian/debstd
	debstd ChangeLog README TODO FAQ
	dpkg-gencontrol -isp
	chown -R root.root debian/tmp
	chmod -R go=rX debian/tmp
	dpkg --build debian/tmp ..

define checkdir
	test -f debian/rules
endef

binary: binary-indep binary-arch

checkroot:
	$(checkdir)
	test root = "`whoami`"

.PHONY: binary binary-arch binary-indep clean checkroot
.PHONY: source
source: clean
	DIR="`pwd`";DIR="$${DIR##*/}"; cd .. && dpkg-source -b "$$DIR"