Subject: FVWM: libXpm.so.4.11, xpm.h, fvwm2 installation dilemnas etc.

From: "Ahmed Aden" <[email-masked]>
Date: Thu, 09 Dec 1999 15:58:18 GMT

As someone who is not familiar with the innerworkings of Xwindows, I'm 
trying to understand what all these things have to do with Fvwm, I'll 
include the full path on my machine for stuff so as not to confuse anyone:

1). /usr/local/X11/include/X11/xpm.h
2). /usr/local/X11/lib/libXpm.so.4.11
3). /usr/include/X11/bitmaps

Additionally, here is how I tried to compile it, and this is the output it 
gave me. It choked when it looked for a C++ compiler, so that is why I opted 
to remove the search for it.  The other stuff is just futile attempts to try 
to get it to look for the libs/xpms (I don't know what I'm talking about:>). 
  I've  included all the output of the config in an attempt to give you the 
most information possible.  I thought libXpm.so.4.11/xpm.h would be all I 
needed, but apparently I'm doing something wrong.  Also, would the 
ModulePath be the directory that contains FvwmPager/, FvwmBanner/, 
FvwmAnimate/ etc.?

Lastly, IconPath and PixmapPath are needed in the .fvwm2rc file, I don't 
have a clue where to find these, any documentation on these fundamental 
concepts would be greatly appreciated.  After having used fvwm2 at another 
company for 5 mos. I think it's worth this week of frustration. Thanks!

(aaden)bart:~/fvwm2/fvwm-2.2.4$ LDFLAGS=-R/usr/local/X11/include/X11 
./configure --without-cxx 
--with-xpm-library=/usr/local/X11/include/X11/xpm.h 
--with-xpm-includes=/usr/local/X11/include/X11/xpm.h

loading cache ./config.cache
checking for a BSD compatible install... ./install-sh -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... (cached) yes
checking for working aclocal... missing
checking for working autoconf... missing
checking for working automake... missing
checking for working autoheader... missing
checking for working makeinfo... missing
checking whether to enable modal dialogs for applications... yes
checking whether to enable saveunders for pop-up menus... yes
checking whether to enable shape extensions... yes
checking whether to enable ActiveDown button state... yes
checking whether to enable Inactive button state... yes
checking whether to enable MiniIcon style option... yes
checking whether to enable vector button style... yes
checking whether to enable pixmap button style... yes
checking whether to enable gradient button style... yes
checking whether to enable stacked button styles... yes
checking whether to enable styled title-bars... yes
checking whether to enable BorderStyle command... yes
checking whether to enable UseDecor style option... yes
checking whether to enable WindowShade function... yes
checking whether to enable debugging messages... no
checking iconpath... /usr/include/X11/bitmaps:/usr/include/X11/pixmaps
checking for gcc... (cached) gcc
checking whether the C compiler (gcc  -R/usr/local/X11/include/X11) works... 
yes
checking whether the C compiler (gcc  -R/usr/local/X11/include/X11) is a 
cross-compiler... no
checking whether we are using GNU C... (cached) yes
checking whether gcc accepts -g... (cached) yes
checking how to run the C preprocessor... (cached) gcc -E
checking for POSIXized ISC... no
checking for minix/config.h... (cached) no
checking for stdarg.h... (cached) yes
checking for vfprintf... (cached) yes
checking for waitpid... (cached) yes
checking for X... (cached) libraries /usr/openwin/lib, headers 
/usr/openwin/include
checking whether -R must be followed by a space... no
checking for dnet_ntoa in -ldnet... (cached) no
checking for dnet_ntoa in -ldnet_stub... (cached) no
checking for gethostbyname... (cached) no
checking for gethostbyname in -lnsl... (cached) yes
checking for connect... (cached) no
checking for connect in -lsocket... (cached) yes
checking for remove... (cached) yes
checking for shmat... (cached) yes
checking for IceConnectionNumber in -lICE... (cached) yes
checking for cpp... (cached) /usr/ccs/lib/cpp
checking for a BSD compatible install... ./install-sh -c
checking whether ln -s works... (cached) yes
checking whether make sets ${MAKE}... (cached) yes
checking for ranlib... (cached) ranlib
checking for flex... (cached) flex
checking for flex... (cached) flex
checking for yywrap in -lfl... (cached) no
checking lex output file root... (cached) lex.yy
checking whether yytext is a pointer... (cached) no
checking for bison... (cached) bison -y
checking for ANSI C header files... (cached) yes
checking for sys/wait.h that is POSIX.1 compatible... (cached) yes
checking for stdlib.h... (cached) yes
checking for fcntl.h... (cached) yes
checking for limits.h... (cached) yes
checking for malloc.h... (cached) yes
checking for string.h... (cached) yes
checking for memory.h... (cached) yes
checking for unistd.h... (cached) yes
checking for getopt.h... (cached) no
checking for sys/select.h... (cached) yes
checking for sys/systeminfo.h... (cached) yes
checking for working const... (cached) yes
checking for inline... (cached) inline
checking for off_t... (cached) yes
checking for pid_t... (cached) yes
checking for size_t... (cached) yes
checking return type of signal handlers... (cached) void
checking for strftime... (cached) yes
checking for gettimeofday... (cached) yes
checking for mkfifo... (cached) yes
checking for putenv... (cached) yes
checking for select... (cached) yes
checking for setvbuf... (cached) yes
checking for socket... (cached) no
checking for waitpid... (cached) yes
checking for strdup... (cached) yes
checking for strstr... (cached) yes
checking for strtol... (cached) yes
checking for memmove... (cached) yes
checking for memcpy... (cached) yes
checking for strchr... (cached) yes
checking for sysconf... (cached) yes
checking for uname... (cached) yes
checking for div... (cached) yes
checking for sigaction... (cached) yes
checking for siginterrupt... (cached) yes
checking for sig_atomic_t... (cached) yes
checking whether setvbuf arguments are reversed... (cached) no
checking for sys/types.h... (cached) yes
checking for sys/time.h... (cached) yes
checking for sys/select.h... (cached) yes
checking for sys/socket.h... (cached) yes
checking types of arguments for select()... (cached) int,fd_set *,struct 
timeval *
checking for gethostname... (cached) yes
checking for strcasecmp... (cached) yes
checking for strncasecmp... (cached) yes
checking for strerror... (cached) yes
checking for usleep... (cached) yes
checking for atexit... (cached) yes
checking for XpmReadFileToXpmImage in -lXpm... no
checking for rplay_create in -lrplay... no
checking for readline in -lreadline... no
checking for readline in -lreadline... no
creating ./config.status
creating Makefile
creating libs/Makefile
creating fvwm/Makefile
creating modules/Makefile
creating extras/Makefile
creating utils/Makefile
creating docs/Makefile
creating icons/Makefile
creating sample.fvwmrc/Makefile
creating tests/Makefile
creating modules/FvwmAnimate/Makefile
creating modules/FvwmAudio/Makefile
creating modules/FvwmAuto/Makefile
creating modules/FvwmBacker/Makefile
creating modules/FvwmBanner/Makefile
creating modules/FvwmButtons/Makefile
creating modules/FvwmCpp/Makefile
creating modules/FvwmEvent/Makefile
creating modules/FvwmForm/Makefile
creating modules/FvwmIconBox/Makefile
creating modules/FvwmIconMan/Makefile
creating modules/FvwmIdent/Makefile
creating modules/FvwmM4/Makefile
creating modules/FvwmPager/Makefile
creating modules/FvwmRearrange/Makefile
creating modules/FvwmSave/Makefile
creating modules/FvwmSaveDesk/Makefile
creating modules/FvwmScroll/Makefile
creating modules/FvwmTalk/Makefile
creating modules/FvwmWinList/Makefile
creating extras/FvwmCommand/Makefile
creating extras/FvwmConfig/Makefile
creating extras/FvwmConsole/Makefile
creating extras/FvwmDebug/Makefile
creating extras/FvwmGoodStuff/Makefile
creating extras/FvwmPipe/Makefile
creating extras/FvwmScript/Makefile
creating extras/FvwmScript/Scripts/Makefile
creating extras/FvwmScript/Scripts/some_nice_icons/Makefile
creating extras/FvwmScript/Widgets/Makefile
creating extras/FvwmTaskBar/Makefile
creating extras/FvwmWharf/Makefile
creating config.h
config.h is unchanged

Configuration:

  FVWM Version:             2.2.4

  Build extra modules?      no
  Have ReadLine support?    no
  Have RPlay support?       no
  Have XPM support?         no: Xpm library or header not found!

(aaden)bart:~/fvwm2/fvwm-2.2.4$

(aaden)bart:~$ k

______________________________________________________
Get Your Private, Free Email at http://www.hotmail.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Thu, 9 Dec 1999 11:12:07 -0500 (EST)

> --with-xpm-library=/usr/local/X11/include/X11/xpm.h 
                                    ^^^^^^^^^^^^^^^^^
> --with-xpm-includes=/usr/local/X11/include/X11/xpm.h

The ^^^^ point to an include file; the parameter should be a LIBRARY.

-- 
Larry Gensch                                          [email-masked]

                  "May I have ten thousand marbles, please?"

---

From: Dan Espen <[email-masked]>
Date: Thu, 09 Dec 1999 11:18:14 -0500

> ModulePath be the directory that contains FvwmPager/, FvwmBanner/, 

Yes, thats what the ModulePath is.

> company for 5 mos. I think it's worth this week of frustration. Thanks!

IconPath and PixMap path point to where you've put your icons.
You can point it right into the fvwm icons directory, but it would make
more sense to download our icons from our web site, and put them some
place like /usr/local/etc/icons.

> --with-xpm-includes=/usr/local/X11/include/X11/xpm.h

You need backslashes on these lines, I assume you had them and just
cut this up for email purposes.  You don't point right to the files,
just the directories they are in:

--with-xpm-library=/usr/local/X11/lib
--with-xpm-includes=/usr/local/X11/include

For LDFLAGS, you need to export where the libraries are:

export LDFLAGS=-R/usr/local/X11/lib
                                ^^^
--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tim Phipps <[email-masked]>
Date: Thu, 09 Dec 1999 16:38:49 +0000

>   Have XPM support?         no: Xpm library or header not found!

I think you want --with-xpm-library=/usr/local/X11/lib and
--with-xpm-includes=/usr/local/X11/include.

Cheers,
Tim.

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 10 Dec 1999 12:45:51 +0100

> Yes, thats what the ModulePath is.

No! 'FvwmPager/', 'FvwmBanner/' are directory names. The ModulePath
points to the directory where the executables are installed.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].