Subject: FVWM: Re: MouseOver/Focus event handler?

From: Nadim Saeed <[email-masked]>
Date: Wed, 15 Dec 1999 10:55:53 -0800 (PST)

On Tuesday - December.14.1999 [13:46:52 +0000],
 Tim Phipps ([email-masked]) wrote:
 >
 > Brennan Cropper wrote:
 >
 > > versions of FVWM?  I've studied the man pages, but can't find a mouse
 > > over or focus event handler hook.
 > > 
 > The module FvwmEvent can be used as a focus event hook.  Together with
 > the PassID option and the WindowId command you can build quite
 > sophisticated behaviour.
 > Try this in your .fvwm2rc file, the 1150 number is because my screen is
 > 1152 pixels wide, this leaves two pixels of FvwmIconMan visible.
 >
 > *FvwmEventPassId
 > *FvwmEvent focus_change my_focusevent
 >
 > DestroyFunc my_focusevent
 > AddToFunc my_focusevent I WindowId $0 (!FvwmIconMan) AnimatedMove -1150p 0p
 > +                       I WindowId $0 (FvwmIconMan) AnimatedMove 0 0
 >
 > AddToFunc StartFunction I FvwmEvent
 >

This is beginning to sound very much like an AutoHide command.  Could someone
familiar enough with the code use the underlying ability noted above and
simply its specification and possibly create a true "autohide" command/style ?

It was be ideal to see something along the lines of,

   Style "Fvwm*"   AutoHide

BTW: this very much relates to PR#466 in the enhancements branch of FVWM's bug
     tracker.

Thanks

 - Nadim

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Brad Giaccio <[email-masked]>
Date: Wed, 15 Dec 1999 14:25:39 -0500

> BTW: this very much relates to PR#466 in the enhancements branch of FVWM's bug

This is untested but if we the function was changed to 
AddToFunc my_focusevent I WindowId $0 (!$1) AnimatedMove -1150p 0p
+                       I WindowId $0 ($1) AnimatedMove 0 0

and 
*FvwmEvent focus_change my_focusevent FvwmIconMan

You would have a generic function that could autohide any whindow.

Brad
 
-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].