Subject: FVWM: How Do I Change to Fvwm

From: "Virginia K. Wills" <[email-masked]>
Date: Mon, 20 Dec 1999 14:48:21 -0600

I compiled and installed fvwm-2.2.4 without any problem. The problem I am
having is that I would like to start using fvwm instead of kde. I have been
unable to figure out out to change the default window manager from kde to fvwm.
No matter what I have done today when I use "startx" kde opens instead of fvwm.

Kathy
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 21 Dec 1999 11:20:25 +0100

> No matter what I have done today when I use "startx" kde opens instead of fvwm.

Which Linux distribution do you use?

I'm no KDE expert, but probably KDE is started from a file
called xinitrc or .xinitrc.  On my system, the global
xinitrc is located at /usr/X11R6/lib/X11/xinit/xinitrc.
Usually you can override it by creating a .xinitrc in your
home directory.  All commands in this file are executed
when X starts up and as soon as the last command returns,
X is shut down.  Thus, the last command should be fvwm2.
All other commands must be started in the background.
A simple example is this:

  xterm &
  exec fvwm2

I prefer to start the window manager with 'exec' so that the
shell it is started from doesn't consume memory, but it works
without it.  Just make sure that your PATH is correct.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Robert Kim <[email-masked]>
Date: Tue, 21 Dec 1999 09:33:58 -0800

Caldera OpenLinux starts kde from kdeinitrc instead of xinitrc.  If let openlinux install kde and you've never seen kde, this can be confusing.  In openlinux  xdm <-> kdm, kdeinitrc <-> xinitrc.  If you still have problem let us know I can tell you exactly where the files are (if you have openlinux). 

-- 
--------------------------------------

 Robert W. Kim
 e-mail: [email-masked]

--------------------------------------

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 21 Dec 1999 15:28:05 +0100

On Tue, Dec 21, 1999 at 08:17:35AM -0600, [email-masked] wrote:
> On Tue, 21 Dec 1999, you wrote:
> 

> I use Redhat 6.1. None of the above worked.

Sigh, RedHat again.  You can find an explanation of how to
configure fvwm with RedHat in the FAQ that comes with fvwm.

> I found I had to edit the .Xdefaults file in the home directory.

The .XDefaults file ???? Um, but this is supposed to be used
for X resources only.

> Fvwm loaded but I still don't have
> something right cause I had no icons and no way to add icons or applications. I
> could use some of the applications I have though by using commands in xterm.

Bye

Dominik ^_^

P.S.: Please reply to the fvwm mailing list instead of directly to me.

---

From: "Thomas A. Gardiner" <[email-masked]>
Date: Wed, 29 Dec 1999 08:46:02 -0500 (EST)

Previously..

>configure fvwm with RedHat in the FAQ that comes with fvwm.

I believe that RedHat 6.1 uses gdm as it's X login interface instead of
xdm.  For info on gdm look at /usr/doc/gdm-1.0.0/gdm-manual.txt .  Yep, it
appears that there is only a text man page... (at least on my system at
work)  From the gdm interface you can choose Anotherlevel as your window
manager.  (Don't ask me why they are calling Anotherlevel a window
manager...)  Any way, this will choose the version an fvwm2 installed on
your machine with fvwm95 decor by default.  It will process the
Anotherlevel m4 package with FvwmM4 and voila.  For modifying the
appearance or decors, see the AnotherLevel man page.

>The .XDefaults file ???? Um, but this is supposed to be used

You should not have to modify the .Xdefaults file.

>> could use some of the applications I have though by using commands in xterm.

Tom