Subject: FVWM: different key bindings in different windows

From: matt cowan <[email-masked]>
Date: Mon, 20 Dec 1999 15:48:13 -0800 (PST)

Is it possible to have different keybindings in
different windows?  I've tried putting bindings
in decor definitions and it doesn't complain :)
but of course it doesn't work either.

What I basically want is for say... F5 to be bound to
say windowlist everywhere except in a window titled
"program_that_uses_F5".

I would even settle for a function that simply allowed
me to turn off or toggle my bindings on and off
everywhere.  As the man page says, using '-' as the
function to bind to 'removes' a binding, but it
doesn't
seem to pass the key on to the underlying window
either.

thanks for your help
-matt

__________________________________________________
Do You Yahoo!?
Thousands of Stores.  Millions of Products.  All in one place.
Yahoo! Shopping: http://shopping.yahoo.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 21 Dec 1999 11:27:29 +0100

On Mon, Dec 20, 1999 at 03:48:13PM -0800, [email-masked] wrote:
> different windows?

No.

> I've tried putting bindings

> doesn't seem to pass the key on to the underlying window
> either.

What fvwm version do you use?  Please provide an example.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 29 Dec 1999 04:52:47 +0100

> What fvwm version do you use?  Please provide an example.

Okay, I found the problem and fixed it.  The fix will be
available in the next beta release (2.3.12).

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].