Subject: FVWM: Query about xpmroot and FvwmBacker

From: Alex Wallis <[email-masked]>
Date: Tue, 7 Dec 1999 02:14:31 +1030

I'm using fvwm-snap-19991205 on linux 2.2.10

I have the following line in my config

*FvwmBackerCommand (Desk 0, Page 2 0) xpmroot bckgnd3.xpm 

but switching to that page gives this error in my X server error logs

[FVWM][ExecuteFunction]: <<ERROR>> No such command 'xpmroot' 

What am I doing wrong? The pixmap exists and is in my path as is xpmroot.

Alex

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Mon, 06 Dec 1999 11:05:17 -0500

> *FvwmBackerCommand (Desk 0, Page 2 0) xpmroot bckgnd3.xpm

Try this:

*FvwmBackerCommand (Desk 0, Page 2 0) Exec xpmroot bckgnd3.xpm
                                      ^^^^

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 6 Dec 1999 17:20:42 +0100

> What am I doing wrong? The pixmap exists and is in my path as is xpmroot.

You should use

instead to tell fvwm to use the normal search path.  Otherwise
fvwm tries to start xpmroot as a module.  Even if it were in
you ModulePath fvwm would supply it with some nonsense arguments
that are normally passed to the modules.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Alex Wallis <[email-masked]>
Date: Tue, 7 Dec 1999 03:12:35 +1030

> *FvwmBackerCommand (Desk 0, Page 2 0) Exec xpmroot bckgnd3.xpm
That did the trick, thanks! But I had to put the full path to the .xpm as well. :-)

Alex