Subject: FVWM: my problems as of 224

From: Elliot Sowadsky <[email-masked]>
Date: Wed, 29 Dec 1999 11:54:53 -0800 (PST)

I'm new to the fvwm bandwagon....running 224....here's what i'm finding.

1) mailtool starting msg iconic
   Well, i can get around the iconic problem via FVWMEvent....it
   opens....but then sinks to the bottom. Raising it doesnt help. It just
   wants to be at the bottom.  Clicking the msg in the header window will
   then bring it to the top.

2) Using click-to-focus....i lose focus when mouse is over root window.
   Doesnt lose focus if i go to another window w/o crossing over root.

3) I wish there was a mouse-over-window (say, called "O"?) so i can use the
   sun's Open/Front keys on it w/o having to click the window first....ala
   olwm.

4) Xview testedit windows dont have a label in pager.

5) What does afterstep support that fvwm2 doesnt?

6) I love watching the netscape popups coming up and then getting
   auto-zapped....ala FVWMEvent.  "No i dont want the plug-in....Zap".
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Wed, 29 Dec 1999 15:29:35 -0500

>    then bring it to the top.

Is  this Sun's "mailtool"  in  /usr/openwin/bin?
If so, which Solaris release?   I've never  used it
before, but it seemed to default to starting iconic for me.
I couldn't reproduce the raise/lower symptoms.

>    Doesnt lose focus if i go to another window w/o crossing over root.

You should tell us what focus commands you issued, but it sounds to
me like you need "SloppyFocus".

>    sun's Open/Front keys on it w/o having to click the window first....ala

I use MouseFocus and the "Front" and "Open" keys all the time.

I'm not too familiar with Click-to-focus, but I just tried using it,
and my Front key binding seems to work.  Its bound like this:

Key F15   FSTWI0123456789 N RaiseLower

The "Open" key does seem to present a problem.

I'm guessing a lot of people use MouseFocus because they find the
mouse pointer gets in the way.  I find the "unclutter" program
the perfect cure for that.

> 4) Xview testedit windows dont have a label in pager.

Don't know.

> 5) What does afterstep support that fvwm2 doesnt?

If you find anything worth stealing, let us know. :)

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 30 Dec 1999 04:48:33 +0100

>    then bring it to the top.

Perhaps it asks fvwm to be at the bottom when it starts up.  If so
you should be able to raise it if you wait a second or two.

>    Doesnt lose focus if i go to another window w/o crossing over root.

Does this happen with any application or just with certain windows?
My guess is that you have either some windows with MouseFocus or
the application reverts the focus back to the root window itself.

> 4) Xview testedit windows dont have a label in pager.

Does the window have a title?  Does it have a title when it's
iconified?  Probably the application doesn't set an icon title
and your pager is configured to show the icon label.  Try

  *FvwmPagerWindowLabelFormat %r

or

  *FvwmPagerWindowLabelFormat %t

> 5) What does afterstep support that fvwm2 doesnt?

Better ask the Afterstep folks :-) If there's something worthwhile,
just give us a hint so we can copy it.

>    auto-zapped....ala FVWMEvent.  "No i dont want the plug-in....Zap".

Hehe.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].