Subject: FVWM: Re: CirculateSkip

From: Mario Saraceni <[email-masked]>
Date: Sat, 4 Dec 1999 11:48:21 GMT

On Sat, Dec 04, 1999 at 11:50:52AM +0100, josvanr wrote:
> Hi!
> 
> I'm using an alt-tab like key binding to switch between the windows 
> on the current page using 'Current'. Now, I launch an Fvwmbuttons
> panel at startup using Module FvwmButtons MyPanel, and I'd like to 
> skip that panel while cycling the windows. I tried using this:
> Current (!MyPanel), but that doesn't work, the panel gets the focus
> anyway. (It does work for other windows, like xterm and FvwmIconMan.)
> Also Current(!FvwmButtons) doesn't work. Does anybody know what
> I could  be doing wrong?

not sure, but why don't you do 
	Style FvwmButtons CirculateSkip
alt-tab will ignore your FvwmButtons.

ta,
mario
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jos <[email-masked]>
Date: Mon, 06 Dec 1999 09:34:02 +0100

> alt-tab will ignore your FvwmButtons.

mmm but this 'CirculateSkip' does it only apply to some kind of 
built-in alt-tab behaviour? (I use a 'vim-like' key binding: alt-j
circulates up (see code fragment below). Using CirculateSkip doesn't
seem to work for me, bummer...

Jos.

[email-masked]

----------------------------------------------------------

define(`SKIPPER',`CurrentPage !Iconic !FvwmIconMan!FvwmButtons
!FvwmPager !Bar !xdaliclock')

AddToFunc FocusAndRaiseNext 
+ I  Next (SKIPPER) Raise
+ I  Next (SKIPPER) Focus
+ I  Next (SKIPPER) WarpToWindow 4 95 

AddToFunc FocusAndRaisePrev
+ I  Prev (SKIPPER) Raise
+ I  Prev (SKIPPER) Focus
+ I  Prev (SKIPPER) WarpToWindow 4 95

Key j A M Function FocusAndRaiseNext
Key k A M Function FocusAndRaisePrev
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].