Subject: Re: FVWM: libXpm.so.4.11, xpm.h, fvwm2 installation dilemnas etc.

From: "Ahmed Aden" <[email-masked]>
Date: Thu, 09 Dec 1999 17:14:52 GMT

Thanks,

that seemed to clear some things up, but I've just got another question, let 
me include some stuff.

(aaden)bart:/usr/local/X11/include$ pwd
/usr/local/X11/include
(aaden)bart:/usr/local/X11/include$ ls
./      ../     X11/    xpm.h
(aaden)bart:/usr/local/X11/include$ cd X11/
(aaden)bart:/usr/local/X11/include/X11$ ls
./      ../     xpm.h
(aaden)bart:/usr/local/X11/include/X11$

There seem to be 2 xpm.h, one is a directory deeper than the other one, this 
doesn't seem normal and I was wondering if it was a result of my multiple 
installation attempts.

Even though I attempt to use xpm.h's in different ./configure attempts, 
neither seem to work, I've enclosed relevant info:

./configure --without-cxx --with-xpm-library=/usr/local/X11/lib \ 
--with-xpm-includes=/usr/local/X11/include/X11
                                           ^^^

I get this error immediately afterwards, I don't know what it means:

configure: warning:  --with-xpm-includes=/usr/local/X11/include/X11: invalid 
host type:
.
.
.
checking for XpmReadFileToXpmImage in -lXpm... yes
checking for X11/xpm.h... noConfiguration:
.
.
.
  FVWM Version:             2.2.4

  Build extra modules?      no
  Have ReadLine support?    no
  Have RPlay support?       no
  Have XPM support?         no: Xpm library or header not found!

**************Here is when I try the xpm.h right above it*********
./configure --without-cxx --with-xpm-library=/usr/local/X11/lib \ 
--with-xpm-includes=/usr/local/X11/include
                                   ^^^^^^  (different directory)

configure: warning:  --with-xpm-includes=/usr/local/X11/include: invalid 
host type
.
.
.
checking for XpmReadFileToXpmImage in -lXpm... yes
checking for X11/xpm.h... noConfiguration:
.
.
.
  FVWM Version:             2.2.4

  Build extra modules?      no
  Have ReadLine support?    no
  Have RPlay support?       no
  Have XPM support?         no: Xpm library or header not found!

>From: Dan Espen <[email-masked]>
>To: "Ahmed Aden" <[email-masked]>
>CC: [email-masked]
>Subject: Re: FVWM: libXpm.so.4.11, xpm.h, fvwm2 installation dilemnas etc.
>Date: Thu, 09 Dec 1999 11:18:14 -0500
>
>"Ahmed Aden" <[email-masked]> writes:
> > As someone who is not familiar with the innerworkings of Xwindows, I'm
> > trying to understand what all these things have to do with Fvwm, I'll
> > include the full path on my machine for stuff so as not to confuse 
>anyone:
> >
> > 1). /usr/local/X11/include/X11/xpm.h
> > 2). /usr/local/X11/lib/libXpm.so.4.11
> > 3). /usr/include/X11/bitmaps
> >
> > Additionally, here is how I tried to compile it, and this is the output 
>it
> > gave me. It choked when it looked for a C++ compiler, so that is why I 
>opted
> > to remove the search for it.  The other stuff is just futile attempts to 
>try
> > to get it to look for the libs/xpms (I don't know what I'm talking 
>about:>).
> >   I've  included all the output of the config in an attempt to give you 
>the
> > most information possible.  I thought libXpm.so.4.11/xpm.h would be all 
>I
> > needed, but apparently I'm doing something wrong.  Also, would the
> > ModulePath be the directory that contains FvwmPager/, FvwmBanner/,
> > FvwmAnimate/ etc.?
>
>Yes, thats what the ModulePath is.
>
> > Lastly, IconPath and PixmapPath are needed in the .fvwm2rc file, I don't
> > have a clue where to find these, any documentation on these fundamental
> > concepts would be greatly appreciated.  After having used fvwm2 at 
>another
> > company for 5 mos. I think it's worth this week of frustration. Thanks!
>
>IconPath and PixMap path point to where you've put your icons.
>You can point it right into the fvwm icons directory, but it would make
>more sense to download our icons from our web site, and put them some
>place like /usr/local/etc/icons.
>
> > (aaden)bart:~/fvwm2/fvwm-2.2.4$ LDFLAGS=-R/usr/local/X11/include/X11
> > ./configure --without-cxx
> > --with-xpm-library=/usr/local/X11/include/X11/xpm.h
> > --with-xpm-includes=/usr/local/X11/include/X11/xpm.h
>
>You need backslashes on these lines, I assume you had them and just
>cut this up for email purposes.  You don't point right to the files,
>just the directories they are in:
>
>--with-xpm-library=/usr/local/X11/lib
>--with-xpm-includes=/usr/local/X11/include
>
>For LDFLAGS, you need to export where the libraries are:
>
>export LDFLAGS=-R/usr/local/X11/lib
>                                 ^^^
>--
>Dan Espen
>444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
>Piscataway, NJ 08854                     Phone: (732) 699-5570

______________________________________________________
Get Your Private, Free Email at http://www.hotmail.com
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 09 Dec 1999 14:30:39 -0500

> --with-xpm-includes=/usr/local/X11/include/X11

The xpm.h file is normally included into programs like this:

#include <X11/xpm.h>

So you don't want that last "/X11" in the include path.
> configure: warning:  --with-xpm-includes=/usr/local/X11/include/X11: invalid 
                                                                 ^^^^

(It looks like you've still got it there.)
Theres only one xpm.h file in my installation.