Subject: FVWM: WindowList configuration [followup]

From: Joseph Manning <[email-masked]>
Date: Fri, 26 Nov 1999 13:01:18 +0000 (GMT)

Hi,

   Recently, I wrote:

>> 2) I use highlighting to show which entry in the WindowList is
>>    currently selected.  But WindowList also puts a cursor on the
>>    selected item.  The cursor is unnecessary, it partially obscures
>>    the name of the icon, and it's just clutter.  Is there any way
>>    to remove the cursor from a WindowList?
>>
>>    I guess I could define my own xpm file with an invisible cursor,
>>    but that seems like an awkward solution.  Might I instead propose
>>    a new option, of the form:
>>
>>       WindowList NoCursor

   As a clarification, I guess I should have mentioned that I use the
   arrow keys, rather than the mouse, for navigation of the windowlist.
   Hence my wish not to have a cursor cluttering things up.

   Since these considerations actually apply more generally,
   to all menus in fact, perhaps a more appropriate suggestion
   would be the option:

      MenuStyle <menuname> NoCursor

   or perhaps (not such a nice solution):

      CursorStyle MENU -1

   where -1 denotes "no cursor".

Joseph (proud supporter of Feeping Creaturism)

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Joseph Manning / Computer Science / University College Cork / [email-masked]
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tim Phipps <[email-masked]>
Date: Fri, 26 Nov 1999 13:31:40 +0000

>       CursorStyle MENU -1
You can already do the equivalent by specifying an xpm file that is
completely transparent. This works quite nicely:

/* XPM */
static char *no_cursor_xpm[] = {
/* width height ncolors cpp [x_hot y_hot] */
"1 1 1 1 0 0",
/* colors */
". s none m none c none",
/* pixels */
"."};
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].