Subject: FVWM: FvwmPagerPixmap option dissapeared

From: Jos <[email-masked]>
Date: Fri, 05 Nov 1999 12:46:02 +0100

Hi, 

I used to use the FvwmpagerPixmap option in my .fvwm2rc file.
By choosing the same pixmap as the root window background pixmap, 
the pager could be made to appear transparant. Today, I downloaded
the new stable release of fvwm2, and now the pixmap didn't appear
in the pager. Looking at the man page, this option seems to 
have been removed from FvwmPager. Is it still possible to put 
pixmaps in the pager, or do I have to be content with a plain color
background?

regards,

Jos van Riswick

(Please also reply to my personal email address, as I am not yet
on the mailing list.)

-- 
___________________________________________________________
J.G.A. van Riswick, Eindhoven University of Technology,
Eindhoven, The Netherlands. mailto://[email-masked]
mailto://[email-masked] http://www.dse.nl/~josvanr
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Brad Giaccio <[email-masked]>
Date: Fri, 5 Nov 1999 07:39:22 -0500

Jos, The option for the pixmap seems to work for me with current CVS
code.  Could you tell me exactlly what your Pager config is, also
verify that the pixmap is being found I use the full path in my config
otherwise you need to set IconPath and PixmapPath in fvwm 2.2.x or
ImagePath in 2.3.x

If all else fails send me your Pager config, version number of fvwm and
the pixmap

On Fri, Nov 05, 1999 at 12:46:02PM +0100, Jos wrote:

> Hi,
>
> I used to use the FvwmpagerPixmap option in my .fvwm2rc file.  By
> choosing the same pixmap as the root window background pixmap, the
> pager could be made to appear transparant. Today, I downloaded the
> new stable release of fvwm2, and now the pixmap didn't appear in the
> pager. Looking at the man page, this option seems to have been removed
> from FvwmPager. Is it still possible to put pixmaps in the pager, or
> do I have to be content with a plain color background?
>
> regards,
>
> Jos van Riswick
>
>
> (Please also reply to my personal email address, as I am not yet on
> the mailing list.)
>

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jos <[email-masked]>
Date: Fri, 05 Nov 1999 14:29:01 +0100

> If all else fails send me your Pager config, version number of fvwm and
 
Hi Brad,

Thanks for the quick response. In my .fvwm2rc I use the following
statements to configure the pager: 

*FvwmPagerFont "none"
*FvwmPagerPixmap /root/icons/bg.xpm
*FvwmPagerHilightPixmap /root/icons/bg1.xpm
*FvwmPagerFore #ffffff
*FvwmPagerBack #555555
*FvwmPagerHighlight #666666
*FvwmPagerFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmPagerDeskTopScale 20
*FvwmPagerSmallFont 5x8
*FvwmPagerColumns 1
*FvwmPagerBalloons Pager
*FvwmPagerBalloonfore white

So I'm using absolute paths for the pixmaps. The pixmaps are in 
the right place, I checked. (I use the same .xpm's for the background
image, and this looks ok.)

The version of my fvwm2 is :

/root/icons# fvwm2 -version
[FVWM][main]:  Fvwm Version 2.2.2 compiled on Nov  5 1999 at 12:03:54

and when I look in the man page of FvwmPager it says:

FvwmPager(1.20)                                   FvwmPager(1.20)

I'll attatch my complete .fvwm2rc and the bitmaps to this mail.
Thanks in advance for helping me,

Jos.

# Start fvwm in your .xinitrc using: exec fvwm2 -cmd "FvwmM4 .fvwm2rc"

define(`PANELWIDTHPERC',`10')
define(`PAGERNROWS',`4')
define(`BORDERWIDTH',`6')

define(`PANELWIDTH',eval(WIDTH*PANELWIDTHPERC/100))
define(`PAGERHEIGHT',eval(PANELWIDTH*PAGERNROWS/2))
define(`PANELHEIGHT',eval(PANELWIDTH+PAGERHEIGHT))
define(`PANELX',eval(WIDTH-PANELWIDTH-2*BORDERWIDTH))
define(`MAXIMIZEXPERC',eval((PANELX+BORDERWIDTH)*100/WIDTH))
define(`ICONMANY',eval(PANELHEIGHT+BORDERWIDTH))
define(`GEOM',`$1x$2+$3+$4')
define(`NXN',`$1x$2')

#################################################################
# Themes: put this in all your .fvwm2_mytheme files, and add
# a popup menu entry 'RCFiles-popup'
# 
AddToFunc UseRCFile "I" Exec cp .fvwm2rc_$0 .fvwm2rc
+ "I" Restart
Read .fvwm2rc_themes
#################################################################

ImagePath /usr/X11R6/include/X11/pixmaps/:$HOME/xpms:$HOME/pixmaps:$HOME/icons

XORvalue 0
SnapAttraction 20 SameType
HilightColor #000000 grey70
WindowFont -*-helvetica-bold-r-*-*-12-*-*-*-*-*-*-*
BorderStyle Inactive TiledPixmap /root/icons/shade.xpm -- NoInset HiddenHandles
TitleStyle LeftJustified
TitleStyle ActiveUp Color #aaaaaa
TitleStyle ActiveDown Color #aaaaaa
TitleStyle Inactive TiledPixmap /root/icons/shade.xpm

AddToFunc BackgroundImage "I" Exec exec xv -root -quit $0
AddToFunc BackgroundImages "I" Function BackgroundImage $0
+ "I" *FvwmPagerPixmap $0

MenuStyle * popupoffset 0 100
MenuStyle * Font -*-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*

DesktopSize NXN(2,PAGERNROWS)
EdgeResistance 0 0
EdgeScroll 10 10
OpaqueMoveSize 50

Style "*" ForeColor #000000
Style "*" BackColor #aaaaaa
Style "*" SmartPlacement
Style "*" RandomPlacement
Style "*" StickyIcon
Style "*" IconBox 5 -50 -134 -5
Style "*" BorderWidth eval(BORDERWIDTH), HandleWidth eval(BORDERWIDTH)
Style "*" NoPPosition
Style "*" NakedTransient
Style "*" MWMBorder

Style "Fvwm*" NoTitle, NoHandles, Sticky, WindowListSkip
Style "FvwmWinList" NoTitle 

*FvwmPagerFont "none"
*FvwmPagerPixmap /root/icons/bg.xpm
*FvwmPagerHilightPixmap /root/icons/bg1.xpm
*FvwmPagerFore #ffffff
*FvwmPagerBack #555555
*FvwmPagerHighlight #666666
*FvwmPagerFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmPagerDeskTopScale 20
*FvwmPagerSmallFont 5x8
*FvwmPagerColumns 1
*FvwmPagerBalloons Pager
*FvwmPagerBalloonfore white

*FvwmButtonsGeometry GEOM(PANELWIDTH,PANELHEIGHT,PANELX,0)
*FvwmButtonsFrame 1
*FvwmButtonsPadding 1
*FvwmButtonsPixmap /root/icons/shade.xpm
*FvwmButtonsRows eval(PAGERNROWS+2+1)
*FvwmButtonsColumns 2
*FvwmButtons(2x2,Swallow "xclock" "Exec xclock -update 1&")
*FvwmButtons(NXN(2,PAGERNROWS),Swallow "FvwmPager" "Module FvwmPager 0 0")
Style "FvwmButtons" NoBorder,BorderWidth 3

*FvwmIconMan*1*buttongeometry GEOM(PANELWIDTH,0,PANELX,0)
*FvwmIconMan*1*managergeometry GEOM(1,0,PANELX,ICONMANY)
*FvwmIconMan*1*show "*"
*FvwmIconMan*1*iconname "FvwmIconMan: all"
*FvwmIconMan*1*font 6x13
Module FvwmIconMan

AddToFunc "Move-or-Raise" "M" Move
+              "M" Raise
+              "C" Raise
+              "D" WindowShade

AddToFunc "Move-or-Iconify" "M" Move
+              "D" Iconify
+              "C" RaiseLower

AddToFunc "Resize-or-Raise" "M" Resize
+              "M" Raise
+              "C" Raise
+              "D" RaiseLower

AddToFunc "LoadModules" "I" Module FvwmAuto 300
+ "I" Module FvwmButtons

AddToFunc "InitFunction" "I" Function LoadModules
+ "I" Function BackgroundImages /root/icons/bg.xpm /root/icons/shade.xpm

AddToFunc "RestartFunction" "I" Function LoadModules
+ "I" Function BackgroundImages /root/icons/bg.xpm /root/icons/shade.xpm

AddToFunc "Maximize_func" "M" Maximize 0 100
+              "C" Maximize 0 80
+              "D" Maximize 100 100

AddToMenu "Window-Popup" "Window Ops" Title
+              "Move" Function Move-or-Raise
+              "Resize" Function Resize-or-Raise
+              "Raise" Raise
+              "Lower" Lower
+              "(De)Iconify" Iconify
+              "(Un)Stick" Stick
+              "(Un)Maximize" Function maximize_func
+              "Identify" Module FvwmIdent
+              "" Nop
+              "Destroy" Destroy
+              "Close" Close
+              "" Nop
+              "Refresh Screen" Refresh

AddToMenu "Window-ops-Popup" "Move" Function Move-or-Raise
+              "Resize" Function Resize-or-Raise
+              "Raise" Raise
+              "Lower" Lower
+              "Iconify" Iconify
+              "(Un)Stick" Stick
+              "Identify" Module FvwmIdent
+              "" Nop
+              "Destroy" Destroy
+              "Close" Close
+              "" Nop
+              "Scrollbar" Module FvwmScroll 2 2

Key F3 W M Iconify 
Key F3 I M Iconify 
Key F4 W M Close 
Key F11 A C Exec exec xlock -mode swarm &

# switch focus to the window next to your current window 
Key Right A C Direction East (CurrentDesk !Iconic) Focus
Key Left A C Direction West (CurrentDesk !Iconic) Focus
Key Up A C Direction North (CurrentDesk !Iconic) Focus
Key Down A C Direction South (CurrentDesk !Iconic) Focus

# Familiar alt-tabbing
Key Tab A M Next (CurrentDesk !Iconic) Focus
Key Tab A SM Prev (CurrentDesk !Iconic) Focus

ButtonStyle All -- UseTitleStyle

ButtonStyle 1 ActiveUp Pixmap /root/icons/iconifyt.xpm
AddButtonStyle 1 ActiveDown Pixmap /root/icons/iconifyt.xpm
AddButtonStyle 1 Inactive TiledPixmap /root/icons/shade.xpm
AddButtonStyle 1 Inactive Pixmap /root/icons/iconifyt.xpm

ButtonStyle 3 ActiveUp Pixmap /root/icons/closet.xpm
AddButtonStyle 3 ActiveDown Pixmap /root/icons/closet.xpm
AddButtonStyle 3 Inactive TiledPixmap /root/icons/shade.xpm
AddButtonStyle 3 Inactive Pixmap /root/icons/closet.xpm

ButtonStyle 2 ActiveUp Pixmap /root/icons/maximizet.xpm
AddButtonStyle 2 ActiveDown Pixmap /root/icons/maximizet.xpm
AddButtonStyle 2 Inactive TiledPixmap /root/icons/shade.xpm
AddButtonStyle 2 Inactive Pixmap /root/icons/maximizet.xpm

ButtonStyle 4 ActiveUp Pixmap /root/icons/verticalt.xpm
AddButtonStyle 4 ActiveDown Pixmap /root/icons/verticalt.xpm
AddButtonStyle 4 Inactive TiledPixmap /root/icons/shade.xpm
AddButtonStyle 4 Inactive Pixmap /root/icons/verticalt.xpm

Mouse 1 R N Menu "Utilities" Nop
Mouse 2 R N Menu "Window-Popup" Nop 
Mouse 3 R N Module FvwmWinList transient

Mouse 1 1 N Iconify 
Mouse 3 1 N Menu "Window-ops-Popup" Nop 

Mouse 3 2 N Maximize 
Mouse 2 2 N Maximize 50 30
Mouse 1 2 N Maximize eval(MAXIMIZEXPERC) 100

Mouse 1 4 N Maximize 0 100

Mouse 1 3 N Delete 
Mouse 3 3 N Destroy

Mouse 1 T N Function "Move-or-Raise"
Mouse 1 SF N Function "Resize-or-Raise"
Mouse 3 T N RaiseLower 
Mouse 1 I N Function "Move-or-Iconify"
Mouse 3 I N Function "Move-or-Iconify"
Mouse 2 TSFI N Menu "Window-ops-Popup" Nop
Mouse 3 S N Function "Move-or-Iconify"

AddToMenu "Remote-Popup" "somewhere" 	exec xterm -sl 1024 -cr white -fg white -bg \#114433 -T Oneway -e ssh -l me somewhere.com
+              "generic" FvwmForm Ssh

AddToMenu "Applications-Popup"  "Netscape" Exec /usr/local/bin/netscape 
+	       "Addressbook" Exec addressbook
+              "Xdir" Exec xdir 
+	       "Knews" Exec knews 

AddToMenu "Graphics-Popup" "The GIMP" Exec xterm -fg \#30d030 -bg black -T gimpit -geometry 80x5+602+787 -e /usr/local/bin/gimp 
+              "Tgif" Exec tgif 
+              "Xpaint" Exec xpaint 
+	       "Xmag" Exec xmag
+              "XView" Exec xv 
+              "Image Magick" Exec display 

AddToMenu "Development-Popup"  "X-gdb" Exec xxgdb 
+              "ddd" Exec ddd 
+              "X-man" Exec xman 

AddToMenu "Accessories-Popup" "Calculator" Exec xcalc 
+              "Seyon" Exec seyon -modems /dev/cuaa1 
+              "Nedit" Exec nedit 
+	       "Lock" Exec xlock -mode swarm 

AddToMenu "Games-Popup" "X-kobo" Exec xkobo 
+              "X-boing" Exec xboing 
+              "Mahjong" Exec xmj 
+              "Minesweeper" Exec xmine 
+              "X-Emeraldia" Exec xemeraldia -noscore 
+              "Solitaire" Exec tksol 

AddToMenu "Sound-Popup" "X-Mixer" Exec xmmix 
+              "Xm-CD Player" Exec xmcd 

AddToMenu "Module-Popup" "FvwmTalk" Module FvwmTalk
+              "Clean-Up" Module FvwmClean
+              "Identify" Module FvwmIdent
+              "IconManager" Module FvwmIconMan
+              "Control Animation" Popup MenuFvwmAnimate

AddToMenu "Utilities" "Utilities" Title
+              "Xterm" Exec xterm -sl 1024 +ut -sb -e tcsh
+              "Netscape" Exec netscape
+              "Gvim" Exec gvim
+              "Win 98" Exec vmware /root/vmware/win98/win98.cfg
+              "Calculator" Exec xcalc
+              "" Nop
+              "Remotes" Popup Remote-Popup
+              "Applications" Popup Applications-Popup
+              "Graphics Apps" Popup Graphics-Popup
+              "Development" Popup Development-Popup
+              "Accessories" Popup Accessories-Popup
+              "Entertainment" Popup Games-Popup
+              "Sound Stuff" Popup Sound-Popup
+              "Modules" Popup Module-Popup
+              "RC Files" Popup RCFiles-Popup
+              "" Nop
+              "Refresh" Refresh
+              "Quit X" Popup Quit-Verify

AddToMenu "Quit-Verify" "Restart WM" Restart
+              "Yes, Really Quit" Quit
+              "" Nop
+              "No, Don't Quit" Nop

---

From: Jos <[email-masked]>
Date: Fri, 05 Nov 1999 14:52:59 +0100

Hi, 

I just found out that the pager version is also 2.2.2. 

When I invoke it from the command line: ./FvwmPager, it echos
that I should not do this, and it says it is version 2.2.2.

regards

Jos.

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 5 Nov 1999 15:03:13 +0100

> that I should not do this, and it says it is version 2.2.2.

You seem to have an installation problem.  Perhaps the pager
in your search path is not the pager from 2.2.2.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Brad Giaccio <[email-masked]>
Date: Fri, 5 Nov 1999 10:32:43 -0500

I'm going to have to go with Dominik, try doing a ps and see what the
path to the pager fvwm is invoking then do a which FvwmPager and find
out which one you are picking up.  If your installation differs from the
way you compiled, then you need to set ModulePath in your rc file to
fvwm where to look, otherwise it looks in $prefix/libexec/fvwm/$version
which got defined during configure