Subject: FVWM: how to expand window in different direction

From: Kevin Nguyen <[email-masked]>
Date: Tue, 16 Nov 1999 09:19:56 -0800

Hi,

What are other commands/variables that I need to set to put these
button in a window and do what I want?  i.e. click on the big button will
expand 
the window full screen, click tall button will expand window to maximum
y-direction,
click skinny button will expand window to maximum x-direction, and click on
dot button
will minimize the window.

I have these variables set but it does not work.

#ButtonStyles:
# big box
ButtonStyle 2 5 25x25@1 25x75@1 75x75@0 75x25@0 25x25@1
# tall box
ButtonStyle 4 5 40x25@1 60x25@1 60x75@0 40x75@0 40x25@1
# skinny box
ButtonStyle 6 5 25x40@1 25x60@1 75x60@0 75x40@0 25x40@1
# dot
ButtonStyle 8 5 40x40@1 60x40@1 60x60@0 40x60@0 40x40@1

Regards,
Kevin Nguyen

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Tue, 16 Nov 1999 12:35:52 -0500

> ButtonStyle 8 5 40x40@1 60x40@1 60x60@0 40x60@0 40x40@1

Those commands just decorate the buttons.  You assign functions to
the buttons like this:

Mouse 0 2 A Iconify

Which says, "any mouse button" (0), on button 2, with any modifier,
invokes the command "Iconify".

I think you will find more examples in the man page.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 16 Nov 1999 19:44:11 +0100

> ButtonStyle 8 5 40x40@1 60x40@1 60x60@0 40x60@0 40x40@1

The ButtonStyle command affects only the looks of the buttons.
Put this in your config file:

  Mouse 1 2 A Maximize 100 100
  Mouse 1 4 A Maximize 0 100
  Mouse 1 6 A Maximize 100 0
  Mouse 1 8 A Iconify

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mario Saraceni <[email-masked]>
Date: Mon, 22 Nov 1999 23:54:01 +0000

hi

can anyone save me the trouble of understanding the man page of
fvwm-menu-directory and tell me if there is a way of implementing a simple
file browser with an associated application to open the files? what i'm
thinking of is somthing like what's done in WindowMaker, where a submenu can
just browse a directory and open its files with a particular
application. can this be done in the same way in fvwm-2.3.9? can different
applications be specified in different menu entries? can anyone send
examples, please? thanx!

mario

---

From: Mario Saraceni <[email-masked]>
Date: Tue, 23 Nov 1999 12:04:10 +0000

> Here's an example from my own config.
> 
> DestroyMenu "Backcolor"
> AddToMenu "[email-masked]@" "Backgrounds" Title 
> + <snip>	assorted menu entries	</snip>
> + MissingSubmenuFunction FuncBackMenuDirectory
> + "Backgrounds dir"     Popup $FVWM_USERHOME/backgrounds
> AddToFunc FuncBackMenuDirectory
> + I PipeRead "fvwm-menu-directory -d $0 --exec-file=^'xv -root -quit' "
> 
> 
> Hope this helps.
> 
> Alex

yes, it does. thanks. in fact, i was doing something like that already,
except that it didnt work for more than one menu because i was very stupidly
using the same function name in the "MissingSubmenuFunction" bit of the menu
definition! what an idiot, ah?

mario

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 23 Nov 1999 16:27:36 +0100

> applications be specified in different menu entries? can anyone send

I have this in my config file:

  AddToFunc MakeMissingDirectoryMenu
  + i piperead 'fvwm_make_directory_menu.sh '$0

  AddToMenu workmenu
  + MissingSubmenuFunction MakeMissingDirectoryMenu
  ...
  + "root directory" popup / MENUPOS
  + home popup /home/luthien MENUPOS

With this I have two directory menus, one starting at / and one
starting at ~. The shell script fvwm_make_directory_menu.sh is
the predecessor of the perl scripts.  Within you will find a line
'ACTION=vi'. Replace 'vi' by any program you would like to run.
It's easy to modify the shell script to take the command as another
argument.  A similar script remembers the directory you last
opened.  To use it, put this in your config file:

  AddToMenu workmenu
  + BrowseMenu popup BrowseMenu MENUPOS

  AddToMenu BrowseMenu
  + DynamicPopupAction Piperead 'fvwm_make_browse_menu.sh BrowseMenu'

The script looks similar.  Again replace 'vi' with any command you
like.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].