Subject: Re: FVWM: how to make it use less memory ?

From: Dominik Vogt <[email-masked]>
Date: Tue, 2 Nov 1999 12:14:56 +0100

On Sun, Oct 31, 1999 at 04:41:39PM -0500, [email-masked] wrote:
> Ilia Chipitsine <[email-masked]> writes:
> > -----BEGIN PGP SIGNED MESSAGE-----
> >  
> > Dear FVWM-team,
> >  
> > I'm currently using fvwm2. What I exactly want is a window
> > manager which uses as less memory as possible (fvwm won that competition !)
> >  
> > How to make it use even less memory ?
> > I want just manager with xpm and GNOME support, I do not want modules,
> > virtual desktops, buttons, etc. can I save some memory that way ?
> 
> You don't say what release you are using.  With 2.2.2,
> "configure" gives you some choices:
> 
>   --disable-modality    disable modal dialogs for applications
>   --disable-saveunder    disable saveunders for pop-up menus
>   --disable-shape    disable shape extensions
>   --disable-activedown-button    disable ActiveDown button state
>   --disable-inactive-button    disable Inactive button state
>   --disable-mini-icons    disable MiniIcon style option
>   --disable-vector-buttons    disable vector button style
>   --disable-pixmap-buttons    disable pixmap button style
>   --disable-gradient-buttons    disable gradient button style
>   --disable-multistyle    disable stacked button styles
>   --disable-extended-titlestyle    disable styled title-bars
>   --disable-borderstyle    disable BorderStyle command
>   --disable-usedecor    disable UseDecor style option
>   --disable-windowshade    disable WindowShade function
> 
> I can't say how much that will save you.

Only very few kilobytes (if at all).  Most of these options will be gone
with the 2.4 release.  I guess the best way to save even more memory is
to use an old release with a smaller binary.  I'd try one of thr 1.24x
releases.  If flexibility is not the thing you want the best place to
save memory is the size of the executable.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Ilia Chipitsine <[email-masked]>
Date: Fri, 5 Nov 1999 00:25:11 +0500 (ES)

-----BEGIN PGP SIGNED MESSAGE-----

> save memory is the size of the executable.

GNOME support is the thing we want :-) does 1.24x support it ?

---

From: [email-masked] (Paul D. Smith)
Date: 04 Nov 1999 15:09:06 -0500

%% Ilia Chipitsine <[email-masked]> writes:

  >> save memory is the size of the executable.

  ic> GNOME support is the thing we want :-) does 1.24x support it ?

You want _GNOME_ support but you want to save a couple of K of memory in
the window manager?

I think you have your priorities mixed up for memory savings! :)

Anyway, no, 1.x doesn't support GNOME.  The last version of 1.x was
released before the first Linux distro even existed, and it hasn't been
supported in that long.

If you want GNOME support you have to wait for 2.4 to be released.  If
you want, you can use one of the betas or a CVS daily snapshot.  They're
pretty stable, generally.  See the Downloads page of http://www.fvwm.org.

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 04 Nov 1999 15:10:25 -0500

> GNOME support is the thing we want :-) does 1.24x support it ?

Gnome support is only in the fvwm2 beta releases.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].