Subject: FVWM: Re: m4 processing on restarts?

From: [email-masked]
Date: Tue, 9 Nov 1999 22:36:26 +0100 (CET)

Hi!

I have a question.

When restarting fvwm2, does the startup file get
processed by M4 again? The reason I'm asking this
is that I'd like to use themes in fvwm. To do this, 
I want to use several .fvwm2rc files, one for each 
theme. To activate a theme, I then copy the rc file
to the user's home directory and then restart 
the windowmanager. However, when using M4 in the rc
file, I could run into trouble if it doesn't get 
M4-ed again. (In fact I am running into trouble, and
I'm wondering if that is the reason.)

regards,

Jos van Riswick

[email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Nathan Froyd <[email-masked]>
Date: Tue, 9 Nov 1999 20:00:45 -0500

> I'm wondering if that is the reason.)

It did when I used m4 to process my config file. I think I just restarted by
using `Restart'. You might be getting in trouble if you explicitly say
`Restart fvwm2'.
-- 
</nathan>  |  [email-masked]  |  http://www.rose-hulman.edu/~froydnj/
Is this *idiocy*? Or something so            If the human brain were so simple
brilliant that it just *looks*                that we could understand it, we
stupid? --Gary Kasparov                       would be so simple we couldn't.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 10 Nov 1999 11:20:17 +0100

On Tue, Nov 09, 1999 at 10:36:26PM +0100, [email-masked] wrote:
> processed by M4 again?

That depends on the version you are using and on how you restart
fvwm. You should be on the safe side if you restart fvwm without
any arguments to the 'Restart' command. If everything else fails
you can provide the complete command line to the 'Restart' command.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].