Subject: FVWM: autohide for buttons?

From: Luis Carlos Yamamoto <[email-masked]>
Date: Sat, 06 Nov 1999 15:06:36 -0200

Hello,
   I am using fvwm-2.3.9 and I made FvwmButtons as a long bar. It is "stick" on my screen and FvwmButtons is not necessary all time
to me. I thought if one could simulate the AutoHide (from taskbar) behavior for FvwmButtons or if this feature could be (or already
is) in your feature-wished list.
   I think the fvwm most versatile wm.
   thanks in advance,

Luís
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 8 Nov 1999 13:51:24 +0100

> is) in your feature-wished list.

This feature will probably added in the future in a more versatile way
(allowing to auto-hide any window, not just FvwmButtons).  I
experimented a bit with FvwmEvent and could roughly get the behaviour
you want.  My config looks like this:

  *FvwmButtonsGeometry 600x57+0-0
  ...
  *FvwmEvent focus_change "function showhidebuttons"
  ...
  AddToFunc showhidebuttons
  + "I" next (FvwmButtons) move 0p +765p
  + "I" current (FvwmButtons) move +0 -0

  AddToFunc InitFuction
  + "I" module FvwmEvent
  AddToFunc RestartFuction
  + "I" module FvwmEvent

My screen is 1024x768 pixels.  When any window gets focus, the
button bar will be moved down so that only a few pixels remain 
visible.  When FvwmButtons gets focus, it's moved back into view.
This works only with MosueFocus and SloppyFocus.  If you have a
swallowed modules in the button bar that can set focus they will
not work properly.  And you will see the button bar reaching into
lower pages on a pager.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 8 Nov 1999 14:09:20 +0100

> not work properly.  And you will see the button bar reaching into

Adding this line should help with ClickToFocus and SloppyFocus:

  Style FvwmButtons MouseFocus

Bye

Dominik ^_^

---

From: Luis Carlos Yamamoto <[email-masked]>
Date: Mon, 08 Nov 1999 23:29:12 -0200

Hello again,
  Thank you so much.
  I will try it. 
  Thanks again,
  yours,
Luís

---

From: Luis Carlos Yamamoto <[email-masked]>
Date: Tue, 09 Nov 1999 23:07:40 -0200

Hello,

    Dominik, I tested your configuration and it worked marvelously.
    My FvwmButton has width of 48 pixels and is vertical with whole height of screen and I changed your function a little to my
1152x864 screen and new location (at right hand side border) to

AddToFunc showhidebuttons
  + "I" next (FvwmButtons) move 1149p 0p
  + "I" current (FvwmButtons) move 1104p 0p

    So my worthy space grew up 46 pixels :))))) . I see 2 pixels to 
get buttons back and I don't need to limit my
maximize to get a "visible" maximum :)). Now I have my whole screen 
back to me :)
    I have swallowed apps and I think they had no problems (astime/push buttons/xpostit/iconman/pager) after these changes. 
    Thanks a lot,

    Luís