Subject: FVWM: a problem

From: [email-masked]
Date: Wed, 3 Nov 1999 12:54:33 -0800 (PST)

Hi,

I am a user of fvwm 1.xx, Sometime I want to run a program in full-screen, so 
I have to click Maximize button after start the program. Can I auto start a 
program in full-screen?

Thanks!
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 4 Nov 1999 03:56:41 +0100

> I have to click Maximize button after start the program. Can I auto start a 

I have never used 1.xx myself, so I'm not sure if it will work
(1.xx is ancient history and has not been supported anymore for
several years).  With any of the 2.x.y version you should be able
to write a function to accopmplish what you want:

  AddToFunc RunAndMaximize
  + I Exec exec $1
  + I Wait $2
  + I Current Maximize

Now, if you want to start a maximized xterm, you would call the
function like this:

  Function RunAndMaximize xterm <title>
                          ^^^^^ 
                            command name

Where <title> is the title of the new window.

What the function does is:

  - it starts the application
  - waits for a window with the given <title> to appear
  - maximizes the currently focused window

Note that this only works if the newly created window gets
the focus.  Otherwise you might want to try

  + I Next ($2) Maximize

instead of 'Current'.

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Wed, 03 Nov 1999 22:17:20 -0500

> to write a function to accopmplish what you want:
                  $0
>   + I Wait $2
             $1
>   + I Current Maximize

(Well, I haven't  tested this  either!  Nor have  I  used fvwm1 years.
But arguments to functions start with 0, not 1.)

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].