Subject: FVWM: Binding Keys

From: Kirk I Reiten <[email-masked]>
Date: Thu, 11 Nov 1999 15:03:30 -0800

Hi,

I added a serial keypad to my system,,  xev sees these "kr" keys but
fvwm2 doesn't seem to bind them...  Any idea why this is?  I did
recompile...  Don't know how much help it did since the source doesnt
ref the XK_kr definitions.

I'm severely disabled and this added keypad doubles as my mouse...

Parts of my config follow.

Thanks

Kirk

part of my xmodmap looks like:

          keycode 146 = Find
          keycode 147 = Cancel
          keycode 148 = Help
          keycode 149 = Break
          keycode 150 = krIcon
          keycode 151 = krMax
          keycode 152 = krPush
          keycode 153 = krClose
          keycode 154 = krKill
          keycode 155 = krMove
          keycode 156 = krSize
          keycode 157 = krMenu
          keycode 158 = krWinOps
          keycode 159 = krRollUp
          keycode 160 = krRollDn
          keycode 161 =

part of my /usr/include/X11/keysymdef.h:

          #define
          XK_DongSign
          0x20ab
          #define
          XK_EuroSign
          0x20ac
          #endif

          #define XK_krIcon                          0x7100
          #define XK_krMax                           0x7101
          #define XK_krPush                          0x7102
          #define XK_krClose                         0x7103
          #define XK_krKill                          0x7104
          #define XK_krMove                          0x7105
          #define XK_krSize                          0x7106
          #define XK_krMenu                          0x7107
          #define XK_krWinOps                        0x7108
          #define XK_krRollUp                        0x7109
          #define XK_krRollDn                        0x710A

part of my /usr/local/etc/system.fvwm2rc

          # some simple default key bindings:
          Key KP_0                A       N       Iconify
          Key krIcon              A       N       Iconify
          Key krMax               A       N       Maximize
          Key krPush              A       N       Lower
          Key krClose             A       N       Close
          Key krKill              A       N       Destroy
          Key krMove              A       N       Move
          Key krSize              A       N       Resize
          Key krMenu              A       N       Popup
          "Utilities"
          Key krWinOps            A       N       Popup
          "Window Ops"
          Key krRollUp            A       N       CirculateUp
          Key krRollDn            A       N
          CirculateDown

          Key Next         A       SCM     Next [*] Focus
          Key Prior        A       SCM     Prev [*] Focus

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 12 Nov 1999 11:08:03 +0100

> Parts of my config follow.

Do these keys appear when you issue 'xmodmap -pke'? Are there any
error messages from fvwm? Do these keys work in some other application?

Bye

Dominik ^_^

-- 
Dominik Vogt, Agilent Technologies, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/464-4596, fax: 07031/464-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].