Subject: Re: FVWM: ChangeDecor doesn't complete without manual intervention

From: Dominik Vogt <[email-masked]>
Date: Mon, 11 Oct 1999 00:16:24 +0200

On Sat, Oct 09, 1999 at 05:42:28PM +0000, [email-masked] wrote:
> The situation described roughly in the Subject line happens in several
> situations, most simply in the following situation:
> 
> I bring up an FvwmConsole using a menu.
> In the console, I type
>    ChangeDecor decor-root
> where decor-root is a decor that has already been defined
> via an AddToDecor command in my .fvwmrc file.
> The mouse pointer changes to a large dot,
> requesting a window selection for this action,
> so I click in that window (no problem there).
> But then the expected action, changing the HilightColor,
> only happens to a very thin outermost border of the window,
> the bulk of the window frame stays in its original color.
> However, if I move the mouse pointer into another active window,
> then back to the window whose decor had been requested to be changed,
> (this is what I meant by "manual intervention")
> then the entire window frame switches to the requested color.
> 
> What do I have to do programatically to make the ChangeDecor take full effect,
> without having to move the mouse around?

You can call a fvwm function that issues a 'RefreshWindow' after the ChangeDecor:

AddToFunc ChangeDecorAndRefresh
+ "I" ChangeDecor decor-root
+ "I" RefreshWindow

This bug is fixed in the current development sources already.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Keith Harbaugh <[email-masked]>
Date: Wed, 13 Oct 1999 03:57:49 +0000

> This bug is fixed in the current development sources already.

Gee fellas, I tried this first in my own naïve way,
starting an FvwmConsole, typing in it the 'ChangeDecor decor-root' command,
then typing 'RefreshWindow'.
That produced the familiar big dot, so I clicked in the Console window.
And that produced no change at all:
still only the very thin outermost border had changed color.

So then I defined a new function using your recipe above in my .fvwmrc file,
restarted fvwm2, and executed that function in an FvwmConsole,
and got the same result: only the outermost pixels change color,
until I move the mouse out of, then back to, the console.

What's the German equivalent for the American phrase
"back to the drawing boards"?  :-)

--
Keith

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 13 Oct 1999 06:22:44 +0200

> "back to the drawing boards"?  :-)

If everything else fails you can issue a 'RecaptureWindow', but
I'm not sure if this command is already in 2.2.x.

Bye

Dominik ^_^

---

From: Keith Harbaugh <[email-masked]>
Date: Wed, 13 Oct 1999 04:42:39 +0000

> I'm not sure if this command is already in 2.2.x.

[FVWM][executeModule]: <<ERROR>> No such module 'RecaptureWindow' in ModulePath '/usr/local/libexec/fvwm/2.2.2'

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 13 Oct 1999 07:43:34 +0200

> [FVWM][executeModule]: <<ERROR>> No such module 'RecaptureWindow' in ModulePath '/usr/local/libexec/fvwm/2.2.2'

That's fvwm's peculiar way of telling the user that a command is unknown.
Well, then only upgrading or a full blown 'Recapture' will help :-/

Bye

Dominik ^_^

---

From: Keith Harbaugh <[email-masked]>
Date: Wed, 13 Oct 1999 07:44:23 +0000

> Well, then only upgrading or a full blown 'Recapture' will help :-/

Sorry, if (in a FvwmConsole) I do:
  ChangeDecor decor-root
  [click in the console to turn the fat dot back into an arrow]
  Recapture
all the windows flicker,
but then the console window loses
the thin outer band of recolored pixels it had,
and goes right back to its original coloration!
In other words, the Recapture wipes out the ChangeDecor entirely :-(

BTW, other than this, fvwm seems to work according to its documentation.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 13 Oct 1999 11:31:14 +0200

> In other words, the Recapture wipes out the ChangeDecor entirely :-(
 
:-( Then it's upgrade time.  As I mentioned before, this bug is
fixed in the (unstable!) development releases.

> BTW, other than this, fvwm seems to work according to its documentation.

You just didn't find the other places where it doesn't - yet :)

Bye

Dominik ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 16 Oct 1999 04:51:57 +0200

> "back to the drawing boards"?  :-)

There's no idiom in German for this, but you could translate
it with "Also nochmal von vorne".

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].