Subject: RE: FVWM: fvwm disappears!

From: [email-masked]
Date: Tue, 26 Oct 1999 08:26:45 -0700

thanks a lot, Tim.

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Tim Phipps
> [email-masked] wrote:
> >   I thought that the fvwm crashed but then I checked 'ps -ef|grep fvwm'
and
> > I saw that all the fvwm processes are running (fvwm itself and few
modules).
>
> Since you can get to a shell you can send the USR1 signal to
> fvwm and it should restart.

  where did you find this out? it really works, I just tried it, hopefully
it works when the fvwm disappears again.

> >   my configuration:
> >     fvwm 2.2.2
> >     solaris
> >     exceed (X server under windows NT)
> Exceed might have something to do with it. Try turning off any screen
> savers or running exceed in full screen mode
> (Exceed_menu/tools/configuration/screen_definintion/window_mode =
> single).

  I already run exceed in fullscreen mode. and I have to run screensaver (we
have to lock the machine when we go away)

  did anybody experience similar behaviour? is there any known reason for
fvwm to stop manage windows? it happens quite rarely and usually after
weekend.

	erik

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Pete Forman <[email-masked]>
Date: Tue, 26 Oct 1999 16:56:39 +0100 (BST)

[email-masked] writes:
 >   did anybody experience similar behaviour? is there any known
 > reason for fvwm to stop manage windows? it happens quite rarely and
 > usually after weekend.

I have seen that sort of problem with a similar setup.  Maybe once in
a couple of weeks.  I don't know if fvwm was still running but I'll
try a restart next time.  My config is fvwm 2.1.10, Solaris 2.6,
Exceed 6.0 on NT4 SP3.
-- 
Pete Forman
Western Geophysical
[email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tim Phipps <[email-masked]>
Date: Thu, 28 Oct 1999 16:36:53 +0100

> it works when the fvwm disappears again.

There's no such thing as an undocumented API when you have the sauce!  I
think it used to be in the man page.  It goes into an endless loop for
me (I have an ExitFunction that starts FvwmBanner) so it should be fixed
before it gets into the man page.

Cheers,
Tim.