Subject: FVWM: FvwmEvent and bplay

From: "Âèêòîð Âèñëîáîêîâ" <[email-masked]>
Date: Mon, 25 Oct 1999 04:06:31 +0600

Hello All!

At first, I'm sorry for my bad English.

I have Fvwm2.3.9 and problem with FvwmEvent.
I want to play wav files with external program - bplay.
I readed man page, but following construction

*FvwmEventCmd Exec /usr/bin/bplay
*FvwmEvent add_window /usr/local/sounds/click.wav

appers error

/bin/sh: /usr/local/sounds/click.wav
Permission denied

But why? I don't understand.
When I uses construction

*FvwmEventCmd Exec
*FvwmEvent add_window /usr/bin/bplay /usr/local/sounds/click.wav

Fvwm is freezed and has no reaction at any events (keyboard or
mouse clicks). I shutdown X Server with Ctrl-Alt-Backspace only.
In this time, ps aux shows running /usr/bin/bplay WITHOUT parameter!
But why? I don't understand.

In this mode, bplay waiting standart input, while Fvwm is freeze.

With best wishes
Victor Vislobokov
Perm, Russia

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Olivier Chapuis <[email-masked]>
Date: Mon, 25 Oct 1999 08:09:30 +0200

> *FvwmEvent add_window /usr/bin/bplay /usr/local/sounds/click.wav

Hello,
You may try:

*FvwmEvent add_window "exec /usr/bin/bplay /usr/local/sounds/click.wav"

Note the " and exec.
Hope this help, Olivier