Subject: FVWM: fvwm-2.3.8 and gnome panel + gtk apps

From: Jerome Breviere <[email-masked]>
Date: Tue, 5 Oct 1999 21:26:36 +0200

I've just compiled fvwm-2.3.8 with --enable-gnome.
I've then noticed that the gnome control panel, some gnome apps as gmc and some
gtk apps as xmms had now windows titles.
It is quite annoying with gmc and its desktop icons which then have decorations
Up to 31 of august snapshot i didn't notice this behaviour.
Of course, i can add a  :
Style "xmms"     NoTitle
Style "gmc"     NoTitle    etc ...
but it is not convenient at all to have gmc without window title !

Is there any way to solve this problem, i mean having window title for gmc
main window but not for the desktop icons ?

Thanks in advance.

Jerome

-------------------------------------------------
Jerome Breviere     -    [email-masked]
	       Utilisez Linux :-)
-------------------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Tue, 05 Oct 1999 16:21:08 -0400

> main window but not for the desktop icons ?

Window titles and icon titles have separate control.  You may want:

Style "gmc" NoIconTitle

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Richard Lister <[email-masked]>
Date: Tue, 05 Oct 1999 18:54:07 -0400

> Window titles and icon titles have separate control.  You may want:

Or use the Class of the icons:

  Style "gmc-desktop-icon" NoTitle

This works for me on RH6.1.

Ric

Richard J Lister, Georgetown Institute for Cognitive and Computational Sciences
Georgetown University Medical Center, Washington, DC 20007, USA
Phone: +1 202-687 2878
Email: [email-masked] 
Web: http://www.giccs.georgetown.edu/~ric/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Benjamin Low <[email-masked]>
Date: Wed, 06 Oct 1999 15:22:44 +1000

I'd like to contribute a little patch (see postings about a month ago
re. "StickyIconsAreReallySticky"). 

However, I'm behind a firewall and can't get at the cvs tree. Are there
any indirect access options?

Ben

---

From: Jason L Tibbitts III <[email-masked]>
Date: 06 Oct 1999 11:09:28 -0500

>>>>> "BL" == Benjamin Low <[email-masked]> writes:

BL> However, I'm behind a firewall and can't get at the cvs tree. Are there
BL> any indirect access options?

You should check www.fvwm.org; all of your options are listed there.  You
probably either want to download a nightly snapshot or mirror the
checked-out copy of the tree that is updated every three hours.  Then just
mail your patch to [email-masked].

 - J<

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 8 Oct 1999 02:04:41 +0200

> re. "StickyIconsAreReallySticky"). 

Uh, can you think of a better name for that style?

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 08 Oct 1999 09:17:24 -0400

> Uh, can you think of a better name for that style?

Can I recommend "IconsStayInPlace"?

(This is another thread that belongs on fvwm-workers, but I don't
have Benjamiin Low's email address handy.)