Subject: FVWM: Confusion regarding BorderStyle

From: "Randy J. Ray" <[email-masked]>
Date: Mon, 4 Oct 1999 14:09:51 -0700 (PDT)

*sigh* Maybe I'm just on drugs, but I though this should work:

AddToDecor AppDecor
[...]
+       BorderStyle Inactive Solid #d3d3d3
+       BorderStyle Active Solid #575760

However, this does not produce the expected behavior; where I expected the
active window to have solid border-handles in color #575760, and all others
to be #d3d3d3, all seem to be #d3d3d3.

I'm pretty sure I'm doing something wrong...

Randy
-- 
[email-masked]

Linux: Because rebooting is for adding new hardware.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 5 Oct 1999 11:46:24 +0200

> I'm pretty sure I'm doing something wrong...

Yep :-) You are using the wrong command.  BorderStyle knows only
the styles 'TiledPixmap' and 'Simple' although it doesn't complain
about the keywords that can be used in TitleStyle and ButtonStyle
commands.

You should use

  AddToDecor AppDecor
  +       BorderStyle Inactive Simple
  +       Style "*" BackColor #d3d3d3
  +       BorderStyle Active Simple
  +       HilightColor <fg> #575760

Where <fg> is the colour you use for the active window titles.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].