Subject: Re: FVWM: how can I focus and raise a window ?

From: Dominik Vogt <[email-masked]>
Date: Fri, 1 Oct 1999 10:07:13 +0200

On Thu, Sep 30, 1999 at 07:27:23PM -0500, [email-masked] wrote:
> Mario Saraceni <[email-masked]> wrote:
> >
> > AddToFunc FocusAndWarp "I" Focus
> > +		       "I" WarpToWindow 50 50
> > 
> > Key Tab A M    Next [*] FocusAndWarp
> 
> That works if you use MouseFocus, but not ClickToFocus.

Of course it works with ClickToFocus.  This has nothing to do
with focus policy.  Windows with 'NeverFocus' style might
interfere however.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Fuzzy Fox <[email-masked]>
Date: Fri, 1 Oct 1999 13:02:12 -0500

Dominik Vogt <[email-masked]> wrote:
> Of course it works with ClickToFocus.  This has nothing to do with
> focus policy.

Really?  The documentation I found for "WarpToWindow" just says that it
will put the cursor in the window.  It doesn't say that any focus policy
is implied by this, so I assumed that your current focus policy would
still apply.  Putting the cursor in the window, while using ClickToFocus
policy, should NOT cause focus to change, IMO.

> Windows with 'NeverFocus' style might interfere however.

I've never heard of a NeverFocus policy.  Must be a 2.3 thing...

-- 
   [email-masked] (Fuzzy Fox)      || "Just about every computer on the market
sometimes known as David DeSimone  ||  today runs Unix, except the Mac (and
  http://www.dallas.net/~fox/      ||  nobody cares about it). -- Bill Joy '85
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Michael Han <[email-masked]>
Date: Fri, 01 Oct 1999 15:32:40 -0700

Previously...
>policy, should NOT cause focus to change, IMO.

WarpToWindow does what the docs say. The effect of WarpToWindow does
depend on the focus policy. However, that's not the point. The example
above works regardless of Focus policy because there's a line to give
focus and a line to warp. One will always be extraneous, but it's
guaranteed to work independent of focus policy. I think you must have
not seen the first line.
-- 
[email-masked]                         http://www.best.com/~mikehan/
coffee achiever                              San Francisco, California
"If you lend me some money, it'll be my treat."
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].