Subject: FVWM: Maximize

From: Staffan Hämälä <[email-masked]>
Date: Wed, 1 Sep 1999 11:18:32 +0200

Hi,

On my fvwm2 setup (2.2.2), I'm using an FvwmButtons bar at the
bottom of the screen and would like to get my maximizefunctions
not to place windows over the bar.
It works if I do "Maximize 100 842p" on this particular machine,
but I would like to do something that works on all machines
I work on.
For example, "Maximize 100 -80p" could maximize windows depending
on the current screen height, minus 80 pixels from the bottom.
Sadly however, that doesn't work at all.
Is there a way to do a work-around for this, or something?

Another way I can think of would be if fvwm2 could read environment
variables, so I could make a script that executes before fvwm, that
sets the variables WIDTH and HEIGHT, which I could then use in
my .fvwm2rc file like "Maximize 100 $HEIGHT-80" or something similar.

Are any of these things something you've thought of implementing?

Thanks,

Staffan Hämälä
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Lee Willis <[email-masked]>
Date: 01 Sep 1999 10:25:30 +0100

> Is there a way to do a work-around for this, or something?

Have you tried something like

Maximize 100 90

Which will maximize to 90% of the height of the screen. Admittedly it
won't give perfect results all the time but it should work nicely in
most cases.

HTH
Lee.
-- 
I was doing object-oriented assembly at 1 year old ...  
For some reason my mom insists on calling it "Playing with blocks"
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tim Phipps <[email-masked]>
Date: Wed, 01 Sep 1999 10:32:06 +0100

> my .fvwm2rc file like "Maximize 100 $HEIGHT-80" or something similar.

You can do this if you use the FvwmM4 module to preprocess your config. 
The line should read

Maximize 100 eval(HEIGHT - 80)p

Cheers,
Tim.

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 1 Sep 1999 12:51:31 +0200

> Are any of these things something you've thought of implementing?

Yup, I've just coded the '-80p' syntax in the development sources.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].