Subject: RE: FVWM: ctrl and alt loose functionality

From: [email-masked]
Date: Wed, 01 Sep 1999 13:20:21 -0700

thanks a lot (Brad, Dominik, Fuzzy), I can't wait to get home to try the
new xmodmap magic I've just learned!

  while still at work (solaris, fvwm 2.2.x, exceed on win nt):

  xmodmap -pm says:

panther:~>xmodmap -pm
xmodmap:  up to 2 keys per modifier, (keycodes in parentheses):

shift       Shift_L (0xc),  Shift_R (0x48)
lock        Caps_Lock (0xb)
control     Control_L (0x11),  Control_R (0x49)
mod1        Alt_L (0x10),  Alt_R (0x4a)
mod2
mod3        Num_Lock (0x52)
mod4
mod5

  there is following shortcut in the fvwm config file:

# erik: Alt-Fn to go to a specific page (like on the Linux console)
Key F1          A       M       GotoPage 0 0

  the shortcut works no matter what's the status of numlock. if I understand
previous explanations correctly, it should not work. I have the same
shortcut at home and it does not work sometime (probably because of numlock,
I haven't verified it yet, though).

  also:

  fvwm2 man page lists following modifiers:

  S, C, M, 1, 2, 3, 4, 5 (and A for any)

  while xmodmap lists:

  shift, lock, control, mod1-5

  there is no lock in fvwm2 list and no M in xmodmap list. does anybody have
any further insight into this?

  [M seems to be the alt key, but alt key is mod1, according to xmodmap.
does it mean that M and 1 are the same?]

  thanks again.

	erik

> -----Original Message-----
> From: Fuzzy Fox [mailto:[email-masked]]
> No, it just means that the default modifier of Num_Lock is different
> than it is for your Unix server.  If you run "xmodmap -pm"
...

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 2 Sep 1999 03:21:28 +0200

> does it mean that M and 1 are the same?]

Yes.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].