Subject: FVWM: tkdesk with fvwm

From: "Matthew W. Roberts" <[email-masked]>
Date: Fri, 17 Sep 1999 09:19:32 -0500

I just saw tkdesk for the first time and was pretty impressed.  One
thing I was wondering:  is there a way to "hide" FvwmButtons like
you can in tkdesk.  If you haven't seen it, there is a small button at
the top of the tkdesk "button bar" that you press and the whole
thing (except the small button) disappears.  Press the button
again and it comes back.

Maybe the real question is, do a lot of people run tkdesk with
fvwm, or is there a way to use fvwm modules to do the same thing?

Thanks,

Matt
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: asja <[email-masked]>
Date: Sun, 19 Sep 1999 00:01:35 +0200

On Fri, Sep 17, 1999 at 09:19:32AM -0500, Matthew W. Roberts wrote:
[...] > If you haven't seen it, there is a small button at
> thing (except the small button) disappears.  Press the button

Hi,
Maybe I did what you are talking about, using module FvwmButtons:
in my theme (you can see it on my homepage: www.sehnsucht.org) I
made 2 drop-down menus on the right side of the screen.

This is the code used to build the one which disappears when you
click on the button with the violet sphere in the upper right corner
of the root window:

Style "NetFvwmButtons"  NoTitle,NoHandles , ClickToFocus , Sticky, WindowListSkip, HandleWidth 0, 
BorderWidth 0
*NetFvwmButtonsPixmap none
*NetFvwmButtonsGeometry -8+4
*NetFvwmButtons( - ,Icon net.xpm, Panel (down)  Net)

*NetFvwmButtonsPanel Net
Style "NetFvwmButtonsPanel"  NoTitle, Sticky, WindowListSkip , HandleWidth 0
*NetFvwmButtonsBack #888888
*NetFvwmButtonsColumns 1
*NetFvwmButtonsPadding 0 0
*NetFvwmButtonsGeometry +3-5
*NetFvwmButtons( - ,Icon b-netscape.xpm , Action (Mouse 1) " exec communicator-smotif-461  &")
*NetFvwmButtons( -  ,Icon b-mutt.xpm ,  Action (Mouse 1) " exec xterm -bg black -fg white -T mUtT 
-geometry  130x70+403+160 -fn -adobe-courier-medium-r-normal-*-*-140-*-*-m-*-iso8859-1 -e mutt &")
*NetFvwmButtons( - ,Icon b-kvirc.xpm , Action (Mouse 1) " exec kvirc &")
*NetFvwmButtons( - ,Icon b-wxftp.xpm , Action (Mouse 1) " exec wxftp &")
*NetFvwmButtons(- , Icon b-fetchmail.xpm , Action (Mouse 1) " exec xterm -bg '#202020' -fg white  
-T FeTcHmAiL  -geometry -250-200 -e fetchmail &")
*NetFvwmButtons(- , Icon b-caterpillar.xpm , Action (Mouse 1) " exec   xterm -bg '#202020' -fg 
blue  -T dSeLeCt  -geometry -250-200 -e su -c dselect &")
*NetFvwmButtons(- , Icon b-kill.xpm , Action (Mouse 1)  " exec killall -9 chat &")

as you can see, there is also another drop-down menu near this.

bye.

.asja

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 19 Sep 1999 16:37:19 +0200

> fvwm, or is there a way to use fvwm modules to do the same thing?

How aboout this (with FvwmButtons):

 1) Draw a pixmap you want to use for this button. Lets call
    it iconify_buttons.xpm.

 2) Tell fvwm to use the pixmap as FvwmButtons's icon:

      style FvwmButtons Icon iconify_buttons.xpm

 3) Tell fvwm where to place the icon (modify the coordinates
    to suit your setup):

      style FvwmButtons IconBox +0 +0 +31 +31

 4) Set up FvwmButtons:

      *FvwmButtons(1x1+0+0, Icon iconify_buttons.xpm, \
                   Action Next (FvwmButtons) Iconify)

This won't work very well if you move your button bar and
requires some work to find the right place for the icon, but
it should work.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].