Subject: RE: FVWM: ctrl and alt loose functionality

From: [email-masked]
Date: Wed, 01 Sep 1999 11:21:54 -0700

I am not sure, but I can sure check it. do you think that the numlock
disables the control/alt in some way? like having the alt with num lock off
and alt with numlock on are two different key combinations? (just like ctrl
and ctrl-alt are two different key combinations?)

  under solaris, exceed (win X server) and fvwm 2.2.x both numlock on and
numlock off work the same way (alt and ctrl shortcuts work).

  :-))

  what is the big numlock problem in unix? I noticed that the realplayer
(older versions) did not work (more precisely: the menu did not work) with
numlock on, we were told by Continuus people (source code control system, we
have solaris version) that our problems with help not working might be
because of the numlock etc...

  thanks for a suggestion. I'll try it when I get home...

	erik

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Brad Giaccio
>
> Is Num Lock turned on when it stops working?
>
> On Wed, Sep 01, 1999 at 10:22:11AM -0700, [email-masked] wrote:
> >   hey guys,
> >
> >   while working in X (using fvwm 2.2.something) I use some keyboard
> > shortcuts that use ctrl and/or alt keys. after certain time
> from start of
> > fvwm these stop working, it looks like the ctrl and alt
> keys are ignored.
> > __restart_of_fvwm_does_not_help__. it only happens in linux
> (it happened in
> > old version of fvwm too, for at least few years), I use
> fvwm on solaris and
> > it works fine (I use the same keyboard shotcuts there).
> >
> >   ctrl and alt work fine in other applications.
> >
> >   any ideas what's going on? thanks in advance.
> >
> > 	erik
> >
>
> --
> --- There are two kinds of knowledge, you either know the answer or
> 			you know where to find it
> 		      -Kane, Johnson, and anonymous
> --
> Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
> To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
> message to [email-masked].
> To report problems, send mail to [email-masked].
>

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Brad Giaccio <[email-masked]>
Date: Wed, 1 Sep 1999 14:38:47 -0400

According to the X specification, NumLock is a modifier Mod3 to be
precise. and fvwm honors anything that has a keycode of Mod n.  So if
you define Ctrl+Meta right arrow to do something you could also define
Ctrl+Meta+NumLock right arrow to do something else. e.x.
Key Right A CM  Scroll +100 0
Key Right A CM3 Scroll +200 0

Brad

On Wed, Sep 01, 1999 at 11:21:54AM -0700, [email-masked] wrote:

>   I am not sure, but I can sure check it. do you think that the
> numlock disables the control/alt in some way? like having the alt
> with num lock off and alt with numlock on are two different key
> combinations? (just like ctrl and ctrl-alt are two different key
> combinations?)
>
>   under solaris, exceed (win X server) and fvwm 2.2.x both numlock on
> and numlock off work the same way (alt and ctrl shortcuts work).
>
>   :-))
>
>   what is the big numlock problem in unix? I noticed that the
> realplayer (older versions) did not work (more precisely: the menu did
> not work) with numlock on, we were told by Continuus people (source
> code control system, we have solaris version) that our problems with
> help not working might be because of the numlock etc...
>

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 1 Sep 1999 21:16:58 +0200

>   thanks for a suggestion. I'll try it when I get home...

Perhaps this section from our FAQ helps you:

-----------------------------------------------------------------
5.5  Why do NumLock, CapsLock and ScrollLock interfere with
     ClickToFocus and/or my mouse bindings?

A: Because they are treated as modifiers. You can use the
   IgnoreModifiers command to turn individual modifiers off for
   bindings. With XFree86 the right command is

     IgnoreModifiers L25

   If you changed your modifiers manually or are using a different
   X server use the 'xmodmap' command to find out which modifiers
   correspond to the keys you want to switch off.

   This command creates a lot of extra network traffic, depending
   on your CPU, network connection, the number of Key Mouse commands
   in you configuration file and the number of modifiers you want to
   ignore. If you do not have a lightning fast machine ore very few
   bindings you should not ignore more than two modifiers. E.g. do
   not ignore scroll-lock if you have no problem with it.

   A better way to solve this problem is to modify the keyboard
   mapping of your X server. The commands

     xmodmap -e "clear Lock"
     xmodmap -e "clear Mod2"
     xmodmap -e "clear Mod5"

   remove the CapsLock, NumLock and ScrollLock from the keyboard map.
   Pressing these keys has no effect then. To re-add them try this:

     xmodmap -e "add Lock = Caps_Lock"
     xmodmap -e "add Mod2 = Num_Lock"
     xmodmap -e "add Mod5 = Scroll_Lock"

   Please refer to the man page of the xmodmap command for further
   details.
-----------------------------------------------------------------

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].