Subject: RE: FVWM: ctrl and alt loose functionality

From: [email-masked]
Date: Wed, 01 Sep 1999 11:58:57 -0700

thanks a lot for clarification. that means that the exceed server is
broken, right? (since the numlock does not have any effect on shortcuts)

  I also noticed that under linux the arrow keys and the numeric pad arrow
keys are not the same, but exceed considers them to be the same keys (at
least apps do not make distinction).

	erik

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Brad Giaccio
> Sent: Wednesday, September 01, 1999 11:39 AM
> To: [email-masked]
> Subject: Re: FVWM: ctrl and alt loose functionality
>
>
> According to the X specification, NumLock is a modifier Mod3 to be
> precise. and fvwm honors anything that has a keycode of Mod n.  So if
> you define Ctrl+Meta right arrow to do something you could also define
> Ctrl+Meta+NumLock right arrow to do something else. e.x.
> Key Right A CM  Scroll +100 0
> Key Right A CM3 Scroll +200 0
>
> Brad
>
> On Wed, Sep 01, 1999 at 11:21:54AM -0700, [email-masked] wrote:
>
> >   I am not sure, but I can sure check it. do you think that the
> > numlock disables the control/alt in some way? like having the alt
> > with num lock off and alt with numlock on are two different key
> > combinations? (just like ctrl and ctrl-alt are two different key
> > combinations?)
> >
> >   under solaris, exceed (win X server) and fvwm 2.2.x both
> numlock on
> > and numlock off work the same way (alt and ctrl shortcuts work).
> >
> >   :-))
> >
> >   what is the big numlock problem in unix? I noticed that the
> > realplayer (older versions) did not work (more precisely:
> the menu did
> > not work) with numlock on, we were told by Continuus people (source
> > code control system, we have solaris version) that our problems with
> > help not working might be because of the numlock etc...
> >
> >   thanks for a suggestion. I'll try it when I get home...
> >
> >       erik
> >
> > > -----Original Message-----
> > > From: [email-masked]
[mailto:[email-masked]]On Behalf Of
> > Brad Giaccio
> >
> > Is Num Lock turned on when it stops working?
> >
> > On Wed, Sep 01, 1999 at 10:22:11AM -0700, [email-masked] wrote:
> > >   hey guys,
> > >
> > >   while working in X (using fvwm 2.2.something) I use some keyboard
> > > shortcuts that use ctrl and/or alt keys. after certain time
> > from start of
> > > fvwm these stop working, it looks like the ctrl and alt
> > keys are ignored.
> > > __restart_of_fvwm_does_not_help__. it only happens in linux
> > (it happened in
> > > old version of fvwm too, for at least few years), I use
> > fvwm on solaris and
> > > it works fine (I use the same keyboard shotcuts there).
> > >
> > >   ctrl and alt work fine in other applications.
> > >
> > >   any ideas what's going on? thanks in advance.
> > >
> > > 	erik
> > >
> >
> > --
> > --- There are two kinds of knowledge, you either know the answer or
> > 			you know where to find it
> > 		      -Kane, Johnson, and anonymous
> > --
> > Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
> > To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
> > message to [email-masked].
> > To report problems, send mail to [email-masked].
> >
>

--
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Fuzzy Fox <[email-masked]>
Date: Wed, 1 Sep 1999 14:21:46 -0500

> broken, right? (since the numlock does not have any effect on shortcuts)

No, it just means that the default modifier of Num_Lock is different
than it is for your Unix server.  If you run "xmodmap -pm" you will see
what modifiers are defined to be what.  Different X servers can have
different defaults.

Here's my HPUX server:

    $ xmodmap -pm
    xmodmap:  up to 2 keys per modifier, (keycodes in parentheses):

    shift       Shift_R (0xd),  Shift_L (0x18)
    lock        Caps_Lock (0x1c)
    control     Control_R (0xe),  Control_L (0x19)
    mod1        Alt_R (0xf),  Alt_L (0x12)
    mod2      
    mod3      
    mod4      
    mod5      

And here's my Linux server:

    $ xmodmap -pm
    xmodmap:  up to 2 keys per modifier, (keycodes in parentheses):

    shift       Shift_L (0x32),  Shift_R (0x3e)
    lock        Caps_Lock (0x42)
    control     Control_L (0x25),  Control_R (0x6d)
    mod1        Alt_L (0x40),  Alt_R (0x71)
    mod2        Num_Lock (0x4d)
    mod3      
    mod4      
    mod5        Scroll_Lock (0x4e)

As you can see, the Linux (XFree) server defaults to adding a few
modifiers that HPUX does not.  So under XFree, hitting Num-Lock or
Scroll-Lock by mistake, causes lots of keys to stop working.  Under
HPUX, hitting Num-Lock has little effect.

If I really wanted to fix this behavior, I suppose a command like
"xmodmap -e 'Clear mod2' -e 'Clear mod5'" would do the trick.

-- 
   [email-masked] (Fuzzy Fox)      || "Just about every computer on the market
sometimes known as David DeSimone  ||  today runs Unix, except the Mac (and
  http://www.dallas.net/~fox/      ||  nobody cares about it). -- Bill Joy '85
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].