Subject: RE: FVWM: Erroneous .fvwm2rc parsing

From: [email-masked]
Date: Mon, 27 Sep 1999 13:09:03 -0700

Jason,

  the \ character is often used to `unspecial` the special characters, in
this case meaning that the new line right after it would NOT be considered
an end of line - i.e. the next line is basically the same line for the
purposes of the program that reads the file.

  it's probably clear enough, but here's an example anyway:

first line \
second line

  would be read as one line:

first line second line

  your MenuStyle command is thus commented out.

	erik

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> jason
> Sent: Monday, September 27, 1999 12:00 PM
> To: fvwm mailing list
> Subject: FVWM: Erroneous .fvwm2rc parsing
>
>
>
> I was tinkering with my .fvwm2rc file, and I found that if you put a
> comment in it, and end the comment line with a '\', the file might be
> parsed incorrectly.  I am using fvwm 2.3.8.
>
> For example, suppose you have the following:
>
> # This is a comment \
> MenuStyle "*" ... (whatever your options are)
>
>
> The '\' prior to the MenuStyle command fouls it up, causing
> the menu style
> to be set with default values for color, font, etc.
> Strangely enough, the
> following 3 examples do *not* cause problems.  It seems that the only
> commands that are affected are those for which the previous line is a
> comment that ends with '\'.  Note that adding any characters
> after the '\'
> or putting empty lines or more comments between the rogue
> comment and the
> desired command makes the problem go away, as shown below.
>
> -jason
>
>
> These examples are ok:
>
> ######################################################################
>
> # (Illustrates that only the immediate line after the '\' is affected)
> # This is a comment \
>
> MenuStyle "*" ... (whatever your options are)
>
> ######################################################################
>
> # (Illustrates again that only the immediate line after the
> '\' is affected)
> # This is a comment \
> # and this is another
> MenuStyle "*" ... (whatever your options are)
>
> ######################################################################
>
> # (Illustrates that the last character must be '\')
> # This is a comment \p
> MenuStyle "*" ... (whatever your options are)
>
>
> --
> Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
> To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
> message to [email-masked].
> To report problems, send mail to [email-masked].
>

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: jason <[email-masked]>
Date: Mon, 27 Sep 1999 15:25:50 -0500 (CDT)

Yes, I knew that's what its purpose was.  I just didn't expect it to
apply on a comment line, so I thought it was a bug.  This is how /bin/sh
works, e.g.:

#!/bin/sh
# \
echo hello
echo world

produces the ouput:

hello
world

when executed, since everything on a comment line is ignored.  I wasn't
aware that fvwm implements this differently, especially since the way
/bin/sh implements it seems more natural to me.  Oh, well.  I'm glad to
hear that it's not a bug.  ;-)

-jason