Subject: Re: FVWM: Keybinding Problems

From: Dominik Vogt <[email-masked]>
Date: Sun, 1 Aug 1999 06:59:16 +0200

On Sun, Jul 25, 1999 at 06:18:13PM -0500, Nathan Froyd wrote:
> I have a function in my .fvwmrc that looks like this:
> 
> AddToFunc "GotoDeskPage"
> + "I" GotoPage $1 $2
> + "I" Desk 0 $0
> 
> I also have a large, semi-complicated m4 function that spits out
> keybindings for switching to any page on any of my virtual desktops.
> 
> The problem is that it doesn't work. The keybindings that come out of the
> m4 function look like this:
> 
> Key F1 A 4 GotoDeskPage 0 0 0
> Key F1 A 5 GotoDeskPage 0 1 0
> 
> and so on, for each one of the function keys. The second keybinding always
> works. The first one, however, does not. I think this is a problem with
> FVWM not recognizing the `4' modifier, because if the keybindings are
> generated like so:
> 
> Key F1 A 3 GotoDeskPage 0 0 0
> Key F1 A 5 GotoDeskPage 0 1 0
> 
> everything works fine. Any suggestions as to what might be causing this
> behavior and how I can get my `4' modifier to work properly?

Most likely the '4' modifier isn't properly bound in X. What is the output
of 'xmodmap -pm'? Is there a '4' modifier at all? Is is bound to the key
you would expect?

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Thomas A. Gardiner" <[email-masked]>
Date: Sun, 1 Aug 1999 15:00:37 -0400 (EDT)

Hi,

I think this question was just recently asked, but I forgot the answer, so
please forgive my ignorance.  Does fvwm2 have built-in scaling abilities
with xpm's for say the titlebar?  That is to say, can you tell fvwm2 to
use an xpm to decorate the titlebar and scale it to fill the titlebar
space?

Thanks,
Tom

_________________________________________________________________________
Thomas Gardiner
[email-masked]

University of Rochester
Department of Physics and Astronomy
P. O. Box 270171
Rochester, NY 14627-0171

(716) 275-9625 Office 2
(716) 275-0537 Office 1
(716) 275-8527 fax
__________________________________________________________________________

The scientist does not study nature because it is useful; he studies it
because he delights in it, and he delights in it because it is beautiful.
If nature were not beautiful, it would not be worth knowing, and if nature
were not worth knowing, life would not be worth living.- Henri Poincare
__________________________________________________________________________

---

From: Nathan Froyd <[email-masked]>
Date: Wed, 4 Aug 1999 21:57:40 -0500 (EST)

> of 'xmodmap -pm'? Is there a '4' modifier at all? Is is bound to the key

xmodmap -pm gives:

xmodmap:  up to 2 keys per modifier, (keycodes in parentheses):

shift       Shift_L (0x32),  Shift_R (0x3e)
lock        Caps_Lock (0x42)
control     Control_L (0x25),  Control_R (0x6d)
mod1        Alt_L (0x40),  Alt_R (0x71)
mod2        Num_Lock (0x4d),  Hyper_L (0x73)
mod3        Super_L (0x75)
mod4        Pause (0x6e)
mod5        Scroll_Lock (0x4e),  Print (0x6f)

So, mod4 is bound to something, and yes it is the key I would
suspect. However, I don't think this is FVWM's fault now (I suspected it
wasn't, but mailed this list to make sure). My set of keybindings with the
`4' modifier work properly with the NumLock (!) on. My set of keybindings
with the `5' modifier work properly with the NumLock off (as they
should). So I think my X server is _very_ buggy. Thanks for the help. Any
suggestions on how to work around a buggy X server?
-- 
Nathan  |  [email-masked]  |  http://www.rose-hulman.edu/~froydnj/

Evolution is a million line computer program falling into place by accident.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 5 Aug 1999 05:22:20 +0200

> suggestions on how to work around a buggy X server?

Since fvwm-2.3.1 there is the IgnoreModifiers command. Perhaps playing
with it may help you (e.g. ignoring no modifiers or only the num-lock
key). If you don't use the num-lock modifier you could switch it off
completely (in X). I have written a description of what to do in the
FAQ.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Nathan Froyd <[email-masked]>
Date: Wed, 4 Aug 1999 22:47:30 -0500 (EST)

> completely (in X). I have written a description of what to do in the

I don't think this will help, since I want to pretend like the NumLock is
on for mod4, but pretend it's off for everything else (since it will screw
everything over, presumably). I will try your suggestion, though.

I think it may be the `Pause' key -- perhaps it has some sort of special
meaning in XFree86? I assigned the `4' modifier to another key and all
works fine. Any ideas on what the `Pause' key is supposed to do?
-- 
Nathan  |  [email-masked]  |  http://www.rose-hulman.edu/~froydnj/

---

From: Neil Bird <[email-masked]>
Date: Thu, 05 Aug 1999 10:18:29 +0100

> completely (in X). I have written a description of what to do in the

  I have:

xmodmap:  up to 3 keys per modifier, (keycodes in parentheses):

shift       Shift_L (0x6a),  Shift_R (0x75)
lock        Caps_Lock (0x16)
control     Control_L (0x53),  Control_R (0x7e)
mod1        Meta_L (0x7f),  Meta_R (0x81)
mod2        Mode_switch (0x14)
mod3        Num_Lock (0x69)
mod4        Alt_L (0x1a)
mod5        F13 (0x20),  F18 (0x50),  F20 (0x68)

  Note NumLock on mod3. My fvwm2rc contains:

IgnoreModifiers L3

  with:

Key L5         WTSFI  N       RaiseLower      # <Front>

  But under the 2.3.6 snap I'm using, <Font> only works with NumLock *
CapsLock off ...

-- 
=====================- http://www.racaldefence.com/ -===================
 Neil Bird                   |   This is who we are     The time is near
                             |
 mailto:[email-masked] |        There are 149 days remaining
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 6 Aug 1999 06:46:50 +0200

>   But under the 2.3.6 snap I'm using, <Font> only works with NumLock *

Yup, you're right. The 'N' modifier was broken. It works now.

Bye

Dominik ^_^

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 2 Aug 1999 04:37:40 +0200

> use an xpm to decorate the titlebar and scale it to fill the titlebar

No, not at the moment.

Bye

Dominik ^_^