Subject: FVWM: bug in configuration file parsing

From: "William L. Sebok" <[email-masked]>
Date: Fri, 6 Aug 1999 15:38:53 -0400 (EDT)

Both fvwm 2.2.2 and fvwm 2.3.5 do not recognize tokens that are surrounded by
double quotes which contain embedded spaces.  In particular the line:

MenuStyle midnightblue "light blue" midnightblue "-adobe-new century schoolbook-*-i-*-*-14-*-*-*-*-*-*-*" fvwm

generates:

[FVWM][nocolor]: <<ERROR>> can't parse color light
  and
[GetFontOrFixed]: WARNING -- can't get font -adobe-new, trying 'fixed'[FVWM][scanForPixmap]: <<WARNING>> Couldn't find pixmap  height

As system manager of the UMD astronomy department, this bug is a show stopper,
making me unable to upgrade past the current fvwm (2.046).  For the past number
of years I have been handing out a .fvwmrc with the above line to new users and
thus upgrading fvwm would now break most users' desktops.

If double quotes won't protect a token from being broken up then what is the
use for double quotes?  I can substitute LightBlue for "light blue" but there
is no getting around that some font names have embedded spaces.

Bill Sebok      Computer Software Manager, Univ. of Maryland, Astronomy
	Internet: [email-masked]	URL: http://www.astro.umd.edu/~wls/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 8 Aug 1999 09:22:34 +0200

> is no getting around that some font names have embedded spaces.

Don't panic. The MenuStyle command has been completely rewritten and
obviously we forgot to handle quoting properly with the old syntax. It
is fixed in the development sources now. Anyway, you can work around
this bug by using the new syntax:

  MenuStyle * fvwm
  MenuStyle * Foreground midnightblue
  MenuStyle * Background "light blue"
  MenuStyle * Greyed midnightblue
  MenuStyle * Font "-adobe-new century schoolbook-*-i-*-*-14-*-*-*-*-*-*-*"

This does exactly the same as the one line above. The '*' is the name
of the menu style (different menus can have different styles now).
The options after the name can be written on a single line separated
by commas:

  MenuStyle * fvwm, Foreground midnightblue, Background ...

Note that the 'fvwm' style has to be the first one specified as it
resets most other menu style options to a default value.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].