Subject: FVWM: how to bind keys ?

From: Ilia Chipitsine <[email-masked]>
Date: Sun, 29 Aug 1999 21:50:08 +0600 (ESS)

Dear Gurus,

I have fvwm-2.2 installed and it works fine.
However, I'd appreciate if somebody would tell me
how to bind "Ctrl-Esc" key sequence to the "RootMenu" Popup.

Also, It doesn't belong to fvwm, but maybe you know how
to emulate mouse using numeric keypad ? I have XFree86-3.3.3.1
for the reference.

Regards, (Наилучшие пожелания)

 Ilia Chipitsine (Илья Шипицин)

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominic Mitchell <[email-masked]>
Date: Sun, 29 Aug 1999 13:10:36 -0400

This should work:

Key Escape		A   	C       PopUp "RootMenu"

Cheers,

Dominic

>>>>> "ic" == Ilia Chipitsine <[email-masked]> writes:

ic> Dear Gurus,

ic> I have fvwm-2.2 installed and it works fine.
ic> However, I'd appreciate if somebody would tell me
ic> how to bind "Ctrl-Esc" key sequence to the "RootMenu" Popup.

-- 
==================================================================
Dominic Mitchell             Email: [email-masked]
Department of Economics      mailto:[email-masked]
Queen's University
Kingston, Ontario            The XXI century starts on 2001-01-01!
Canada, K7L 3N6	             Le XXI siècle débute le 2001-01-01!
==================================================================
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 30 Aug 1999 02:53:38 +0200

> how to bind "Ctrl-Esc" key sequence to the "RootMenu" Popup.

Put this line in your .fvwm2rc file:

  Key Escape A C Popup RootMenu

Actually, the title and the name of the menu may not be the
same. You must use the menu name in the command.

> to emulate mouse using numeric keypad ? I have XFree86-3.3.3.1

Put this in your .fvwm2rc

  Key KP_1 A A CursorMove -10p +10p
  Key KP_2 A A CursorMove 0 -10p
  Key KP_3 A A CursorMove +10p +10p
  Key KP_4 A A CursorMove -10p 0
  Key KP_6 A A CursorMove +10p 0
  Key KP_7 A A CursorMove -10p -10p
  Key KP_8 A A CursorMove 0 -10p
  Key KP_9 A A CursorMove +10p -10p

Alas, you can't simulate button clicks with the keyboard.
If fvwm generates a button press event itself it is marked
as 'synthetic' by the X server. Many applications ignore
such events completely.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Ilia Chipitsine <[email-masked]>
Date: Tue, 31 Aug 1999 21:01:05 +0600 (ESS)

thank you very mucho !
I just didn't know that I shall write "Escape" instead of just "Esc".
I found that "/usr/X11R6/bin/xev" tells me name of different keys.
But it tells "NoSymbol" if I press a key with flying windows on it ...
(I was that sure it's the same as Ctrl-Esc :-)

How can I assign a name for that key ? 

> Alas, you can't simulate button clicks with the keyboard.

that's great. but I've no idea what is "alas" ...

> as 'synthetic' by the X server. Many applications ignore

I just read somewhere (maybe not about fvwm) that mouse emulating
code was removed from the window manager due to "powerful XFree86
features"

---

From: Dan Espen <[email-masked]>
Date: Tue, 31 Aug 1999 12:56:03 -0400

> How can I assign a name for that key ? 

If you look closely at the xev output, you will see that
xev knows the "keycode" for the key.

Using xmodmap you can assign any keysym to the keycode.
Your "keysymdef.h" header file lists the keysyms you can assign.
Drop the "XK_" part.

I think you will find the header file in /usr/X11R6/include/X11/keysymdef.h.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].