Subject: FVWM: libXpm reports undefined references to _fxstat and _xstat

From: "Shawn Mckisson" <[email-masked]>
Date: Sun, 1 Aug 1999 15:13:49 -0500

(Hopefully) All relevant package information:
FVWM 2.2.2
libXpm.so.4.11
glibc 2.1
gcc 2.95
X 3.1.1.1

When I checked config.logs, I saw that it was trying to compile a test program, which resulted in the following error message:

/usr/X11R6/lib/libXpm.so: undefined reference to '_fxstat'.

I did an 'nm' on the libXpm library, and sure enough _xstat and _fxstat are declared as external.
I tried to install the jdk117 right before fvwm2.2.2, and it also reports this same error.

Does anyone know how to fix this? What libs hold the _fxstat and _xstat code?

--shawn

---

From: "Shawn Mckisson" <[email-masked]>
Date: Sun, 1 Aug 1999 15:58:15 -0500

I had to rebuild libXpm in order to solve the problem.
I believe that it stems from my move from libc5 to glibc.

  ----- Original Message ----- 
  From: Shawn Mckisson 
  To: [email-masked] 
  Sent: Sunday, August 01, 1999 3:13 PM
  Subject: FVWM: libXpm reports undefined references to _fxstat and _xstat

   

  --shawn