Subject: FVWM: nailing window to panner ?

From: "Hung, Angela" <[email-masked]>
Date: Wed, 11 Aug 1999 13:17:54 -0400

Is there a way to start up an application in fvmw and nail it to the panner
automatically by 
setting some variable in the environment  ?  By nailing the window to the
panner, I mean 
that the window will appear in the same position regardless of which paaner
the user 
toggles to. 

Thanks.

Angela Hung
Pager:	(917)424-4658
Tel:	(212)902-3556
E-mail:	[email-masked]

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Wed, 11 Aug 1999 14:12:51 -0400

> that the window will appear in the same position regardless of which paaner

I think you want to make the window "sticky".
Check the fvwm2 man page for the word, "sticky".

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Bob Woodside <[email-masked]>
Date: Wed, 11 Aug 1999 22:45:30 -0400

> Check the fvwm2 man page for the word, "sticky".

	Hint:  it's under the Style command. Setting a window's style to
"Sticky" will cause it to be "stuck" (or "pinned", or whatever
terminology you like) when it's initially created. The style just
governs its initial state: you can still toggle it between stuck and
unstuck with the "Stick" command (a good thing to bind to one of the
titlebar buttons, and to have in a general Window-Ops menu).

- Bob

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 12 Aug 1999 07:12:46 +0200

> that the window will appear in the same position regardless of which paaner

Yes. There is a style option:

  Style my_application Sticky

If you have several such applications but only want one specific
to be sticky you need to give it a title that distinguishes it
from the other ones and use that title in the Style command.

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].