Subject: Re: FVWM: help

From: Michael Bletzinger <[email-masked]>
Date: Thu, 01 Jul 1999 16:01:49 +0000

Pushpak Patel wrote:
> 
> I am sorry to have bother you again but I am not sure how to do this and
> reading
> README file and INSTALL does not help me.
> I ran make and here is what it does.
> can you help?
> I appreciate it
> 
> thanks
> pushpak
> 
> make
> No suffix list.
>         make  all-recursive
> No suffix list.
> Making all in libs
> Making all in fvwm
> Making all in modules
> No suffix list.
> Making all in FvwmAnimate
> Making all in FvwmAudio
> Making all in FvwmAuto
> Making all in FvwmBacker
> Making all in FvwmButtons
> Making all in FvwmCpp
>         gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../../libs
> -DFVWM_MODULEDIR=\"/home/gsm/u08/pushpak/fvwm/fvwm-2.2.2/libexec/fvwm/2.2.2\"
> 
> -DFVWM_CONFIGDIR=\"/home/gsm/u08/pushpak/fvwm/fvwm-2.2.2/etc\"
> -DFVWM_CPP='"/lib/cpp"'    -O2 -c FvwmCpp.c
> FvwmCpp.c:45: X11/Xmu/SysUtil.h: No such file or directory
> *** Error exit code 1
> 
> Stop.
> *** Error exit code 1
> 
> Stop.
> *** Error exit code 1
> 
> Stop.
> *** Error exit code 1
> 
> Stop.

Type "find / -name SysUtil.h" to find out where this file is located
because the build process can't locate it.  If you have a lot of mounted
directories you might try finding in the root subdirectories such as
/usr or /opt.

Let us know where it is then we can perhaps tell you what went wrong in
your configure stage.  I hope you have already mentioned to the list the
system your building on (uname -a) and the version of fvwm you are
building.

	Michael

-- 
First Rule of Engineering Design:
It is wiser to present an unworkable design rather
than a workable design to speed up the revision process
Phone (voice): (812)854-1101    (fax):   (812)854-3437
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Paul D. Smith)
Date: 02 Jul 1999 15:21:03 -0400

%% "Pushpak Patel" <[email-masked]> writes:

  pp> I am sorry to have bother you again but I am not sure how to do
  pp> this and reading README file and INSTALL does not help me.  I ran
  pp> make and here is what it does.  can you help?  I appreciate it

There's something really fundamentally wrong here.  It looks like your
configure step never worked.

  pp> make
  pp> No suffix list.
  pp>         make  all-recursive
  pp> No suffix list.

"No suffix list."?  Looks like the makefiles are corrupted (or, you're
using a bogus version of make, maybe).

  pp>         gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../../libs
  pp> -DFVWM_MODULEDIR=\"/home/gsm/u08/pushpak/fvwm/fvwm-2.2.2/libexec/fvwm/2.2.2\" -DFVWM_CONFIGDIR=\"/home/gsm/u08/pushpak/fvwm/fvwm-2.2.2/etc\" -DFVWM_CPP='"/lib/cpp"'    -O2 -c FvwmCpp.c

  pp> the SysUtil.h file was

  pp> /usr/contrib/X11R5/include/X11/Xmu/SysUtil.h

If you don't have X installed in the normal place (that is, if
/usr/include/X11 doesn't contain the Xmu/SysUtil.h file somehow, either
directly or by symbolic link) you'll have to use --with-x-includes,
etc. on the configure line to tell it where to find X.

In short, we can't help further until you provide more details:

  * What version of FVWM are you trying to compile?

  * What operating system and version are you building on?

  * What "configure" command line did you use?

  * Did you get any errors during the configure step?

  * What were the results printed at the end of configure?

Etc.

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Pushpak Patel" <[email-masked]>
Date: Fri, 02 Jul 1999 15:14:20 -0500

* What version of FVWM are you trying to compile?  2.2.2

  * What operating system and version are you building on? Unix, and currently I am using CDE

  * What "configure" command line did you use?
            configure --prefix=/home/gsm/u08/pushpak/fvwm/fvwm-2.2.2 --without-cxx

  * Did you get any errors during the configure step?
                I have attached a config.log file.

  * What were the results printed at the end of configurConfiguration:

  FVWM Version:             2.2.2

  Build extra modules?      no
  Have ReadLine support?    no
  Have RPlay support?       no
  Have XPM support?         no: Xpm library or header not found!

>   * What were the results printed at the end of configure?
configure --prefix=/home/gsm/u08/pushpak/fvwm/fvwm-2.2.2 --without-cxx

This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

configure:610: checking for a BSD compatible install
configure:663: checking whether build environment is sane
configure:720: checking whether make sets ${MAKE}
configure:766: checking for working aclocal
configure:779: checking for working autoconf
configure:792: checking for working automake
configure:805: checking for working autoheader
configure:818: checking for working makeinfo
configure:853: checking whether to enable modal dialogs for applications
configure:874: checking whether to enable saveunders for pop-up menus
configure:895: checking whether to enable shape extensions
configure:919: checking whether to enable ActiveDown button state
configure:943: checking whether to enable Inactive button state
configure:967: checking whether to enable MiniIcon style option
configure:991: checking whether to enable vector button style
configure:1015: checking whether to enable pixmap button style
configure:1039: checking whether to enable gradient button style
configure:1063: checking whether to enable stacked button styles
configure:1087: checking whether to enable styled title-bars
configure:1111: checking whether to enable BorderStyle command
configure:1135: checking whether to enable UseDecor style option
configure:1159: checking whether to enable WindowShade function
configure:1183: checking whether to enable debugging messages
configure:1204: checking iconpath
configure:1231: checking for gcc
configure:1344: checking whether the C compiler (gcc  ) works
configure:1360: gcc -o conftest    conftest.c  1>&5
configure:1386: checking whether the C compiler (gcc  ) is a cross-compiler
configure:1391: checking whether we are using GNU C
configure:1419: checking whether gcc accepts -g
configure:1451: checking how to run the C preprocessor
configure:1532: checking for POSIXized ISC
configure:1554: checking for minix/config.h
configure:1607: checking for stdarg.h
configure:1646: checking for vfprintf
configure:1706: checking for waitpid
configure:2057: checking for X
configure:2371: checking for dnet_ntoa in -ldnet
configure:2412: checking for dnet_ntoa in -ldnet_stub
configure:2460: checking for gethostbyname
configure:2558: checking for connect
configure:2650: checking for remove
configure:2742: checking for shmat
configure:2843: checking for IceConnectionNumber in -lICE
configure:2890: checking for cpp
configure:2940: checking for a BSD compatible install
configure:2993: checking whether ln -s works
configure:3014: checking whether make sets ${MAKE}
configure:3043: checking for ranlib
configure:3076: checking for flex
configure:3109: checking for flex
configure:3143: checking for yywrap in -lfl
configure:3185: checking lex output file root
configure:3206: checking whether yytext is a pointer
configure:3251: checking for bison
configure:3284: checking for ANSI C header files
configure:3388: checking for sys/wait.h that is POSIX.1 compatible
configure:3433: checking for stdlib.h
configure:3433: checking for fcntl.h
configure:3433: checking for limits.h
configure:3433: checking for malloc.h
configure:3433: checking for string.h
configure:3433: checking for memory.h
configure:3433: checking for unistd.h
configure:3473: checking for getopt.h
configure:3473: checking for sys/select.h
configure:3473: checking for sys/systeminfo.h
configure:3511: checking for working const
configure:3586: checking for inline
configure:3626: checking for off_t
configure:3659: checking for pid_t
configure:3692: checking for size_t
configure:3726: checking return type of signal handlers
configure:3767: checking for strftime
configure:3865: checking for gettimeofday
configure:3865: checking for mkfifo
configure:3865: checking for putenv
configure:3865: checking for select
configure:3865: checking for setvbuf
configure:3865: checking for socket
configure:3865: checking for waitpid
configure:3920: checking for strdup
configure:3920: checking for strstr
configure:3920: checking for strtol
configure:3920: checking for memmove
configure:3920: checking for memcpy
configure:3920: checking for strchr
configure:3920: checking for sysconf
configure:3920: checking for uname
configure:3920: checking for div
configure:3975: checking for sigaction
configure:3975: checking for siginterrupt
configure:4029: checking for sig_atomic_t
configure:4065: checking whether setvbuf arguments are reversed
configure:4117: checking for sys/types.h
configure:4117: checking for sys/time.h
configure:4117: checking for sys/select.h
configure:4117: checking for sys/socket.h
configure:4154: checking types of arguments for select()
configure:4230: checking for gethostname
configure:4230: checking for strcasecmp
configure:4230: checking for strncasecmp
configure:4230: checking for strerror
configure:4230: checking for usleep
configure:4230: checking for atexit
configure:4384: checking for XpmReadFileToXpmImage in -lXpm
configure:4403: gcc -o conftest -O2   conftest.c -lXpm -lXpm   -lSM -lICE -lX11   1>&5
collect2: ld returned 1 exit status
/usr/ccs/bin/ld: Can't find library for -lXpm
configure: failed program was:
#line 4392 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char XpmReadFileToXpmImage();

int main() {
XpmReadFileToXpmImage()
; return 0; }
configure:4615: checking for rplay_create in -lrplay
configure:4634: gcc -o conftest -O2   conftest.c -lrplay -lrplay   1>&5
collect2: ld returned 1 exit status
/usr/ccs/bin/ld: Can't find library for -lrplay
configure: failed program was:
#line 4623 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char rplay_create();

int main() {
rplay_create()
; return 0; }
configure:4782: checking for readline in -lreadline
configure:4801: gcc -o conftest -O2   conftest.c -lreadline -lreadline -ltermcap  1>&5
collect2: ld returned 1 exit status
/usr/ccs/bin/ld: Can't find library for -lreadline
configure: failed program was:
#line 4790 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char readline();

int main() {
readline()
; return 0; }
configure:4949: checking for readline in -lreadline
configure:4968: gcc -o conftest -O2   conftest.c -lreadline -lreadline -lncurses  1>&5
collect2: ld returned 1 exit status
/usr/ccs/bin/ld: Can't find library for -lreadline
configure: failed program was:
#line 4957 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char readline();

int main() {
readline()
; return 0; }

---

From: [email-masked] (Paul D. Smith)
Date: 02 Jul 1999 16:56:02 -0400

%% "Patel, Pushpak" <[email-masked]> writes:

  pp>   * What version of FVWM are you trying to compile?  2.2.2

  pp>   * What operating system and version are you building on? 
  pp> Unix, and currently I am using CDE

:)

I know Unix; what _kind_ of Unix, and what version?  Solaris 2.5.1?
HP-UX 10.20?  Etc.

  pp> configure --prefix=/home/gsm/u08/pushpak/fvwm/fvwm-2.2.2 --without-cxx

Hmm... this prefix you're using isn't the directory where the source
code is, is it?

The --prefix option is supposed to be where you want to _install_ the
program(s) once their built, not where the source is.  I guess it should
work either way.

---------------

OK, say "ls -l /usr/include/X11".  See if that's a symlink and if so, if
it points somewhere reasonable.  You should be able to say:

  $ ls /usr/include/X11/Xmu/SysUtil.h

and have it list a file, not give an error.

---

From: "Thomas A. Gardiner" <[email-masked]>
Date: Fri, 2 Jul 1999 22:31:58 -0400 (EDT)

Previously...

> program(s) once their built, not where the source is.  I guess it should

If I may chime in, I think it's worth mentioning that the choice of
"where" to install the compiled code is worth thinking about, since they
can not be moved from there without recompiling...  Therefore, I think a
different directory would be preferable, say without the dash...

configure --prefix=/home/gsm/u08/pushpak/fvwm/fvwm2.2.2 --without-cxx

Tom

---

From: [email-masked] (Paul D. Smith)
Date: 03 Jul 1999 00:24:54 -0400

%% "Thomas A. Gardiner" <[email-masked]> writes:

  tag> If I may chime in, I think it's worth mentioning that the choice
  tag> of "where" to install the compiled code is worth thinking about,
  tag> since they can not be moved from there without recompiling...

Well, FVWM can be moved without recompiling, but the builtin ModulePath
will be wrong so you'll have to reset that in ~/.fvwm2rc.

I guess some of the newer self-config features in 2.3.x may also not
work quite correctly.

But, in general, FVWM is fairly portable.  There do exist some GNU tools
(Emacs and GCC spring immediately to mind) which are a pain in the rear
to move--easier to recompile them.

  tag> Therefore, I think a different directory would be preferable, say
  tag> without the dash...

OK... but what's wrong with the dash?

---

From: "Thomas A. Gardiner" <[email-masked]>
Date: Sat, 3 Jul 1999 08:12:41 -0400 (EDT)

> OK... but what's wrong with the dash?

I stand corrected...  regarding the dash, just a _different_ directory
from the source, but located near by...

Tom