Subject: FVWM: Icons sizing

From: [email-masked]
Date: Tue, 6 Jul 1999 10:44:20 +0200

Hi,

This was posted sometime ago, but didn't get a real answer. Is
there a way to specify a fixed size for all the icons, for
example 48x48. All icons would then either keep their size, but
centered into a defined shape, or be cropped to that size. Lots
of icons, i.e. Netscape have transparency in their small icon. I
would suggest something like :

Style "*" IconSize 48 48
Style "*" IconShape SilverBackGround.xpm

That would be far more easier than doing the work manually
on all icons, or creating own icons (I'm so bad at drawing...)

Does that make any sense ?? Am I just dreaming ? :-)

Cheers
Stephane

-- 
SILICON GRAPHICS                 EUROPEAN MANUFACTURING CENTER
##############################################################
Stephane Rosa                     Tel :     +41 (0)32 843-3638
Business Analyst                  Fax :     +41 (0)32 843-3909
APS/FP  Project                   GSM :     +41 (0)79 448-5335
--------------------------------------------------------------
irc.stealth.net     Euro-IRCNet   IRC :     Clipper on #geneva
ircnoc.neu.sgi.com  SGI Intranet  IRC :         EuroBA on #APS

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Neil Bird <[email-masked]>
Date: Tue, 06 Jul 1999 10:01:05 +0100

> Style "*" IconShape SilverBackGround.xpm

  IMHO, this [clever auto-scaling of foreign pixmaps] is beyond the call
of duty for a window manager! Maybe as a module, but you'd have to write
it yourself! Far easier to ...

> on all icons, or creating own icons (I'm so bad at drawing...)

  ... get a hold of ImageMagick, and pass all your app.'s icons through
'convert' to make 'em 48x48, plotted on a non-tranbsparent b.g. Then set
the individual styles buy hand.

  OK, it's an arse, but that's what the configuration stuff's there for! 
:-)

-- 
========================- http://www.rdel.co.uk/ -======================
 Neil Bird                   |   This is who we are     The time is near
                             |
 mailto:[email-masked] |        There are 179 days remaining
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Rene Huber <[email-masked]>
Date: Tue, 6 Jul 1999 12:06:00 +0200 (CEST)

> it yourself! Far easier to ...

As I understand it, auto-scaling of the pixmaps was not asked for, only
keeping the icon windows the same size.
This is what MWM does (I hate that about MWM).
Or can it already be done by FvwmIconMan ?

	RH.

-- 
#   Rene Huber - Software Engineer  \ / Pallas Athena B.V., The Netherlands #
#   Email:  [email-masked]   \     PO box 747, 7300 AS Apeldoorn    #
#     Phone/Fax:  +31 55 5760881    / \      Web: http://www.pallas.nl      #
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Tue, 6 Jul 1999 13:28:45 +0200

>  keeping the icon windows the same size.

Right. auto-scaling an icon to a bigger size usually gives
bad result, due to the resolution. For instance, Adobe Acrobat 4
has by default a very tiny ugly gray icon, but if it could be
centered over a let's say 48x48 colored icon, it would be nice.

I'm getting ImageMagick installed right now... ;-))

>  This is what MWM does (I hate that about MWM).

Why do you hate that ? Do you prefer to have random sized
icons ? Actually 4DWm under SGI Irix does the same, all
icons, wherever they're coming from, are shaped into a
default 78x78 size (ok it's too big but the idea is there,
and the Acrobat icon just looks like others and is perfectly
aligned with others). And no, I don't wanna switch back to
4DWm :-))

Stephane