Subject: RE: FVWM: Using META key on CDE/Solaris

From: "Sheppard, Doug" <[email-masked]>
Date: Wed, 9 Jun 1999 13:15:21 -0700

Ah, sorry.. more details:

My Sun has the CDE junk on it so it comes up with that standard login
screen... in other words, when you reboot your Sun it comes up with a GUI
login screen. You can adjust your .xinitrc to start FVWM and so that is how
I am running FVWM on CDE (I think that login screen is part of CDE).

The funny thing is, I had my FVWM working fine on another Sun w/o the CDE
stuff and the META (diamond) key worked fine there... so I think it has
something to do with CDE but don't know how to disable it.

-d

> -----Original Message-----
> From:	Dan Espen [SMTP:[email-masked]]
> Sent:	Wednesday, June 09, 1999 12:08 PM
> To:	Sheppard, Doug
> Cc:	Fvwm Mailing list
> Subject:	Re: FVWM: Using META key on CDE/Solaris 
> 
> "Sheppard, Doug" <[email-masked]> writes:
> > This message is in MIME format. Since your mail reader does not
> understand
> > this format, some or all of this message may not be legible.
> > 
> > ------_=_NextPart_001_01BEB29E.C887D6B8
> > Content-Type: text/plain
> > 
> > Hi all,
> > 
> > I am using FVWM on my Sun/Solaris on top of CDE and I can't get it to
> > recognize the META key for key modifiers. SHIFT and CONTROL work, but
> not
> > META. Any one see this before, and know how to get it to work?
> 
> I'm not familiar with the terminology, "fvwm on top of CDE".
> Either fvwm is running or dtwm is running.
> 
> What version of fvwm2?
> 
> What do your keybindings look like?
> 
> Which key on your keyboard do you think is the Meta key.  My Meta key
> has a diamond on it.
> 
> This works for me in all recent versions of fvwm2:
> 
> Key F1 A M Maximize 0 100
> 
> > Thanks,
> > 
> > -doug
> > 
> > 
> > 
> > ------_=_NextPart_001_01BEB29E.C887D6B8
> > Content-Type: text/html
> > Content-Transfer-Encoding: quoted-printable
> > 
> > <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">
> > <HTML>
> > <HEAD>
> 
> [snip]
> 
> We don't need this stuff.
> 
> > </BODY>
> > </HTML>
> > ------_=_NextPart_001_01BEB29E.C887D6B8--
> > --
> > Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
> > To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
> > message to [email-masked].
> > To report problems, send mail to [email-masked].
> 
> --
> Dan Espen
> 444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
> Piscataway, NJ 08854                     Phone: (732) 699-5570

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 10 Jun 1999 01:22:42 +0200

On Wed, Jun 09, 1999 at 01:15:21PM -0700, Sheppard, Doug wrote:
> login screen.

I don't know how this works on a Sun, but on my AIX (over a year in the past
now) you could disable the graphiical login by removing the 'dtlogin'
(or something else beginning with 'dt') from your /etc/inittab and then
starting X manually. As root you might as well 'kill' the process (use
ps to get a list of processes with names beginning with 'dt' and kill them
one by one :) ).

> You can adjust your .xinitrc to start FVWM and so that is how

Look at the output of 'xmodmap -pm'. Is there an entry mapping
mod1 to your meta key? If not you should ajust your key mappings
with the xmodmap command (see man page).

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].