Subject: FVWM: Sizing individual FvwmButtons

From: Allin Cottrell <[email-masked]>
Date: Fri, 11 Jun 1999 22:42:57 -0400

I'm running version 2.2.2.  I have an FvwmButtons panel with
one column and 8 rows/buttons down the left-hand edge of my
screen.  All works nicely but for the sizing of the buttons.
By default all the buttons are the same size, and I'd like to
make some of them taller.  I find that if I put a "Padding" or
"Size" directive into the parenthesized section for one
button, e.g.

 *FvwmButtons(Title "Editors", Icon Clipboard.xpm, \
   Padding 2 10, Action "Popup" Editors-Popup)

it ends up making _all_ the buttons bigger.  Is this a bug or
am I missing something?  Thanks in advance.  I'd appreciate
email since I'm not actually subscribed.

-- 
Allin Cottrell
Department of Economics
Wake Forest University, NC
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 12 Jun 1999 19:43:46 +0200

> email since I'm not actually subscribed.

Padding is done *inside* the buttons. If you want the buttons
to have different sizes, you must use several slots for the
bigger buttons. E.g.:

  *FvwmButtons(1x2, Title "Editors", Icon Clipboard.xpm, \
   Action "Popup" Editors-Popup)

Makes the button twice a tall as the other buttons. You need
one additional row for the button.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Brian Servis <[email-masked]>
Date: Sun, 13 Jun 1999 09:15:27 -0500 (EST)

*- On 12 Jun, Dominik Vogt wrote about "Re: FVWM: Sizing individual FvwmButtons"
> one additional row for the button.

Along this same line, is it possible to make a swallowed app in
FvwmButtons take up 1.5 button columns and 2 button rows in a 3 
column button bar? Like this:

   -------------------------
   |           |            |
   |           |            |
   |           |            |
   |           |            |  
   |           |            |
   --------------------------
   |       |        |       |
   |       |        |       |
   |       |        |       |
   --------------------------
   |       |        |       |
   |       |        |       | 
   |       |        |       |
   --------------------------

I would like to swallow a some apps that don't scale well to the typical
64x64 icon/button dimensions. 
 
Thanks,
 
-- 
Brian 
---------------------------------------------------------------------
Mechanical Engineering                              [email-masked]
Purdue University                   http://www.ecn.purdue.edu/~servis
---------------------------------------------------------------------

---

From: Jason Kibblewhite <[email-masked]>
Date: Sun, 13 Jun 1999 08:45:18 -0600

> column button bar? Like this:

It may seem rather kludge looking but this is how I would do it.
*FvwmButtonsRows 7
*FvwmColumns 6
*FvwmButtons(3x3 Swallow etc.)
*FvwmButtons(3x3 Swallow etc.)
*FvwmButtons(2x2 etc.) repeat x5
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Giovanni A. Faggioli" <[email-masked]>
Date: Sun, 13 Jun 1999 17:13:56 +0200 (CEST)

Brian Servis writes:
 ...
 > column button bar? Like this:
 
I suppose this can be done with a 6 column wide button bar. The buttons of
first row are 3 columns wide any, and the buttons of the other rows 2 columns
wide. But I have not checked if this really works!  Try it yourself.

-- 

Gruesse

Giovanni A. Faggioli
--------------------
[email-masked]
[gem. Par.28Abs.3 BDSG ist die Verwendung der Adresse fuer Werbung untersagt.]