Subject: FVWM: xload problem

From: "John E. Garrott" <[email-masked]>
Date: Fri, 11 Jun 1999 17:47:18 -0700

The following line has been sufficient to put an active xload window in
my FvwmButtons console in fvwm2.0.46 and prior.

	*FvwmButtons (2x1) load NULL               Swallow "xload" \
		Exec nice -16 xload -nolabel -bg grey60 -update 5 \
		-geometry -1500-1500

It does not work in fvwm2.2, giving the following error messages:

	FwvmButton: Illegal Swallow option "Exec"
	FwvmButton: Illegal Swallow option "nice"
	FwvmButton: Illegal Swallow option "-16"
	FwvmButton: Illegal Swallow option "xload"
	FwvmButton: Illegal Swallow option "-nolabel"
	FwvmButton: Illegal Swallow option "-bg"
	FwvmButton: Illegal Swallow option "grey60"
	FwvmButton: Illegal Swallow option "-update"
	FwvmButton: Illegal Swallow option "5"
	FwvmButton: Illegal Swallow option "-geometry"
	FwvmButton: Illegal Swallow option "-1500-1500"
	FwvmButton: Illegal Swallow option ""
	Missing Swallow argument

I have read the documentation through and through, searched the
archives,
and tried every combination of the above command I can find or think of.

Any suggests on how to get it to swallow a working xload window into the 
FvwmButton console?

Thanks in advance,

John
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Al Bolduc <[email-masked]>
Date: Fri, 11 Jun 1999 23:21:36 -0400 (EDT)

The following works for me.

*FvwmButtons(Swallow "xload" 'Exec exec xload -bg grey70 -label "  Load"
-geometry -1500-1500')

Al

> Any suggests on how to get it to swallow a working xload window into the 

#  Al Bolduc - [email-masked] - [email-masked] - [email-masked]

---

From: Jason Kibblewhite <[email-masked]>
Date: Fri, 11 Jun 1999 22:54:09 -0600

>                 Exec nice -16 xload -nolabel -bg grey60 -update 5 \

Well hardly been the expert in FvwmButtons setup I'd place "'s around Exec
to the end of the line, that always seems to work for me.
Other then that I can't see what is wrong.