Subject: FVWM: xload in fvwm Buttons

From: Rainer Dorsch <[email-masked]>
Date: Fri, 11 Jun 1999 18:51:34 +0200

I replace FvwmPager in the standard configuration of Debian Linux

*DebianFvwmButtons(2x1, Swallow(UseOld,NoKill) "FvwmPager")

by xload and added it

*DebianFvwmButtons(2x1, Swallow(UseOld,NoKill) xload)
 
Though there appear something like xload no information is displayed.

Is it possible to incorporate an xload into the buttons list (like fvwm95)?

Thanks.
-- 
Rainer Dorsch
Abt. Rechnerarchitektur  e-mail:[email-masked]
Uni Stuttgart            Tel.: 0711-7816-215

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 13 Jun 1999 05:32:58 +0200

> *DebianFvwmButtons(2x1, Swallow(UseOld,NoKill) "FvwmPager")

This does not work either. If a pager *does* appear that's because it
is started somewhere else in your config file.

> *DebianFvwmButtons(2x1, Swallow(UseOld,NoKill) "FvwmPager")
                                                 ^^^^^^^^^^^
                                                      |
This is just the label. ------------------------------|

The correct syntax of the Swallow commands is:

  Swallow(options) Label Command

I.e. in above line the command part is missing, i.e. nothing is executed.
If you would start xload manually it would be swallowed into the button bar.

> Though there appear something like xload no information is displayed.

I believe what you see is simply an empty button that looks pressed in.
The correct line is:

*DebianFvwmButtons(2x1, Swallow(UseOld,NoKill) "xload" 'Exec xload')
                                                       ^^^^^^^^^^^^
                                                             |
The command that FvwmButtons will run -----------------------|

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].