Subject: RE: FVWM: shutdown

From: Joel Golden <[email-masked]>
Date: Thu, 3 Jun 1999 16:23:43 -0500

Would you happen to have the commands for the script?

Joel Golden
www.bcs-systems.com
[email-masked]
BCS
1100 71 Plaza Court
Suite 11
Springdale, AR 72764
(501)750-7475

		-----Original Message-----
		From:	Dominik Vogt [mailto:[email-masked]]
		Sent:	Wednesday, June 02, 1999 7:59 PM
		To:	[email-masked]
		Subject:	Re: FVWM: shutdown

		On Wed, Jun 02, 1999 at 10:42:59AM -0500,
[email-masked] wrote:
		> 	Is there a command I can use for shutdown from a
Popup menu?
		> For instance, change the Quit command to execute
shutdown -h now?

		  AddToMenu "Shut down" Exec shutdown -h

		or if you need to do more

		  AddToMenu "Shut down" Exec my_shutdown_script.sh

		Bye

		Dominik ^_^

		-- 
		Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
		Herrenberger Str.130, 71034 Boeblingen, Germany
		phone: 07031/14-4596, fax: 07031/14-3883,
[email-masked]
		--
		Visit the official FVWM web page at <URL:
http://www.fvwm.org/>.
		To unsubscribe from the list, send "unsubscribe fvwm" in
the body of a
		message to [email-masked].
		To report problems, send mail to [email-masked].
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominic Mitchell <[email-masked]>
Date: Thu, 3 Jun 1999 17:46:11 -0400

To be able to shutdown form a menu in fvwm I use sudo for my user account
then I added this in my .fvwmrc.  With this I get prompted for my
password in a rxvt term before a Reboot or complete shutdown occurs.  

Popup	   "Shutdown"
Title	   "Shutdown"
Exec	   "Reboot!!!" exec rxvt -T Reboot!!! -geometry 40x2+262+332 -n sudo -e sudo /sbin/shutdown -r now &
nop
Exec	   "Close!!!" exec rxvt -T Close!!! -geometry 40x2+262+332 -n sudo -e sudo /sbin/shutdown -h now &
EndPopup

Chow,

Dominic.

-- 
==============================================================
Dominic Mitchell           Email: [email-masked]
Department of Economics    mailto:[email-masked]
Queen's University
Kingston, Ontario      
Canada, K7L 3N6	           Running Linux Redhat 5.2	
==============================================================
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].