Subject: FVWM: Icon Titles hidden behind other Icons

From: Patrick Stadler <[email-masked]>
Date: Fri, 25 Jun 1999 17:40:18 -0700

Hello.  I just recently started using FVWM 2.2.2, and I have been trying
(unsuccessfully) to find the answers to several questions related to
icons.

First, is there a way to make the icon title come to the front of the
surrounding area when the mouse passes over it?  At present, when I pass
the mouse over an icon, the icon title will expand to give me the full
title, but sometimes will expand behind other icons instead of in front
of other icons where I can read it.  How can I make it always come to
the front without using the Autoraise module.

Also, is there a way to make all the icons the same size so that they
have a uniform look?  Is there an option I can specify?

Last, every once in a while, an icon will place itself behind another
icon, instead of in an open spot.  I haven't been able to reproduce this
reliably.  Its not a problem, though, since I have the WindowList bound
to a mouse button, but I just thought you might like to know.

Thank you in advance,
Patrick
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Noel St. John" <[email-masked]>
Date: Fri, 25 Jun 1999 17:53:28 -0700 (PDT)

> have a uniform look?  Is there an option I can specify?

I wanted the same uniform look so I've specified Icons for programs which
would normally provide their own as well as a default:

Style "NCDterm"     Icon Terminal.xpm, Sticky
Style "NCDconsole"  Icon Terminal.xpm, Sticky
Style "xlsbatch"    Icon Database.xpm, Sticky
Style "Crisp"       Icon TextEditor.xpm
Style "Netscape*"   Icon Multiview.xpm
Style "pine"        Icon Mail.xpm, Sticky
Style "*"           Icon Shell2.xpm, Color lightgrey/dimgrey

My specified icons were choosen in such that they are the same size.

-Noel

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 26 Jun 1999 14:55:44 +0200

> the front without using the Autoraise module.

This feature is not in 2.2.2 but in the current alpha releases (2.3.4 is
the latest). If you need it urgently you can fetch fvwm-2.3.4 from our
web site, but be warned that 2.3.4 is not considered stable. It has
several open problems that may bother you, foremost some debugging
output on the console. We are planning to get out the next stable release
(fvwm-2.4) within two months. So if you can wait a little longer...

> to a mouse button, but I just thought you might like to know.

Can you find a fairly reliable way to reproduce this?

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Sat, 26 Jun 1999 22:22:26 -0400

> Can you find a fairly reliable way to reproduce this?

Manually move an icon.  Fvwm2 stops avoiding it.

I believe this is on purpose, but the motivation for the "feature"
isn't clear to me.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 28 Jun 1999 02:21:22 +0200

> I believe this is on purpose, but the motivation for the "feature"

Uh, really?  Experimenting with this I see that new icons *do* avoid
the moved one, but the move icon itself will happily overlap any other
in its designated place.

Dan, you know your way around with icon boxes. The passage responsible
for this bug is (icons.c, AutoPlaceIcon, line 489 ff.):

  if(IS_ICON_MOVED(t))
    {
      ... use old location
    }
  else if (t->wmhints && t->wmhints->flags & IconPositionHint)
    {
      ... unrelated code
    }
  /* dje 10/12/97:
     Look thru chain of icon boxes assigned to window.
     Add logic for grids and fill direction.
  */
  else {
      ... handle icon boxes
    }

When the icon has been moved the code avoiding other icons is
never activated (the passage handling icon boxes). Is it
difficult to feed the icon box code with the current position
of the icon as default and just make the icon avoid others
without warping into the icon box?

The general structure should be like this:

  if (t->wmhints && t->wmhints->flags & IconPositionHint)
  {
    if (!IS_ICON_MOVED(t))
    {
      ... use wm hints
    }
    else
    {
      ... use old position
    }
  }
  else
  {
    if (IS_ICON_MOVED(t))
    {
      ... default to old position
      do_ignore_icon_boxes = True;
    }
    else
    {
      do_ignore_icon_boxes = False;
    }
    ... handle icon boxes, avoid overlapping icons etc.
  }

Bye

Dominik ^_^

---

From: Allin Cottrell <[email-masked]>
Date: Sun, 27 Jun 1999 20:37:23 -0400 (EDT)

I'm signing off the fvwm list, because my mailbox is full
enough and I don't have a lot to contribute.  But in departing,
let me say a big Thank You for the high-quality help I received
in resolving one of the few problems I've ever had with fvwm.
It confirms me in my belief that fvwm is the smart choice for
window managers for a GNU/Linux system.

Allin Cottrell.