Subject: FVWM: fvwmaudio & fvwmevent dump cores

From: "Jacques B. Siboni" <[email-masked]>
Date: Mon, 07 Jun 1999 16:24:43 +0000

Hi,

I have been enjoying fvwm2 with sounds for a long while with Slackware Linux.
But now I turned to Red Hat 5.2. Since then I could not make fvwmaudio work
with fvwm2.

I exercised many combinations, fvwm2.0.46 + standard sound system; 
fvwm2.0.46 + OSS sound, fvwm2.2.2 + OSS. The result is a core dump when
loading
the module, the error seems to be Segmentation fault.

The problem is the same with FvwmEvent.

Are you aware of a problem or did I forget something?

I have seen that in the archives, notification # 156 depicts the same problem,
but I could not find the answer.

Thanks in advance

Jacques

PS 'play' works fine directly on files, but xmailbox does not provide sound.

-- 
Dr. Jacques B. Siboni mailto:[email-masked]
8 pass. Charles Albert, F75018 Paris, France
Tel. & Fax: 33 (0) 1 42 28 76 78
Home Page: http://www.lutecium.fr/jacsib/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 7 Jun 1999 18:30:06 -0600

> the module, the error seems to be Segmentation fault.

Can you try that with 2.3.3 (2.3.3 is an alpha release, don't use
it except for testing)? If the problem persiste, can you send us a
stack trace? To get one, do this:

  # gdb fvwm2 core
  (gdb) where

Note that there is no FvwmAudio module in 2.3.3 any more. It has been replaced
with a shell script that calls FvwmEvent in a 'FvwmAudio compatibility mode'.

> but I could not find the answer.

Bye

Dominik

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "s.a>" <[email-masked]>
Date: Mon, 07 Jun 1999 15:31:06 -0600

> the module, the error seems to be Segmentation fault.
I really dont know what I'm talking about, but using redhat linux(well
the ppc port)
when I try to play xgalaga I dont get any sounds except when I'm
root.(because it needs read write permisions to /dev/dsp.. any ways
mabey Fvwm needs read write permitions to an audio device ?

-- 
<^>/|\\V//|\<^>