Subject: FVWM: Problem with virtual window switching with mouse under 2.2.2

From: Jason White <[email-masked]>
Date: Wed, 16 Jun 1999 16:25:54 CDT

I've noticed a slight oddity with fvwm-2.2.2 under Tru64/Dec Unix/OSF1
when running on a 1280x1024 display; it works fine on 1024x768 displays
(which use the on-board video card as opposed to the machine with the
1280x1024 display which uses an add-on card from Digital).

  If I use the mouse to switch virtual windows by moving the mouse off
the right side of the screen and move the mouse too quickly, the pointer
goes off in to "null space" -- the virtual window does not switch.  If I
do the same behavior, moving the mouse very slowly, then it switches with
no problem.

  As far as panning up, down, and left, I can move the mouse as fast as I
want to and it switches every time, but the right side is picky.  I also
noticed that this same machine (with the 1280x1024 display) has two
displays, so I had to use fvwm2's '-s' option to prevent two instances of
fvwm from starting.

  My best guess is that the machine with the add-on video card (and the
1280x1024 display) is running a different X server than most of our other
Dec Unix running 1024x768.

I have enclosed the output from 'xdpyinfo -ext all' from the 1280x1024
screen in hopes it will be useful.  Any thoughts on how to fix this
problem would be most appreciated.

Thanks,
-Jason

-------------------------------------------------------------------------------

% xdpyinfo -ext all
name of display:    :0.0
version number:    11.0
vendor string:    DECWINDOWS Digital Equipment Corporation Digital UNIX V4.0
vendor release number:    1
maximum request size:  4194300 bytes
motion buffer size:  100
bitmap unit, bit order, padding:    32, LSBFirst, 32
image byte order:    LSBFirst
number of supported pixmap formats:    6
supported pixmap formats:
    depth 1, bits_per_pixel 1, scanline_pad 32
    depth 4, bits_per_pixel 8, scanline_pad 32
    depth 8, bits_per_pixel 8, scanline_pad 32
    depth 12, bits_per_pixel 32, scanline_pad 32
    depth 24, bits_per_pixel 32, scanline_pad 32
    depth 32, bits_per_pixel 32, scanline_pad 32
keycode range:    minimum 86, maximum 255
focus:  window 0x1c0000e, revert to Parent
number of extensions:    20
    Adobe-DPS-Extension
    BIG-REQUESTS
    DEC-XTRAP
    DOUBLE-BUFFER
    DPMS
    DPSExtension
    Keyboard-Management-Extension
    MIT-SCREEN-SAVER
    MIT-SHM
    MIT-SUNDRY-NONSTANDARD
    Multi-Buffering
    SHAPE
    SYNC
    Shared-Memory Transport
    XC-MISC
    XIE
    XInputExtension
    XKEYBOARD
    XTEST
    XVideo
default screen number:    0
number of screens:    2

screen #0:
  dimensions:    1280x1024 pixels (342x274 millimeters)
  resolution:    95x95 dots per inch
  depths (2):    1, 8
  root window id:    0x2a
  depth of root window:    8 planes
  number of colormaps:    minimum 1, maximum 1
  default colormap:    0x27
  default number of colormap cells:    256
  preallocated pixels:    black 1, white 0
  options:    backing-store YES, save-unders YES
  largest cursor:    64x64
  current input event mask:    0x58003d
    KeyPressMask             ButtonPressMask          ButtonReleaseMask        
    EnterWindowMask          LeaveWindowMask          SubstructureNotifyMask   
    SubstructureRedirectMask PropertyChangeMask       
  number of visuals:    6
  default visual id:  0x20
  visual:
    visual id:    0x20
    class:    PseudoColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x21
    class:    DirectColor
    depth:    8 planes
    available colormap entries:    8 per subfield
    red, green, blue masks:    0x7, 0x38, 0xc0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x22
    class:    GrayScale
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x23
    class:    StaticGray
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x24
    class:    StaticColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x7, 0x38, 0xc0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x25
    class:    TrueColor
    depth:    8 planes
    available colormap entries:    8 per subfield
    red, green, blue masks:    0x7, 0x38, 0xc0
    significant bits in color specification:    8 bits

screen #1:
  dimensions:    1280x1024 pixels (342x274 millimeters)
  resolution:    95x95 dots per inch
  depths (2):    1, 8
  root window id:    0x2c
  depth of root window:    8 planes
  number of colormaps:    minimum 1, maximum 1
  default colormap:    0x28
  default number of colormap cells:    256
  preallocated pixels:    black 1, white 0
  options:    backing-store YES, save-unders YES
  largest cursor:    64x64
  current input event mask:    0x58003d
    KeyPressMask             ButtonPressMask          ButtonReleaseMask        
    EnterWindowMask          LeaveWindowMask          SubstructureNotifyMask   
    SubstructureRedirectMask PropertyChangeMask       
  number of visuals:    6
  default visual id:  0x20
  visual:
    visual id:    0x20
    class:    PseudoColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x21
    class:    DirectColor
    depth:    8 planes
    available colormap entries:    8 per subfield
    red, green, blue masks:    0x7, 0x38, 0xc0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x22
    class:    GrayScale
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x23
    class:    StaticGray
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x0, 0x0, 0x0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x24
    class:    StaticColor
    depth:    8 planes
    available colormap entries:    256
    red, green, blue masks:    0x7, 0x38, 0xc0
    significant bits in color specification:    8 bits
  visual:
    visual id:    0x25
    class:    TrueColor
    depth:    8 planes
    available colormap entries:    8 per subfield
    red, green, blue masks:    0x7, 0x38, 0xc0
    significant bits in color specification:    8 bits

MIT-SHM version 1.1 opcode: 129, base event: 65, base error: 129
  shared pixmaps: yes, format: 2

Multi-Buffering version 1.0 opcode: 134, base event: 83, base error: 136
  screen 0 number of mono multibuffer types:    6
    visual id, max buffers, depth:    0x20, 0, 8
    visual id, max buffers, depth:    0x21, 0, 8
    visual id, max buffers, depth:    0x22, 0, 8
    visual id, max buffers, depth:    0x23, 0, 8
    visual id, max buffers, depth:    0x24, 0, 8
    visual id, max buffers, depth:    0x25, 0, 8
  number of stereo multibuffer types:    0
  screen 1 number of mono multibuffer types:    6
    visual id, max buffers, depth:    0x20, 0, 8
    visual id, max buffers, depth:    0x21, 0, 8
    visual id, max buffers, depth:    0x22, 0, 8
    visual id, max buffers, depth:    0x23, 0, 8
    visual id, max buffers, depth:    0x24, 0, 8
    visual id, max buffers, depth:    0x25, 0, 8
  number of stereo multibuffer types:    0

SHAPE version 1.0 opcode: 133, base event: 82

SYNC version 3.0 opcode: 135, base event: 85, base error: 137
  system counters: 1
    SERVERTIME  id: 0x00000030  resolution_lo: 4  resolution_hi: 0

XIE version 5.0 opcode: 136, base event: 87, base error: 139
  service class: FULL
  alignment: Arbitrary
  uncnst_mantissa: 24
  uncnst_min_exp: -126
  uncnst_max_exp: 128
  cnst_levels: 2 256 65536 16777216
  technique group: ColorAlloc
    ALLOC-ALL	speed: 128  needs_param: True   number: 2
  technique group: Constrain
    CLIP-SCALE	speed: 128  needs_param: False  number: 2
    HARD-CLIP	speed: 128  needs_param: False  number: 4
  technique group: ConvertFromRGB
    CIELAB	speed: 128  needs_param: True   number: 2
    CIEXYZ	speed: 128  needs_param: True   number: 4
    YCbCr	speed: 128  needs_param: True   number: 6
    YCC	speed: 128  needs_param: True   number: 8
  technique group: ConvertToRGB
    CIELAB	speed: 128  needs_param: True   number: 2
    CIEXYZ	speed: 128  needs_param: True   number: 4
    YCbCr	speed: 128  needs_param: True   number: 6
    YCC	speed: 128  needs_param: True   number: 8
  technique group: Convolve
    CONSTANT	speed: 128  needs_param: False  number: 2
  technique group: Decode
    UNCOMPRESSED-SINGLE	speed: 128  needs_param: True   number: 2
    UNCOMPRESSED-TRIPLE	speed: 128  needs_param: True   number: 3
    CCITT-G31D	speed: 128  needs_param: True   number: 4
    CCITT-G32D	speed: 128  needs_param: True   number: 6
    CCITT-G42D	speed: 128  needs_param: True   number: 8
    JPEG-BASELINE	speed: 128  needs_param: True   number: 10
    TIFF-2	speed: 128  needs_param: True   number: 14
    TIFF-PACKBITS	speed: 128  needs_param: True   number: 16
  technique group: Dither
    ERROR-DIFFUSION	speed: 128  needs_param: False  number: 2
    ORDERED	speed: 128  needs_param: False  number: 4
  technique group: Encode
    UNCOMPRESSED-SINGLE	speed: 128  needs_param: True   number: 2
    UNCOMPRESSED-TRIPLE	speed: 128  needs_param: True   number: 3
    CCITT-G31D	speed: 128  needs_param: True   number: 4
    CCITT-G32D	speed: 128  needs_param: True   number: 6
    CCITT-G42D	speed: 128  needs_param: True   number: 8
    JPEG-BASELINE	speed: 128  needs_param: True   number: 10
    TIFF-2	speed: 128  needs_param: True   number: 14
    TIFF-PACKBITS	speed: 128  needs_param: True   number: 16
  technique group: Gamut
    NONE	speed: 128  needs_param: False  number: 1
    CLIP-RGB	speed: 128  needs_param: False  number: 2
  technique group: Geometry
    ANTIALIAS	speed: 128  needs_param: False  number: 2
    BILINEAR-INTERPOLATION	speed: 128  needs_param: False  number: 8
    GAUSSIAN	speed: 128  needs_param: True   number: 10
    NEAREST-NEIGHBOR	speed: 128  needs_param: False  number: 12
  technique group: Histogram
    FLAT	speed: 128  needs_param: False  number: 2
    GAUSSIAN	speed: 128  needs_param: True   number: 4
    HYPERBOLIC	speed: 128  needs_param: True   number: 6
  technique group: WhiteAdjust
    NONE	speed: 128  needs_param: False  number: 1
    CIELAB-SHIFT	speed: 128  needs_param: True   number: 2

XTEST version 2.2 opcode: 137

DOUBLE-BUFFER version 1.0 opcode: 138, base error: 146
  Double-buffered visuals on screen 0
    visual id 0x20  depth 8  perflevel 0
    visual id 0x21  depth 8  perflevel 0
    visual id 0x22  depth 8  perflevel 0
    visual id 0x23  depth 8  perflevel 0
    visual id 0x24  depth 8  perflevel 0
    visual id 0x25  depth 8  perflevel 0
  Double-buffered visuals on screen 1
    visual id 0x20  depth 8  perflevel 0
    visual id 0x21  depth 8  perflevel 0
    visual id 0x22  depth 8  perflevel 0
    visual id 0x23  depth 8  perflevel 0
    visual id 0x24  depth 8  perflevel 0
    visual id 0x25  depth 8  perflevel 0

--
       Jason D. White                http://www.public.iastate.edu/~jdwhite
     [email-masked]                'finger' for other information
    Iowa State University            (PGP pub key, Anon FTP, US Mail Addr)
Durham Center Operations Staff       Strive for excellence, not perfection.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 23 Jun 1999 03:16:18 +0200

> displays, so I had to use fvwm2's '-s' option to prevent two instances of

Uh, did the pointer perhaps move to the second display? I don't know
exactly what you have to do to get a multi headed setup, but this
sounds awfully like it. When you move over the right border on such
a setup you cursor will warp to the other display. That's an issue of
the X server(s).

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].