Subject: RE: FVWM: shutdown

From: Joel Golden <[email-masked]>
Date: Tue, 8 Jun 1999 09:48:28 -0500

Ok.. I have a program that will let me log in as root and
perform commands.  Question is should this syntax work in the
fvwm2rc.menus.m4 file as an Exec?  

	Exec progx root shutdown -h now

	'progx root shutdown -h now' works fine from the user prompt,
but it does not from the .m4 file.
	
Joel Golden
www.bcs-systems.com
[email-masked]
BCS
1100 71 Plaza Court
Suite 11
Springdale, AR 72764
(501)750-7475

		-----Original Message-----
		From:	Dominik Vogt [mailto:[email-masked]]
		Sent:	Friday, June 04, 1999 12:05 PM
		To:	[email-masked]
		Subject:	Re: FVWM: shutdown

		On Thu, Jun 03, 1999 at 04:37:49PM -0500,
[email-masked] wrote:
		> 	Or, is there a way to disable the password
dialog box that
		> appears when the Exec shutdown -h now command is
issued?

		Well, that depends on what OS you are using and what
program
		draws the box. If you need to log in as a different user
to
		do the shutdown this is a problem.

		Bye

		Dominik ^_^

		-- 
		Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
		Herrenberger Str.130, 71034 Boeblingen, Germany
		phone: 07031/14-4596, fax: 07031/14-3883,
[email-masked]
		--
		Visit the official FVWM web page at <URL:
http://www.fvwm.org/>.
		To unsubscribe from the list, send "unsubscribe fvwm" in
the body of a
		message to [email-masked].
		To report problems, send mail to [email-masked].
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 9 Jun 1999 00:59:02 +0200

> but it does not from the .m4 file.

It should work. Does it help if you put the command line in a shell
script and call this instead (don't forget to make it executable)?
If not, try to start a FvwmConsole window (from your config file)
and type the command there. Do you get any error messages?

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].