Subject: FVWM: Amaya and decorations

From: Rob Urban <[email-masked]>
Date: Thu, 03 Jun 1999 21:57:22 +0200

Hi all,

on fvwm-2.2.2 on Digital UNIX I've got a small but annoying problem:  Amaya
(the w3-consortiums html editor) doesn't get any window decorations.  I've
got the usual

	Style "*"           BorderWidth 5, HandleWidth 5
	Style "*"           Icon unknown1.xpm, Color Black/#40a0c0
	Style "*"           ActivePlacement, SmartPlacement
	Style "*"           MWMFunctions,MWMDecor,HintOverride
	Style "*"           DecorateTransient,IconBox 0 -10 -280 -1

and this works for all other windows.  fvwm v2.0.46 exibited exactly the
same behaviour.  Anyone got an idea?

I've noticed that the name of the window, as returned by xwininfo depends
on the document being edited, but the 'style "*" ...' directive shouldn't
be bothered by this, should it?

confused in Munich,

Rob Urban
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Michael Han <[email-masked]>
Date: Thu, 03 Jun 1999 14:01:00 -0700

Previously...
>be bothered by this, should it?

Typically, I'd suspect that a style directive that strips the
decorations is accidentally applying to Amaya windows... What are the
strings matching name, icon, resource and class, as reported by
FvwmIdent or xwininfo? See if any of these strings will match a style
line in your .fvwm2rc stripping away decorations, as would commonly be
found applying to things like "*clock*" or "Fvwm*".

Outside of that, I haven't any suggestions. Anyone else running this
and have different results to report?
-- 
[email-masked]
"Bagman" is not a legitimate career choice
 - The collected wisdom of Bart Simpson
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Rob Urban <[email-masked]>
Date: Thu, 03 Jun 1999 23:27:21 +0200

Hello Michael,

> found applying to things like "*clock*" or "Fvwm*".

Name, Icon Name, and Resource are all the same, namely

	AmayaPage.html Formatted_view

Class is

	Dialogue

Any ideas?

Rob Urban

---

From: Rob Urban <[email-masked]>
Date: Fri, 04 Jun 1999 00:02:16 +0200

Michael Han wrote:
> How about the Style lines from your rcfile?

Well, I just commented out every style command except for those I listed
earlier.  No change.

> 
> Nothing here is very obviously an unintentional substring match to
> popular non-decorated styles.

Rob Urban

---

From: Michael Han <[email-masked]>
Date: Thu, 03 Jun 1999 14:52:01 -0700

Previously...

I will not go near the kindergarten turtle

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 4 Jun 1999 03:11:59 +0200

> be bothered by this, should it?

Does this work with older fvwm versions? Doe is work with other window
managers? If both answers are no, could you use 'xwininfo -all' on such
a window to find out if the 'Override Redirect' property is set?
(You should get a line saying 'Override redirection?: Yes/No'.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Rob Urban <[email-masked]>
Date: Fri, 04 Jun 1999 04:37:52 +0200

Dominik Vogt wrote:
> > and this works for all other windows.  fvwm v2.0.46 exibited exactly the <-+  
> > same behaviour.  Anyone got an idea?                                       |
> >                                                                            |
> > I've noticed that the name of the window, as returned by xwininfo depends  ^
> > on the document being edited, but the 'style "*" ...' directive shouldn't  |
> > be bothered by this, should it?                                            /
>                                                                             /
> Does this work with older fvwm versions? Doe is work with other window     /
  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^ >>>------------>------------>------

if I start mwm, the amaya window gets decorations.

> (You should get a line saying 'Override redirection?: Yes/No'.

'xwininfo -all' returns

	Override Redirect State: no

Here is the entire output of xwininfo -all:

xwininfo -all

xwininfo: Please select the window about which you
          would like information by clicking the
          mouse in that window.

xwininfo: Window id: 0x3800187 "AmayaPage.html  Formatted_view"

  Root window id: 0x29 (the root window) (has no name)
  Parent window id: 0xc0009b (has no name)
     1 child:
     0x3800188 (has no name): ()  596x820+0+0  +530+5
        6 children:
        0x3800194 (has no name): ()  596x32+0+0  +530+5
           9 children:
           0x380019d (has no name): ()  37x22+5+5  +535+10
           0x380019c (has no name): ()  37x22+42+5  +572+10
           0x380019b (has no name): ()  50x22+79+5  +609+10
           0x380019a (has no name): ()  45x22+129+5  +659+10
           0x3800199 (has no name): ()  50x22+174+5  +704+10
           0x3800198 (has no name): ()  44x22+224+5  +754+10
           0x3800197 (has no name): ()  58x22+268+5  +798+10
           0x3800196 (has no name): ()  68x22+326+5  +856+10
           0x3800195 (has no name): ()  42x22+549+5  +1079+10
        0x3800193 (has no name): ()  581x15+0+787  +530+792
        0x3800192 (has no name): ()  15x655+581+132  +1111+137
        0x380018d (has no name): ()  596x100+0+32  +530+37
           2 children:
           0x3800191 (has no name): ()  596x26+0+0  +530+37
              24 children:
              0x38001b9 (has no name): ()  26x26+544+0  +1074+37
              0x38001b8 (has no name): ()  26x26+518+0  +1048+37
              0x38001b7 (has no name): ()  26x26+492+0  +1022+37
              0x38001b6 (has no name): ()  26x26+466+0  +996+37
              0x38001b5 (has no name): ()  26x26+440+0  +970+37
              0x38001b4 (has no name): ()  26x26+414+0  +944+37
              0x38001b3 (has no name): ()  26x26+388+0  +918+37
              0x38001b2 (has no name): ()  26x26+362+0  +892+37
              0x38001b1 (has no name): ()  26x26+336+0  +866+37
              0x38001b0 (has no name): ()  26x26+310+0  +840+37
              0x38001af (has no name): ()  8x26+302+0  +832+37
              0x38001ae (has no name): ()  26x26+276+0  +806+37
              0x38001ad (has no name): ()  26x26+250+0  +780+37
              0x38001ac (has no name): ()  26x26+224+0  +754+37
              0x38001ab (has no name): ()  8x26+216+0  +746+37
              0x38001aa (has no name): ()  26x26+190+0  +720+37
              0x38001a9 (has no name): ()  26x26+164+0  +694+37
              0x38001a8 (has no name): ()  26x26+138+0  +668+37
              0x38001a7 (has no name): ()  8x26+130+0  +660+37
              0x38001a6 (has no name): ()  26x26+104+0  +634+37
              0x38001a5 (has no name): ()  26x26+78+0  +608+37
              0x38001a4 (has no name): ()  26x26+52+0  +582+37
              0x38001a3 (has no name): ()  26x26+26+0  +556+37
              0x38001a2 (has no name): ()  26x26+0+0  +530+37
           0x380018e (has no name): ()  596x71+0+29  +530+66
              2 children:
              0x3800190 (has no name): ()  61x53+5+5  +535+71
              0x380018f (has no name): ()  520x66+71+5  +601+71
                 2 children:
                 0x38001ca (has no name): ()  520x33+0+33  +601+104
                    2 children:
                    0x38001cc (has no name): ()  460x33+60+0  +661+104
                    0x38001cb (has no name): ()  60x18+0+15  +601+119
                 0x38001ba (has no name): ()  520x33+0+0  +601+71
                    2 children:
                    0x38001c0 (has no name): ()  460x33+60+0  +661+71
                    0x38001bb (has no name): ()  60x18+0+15  +601+86
        0x380018b (has no name): ()  581x655+0+132  +530+137
           1 child:
           0x380018c (has no name): ()  577x651+2+2  +532+139
        0x3800189 (has no name): ()  596x18+0+802  +530+807
           1 child:
           0x380018a (has no name): ()  55x18+0+0  +530+807

  Absolute upper-left X:  530
  Absolute upper-left Y:  5
  Relative upper-left X:  0
  Relative upper-left Y:  0
  Width: 596
  Height: 820
  Depth: 8
  Visual Class: PseudoColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x27 (installed)
  Bit Gravity State: ForgetGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: no
  Map State: IsViewable
  Override Redirect State: no
  Corners:  +530+5  -154+5  -154-199  +530-199
  -geometry 596x820+530+5

  Bit gravity: ForgetGravity
  Window gravity: NorthWestGravity
  Backing-store hint: NotUseful
  Backing-planes to be preserved: 0xffffffff
  Backing pixel: 0
  Save-unders: No

  Someone wants these events:
      KeyPress
      KeyRelease
      EnterWindow
      LeaveWindow
      Exposure
      StructureNotify
      FocusChange
      PropertyChange
      ColormapChange
  Do not propagate these events:
      ButtonPress
      ButtonRelease
  Override redirection?: No

  Window manager hints:
      Client accepts input or input focus: Yes
      Initial state is Normal State

  Normal window size hints:
      User supplied location: 2, 2
      Program supplied size: 596 by 820
      Program supplied window gravity: NorthWestGravity
  No zoom window size hints defined

  No window shape defined
  No border shape defined

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 4 Jun 1999 11:02:34 -0600

On Fri, Jun 04, 1999 at 04:37:52AM +0200, [email-masked] wrote:
>...

Hrm, looks ok. Can you start this application with a different name and see
if that helps? Or perhaps if you set a specific style for "amaya*"?

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Pete Forman <[email-masked]>
Date: Fri, 4 Jun 1999 11:55:18 +0100 (BST)

Just to let you know, amaya is decorated normally for me.
(amaya 1.2a and fvwm 2.1.10)
-- 
Pete Forman
Western Geophysical
[email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Rob Urban <[email-masked]>
Date: Fri, 04 Jun 1999 16:17:39 +0200

> if that helps? Or perhaps if you set a specific style for "amaya*"?

I tried commenting *all* other 'Style' lines out except for the five above
and restarting fvwm and amaya.  no change.

If I run amaya under another name I get exactly the same behavior.

I suppose I could re-compile fvwm with some debug options and then get
a better idea of what's going on by analyzing some log?

Rob Urban

---

From: Michael Han <[email-masked]>
Date: Fri, 04 Jun 1999 08:24:26 -0700

Previously...
>a better idea of what's going on by analyzing some log?

I compiled amaya 2.0a last night from sources, linked against lesstif
0.88. When I run it under fvwm (I think I'm running 2.2, but it's so
hard to remember), it's properly decorated...
-- 
[email-masked]
I will not fake my way through life
 - The collected wisdom of Bart Simpson
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].