Subject: [Fwd: FVWM: fvwmaudio & fvwmevent dump cores]

From: "Jacques B. Siboni" <[email-masked]>
Date: Tue, 08 Jun 1999 07:32:48 +0000

Subject: Re: FVWM: fvwmaudio & fvwmevent dump cores
From: "Jacques B. Siboni" <[email-masked]>
To: Dominik Vogt <[email-masked]>
Date: Mon, 07 Jun 1999 20:55:14 +0000

Dominik,

Thank you for your fast answer. I downloaded the 2.3.3 version and the result
is very different. I don't get a core file and the FvwmEvent keeps running.
But I don't get no sound and the play program appears as zombie in the ps
list.

Maybe it could be a  configuration error. Here is my .fvwm2rc file

*FvwmEventCmd myplay
*FvwmEventDelay 0
*FvwmEvent startup 		start.au
*FvwmEvent shutdown 		cannot.be.completed.au
*FvwmEvent unknown 		crash.au
*FvwmEvent add_window 		gong.au
*FvwmEvent raise_window 	door_open.au
... ...
AddToMenu AudioSettings 
+ "Event mapping" 			FvwmForm AudioEvents
+ "FvwmEvents"				Module FvwmEvent

AddToFunc "myplay" "I" Exec exec /usr/bin/play /usr/share/sound/$1

Here is what I get in the log file

sox: Type AUTO input must be a file, not a pipe
sox: Type AUTO input must be a file, not a pipe
sox: Type AUTO input must be a file, not a pipe
sox: Type AUTO input must be a file, not a pipe
sox: Type AUTO input must be a file, not a pipe
... ...

I think it  is very close to make it work!!!

What do you suggest?

Cheers

Jacques

Dominik Vogt wrote:
> 
> 
> Can you try that with 2.3.3 (2.3.3 is an alpha release, don't use
> it except for testing)? If the problem persiste, can you send us a
> stack trace? To get one, do this:
> 
>   # gdb fvwm2 core
>   (gdb) where
> 
> Note that there is no FvwmAudio module in 2.3.3 any more. It has been replaced
> with a shell script that calls FvwmEvent in a 'FvwmAudio compatibility mode'.
> 
> > The problem is the same with FvwmEvent.
> >
> > Are you aware of a problem or did I forget something?
> >
> > I have seen that in the archives, notification # 156 depicts the same problem,
> > but I could not find the answer.
> 
> Bye
> 
> Dominik
> 
> --
> Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
> Herrenberger Str.130, 71034 Boeblingen, Germany
> phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]

-- 
Dr. Jacques B. Siboni mailto:[email-masked]
8 pass. Charles Albert, F75018 Paris, France
Tel. & Fax: 33 (0) 1 42 28 76 78
Home Page: http://www.lutecium.fr/jacsib/

---

From: Michael Han <[email-masked]>
Date: Tue, 08 Jun 1999 01:33:11 -0700

Previously...
>Maybe it could be a  configuration error. Here is my .fvwm2rc file

I think this is a configuration error.

>[snip]

Note that the first variable of a function is represented in AddToFunc
as $0. See 'man fvwm2' in the section for AddToFunc. Anyway, try
replacing $1 above with $0. Currently you're trying to play a
directory, I believe.
-- 
[email-masked]
I am not a 32 year old woman
 - The collected wisdom of Bart Simpson
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Jacques B. Siboni" <[email-masked]>
Date: Tue, 08 Jun 1999 10:06:58 +0000

> replacing $1 above with $0. Currently you're trying to play a

Thank you Mike!!

That's right, with $0 it works. 

The point is that I use version 2.3.3 which is not stable.

Do I have to wait till it is stable or is there a version between 2.2.2 and
2.3.3 which works?

Thanks again

Jacques

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 8 Jun 1999 12:38:47 -0600

> Do I have to wait till it is stable or is there a version between 2.2.2 and

No. 2.2.2 is the latest 'stable' version. But you might try to use the
FvwmEvent executable of 2.3.3 and run it under 2.2.2. That *might* work.

Bye

Dominik ^_^

---

From: "Jacques B. Siboni" <[email-masked]>
Date: Tue, 08 Jun 1999 11:56:29 +0000

Dominik,

Yes I confirm it does work with that configuration. Thanks again

Jacques