Subject: FVWM: Menus - missing separator

From: Neil Bird <[email-masked]>
Date: Thu, 20 May 1999 09:19:02 +0100

fvwm2.2/sparc/solaris2.5.1: if I create a menu 'by hand' (fvwm2rc):

AddTomenu uaa2src____ "uaa2-src ..." Title
+ "localhost"  exec xterm -T uaa2-src -n uaa2src -e rlogin -l uaa2src
localhost
+ ""           Nop
+ "wsc097"     exec xterm -n uaa2src -e rlogin -l uaa2src wsc097
+ "wsc098"     exec xterm -n uaa2src -e rlogin -l uaa2src wsc098
+ "wsc099"     exec xterm -n uaa2src -e rlogin -l uaa2src wsc099

 ... etc. for lots of machines ... I get a separator for the "" Nop bit.
Fine. However, I have several accounts now that I need to bring up xterms
for in the same way, and it's an arse maintaining several lists of valid
machines. So, I did this in my fvwm2rc (XTerm iss a small wrpper for xterm
- ignore):

Function NewPeep  uaa2src
Function NewPeep  twkadm
Function NewPeep  hjmoore

AddToFunc NewPeep  \
   "I" AddToMenu Peeps "$0" Popup $0____ Item 80 -100-4p
+  "I" DestroyMenu $0____
+  "I" AddTomenu $0____ "localhost"  \
       exec XTerm -r `uname -n` $0 "$0 login `uname -n`" "$0"
+  "I" AddTomenu $0____ ""           \
       Nop
+  "I" AddTomenu $0____ "wsc097"     \
       exec XTerm -r wsc097 $0 "$0 login wsc097" "$0"
+  "I" AddTomenu $0____ "wsc098"     \
       exec XTerm -r wsc098 $0 "$0 login wsc098" "$0"

  .. etc. (I've split the lines to fit them into the e-mail).

  This does work, but I don't get any separator! Now, I *can* make the ""
into "-", and the entry duly appears, but of course then I just see '-' as
its label!

  Why does the 'AddTomenu blah "" Nop' not work in this instance?

-- 
========================- http://www.rrds.co.uk/ -======================
 Neil Bird                   |   This is who we are     The time is near
                             |        There are 226 days remaining
 mailto:[email-masked] |                           [ T-19 days! ]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 20 May 1999 12:56:58 +0200

>   Why does the 'AddTomenu blah "" Nop' not work in this instance?

Can you try this instead:

  +  "I" AddTomenu $0____ \"\" Nop
                          ^^^^

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Neil Bird <[email-masked]>
Date: Thu, 20 May 1999 12:06:24 +0100

>   +  "I" AddTomenu $0____ \"\" Nop

  Yup. I now get a menu entry labelled '""' :-/