Subject: FVWM: key binding in fvwm 1.24r

From: Dominic Mitchell <[email-masked]>
Date: Mon, 10 May 1999 00:15:19 -0400

Dear all,

I am trying to figure out how to bind a key to restart fvwm.  I have
experimented with a few configurations but what it does is exit X all
together uncleanly.  

Key F13         A       C       Restart fvwm

Any good soul to give a hint on how to do this?  

Thanks,

Dominic.

-- 
==========================================================
Dominic Mitchell      Email: [email-masked]
Economic Department          mailto:[email-masked]
Queen's University
Kingston, Ontario      
Canada, K7L 3N6	      Running Linux Redhat 5.2	
==========================================================
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Adam L Rice <[email-masked]>
Date: Tue, 11 May 1999 03:06:52 +0100

>From ye olde fvwm 1 manual:

       Restart  name WindowManagerName
              Causes  fvwm to re-read itself if WindowManagerName
              = fvwm, or to switch to an alternate window manager
              if  WindowManagerName  != fvwm.  If the window man-
              ager is not in your default search path,  then  you
              should  use  the  full path name for WindowManager-
              Name.
	      
              WindowManagerName  is  not  quoted,  but  name  is.
              name is the name that appears in a menu, if that is
              where the function is called from. name is required
              even if the function is not called from a menu, for
              ease of parsing.

              This command should not have a  trailing  ampersand
              or  any command line arguments, and should not make
              use of any environmental variables. Of the  follow-
              ing  examples, the first three are sure losers, but
              the third is OK:
		
              Key F1 R N Restart " " fvwm &
              Key F1 R N Restart " " $(HOME)/bin/fvwm
              Key F1 R N Restart " " twm -f .mystartupfile
              Key F1 R N Restart " " /home/nation/bin/fvwm

So, it looks like your problem is missing the " " which is required to parse
the line properly. It looks like you're using the syntax for fvwm2. Check
that it's the fvwm version 1 man page you're looking at... on my machine it
has FVWM(1.2) at the top rather than FVWM(2.xx), and it has a headline
"SPECIAL NOTE FOR XFREE86 USERS" on the first page, which has been removed
from the fvwm2 man pages.

All this comes with a big disclaimer that I haven't used fvwm version 1 in
about 3 years and it isn't really "supported" any more. Actually, perhaps
there should be a seperate mailing list for it, given that it is still
useful as one of the "lightest" configurable window managers out there.

-- 
Adam Rice -- [email-masked] -- Blackburn, Lancashire, England