Subject: FVWM: Re FVWM, Help Newbie drowning, Beware, Huge message

From: Paul Hurley <[email-masked]>
Date: Sat, 22 May 1999 16:38:44 +0100

Okay, I altered the script and deleted the cache. I then get this

<quote>
loading cache ./config.cache
checking for a BSD compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking whether make sets ${MAKE}... yes
checking for working aclocal... found
checking for working autoconf... found
checking for working automake... found
checking for working autoheader... found
checking for working makeinfo... found
checking whether to enable modal dialogs for applications... yes
checking whether to enable saveunders for pop-up menus... yes
checking whether to enable shape extensions... yes
checking whether to enable ActiveDown button state... yes
checking whether to enable Inactive button state... yes
checking whether to enable MiniIcon style option... yes
checking whether to enable vector button style... yes
checking whether to enable pixmap button style... yes
checking whether to enable gradient button style... yes
checking whether to enable stacked button styles... yes
checking whether to enable styled title-bars... yes
checking whether to enable BorderStyle command... yes
checking whether to enable UseDecor style option... yes
checking whether to enable WindowShade function... yes
checking whether to enable debugging messages... no
checking iconpath... /usr/include/X11/bitmaps:/usr/include/X11/pixmaps
checking for gcc... gcc
checking whether the C compiler (gcc  ) works... yes
checking whether the C compiler (gcc  ) is a cross-compiler... yes
checking whether we are using GNU C... yes
checking whether gcc accepts -g... yes
checking how to run the C preprocessor... gcc -E
checking for POSIXized ISC... no
checking for minix/config.h... no
checking for stdarg.h... yes
checking for vfprintf... yes
checking for waitpid... yes
checking for c++... c++
Using c++ to compile C++ programs
checking for c++... (cached) c++
checking whether the C++ compiler (c++  ) works... yes
checking whether the C++ compiler (c++  ) is a cross-compiler... yes
checking whether we are using GNU C++... yes
checking whether c++ accepts -g... yes
checking for X... libraries /usr/X11/lib, headers
checking for dnet_ntoa in -ldnet... no
checking for dnet_ntoa in -ldnet_stub... no
checking for gethostbyname... yes
checking for connect... yes
checking for remove... yes
checking for shmat... yes
checking for IceConnectionNumber in -lICE... yes
checking for cpp... /lib/cpp
checking for a BSD compatible install... /usr/bin/install -c
checking whether ln -s works... yes
checking whether make sets ${MAKE}... (cached) yes
checking for ranlib... ranlib
checking for flex... flex
checking for flex... (cached) flex
checking for yywrap in -lfl... yes
checking lex output file root... lex.yy
checking whether yytext is a pointer... yes
checking for bison... bison -y
checking for ANSI C header files... yes
checking for sys/wait.h that is POSIX.1 compatible... yes
checking for stdlib.h... yes
checking for fcntl.h... yes
checking for limits.h... yes
checking for malloc.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for unistd.h... yes
checking for getopt.h... yes
checking for sys/select.h... no
checking for sys/systeminfo.h... no
checking for working const... yes
checking for inline... inline
checking for off_t... yes
checking for pid_t... yes
checking for size_t... yes
checking return type of signal handlers... void
checking for strftime... yes
checking for gettimeofday... yes
checking for mkfifo... yes
checking for putenv... yes
checking for select... yes
checking for setvbuf... yes
checking for socket... yes
checking for waitpid... (cached) yes
checking for strdup... yes
checking for strstr... yes
checking for strtol...

./conftest: error in loading shared libraries
libc.so.5: cannot open shared object file: No such file or directory
configure: error: can not run test program while cross compiling
</quote>

This is the content of the config.log

<quote>
This file contains any messages produced by compilers while
running configure, to aid debugging if configure makes a mistake.

configure:610: checking for a BSD compatible install
configure:663: checking whether build environment is sane
configure:720: checking whether make sets ${MAKE}
configure:766: checking for working aclocal
configure:779: checking for working autoconf
configure:792: checking for working automake
configure:805: checking for working autoheader
configure:818: checking for working makeinfo
configure:853: checking whether to enable modal dialogs for applications

configure:874: checking whether to enable saveunders for pop-up menus
configure:895: checking whether to enable shape extensions
configure:919: checking whether to enable ActiveDown button state
configure:943: checking whether to enable Inactive button state
configure:967: checking whether to enable MiniIcon style option
configure:991: checking whether to enable vector button style
configure:1015: checking whether to enable pixmap button style
configure:1039: checking whether to enable gradient button style
configure:1063: checking whether to enable stacked button styles
configure:1087: checking whether to enable styled title-bars
configure:1111: checking whether to enable BorderStyle command
configure:1135: checking whether to enable UseDecor style option
configure:1159: checking whether to enable WindowShade function
configure:1183: checking whether to enable debugging messages
configure:1204: checking iconpath
configure:1231: checking for gcc
configure:1344: checking whether the C compiler (gcc  ) works
configure:1360: gcc -o conftest    conftest.c  1>&5
configure:1386: checking whether the C compiler (gcc  ) is a
cross-compiler
configure:1391: checking whether we are using GNU C
configure:1400: gcc -E conftest.c
configure:1419: checking whether gcc accepts -g
configure:1451: checking how to run the C preprocessor
configure:1472: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:1532: checking for POSIXized ISC
configure:1554: checking for minix/config.h
configure:1564: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:1560: minix/config.h: No such file or directory
configure: failed program was:
#line 1559 "configure"
#include "confdefs.h"
#include <minix/config.h>
configure:1607: checking for stdarg.h
configure:1617: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:1646: checking for vfprintf
configure:1674: gcc -o conftest -g -O2   conftest.c  1>&5
configure:1706: checking for waitpid
configure:1734: gcc -o conftest -g -O2   conftest.c  1>&5
configure:1873: checking for c++
configure:1911: checking for c++
configure:1943: checking whether the C++ compiler (c++  ) works
configure:1959: c++ -o conftest    conftest.C  1>&5
/usr/bin/ld: warning: libm.so.6, needed by /usr/lib/libstdc++.so, may
conflict with
libm.so.5
/usr/bin/ld: warning: libc.so.6, needed by /usr/lib/libstdc++.so, may
conflict with
libc.so.5
configure:1985: checking whether the C++ compiler (c++  ) is a
cross-compiler
configure:1990: checking whether we are using GNU C++
configure:1999: c++ -E conftest.C
configure:2018: checking whether c++ accepts -g
configure:2057: checking for X
configure:2124: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:2200: gcc -o conftest -g -O2   conftest.c -lXt  1>&5
ld: cannot open -lXt: No such file or directory
configure: failed program was:
#line 2193 "configure"
#include "confdefs.h"

int main() {
XtMalloc()
; return 0; }
configure:2371: checking for dnet_ntoa in -ldnet
configure:2390: gcc -o conftest -g -O2   conftest.c -ldnet   1>&5
ld: cannot open -ldnet: No such file or directory
configure: failed program was:
#line 2379 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char dnet_ntoa();

int main() {
dnet_ntoa()
; return 0; }
configure:2412: checking for dnet_ntoa in -ldnet_stub
configure:2431: gcc -o conftest -g -O2   conftest.c -ldnet_stub   1>&5
ld: cannot open -ldnet_stub: No such file or directory
configure: failed program was:
#line 2420 "configure"
#include "confdefs.h"
/* Override any gcc2 internal prototype to avoid an error.  */
/* We use char because int might match the return type of a gcc2
    builtin and then its argument prototype would still apply.  */
char dnet_ntoa();

int main() {
dnet_ntoa()
; return 0; }
configure:2460: checking for gethostbyname
configure:2488: gcc -o conftest -g -O2   conftest.c  1>&5
configure:2558: checking for connect
configure:2586: gcc -o conftest -g -O2   conftest.c  1>&5
configure:2650: checking for remove
configure:2678: gcc -o conftest -g -O2   conftest.c  1>&5
configure:2742: checking for shmat
configure:2770: gcc -o conftest -g -O2   conftest.c  1>&5
configure:2843: checking for IceConnectionNumber in -lICE
configure:2862: gcc -o conftest -g -O2   -L/usr/X11/lib conftest.c
-lICE   1>&5
ld: warning: libc.so.6, needed by /usr/X11/lib/libICE.so, may conflict
with libc.so.5

configure:2890: checking for cpp
configure:2940: checking for a BSD compatible install
configure:2993: checking whether ln -s works
configure:3014: checking whether make sets ${MAKE}
configure:3043: checking for ranlib
configure:3076: checking for flex
configure:3109: checking for flex
configure:3143: checking for yywrap in -lfl
configure:3162: gcc -o conftest -g -O2   conftest.c -lfl   1>&5
configure:3185: checking lex output file root
configure:3206: checking whether yytext is a pointer
configure:3225: gcc -o conftest -g -O2   conftest.c  -lfl 1>&5
configure:3251: checking for bison
configure:3284: checking for ANSI C header files
configure:3297: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:3388: checking for sys/wait.h that is POSIX.1 compatible
configure:3409: gcc -c -g -O2  conftest.c 1>&5
configure:3433: checking for stdlib.h
configure:3443: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:3433: checking for fcntl.h
configure:3443: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:3433: checking for limits.h
configure:3443: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:3433: checking for malloc.h
configure:3443: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:3433: checking for string.h
configure:3443: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:3433: checking for memory.h
configure:3443: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:3433: checking for unistd.h
configure:3443: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:3473: checking for getopt.h
configure:3483: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:3473: checking for sys/select.h
configure:3483: gcc -E  conftest.c >/dev/null 2>conftest.out
In file included from /usr/include/sys/select.h:31,
                 from configure:3479:
/usr/include/selectbits.h:30: warning: `__FD_ZERO' redefined
/usr/include/asm/posix_types.h:61: warning: this is the location of the
previous
definition
/usr/include/selectbits.h:35: warning: `__FD_SET' redefined
/usr/include/asm/posix_types.h:41: warning: this is the location of the
previous
definition
/usr/include/selectbits.h:40: warning: `__FD_CLR' redefined
/usr/include/asm/posix_types.h:46: warning: this is the location of the
previous
definition
/usr/include/selectbits.h:49: warning: `__FD_ISSET' redefined
/usr/include/asm/posix_types.h:54: warning: this is the location of the
previous
definition
In file included from configure:3479:
/usr/include/sys/select.h:60: warning: `FD_SET' redefined
/usr/include/linux/time.h:30: warning: this is the location of the
previous
definition
/usr/include/sys/select.h:61: warning: `FD_CLR' redefined
/usr/include/linux/time.h:31: warning: this is the location of the
previous
definition
/usr/include/sys/select.h:62: warning: `FD_ISSET' redefined
/usr/include/linux/time.h:32: warning: this is the location of the
previous
definition
/usr/include/sys/select.h:63: warning: `FD_ZERO' redefined
/usr/include/linux/time.h:33: warning: this is the location of the
previous
definition
configure: failed program was:
#line 3478 "configure"
#include "confdefs.h"
#include <sys/select.h>
configure:3473: checking for sys/systeminfo.h
configure:3483: gcc -E  conftest.c >/dev/null 2>conftest.out
configure:3479: sys/systeminfo.h: No such file or directory
configure: failed program was:
#line 3478 "configure"
#include "confdefs.h"
#include <sys/systeminfo.h>
configure:3511: checking for working const
configure:3565: gcc -c -g -O2  conftest.c 1>&5
configure:3586: checking for inline
configure:3600: gcc -c -g -O2  conftest.c 1>&5
configure:3626: checking for off_t
configure:3659: checking for pid_t
configure:3692: checking for size_t
configure:3726: checking return type of signal handlers
configure:3748: gcc -c -g -O2  conftest.c 1>&5
configure:3767: checking for strftime
configure:3795: gcc -o conftest -g -O2   conftest.c  1>&5
configure:3865: checking for gettimeofday
configure:3893: gcc -o conftest -g -O2   conftest.c  1>&5
configure:3865: checking for mkfifo
configure:3893: gcc -o conftest -g -O2   conftest.c  1>&5
configure:3865: checking for putenv
configure:3893: gcc -o conftest -g -O2   conftest.c  1>&5
configure:3865: checking for select
configure:3893: gcc -o conftest -g -O2   conftest.c  1>&5
configure:3865: checking for setvbuf
configure:3893: gcc -o conftest -g -O2   conftest.c  1>&5
configure:3865: checking for socket
configure:3893: gcc -o conftest -g -O2   conftest.c  1>&5
configure:3865: checking for waitpid
configure:3920: checking for strdup
configure:3948: gcc -o conftest -g -O2   conftest.c  1>&5
configure:3920: checking for strstr
configure:3948: gcc -o conftest -g -O2   conftest.c  1>&5
configure:3920: checking for strtol
configure:3948: gcc -o conftest -g -O2   conftest.c  1>&5

</quote>

Seems theres a problem with libc.so.5 (not sure what version is on my
box or where it
sits ?

Any help greatly appreciated

--
--------------------------------------------------------
| Paul Hurley  @ Aston University                      |
| [email-masked]   /    www.aston.ac.uk/~hurleyp/ |
| .sig 's all shiny and new !                          |
--------------------------------------------------------

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Adam Rice <[email-masked]>
Date: Sat, 22 May 1999 21:31:24 +0100

> Seems theres a problem with libc.so.5 (not sure what version is on my

Okay, it looks like what has happened is that your compiler has got
misconfigured somehow to compile for libc.so.5 instead of libc.so.6. I don't
know why, i assume Red Hat don't ship it like that. If noone else comes up
with a smart fix for this, all I can suggest is the brute-force method of
reinstalling gcc from CD (or from an official RPM, if you don't have the Red
Hat CD).

-- 
Adam Rice -- [email-masked] -- Blackburn, Lancashire, England

---

From: Paul Hurley <[email-masked]>
Date: Sun, 23 May 1999 20:34:58 +0100

Yay,
    After taking the monster step of reinstalling all of linux (I used a newer
version of Redhat that I had lying around) the configure and install worked
great, and I'm now runnign fvwm2 !

BP

PS Does anyone know how to stop the mousepointer turning into a huge blue
rectangle when in xlock ??