Subject: FVWM: help! window sizing problem

From: Josh Beavers <[email-masked]>
Date: Tue, 11 May 1999 15:31:53 -0500

Is there an option (like in MWM) that makes a new window automatically size
or fit itself to the screen, so it doesn't extend onto other desktops?
Thanks,
   Josh Beavers

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 12 May 1999 12:48:07 +0200

> or fit itself to the screen, so it doesn't extend onto other desktops?

Do you want to make windows smaller so that they fit nicely on a single page?
Could you explain in detail where the problem lies so that we can better judge
if some built in mechanism suffices or if new code is needed?

Possible solutions:

 - make the window fit on the page exactly

     Resize 100 100

 - make the window fill the available space without overlapping other windows
   (This is a recent change in the development sources, not available in the
   2.2 release)

     Resize grow grow

 - clip the window to page boundaries when it is created

     not possible at the moment

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: 12 May 1999 15:48:54 +0200

>  - clip the window to page boundaries when it is created

ctwm has a MaxWindowSize option and makes larger windows smaller.  I
think this applies to newly created windows as well as already
existing windows.  Here's the relevant man page excerpt:

,----- from ctwm man page
|      MaxWindowSize string
|              This variable specifies  a  geometry  in  which  the
|              width  and  height give the maximum size for a given
|              window.  This is typically used to restrict  windows
|              to   the   size  of  the  screen.   The  default  is
|              "30000x30000".
`-----

Dunno if this is what Josh wants, but maybe it is.

kai
-- 
Abort this operation?   [Abort]  [Cancel]

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 28 May 1999 01:35:10 +0200

> or fit itself to the screen, so it doesn't extend onto other desktops?

I've just implemented the 'MaxWindowSize' command. It will be in the next
release.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].