Subject: FVWM: Multi Desk Question

From: "Keven R. Pittsinger" <[email-masked]>
Date: Tue, 20 Apr 1999 21:53:06 -0400

OK, I'm using Fvwm 2.2, and I like it.  I'm also using XFCE 2.4.0 as a toolbar 
and I want to migrate to using FvwmWharf instead.  What I need is a way to 
flip between desktops with a function key.  The appropriate snips of my 
.fvwm2rc:

DeskTopSize 3x3

AddToFunc "InitFunction"
+		"I" Desk 0 3
+		"I" Module FvwmPager 0 3

AddToFunc "RestartFunction"
+		"I" Desk 0 3
+		"I" Module FvwmPager 0 3

I want to keep the 3x3 size and 4 desks.  The pager works fine with XFCE.  I 
tried something like this to flip between desks:

Key F1          RTSF    A       GotoPage 1 4
Key F2          RTSF    A       GotoPage 1 3
Key F3          RTSF    A       GotoPage 1 2
Key F4          RTSF    A       GotoPage 1 1

This doesn't work, it just bounces me around on the screens on one desk.  I need to bounce to different desks.

OK, so what am I doing wrong here??

Keven

tc++ tm+ tn t4- to ru++ ge+ 3i c+ jt au st- ls pi+ ta+ he+ so- vi zh sy
------------------------------------------------------------------------------
                                                     Science-Fiction Adventure
                                                     In Reavers' Deep

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Nathan Froyd <[email-masked]>
Date: Tue, 20 Apr 1999 21:02:04 -0500 (EST)

>From my .fvwmrc:

Key F1 A 2 Desk 0 0
Key F2 A 2 Desk 0 1
Key F3 A 2 Desk 0 2
Key F4 A 2 Desk 0 3
Key F5 A 2 Desk 0 4
Key F6 A 2 Desk 0 5
Key F7 A 2 Desk 0 6
Key F8 A 2 Desk 0 7
Key F9 A 2 Desk 0 8
Key F10 A 2 Desk 0 9
Key F11 A 2 Desk 0 10
Key F12 A 2 Desk 0 11
-- 
Nathan | [email-masked] | http://www.rose-hulman.edu/~froydnj/
God went through hell so we don't have to.      ICQ:18861764 | AOL:myrlyn007
Avoid the gates of hell. Use Linux.           Python:"x='x=%s;x%%`x`';x%`x`"
Evolution is a million line computer program falling into place by accident.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: 21 Apr 1999 10:19:16 +0200

> Key F1          RTSF    A       GotoPage 1 4

Use Desk rather than GotoPage to change desks rather than pages.

kai
-- 
Abort this operation?   [Abort]  [Cancel]

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 21 Apr 1999 11:41:13 +0200

> OK, so what am I doing wrong here??

You're using the wrong command. You need to use the 'Desk' or 'GotoDesk'
command (GotoDesk is a synonym for Desk that is new in the current
development sources. Only Desk will work in 2.2, but I plan to phase
the desk command out in falour of GotoDesk some day).

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].