Subject: Re: FVWM: rc file questions

From: Dominik Vogt <[email-masked]>
Date: Wed, 7 Apr 1999 01:20:54 +0200

On Mon, Mar 29, 1999 at 03:27:40PM -0700, Bob van der Poel wrote:
> >   bvdp> 2. I have
> > 
> >   bvdp>         Style "*"       RandomPlacement
> > 
> >   bvdp> However, when my netscape windows come up they want to
> >   bvdp> 'tile'. Each new window is a bit lower (vertically) than the
> >   bvdp> next. I assume that this is to show the different titlebars. I
> >   bvdp> have the geom set to +0+0 for the netscape windows and really do
> >   bvdp> want it that way. Can I force this?
> > 
> > If I understand you correctly, you should be able to create a specific
> > style for netscape windows and specify a different placement scheme for
> > them:
> > 
> >   Style "Netscape" <something else>
> > 
> > and that will override the "*" style.
> >
> 
> Yes. I understand this. But, I guess what I'm asking is what placement
> scheme forces the placement specified in the *geometry X resource? It
> seems that fvwm2 is trying to be nice to me...and I don't want it to.

Hmm, that's difficult. Placing windows is one of the tasks the window
manager is supposed to do. The problem is: how can fvwm know that *you*
specified the position for the window. In X, when a window is created
it has to supply a preferred position to the window manager. This position
depends on your X resources. So if an application tells the window manager
it prefers to be at +0+0, how does the window manager disstinguish between
the application default and the user's geometry spec?

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: 07 Apr 1999 11:09:52 +0200

Dominik Vogt <[email-masked]> writes:

  > [...] So if an application tells the window manager it prefers to
  > be at +0+0, how does the window manager disstinguish between the
  > application default and the user's geometry spec?

At work, I'm using ctwm, and I started two xterms:

  xterm -geometry +50+50
  xterm

xprop on these windows returned:

WM_NORMAL_HINTS(WM_SIZE_HINTS):
                user specified location: 50, 50
                user specified size: 644 by 388
                program specified size: 644 by 388
                program specified minimum size: 12 by 20
                program specified resize increment: 8 by 16
                program specified base size: 4 by 4
                window gravity: NorthWest

for the first one, and

WM_NORMAL_HINTS(WM_SIZE_HINTS):
                user specified size: 644 by 404
                program specified size: 644 by 404
                program specified minimum size: 12 by 20
                program specified resize increment: 8 by 16
                program specified base size: 4 by 4

for the second one.

The difference seems to be in the `user specified location' line.  I'd
assume that you see `program specified location' if the program has
specified that location.

I don't know anything about the underlying C functions used by xprop.

kai
-- 
Abort this operation?   [Abort]  [Cancel]