Subject: FVWM: Want my FvwmPager go public

From: Martin Gisser <[email-masked]>
Date: Tue, 20 Apr 1999 05:14:42 +0000

Hi there!

I'd like to put a screenshot of my FvwmPager (which is swallowed by FvwmButtons)
on my machine's homepage using some SSI or CGI.
http://www.gisser.de - only when box & ISDN are up.

I'm quite a newbie to Linux programming.
Wrote my first real bash script yesterday.
Don't know much about Fvwm internals beyond .fvwmrc

Maybe someone has a ready script or some hint.

Thanks in advance,
--Martin
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tim Phipps <[email-masked]>
Date: Tue, 20 Apr 1999 12:48:11 +0100

> http://www.gisser.de - only when box & ISDN are up.

xwd -id $(xlswins | grep "Fvwm Pager" | awk '{print $1}') | xwdtopnm |
ppmtogif > pager.gif

(all on one line) will give you a pager.gif from a ksh/bash script.  You
could run this from cron to give a snapshot at regular intervals.  If
you're worried about being sued for using GIF software you could use
ppmtojpeg or even pnmtopng.

It would be nice to set a short expiry date on the picture so that
clients don't use an old cached copy but I don't know how to do that.

Cheers,
Tim.

---

From: Martin Gisser <[email-masked]>
Date: Tue, 20 Apr 1999 21:27:04 +0000

Tim Phipps wrote:
> (all on one line) will give you a pager.gif from a ksh/bash script.

Fine.  I like that: Saying it all with one command line.  Now I know what to do.

Alas, xlswins seems not to be readily available for the mortal Linux user.
But I found xwininfo.  I'll try to extract the window id from there.

Thanks,
  Martin

---

From: Martin Gisser <[email-masked]>
Date: Wed, 21 Apr 1999 04:12:12 +0000

> xwd -id $(xlswins | grep "Fvwm Pager" | awk '{print $1}') | xwdtopnm |

Here's what I did:

  xwd -silent -name "Desk 0" | xwdtopnm  > pager.pnm

(and then turned on the GIMP)

But
1.) I only get the green channel 
2.) Parts of other windows overlapping FvwmPager are also rendered

See http://www.gisser.de/pager.xwd.pnm.gif and http://www.gisser.de/pager.real.gif
Maybe this is more something for a pure X mailing list...
Seems I'll wind up doing this with the GIMP...

Can anybody tell me how to automatically raise the FvwmButtons window before doing
the xwd stuff ?

:-)
    Martin