Subject: Re: FVWM: Make a window smaller using Resize

From: Brad Giaccio <[email-masked]>
Date: Thu, 1 Apr 1999 06:31:05 -0500

On Mon, Mar 29, 1999 at 05:24:55AM +0200, Dominik Vogt wrote:
> On Fri, Mar 26, 1999 at 03:11:58PM -0800, [email-masked] wrote:
> >    Version: Fvwm 2.2
> > 
> >    The Resize function acts a bit weird when I try make a window
> >    smaller. First I have to move the a little bit to make the window
> >    larger, then I can make it smaller.
> > 
> >    An inconvenience. Would it be possible to allow making the window
> >    smaller right away?
> 
> It works for me. Could you provide some more information (config file)?
> 
> Bye
> 
> Dominik ^_^
> 

The problem is with windows that don't have handles.
 
-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 1 Apr 1999 21:53:47 +0200

> The problem is with windows that don't have handles.

Well, how would we know which of the eight sides and corners
you wanted to grab? If you click in the center of the window
there is no way to guess the direction in which you want the
resize.

Perhaps this might work:

Divide the window into 9 sectors. If the pointer is in any
sector but #5 it it warped to the corresponding spot on the
edge of the window:

7-------8-------9
|   |       |   |
|s7  \ s8  /  s9|
|  +---------+  |
|_ |         | _|
| \|         |/ |
|  |         |  |
|  |         |  |
4  |    5    |  6
|  |         |  |
|s4|   s5    |s6|
|_/|         |\_|
|  |         |  |
|  +---------+  |
|s1  / s2  \  s3|
|   |       |   |
1-------2-------3

E.g.: Click in (s7) -> pointer warped to (7).

Any comments?

---- a few hours later ----

I've made an experimental patch with this:

  if (pointer is within <tolerance> pixels from a corner or the side bars)
  {
    Warp pointer to corresponding corner or center of side bar.
  }

where <tolerance> (in x/y direction) is defined as:

  5% of window's original width/height,
  if this is less than 20 pixels
    25% of window's original width/height
    if this is more than 20 pixels
      20 pixels

In other words: try resizing from FvwmButtons or a root menu,
click near the edge of a window and tell me what you think
about what happens.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].