Subject: FVWM: Is it possible to place the cursor on a window

From: Sam Krishnabhat <[email-masked]>
Date: Mon, 26 Apr 1999 19:56:31 -0700 (PDT)

Hi,

I am using fvwm2.2.

Is it possible to place the cursor automatically on a window
when it pops up, I mean to draw the FOCUS on that. For example,
when I do netscape find, netscape will open a dialog box
with title "Netscape: Find". I want to be able to give focus
to this whenever it pops up, by automatically placing the
cursor there. How can I do it ?

-sam
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Local Echo <[email-masked]>
Date: Mon, 26 Apr 1999 21:07:35 -0600 (MDT)

> cursor there. How can I do it ?
I'm not sure what netscape calls the find window off the top of my head.

As a matter of fact I'm not even sure if this is a GlobalOpts in 2.2 but
in 2.3.2 it's style "?netscape*" GrabFocus  seems to work find for me.

This style command will make any netscape window grap focus when it comes
up.

---

From: Neil Bird <[email-masked]>
Date: Tue, 27 Apr 1999 09:35:09 +0100

> cursor there. How can I do it ?

  Here's what I have - BTW, it doesn't use the title of the window, but
the fact that all netscape's popups' classes have a "_popup" suffix:

AddToFunc NewWindowFunc  \
   "I" WindowId $0 (*_popup)       WarpToWindow 50 53

# FvwmEvent settings

*FvwmEventPassID

*FvwmEventCmd
*FvwmEvent        add_window NewWindowFunc

  ... and start FvwmEvent in InitFunc.

  Warning: I /think/ that the PassID flag was a patch I included at some
point; I can't remember if it's in the raw 2.2 release ...
  
-- 
========================- http://www.rrds.co.uk/ -======================
 Neil Bird                   |   This is who we are     The time is near
                             |        There are 249 days remaining
 mailto:[email-masked] |                           [ T-42 days! ]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: 27 Apr 1999 13:48:09 +0200

> cursor there. How can I do it ?

Apart from the (old?) GrabFocus option, the current development code
contains an option to automatically focus all transient windows.  I
find that nearly all windows which require input from the user are
transient windows, so this option can be turned on for all windows and
it does the right thing.

kai
-- 
Abort this operation?   [Abort]  [Cancel]