Subject: FVWM: How to scroll only when moving windows and not otherwise?

From: Josip Gracin <[email-masked]>
Date: 03 Apr 1999 21:12:25 +0200

Hello!

I started using X Window and fvwm2 again after awhile (I used text mode
exclusively :-)) and I can't seem to find a certain functionality that I
could swear was there last time I used fvwm2.

I need the Pager to scroll by 100% ONLY when I'm moving a window and hit
the edge of the screen with a mouse pointer.  Otherwise, hitting the edge
with the pointer shouldn't switch to another screen.

Basically, I need the "EdgeScroll 0 0" functionality but also to be able
to move windows across screens more easily.

Thanks in advance!

Please send your replies to me directly because I'm not subscribed to the
list.  Thanks!
-- 
| Josip Gracin
| Zagreb, Croatia
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Scott Scriven <[email-masked]>
Date: Sat, 03 Apr 1999 14:50:01 -0700

> with the pointer shouldn't switch to another screen.

I've looked for the same thing, and couldn't get this behavior without
modifying the source.  I may have just missed something, though.  But here's
the simple patch I use to "fix" this behavior.  Apply it to fvwm/events.c...

--------------------------------------------------
*** events.c~   Tue Feb 16 09:11:43 1999
--- events.c    Wed Feb 24 16:37:45 1999
***************
*** 1206,1214 ****
--- 1206,1217 ----
    {
      int delta_x=0, delta_y=0;
      /* this was in the HandleMotionNotify before, HEDU */
+ /* Modified by Scott Scriven..  I hate this behavior */
+ #if 0
      HandlePaging(Scr.EdgeScrollX,Scr.EdgeScrollY,
                   &Event.xcrossing.x_root,&Event.xcrossing.y_root,
                   &delta_x,&delta_y,True);
+ #endif
      return;
    }
  #endif /* NON_VIRTUAL */
--------------------------------------------------

 _  _ _  _ ___ ___  -----------"Use the source, Luke!"---------
( \/ ( \/ (__ (__ ) | ~  Scott Scriven (Toy Keeper / XYZZ)    |
 \  / \  /  //  //  | mailto:[email-masked]           |
 /  \ / /  //_ //_  | mailto:[email-masked]         |
(_/\_(_/  (___(___) | http://www.vis.colostate.edu/~scriven/  |
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sun, 4 Apr 1999 01:29:15 +0200

> to move windows across screens more easily.

I do it this way (and it works well):

  EdgeResistance   250 10
  EdgeScroll       0 0

Propably you didn't have the proper EdgeResistance.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].