Subject: FVWM: PLZ, how to use keys F20-F29 in fvwm2rc.keys ?

From: Josin Etienne <[email-masked]>
Date: Mon, 15 Mar 1999 08:12:34 -0700 (MST)

Hi,

------------------------------------------------------------------------
(current .Xmodmap and output of 'xmodmap -pke' are in attachment 1)
My setup is:
  Linux RedHat 5.0 for intel -- 2.0.31 kernel
  XFree86 3.3
  fvwm 2.0.46
  vim 5.3 running on xterms 
------------------------------------------------------------------------

The plan is that i would like to use keys F20-F29 in fvwm to do mappings 
like the following:
	Key F20     A   A  Popup "Utilities"
	Key F21     A   A  WindowList

To achieve that, I want to use the windoz keys in my keyboard as modifiers.
(i have already placed them as osf keys in my xmodmap keycode table)

Thus, I would like to produce keys F20-F29 by typing (for example)
    osfSelect + a
    osfSelect + b
	...

The modifier map follows:

	xmodmap:  up to 2 keys per modifier, (keycodes in parentheses):

	shift       Shift_L (0x32),  Shift_R (0x3e)
	lock        Caps_Lock (0x42)
	control     Control_L (0x25),  Control_R (0x6d)
	mod1        Alt_L (0x40),  Alt_R (0x71)
	mod2        Num_Lock (0x4d)
	mod3        
	mod4
	mod5        Scroll_Lock (0x4e)

To be honest, in spite of reading the man page and a couple of HOW TO's,
i still don't have a very good grasp of how the modifiers work.  

The only thing that i know is that Alt-<char> currently gives the 
corresponding char with the high bit set.  And since i use those Meta's 
in my editor (vim), i would not want to change how that works.

[i say that because I see that Alt is my modifier 1 up above]

any help and enlightment will be appreciated... 

- josin

_________________________________________________________________________
In Heaven there will be no DOS, no Intel, and above all, no Bill.

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Josin Etienne <[email-masked]>
Date: Mon, 15 Mar 1999 23:12:27 -0700 (MST)

> Thus, I would like to produce keys F20-F29 by typing (for example)

well, 

i found a way to achieve what i wanted in regards to fvwm.  Looking 
thru the fvwm archives, i found a msg from 1996, from Andrew Eskilsson,
mentioning that fvwm will recognize a modifier which has been added 
thru xmodmap.

thus, now i have in my .Xmodmap:

  ! ADD MODIFIERS FOR FVWM...
  add mod3 = osfSelect

and in fvwm2rc.keys:

  Key g     A   3  Prev [!Visible *] FlipFocusAndWarp
  Key l     A   3  Next [CurrentScreen *lll*] FocusAndWarp
 
and it works great !

----------------------

i am still in a fog concerning how modifiers work in xmodmap though.

for example (this is a default setting):
    keycode  64 = Alt_L Meta_L
    
    I assume this means that if i shift my Alt_L key, then i get Meta_L

    But... don't i already get Meta, without shifting ? 

    (because, to use this fvwm mapping, i type Alt-a, NOT Shift-Alt-a)

         Key a       A   M   Next [CurrentScreen *aux*] FocusAndWarp

so, shat gives ?   looking thru the linux documentation for the 
loadkeys command (for the console), i found a description 
of how modifiers work
	but i am not sure they work the same way in X.

- josin