Subject: FVWM: A suggestion for FVWM developers.

From: "Bill OConnor" <[email-masked]>
Date: Fri, 26 Mar 1999 10:16:03 -0800

I'm currently using FVWM95 with RH Linux 5.2.  I keep a lot of shell windows
open but I'm unable to tell which one is which in the taskbar. It would be
nice if the working directory would show up in the window title and in the
taskbar when the window is reduced.  Maybe this is already possible.  I
would delve into this myself but I just have to many other projects to work
on at the moment that are not optional.

Another small but sometimes annoying occurrence is popup menus near the
right side of the screen.  If you right click close to the right side, roll
over an item that is itself a menu, the new menu pops up over the top of the
current menu, preventing selection of the next item.  The new menu should
popup to the left of the current menu.

Just a few suggestion to make things a little more usable.

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Fri, 26 Mar 1999 13:30:17 -0500 (EST)

On 26 Mar, Bill OConnor wrote:

> I'm currently using FVWM95 with RH Linux 5.2.

This is the FVWM (FVWM-2, actually) mailing list; there's another list
for Fvwm95.

> I keep a lot of shell windows

Here's a simple script that might work for you (title.sh)

    #! /bin/sh

    case "$TERM" in
    xterm*)	    [ -n "$1" ] && echo -n "^[]0;${1}";;
    esac

Note that the '^[' above should be a literal ESCAPE (Hex 1b) in your
script file and not the two characters I replaced it with above.

Note that your shell may require the use of "echo \c" instead:

    #! /bin/sh

    case "$TERM" in
    xterm*)	    [ -n "$1" ] && echo "^[]0;${1}\c";;
    esac

Anyway, typing "title.sh `pwd`" should then retitle your xterm to the
current working directory.  You can use aliases, shell functions, or
hooks to get your shell to run this whenever you change directories. 
Consult your shell documentation or man page for more information.

-- 
Larry Gensch					      [email-masked]

I would really appreciate it if the login command had a better sense of humor.

---

From: Benoit Champagne <[email-masked]>
Date: Fri, 26 Mar 1999 13:33:54 -0500 (EST)

Are you using xterms (or any variant thereof)?

If you do, you can achieve this using simple escape sequences on your command
line.

For example, I have these funcs defined in my .profile:

# Sorry for the french: Translation: set window title
# Fonction pour mettre le titre de la fenetre a une valeur quelconque.
set_wmtitle() {
  if [ ".$1" = "." ]; then
    echo "Utilisation: set_wmtitle TITRE"
  else
    echo "]2;$1\c"
  fi
}

# Translation: Set Icon title
# Fonction pour changer le nom de l'icon
set_wmicon() {
  if [ ".$1" = "." ]; then
    echo "Utilisation: set_wmicon TITRE"
  else
    echo "]1;$1\c"
  fi
}

# Augment the 'cd' command: this one puts the PWD in the title bar
cdd() {
  if [ $SHELL = zsh ]; then
    OLDCWD=`pwd`;command cd;cd $1;CWD=`pwd`
  else
    OLDCWD=`pwd`;unalias cd;cd $1;CWD=`pwd`; alias cd=cdd
  fi

  #  PS1="../`basename $CWD`> "
  echo  "]2;LOGIN - [$HOST":"$LOGNAME] $CWD\c"
}

# If not using VIM...
# use this to put the buffer name in the window title area
# VI pour mettre le nom du fichier ainsi que le CWD dans le haut de la fenetre
_vi() {
  # CSH Syntaxe
  #   echo "]2; [$HOST":" $CWD] \!*"; ex -v \!*; mypwd'
  # KSH Syntax
   echo "]2; [$HOST":" $CWD] $*"; ex -v $*;cdd $CWD
}

Hope this helps a little..

Best Regards

===>Bill OConnor writes:

    Bill> I'm currently using FVWM95 with RH Linux 5.2.  I keep a lot of shell
    Bill> windows open but I'm unable to tell which one is which in the
    Bill> taskbar. It would be nice if the working directory would show up in
    Bill> the window title and in the taskbar when the window is reduced.
    Bill> Maybe this is already possible.  I would delve into this myself but I
    Bill> just have to many other projects to work on at the moment that are
    Bill> not optional.

    Bill> Another small but sometimes annoying occurrence is popup menus near
    Bill> the right side of the screen.  If you right click close to the right
    Bill> side, roll over an item that is itself a menu, the new menu pops up
    Bill> over the top of the current menu, preventing selection of the next
    Bill> item.  The new menu should popup to the left of the current menu.

    Bill> Just a few suggestion to make things a little more usable.

    Bill> -- Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
    Bill> To unsubscribe from the list, send "unsubscribe fvwm" in the body of
    Bill> a message to [email-masked].  To report problems, send mail to
    Bill> [email-masked].

-- 
---------------------------------------------------------------------
    Continuum all the way                 COMPUTER ASSOCIATES
Benoit Champagne  ift.a             |  Main Line : (450) 978-4899
Tel  : (450) 978-4913               |    3090 Boul. Le Carrefour
FAX  : (450) 978-4909               |          Suite 300
Email: [email-masked]     |          Laval, PQ
                                    |           H7T 2J7
Nice Words from F1 analysts:
  Murray: And look at the flames coming from the back of Berger's McLaren 
   James: Actually, Murray, they're not flames, it's the safety light
---------------------------------------------------------------------
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 26 Mar 1999 14:12:00 -0500

> Just a few suggestion to make things a little more usable.

As has already been pointed out, wrong list.

Fvwm2 has all the menu controls you could think of, including
the fix for the problem you identified.

(And it is just as capable of looking like Windows as fvwm95 is.)

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Richard Lister <[email-masked]>
Date: Mon, 29 Mar 1999 10:43:34 -0500

On Fri, 26 Mar 1999 10:16:03 -0800
"Bill OConnor" <[email-masked]> 
> on at the moment that are not optional.

Bill

You can do this using xterm escape sequences. See
  http://www.giccs.georgetown.edu/~ric/howto/Xterm-Title.html

Cheers
Ric

Richard J Lister, Georgetown Institute for Cognitive and Computational Sciences
Georgetown University Medical Center, Washington, DC 20007, USA
Phone: +1 202-687 2878
Email: [email-masked] 
Web: http://www.giccs.georgetown.edu/~ric/
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].