Subject: FVWM: Menu behaviour - patch to ver. 2.2

From: Adam Tla/lka <[email-masked]>
Date: Wed, 10 Mar 1999 13:30:05 +0100 (MET)

Below is the patch:

~~~~~~~
--- fvwm/menus.c.orig   Wed Mar 10 13:00:28 1999
+++ fvwm/menus.c        Wed Mar 10 13:29:08 1999
@@ -444,6 +444,8 @@
        isn't pressed */
     MenuItem *mi;
     char key;
+    /* if this is a letter set it to lower case */  
+    (int)keychar = tolower((int)keychar) ;    
     /* Search menu for matching hotkey */
     for (mi = menu->first; mi; mi = mi->next) {
       key = tolower(mi->chHotkey);
~~~~~~~

Regards

 . .  Adam Tla/lka      mailto:[email-masked]    ^v^ ^v^ ^v^
  )   System  & Network Administration Group           ~~~~~~
  -  Computer Center,  Technical University of Gdansk, Poland
     PGP public key:   finger [email-masked]

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 10 Mar 1999 15:40:55 +0100

> Below is the patch:

OK, I see the patch, but what is the problem? I see no discussion
of a bug here.

Bye

Dominik

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Paul D. Smith)
Date: 10 Mar 1999 11:17:50 -0500

%% Dominik Vogt <[email-masked]> writes:

  >> Below is the patch:

  dv> OK, I see the patch, but what is the problem? I see no discussion
  dv> of a bug here.

The problem was reported in a previous message: the fact that keyboard
accelerators are case-sensitive.  On the one hand this seems like a good
thing, as it gives you more possible accelerators; on the other hand it's
a drag that you have to change the case of your description to fit the
case of your accelerator, and maybe it should be ignored.

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 11 Mar 1999 00:10:04 +0100

> case of your accelerator, and maybe it should be ignored.

Ah, *this* mail. I'll apply the patch. Shortcuts were supposed to be case
insensitive anyway.

Bye

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]