Subject: FVWM: Fvwm2.2 and Taskbar

From: Len Smith <[email-masked]>
Date: Mon, 29 Mar 1999 10:04:47 -0500 (EST)

I am suporting a site which is using Fvwm95, and I am trying to
migrate them to Fvwm-2.2 and the Taskbar under that. Under the Fvwm95
taskbar the third mouse click, on one of the task bar entries, would bring
up a menu which would allow the use to Iconify, Minimize, Kill, etc the
window. I tried using the same menu under fvwm-2.2 and Fvwm-2.2 crashes
with a seg fault whenever I select one of the menu items.

	the menu is defined as

DestroyMenu "Window-Ops2"
AddToMenu "Window-Ops2" "&Restore"        Iconify -1
+                       "&Move"           Move-or-Raise
+                       "&Size"           Resize-or-Raise
+                       "Mi&nimize"       Iconify 1
+                       "Ma&ximize"       Maximize 100 100
+                       ""                Nop
+                       "&Kill"           Destroy
+                       "&Close Alt+F4"   Delete 

	and under the FvwmTaskbar section I defined click 3 as

*FvwmTaskBarAction Click3 Popup Window-Ops2

	Am I doing anything obviously wrong, or incorrect?

			thanx,
				len Smith

--------------------------------------------------------------------------------

In a world where data is coin of the realm, and transmissions are guarded by
no better sentinels than man-made codes and corruptible devices, there is no
such thing as a secret.	--C.S. Friedman, "This Alien Shore"

--------------------------------------------------------------------------------

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Michael Han <[email-masked]>
Date: Mon, 29 Mar 1999 09:59:40 -0800

Previously...
>with a seg fault whenever I select one of the menu items.

Yeah, I noticed the same, but since it was a signal 11 segfault, I
wasn't sure if it was a problem specific to me or not... guess not.
Well, in all likelihood when taskbar tells fvwm what window to send
its actions to, it's okay with a builtin like Iconify, but something
naughty happens if it's a menu, that subsequently needs to know where
to send its actions to... Almost certainly a bug in 2.2's taskbar.
-- 
[email-masked]
I will not sell land in Florida
 - The collected wisdom of Bart Simpson
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].