Subject: Re: FVWM: Fvwm2.2 and Taskbar

From: Dominik Vogt <[email-masked]>
Date: Tue, 30 Mar 1999 06:58:02 +0200

On Mon, Mar 29, 1999 at 10:04:47AM -0500, [email-masked] wrote:
> 
> 
> 	I am suporting a site which is using Fvwm95, and I am trying to
> migrate them to Fvwm-2.2 and the Taskbar under that. Under the Fvwm95
> taskbar the third mouse click, on one of the task bar entries, would bring
> up a menu which would allow the use to Iconify, Minimize, Kill, etc the
> window. I tried using the same menu under fvwm-2.2 and Fvwm-2.2 crashes
> with a seg fault whenever I select one of the menu items.
> 
> 	the menu is defined as
> 
> DestroyMenu "Window-Ops2"
> AddToMenu "Window-Ops2" "&Restore"        Iconify -1
> +                       "&Move"           Move-or-Raise
> +                       "&Size"           Resize-or-Raise
> +                       "Mi&nimize"       Iconify 1
> +                       "Ma&ximize"       Maximize 100 100
> +                       ""                Nop
> +                       "&Kill"           Destroy
> +                       "&Close Alt+F4"   Delete 
> 
> 	and under the FvwmTaskbar section I defined click 3 as
> 
> *FvwmTaskBarAction Click3 Popup Window-Ops2

Could you fetch us a stack trace?

  # gdb fvwm2 core
  (gdb) where

If it's not fvwm that coredumped replace the approriate file name
(gdb tells you which).

Bye

Dominik ^_^

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Michael Han <[email-masked]>
Date: Mon, 29 Mar 1999 23:12:21 -0800

Previously...
>If it's not fvwm that coredumped replace the approriate file name

Dominik, since I've seen the same problem and can reproduce it, here's
a trace:

<78> gdb /usr/X11R6/bin/fvwm2.3.0 
GDB is free software and you are welcome to distribute copies of it
 under certain conditions; type "show copying" to see the conditions.
There is absolutely no warranty for GDB; type "show warranty" for details.
GDB 4.16 (i586-unknown-linux), Copyright 1996 Free Software Foundation, Inc...
(gdb) core ../core
Core was generated by `fvwm2.3.0 -f windoze.fvwm2rc'.
Program terminated with signal 11, Segmentation fault.
Reading symbols from /usr/X11R6/lib/libXpm.so.4.9...done.
Reading symbols from /usr/X11R6/lib/libSM.so.6.0...done.
Reading symbols from /usr/X11R6/lib/libICE.so.6.0...done.
Reading symbols from /usr/X11R6/lib/libXext.so.6.1...done.
Reading symbols from /usr/X11R6/lib/libX11.so.6.1...done.
Reading symbols from /lib/libc.so.5.3.12...done.
Reading symbols from /lib/ld-linux.so.1...done.
#0  0x8050f0c in iconify_function (eventp=0x80740dc, w=36, tmp_win=0x0, 
    context=1, action=0x808dfc7 "", Module=0xbffff618) at builtins.c:694
694         if(val <=0)
(gdb) where
#0  0x8050f0c in iconify_function (eventp=0x80740dc, w=36, tmp_win=0x0, 
    context=1, action=0x808dfc7 "", Module=0xbffff618) at builtins.c:694
#1  0x805b108 in ExecuteFunction (Action=0x80877f0 "Iconify", tmp_win=0x0, 
    eventp=0x80740dc, context=1, Module=-1) at functions.c:273
#2  0x805ef8f in do_menu (menu=0x8087c80, menuPrior=0x0, 
    pmiExecuteAction=0xbffff67c, cmenuDeep=0, fStick=0, eventp=0x80740dc, 
    pops=0xbffff684) at menus.c:275
#3  0x8051764 in menu_func (eventp=0x80740dc, w=16777229, tmp_win=0x808d0c0, 
    context=1, action=0x808df9e "Window", Module=0xbffff734, fStaysUp=0)
    at builtins.c:1069
#4  0x80517a8 in popup_func (eventp=0x80740dc, w=16777229, tmp_win=0x808d0c0, 
    context=1, action=0x808df9e "Window", Module=0xbffff734) at builtins.c:1080
#5  0x805b108 in ExecuteFunction (Action=0xbffff75c "PopUp Window", 
    tmp_win=0x808d0c0, eventp=0x80740dc, context=1, Module=0)
    at functions.c:273
#6  0x8065332 in HandleModuleInput (w=16777229, channel=0) at module.c:358
#7  0x805aa82 in My_XNextEvent (dpy=0x8076f58, event=0x80740dc)
    at events.c:1591
#8  0x8058eea in HandleEvents () at events.c:182
#9  0x805bb9c in main (argc=3, argv=0xbffffd1c) at fvwm.c:521
#10 0x804b27b in ___crt_dummy__ ()

This got produced by binding a menu to Mouse 3 on a taskbar button
like so:

*FvwmTaskBarAction      Click3  PopUp Window

where the menu "Window" is as follows:

AddToMenu       Window          "&Restore"      Maximize
+                               "&Move"         Move
+                               "&Size"         Resize
+                               "Mi&nimize%mini.winXX-minimize.xpm%" \
                                                Iconify
+                               "Ma&ximize%mini.winXX-maximize.xpm%" \
                                                Maximize
+                               ""              Nop
+                               "&Close Alt-F4%mini.winXX-close.xpm%" \
                                                Close

I think I chose "Minimize" though I'm pretty sure I can segfault with
*any* fvwm builtin that requires a target window.

The complete rcfile is available at
http://www.best.com/~mikehan/windoze.fvwm2rc
It's a Win98 emulation rcfile I've been working on.

Finally, this is a RH4.1 box running kernel 2.0.34 with the original
libc5.3.12 library. X libs are R6.1 and the server is AcceleratedX
2.1.
-- 
[email-masked]
I will not conduct my own fire drills
 - The collected wisdom of Bart Simpson
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Len Smith <[email-masked]>
Date: Tue, 30 Mar 1999 10:09:51 -0500 (EST)

I've attached the trace of the core from when Fvwm2.2 crashed.

		Thanx,
			len

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 30 Mar 1999 19:54:54 +0200

>  file core
> core:           ELF 32-bit MSB core file SPARC Version 1, from 'fvwm2'
>...

Fixed in the development tree now. Thanks.

Bye

Dominik ^_^

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].