Subject: FVWM: FvwmTaskBar not refreshing?

From: John H Palmieri <[email-masked]>
Date: 18 Mar 1999 09:45:23 -0500

Hi,

I recently started using fvwm 2.2, and I've noticed a problem with
FvwmTaskBar: in my .fvwm2rc file, I have (among other things)

AddToFunc "InitFunction" "I" Exec emacs 
AddToFunc "InitFunction" "I" Exec xterm 
AddToFunc "InitFunction" "I" Exec xterm 
AddToFunc "InitFunction" "I" Exec netscape
AddToFunc "InitFunction" "I" Module FvwmTaskBar

The task bar starts up as it should, but it looks like this:

  Quit |  Xterm       |  Xterm       |

with no entries for Emacs or Netscape.  When I move the mouse over the
task bar, then it refreshes itself and shows all of the appropriate
buttons.  Any ideas why?

-- 
John H. Palmieri
e-mail: [email-masked]             205 Computing/Math Bldg.
URL:http://www.nd.edu/~jpalmier/      University of Notre Dame
(219) 631-8846                        Notre Dame, IN 46556
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: John H Palmieri <[email-masked]>
Date: 18 Mar 1999 09:54:03 -0500

> task bar, then it refreshes itself and shows all of the appropriate

Sorry, I forgot to say, this is on a Sparcstation running Solaris 2.5.

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 18 Mar 1999 16:32:08 +0100

> task bar, then it refreshes itself and shows all of the appropriate

Yes. In several places initiating a refresh is simply forgotten in
the code. I have fixed it on my disk at home already. The fixes
will make it into the development tree in a few days.

Bye

Dominik

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].