Subject: FVWM: How to make ClickToFocus working regardless of modifier key?

From: Samuel Chung <[email-masked]>
Date: Tue, 23 Mar 1999 15:45:59 -0800 (PST)

Hello all,

I am new to FVWM. I like to set it up with
ClickToFocus
working regardless of any modifier key. How should
I modify my .fvwm2rc to pass on ButtonPress Event
after
FVWM have been reacted from ClickToFocus?
Thank you in advance!

Samuel
_________________________________________________________
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com

--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 24 Mar 1999 12:17:15 +0100

On Tue, Mar 23, 1999 at 03:45:59PM -0800, [email-masked] wrote:
> I am new to FVWM. I like to set it up with ClickToFocus
> after FVWM have been reacted from ClickToFocus?

You're out of luck here. ClickToFucus does not work with
modifiers pressed.  If you absolutely need this you can
modify the source:

In file fvwm/events.c, function HandleButtonPress:

Replace

  /* click to focus stuff goes here */                                          
  if((Tmp_win)&&(Tmp_win->flags & ClickToFocus)&&(Tmp_win != Scr.Ungrabbed) &&  
     (!MaskUsedModifiers(Event.xbutton.state)))                                 
  {                                                                             

With

  /* click to focus stuff goes here */                                          
  if((Tmp_win)&&(Tmp_win->flags & ClickToFocus)&&(Tmp_win != Scr.Ungrabbed))                                 
  {                                                                             

(I didn't test this myself).

The following command solves your second problem:

  GlobalOpts ClickToFocusPassesClick

Bye

Dominik

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].