Subject: Re: FVWM: menu animation stopped working?

From: Dominik Vogt <[email-masked]>
Date: Fri, 12 Mar 1999 14:15:18 +0100

On Fri, Mar 12, 1999 at 06:01:01AM -0800, [email-masked] wrote:
> I've recently switched from fvwm 2.1.6 to fvwm 2.2.  My menus are no longer
> animated.  ie.  when a submenu appears near the edge of the screen the menu
> doesn't slide over the make more room.  It appears that animation doesn't work
> unless the second argument to popupoffset is >=100.  For example
> 
> menustyle * popupoffset 0 67, Animation      # no animation
> menustyle * popupoffset 0 100, Animation     # yes animation
> menustyle * popupoffset 50 99, Animation     # no animation

animation should occur whenever the menus overlap more than
the popupoffset suggests. E.g. with '0 67' the parent menu
should be animated away if the overlap if bigger than 33%
(wich doesn't occur normally), give or take a few pixels.

Doesn't it do that?

Bye

Dominik

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Trent Piepho <[email-masked]>
Date: Fri, 12 Mar 1999 17:26:06 -0800 (PST)

> (wich doesn't occur normally), give or take a few pixels.

Not for me.  If I have the first menu against the right edge of the screen the
second popup will overlap it almost completely.  But no animation, even if I
set it to '0 99', which should mean the overlap only has to be 1%.

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 13 Mar 1999 19:05:52 +0100

> (wich doesn't occur normally), give or take a few pixels.

OK, right. I've fixed it in 2.3.x. Could somebody apply this to
2.2.1 too, please? You have to change this line in menus.c
(DoMenusOverlap)

      prior_width *= mr->ms->feel.PopupOffsetPercent / 100;

to this:

      prior_width *= (float)(mr->ms->feel.PopupOffsetPercent) / 100.0;

Bye

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]