Subject: FVWM: please help: borders around children of parent windows

From: Neil Zanella <[email-masked]>
Date: Sun, 14 Feb 1999 11:58:09 -0330 (NST)

Hello,

I am having trouble with getting borders around windows which are spawned

by other windows. For example, if I open a netscape browser it has a window

but if I then click on preferences then the window that pops up has no 

border. The same is true of other programs such as xgopher, xboard,

and so on...

Can anyone tell me how I can fix this, perhaps by giving me the relevant 

snippet of their fvwm2rc file?

Thanks a lot,

Neil Zanella
[email-masked]
--
Visit the official FVWM web page at <URL: http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Bob Woodside <[email-masked]>
Date: Sun, 14 Feb 1999 14:27:02 -0500 (EST)

Neil Zanella <[email-masked]> wrote:
> 
> I am having trouble with getting borders around windows which are
> spawned by other windows. For example, if I open a netscape browser
> it has a window but if I then click on preferences then the window
> that pops up has no  border. The same is true of other programs such
> as xgopher, xboard...

	Try adding 

Style	"*"	DecorateTransient

to your .fvwm2rc.

- Bob

---

From: Neil Zanella <[email-masked]>
Date: Sun, 14 Feb 1999 16:10:16 -0330 (NST)

Thanks for pointing that out.

As a result of that, I have a bug to point out:

The fvwm man page does not describe the functionality of the option
DecorateTransient . Two lines would probably have been enough.

---

From: Bob Woodside <[email-masked]>
Date: Sun, 14 Feb 1999 18:12:44 -0500 (EST)

> DecorateTransient . Two lines would probably have been enough.

	I don't know when it disappeared from the man page. I just
checked the 2.0.45 page, which is the oldest 2.0.x page that I still
have lying around, and it was gone then.

	I'm really surprised that no one's pointed this out before
now. (Or maybe someone has, long ago, and it got overlooked.) I
guess the knowledge has just been floating around for years as part
of the Great Oral Tradition.

	It will be corrected in the 2.2 release.

	Dom:  The option is actually mentioned in the list of Style
options, but there's no description of what it might do. I'll hack
a description into the CVS tree tonight.

- Bob

---

From: Michael Han <[email-masked]>
Date: Sun, 14 Feb 1999 15:37:05 -0800

Previously...
>snippet of their fvwm2rc file?

The windows you refer to are generally called transients. Try the
DecorateTransient option. It's a Style, so you could try:

Style * DecorateTransient

Enjoy.
-- 
[email-masked]
Cursive writing does not mean what I think it does
 - The collected wisdom of Bart Simpson
--
Visit the official FVWM web page at <URL: http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Andreas Dischinger <[email-masked]>
Date: Mon, 15 Feb 1999 10:45:02 +0100 (MET)

Hi,

Some similar question:

Is it possible to decorate transients in a special way. Something like

Style "Transient" UseDecor xy

Andreas
-- 
   //|       |\\
  //||       ||\\         http://degnet.de/~awd/
 //=||       ||//         email: [email-masked]
//  ||ndreas |//ischinger PGP-Key by finger.

'I don't think I've had enough beer yet, to understand that' 
T. Pratchett