Subject: Re: FVWM: Bug in 2.1.7 and 2.1.10 ?

From: [email-masked]
Date: Wed, 3 Feb 1999 12:28:38 -0800 (PST)

Hello,

Wondering if anybody is looking into the following problem.
Did not see any resposes after that.

-sam

> Dominik Vogt sez...
> > 
> > On Mon, Feb 01, 1999 at 06:03:36PM -0800, [email-masked] wrote:
> > > Hi,
> > > 
> > > On the black and white NCDs, I am not able to see the arrow marks
> > > in the menus.
> > 
> > Do you mean the little triangle on the right side of a sub menu item?
> > 
> > > I have the following line, I have this since
> > > 2.0.46.
> > > 
> > > 	MenuStyle maroon grey60 grey40 9x15 fvwm
> > > 
> > > Initially I thought, since XPM was not built into fvwm, may be I am
> > > facing this problem. Now, I have rebuilt this 2.1.10 fvwm with
> > > XPM, still I have the same problem. I tried to change the colors, no luck.
> > > 
> > > Menus do not show arrow marks. Anybody know a work-around ?
> > 
> > Can you post the definition of a menu that has this problem?
> > I'd guess you are using the 'Menu' command for your sub menus.
> > This implies that your sub menus do not pop up when you enter
> > the item with the mouse pointer. If this is the case you will
> > have to use the 'Popup' command in your sub menu items.
> > 
> > Bye
> > 
> > Dominik
> 
> Dominik,
> 
> Yes, I am talking about those little triangles, pointing right. Menus DO
> popup when the mouse goes there, but only the triangles donot appear.
> Documentation says that monochrome terminals do not have the effect of
> the color, but looks like somebody has stepped on that part of the code.
> 
> I have been this using this config file since 2.0.46. Note that this problem
> only exists on black/white NCD, color terminal do not have this problem.
> I have Popup command whereever I need popup. I do have XPM support now,
> if that is a problem.
> 
> -sam
--
Visit the official FVWM web page at <URL: http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 3 Feb 1999 22:15:43 +0100

> Did not see any resposes after that.

That is because there were no responses, but yes, we are
looking into it. I think it's the same problem as with
the FvwmScroll scrollbars (the new hilighting calculation).
Probably Dan Espen will want to have a look at this (he
wrote the code).

Bye

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Wed, 03 Feb 1999 16:29:43 -0500

> Probably Dan Espen will want to have a look at this (he

Yes, I am looking too.  The menu code appears  to be unchanged, so the
new shadow  and highlight logic  must be  coming up  with a  color the
black and white terminal can't cope with.

I don't have a black and white terminal to play with.

Your menustyle line is:

          (fore) (back) (shade)

So the shadows and highlights are calculated off "grey60".

What does a grayscale terminal do with "maroon"?
How different does a color have to be from "grey60" before
you can see it?

I'll  put together a  test case to see what  colors the logic comes up
with for "grey60" when I can.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Wed, 03 Feb 1999 22:16:41 -0500

> with for "grey60" when I can.

On my machine, gray60 is RGB:9999/9999/9999
I get a shadow of        RGB:4ccc/4ccc/4ccc
and a hilite of          RGB:d709/d709/d709

I think these numbers are similar to what the old calculation
would produce.

When I use the exact command:

The reliefs around the arrows look OK to me.

I think I need more hints about how a greyscale terminal works.

---

From: Sam Krishnabhat <[email-masked]>
Date: Wed, 3 Feb 1999 22:03:03 -0800 (PST)

Dan Espen sez...
> > with for "grey60" when I can.

I thank your for your effort.

My /usr/openwin/lib/rgb.txt file has these entries:

	102 102 102             grey40
	153 153 153             grey60
 
If you have a fix and you cannot find a B/W terminal, I can test it.
You can email me the executable or give me the ftp address, I can download it.

For the time being I am using the following, even though I hate it.

	MenuStyle maroon grey60 grey40 9x15bold mwm anim

On Black/White NCD, I do not get the nice shade on the selected item that
I see on Color monitor.

-sam

---

From: Tim Phipps <[email-masked]>
Date: Thu, 04 Feb 1999 09:13:05 +0000

> You can email me the executable or give me the ftp address, I can download it.

Sam: is your terminal grayscale or B/W? I suspect it's just black and
white and the grays that the color logic is picking get rounded off to
black. Could you run "xwininfo -root" and let us know what is reports
for Depth and Visual Class?

Cheers,
Tim.

---

From: Sam Krishnabhat <[email-masked]>
Date: Thu, 4 Feb 1999 08:46:13 -0800 (PST)

> for Depth and Visual Class?

I have been using this setup for about 4 years now. Recently I migrated
from 2.0.46 to 2.1.7 to 2.1.10. .fvwm2rc is almost the same, no errors.

/users/samk>xwininfo -root
 
xwininfo: Window id: 0x22 (the root window) (has no name)
 
  Absolute upper-left X:  0
  Absolute upper-left Y:  0
  Relative upper-left X:  0
  Relative upper-left Y:  0
  Width: 1280
  Height: 1024
  Depth: 1
  Visual Class: StaticGray
  Border width: 0
  Class: InputOutput
  Colormap: 0x21 (installed)
  Bit Gravity State: ForgetGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: WhenMapped
  Save Under State: no
  Map State: IsViewable
  Override Redirect State: no
  Corners:  +0+0  -0+0  -0-0  +0-0
  -geometry 1280x1024+0+0
 
/users/samk>

---

From: Dan Espen <[email-masked]>
Date: Thu, 04 Feb 1999 12:01:53 -0500

> xwininfo: Window id: 0x22 (the root window) (has no name)

The logic in builtins.c that checks for a depth of <2
when creating the shadow and relief GCs is gone.

Any volunteers?

---

From: Sam Krishnabhat <[email-masked]>
Date: Thu, 4 Feb 1999 10:53:21 -0800 (PST)

> when creating the shadow and relief GCs is gone.

I checked in the 2.0.46 code. Initially I thought "depth" is being used properly,
but I did come to know that "SetMenuStyle" function is been changed a lot and has
the "depth > 2" logic. I have no idea what depth is anyway ?

Is there any way I can change the settings in my B/W NCD to have
a depth of 3 (which is less than 2). Does it affect the operation badly...

-sam

---

From: Dan Espen <[email-masked]>
Date: Thu, 04 Feb 1999 14:03:54 -0500

Sam Krishnabhat <[email-masked]> writes:
> > > > > You can email me the executable or give me the ftp address, I can dow
> nloa
> > > d it.
> > > > 

Depth is  the number of bits used  to represent color on your display.
In your case, your  "Depth" is "1".   Ie. a  pixel is either  black or
white.  I doubt you can change that.

Forgive my earlier confusion, when I saw  that you had "grey"s in your
.fvwm2rc, I mistakenly  came to  the  conclusion that you  had a  gray
scale terminal.

Let us know if the patch I sent earlier helps.  I didn't duplicate the
original logic, but I  think you should see the  menu arrows after the
change.