Subject: FVWM: startbutton

From: Andre De Boer <[email-masked]>
Date: Fri, 19 Feb 1999 18:39:56 +0000

Hello,

I use fvwm 2.1.11.

This is mine configuration of the taskbar:

*FvwmTaskBarBack #c3c3c3
*FvwmTaskBarFore black
*FvwmTaskBarTipsBack bisque
*FvwmTaskBarTipsFore black
*FvwmTaskBarGeometry +0-1
*FvwmTaskBarShowTransients
*FvwmTaskBarHighLightFocus
*FvwmTaskBarFont -adobe-helvetica-medium-r-*-*-14-*-*-*-*-*-*-*
*FvwmTaskBarSelFont -adobe-helvetica-bold-r-*-*-14-*-*-*-*-*-*-*
*FvwmTaskBarStatusFont fixed
*FvwmTaskBarAction Click1 Iconify -1, Raise
*FvwmTaskBarAction Click2 Iconify +1, Lower
*FvwmTaskBarAction Click3 Iconify -1, Raise

*FvwmTaskBarUseSkipList
*FvwmTaskBarUseIconNames
*FvwmTaskBarAutoStick
*FvwmTaskBarShowTips

*FvwmTaskBarBellVolume 20
*FvwmTaskBarMailBox /home/redhat/Mail/inbox/Inbox
*FvwmTaskBarMailCommand Exec xterm -e mail
*FvwmTaskBarClockFormat %I:%M %p
*FvwmTaskBarStartName Start
*FvwmTaskBarStartMenu Rootmenu
*FvwmTaskBarStartIcon mini-penguin.xpm

And this is the menu i want to popup:

AddToMenu RootMenu  "%mini-penguin.xpm%"        Title
+ "XTerm        %mini-term.xpm%"        Exec    xterm -ls -sb -sl 10000
-fn 9x15 -bg Ligh
+ "color-xterm  %mini-term.xpm%"        Exec    color-xterm -fn 9x15
+ "Rxvt         %mini-term.xpm%"        Exec    rxvt -fn 9x15
+ ""                                    Nop
+ "xmcd         %mini-cdlabel.xpm%"     Exec    xmcd
+ "Netscape     %mini-nscape.xpm%"      Exec
/usr/local/netscape/netscape -font 9x15
+ "Top          %mini-run.xpm%"         Exec    rxvt -font 7x14 -T Top
-n Top -e top
+ "Manual pages %mini-book1.xpm%"       Exec    xman
+ ""                                    Nop
+ "Emacs        %jemacs.xpm%"           Exec    emacs &
+ "xemacs       %jemacs.xpm%"           Exec    exec xemacs
+ "WP"                                  Exec
/home/redhat/wordperfect/wpbin/./xwp &
+ "StarOffice"                          Exec    ~/Office50/bin/./soffice
-geometry 100x10
+ "Graphics     %mini-paint.xpm%"       Popup   Graphics
+ "Calculator   %mini-calc.xpm%"        Exec    xcalc &
+ "Utilities    %jf.xpm%"               Popup   Utilities
+ "Games"                               Popup   Games
+ "Modules      %mini-modules.xpm%"     Popup   Module-Popup
+ "Lock Screen  %mini-lock.xpm%"        Exec    xlock
+ "Refresh      %mini-ray.xpm%"         Refresh
+ ""                                    Nop
+ "Exit Fvwm    %mini-stop.xpm%"        Popup   Quit-Verify

Sorry for the garbage i sent with, there is something wrong with
mozilla  i think, but i don't what yet.

Thanks for the answers,
Andre de Boer
ŠÈ­¶¨}øœ‰©EUc0yºZæQá¶Úýûðšf†è^vïÓ¢éì¹»®&Þ~º&¶¥ŠËlzwnžË›±ÊâmçïÂh§¶›¡Ü¨}©ž²Æ zÚ&j:+v‰¨†—.…çnNŠÞ¦Ší¦º•é¬±éÝ™¨¥¶‡ïÂj0êá¥Ë¡yÛ

---

From: Dan Espen <[email-masked]>
Date: Fri, 19 Feb 1999 14:29:21 -0500

> This is mine configuration of the taskbar:

Thanks.  You're  right, the start button does  stay  depressed.  (Even
with   my  configuration.)  I'm  afraid   there  are multiple problems
outstanding with FvwmTaskBar.

I'll enter a bug report into our bug database.

--
Dan Espen
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854                     Phone: (732) 699-5570
--
Visit the official FVWM web page at <URL: http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Sam Krishnabhat <[email-masked]>
Date: Fri, 19 Feb 1999 13:18:23 -0800 (PST)

> I'll enter a bug report into our bug database.

While we are on the subject, why is that my task bar does not work
with this version 2.1.10, it stays always UP. If I point my mouse
at a window, shouldn't it go down. Can you give me your TaskBar
specific config please.
 
-sam

---

From: Dan Espen <[email-masked]>
Date: Fri, 19 Feb 1999 16:37:01 -0500

> at a window, shouldn't it go down. Can you give me your TaskBar

I get similar symptoms on my home machine but  not on my work machine.
Same config on both.  The one  with the symptoms  is Solaris 2.5.1, the
other 2.6.  (I doubt that has anything to do with it.)

As I said, there are multiple problems outstanding.

I predict, sooner or later, it will be fixed.
Patches are always looked at.