Subject: FVWM: version info

From: Os <[email-masked]>
Date: Tue, 23 Feb 1999 09:38:07 +0000

How does one determine the version number of fvwm that is currently
running?

cheers,
-- 
Os
[email-masked]
[email-masked]
http://www.collective.co.uk/
--
Visit the official FVWM web page at <URL: http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Neil Bird <[email-masked]>
Date: Tue, 23 Feb 1999 10:59:43 +0000

> How does one determine the version number of fvwm that is currently

  Not /quite/ what you want, I suspect, but you could always try:

    fvwm2 -version

-- 
========================- http://www.rrds.co.uk/ -======================
 Neil Bird                   |   This is who we are     The time is near
                             |        There are 312 days remaining
 mailto:[email-masked] |                           [ T-105 days! ]
--
Visit the official FVWM web page at <URL: http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Nathan Froyd <[email-masked]>
Date: Tue, 23 Feb 1999 07:25:06 -0500 (EST)

> How does one determine the version number of fvwm that is currently

If you're running FvwmM4 (and FvwmCpp, I suspect), you can identify
the version at runtime with FVWM_VERSION.
-- 
Nathan -- [email-masked] -- [email-masked] -- CS/MA 02
Evolution is a million line computer program falling into place by accident.
God went through hell so we don't have to.        ICQ:18861764 AOL:myrlyn007
                    http://www.rose-hulman.edu/~froydnj/
--
Visit the official FVWM web page at <URL: http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 23 Feb 1999 13:40:28 +0100

> How does one determine the version number of fvwm that is currently

If you are on Linux you can look directly into the executable:
Find out the process id:

  # ps | grep fvwm2

And then cd search for the string 'fvwm':

  # strings /proc/<process id>/exe | grep 'fvwm'

You should see the version number in the last line of
output.

Bye

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]