Subject: Re: FVWM: While running configure for 2.1.7, not able to include xpm

From: Sam Krishnabhat <[email-masked]>
Date: Mon, 1 Feb 1999 15:47:41 -0800 (PST)

Hi,

I tried with the following, but still with no luck.

./configure --with-xpm-library=/usr/openwin/lib 
--with-xpm-includes=/usr/openwin/include/X11

I get the following error message.

checking for XpmReadFileToXpmImage in -lXpm... no

I need xpm.h and libXpm.a, that's it right ?

-sam

> From [email-masked] Mon Feb  1 14:40:09 1999
> To: [email-masked]
> cc: Sam Krishnabhat <[email-masked]>
> Subject: Re: FVWM: While running configure for 2.1.7, not able to include xpm
> 
> 
> I had a similar problem when I first tried:
> ./configure --with-cxx=gcc
> 
> I had to tell it where it was:
> ./configure --with-cxx=gcc --with-xpm-library=/usr/X11R6/lib
> --with-xpm-includes=/usr/X11R6/include
> 
> Don't forget to clear the config.cache when you try to configure again.
> 
> --------------------------------------
> 
>  Robert W. Kim
>  e-mail: [email-masked]
> 
> --------------------------------------
> 
> 
> On Mon, 1 Feb 1999, Sam Krishnabhat wrote:
> 
> > Hi,
> > 
> > While I run the configure utility I get the following message:
> > 
> > "no : Xpm library or header not found!"
> > 
> > Following is part of the run of the configure with "set -x".
> > I do have xpm.h in the /usr/openwin/include/X11/ and the libXpm.*
> > files in /usr/openwin/lib/ directories.
> > 
> > Can you please help me. Why is it saying it is not able
> > to find XpmReadFileToXpmImage in the lib file. I went to
> > the lib file and I could see the XpmReadFileToXpmImage in there.
> > 
> > /usr/openwin/lib>l libXpm.*
> > -rwxr-xr-x   1 root     oldother   61440 Feb  1 12:50 libXpm.so.4.7*
> > -rw-r--r--   1 root     oldother   12110 Feb  1 12:50 libXpm.sa
> > -rw-r--r--   1 root     oldother   90338 Feb  1 12:50 libXpm.a
> > lrwxrwxrwx   1 root     oldother      13 Feb  1 13:00 libXpm.so -> 
libXpm.so.4.7*
> > /usr/openwin/lib>
> > /usr/openwin/include>l xpm.h
> > -rw-r--r--   1 samk     eng        15133 Oct  8  1995 xpm.h
> > /usr/openwin/include>
> > 
> > -sam
> > _________________________________________________________________
> > 
> > 
> > smr_lib=Xpm
> > smr_header=X11/xpm.h
> > smr_lib=Xpm
> > + test  = set 
> > with_xpm=maybe
> > xpm_LIBS=-lXpm
> > + test maybe != no 
> > + echo checking for XpmReadFileToXpmImage in -lXpm... \c 
> > checking for XpmReadFileToXpmImage in -lXpm... + echo configure:4382: 
checking for XpmReadFileToXpmImage in -lXpm 
> > + echo Xpm_XpmReadFileToXpmImage 
> > + sed y%./+-%__p_% 
> > ac_lib_var=Xpm_XpmReadFileToXpmImage
> > + echo ${ac_cv_lib_Xpm_XpmReadFileToXpmImage+set} 
> > + eval test "${ac_cv_lib_Xpm_XpmReadFileToXpmImage+set}" = set 
> > + test set = set 
> > + echo (cached) \c 
> > (cached) + echo $ac_cv_lib_Xpm_XpmReadFileToXpmImage 
> > + eval test "$ac_cv_lib_Xpm_XpmReadFileToXpmImage" = yes 
> > + test no = yes 
> > + echo no 
> > no
> > smr_havelib=no
> > + test no = yes -a X11/xpm.h !=  
> > + test no = yes 
> > xpm_LIBS=
> > xpm_CFLAGS=
> > with_xpm=no
> > xpm_problem=: Xpm library or header not found!
> > 
> > --
> > Visit the official FVWM web page at <URL: http://fvwm.math.uh.edu/>.
> > To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
> > message to [email-masked].
> > To report problems, send mail to [email-masked].
> > 
> 
> 
--
Visit the official FVWM web page at <URL: http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Paul D. Smith)
Date: 01 Feb 1999 18:56:23 -0500

%% Sam Krishnabhat <[email-masked]> writes:

  sk> I tried with the following, but still with no luck.

  sk> ./configure --with-xpm-library=/usr/openwin/lib 
  sk> --with-xpm-includes=/usr/openwin/include/X11
                                              ^^^^

This is incorrect; you just want /usr/openwin/include.  All X headers
are always accessed as "#include <X11/xpm.h>", so you don't want the X11
on the pathname.

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL: http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].