Subject: FVWM: FvwmTaskbar comes up, but autohide does not work

From: Sam Krishnabhat <[email-masked]>
Date: Thu, 4 Feb 1999 14:41:32 -0800 (PST)

Hi,

I did read somewhere that Taskbar does not work properly with AutoHide turned 
on. But, for me autohide does not work at all. Am I doing anything wrong here ?
I have the latest code downloaded from the CVS tree.

(Let me also know if you have a fix for the Start button being
depressed problem)

-sam

*FvwmTaskBarBack #c3c3c3
*FvwmTaskBarFore black
*FvwmTaskBarTipsBack bisque
*FvwmTaskBarTipsFore black
*FvwmTaskBarGeometry +0-1
*FvwmTaskBarFont -adobe-helvetica-medium-r-*-*-14-*-*-*-*-*-*-*
*FvwmTaskBarSelFont -adobe-helvetica-bold-r-*-*-14-*-*-*-*-*-*-*
*FvwmTaskBarStatusFont fixed
 
#*FvwmTaskBarAction Click1 Iconify -1, Raise
*FvwmTaskBarAction Click1 Iconify -1,Focus
*FvwmTaskBarAction Click2 Iconify +1, Lower
*FvwmTaskBarAction Click3 Iconify -1, Raise
 
*FvwmTaskBarUseSkipList
*FvwmTaskBarUseIconNames
*FvwmTaskBarAutoStick
*FvwmTaskBarAutoHide
*FvwmTaskBarShowTips
# I Don't know what this is : *FvwmTaskBarShowTransients
 
*FvwmTaskBarButtonWidth 180
#*FvwmTaskBarButtonWidth 40
*FvwmTaskBarBellVolume 20
*FvwmTaskBarMailBox /var/spool/mail/
*FvwmTaskBarMailCommand Exec xterm -e mail
*FvwmTaskBarClockFormat %I:%M %p
 
*FvwmTaskBarStartName X
#*FvwmTaskBarStartMenu StartMenu
*FvwmTaskBarStartMenu RootMenu
*FvwmTaskBarStartIcon mini-exp.xpm
--
Visit the official FVWM web page at <URL: http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tim Phipps <[email-masked]>
Date: Mon, 15 Feb 1999 13:08:56 +0000

> I have the latest code downloaded from the CVS tree.

It works for me (using your config lines).  What part of Authohide
doesn't work for you?

The problems with AutoHide were that it was impossible to put the
pointer on the FvwmTaskBar window with a setup that had more than one
virtual page. The thin transparent windows around the edge of the screen
(the pan-frames) got in the way.  The fix was to make autohide leave two
pixels visible and to use the "EdgeThickness 1" command at the start of
your .fvwm2rc. Some X-servers have a bug that prevents page scrolling
with a pan-frame of one pixel.

Cheers,
Tim.

---

From: Sam Krishnabhat <[email-masked]>
Date: Tue, 16 Feb 1999 11:45:05 -0800 (PST)

> with a pan-frame of one pixel.

With the command "EdgeThickness 1", I am still not able to
autohide the TaskBar bar. When point at a window, and start
working the taskbar should automatcally vanish right ?
I have enclosed the FvwmTaskBar specific config. Can you help ?
(FVWM Version: 2.1.10)

-sam
_________________________________________________________________

EdgeThickness 1
Style "FvwmTaskBar" NoTitle, BorderWidth 4, HandleWidth 4, Sticky, StaysOnTop

*FvwmTaskBarBack #c3c3c3
*FvwmTaskBarFore black

*FvwmTaskBarUseSkipList
*FvwmTaskBarUseIconNames
*FvwmTaskBarAutoStick
*FvwmTaskBarAutoHide
*FvwmTaskBarShowTips

*FvwmTaskBarStartName X

---

From: Jonathan Ryshpan <[email-masked]>
Date: Tue, 23 Feb 1999 18:04:37 -0800

> I have enclosed the FvwmTaskBar specific config. Can you help ?

I have exactly the same problem as SK, running Fvwm Version 2.2 .

It may be of some interest that Fvwm Version 2.0.46 FvwmTaskBarAutoHide
**does** work.  At least in the top two virtual windows of a 2x2 window
desktop it does.  In the bottom two windows, the task bar only slides
halfway down, ie. only the bottom half disappears.

I'm running RedHat AfterStep, and the *rc files are **rather** long and
complex; but I'll be happy to post them or email them if there's any
interest.

Here's the version info:

    1002 jon> /usr/X11R6/bin/fvwm2 -version
    [FVWM][main]:  Fvwm Version 2.0.46 compiled on Oct  2 1998 at 22:17:14

Jonathan Ryshpan <[email-masked]>

Yesterday it worked
Today it is not working
Windows is like that.
-- Mike Slama
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tim Phipps <[email-masked]>
Date: Thu, 25 Feb 1999 09:13:39 +0000

> working the taskbar should automatcally vanish right ?

Yes, it should.  I can't reproduce this, your config works fine for me. 
Does it start hidden?

Cheers,
Tim.
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Brad Giaccio <[email-masked]>
Date: Thu, 25 Feb 1999 08:32:06 -0500

> Yes, it should.  I can't reproduce this, your config works fine for me. 
I can also make it hide using this config, but I can't make it come back up when I move my mouse over it.

Brad
 
-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL: http://www.fvwm.org/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].