Subject: FVWM: How to move window to the next page?

From: Meik Hellmund <[email-masked]>
Date: Tue, 16 Feb 1999 19:14:30 +0100 (MET)

Hello,

I'd like to have a function (connected to a button) which moves
a window to the next page. I tried something like

     AddToFunc move-to-next-page
     +    "I"   Scroll   100000 0
     +    "I"   WindowId $w MoveToPage

in fvwm-2.1.10, but it doesn't work. The viewpoint switches, but the window
stays on the old page.

Does anyone know the right way to get such a function?

Thanks,
Meik

[email-masked]

--
Visit the official FVWM web page at <URL: http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Brad Giaccio <[email-masked]>
Date: Tue, 16 Feb 1999 14:12:50 -0500

> in fvwm-2.1.10, but it doesn't work. The viewpoint switches, but the window

You can do 
AddToFunc move-to-right-page
+    "I"   Move w+100 w
AddToFunc move-to-left-page
+    "I"   Move w-100 w

the first arg is x and the second is y the integer by default is a
percentage, if you want the pointer to move with the window add Warp as
the last arg of Move.  Try doing man fvwm2, and look for Move it gives a
better explination and examples.

-- 
--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous
--
Visit the official FVWM web page at <URL: http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 16 Feb 1999 23:29:59 +0100

> Does anyone know the right way to get such a function?

If you want windows on a specific page/desk you can use the
MoveToPage and MoveToDesk commands.

Bye

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]