Subject: FVWM: Making fvwm 2.1.7

From: Sam Krishnabhat <[email-masked]>
Date: Mon, 18 Jan 1999 18:10:22 -0800 (PST)

Hi,

Where can I get directions as to how to make fvwm executables.
I have downloaded the tar.gz package. I have run configure shell
script. Initially it gave me an error saying "ar" not found. Then
replaced "ar" with "ld -o", since it is a linker used in our environment.

I get this error. What should I do ? I have enclosed here the error I get.
Can you help. Pointing me at the related docs will also be helpful.

-sam
_________________________________________________________________

/usr/samk/fvwm-2.1.7/libs>make
rm -f libfvwm.a
ld -o libfvwm.a ClientMsg.o GetFont.o Grab.o ModParse.o Module.o Parse.o Picture.o Strings.o System.o envvar.o safemalloc.o wild.o XResource.o debug.o ColorUtils.o 
Undefined                       first referenced
 symbol                             in file
read                                Module.o  (symbol belongs to implicit dependency /usr/lib/libc.so.1)
XrmGetStringDatabase                XResource.o
XUngrabServer                       Grab.o
XFreePixmap                         Picture.o
toupper                             ModParse.o  (symbol belongs to implicit dependency /usr/lib/libc.so.1)
strdup                              Parse.o  (symbol belongs to implicit dependency /usr/lib/libc.so.1)
_iob                                GetFont.o  (symbol belongs to implicit dependency /usr/lib/libc.so.1)
XQueryColor                         ColorUtils.o
__ctype                             ModParse.o  (symbol belongs to implicit dependency /usr/lib/libc

--
Visit the official FVWM web page at <URL: http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Paul D. Smith)
Date: 18 Jan 1999 21:47:59 -0500

%% Sam Krishnabhat <[email-masked]> writes:

  sk> Where can I get directions as to how to make fvwm executables.  I
  sk> have downloaded the tar.gz package. I have run configure shell
  sk> script. Initially it gave me an error saying "ar" not found. Then
  sk> replaced "ar" with "ld -o", since it is a linker used in our
  sk> environment.

No.
ar is the archiver; it's used to build libraries.
ld is the linker; it's used to build executables.
You can't replace one with the other.

You have to find the ar program on your system.  You cannot build fvwm
without ar.

  sk> I get this error. What should I do ? I have enclosed here the
  sk> error I get.  Can you help. Pointing me at the related docs will
  sk> also be helpful.

Please always remember to include information about what operating
system you are using.  Without this info we cannot tell you where to
look.

Normally ar is found by default in /bin or similar.  Some "modern"
operating system, such as Solaris, have decided in their infinite wisdom
to move these tools.  If you have Solaris, for example, you might try
adding /usr/ccs/bin to your PATH before running configure.

-- 
-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
   These are my opinions---Nortel Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL: http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Sam Krishnabhat <[email-masked]>
Date: Mon, 18 Jan 1999 19:05:57 -0800 (PST)

Paul D. Smith sez...
> system you are using.  Without this info we cannot tell you where to

/usr/samk/fvwm-2.1.7>uname -a
SunOS samk-ultra 5.5.1 Generic_103640-14 sun4u sparc SUNW,Ultra-1
/usr/samk/fvwm-2.1.7>
 
> adding /usr/ccs/bin to your PATH before running configure.
  ^^^^^^^^^^^^^^^^^^^ Did all the trick.
Thanks you very much for your help.

-sam