Subject: FVWM: Mouse binding syntax problem

From: Neil Bird <[email-masked]>
Date: Fri, 08 Jan 1999 16:02:06 +0000

Here's a snippet from my .fvwm2rc :

#   for the root window:
Mouse 1 R       A       Menu Window-Ops Nop
Mouse 2 R       A       WindowList
Mouse 3 R       A       Menu RootMenu Nop

#   for the title bar buttons:
Mouse 0 1       A       Menu Window-Ops2 Close
Mouse 0 3       A       Close
Mouse 0 2       A       Maximize-Func
Mouse 0 4       A       Iconify

#   for other parts of the window/borders/icons:
Mouse 1 T       A       Move-or-Raise
Mouse 1 SF      A       Resize-or-Raise
Mouse 1 I       A       Move-or-Iconify
Mouse 1 WITSF   1       Move-or-Raise		# This bit
Mouse 2 TSIF    A       RaiseLower
Mouse 2 W       1       RaiseLower
Mouse 3 I       A       Menu Window-Ops Nop
Mouse 3 I       1       Menu Window-Ops Nop
Mouse 3 FST     A       Menu Window-Ops2 Nop
Mouse 3 WITSF   1       Menu Window-Ops2 Nop

  Can anyone tell me why the tagged line *isn't* allowing me to pick up
and move a window (e.g., xterm) by holding Sun's diamond 'meta' (which is
modifier '1' OK elsewhere - certainly for Keys stuff) and
left-click-dragging doesn't do anything (except change the pointer to an
up-left arrow from xterm's caret)?

  The Meta-Menu doesn't work, either.

  What've I done?

  I have a feeling this worked under 2.1.5 (I'm now running 2.1.7 - I
think our firewall's stopping CVS wokring), but I won't swear to it.

-- 
========================- http://www.rrds.co.uk/ -======================
 Neil Bird                   |   This is who we are     The time is near
                             |        There are 357 days remaining
 mailto:[email-masked] |                           [ T-150 days! ]
--
Visit the official FVWM web page at <URL: http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Brad Giaccio <[email-masked]>
Date: Fri, 8 Jan 1999 11:14:06 -0500

> Mouse 3 WITSF   1       Menu Window-Ops2 Nop

Try
 Mouse 1 WITSF   M Move-or-Raise
that works on my sun type 5 keyboard
--
Visit the official FVWM web page at <URL: http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 8 Jan 1999 17:15:53 +0100

On Fri, Jan 08, 1999 at 04:02:06PM +0000, [email-masked] wrote:
>... 

What is your focus policy?

Dominik

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Sat, 9 Jan 1999 09:00:10 +0100

> think our firewall's stopping CVS wokring), but I won't swear to it.

I have a few questions to narrow down where the problem
comes from. Please answer them evem if the 'M' as a modifier
solves your problem.

1) By saying 'the tagged line *isn't* allowing me to ...' you imply
   that the other lines with '1' do all work. Correct?

2) Does the binding fail on all parts of the window? The other
   line (see above) seems to work on the client window (correct?)
   so I'd guess the binding fails on 'ITSF' only. So, on which of
   the five parts does it work?

3) Could you verify if it was already broken with 2.1.5 or not?
   Hope you didn't throw away the source.

4) What does xmodmap say about your bindings? Please post the
   output of 'xmodmap -pm', 'xmodmap -pk' and 'xmodmap -pke'
   (only the lines with the meta keys for '-pk' and '-pke'
   please).

5) Do you use SloppyFocus? This may affect how bindings work
   (no it's not documented).

6) The pointer you get when clicking on the window, is it the
   same as when you move the pointer over the title bar of a
   window without clicking?

Bye

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

---

From: Neil Bird <[email-masked]>
Date: Mon, 11 Jan 1999 10:31:03 +0000

>    that the other lines with '1' do all work. Correct?

  [you asked before: I'm using Sloppy/Follows focus]

  AFAICT, all but the those two work; e.g., my '1' key bindings work,
picking alternate menus off icons works (Meta picks a dif. one to normal).
However, the Meta-drag and Meta-menu just change the xterm cursor to a
'standard' arrow, and nothing else. The other bindings work as expected
with Meta held down, as set with the 'A' any/all definitions.

>    the five parts does it work?

  Nope, that's another one that fails. Works on the title bar, but that's
because of the
  Mouse 2 TSIF    A       RaiseLower
  ... before it.

>    Hope you didn't throw away the source.

  Still got the exe. When I've finished typing this out, I'll 'draft' it &
take to time to restart with 2.1.5.

  [Yes, works a treat under 2.1.5.]

  OK:

> xmodmap -pm
xmodmap:  up to 3 keys per modifier, (keycodes in parentheses):

shift       Shift_L (0x6a),  Shift_R (0x75)
lock        Caps_Lock (0x16)
control     Control_L (0x53),  Control_R (0x7e)
mod1        Meta_L (0x7f),  Meta_R (0x81)
mod2        Mode_switch (0x14)
mod3        Num_Lock (0x69)
mod4        Alt_L (0x1a)
mod5        F13 (0x20),  F18 (0x50),  F20 (0x68)

  Looks like mod1 is Meta OK.

> xmodmap -pk
    127         0xffe7 (Meta_L) 
    129         0xffe8 (Meta_R) 

> xmodmap -pke

keycode 127 = Meta_L
keycode 129 = Meta_R

  I don't think I've ever fiddled with the Meta definitions in my set-up.

>    (no it's not documented).

  Yup. Sloppy/Follows. The focus is set to the window the pointer's in
when the things fail.

>    same as when you move the pointer over the title bar of a

  Yup, that's the one.

  Right, I'll try 2.1.5 now ...

-- 
========================- http://www.rrds.co.uk/ -======================
 Neil Bird                   |   This is who we are     The time is near
                             |        There are 355 days remaining
 mailto:[email-masked] |                           [ T-148 days! ]
--
Visit the official FVWM web page at <URL: http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 12 Jan 1999 21:44:34 +0100

On Fri, Jan 08, 1999 at 04:02:06PM +0000, Neil Bird wrote:
> and move a window (e.g., xterm) ...

Ark, I'm so dumb. That's this idiotic bug that breaks mouse bindings on
the client portion of a window. Sorry for molesting you with all these
questions. The reply with the 'M' versus '1' fooled me. It is fixed in
the CVS tree.

Bye

Dominik