Subject: FVWM: restart with no decor

From: Frederic Barrat <[email-masked]>
Date: Thu, 07 Jan 1999 13:36:12 -0800

Hi,

I'm having a problem whenever I restart fvwm2. I get some default
decoration on the windows instead of what is in my .fvwm2rc file. Yet,
everything works fine when I start fvwm2 the first time.

I get the following error:
[FVWM][executeModule]: <<ERROR>> No such module
/home/fxb/fvwm2/libexec/fvwm/2.1.4/ BorderStyle
(the list goes on and on with all the commands related to style).

I don't quite understand why "BorderSytle" is interpreted as a module.

Does anyone have the same problem?

I'm using v2.1.4, but the same thing was happening with 2.0.46.
Attached is my .fvwm2rc file

Thanks,
-- 
  Fred

#############################################################
# PATH Setup
PixmapPath /home/fxb/fvwm2/pixmaps/
ModulePath /home/fxb/fvwm2/libexec/fvwm/2.1.4/
IconPath /home/fxb/fvwm2/pixmaps/

#############################################################
# COLORS and FONTS

HilightColor	 black #c4c5ab
Style "*" MWMBorder, SloppyFocus, IconBox +0+950+620+1006, Color white/#c4c5ab, BorderWidth 4, HandleWidth 4, SmartPlacement, DecorateTransient

BorderStyle  -- HiddenHandles NoInset

TitleStyle              Centered -- flat
AddTitleStyle ActiveUp (TiledPixmap cheese.xpm) ActiveDown (TiledPixmap cheese.xpm) Inactive (TiledPixmap cheese2.xpm)

ButtonStyle All         TiledPixmap cheese.xpm -- flat
ButtonStyle All         Inactive TiledPixmap cheese2.xpm -- flat
AddButtonStyle 1        InActive Pixmap close.xpm -- flat
AddButtonStyle 1        ActiveUp Pixmap close.xpm -- flat
AddButtonStyle 1        ActiveDown Pixmap close2.xpm -- flat
AddButtonStyle 4        InActive Pixmap iconify.xpm -- flat
AddButtonStyle 4        ActiveUp Pixmap iconify.xpm -- flat
AddButtonStyle 4        ActiveDown Pixmap iconify2.xpm -- flat
AddButtonStyle 2        InActive Pixmap shade.xpm -- flat
AddButtonStyle 2        ActiveUp Pixmap shade.xpm -- flat
AddButtonStyle 2        ActiveDown Pixmap shade2.xpm -- flat

MenuStyle black #c4c5ab #8b8c75 -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-* mwm anim

WindowFont -adobe-helvetica-bold-r-*-*-12-*-*-*-*-*-*-*
IconFont -adobe-helvetica-medium-r-*-*-10-*-*-*-*-*-*-*

#############################################################
# MISC Setup

OpaqueMoveSize 100
EdgeScroll 100 100
EdgeResistance 1000 20
Module FvwmAuto 650

#############################################################
# STYLE Flag Setup
Style "FvwmButtons"	Handles, Sticky, NoTitle, BorderWidth 0
Style "emacs"		Icon ColorGNU.xpm
Style "xterm"		Icon SunMicrosystemsMonitor.xpm
Style "rxvt"		Icon SunMicrosystemsMonitor.xpm

#############################################################
# MENU Setup

AddToMenu DisplayControls "Display Characteristics" Title
+	"Disable all outside access to the Display" exec xhost -
+	"Enable any outside access to the Display" exec xhost +

AddToMenu System "Fvwm Controls" Title
+	"Screen Lock"		exec xlock -mode blank -remote -allowaccess &
+	""			Nop
+	"Reload X defaults"	exec xrdb -load $HOME/.Xdefaults
+	"Display Controls"	Popup DisplayControls
+	"List of Windows"	WindowList
+	"FvwmAnimate"		Popup MenuFvwmAnimate
+	""			Nop
+	"Restart"		Restart fvwm2
+	""			Nop
+	"Exit"			Popup Confirm

AddToMenu Window-Ops "Window Options" Title
+	"Move"		Move
+	"Resize"	Resize
+	"Raise"		Raise
+	"Lower"		Lower
+	"(De)Iconify"	Iconify
+	"(Un)Stick"	Stick
+	"(Un)Maximize"	Maximize
+	"(Un)Maximize Vertical"	Maximize 0 100
+	""		Nop
+	"Delete"	Delete
+	"Destroy"	Destroy

AddToMenu Quick-Menu    "Applications" Title
+	"Rxvt"		exec rxvt &
+	"Choruslab1"	exec rxvt -e rlogin choruslab1 &
+	"XEmacs"	exec xemacs-light &
+	"Netscape"	exec netscape &
+	"Calculator"	exec dtcalc &
+	"XV"		exec xv &
+	"GhostView"	exec ghostview &

AddToMenu Confirm "Really quit FVWM ?" Title
+	"Yes"		Quit
+	"No"

#############################################################
# COMPLEX FUNCTIONS

AddToFunc Move-or-Raise		"I" Raise
+				"M" Move

AddToFunc Move-or-Iconify       "M" Move
+                               "C" Iconify

AddToFunc Resize-or-Raise       "I" Raise
+                               "M" Resize

AddToFunc Maximize-or-Resize	"I" Raise
+				"C" Maximize
+				"M" Resize

AddToFunc Menu-or-Exit		"M" Menu Window-Ops
+				"D" Close

#############################################################
# MOUSE Setup

Mouse 1	R   	A       Menu Quick-Menu Nop
Mouse 3	R    	A      	Menu System Nop

Mouse 1	1	A	Menu-or-Exit
Mouse 1	2	A	Maximize-or-Resize
Mouse 1	4    	A     	Iconify

Mouse 1	I       A       Move-or-Iconify
Mouse 3	I	A	Menu Window-Ops

Mouse 1 	FS      A       Resize-or-Raise
Mouse 1	T       A       Move-or-Raise
Mouse 2	T	A	WindowShade

Mouse 1	TFS	C	Move-or-Raise

#############################################################
# FvwmPager
DeskTopSize 4x1
*FvwmPagerBack #c4c5ab
*FvwmPagerFore black
*FvwmPagerFont none
*FvwmPagerHilight #8b8c75
*FvwmPagerSmallFont
#*FvwmPagerGeometry 300x64
*FvwmPagerBalloons
*FvwmPagerBalloonYOffset -1

#############################################################
# FvwmButtons
Module FvwmButtons
*FvwmButtonsFore black
*FvwmButtonsBack #c4c5ab
*FvwmButtonsPixmap cheese.xpm
*FvwmButtonsFrame 0
*FvwmButtonsGeometry -1-1
*FvwmButtonsRows 1
*FvwmButtons(2x1, Swallow "asclock" "exec asclock -led palegoldenrod  -noblink -12 -shape &" )
*FvwmButtons(2x1, Icon Netscape.xpm, Action `exec netscape &`)
#*FvwmButtons(2x1, Swallow "asmail-imap" 'exec asmail-imap &' )
*FvwmButtons(2x1, Icon OldBlueAddingMachine.xpm, Action `exec dtcalc &` )
*FvwmButtons(2x1, Icon SunMicrosystemsMonitor.xpm, Action `exec rxvt &`)
*FvwmButtons(2x1, Icon ClipboardWithPencilAndPaper.xpm, Action `exec xemacs-light &`)
*FvwmButtons(2x1, Icon ComputerScrewdriver.xpm, Action `exec rxvt -e rlogin choruslab1 &` )
*FvwmButtons(8x1, Frame -2, Swallow "FvwmPager" `module FvwmPager * *`  )

#############################################################
# FvwmAnimate
Module FvwmAnimate
*FvwmAnimateEffect Twist
*FvwmAnimateIterations 16
*FvwmAnimateDelay 10

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 8 Jan 1999 01:47:09 +0100

> Does anyone have the same problem?

I remember somebody had the same problem but with
SnapAttraction instead of BorderStyle. Perhaps
we can reproduce it with your config file.

---- 10 minutes later ----

No, I don't get this. Is it possible you have some
very old fvwm somewhere in the PATH that gets
executed when you restart?

Bye

Dominik

--
Dominik Vogt, [email-masked]
Reply-To: [email-masked]

--
Visit the official FVWM web page at <URL: http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Frederic Barrat <[email-masked]>
Date: Thu, 07 Jan 1999 17:46:58 -0800

> executed when you restart?

Silly me... You are right, that was the problem.
Thanks a lot.

---

From: Adam L Rice <[email-masked]>
Date: Fri, 8 Jan 1999 00:56:43 +0000

> I'm using v2.1.4, but the same thing was happening with 2.0.46.

Check that you don't have another fvwm2 in your path ("which fvwm2" should
tell you which version of fvwm2 is getting run by default). I have a hunch
that a different version of fvwm is getting run when you do the restart.

-- 
Adam Rice -- [email-masked] -- Blackburn, Lancashire, England

---

From: "Randall S. Winchester" <[email-masked]>
Date: Fri, 8 Jan 1999 10:47:14 -0500 (EST)

On Fri, 8 Jan 1999, Dominik Vogt wrote:

: On Thu, Jan 07, 1999 at 01:36:12PM -0800, Frederic Barrat wrote:
: > 
: > Hi,
: > 
: > I'm having a problem whenever I restart fvwm2. I get some default
: > decoration on the windows instead of what is in my .fvwm2rc file. Yet,
: > everything works fine when I start fvwm2 the first time.
: > 
: > I get the following error:
: > [FVWM][executeModule]: <<ERROR>> No such module
: > /home/fxb/fvwm2/libexec/fvwm/2.1.4/ BorderStyle
: > (the list goes on and on with all the commands related to style).
: > 
: > I don't quite understand why "BorderSytle" is interpreted as a module.
: > 
: > Does anyone have the same problem?
: 
: I remember somebody had the same problem but with
: SnapAttraction instead of BorderStyle. Perhaps
: we can reproduce it with your config file.
: 
: ---- 10 minutes later ----
: 
: No, I don't get this. Is it possible you have some
: very old fvwm somewhere in the PATH that gets
: executed when you restart?

The reason is that there is a subtle change in the requiremnets in the
.fvwm2rc file that were accepted previously. I think the nuance may
have occurred when I ran the conversion script to go from fvwm1 to fvwm2
but it has been so long that I forget now.

Here is what I had to change in our global fvwm2rc file. It works correctly
with fvwm2*.

< *FvwmButtons(2x1) - whatever Swallow "FvwmPager" Module FvwmPager 0 1
< # *FvwmButtons(4x1) - whatever Swallow "FvwmPager" Module FvwmPager 0 3
---
> *FvwmButtons(2x1 Swallow "FvwmPager" "FvwmPager 0 1")
> # *FvwmButtons(4x1 Swallow "FvwmPager" "FvwmPager 0 3")

Randall

---

From: Dominik Vogt <[email-masked]>
Date: Fri, 8 Jan 1999 17:19:42 +0100

> > # *FvwmButtons(4x1 Swallow "FvwmPager" "FvwmPager 0 3")

I don't catch what this has to do with the BorderStyle/Restart
problem. Please elaborate. Apart from this I think the problem
was solved.

Bye

Dominik

-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].