Subject: FVWM: hard question: fvwm2 and Red Hat (5.0 and above)

From: Neil Zanella <[email-masked]>
Date: Thu, 31 Dec 1998 00:37:12 -0330 (NST)

Hello,

I asked before and got very little feedback.

If you have Red Hat you will realize that the solution to this problem

is not the same as for other distributions of Linux.

So, how do I have fvwm2 read the system.fvwm2rc that *I* create so that

all users use that very file???

I *do not* want to place a .fvwm2rc file in *every* single user's directory.

If you know the solution to this problem then please write back,

Thanks a lot,

I appreciate your help,

Neil
--
Visit the official FVWM web page at <URL: http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Thu, 31 Dec 1998 10:52:59 +0100

> is not the same as for other distributions of Linux.

I don't, so I can only guess.

> I *do not* want to place a .fvwm2rc file in *every* single user's directory.

What is your problem? One of these?

1) You can't find the system wide fvwm2rc

2) You know where it is but want to use another file
   without touching it?

If 2) is your problem I suppose it would be best to rename
the existing file and use your own instead.

If 1) is the problem, try running fvwm2 with strace:

  # strace -eopen fvwm2

This gives you a trace of all open() kernel calls. One of
these will be the system wide fvwm2rc file.

Basically you should have a look at the system wide
xinitrc file too.

Bye

Dominik

-- 
Dominik Vogt, [email-masked]
Reply-To: [email-masked]