Subject: FVWM: num-lock a modifier?

From: Kent Howard <[email-masked]>
Date: Sun, 20 Dec 1998 03:09:26 -0800

Why does Num-Lock cause my key and mouse bindings not to work?
Is it being treated as a modifier for some reason?

thanks,
- Kent
--
Visit the official FVWM web page at <URL: http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Sue Blake <[email-masked]>
Date: Sun, 20 Dec 1998 23:26:34 +1100

> Is it being treated as a modifier for some reason?

I'd noticed that, and it seemed consistent so I built my whole .fvwm2rc
around it. With numlock off most function keys etc have been assigned
handy actions. With numlock on all keys go straight to whatever's
running in the current window.

This way of working has become addictive, so I do hope it's not just a
quirk. Can anyone confirm it's supposed to be so? Could another key be
used for this purpose instead, in order to leave the numlock on all the
time?

-- 

Regards,
        -*Sue*-

---

From: Bob Woodside <[email-masked]>
Date: Sun, 20 Dec 1998 09:37:36 -0500 (EST)

Sue Blake <[email-masked]> wrote:
> Can anyone confirm it's supposed to be so? Could another key be

	From the FAQ:

----------------------------------------------------------------------

42) Why do NumLock and CapsLock interfere with ClickToFocus and/or my
    mouse bindings?

A: Because they are treated as modifiers.

----------------------------------------------------------------------

- Bob

---

From: Sue Blake <[email-masked]>
Date: Mon, 21 Dec 1998 02:29:17 +1100

> > used for this purpose instead, in order to leave the numlock on all the

Ooooh, so that means key bindings too does it?
Thanks. I live and learn :-)

When I saw this a while ago I tried to fiddle with the CapsLock and
couldn't see what it does. Is there any other documentation on this?

-- 

Regards,
        -*Sue*-

---

From: Dan Espen <[email-masked]>
Date: Sun, 20 Dec 1998 14:27:12 -0500

> couldn't see what it does. Is there any other documentation on this?

Please answer only to the list (you copied Bob but he's already on the
list).

You  might want to  start  with "man xmodmap".   This  is not an fvwm2
issue, fvwm2 treats keyboard events like any other X application.

--
Dan Espen                                Phone: (732) 699-5570
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL: http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Kent Howard <[email-masked]>
Date: Sun, 20 Dec 1998 15:40:32 -0800

On Sun, Dec 20, 1998 at 11:26:34PM +1100, Sue Blake wrote:
+----------
| On Sun, Dec 20, 1998 at 03:09:26AM -0800, Kent Howard wrote:
| > Why does Num-Lock cause my key and mouse bindings not to work?
| > Is it being treated as a modifier for some reason?
| 
| I'd noticed that, and it seemed consistent so I built my whole .fvwm2rc
| around it. With numlock off most function keys etc have been assigned
| handy actions. With numlock on all keys go straight to whatever's
| running in the current window.
| 
| This way of working has become addictive, so I do hope it's not just a
| quirk. Can anyone confirm it's supposed to be so? Could another key be
| used for this purpose instead, in order to leave the numlock on all the
| time?
+----------

Well this seems to help...

I reversed the action of the num-lock key by running the
following commands through xmodmap.  So when Num-Lock is off, the
numerals are produced; and when Num-Lock is on, the
Home/arrows/Page ones work.

keysym KP_Home = KP_7 KP_Home
keysym KP_Up = KP_8 KP_Up
keysym KP_Prior = KP_9 KP_Prior
keysym KP_Left = KP_4 KP_Left
keysym KP_Begin = KP_5 KP_Begin
keysym KP_Right = KP_6 KP_Right
keysym KP_End = KP_1 KP_End
keysym KP_Down = KP_2 KP_Down
keysym KP_Next = KP_3 KP_Next
keysym KP_Insert = KP_0 KP_Insert
keysym KP_Delete = KP_Decimal KP_Delete
--
Visit the official FVWM web page at <URL: http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].