Subject: FVWM: crash on menus

From: TG <[email-masked]>
Date: Sat, 05 Dec 1998 18:32:05 +0100

i'm using fvwm-2.1.4 and when i hit the up or down cursor key after a menu
popped up, fvwm suddenly dies without any message. it does not matter wether
the menu is calles by a hotkey or mouseclick. when the mouse pointer is
outside of the menu area the two keys will just cause the menu to disappear.

running on rh5.1, linux kernel 2.0.34, xfree 3.3.2.

a small note: keep up the good work. i really love the stability, speed and
configuration options of fvwm!

tung

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 7 Dec 1998 16:25:16 +0100

> running on rh5.1, linux kernel 2.0.34, xfree 3.3.2.

Please try to fetch a stack trace for me. Enable full core files if
necessary and on the command line type

  # gdb fvwm2 core
...(lots of output, make sure the core was generated by fvwm2)
  (gdb) where
...(stack trace follows)

Make sure you look at the right executable (add a path if
necessary) and don't strip the executables.

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 8 Dec 1998 00:10:58 +0100

> outside of the menu area the two keys will just cause the menu to disappear.

I can't reproduce this with any menu style. Can you send me your
.fvwm2rc file? What exactly do you do to get the coredump? I need
a step-by-step description for idiots ;-)

Bye

Dominik
-- 
Dominik Vogt, [email-masked]