Subject: FVWM: changing the pager grid

From: Zack Brown <[email-masked]>
Date: Tue, 22 Dec 1998 09:19:22 -0500 (EST)

Hi,

When I start X and FVWM, the pager displays a grid whose elements are the
same size as the viewport. I would like this grid to represent things that
are more meaningful for my desktop set-up, such as the distance the viewport
jumps when I press certain hotkeys. Is the grid configurable?

Zack

--
Visit the official FVWM web page at <URL: http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dominik Vogt <[email-masked]>
Date: Tue, 22 Dec 1998 16:37:57 +0100

> jumps when I press certain hotkeys. Is the grid configurable?

Huh? We have a communications problem here. If the grid elements
were as large as the viewport the pager would cover the entire
scree. That is probably not what you want to say. So here is what
the pager (FvwmPager I assume) does:

For the specified range of desks it displays a mini-representation
of the configured pages. You can switch desks or pages via the pager
by clicking in it. The number of desks is given on the command line
for FvwmPager:

  Module FvwmPager 4 9

will give you six desks numbered from 4 to 9. Each desk has the
same grid size specified by

  DeskSize x y

Each grid rectangle represents a page, the dashed lines in between
are the page boundaries. If you want to change the size of the
grid you have to change the number of pages on your desktop.

Does this answer your question?

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL: http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Zack Brown <[email-masked]>
Date: Tue, 22 Dec 1998 22:29:33 -0500 (EST)

> Does this answer your question?

I think so, but it doesn't solve my problem. You see, the grid of dashed
lines may have the purpose of identifying individual pages, but I want to
use them for a different purpose. I want to tell FvwmPager exactly where to
place those dashed lines, regardless of page-boundaries.

But if I understand you correctly, those lines are hard-coded to the page
boundaries. Correct?

Zack

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 23 Dec 1998 10:19:13 +0100

> But if I understand you correctly, those lines are hard-coded to the page

Yup.

Bye

Dominik

---

From: Adam Tla/lka <[email-masked]>
Date: Wed, 23 Dec 1998 11:49:02 +0100 (MET)

Hello!

As I read from doc modifiers are: control, shift, lock, meta, mod1-mod5 
or all (CSML12345A).
So if we want to obtain the same behaviour with or without Num etc.
we must define additional bindings i.e. :

# without additional modifiers
Key Escape      A       S       PopUp Window-Ops

# with NumLock
Key Escape      A       S2      PopUp Window-Ops

#with CapsLock
Key Escape      A       SL      PopUp Window-Ops

.. the same with mouse bindings.

Regards

 . .  Adam Tla/lka      mailto:[email-masked]    ^v^ ^v^ ^v^
  )   System  & Network Administration Group           ~~~~~~
  -  Computer Center,  Technical University of Gdansk, Poland
     PGP public key:   finger [email-masked]

---

From: Adam Tla/lka <[email-masked]>
Date: Wed, 23 Dec 1998 12:29:00 +0100 (MET)

> .. the same with mouse bindings.

Sorry something doesn't work for mouse bindings.
Type A (All) works fine with CapsLock but with NumLock it fails.
Why?

---

From: Adam Tla/lka <[email-masked]>
Date: Wed, 23 Dec 1998 12:54:55 +0100 (MET)

I observed that:
+ while in ClickToFocus mode and no modifiers while I click in my iconify
  button inactive widow is activated, raised and button is in pressed
state  - releasing mouse activate iconification;
- with CapsLock the same click activates and raises window but
iconification is not invoked, second click does it

- with NumLock iconification is activated but window is not activated nor
raised.

Mouse binding is:
Mouse 0 4 A Iconify

Is that correct behaviour?

---

From: Dominik Vogt <[email-masked]>
Date: Wed, 23 Dec 1998 14:15:50 +0100

> Type A (All) works fine with CapsLock but with NumLock it fails.

It doesn't? I'll check that in the code.

Bye

Dominik