Subject: FVWM: Re: lost buttons

From: Chad Hall <[email-masked]>
Date: Thu, 17 Dec 1998 16:01:27 -0500

I've just lost my additions again, this time running 2.1.5 on a SparcStation 4
Solaris 2.5.1.  I still have no idea what causes it, I just go to open a new
window, and there's no menu there.  Included are my .fvwm2rc and .Xdefaults, 
complete with horrid colors that keep others from using my workstation.  The 
rc is the 1.x example, converted to 2.x with included script and modified to
my liking.

Chad.

-- Begin .fvwm2rc --
HilightColor   DarkCyan midnightblue

Style "Black" Sticky
Style "#60c0a0" Sticky

############################################################################
# Now the fonts - one for menus, another for window titles, another for icons
#Font			-adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*
#!Font			-*-times-medium-i-*-*-*-120-*-*-*-*-*-* (new command=MenuStyle)
WindowFont		-adobe-helvetica-bold-r-*-*-12-*-*-*-*-*-*-*
#WindowFont -adobe-times-bold-r-*-*-18-*-*-*-*-*-*-*,-*-fixed-medium-r-normal-*-18-*-*-*-*-*-*-*,-*-gothic-medium-r-normal-*-18-*-*-*-*-*-*-*,-*-mincho-medium-r-normal-*-18-*-*-*-*-*-*-*,-*-*-medium-r-normal-*-18-*-*-*-*-*-*-*
#IconFont		-adobe-helvetica-medium-r-*-*-11-*-*-*-*-*-*-*
IconFont		fixed

###########################################################################
# Set up the major operating modes
#
########################      FOCUS STUFF     ##############################
# Set windows to auto-raise after 750 milliseconds if you like it.
# Autoraise can sometimes obscure pop-up windows. Performance is now
# similar to olvwm's auto-raise feature.
#! AutoRaise 500 (use Module FvwmAuto)
AddToFunc "InitFunction" "I" Module FvwmAuto 500
AddToFunc "RestartFunction" "I" Module FvwmAuto 500

# Normally, we'll be in focus-follows mouse mode, but uncomment this 
# for mwm-style click-to-focus
#ClickToFocus

########################      ICON STUFF     ##############################
# Auto Place Icons is a nice feature....
# This creates two icon boxes, one on the left side, then one on the
# bottom. Leaves room in the upper left for my clock and xbiff,
# room on the bottom for the Pager.
#IconBox -150 90 -5 -140
#IconBox 5 -140 -140 -5
Style "*" IconBox -70 1 -1 -140

########################      MWM EMULATION     #######################
#
# My feeling is that everyone should use MWMDecorHints and MWMFunctionHints,
# since some applications depend on having the window manager respect them

# MWMFunction hints parses the function information in the MOTIF_WM_HINTS
# property, and prohibits use of these functions on the window. Appropriate
# portions of the window decorations are removed.
Style "*" MWMFunctions

# MWM is kinda picky about what can be done to transients, and it was keeping
# me from iconifying some windows that I like to iconify, so here's an
# over-ride that will allow me to do the operation, even tough the menu
# item is shaded out.
Style "*" HintOverride

# MWMDecor hints parses the decoration information in the MOTIF_WM_HINTS
# property, and removes these decoratons from the window. This does not affect
# the functions that can be performed via the menus.
Style "*" MWMDecor

# These are affect minor aspects for the look-and-feel.
# Sub-menus placement mwm-style?
# MWMMenus
# mwm-style border reliefs (less deep than default fvwm) ?
# MWMBorders
# Maximize button does mwm-inversion thingy
# MWMButtons
########################      MISCELLANEOUS STUFF     #######################
# If you don't like the default 150 msec click delay for the complex functions
# change this and uncomment it.
#ClickTime 150

# OpaqueMove has a number (N) attached to it (default 5).
# if the window occupies less than N% of the screen, 
# then opaque move is used. 0 <= N <= 100
OpaqueMoveSize 80

# flip by whole pages on the edge of the screen.
EdgeScroll 100 100

# A modest delay before flipping pages seems to be nice...
# I thresh in a 50 pixel Move-resistance too, just so people
# can try it out.
EdgeResistance 250 50

########################      WINDOW PLACEMENT     #######################
# RandomPlacement prevents user interaction while placing windows:
# RandomPlacement
#Style "*" ActivePlacement

# SmartPlacement makes new windows pop-up in blank regions of screen 
# if possible, or falls back to random or interactive placement.
Style "*" ActivePlacement, SmartPlacement

# With SmartPlacement, windows will normally place themselves over icons. 
# Uncomment this to change that.
#StubbornPlacement

# NoPPosition instructs fvwm to ignore the PPosition field in window 
# geometry hints. Emacs annoyingly sets PPosition to (0,0)!
Style "*" NoPPosition

########################      DECORATIONS     #######################
# If you want decorated transient windows, uncomment this:
#Style "*"	DecorateTransients

###########################################################################
# Set up the virtual desktop and pager

#set the desk top size in units of physical screen size
DeskTopSize 3x3

# and the reduction scale used for the panner/pager
#!DeskTopScale 32 (new command=*FvwmPagerDeskTopScale <scale>)
*FvwmPagerDeskTopScale 32

##########################################################################
# Module path and paths to the icons
#
# ModulePath is a colon-separated list, just like regular unix PATH
ModulePath /usr/local/libexec/fvwm/2.1.5/
PixmapPath /usr/local/X11/include/X11/pixmaps/
IconPath   /usr/local/X11/include/X11/bitmaps/

############################################################################
# Set the decoration styles and window options
# Order is important!!!!
# If compatible styles are set for a single window in multiple Style
# commands, then the styles are ORed together. If conflicting styles
# are set, the last one specified is used.

# These commands should command before any menus or functions are defined,
# and before the internal pager is started.

# change the default width.
Style "*" BorderWidth 5, HandleWidth 5, Color yellow4/purple4, Icon unknown1.xpm

Style "Fvwm*"	NoTitle, NoHandles, Sticky, WindowListSkip,BorderWidth 0
#Style "FvwmPager" StaysOnTop, NoTitle, NoHandles
Style "FvwmPager" NoTitle, NoHandles
Style "FvwmBanner" StaysOnTop
Style "FvwmButtons" NoTitle, NoHandles, Sticky, WindowListSkip, BorderWidth 0, Icon toolbox.xpm
Style "FvwmWinList" Sticky, Title
Style "*lock"	NoTitle, NoHandles, Sticky, WindowListSkip, BorderWidth 0
Style "xbiff"	NoTitle,            Sticky, WindowListSkip
Style "xload"	NoTitle,            Sticky, WindowListSkip
Style "xmcd"	NoTitle
Style "rxvt"	Icon  term.xpm
Style "xterm"	Icon xterm.xpm, Color yellow4/purple4
Style "xload"	NoTitle, NoHandles, Sticky, WindowListSkip, BorderWidth 0
#Style "Appointment" Icon datebook.xpm, NoButton 2, NoButton 4
Style "xcalc"	Icon xcalc.xpm, NoButton 2
Style "xbiff"	Icon mail1.xpm, NoButton 2
#Style "xmh"	Icon mail1.xpm, StartsOnDesk 1, NoButton 2
Style "xman"	Icon xman.xpm
Style "xvgr"	Icon graphs.xpm
Style "xmag"	Icon mag_glass.xpm
Style "xgraph"	Icon graphs.xpm
Style "YTalk"	StaysOnTop

# Change the Maximize and iconify buttons to up and down triangles.

ButtonStyle 2 4 50x35@1 65x65@0 35x65@0 50x35@1
ButtonStyle 4 4 50x65@1 35x35@1 65x35@1 50x65@0

#############################################################################

# Stuff to do at start-up

AddToFunc "InitFunction" "I" Module FvwmPager 0 0
#+		"I" Module FvwmButtons
#+		"I" Exec exec xterm -fg white -bg black -geometry 135x25+235+0 &
#+		"I" Exec exec xterm -fg white -bg black -geometry 80x51+0+169 &
+		"I" Exec xload -fg cyan4 -bg midnightblue -hl midnightblue -nolabel -geometry -0+0 &
+              "I" Desk 0 0

#AddToFunc "RestartFunction" "I" Exec xsetroot -solid "#266294"
#AddToFunc "RestartFunction" "I" Module FvwmButtons
AddToFunc "RestartFunction" "I" Module FvwmPager 0 0

############################################################################
# Now define some handy complex functions

# This one moves and then raises the window if you drag the mouse,
# only raises the window if you click,  or does a RaiseLower if you double 
# click
AddToFunc "Move-or-Raise" "M" Move
+              "M" Raise
+              "C" Raise
+              "D" RaiseLower

# This one maximizes vertically if you click (leaving room for the GoodStuff bar at the
# bottom, or does a full maximization if you double click, or a true full vertical 
# maximization if you just hold the mouse button down.
AddToFunc "maximize_func" "M" Maximize 0 100
+              "C" Maximize 0 80
+              "D" Maximize 100 100

# This one moves and then lowers the window if you drag the mouse,
# only lowers the window if you click,  or does a RaiseLower if you double 
# click
AddToFunc "Move-or-Lower" "M" Move
+              "M" Lower
+              "C" Lower
+              "D" RaiseLower

# This one moves or (de)iconifies:
AddToFunc "Move-or-Iconify" "M" Move
+              "D" Iconify

# This one resizes and then raises the window if you drag the mouse,
# only raises the window if you click,  or does a RaiseLower if you double 
# click
AddToFunc "Resize-or-Raise" "M" Resize
+              "M" Raise
+              "C" Raise
+              "D" RaiseLower

# This is provided as a hint only.
# Move to a known page on the desktop, then start an application in a 
# known location. Could also switch to a known desktop, I guess
#Function "abs_coord"
#	GoToPage "Immediate"	1,1
#	Exec	"Immediate"	exec xcalc -geometry +100+100&
#EndFunction

AddToFunc "SpawnTerm" 
+	"I" Exec xterm -ut +ls -T $0 -n $0 -geometry 80x24+200+200 -e rlogin $0 $1

AddToFunc "SpawnTelnet" 
+	"I" Exec xterm -ut -T $0 -n $0 -geometry 80x24+200+200 -e telnet $0

##############################################################################
#now define the menus - defer bindings until later

AddToMenu Terms "Local Terms" Title
+	"genetic"	Function SpawnTerm genetic "-l biswick"
+	"heretic"	Function SpawnTerm heretic "-l biswick"
+	"spaztic"	Function SpawnTerm spaztic "-l biswick"
+	""		Nop
+	"alien"		Function SpawnTelnet alien
+	"heathers"	Function SpawnTerm heathers
+	"impact"	Function SpawnTerm impact
+	"newsread"	Function SpawnTerm newsread
+	"outbreak"	Function SpawnTelnet outbreak
+	"thewall"	Function SpawnTerm thewall
+	""		Nop
+	"jedi"		Function SpawnTelnet jedi

AddToMenu Quit-Verify "Really Quit Fvwm?" Title
+	"No, Don't Quit" Nop
+	"" Nop
+	"Restart fvwm2" Restart /usr/local/bin/fvwm2
+	"" Nop
#+	"Start fvwm95" Restart fvwm95
#+	"Start qvwm" Restart qvwm
#+	"Start afterstep" Restart afterstep
#+	"Start mlvwm" Restart mlvwm
#+	"Start twm" Restart twm
#+	"Start tvtwm" Restart tvtwm
#+	"Start mwm" Restart mwm
+	"Start olwm" Restart /usr/openwin/bin/olwm
+	"" Nop
+	"Yes, Really Quit" Quit

AddToMenu Module-Popup "Modules" Title
+	"FvwmButtons" Module FvwmButtons
+	"Clean-Up" Module FvwmClean
+	"Identify" Module FvwmIdent
+	"SaveDesktop" Module FvwmSave
+	"Debug" Module FvwmDebug
+	"Pager" Module FvwmPager 0 0
+	"FvwmWinList" Module FvwmWinList

AddToMenu Utilities "Utilities" Title
+	"Xterm" Exec exec xterm -geometry 80x24+200+200 &
+	"Terms" Popup Terms
+	"Netscape" Exec /usr/local/bin/netscape &
#+	"Cdplayer" Exec /usr/local/X11/bin/xmcd &
+	"green" Exec xterm -bg "#000057092147" -fg white &
+	"big" Exec xterm -fg white -bg black -geometry 80x54 &
#+	"Rxvt" Exec rxvt &
+	"Top" Exec xterm -T Top -n Top -e top &
+	"Calculator" Exec xcalc &
+	"XLoad" Exec xload -fg cyan4 -bg midnightblue -hl midnightblue -nolabel -geometry -0+0
+	"Xman" Exec xman &
+	"Xmag" Exec xmag &
+	"" Nop
+	"Modules" Popup Module-Popup
#	Nop	""
#	Popup	"Exit Fvwm"	Quit-Verify

AddToMenu WindowOps "Window Ops" Title
+	"Move" Function Move-or-Raise
+	"Resize" Function Resize-or-Raise
+	"Raise" Raise
+	"Lower" Lower
+	"(De)Iconify" Iconify
+	"(Un)Stick" Stick
+	"(Un)Maximize" Function maximize_func
+	"" Nop
+	"Destroy" Destroy
+	"Close" Close
+	"" Nop
+	"Refresh Screen" Refresh

AddToMenu WindowOps2 "Move" Function Move-or-Raise
+	"Resize" Function Resize-or-Raise
+	"Raise" Raise
+	"Lower" Lower
+	"Iconify" Iconify
+	"(Un)Stick" Stick
+	"" Nop
+	"Destroy" Destroy
+	"Close" Close
+	"" Nop
+	"ScrollBar" Module FvwmScroll 2 2

#############################################################################
# One more complex function - couldn't be defined earlier because it used 
# pop-up menus
#
# This creates a motif-ish sticky menu for the title-bar window-ops
# pop-up
# Menu acts like normal twm menu if you just hold the button down,
# but if you click instead, the menu stays up, motif style
AddToFunc "window_ops_func" "C" PopUp WindowOps2
+              "M" PopUp WindowOps2
# Motif would add:
# I'll add it too, it can be mighty handy.
+              "D" Close

##############################################################################
# This defines the mouse bindings

# First, for the mouse in the root window
# Button 1 gives the Utilities menu
# Button 2 gives the Window Ops menu
# Button 3 gives the WindowList (like TwmWindows)
# I use the AnyModifier (A) option for the modifier field, so you can hold down
# any shift-control-whatever combination you want!

#     Button	Context Modifi 	Function
Mouse 1 	W	M	Function "Move-or-Raise"
Mouse 3		W	M	Menu Quit-Verify Nop

Mouse 1		R   	N       PopUp Utilities Nop
Mouse 2		R    	A       PopUp WindowOps Nop
Mouse 3		R    	A      	Module FvwmWinList transient

Mouse 2		W	M	Destroy
Mouse 3		R	M	Menu Quit-Verify Nop

# Now the title bar buttons
# Any button in the left title-bar button gives the window ops menu
# Any button in the right title-bar button Iconifies the window
# Any button in the rightmost title-bar button maximizes
# Note the use of "Mouse 0" for AnyButton.

#     Button	Context Modifi 	Function
Mouse 0		1    	A      	Function "window_ops_func"
Mouse 0		2    	A     	Function "maximize_func"
Mouse 0		4    	A     	Iconify

# Now the rest of the frame
# Here I invoke my complex functions for Move-or-lower, Move-or-raise,
# and Resize-or-Raise. 
# Button 1 in the corner pieces, with any modifiers, gives resize or raise
Mouse 1		F	A	Function "Resize-or-Raise"
# Button 1 in the title, sides, or icon, w/ any modifiers, gives move or raise
Mouse 1		TS	A	Function "Move-or-Raise"

# Button 1 in an icons gives move for a drag, de-iconify for a double-click,
# nothing for a single click
# Button 2 in an icon, w/ any modifiers, gives de-iconify

Mouse 1		I	A	Function "Move-or-Iconify"
Mouse 2		I	A	Iconify

# Button 2 in the corners, sides, or title-bar gives the window ops menu
Mouse 2		FST	A	Function "window_ops_func"
# Button 3 anywhere in the decoration (except the title-bar buttons)
# does a raise-lower
Mouse 3		TSIF	A	RaiseLower

# Button 3 in the window, with the Modifier-1 key (usually alt or diamond)
# gives Raise-Lower. Used to use control here, but that interferes with xterm
Mouse 3         W       M       RaiseLower

Mouse 1		R	C	Exec xlock -mode flame

############################################################################
# Now some keyboard shortcuts.

# Arrow Keys
# press arrow + control anywhere, and scroll by 1 page
Key Left	A	C	Scroll -100 0
Key Right	A	C	Scroll +100 +0
Key Up		A	C	Scroll +0   -100
Key Down	A	C	Scroll +0   +100

# press arrow + meta key, and scroll by 1/10 of a page
#Key Left	A	M	Scroll -10 +0
#Key Right	A	M	Scroll +10 +0
#Key Up		A	M	Scroll +0   -10
#Key Down	A	M	Scroll +0   +10

# press shift arrow + control anywhere, and move the pointer by 1% of a page
Key Left	A	SC	CursorMove -1 0
Key Right	A	SC	CursorMove +1 +0
Key Up		A	SC	CursorMove +0   -1
Key Down	A	SC	CursorMove +0   +1

# press shift arrow + meta key, and move the pointer by 1/10 of a page
Key Left	A	SM	CursorMove -10 +0
Key Right	A	SM	CursorMove +10 +0
Key Up		A	SM	CursorMove +0   -10
Key Down	A	SM	CursorMove +0   +10

# Keyboard accelerators
Key F1		A	M	Popup "Utilities"
Key F1		A	M	Popup "Utilities"
Key F2		A	M	Popup "Window Ops"
Key F3		a	m	Module "FvwmWinList" FvwmWinList 
Key F4		A	M	Iconify
Key F5		A	M	Move
Key F6		A	M	Resize
Key F7		A	M	CirculateUp
Key F8		A	M	CirculateDown

#Page Up/Dapge Down keys are used to scroll by one desktop page
# in any context, press page up/down + control
# in root context, just pressing page up/down is OK
# 
# I prefer the non-wrapping scroll. These are for example purposes only
#Key Next	A       C       Scroll 100000 0
#Key Next	R       N       Scroll 100000 0  
#Key Prior	A       C       Scroll -100000 0
#Key Prior	R       N       Scroll -100000 0

Key n		W	M	Exec xterm -fg white -bg black &
Key Tab		A	C	Next [!CurrentPage !Iconic !Transient !Sticky]WarpToWindow 50 50 
Key Tab		A	M	Next [!Iconic CurrentPage !Transient !Sticky]WarpToWindow 50 50
Key p		A	M	FlipFocus

############################################################################
############################################################################
#Definitions used by the modules

###################### GoodStuff button-bar ################################
# Colors
*FvwmButtonsFore Black
*FvwmButtonsBack #908090

# Font
*FvwmButtonsFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
# Geometry - really likes to pick its own size, but giving a position is OK
*FvwmButtonsGeometry -1-1

# Layout: specify rows or columns, not both
*FvwmButtonsRows 1

# Define the buttons to use.....
#*GoodStuff Kill    rbomb.xpm    Destroy

# xterm or rxvts on remote machines can be done like this
# Output re-direction is csh style, not sh style
# You will want to substitute your own hosts here!

#*GoodStuff DT   rterm.xpm   Exec "" ~/bin/newterm.dt </dev/null >&/dev/null & 
#*GoodStuff Heathers  rterm.xpm   Exec "" exec ~/bin/newterm.h </dev/null >&/dev/null & 
#*GoodStuff Heathers  rterm.xpm   Exec "" rsh heathers "exec xterm -T heathers -display $HOSTDISPLAY </dev/null >&/dev/null & "&
#*GoodStuff Snoopy  rterm.xpm   Exec "" rsh snoopy "exec xterm -T snoopy -display $HOSTDISPLAY </dev/null >&/dev/null & "&
#*GoodStuff Xcalc   rcalc.xpm   Exec "" xcalc &
#*GoodStuff mail    mail2.xpm   Exec "" xmh &

#*GoodStuff Paging  clamp.xpm   TogglePage
#*GoodStuff -  clock.xpm   Swallow "xclock" xclock -bg \#908090 -geometry -1500-1500 -padding 0
#*FvwmButtons(1x1) - whatever SwallowModule "FvwmPager" FvwmPager 0 0

######################### No Clutter ########################################
# I only wrote NoClutter as a simple test case, but maybe some big sites like
# universities really have usage problems (too many open windows)....
# Time delays are in seconds.
*FvwmNoClutter 3600 Iconify 1
*FvwmNoClutter 86400 Delete
*FvwmNoCLutter 172800 Destroy

########################## Window-Identifier ###############################
# Just choose colors and a fonts
*FvwmIdentBack MidnightBlue
*FvwmIdentFore Yellow
*FvwmIdentFont -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*

########################### Pager #########################################
*FvwmPagerBack	MidnightBlue
*FvwmPagerFore	SteelBlue3
*FvwmPagerHilight MidnightBlue

*FvwmPagerFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmPagerGeometry -1-1
*FvwmPagerLabel 0 Blearg
*FvwmPagerSmallFont 5x8

##########################FvwmWinList##################################
*FvwmWinListBack DarkOrchid4
*FvwmWinListFore grey75
#*FvwmWinListBack #908090
#*FvwmWinListFore Black
*FvwmWinListFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
#*FvwmWinListAction Click1 WarpToWindow 50 50
*FvwmWinListAction Click1 focus 50 50
*FvwmWinListAction Click2 Iconify
*FvwmWinListAction Click3 Module "FvwmIdent" FvwmIdent
*FvwmWinListUseSkipList
*FvwmWinListGeometry +0-1
#!Warning: Keyword "" not handled yet

#Set the foreground, background and stipple color and font for menus
#MenuStyle   Black grey SlateGrey -*-times-medium-i-*-*-*-120-*-*-*-*-*-* fvwm
MenuStyle Black grey60 grey40 -*-times-bold-r-*-*-14-*-*-*-*-*-*-*,-*-fixed-medium-r-normal-*-14-*-*-*-*-*-*-*,-*-gothic-medium-r-normal-*-14-*-*-*-*-*-*-*,-*-mincho-medium-r-normal-*-14-*-*-*-*-*-*-*,-*-*-medium-r-normal-*-14-*-*-*-*-*-*-* fvwm

-- End .fvwm2rc --

-- Begin .Xdefaults --

*highlight:	#ffffffffffff
*borderColor:	#ffffffffffff
*doubleClickDelay: 250
*language_preference1:	112
*language_preference2: 6
rxvt*scrollColor: yellow4
*VT100.colorMode: on
XTerm*VT100.scrollBar: on
XTerm*VT100.saveLines: 1000
XTerm*borderwidth: 5
!XTerm*geometry:80x24+200+200
XTerm*foreground: yellow2
XTerm*background: midnightblue
XTerm*cursorColor: yellow4
XTerm*fontMenu.Label:  VT Fonts
XTerm*fontMenu*fontdefault*Label:	Default
Xterm*fontMenu*fontdefault:		8x10
XTerm*fontMenu*font1*Label:	Tiny
XTerm*VT100*font1:		nil2
XTerm*fontMenu*font2*Label:	12 Point
XTerm*VT100*font2:		fixed
XTerm*fontMenu*font3*Label:	14 Point
XTerm*VT100*font3:		9x15
XTerm*fontMenu*font4*Label:	18 Point
XTerm*VT100*font4:		-*-lucidatypewriter-medium-*-*-*-*-180-*-*-*-*-*-*
XTerm*VT100*font5:		-adobe-courier-*-r-*-*-22-*-*-*-*-*-iso8859-*
XTerm*fontMenu*font5*Label:	Courier
!XTerm*fontMenu*font6*Label:	8 Point
!XTerm*VT100*font6:		rk24
XTerm*VT100*font6:		-b&h-lucidabright-medium-r-*-*-24-*-*-*-p-*-*-*
XTerm*fontMenu*fontescape*Label:	Escape Sequence
XTerm*fontMenu*fontsel*Label:		Selection
XTerm*allowSendEvents:		true
XTerm*VT100.Translations:	#override \n\
	<Key>F1: 	set-vt-font(1) \n\
	<Key>F2:	set-vt-font(2) \n\
	<Key>F3:	set-vt-font(3) \n\
	<Key>F4:	set-vt-font(4) \n\
	<Key>F5:	set-vt-font(5) \n\
	<Key>F6:	set-vt-font(6) \n\
	<Key>F9:	set-scrollbar(toggle) \n\
	<Key>L7:	set-vt-font(1) keymap(unicon)

XTerm*VT100.uniconKeymap.Translations: #override \n\
	<Key>L7:	set-scrollbar(toggle) set-vt-font(2) keymap(None)

Vim*useSchemes:		all
Vim*sgiMode:		true
Vim*useEnhancedFSB:	true
Vim*background:		black
Vim*foreground:		white
Vim*boldColor:		green1
Vim*font:		-*-lucidatypewriter-medium-*-*-*-*-140-*-*-*-*-*-*
!Vim*font:		-adobe-courier-medium-r-*-*-*-140-*-*-*-*-*-*
!Vim*font:		7x13bold
Vim*boldFont:		8x13bold
Vim*scrollbarWidth:	3
Vim*menuBar.font:	-misc-fixed-medium-r-normal--13-100-100-100-c-70-iso8859-1
Vim*menuBackground:	gray70
Vim*menuForeground:	green1
Vim*menuHeight:		30
--
Visit the official FVWM web page at <URL: http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 17 Dec 1998 16:33:18 -0500

> Mouse 2		R    	A       PopUp WindowOps Nop

I  think you are trying  to tell us that  you are loosing  the 2 mouse
bindings above?

After you  open a new   window, the buttons  on  the root (background)
window, fail to popup menus?

If thats the case, try taking the string "Nop" off the line.
Reading the documentation, I don't see what thats supposed to do.

--
Dan Espen                                Phone: (732) 699-5570
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL: http://fvwm.math.uh.edu/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].