Subject: FVWM: embedding shell scripts

From: Neil Zanella <[email-masked]>
Date: Sun, 6 Dec 1998 12:10:01 -0330 (NST)

Hello,

Could someone _please_ write a hack to
embed shell scripts into a .fvwm2rc
file. Then shell scripts can be invoked
from within a .fvwm2rc file as fucntions.
This would make distribution and maintenance
of .fvwm2rc files a lot easier. I like my
.fvwm2rc files to be self contained.

Thanks,

Neil
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: TG <[email-masked]>
Date: Sun, 06 Dec 1998 19:54:48 +0100

> .fvwm2rc files to be self contained.

I used to see the .fvwm2rc file as a huge block of data, but some time
ago, I downloaded the fvwm2gnome config and I discovered the Read
command. You can split up the file and organize it in directories. Still
not really functions, but it is much more maintainable.

My config looks like this (just to give you an idea):

.fvwm2rc
.fvwm2gnome
  |--- icons
  |--- backgrounds
  |--- config
	  |--- pager.config
	  |--- buttons.config
          |--- menus.config
          |--- functions.config
          |--- backer.config
   ....

Here is the URL: [http://www.staticbomb.com/fvwm2gnome].

Regards,

Wing Tung

---

From: Dominik Vogt <[email-masked]>
Date: Mon, 7 Dec 1998 16:04:15 +0100

> .fvwm2rc files to be self contained.

Why should you need a hack? Just say

  Exec my_shell_script

The only drawback is that you can't wait until the script
has finished. fvwm spawns a new process and continues.
Well, and you have to add 'Exec'. Is that a problem?

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Toy Keeper <[email-masked]>
Date: Mon, 07 Dec 1998 15:15:20 -0700

> .fvwm2rc files to be self contained.

Besides the already-mentioned tricks, there's also the "PipeRead"
command.  With this, you can change the configuration dynamically by
having a program output Fvwm commands...  I used this to create a
Windows-like "Documents" menu in Fvwm, for example.  I don't actually
use/like that particular menu, but it was a nice way to learn.  :)

 _  _ _  _ ___ ___  -----------"Use the source, Luke!"---------
( \/ ( \/ (__ (__ ) | ~  Scott Scriven (Toy Keeper / XYZZ)    |
 \  / \  /  //  //  | mailto:[email-masked]           |
 /  \ / /  //_ //_  | mailto:[email-masked]         |
(_/\_(_/  (___(___) | http://www.vis.colostate.edu/~scriven/  |
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].