Subject: FVWM: New feature: *FvwmTaskBarAutoFocus

From: Mohsin_Ahmed <[email-masked]>
Date: Sat, 21 Nov 1998 14:10:47 +0530

I added a new feature to Fvwm2.0.46/extras/FvwmTaskBar/FvwmTaskBar.c,
whereby keeping the cursor on a button in taskbar raises the window,
if tip is open (should be independent ideally).

BTW, I don't know X so well, but ideally I am looking at taskbar
taking keyboard input. Let me know if you have any suggestions,
eg. left / Right arrow in TaskBar can move between windows.

- Mohsin.

In ~/.fvwm2rc turn on the option by:
*FvwmTaskBarAutoFocus
*FvwmTaskBarShowTips

$ cd Fvwm2.0.46/extras/FvwmTaskBar
$ diff FvwmTaskBar.c-orig FvwmTaskBar.c
27a128
>     AutoFocus      = False,      // mosh
522c523,532
<   if (Tip.open) RedrawTipWindow();
---
>     if (Tip.open){
>       RedrawTipWindow();
>
>       // 98-11-21 13:45, Mohsin_Ahmed, mailto:[email-masked].
>       if( Tip.type >= 0 && AutoFocus ){
>           SendFvwmPipe( "Iconify -1, Raise, Focus",
>                         ItemID( &windows, Tip.type ) );
>       }
>     }
>
606a617,618
>       else if(mystrncasecmp(tline,CatString3(Module, "AutoFocus",""),
>                             Clength+9)==0) AutoFocus=True;

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jason L Tibbitts III <[email-masked]>
Date: 21 Nov 1998 11:13:59 -0600

>>>>> "MA" == Mohsin Ahmed <[email-masked]> writes:

MA> I added a new feature to Fvwm2.0.46/extras/FvwmTaskBar/FvwmTaskBar.c,
MA> whereby keeping the cursor on a button in taskbar raises the window, if
MA> tip is open (should be independent ideally).

You should probably send your additions to the fvwm-workers list.  You
might also want to make sure it applies against the current development
version, available from the testing directory on the FTP site.

Also, please make sure to send a diff with some context; as you sent it, it
can't be applied automatically as it shows only the changes and not any of
the surrounding code.  Try using diff -u or diff -c; either of those will
generate something that the 'patch' program can apply.

 - J<