Subject: FVWM: Re: .xsession-errors

From: Neil Zanella <[email-masked]>
Date: Fri, 6 Nov 1998 04:12:16 -0330 (NST)

> Probably some configuration error in your .fvwm2rc. My guess
> is that Some '+'-line to AddToMenu, AddToFunc etc. is not
> in correct format. Perhaps the + is missing or another
> word comes before the "I" (=immediate in functions).

Thanks for the reply,

You were right about the missing plus. I should have known better.

I think it would be somewhat handy though if the errors reported line numbers
just like gcc does. This would make it easier to spot mistakes in big files.

Neil
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 06 Nov 1998 08:56:40 -0500

> just like gcc does. This would make it easier to spot mistakes in big files.

Thanks for the idea Neil, I will add this to the TODO list:

  - Investigate reporting file, and line number when issuing error messages.
    Note that some commands are generated by modules, on pipes and in
    these cases it could be a little tricky figuring out where the command
    came from, and it doesn't really have a line number.

--
Dan Espen                                Phone: (732) 699-5570
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].