Subject: FVWM: Problems with fvwm2

From: Ralph Bigio <[email-masked]>
Date: Tue, 10 Nov 1998 13:44:09 +0000

I am using v2.0.46 under HPUX 10.20, and can't get past 3 problems:

1.	Whenever I try to use the scroll bar, the window locks up.  This
happens when I try to grab the slider, or click in the scroll bar, or
click on the up/down arrows in the bar.  The only way out is to kill the
window and open a new one.

2.	I cannot invoke click-to-focus.  Regardless of focus setting in
.fvwm2 it stays in focus-follows-mouse without auto-raise.  I know I'm
invoking the correct .fvwm2 because the menu buttons are correct.

3.	The only way to raise a window seems to be to click in the top bar. 
I want to be able to click anywhere in a window to raise it.

Any help you can offer would be appreciated.

Thanks

Ralph Bigio

-- 

****************************************************
*
*	Ralph Bigio 
*	Weather Services Centre Halifax (METOC CENTRE)
*
*	[email-masked]
*
*	voice 902-427-0550 ext 6374
*	fax   902-427-6381
*	CSN       447-6374
*
****************************************************
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Wed, 11 Nov 1998 10:02:12 +0100

> window and open a new one.

What scrollbars? Application scrollbars or FvwmScroll scrollbars?

> invoking the correct .fvwm2 because the menu buttons are correct.

Still the config file is usually called .fvwm2rc

> I want to be able to click anywhere in a window to raise it.

No. In the next release it will be possible.

Bye

Dominik
-- 
Dominik Vogt, Hewlett-Packard GmbH, Dept. BVS
Herrenberger Str.130, 71034 Boeblingen, Germany
phone: 07031/14-4596, fax: 07031/14-3883, [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Michael M Han <[email-masked]>
Date: Wed, 11 Nov 1998 09:51:46 -0800

Previously...
<snip>
>No. In the next release it will be possible.

Eh? This is the behavior defined by the pairs:
ClickToFocusRaises/ClickToFocusDoesntRaise
&
MouseFocusClickRaises/MouseFocusClickDoesntRaise
which are GlobalOpts. See the fvwm2 manpage... unless you're using
fvwm1. Don't know about SloppyFocus, though...
_________
mike ([email-masked])
I will not do anything bad ever again
 - The collected wisdom of Bart Simpson
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Wed, 11 Nov 1998 19:39:03 +0100

> fvwm1. Don't know about SloppyFocus, though...

Not quite. This works only if you use ClickToFocus, not with
the mouse following focus styles. You could wand to have
autofocus and still raise windows by clicking in the application
part of the window (in fact I use it and I love it).

Bye

Dominik

---

From: Michael Tiefenback <[email-masked]>
Date: Wed, 11 Nov 1998 15:47:45 -0500 (EST)

The "How do I enable click to raise" issue has been mentioned a few times
in recent days.  I use the following mouse binding:

Mouse 1         W       M       RaiseLower

to enable <Alt>-Button1 as a RaiseLower mechanism.  Such things can fail
if the application also wants to use this as an input mechanism from the
user.  I ran into this one when one application failed to run with "Cannot
access private resource" errors (I don't remember the exact syntax).  It
was educational, at least.  I hope this isn't entirely a waste of
bandwidth. 

Michael Tiefenback