Subject: FVWM: Patch to fix bug on IRIX 6.5

From: Derek Ney <[email-masked]>
Date: Tue, 10 Nov 1998 15:17:29 -0500

The variable PPosOverride is declared as "Boolean" in fvwm.c, but is
referenced as "extern Bool" in other files. This causes a bus error on
IRIX machines. Enclosed is a patch to fixup fvwm.c and simply change
the variable to be declared as "Bool" which fixes the problem. This is
for fvwm-2.0.46.

*** fvwm/fvwm.c.orig    Tue Nov 10 15:14:36 1998
--- fvwm/fvwm.c Tue Nov 10 15:14:52 1998
***************
*** 84,90 ****
  Window JunkRoot, JunkChild;           /* junk window */
  unsigned int JunkWidth, JunkHeight, JunkBW, JunkDepth, JunkMask;

! Boolean debugging = False,PPosOverride,Blackout = False;

  char **g_argv;
  int g_argc;
--- 84,92 ----
  Window JunkRoot, JunkChild;           /* junk window */
  unsigned int JunkWidth, JunkHeight, JunkBW, JunkDepth, JunkMask;

! Boolean debugging = False;
! Bool PPosOverride;
! Boolean Blackout = False;

  char **g_argv;
  int g_argc;

--
-Derek
[email-masked]

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Bob Woodside <[email-masked]>
Date: Tue, 10 Nov 1998 21:33:57 -0500 (EST)

Derek Ney <[email-masked]> wrote:
> IRIX machines. Enclosed is a patch....

	Good catch.

	FYI, this is fixed in the latest development source tree, so the
next formal release (Real Soon Now, I hope) will carry the correction.
It's the inverse of your patch, though. It seems that somebody did an
exercise in resolving the Bool/Boolean discrepancies, and changed all
the *other* declarations to "Boolean".

- Bob

---

From: Bob Mende Pie <[email-masked]>
Date: Tue, 10 Nov 1998 18:35:39 -0800 (PST)

> Date: Tue, 10 Nov 1998 21:33:57 -0500 (EST)
> Cc: [email-masked]
> From: Bob Woodside <[email-masked]>
> Organization: Woodsway Consulting
> X-Mailer: Ishmail 1.3.2-970722-linux <http://www.ishmail.com>
> MIME-Version: 1.0
> Content-Type: text/plain
> Sender: [email-masked]
> Precedence: list
> X-Majordomo: 1.94.jlt7
> 

I submitted this bug about 2 1/2 years ago :-) ... sigh.

btw:  If anyone else has an SGI O2 with the dual channel display, talk to
     me.  I have some very rough patches to deal with the 1280x2048 screen
     as 2 mostly sepearate entieies.

                    /Bob...                    mailto:[email-masked]
              http://reality.sgi.com/mende            KF6EID