Subject: Re: FVWM: How do you run fvwm?

From: [email-masked]
Date: Tue, 6 Oct 98 15:40:52 +0000

Hello,

   Well I am running redhat 4.2 with the source of 2.0.35 and I am actually
trying to run fvwm95-2.
If you could send me a script I would greatly appreciate it.

The paths of my files are

#! /bin/sh
/usr/X11R6/bin/xterm
/usr/X11R6/bin/xbiff
exec /usr/lib/X11/fvwm95-2

Thanks for your help in this matter....

Bregards,

Joe Fialkowski
[email-masked]

> On Tue, 6 Oct 1998 09:33:30 -0500 (CDT)
> Phil Romig <[email-masked]> 
> wrote concerning 'Re: FVWM: How do you run fvwm?':
> > > 
> > > I have installed and done all the makes and etc. Now I have just one
question
> > > which I can't find in the faq's. 
> > > How do you run fvwm?
> > > 
> > > 
> > > Joe Fialkowski
> > > [email-masked]
> > > 
> > 
> > The answer depends a little bit on how X is installed on your system.
> > For most people you need a startup file, and the last thing in the
> > startup file should be the command to run fvwm.  A typically startup
> > file might look like this:
> > 
> >    #! /bin/sh
> >    /usr/X11R6/bin/xterm
> >    /usr/X11R6/bin/xbiff
> >    exec /usr/local/bin/fvwm2
> 
> 
> You'll need to put all clients except the last one in the background.
> 
> 
> > Of course you will need to adjust the paths to point to where your
> > X11 and fvwm are stored.
> 
> Or better, just let your environment and $PATH handle it. So a trivial
> startup script would be:
> 
>   xterm &
>   xbiff &
>   fvwm2
> 
> When X starts this script is executed. When the script finishes X quits,
> so all client should be in the background, except the last one, which
> is typically the window manager. So doing a quit from the wm quits X. 
> 
> 
> > This startup file typically needs to be called EITHER: .xsession or
> > .xinitrc (both would go in your home directory).
> 
> 
> You can start X by running xinit, which looks for .xinitrc. However,
> it is generally better to run a script which sets up the X environment
> correctly before calling xinit. On many linux distributions this script
> is called startx, and looks for a file called .Xclients.
> 
> If you wish I can send a copy of a simplified startx script I wrote
> for my own use.
> 
> If xdm is running, it will usually look for .xsession, so you
> should use that instead if running xdm.
> 
> If none of this works for you let me know what platform(s) you are
> using and I'll try to give more specific advice.
> 
> Ric
> 
> Richard J Lister, Georgetown Institute for Cognitive and Computational
Sciences
> Georgetown University Medical Center, Washington, DC 20007, USA
> Phone: +1 202-687 2878
> Email: [email-masked] 
> Web: http://www.giccs.georgetown.edu/~ric/

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Richard Lister <[email-masked]>
Date: Tue, 06 Oct 1998 11:54:30 -0400

On Tue, 6 Oct 98 15:40:52 +0000
[email-masked] 
> exec /usr/lib/X11/fvwm95-2

Joseph

OK, I have RedHat 4.2 here, as well. You already have startx, in
/usr/X11R6/bin.

1. Make sure /usr/X11R6/bin is in your PATH.
2. Edit ~/.Xclients to look like this:
    #!/bin/sh
    xterm &
    xbiff &
    twm

and type startx.

twm is another window manager that will always be there. If this works
we have a good start.

3. Now find the executable for fvwm95-2. /usr/lib/X11 is a strange place
for the executable to live. Are you sure it isn't in /usr/bin/X11
(which is, in fact, just a symlink to /usr/X11R6/bin)?

Try substituting it for twm:

    #!/bin/sh
    xterm &
    xbiff &
    fvwm95-2

If none of this works send me the error messages and I'll try and figure
out what went wrong.

Also, if you like, take a look at /usr/X11R6/bin/startx to see what it
is doing. I'll send a copy of my simplified version later on when I have
some more time.

Ric

Richard J Lister, Georgetown Institute for Cognitive and Computational Sciences