Subject: FVWM: fvwm instead of cde on hp

From: [email-masked]
Date: Tue, 29 Sep 1998 15:05:18 -0400 (EDT)

I'm temporarily working on an HP unix box which is running the CDE window
manager.  I've installed FVWM but I can't figure out how to get it to run 
instead of CDE (on my IBM I just type startx and it works).  Can any HP 
users out there tell me how to run FVWM instead of CDE?

Thanks,
Greg

_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/
_/ Gregory J. Wawro                 [email-masked]    _/
_/ Assistant Professor              phone:  212/854-8540  _/
_/ Department of Political Science  fax:    212/222-0598  _/
_/ 741 International Affairs                              _/
_/ Columbia University                                    _/
_/ New York, NY 10027                                     _/
_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/_/

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: ajam <[email-masked]>
Date: Tue, 29 Sep 1998 17:48:13 -0400

Doesn't it have the main "xinit" file and/or the local ".xinitrc" file,
where you only have to change at the end of the file something like "cde" or
"cdewm" to "fvwm"?  Just fo a search (i.e. find / -name xinit -print) for
them.  Good luck!

Regards, ajam
www.ajam.org
  ------------------------------------------------------------------------

---

From: "Robert A. Nader" <[email-masked]>
Date: Wed, 30 Sep 1998 06:56:15 +0300 (GMT+3)

Hi,

On Solaris CDE, the trick I use is to configure ~/.dtprofile to
run an XDM session instead of a DT session; that's cause around here
they do not have fvwm in the session options of the CDE login mennu
(yet :) ...

So, at the end of your ~/.dtprofile, place something like:

# ekxran - yes, please do source my .bash_profile <- .profile anyway!
DTSOURCEPROFILE=true
 
export SESSIONTYPE="xdm"
export SDT_ALT_SESSION="$HOME/.xsession"
export SDT_ALT_HELLO="/usr/openwin/bin/xsetroot -default &"

And setup your ~/.xsession something like:

screens=`xdpyinfo | grep screens | awk '{print $4}'`
if [ $screens -eq 2 ] ; then
    hostname=`uname -n`
    export DISPLAY=${hostname}:0.1
    fvwm2 -s -f $HOME/.fvwm2rc.0.1 &
    export DISPLAY=${hostname}:0.0
    fvwm2 -s -f $HOME/.fvwm2rc.0.0 
else
    fvwm2
fi

HTH,

	Rob -

-- 
Robert A. Nader
Phone: 873-3687
Email: [email-masked]
Geophysical Data Processing Division - EXPEC - ARAMCO
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Richard Lister <[email-masked]>
Date: Wed, 30 Sep 1998 10:09:39 -0400

On Tue, 29 Sep 1998 15:05:18 -0400 (EDT)
[email-masked] 

Greg

See the FAQ at the fvwm home page.

Ric

Richard J Lister, Georgetown Institute for Cognitive and Computational Sciences
Georgetown University Medical Center, Washington, DC 20007, USA
Phone: +1 202-687 2878
Email: [email-masked] 
Web: http://www.giccs.georgetown.edu/~ric/
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].