Subject: FVWM: hiding things from pages

From: Neil Zanella <[email-masked]>
Date: Tue, 8 Sep 1998 14:28:52 -0230 (NDT)

Hello,

I would like to hide things from the FvwmPager in a similar manner in which
one hides things from FvwmWinList with the (? WindowSkip ?) Style option.
Objects falling into this category wold be sicky clocks and the buttonbox 
module I have checked the FvwmPager man pages but found nothing there.
Does anyon know of a solution. If this feature has not ye been implemened then 
it would certainly be a nice add-on.

Neil
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Lee Willis <[email-masked]>
Date: 10 Sep 1998 15:18:31 +0100

> one hides things from FvwmWinList with the (? WindowSkip ?) Style option.

OK this isn't intended in any way to be a 'proper' feature but it might
help you for now. All it does is ban from the Pager the same windows
that are banned from the windowlist. Quick 'n' dirty.

Apologies if the patch doesn't apply, but I'm not used to doing them
(Any hints gratefully accepted :)

--- old/FvwmPager.c	Thu Sep 10 15:08:43 1998
+++ FvwmPager.c	Thu Sep 10 15:07:14 1998
@@ -307,6 +307,7 @@
   PagerWindow *t,**prev;
   int i=0;
   
+ if (!(body[8]&WINDOWLISTSKIP)){
   t = Start;
   prev = &Start;
   while(t!= NULL)
@@ -347,6 +348,7 @@
         (*prev)->back = body[23];
   }
   AddNewWindow(*prev);
+}
 }
 
 /***********************************************************************

Lee.
-- 
Lee Willis
GBDirect Ltd, 27 Park Drive, Heaton, Bradford, UK, BD9 4DS
Tel: +44 (0)1274 772277