Subject: FVWM: Using wingmr-mode.el to edit .fvwmrc

From: Dominic Mitchell <[email-masked]>
Date: 04 Sep 1998 21:23:05 -0400

The following message is a courtesy copy of an article
that has been posted to gnu.emacs.help,comp.emacs as well.

I grabbed on the net wingmr-mode.el which is suppose to be a mode to
edit the .fvwmrc and alike.

It is said to put the following in your .emacs

(setq auto-mode-alist
      (append '(("\\.[A-Za-z]*wm$" . winmgr-mode)
              ("\\.[A-Za-z]*wmrc" . winmgr-mode) 
	      auto-mode-alist)))

(autoload 'winmgr-mode "winmgr-mode"
  "Mode for editing window manager config files")

(add-hook 'winmgr-mode-hook
	  '(lambda ()
	     (font-lock-mode t)
	     (setq font-lock-keywords winmgr-font-lock-keywords)
           (font-lock-fontify-buffer)))

When I tried to byte compile .emacs an error message about the
auto-mode-alist appeared:

file mode specification error: (wrong-type-argument listp auto-mode-alist)

I am using Gnu Emacs-20.3 on Redhat Linux 5.0

Any idea what is wrong with this?

Thanks

-- 
==========================================================
Dominic Mitchell      Email: [email-masked]
Economic Department          mailto:[email-masked]
Queen's University
Kingston, Ontario      
Canada, K7L 3N3	      Running Linux Redhat 5.0	
==========================================================
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Håvard Fosseng <[email-masked]>
Date: Sat, 5 Sep 1998 12:13:15 +0200 (MET DST)

>               ("\\.[A-Za-z]*wmrc" . winmgr-mode) 

[...]

> file mode specification error: (wrong-type-argument listp auto-mode-alist)

Try using this instead, and see if it helps:

(setq auto-mode-alist
      (append '(("\\.[A-Za-z]*wm$" . winmgr-mode)
		("\\.[A-Za-z]*wmrc" . winmgr-mode))
		auto-mode-alist))

Parantheses must balance in emacs lisp. It appears that you have given
append only one argument.

- Håvard Fosseng

-- 
S'il fallait tolérer aux autres tout ce qu'on se permet á soi-même, la
vie ne serait plus tenable.
                     -- Georges Courteline