Subject: FVWM: SmartPlacement for single application?

From: Stef Hoesli Wiederwald <[email-masked]>
Date: Sat, 15 Aug 1998 20:21:41 +0200

I use Fvwm Ver 1.23b. Normaly windows are configured to be user
placeable. But for the gimp this is rather annoying, so I want the
gimp to use SmartPlacement.  I tried

Style "gimp"       SmartPlacement, RandomPlacement

in .fvwmrc but it seems not to be possible to do that. Can this be
accomplished in another way?

Stef
-- 
WebMaster D-CHEM and D-WERK
UNIX and Windows NT administration, SOS-ETH 
ETH Zurich
[email-masked]        http://hoes.li
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Bob Woodside <[email-masked]>
Date: Sun, 16 Aug 1998 08:09:02 -0400 (EDT)

On 15-Aug-98 Stef Hoesli Wiederwald wrote:
> I use Fvwm Ver 1.23b. 

        Whew! I don't think many people would even know where to lay their
hands on a copy of that release. The last Version 1 release was 1.24r. It's
the only one readily available, but no one has done any work on it in years.

> Normaly windows are configured to be user

        Have you looked at your man page for fvwm? I believe you'll find that
the various placement options were global in version 1. You'll need to upgrade
to version 2 to set them via the per-window Style options.

        Also, be aware that this Style spec will only work for the old Motif
version of the Gimp (0.54). The new GTK version uses different window names.

---

From: Stef Hoesli Wiederwald <[email-masked]>
Date: Sun, 16 Aug 1998 16:02:38 +0200

> to version 2 to set them via the per-window Style options.

But I don't like the look and feel of fvwm2. Can I set up fvwm2 in a
way it resembles fvwm?

Stef

---

From: Dan Espen <[email-masked]>
Date: Sun, 16 Aug 1998 10:36:15 -0400

Stef Hoesli Wiederwald <[email-masked]> writes:
> > the various placement options were global in version 1. You'll need to
> > upgrade to version 2 to set them via the per-window Style options.
> 

fvwm2 can be made to look like just about anything you want it to look
like.  Emulating fvwm1 should be no problem at all.

Long ago I made the transition from fvwm1  to fvwm2.  I don't remember
any   particular appearance change.   Is  there something specific you
didn't like?

--
Dan Espen                                Phone: (732) 699-5570
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].