Subject: FVWM: Keybindings are almost OK - the're working

From: imre oolberg <[email-masked]>
Date: Tue, 21 Jul 1998 19:33:24 -0500

Hallo,

Thank you for your advice, i inserted the lines

######################  Key and mouse bindings
##########################M
# Format:M
# Key   keyname context modifiers functionM
# Mouse button  context modifiers functionM
#       ------- ------- --------- --------M
#                  |        |M
#                  |        |- A = AnyM
#                  |        |- C = ControlM
#                  |        |- M = Meta (Esc or Alt)M
#                  |        |- N = NoneM
#                  |        |- S = ShiftM
#                  |M
#                  |- 0-9 = Title bar buttons [1 3 5 7 9    0 8 6 4 2]M
#                  |- A   = Any except buttonsM
#                  |- F   = Frame cornersM
#                  |- I   = IconM
#                  |- R   = Root windowM
#                  |- S   = Sides, top, bottomM
#                  |- T   = Title barM
#                  |- W   = Application windowM
M
# Alt-tab for next window [like CDE]M
Key Tab A       M       Next [*] FocusM
Key Tab A       SM      Prev [*] FocusM
M
# Alt-F4 to close current window [like CDE]M
Key 5  A       M       CloseM
M
# Alt-1 through Alt-4 for changing desktopsM
Key 1   A       M       Desk 0 0M
Key 2   A       M       Desk 0 1M
Key 3   A       M       Desk 0 2M
Key 4   A       M       Desk 0 3M

into system.fvwmrc and alt 1,2,3,4 switch between Desks, and alt-tab
between windows. and i binded alt -5 to close a window.

But, somehow, on the console appears following error text:

fvwm: bad key function: Next in line Key Tab A       M       Next [*]
Focus
fvwm: bad key function: Prev in line Key Tab A       SM      Prev [*]
Focus
fvwm: bad key function: Next in line Key Tab A       M       Next [*]
Focus
fvwm: bad key function: Prev in line Key Tab A       SM      Prev [*]
Focus

though bindings work ?

It is puzzling, isnt it?

Thanks all the same, now it is a lot comfortable to toil around :)
I promise not to bother you people for quite a some time.

Imre

PS

As you have perceived i am not a born english-speaker and in Estonia we
have a spell (or is it a curse) on our nation:

we have common letters like this: õöäü ÕÖÄÜ - it is most probably
clutter on your screen :)

But the point is that somebody told me to experiment with keykodes with
the X-program xev - x event.

So i put following lines into my /var/X11R6/lib/xinit/.Xmodmap

keycode 22 = BackSpace
keycode 21 = grave
keycode 49 = asciitilde

(other definitons could be probaby found in
/usr/X11R6/include/X11/keysymdef.h in my case - Slackware 3.4)

If you find it useful too, i am gled. My borrowed two cents, maybe,
maybe not.

And if somebody knows a place where to LEARN how an character is taken
from a keybouard and is put onto a screen (be it termnal or X terminal)
i would be most greatful. Just to try and err is human but .... sad.

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Chuck O'Donnell" <[email-masked]>
Date: Tue, 21 Jul 1998 12:55:39 -0400 (EDT)

On Tue, 21 Jul 1998, imre oolberg wrote:

> fvwm: bad key function: Next in line Key Tab A  M Next [*] Focus
> fvwm: bad key function: Prev in line Key Tab A SM Prev [*] Focus
> fvwm: bad key function: Next in line Key Tab A  M Next [*] Focus
> fvwm: bad key function: Prev in line Key Tab A SM Prev [*] Focus
> 
> though bindings work ?
> 
> It is puzzling, isnt it?
> 

Which version of Fvwm are you using? I don't get those error messages
on ver. 2.0.46

Thanks.

Chuck