Subject: FVWM: Cursor -X; Desk Exec Wait

From: imre oolberg <[email-masked]>
Date: Tue, 21 Jul 1998 09:28:43 -0500

Hi,

thanks a lot, now i am saticfied.
xsetroot -cursor_name hand2
works good for my for now :)
and also i discowered a bitmap program. It eeds aom efuther attention, i
will pay it to it :)

But, i played with the system.fvwmrc file like this

Desk 0 1
Exec netscape &
Wait netscape

Desk 0 2
Exec soffice &
Wait soffice

(of cousre not exactly as i provide them here)

and they ar not behaving like xterms would be in their place.
it seems they dislike the Wait.

Does this mean that i should upgrade to fvwm2 or i am just stupid or
both ?

Imre Oolberg

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Sam Krishnabhat <[email-masked]>
Date: Tue, 21 Jul 1998 05:09:42 -0700 (PDT)

imre oolberg sez...
> xsetroot -cursor_name hand2
                        ^^^^^ Where do I get the documentation on these
different cursor types or PIXMAP files for that matter. Which directory
does it choose these pictures from ?

-sam

---

From: imre oolberg <[email-masked]>
Date: Tue, 21 Jul 1998 15:24:15 -0500

> does it choose these pictures from ?

  I found (with the command locate cursor:) the magical file to be named
/usr/X11R6/include/X11/cursorfont.h
or at least valid names i tried randomly are likley to be:

#define XC_num_glyphs 154
#define XC_X_cursor 0
#define XC_arrow 2
#define XC_based_arrow_down 4
#define XC_based_arrow_up 6
#define XC_boat 8
#define XC_bogosity 10
#define XC_bottom_left_corner 12
#define XC_bottom_right_corner 14
#define XC_bottom_side 16
#define XC_bottom_tee 18
#define XC_box_spiral 20
#define XC_center_ptr 22
#define XC_circle 24
#define XC_clock 26
#define XC_coffee_mug 28
#define XC_cross 30
#define XC_cross_reverse 32
#define XC_crosshair 34
#define XC_diamond_cross 36
#define XC_dot 38
#define XC_dotbox 40
#define XC_double_arrow 42
#define XC_draft_large 44
#define XC_draft_small 46
#define XC_draped_box 48
#define XC_exchange 50
#define XC_fleur 52
#define XC_gobbler 54
#define XC_gumby 56
#define XC_hand1 58
#define XC_hand2 60
#define XC_heart 62
#define XC_icon 64
#define XC_iron_cross 66
#define XC_left_ptr 68
#define XC_left_side 70
#define XC_left_tee 72
#define XC_leftbutton 74
#define XC_ll_angle 76
#define XC_lr_angle 78
#define XC_man 80
#define XC_middlebutton 82
#define XC_mouse 84
#define XC_pencil 86
#define XC_pirate 88
#define XC_plus 90
#define XC_question_arrow 92
#define XC_right_ptr 94
#define XC_right_side 96
#define XC_right_tee 98
#define XC_rightbutton 100
#define XC_rtl_logo 102
#define XC_sailboat 104
#define XC_sb_down_arrow 106
#define XC_sb_h_double_arrow 108
#define XC_sb_left_arrow 110
#define XC_sb_right_arrow 112
#define XC_sb_up_arrow 114
#define XC_sb_v_double_arrow 116
#define XC_shuttle 118
#define XC_sizing 120
#define XC_spider 122
#define XC_spraycan 124
#define XC_star 126
#define XC_target 128
#define XC_tcross 130
#define XC_top_left_arrow 132
#define XC_top_left_corner 134
#define XC_top_right_corner 136
#define XC_top_side 138
#define XC_top_tee 140
#define XC_trek 142
#define XC_ul_angle 144
#define XC_umbrella 146
#define XC_ur_angle 148
#define XC_watch 150
#define XC_xterm 152

Best regards, Imre

---

From: Bob Woodside <[email-masked]>
Date: Tue, 21 Jul 1998 08:33:39 -0400 (EDT)

> does it choose these pictures from ?

        Check the man page for xsetroot, then look at cursorfont.h (wherever
your X11 includes live). xsetroot uses the names defined there (minus the
leading "XC_").