Subject: Re: FVWM: Is it possible to switch to a particular window in a desktop with a hot key

From: "A. van Werven" <[email-masked]>
Date: Wed, 1 Jul 1998 13:36:46 +0200 (DST)

Near 2000, Sam Krishnabhat mumbled something about:

> In other words, say I have 9 screens configured in my desktop 0. Is it possible
> for me to say "Meta 1" to switch to 1st screen TO "Meta 9" to switch to 9th screen.

Excerpt from my very own .fvwm2rc (edit as desired):

Key F1     A M GotoPage 0 0
Key F2     A M GotoPage 1 0
Key F3     A M GotoPage 2 0
Key F4     A M GotoPage 0 1
Key F5     A M GotoPage 1 1
Key F6     A M GotoPage 2 1
Key F7     A M GotoPage 0 2
Key F8     A M GotoPage 1 2
Key F9     A M GotoPage 2 2
Key F10    A M Exec (rxvt -ls -fg red -bg black -scale T -pixmap /home/avwerven/etc/pixmaps/Laura.xpm &)
Key F11    A M Exec (viewlock &)
Key F12    A M Quit
Key Escape A M Exec (xsetroot -solid black &)

Hope this helps,

P.S. In reply to one of the other messages

I found this in my .fvwm2rc file as well:
*FvwmPagerGeometry  -0+0
So I only use the Geometry for the pager location, not for its size.

-- 

A. van Werven
Dept. of Computer Science, Leiden University, The Netherlands
E-mail: [email-masked]
URL: http://www.wi.leidenuniv.nl/~avwerven

Life would be easier if I had the source code. 

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Bob Mende Pie <[email-masked]>
Date: Wed, 1 Jul 1998 08:19:27 -0700 (PDT)

I think the following fvwm functions will do what you want.   Just a little
bit of background.   I run fvwm with 9 pages, arranged in a 3x3 grid.  I
have EdgeResistance 10000 10000, all page and desktops changes have to be
done via these macros.

I have setup the keypad so that <ALT>KP_[1-9] move me to a page on the
current desktop.   The <SHIFT> modifier to this switches me between desks.
(note that I use desks 0-9).   The <CTRL> modifier has the effect of
dragging the window that I am currently in with me to the new page/desk.   
I do not have page/desk access on a single keyset with the exception of
desk 0, page 0.

### Keypad 
Key KP_Insert	A	M	GotoPageDesk 0 0 0		# 0
Key KP_0	A	M	GotoPageDesk 0 0 0		# 0
Key KP_End	A	M	GotoPage 0 2			# 1
Key KP_1	A	M	GotoPage 0 2			# 1
Key KP_Down	A	M	GotoPage 1 2			# 2
Key KP_2	A	M	GotoPage 1 2			# 2
Key KP_Next	A	M	GotoPage 2 2			# 3
Key KP_3	A	M	GotoPage 2 2			# 3
Key KP_Left	A	M	GotoPage 0 1			# 4
Key KP_4	A	M	GotoPage 0 1			# 4
Key KP_Begin	A	M	GotoPage 1 1			# 5
Key KP_5	A	M	GotoPage 1 1			# 5
Key KP_Right	A	M	GotoPage 2 1			# 6
Key KP_6	A	M	GotoPage 2 1			# 6
Key KP_Home	A	M	GotoPage 0 0			# 7
Key KP_7	A	M	GotoPage 0 0			# 7
Key KP_Up	A	M	GotoPage 1 0			# 8
Key KP_8	A	M	GotoPage 1 0			# 8
Key KP_Prior	A	M	GotoPage 2 0			# 9
Key KP_9	A	M	GotoPage 2 0			# 9

Key KP_Insert	WTSF	CM	StickPageDesk 0 0 0		# 0
Key KP_0	WTSF	CM	StickPageDesk 0 0 0		# 0
Key KP_End	WTSF	CM	StickPage 0 2			# 1
Key KP_1	WTSF	CM	StickPage 0 2			# 1
Key KP_Down	WTSF	CM	StickPage 1 2			# 2
Key KP_2	WTSF	CM	StickPage 1 2			# 2
Key KP_Next	WTSF	CM	StickPage 2 2			# 3
Key KP_3	WTSF	CM	StickPage 2 2			# 3
Key KP_Left	WTSF	CM	StickPage 0 1			# 4
Key KP_4	WTSF	CM	StickPage 0 1			# 4
Key KP_Begin	WTSF	CM	StickPage 1 1			# 5
Key KP_5	WTSF	CM	StickPage 1 1			# 5
Key KP_Right	WTSF	CM	StickPage 2 1			# 6
Key KP_6	WTSF	CM	StickPage 2 1			# 6
Key KP_Home	WTSF	CM	StickPage 0 0			# 7
Key KP_7	WTSF	CM	StickPage 0 0			# 7
Key KP_Up	WTSF	CM	StickPage 1 0			# 8
Key KP_8	WTSF	CM	StickPage 1 0			# 8
Key KP_Prior	WTSF	CM	StickPage 2 0			# 9
Key KP_9	WTSF	CM	StickPage 2 0			# 9

Key KP_Insert	A	SM	Desk 0 0			# 0
Key KP_0	A	SM	Desk 0 0			# 0
Key KP_End	A	SM	Desk 0 1			# 1
Key KP_1	A	SM	Desk 0 1			# 1
Key KP_Down	A	SM	Desk 0 2			# 2
Key KP_2	A	SM	Desk 0 2			# 2
Key KP_Next	A	SM	Desk 0 3			# 3
Key KP_3	A	SM	Desk 0 3			# 3
Key KP_Left	A	SM	Desk 0 4			# 4
Key KP_4	A	SM	Desk 0 4			# 4
Key KP_Begin	A	SM	Desk 0 5			# 5
Key KP_5	A	SM	Desk 0 5			# 5
Key KP_Right	A	SM	Desk 0 6			# 6
Key KP_6	A	SM	Desk 0 6			# 6
Key KP_Home	A	SM	Desk 0 7			# 7
Key KP_7	A	SM	Desk 0 7			# 7
Key KP_Up	A	SM	Desk 0 8			# 8
Key KP_8	A	SM	Desk 0 8			# 8
Key KP_Prior	A	SM	Desk 0 9			# 9
Key KP_9	A	SM	Desk 0 9			# 9

Key KP_Insert	WTSF	CSM	StickDesk 0			# 0
Key KP_0	WTSF	CSM	StickDesk 0			# 0
Key KP_End	WTSF	CSM	StickDesk 1			# 1
Key KP_1	WTSF	CSM	StickDesk 1			# 1
Key KP_Down	WTSF	CSM	StickDesk 2			# 2
Key KP_2	WTSF	CSM	StickDesk 2			# 2
Key KP_Next	WTSF	CSM	StickDesk 3			# 3
Key KP_3	WTSF	CSM	StickDesk 3			# 3
Key KP_Left	WTSF	CSM	StickDesk 4			# 4
Key KP_4	WTSF	CSM	StickDesk 4			# 4
Key KP_Begin	WTSF	CSM	StickDesk 5			# 5
Key KP_5	WTSF	CSM	StickDesk 5			# 5
Key KP_Right	WTSF	CSM	StickDesk 6			# 6
Key KP_6	WTSF	CSM	StickDesk 6			# 6
Key KP_Home	WTSF	CSM	StickDesk 7			# 7
Key KP_7	WTSF	CSM	StickDesk 7			# 7
Key KP_Up	WTSF	CSM	StickDesk 8			# 8
Key KP_8	WTSF	CSM	StickDesk 8			# 8
Key KP_Prior	WTSF	CSM	StickDesk 9			# 9
Key KP_9	WTSF	CSM	StickDesk 9			# 9

AddToFunc GotoPageDesk		"I" Desk 0 $2
+				"I" GotoPage $0 $1

AddToFunc StickDesk		"I" Stick
+				"I" Desk 0 $0
+				"I" Stick

AddToFunc StickPage		"I" Stick
+				"I" GotoPage $0 $1
+				"I" Stick

AddToFunc StickPageDesk		"I" Stick
+				"I" GotoPageDesk $0 $1 $2
+				"I" Stick

                    /Bob...                    mailto:[email-masked]
              http://reality.sgi.com/mende            KF6EID
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].