Subject: FVWM: FVWM

From: "Mendoza, Sheila" <[email-masked]>
Date: 24 Jul 1998 10:46:43 U

Hi my name is Sheila Mendoza, from Boeing in Huntington Beach, CA.
I work with Ted Ramsdell.

My boss has assigned me the task of making sure all of our COTS s/w that were
are using on our deliverable product is Y2K compliant.  I was wondering if you
could fax me a statement on the FVWM V1.24r that we are using saying that it IS
Y2K compliant, it IS NOT Y2K compliant, or it is N/A.   

You can fax this statement to 714-372-0572.  A e-mail message is not going to be
acceptable to our customer, according to my manager.  So if you could mail or
fax a statement that would be appreciated.

Sheila Mendoza
Boeing
5301 Bolsa Ave.
H46S   A505
Huntington Beach, CA 92647
714-372-0624
[email-masked]

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Randall S. Winchester" <[email-masked]>
Date: Fri, 24 Jul 1998 14:05:25 -0400 (EDT)

On 24 Jul 1998, Mendoza, Sheila wrote:

: Hi my name is Sheila Mendoza, from Boeing in Huntington Beach, CA.
: I work with Ted Ramsdell.
: 
: My boss has assigned me the task of making sure all of our COTS s/w that were
: are using on our deliverable product is Y2K compliant.  I was wondering if you
: could fax me a statement on the FVWM V1.24r that we are using saying that it IS
: Y2K compliant, it IS NOT Y2K compliant, or it is N/A.   
: 
: You can fax this statement to 714-372-0572.  A e-mail message is not going to be
: acceptable to our customer, according to my manager.  So if you could mail or
: fax a statement that would be appreciated.
: 
: Sheila Mendoza
: Boeing
: 5301 Bolsa Ave.
: H46S   A505
: Huntington Beach, CA 92647
: 714-372-0624
: [email-masked]
: 

Cool, can anybody send you a FAX? Stupid managers... 

If it will make Ted happy, I am sure lots of the people on this public
domain (and supported) software list could FAX him a big "sure".

"Paranoia is the height of awareness"
Charles Manson (who was highly aware)

Randall

---

From: brian moore <[email-masked]>
Date: Fri, 24 Jul 1998 11:16:22 -0700

> I work with Ted Ramsdell.

Um, okay.  Who is 'Ted Ramsdell' and why should I care?

> My boss has assigned me the task of making sure all of our COTS s/w
> that were are using on our deliverable product is Y2K compliant.  I
> was wondering if you could fax me a statement on the FVWM V1.24r
> that we are using saying that it IS Y2K compliant, it IS NOT Y2K
> compliant, or it is N/A. 

It is as Y2k compliant as your pencil.  Perhaps more so, even.

> You can fax this statement to 714-372-0572.  A e-mail message is not
> going to be acceptable to our customer, according to my manager.  So
> if you could mail or fax a statement that would be appreciated.

You're kidding, right?

You have the source: you can certainly look for any attempts in the code
to determine the date or manipulate and compare it in any way.

-- 
Brian Moore                             Kill A Spammer For Jesus
Sysadmin, C/Perl Hacker, Usenet Vandal 
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Vikas Agnihotri <[email-masked]>
Date: Fri, 24 Jul 1998 14:22:57 -0400

On Fri, Jul 24, 1998 at 10:46:43AM +0000, Mendoza, Sheila wrote:

> My boss has assigned me the task of making sure all of our COTS s/w that
> were are using on our deliverable product is Y2K compliant.  I was
> wondering if you could fax me a statement on the FVWM V1.24r that we are
> using saying that it IS Y2K compliant, it IS NOT Y2K compliant, or it is
> N/A.   

(sigh) What should we do with these people?

Vikas

---

From: Peter S Galbraith <[email-masked]>
Date: Fri, 24 Jul 1998 14:53:40 -0400

> (sigh) What should we do with these people?

Her boss, Ted, wants someone to blame (and perhaps sue) if a free product
that they include in their perhaps profit-making delivable product IS NOT
Y2K compliant.  Random email is just not good enough.

Man, does the open-source community have to ways to go before the rest of
the world understands.

--

A few months ago, someone from our organisation called me up because I was
listed as a user of some software she had to make sure was Y2K compliant.
The software was TeX, and she inquired whether I had web links or hard
paper documentation that could show TeX to be Y2K compliant.  She was going
through an exhaustive list of software we happen to use.  Can you believe
that? 

Peter

---

From: Karl & Betty Schendel <[email-masked]>
Date: Fri, 24 Jul 1998 16:20:08 -0400

> (sigh) What should we do with these people?

I suppose one shouldn't be too hard on Ms Mendoza, who at least has some
command of the English language (I note with approval the non-use of
the hideous "I have been tasked with ...").  Perhaps she can use those
same skills to convince her boss that requesting a compliance statement
about an open-source program is meaningless at best and idiotic at worst.

Karl R. Schendel, Jr.
K/B Computer Associates   [email-masked]
Ingres and Unix Expertise

NAIUA Vice President      [email-masked]

---

From: Nils Lohner <[email-masked]>
Date: Fri, 24 Jul 1998 16:00:10 -0400

In message <[email-masked]>, Peter S Galbraith 
>Y2K compliant.  Random email is just not good enough.

  Seriously, though... what if a 747 with FVWM2 installed in the cockpit 
crashes?  Maybe if we rewrote it in COBOL real quick... :)

rotfl,
Nils.

---

From: "Randall S. Winchester" <[email-masked]>
Date: Sat, 25 Jul 1998 13:03:27 -0400 (EDT)

Dispite the Friday-humor, your point is well taken. Many of us have our own,
at times silly, Year-2000 policies. Not that y2k is not important, just the
policies that get written by the confused. Oh, well..

The upcoming FVWM-2 release should have a y2k seal. It should be tested
against the various y2k relevant dates on a computer that is y2k compliant.

Doing anything for FVWM V1.24r, however seems a little late in the game (in
my opinion). I just looked at my own source trees, and the oldest version I
have around is in fact, "FVWM V1.24r" with a date of "Jun 14 1995". It is
what is runnning on our non-y2k machines, that we will be replacing. However
the few places in the code where time is used are in "ctime" which is y2k
compliant. Your group should be able to verify it themselves though.

Fvwm-workers, Can we have a README.Y2K or similar for the official release?

Randall

On Fri, 24 Jul 1998, Randall S. Winchester wrote:

: On 24 Jul 1998, Mendoza, Sheila wrote:
: 
: : Hi my name is Sheila Mendoza, from Boeing in Huntington Beach, CA.
: : I work with Ted Ramsdell.
: : 
: : My boss has assigned me the task of making sure all of our COTS s/w that were
: : are using on our deliverable product is Y2K compliant.  I was wondering if you
: : could fax me a statement on the FVWM V1.24r that we are using saying that it IS
: : Y2K compliant, it IS NOT Y2K compliant, or it is N/A.   
: : 
: : You can fax this statement to 714-372-0572.  A e-mail message is not going to be
: : acceptable to our customer, according to my manager.  So if you could mail or
: : fax a statement that would be appreciated.
: : 
: : Sheila Mendoza
: : Boeing
: : 5301 Bolsa Ave.
: : H46S   A505
: : Huntington Beach, CA 92647
: : 714-372-0624
: : [email-masked]
: : 
: 
: Cool, can anybody send you a FAX? Stupid managers... 
: 
: If it will make Ted happy, I am sure lots of the people on this public
: domain (and supported) software list could FAX him a big "sure".
: 
: "Paranoia is the height of awareness"
: Charles Manson (who was highly aware)
: 
: Randall
: 
: 
: --
: Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
: To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
: message to [email-masked].
: To report problems, send mail to [email-masked].
:

---

From: brian moore <[email-masked]>
Date: Sat, 25 Jul 1998 12:22:09 -0700

> against the various y2k relevant dates on a computer that is y2k compliant.

It doesn't even need to be tested.  Try 'grep time' in your src directory
and see what fvwm does with times.  (Hint: the vast majority of references
are in comments like 'check this 3 times', the rest are timestamps of X
events or timeval's for select().)

> compliant. Your group should be able to verify it themselves though.

[durin:~/fvwm-2.0.46/fvwm] 244 % grep ctime *.[ch]
[durin:~/fvwm-2.0.46/fvwm] 245 % 

I see no 'ctime'.  (or localtime or gmtime, for that matter.)

I deleted 1.24 long ago.

> Fvwm-workers, Can we have a README.Y2K or similar for the official release?

Use the one from http://language.perl.com/news/y2k.html, though that
assumes that there -is- an interface for getting the date: fvwm has no
such interface.

It is more Y2k-compliant than a piece of blank paper: Perl (and C and
every other language) is as compliant as a pencil.

I think feeding Y2k compliancy statements to the clueless is a Bad Thing
in that encourages them in thinking that if they send out enough mail to
everyone their system is safe instead of actually thinking about the
problems.

I think avoiding Boeing airplanes for a few days would be a better thing
in that if this is how they ascertain compliance, the planes -will- be
falling out of the sky.

---

From: [email-masked] (Nix)
Date: Sun, 26 Jul 1998 00:00:22 +0100 (BST)

> against the various y2k relevant dates on a computer that is y2k compliant.

If merely because (if the rate of progress over the past three years
has been any guide) it will be past the turn of the millennium by the
time fvwm2 comes out of beta :(

-- 
`It is inelegant and it was hacked on. But it was hacked on with
 careful consideration.' - PLA on perl and OO
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Bob Woodside <[email-masked]>
Date: Sun, 26 Jul 1998 00:05:52 -0400 (EDT)

> crashes?  Maybe if we rewrote it in COBOL real quick... :)

        Dang! Why didn't I think of that? CGWM*, a window manager for the
double-oughts.

       PERFORM MAP-WINDOWS-ON-CURRENT-DESK 
           THRU MAP-WINDOWS-ON-CURRENT-DESK-EXIT
           VARYING I BY 1 FROM 1 TO NUMBER-OF-WINDOWS.

Whew!

    ---------------------------------------
    * The CandyGrammar Window Manager.