Subject: FVWM: HELP PLEASE! Fixing a position of FvwmButtons in WinList.

From: Tigran Aivazian <[email-masked]>
Date: Tue, 16 Jun 1998 10:09:22 +0000 (GMT)

Hello guys,

I managed to configure my fvwm2.0.46 into a very nice and useable desktop
(see my fvwm2rc attached). However, to make it almost absolutely perfect I
need to be able to do the following.

I bound Ctrl-ESC to show WinList so I can select a window from it.
However, the windows in WinList are stacked in a dynamic manner. What I
want is to ensure that a particular thing, e.g. FvwmButtons always appears
on top of the WinList so pressing Ctrl-ESC followed by 1 will always
select FvwmButtons without me having to look at the list find a miniicon I
assigned to it and select it (I got rid of the need to use the mouse
almost - now I want to avoid looking at the screen as well :) ).

Regards,
------
Tigran A. Aivazian           | http://www.sco.com/
Escalations Research Group   | Email: [email-masked]
Santa Cruz Operation Ltd     | 
ModulePath /usr/local/X11R6/lib/X11/fvwm2
PixmapPath /usr/include/X11/pixmaps/:/usr/share/icons:/usr/share/icons/mini:/usr/lib/TkDesk/images/next:/usr/lib/TkDesk/images:/usr/share/textures
IconPath   /usr/include/X11/bitmaps/

#ButtonStyle 1 Pixmap mini-penguin.xpm -- Top Left
ButtonStyle 1 MiniIcon
AddButtonStyle 1 ActiveDown HGradient 8 white DarkOrchid

# Button 4: Minimize (image of large window being shrunk down)
ButtonStyle 4 ActiveUp (12 40x10@1 90x10@1 90x60@0 20x90@0 90x60@0 40x60@0 40x10@1 10x80@1 20x80@1 20x90@0 10x90@0 10x80@1) -- Flat
ButtonStyle 4 ActiveDown (18 40x10@0 90x10@0 90x60@1 20x90@1 90x60@1 40x60@1 40x10@0 10x80@0 20x80@0 20x90@1 10x90@1 01x99@1 01x01@0 99x01@0 99x99@1 01x99@1 10x90@0 10x80@0) -- Flat
ButtonStyle 4 Inactive (12 40x10@1 90x10@1 90x60@0 20x90@0 90x60@0 40x60@0 40x10@1 10x80@1 20x80@1 20x90@0 10x90@0 10x80@1) -- Flat

# Button 2: Maximize (image of window being enlarged)
ButtonStyle 2 ActiveUp (11 90x10@0 90x75@0 25x75@0 60x75@0 60x90@0 10x90@0 10x55@1 25x55@1 25x75@1 25x10@1 90x10@1) -- Flat
ButtonStyle 2 ActiveDown (17 90x10@1 90x75@1 25x75@1 60x75@1 60x90@1 10x90@1 01x99@1 01x01@0 99x01@0 99x99@1 01x99@1 10x90@0 10x55@0 25x55@0 25x75@0 25x10@0 90x10@0) -- Flat
ButtonStyle 2 Inactive (11 90x10@0 90x75@0 25x75@0 60x75@0 60x90@0 10x90@0 10x55@1 25x55@1 25x75@1 25x10@1 90x10@1) -- Flat

ButtonStyle 3 13 26x29@1 34x21@1 50x35@1 70x21@1 79x29@1 63x48@0 79x65@1 70x75@0 50x61@0 34x75@0 26x65@0 44x48@1 26x29@0
ButtonStyle 5 5 25x25@1 25x75@1 75x75@0 75x25@0 25x25@1
ButtonStyle 6 5 40x25@1 60x25@1 60x75@0 40x75@0 40x25@1
ButtonStyle 7 5 45x45@1 55x45@1 55x55@0 45x55@0 45x45@1
ButtonStyle 8 5 40x40@1 60x40@1 60x60@0 40x60@0 40x40@1

# small up triangle
# ButtonStyle 2 4 50x35@1 65x65@0 35x65@0 50x35@1
# small down triangle
# ButtonStyle 4 4 50x65@1 35x35@1 65x35@1 50x65@0

TitleStyle ActiveUp (HGradient 128 2 DarkOrchid 50 white 50 DarkOrchid -- Flat)
TitleStyle ActiveDown (HGradient 128 2 DarkOrchid 50 white 50 DarkOrchid -- Flat) Inactive (HGradient 128 2 #40a0c0 50 white 50 #40a0c0 -- Flat)

EdgeResistance 2000 10
WindowFont		-adobe-times-medium-r-*-*-18-*-*-*-*-*-*-*
IconFont		-adobe-helvetica-medium-r-*-*-10-*-*-*-*-*-*-*
EdgeScroll 100 100
HilightColor black DarkOrchid
DeskTopSize 7x7
MenuStyle black grey grey40 -adobe-times-bold-r-*-*-14-*-*-*-*-*-*-* mwm
ClickTime 150
XORValue 65535
ColormapFocus FollowsMouse

Style "*"           BorderWidth 5, HandleWidth 5,Icon unknown1.xpm,MiniIcon mini-penguin.xpm,Color Black/#40a0c0
Style "*"           ActivePlacement, SmartPlacement,MWMFunctions,MWMDecor,HintOverride,DecorateTransient,IconBox 0 -10 -280 -1
Style "Fvwm*"       NoTitle,NoHandles,Sticky,WindowListSkip,BorderWidth 0,CirculateSkipIcon
Style "FvwmBanner"  StaysOnTop
#Style "FvwmButtons" Title,Handles,WindowListHit,BorderWidth 1,CirculateSkip,Icon toolbox.xpm,MiniIcon mini-chinese.xpm,ClickToFocus
Style "FvwmButtons" Title,Handles,WindowListHit,BorderWidth 1,Icon toolbox.xpm,MiniIcon mini-chinese.xpm,StartIconic
Style "*lock"       NoTitle, NoHandles, Sticky, WindowListSkip,RandomPlacement
Style "xbiff"       NoTitle, Sticky, WindowListSkip,ClickToFocus
Style "Maker"       StartsOnDesk 1,RandomPlacement,ClickToFocus
Style "matlab"      StartsOnDesk 3
Style "signal"      StartsOnDesk 3 
Style "rxvt"        Icon xterm-linux.xpm,SloppyFocus,IconBox -70 1 -1 -140
Style "XTerm"       Icon xterm-linux.xpm,MiniIcon mini-bx2.xpm,SloppyFocus,IconBox -70 1 -1 -140
Style "NXTerm"      Icon xterm-linux.xpm,SloppyFocus,IconBox -70 1 -1 -140
Style "XTerm"       MWMBorder,MWMButtons,Button 3,Button 5
Style "NXTerm"      MWMBorder,MWMButtons,Button 3,Button 5
Style "Appointment" Icon datebook.xpm, NoButton 2, NoButton 4,ClickToFocus
Style "xcalc"       Icon xcalc.xpm,RandomPlacement,ClickToFocus
Style "xmh"         Icon mail1.xpm, NoIconTitle,StickyIcon
Style "xmh"	    RandomPlacement, StartsOnDesk 2, NoButton 2
Style "xman"	    Icon xman.xpm,RandomPlacement,ClickToFocus
Style "xvgr"	    Icon graphs.xpm,RandomPlacement,ClickToFocus
Style "matlab"	    Icon math4.xpm,ClickToFocus
Style "xmag"	    Icon mag_glass.xpm,RandomPlacement, ClickToFocus
Style "xgraph"      Icon graphs.xpm,RandomPlacement,ClickToFocus
Style "sppeed6"     Icon math3.xpm,NoTitle,ClickToFocus
Style "sppeed6_user" Icon math4.xpm,NoTitle
Style "xmosaic"     NoPPosition, color Green/Yellow,ClickToFocus
Style "Netscape"    MiniIcon mini-netscape.xpm
Style "dsk_FileViewer" MiniIcon mini-cabaret.xpm
Style "dsk_Editor"     MiniIcon mini-happy.xpm
Style "XbmBrowser"     MiniIcon mini-rainbow.xpm
Style "Hexcalc"        MiniIcon mini-calc.xpm

Key Left	A	C	Scroll -100 0
Key Right	A	C	Scroll +100 +0
Key Up		A	C	Scroll +0   -100
Key Down	A	C	Scroll +0   +100
Key Left	A	M	Scroll -10 +0
Key Right	A	M	Scroll +10 +0
Key Up		A	M	Scroll +0   -10
Key Down	A	M	Scroll +0   +10
Key Left	A	SC	CursorMove -1 0
Key Right	A	SC	CursorMove +1 +0
Key Up		A	SC	CursorMove +0   -1
Key Down	A	SC	CursorMove +0   +1
Key Left	A	SM	CursorMove -10 +0
Key Right	A	SM	CursorMove +10 +0
Key Up		A	SM	CursorMove +0   -10
Key Down	A	SM	CursorMove +0   +10
#Key KP_F1	A	M	Popup "Utilities"
#Key KP_F2	A	M	Popup "Window-Ops"
#Key KP_F3	A	M	Module FvwmWinList 
#Key KP_F4	A	M	Iconify
Key F4		A	M	Quit
Key Escape	A	M	Next [XTerm] focus
Key Tab		A	C	Next [CurrentDesk *] Focus
Key Tab		A	M	Next [*] focus
Key Escape	A	C	WindowList
Key F1		A	S	Maximize-Func
Key F2		A	S	Iconify
Key F3		A	S	Resize 50 50
Key F4		A	S	Destroy
Key F5		A	S	Next [*] focus
Key F6		A	S	Next [*] focus
Key F7		A	S	Next [CurrentDesk *] focus
Key F8		A	S	Next [CurrentDesk *] focus
Key F9		A	S	Exec nxterm -g 99x36+0+0 -n tigran@newton -ls &
Key F10		A	S	Exec nxterm -g 99x36+0+0  -T root@newton -n root@newton -e su - root &
Key F8		A	C	Exec rxvt -g 99x36+0+0 -n PINE -T PINE -e pine &
Key F9		A	C	Exec rxvt -g 99x36+0+0 -n tigran@newton -ls &
Key F10		A	C	Exec rxvt -g 99x36+0+0  -T root@newton -n root@newton -e su - root &
Key F11		A	C	Exec rxvt -font fixed -g 166x56+0+0  -T "cat /proc/kmsg" -n "cat /proc/kmsg" -e su - root -c cat /proc/kmsg &
Key F11		A	S	Exec rxvt -font fixed -g 166x56+0+0  -T "tail -f messages" -n "tail -f messages" -e su - root -c tail -f /var/log/messages &
Key F11		A	M	Exec rxvt -font fixed -g 166x56+0+0  -T "tail -f maillog" -n "tail -f maillog" -e su - root -c tail -f /var/log/maillog &
Key F1		A	CS	Exec xlock -use3d -nice 10 -mode flag
Key F1		A	C	Stick
Key F2		A	C	Maximize
Key F3		A	C	Iconify
Key F4		A	C	Module FvwmIdent

Mouse 1	R   	A       Menu MainMenu Nop
Mouse 2	R    	A      	Menu Window-Ops Nop
Mouse 3	R    	A      	WindowList
Mouse 0	1    	A      	Menu Window-Ops Close
Mouse 0	2    	A     	Maximize-Func
Mouse 0	3    	A     	Delete
Mouse 0	4    	A     	Iconify
Mouse 0	5    	A     	Close
Mouse 0	6    	A     	WindowList
Mouse 0	7    	A     	Destroy
Mouse 1	F	A	Resize-or-Raise
Mouse 1	TS	A	Move-or-Raise
Mouse 1	I	A	Move-or-Iconify
Mouse 2	I	A	Iconify
Mouse 2	FST	A	Menu Window-Ops2 Nop
Mouse 3	TSIF	A	RaiseLower

########################Initialization Functions ############################
AddToFunc InitFunction 	  "I" Module FvwmButtons
#+	"I" exec xv -root -quit ~/penguins.jpg
#+  "I" exec xsetroot -solid steelblue
+  "I" exec tkdesk &

AddToFunc RestartFunction "I" Module FvwmButtons
+			  "I" exec xsetroot -solid steelblue

DestroyFunc "FocusAndWarp"
AddToFunc   "FocusAndWarp"  "I"       Raise
+ "I"       Focus
+ "I"       Iconify -1
+ "I"       WarpToWindow    50 50

DestroyFunc "RunAndFocus"
AddToFunc   "RunAndFocus"  "I"       Exec $1 $2 $3 $4 $5 $6 $7 $8 $9
+ "I"       Next [$0] FocusAndWarp 

########################Menus ########################################
AddToMenu MainMenu	"Main"	Title 	
+			"New Shell"	Popup	Shells
+			"Screensavers"	Popup Screensavers
+			"Games"		Popup Games
+			"Applications"	Popup Applications
+			"Utilities"	Popup Utilities
+			"Calculator%mini-redhat.xpm%"	Exec  xcalc &
#+          "Mail"          MailFunction xmh "-font fixed"
+			""		Nop
+			"Modules"	Popup Module-Popup
+			""		Nop		
+			"Exit Fvwm"	Popup Quit-Verify

AddToMenu "Shells" "Shells" Title
+ "Bash (xterm)%mini-penguin.xpm%"     Exec nxterm -e bash &
+ "Bash (rxvt)%mini-penguin.xpm%"      Exec rxvt -e bash &
+ "Ksh  (xterm)%mini-term.xpm%"     Exec nxterm -e ksh &
+ "Ksh  (rxvt)%mini-term.xpm%"      Exec rxvt -e ksh &
+ "Csh  (xterm)%mini-term.xpm%"     Exec nxterm -e tcsh &
+ "Csh  (rxvt)%mini-term.xpm%"      Exec rxvt -e tcsh &
+ "Ash  (xterm)%mini-term.xpm%"     Exec nxterm -e ash &
+ "Ash  (rxvt)%mini-term.xpm%"      Exec rxvt -e ash &
+ "Zsh  (xterm)%mini-rainbow.xpm%"     Exec nxterm -e zsh &
+ "Zsh  (rxvt)%mini-rainbow.xpm%"      Exec rxvt -e zsh &
+ ""                                            Nop
+ "MC   (xterm)%mini-recapture.xpm%"     Exec nxterm -e mc -c &
+ "MC   (rxvt)%mini-recapture.xpm%"      Exec rxvt -e mc -c &

AddToMenu "Screensavers" "Screensavers" Title
+ "Linux%mini-penguin.xpm%"     Exec xlock -use3d -nice 10 -mode flag &
+ "Bat%mini-bball.xpm%"         Exec xlock -nolock -nice 0 -mode bat &
+ "Blank%mini-bball.xpm%"       Exec xlock -nolock -nice 0 -mode blank &
+ "Blot%mini-bball.xpm%"        Exec xlock -nolock -nice 0 -mode blot &
+ "Bounce%mini-bball.xpm%"      Exec xlock -nolock -nice 0 -mode bounce &
+ "Flame%mini-bball.xpm%"       Exec xlock -nolock -nice 0 -mode flame &
+ "Galaxy%mini-bball.xpm%"      Exec xlock -nolock -nice 0 -mode galaxy &
+ "Grav%mini-bball.xpm%"        Exec xlock -nolock -nice 0 -mode grav &
+ "Helix%mini-bball.xpm%"       Exec xlock -nolock -nice 0 -mode helix &
+ "Hop%mini-bball.xpm%"         Exec xlock -nolock -nice 0 -mode hop &
+ "Hyper%mini-bball.xpm%"       Exec xlock -nolock -nice 0 -mode hyper &
+ "Kaleid%mini-bball.xpm%"      Exec xlock -nolock -nice 0 -mode kaleid &
+ "Life%mini-bball.xpm%"        Exec xlock -nolock -nice 0 -mode life &
+ "Life3d%mini-bball.xpm%"      Exec xlock -nolock -nice 0 -mode life3d &
+ "Maze%mini-bball.xpm%"        Exec xlock -nolock -nice 0 -mode maze &
+ "Pyro%mini-bball.xpm%"        Exec xlock -nolock -nice 0 -mode pyro &
+ "Qix%mini-bball.xpm%"         Exec xlock -nolock -nice 0 -mode qix &
+ "Random%mini-bball.xpm%"      Exec xlock -nolock -nice 0 -mode random &
+ "Rect%mini-bball.xpm%"        Exec xlock -nolock -nice 0 -mode rect &
+ "Rock%mini-bball.xpm%"        Exec xlock -nolock -nice 0 -mode rock &
+ "Rotor%mini-bball.xpm%"       Exec xlock -nolock -nice 0 -mode rotor &
+ "Sphere%mini-bball.xpm%"      Exec xlock -nolock -nice 0 -mode sphere &
+ "Spline%mini-bball.xpm%"      Exec xlock -nolock -nice 0 -mode spline &
+ "Swarm%mini-bball.xpm%"       Exec xlock -nolock -nice 0 -mode swarm &
+ "Wator%mini-bball.xpm%"       Exec xlock -nolock -nice 0 -mode wator &
+ "Worm%mini-bball.xpm%"        Exec xlock -nolock -nice 0 -mode worm &
+ "World%mini-bball.xpm%"       Exec xlock -nolock -nice 0 -mode world &

AddToMenu "Applications" "Applications" Title
+ "Desktop"			Popup DesktopApps
+ "Publishing"			Popup Publishing
+ "Graphics"			Popup Graphics
+ "Ghostview%mini-gv.xpm%"      Exec ghostview &
+ "Xview%mini-xv.xpm%"          Exec xv &
+ "Textedit%mini-edit.xpm%"     Exec textedit -geometry 630x490+95+5 &
+ "Xedit%mini-edit.xpm%"        Exec xedit &
+ "Xfractint%mini-fractal.xpm%" Exec rxvt -font 7x14 -e xfractint map=chroma &
+ "Xpaint%mini-paint.xpm%"      Exec xpaint &
+ "Xgrab%mini-camera.xpm%"      Exec xgrab &
+ "Xcolormap%mini-colors.xpm%"  Exec xcolormap &
+ "Xxgdb%mini-bug2.xpm%"        Exec xxgdb &

AddToMenu "DesktopApps" "DesktopApps" Title 
+ "Xfm%mini-filemgr.xpm%"		Exec xfm &
+ "Xfilemanager%mini-filemgr.xpm%"	Exec xfilemanagerm &
+ "TkDesk%mini-maze.xpm%"		Exec tkdesk &

AddToMenu "Utilities" "Utilities" Title
+ "Ghostview%mini-gv.xpm%"      Exec ghostview &

AddToMenu "Games" "Games" Title
+ "Maze%mini-maze.xpm%"         Exec maze &
+              "Spider" Exec exec spider &
+ "Workman%mini-cdlabel.xpm%"   Exec exec workman &
+ "Xboard%mini-slon.xpm%"       Exec xboard &
+ "Xeyes%mini-eyes.xpm%"        Exec xeyes &
+ "Xhextris%mini-hextris.xpm%"  Exec exec xhextris &
+              "Xlander" Exec exec xlander &
+ "Xlogo%mini-bx2.xpm%"         Exec xlogo &
+ "Xmahjongg%mini-xmahjongg%"   Exec exec xmahjongg &
+ "Xroach%mini-roach.xpm%"      Exec exec xroach &
+ "Xtetris%mini-tetris.xpm%"    Exec xtetris &
+              "Xvier" Exec exec xvier &

AddToMenu Window-Ops	"Window Ops"	Title
+			"%mini-penguin.xpm%Lock"	Exec xlock -use3d -nice 10 -mode flag
+			"%mini-question.xpm%Id"		Module FvwmIdent
+			"Move"		Move-or-Raise2
+			"Resize"	Resize-or-Raise2
+			"Raise"		Raise
+			"Lower"		Lower 
+		 	"(De)Iconify"	Iconify
+			"(Un)Stick"	Stick		
+			"(Un)Maximize"	maximize_func
+			""		Nop  
+			"Delete"	Delete	 
+			"Close"		Close	 
+			"Destroy"	Destroy
+			""		Nop		
+			"Refresh Screen" Refresh		

AddToMenu Window-Ops2	"Move"		Move-or-Raise
+			"Resize"	Resize-or-Raise
+			"Raise"		Raise   	
+			"Lower"		Lower   	
+			"Iconify"	Iconify 	
+			"(Un)Stick"	Stick		
+			""		Nop     	
+			"Delete"	Delete	
+			"Close"		Close	  	
+			"Destroy"	Destroy 	
+			""		Nop 		
+			"ScrollBar" 	Module FvwmScroll 2 2	
+			"Print"         PrintFunction

#This Menu will fire up some Screen-savers
AddToMenu ScreenSavers "Lock Screen" Title
+              "%mini-xlock.xpm%Screen -> Linux..." Exec exec xlock -use3d -mode flag &
+              "%mini-xlock.xpm%Screen -> Swarm..." Exec exec xlock -mode swarm &
+              "%mini-xlock.xpm%Screen -> Random..." Exec exec xlock -mode random &

AddToMenu Remote-Logins	"newton"	 PopUp Newton-Logins
+			"root" 			PopUp Root-Logins
+			"ulysses"		PopUp Ulysses-Logins
+			"perdita"		PopUp Perdita-Logins
+			"eros"			PopUp Eros-Logins
+			"samson"		PopUp Samson-Logins
+			"jessica"		PopUp Jessica-Logins

AddToMenu Module-Popup	"Modules"	Title	
+			"Button-Bar"	Module	FvwmButtons
+			"Clean-Up"	Module	FvwmClean
+			"Identify"	Module	FvwmIdent
+			"SaveDesktop"	Module  FvwmSave
+			"Debug"		Module	FvwmDebug
+			"Pager"		Module  FvwmPager 0 0
+			"WinList"	Module  FvwmWinList
+			"Background"	Module  FvwmBacker
+			"IconBox"	Module	FvwmIconBox
+			"Banner"	Module	FvwmBanner
+			"Talk"  	Module	FvwmTalk
+			"Tile"  	Module	FvwmTile
+			"Config"  	Module	FvwmConfig
+			"Prompt"	Module	FvwmPrompt "hello" raise

AddToMenu Quit-Verify 	"Really Quit Fvwm?" Title	
+		      	"Yes, Really Quit"  Quit	
+		      	"Restart Fvwm"	    Restart fvwm	
+		      	"Start twm"         Restart twm
+		      	"Start mwm"    	    Restart mwm
+	      	      	"Start olwm"        Restart /usr/openwin/bin/olwm
+		        "Start tvtwm"       Restart vtwm
+		      	"Start dummy"       Restart xterm
+		      	""		    Nop	
+		      	"No, Don't Quit"    Nop	

########################Functions ########################################

AddToFunc MailFunction	   "I" Next [$0] Iconify -1
+		           "I" Next [$0] focus
+			   "I" None [$0] Exec $0 $1

AddToFunc Move-or-Raise		"I" Raise
+				"M" Move
+  				"D" Lower

AddToFunc Move-or-Raise2	"M" Raise
+				"M" Move
+  				"D" Lower

AddToFunc Maximize-Func		"C" Maximize	 100 100
#+				"C" Maximize	 0 80
#+				"D" Maximize	 100 100

AddToFunc Move-or-Iconify	"I" Raise
+				"M" Move
+				"D" Iconify

AddToFunc Resize-or-Raise	"I" Raise
+				"M" Resize
+				"D" Lower

AddToFunc Resize-or-Raise2	"M" Raise
+				"M" Resize
+				"D" Lower

AddToFunc PrintFunction		"I" Raise
+				"I" Exec xdpr -id $w

AddToFunc Iconify-and-Raise     "I" Iconify
+                               "I" Raise

Module FvwmBacker
################## FvwmButtons button-bar ################################
# Colors
#*FvwmButtonsFore Black
#*FvwmButtonsBack #908090
#*FvwmButtonsBack steelblue
*FvwmButtonsFont -adobe-helvetica-bold-r-*-*-12-*-*-*-*-*-*-*
*FvwmButtonsGeometry -1-1
*FvwmButtonsRows 5

*FvwmButtons TkDesk window3d.xpm Exec tkdesk &
*FvwmButtons newton Penguin.xpm Exec "XTerm" nxterm -bg white -fg black -T tigran@newton -ls &
*FvwmButtons root xterm-linux.xpm Exec "XTerm" nxterm -g 94x36+54+0 -C -fg white -bg black -T root@newton -e su - root &
*FvwmButtons telnet checked_monitor.xpm Exec "XTerm" nxterm -g 94x36+54+0 -T telnet -e telnet &
*FvwmButtons tigran-test shell.xpm Exec nxterm -g 94x36+54+0 -T tigran-test -e telnet tigran-test &
*FvwmButtons nova shell.xpm Exec "XTerm" nxterm -g 94x36+54+0 -T nova -e telnet nova &
*FvwmButtons rizzo shell.xpm Exec "XTerm" nxterm -g 94x36+54+0 -T rizzo -e telnet rizzo &
*FvwmButtons beeker galaxy.xpm Exec "XTerm" nxterm -g 94x36+54+0 -bg white -fg black -T beeker -e telnet beeker &
*FvwmButtons buildesc Equation.xpm Exec "XTerm" nxterm -g 94x36+54+0 -bg white -fg black -T buildesc -e telnet buildesc &
*FvwmButtons tyne sealed_document.xpm Exec "XTerm" nxterm -bg white -fg black -T tyne -e telnet tyne &
*FvwmButtons xman xman.xpm Exec xman &
*FvwmButtons hypercube envelope.xpm Exec hypercube &
*FvwmButtons hexcalc gear.xpm Exec hexcalc &
*FvwmButtons xcalc globe.xpm Exec xcalc &
*FvwmButtons xpaint 3dpaint.xpm Exec xpaint &
*FvwmButtons eject monalisa.xpm Exec "rxvt" eject &
*FvwmButtons julia 3D.xpm Exec julia &
*FvwmButtons moire feltpend.xpm Exec julia &
*FvwmButtons sphere nest.xpm Exec sphere &
*FvwmButtons spider hammer_chart.xpm Exec spider &
*FvwmButtons starfish hammer_doc.xpm Exec starfish &
*FvwmButtons strange Beer.xpm Exec strange &
*FvwmButtons sierpinski C-Devel.xpm Exec sierpinski &
*FvwmButtons swirl Camera2.xpm Exec swirl &
*FvwmButtons goop radar.xpm Exec swirl &
*FvwmButtons ifs DarkForest.xpm Exec ifs &
*FvwmButtons LinCity Home.xpm Exec xlincity &
*FvwmButtons xboing World.xpm Exec xboing &
*FvwmButtons xbill Java.xpm Exec xbill &
*FvwmButtons xbl wrench.xpm Exec xbl &
*FvwmButtons xearth pillars.xpm Exec xearth &
*FvwmButtons imsmap dtp.xpm Exec imsmap &
*FvwmButtons ghostview Ghost.xpm Exec ghostview &
*FvwmButtons xsysinfo chip.xpm Exec xsysinfo &
*FvwmButtons scomail next/dialog.xpm Exec "rxvt" rsh tyne /usr/bin/X11/scomail -display 150.126.4.166:0.0 -geometry 785x562+0+0 < /dev/null &
*FvwmButtons netscape  netscape3.xpm Exec "Netscape" netscape -geometry 959x734+56+0 &
*FvwmButtons chess Chess.xpm	Exec xboard &
*FvwmButtons Quit KeyPower.xpm Quit
#*FvwmButtons(Swallow xeyes 'Exec xeyes &')
*FvwmButtons(2x1 Swallow xosview 'Exec nice xosview -labels &')
*FvwmButtons(10x1 Swallow "FvwmPager" "Module FvwmPager 0 4")
#*FvwmButtons(2x1 Swallow (NoHints,Respawn) "FvwmTalk" "FvwmTalk")

########################## Window-Identifier ###############################
# Just choose colors and a fonts
*FvwmIdentBack MidnightBlue
*FvwmIdentFore Yellow
*FvwmIdentFont -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*

########################### Pager #########################################
*FvwmPagerBack #908090
*FvwmPagerFore #484048
#*FvwmPagerFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmPagerFont none
*FvwmPagerHilight #cab3ca
*FvwmPagerGeometry -1-1
*FvwmPagerLabel 0 Shells
*FvwmPagerLabel 1 X Apps
*FvwmPagerSmallFont 5x8
#*FvwmPagerDeskTopScale 27

##########################FvwmWinList##################################
*FvwmWinListBack #908090
*FvwmWinListFore Black
*FvwmWinListFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmWinListAction Click1 Iconify -1,Focus
*FvwmWinListAction Click2 Iconify
*FvwmWinListAction Click3 Module "FvwmIdent" FvwmIdent
*FvwmWinListUseSkipList
*FvwmWinListGeometry +0-1

*FvwmBackerDesk 0 Exec xpmroot /usr/share/textures/rock018.xpm
*FvwmBackerDesk 1 Exec xpmroot /usr/share/textures/drops.xpm
*FvwmBackerDesk 2 Exec xpmroot /usr/share/textures/red_stucco.xpm
*FvwmBackerDesk 3 Exec xpmroot /usr/share/textures/fish.xpm
*FvwmBackerDesk 4 Exec xpmroot /usr/share/textures/slate_green.xpm

*FvwmScrollBack grey40
*FvwmScrollFore green
	
############################################################
############################################################
# Note that icons are shown in the module
#    only if NoIcon commnand is applied.
#Style     "*"  NoIcon

############################################################
*FvwmIconBoxIconBack    #cfcfcf
*FvwmIconBoxIconHiFore  black
*FvwmIconBoxIconHiBack  LightSkyBlue
*FvwmIconBoxBack        #5f9ea0
#*FvwmIconBoxFore       blue
*FvwmIconBoxGeometry    5x1+0+0
*FvwmIconBoxMaxIconSize 64x38
*FvwmIconBoxFont        -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*
*FvwmIconBoxSortIcons
*FvwmIconBoxPadding     4
*FvwmIconBoxLines       10
*FvwmIconBoxSBWidth     11
*FvwmIconBoxPlacement   Left Top
*FvwmIconBoxPixmap      fvwm.xpm
#*FvwmIconBoxHideSC Horizontal
*FvwmIconBoxSetWMIconSize
*FvwmIconBoxHilightFocusWin
*FvwmIconBoxMouse       1       Click           RaiseLower
*FvwmIconBoxMouse       1       DoubleClick     Iconify
*FvwmIconBoxMouse       2       Click           Iconify -1, Focus
*FvwmIconBoxMouse       3       Click           Module "FvwmIdent" Fvw
*FvwmIconBoxKey         r       RaiseLower
*FvwmIconBoxKey         space   Iconify
*FvwmIconBoxKey         d       Close
*FvwmIconBoxKey         n       Next
*FvwmIconBoxKey         p       Prev
*FvwmIconBoxKey         h       Left
*FvwmIconBoxKey         j       Down
*FvwmIconBoxKey         k       Up
*FvwmIconBoxKey         l       Right
#
# Icon file specifications
#
# Mostly, you don't have to specify icon files, as FvwmIconBox now
# reads icon files specified in Style commands.
#
*FvwmIconBox            "Fvwm*"         -

---

From: Douglas Denault <[email-masked]>
Date: Tue, 16 Jun 1998 15:06:09 -0400

If this post does not belong here - I just subscribed here last night
and I apoligize for the extranious bandwidth, but I am using FVWM 1.24
on a BSDI 3.1 system.

The Question:

What is the syntax for setting the DPMS power settings? In installing
the X server /etc/Xaccell.ini is setup with:

     :
[SCREEN]
    Board   = "s3/764-1.xqa";
    Monitor = "mfreq/mfreq64.vda";
    Depth   = 8;
    Desktop = 1024x768;
    EnergyStar = YES;
     :

The .xinitrc file refers to SuspendTime and OffTime. Are these set with
xset or added to /etc/Xaccell.ini?  the BSDI man pages do not mentions
these parms at all. The only ref to DPMS is to say it is experiemental
(it works using some defaults).

My final question is can/does with work with using a screen saver. I.e.,
I would like to have xlock get turned on and then have the monitor move
to the low power modes after an interval.

Thanks for any help

Doug Denault
Safeport Network Services
www.safeport.com
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Bob Woodside <[email-masked]>
Date: Tue, 16 Jun 1998 22:55:45 -0400 (EDT)

> and I apoligize for the extranious bandwidth, but I am using FVWM 1.24

        It's a tad off-topic, not being a window-manager issue,
but the group's usually pretty good-natured about this sort of question.

> xset or added to /etc/Xaccell.ini?

        Yes. Both.

>  the BSDI man pages do not mentions these parms at all. The only ref
>  to DPMS is to say it is experiemental (it works using some defaults).

        Your AcceleratedX install should have included a verbose man
page called Xaccel.1, which should explain the Xaccel.ini setup, so try
"man Xaccel" (or, better, if you use xman, look for Xaccel at the top of 
Section 1).

        To change the settings on the fly, use "xset s [settings]" -
check the xset man page. I normally set it like so -

                xset s 600 300

in a little script that I run from the InitFunction function in my
fvwmrc. This gives me 10 minutes before the monitor is kicked into 
standby mode, then another 5 before it shuts off.

> to the low power modes after an interval.

        Er...does what work with the screensaver?  :-)  In any case
the answer is yes. If you mean FVWM, it doesn't interfere with the
screensaver. If you mean the AcceleratedX X server, yes, it works fine
with xlock. Xaccel will switch your monitor to low power mode regardless
of whether xlock is running or not. 

        I believe that xscreensaver, on the other hand, overrides the X
server's DPMS settings. I'm not sure there's any way around this short
of writing a little script to manipulate xscreensaver, and shut it down
after a suitable interval.