Subject: Re: FVWM: Pager & other Questions

From: "Keven R. Pittsinger" <[email-masked]>
Date: Tue, 23 Jun 1998 13:51:57 -0400

> "Keven R. Pittsinger" <[email-masked]> writes:
> 
> > Also, XFCE seems to be stepping on my environment.  Specifically, my 
> > NNTPSERVER variable.  I need this active so I can pull binaries down off the 
> > net with slrn.  Knews doesn't work for this purpose, I use it for my other 
> > readings.  Any clues?
> 
> are you setting these variables from .login or .cshrc
> and your fvwm is started from .xsession with another shell ?

I've tried setting them in /etc/profile (I'm a bash'er) and $HOME/.bash_rc.  I start up with an xdm login cause my roomie sometimes uses my machine and he's not too up on CLI's yet.

Keven

-- 
==============================================================================
          http://www.glasscity.net/users/jamstar/index.html
==============================================================================
 "When the going gets weird, | [email-masked]  |  Keven R. Pittsinger
  the weird turn pro." --    |    [email-masked]   |   Certified Public
  Dr. Hunter S. Thompson     |        SUE ME!!        |       Nuisance

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Richard Lister <[email-masked]>
Date: Wed, 24 Jun 1998 11:36:43 -0400

On Tue, 23 Jun 1998 13:51:57 -0400
"Keven R. Pittsinger" <[email-masked]> 
> I've tried setting them in /etc/profile (I'm a bash'er) and $HOME/.bash_rc.  I start up with an xdm login cause my roomie sometimes uses my machine and he's not too up on CLI's yet.

When you start an xdm session you don't actually get a login shell,
so your .profile is never run. You could set the variables in your
.xsession, but the way I always do it is to write .profile so that
it can just be sourced in my .xsession. All my profile does is set
env variables, anyway. Everything else for the shell is done in the
rc file.

A simple .xsession would look something like this:

  #!/bin/sh

  if [ -f ${HOME}/.profile ] ; then
    . ${HOME}/.profile
  fi

  xrdb -load ${HOME}/.Xdefaults

  xterm&
  fvwm2

Ric

Richard J Lister, Georgetown Institute for Cognitive and Computational Sciences
Georgetown University Medical Center, Washington, DC 20007, USA
Phone: +1 202-687 2878
Email: [email-masked] 
Web: http://www.giccs.georgetown.edu/~ric/
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].