Subject: Re: FVWM: Re: fvwm and colors, please help

From: Chad Fors <[email-masked]>
Date: Fri, 05 Jun 1998 15:46:58 -0500

These all appear multiple times because the spelling of the color is different in each occasion.  showrgb gives the mapping between RGB
codes and the various names for those colors.  For example, if you want to use the color "ghost white," you may specify this with
"ghost white" or "GhostWhite" (no spaces in the latter).  The color names are not just descriptions of the color, they can be used in
place of the RGB code to specify the color within .fvwmrc or html files or whatever.

Neil Zanella wrote:

> > >
> >       Well, carelessly listed. I've seen colors that *should've* been grouped
> > together at opposite ends of the showrgb list.
> >
>
> The colors are indeed carelessly listed.
> What bothers me the most is that some colors have multiple entries whereas
> others don't. Here is part of my showrgb output:
>
> Note that "snow" appears once, "ghostwhite" appears twice as "ghost white"
> and "GhostWhite", and "slategray" apperas four times as "slate gray", "SlateGrey", and then once more "slate grey", and "SlateGrey".
>
> 255 250 250             snow
> 248 248 255             ghost white
> 248 248 255             GhostWhite
> 245 245 245             white smoke
> 245 245 245             WhiteSmoke
> 220 220 220             gainsboro
> 255 250 240             floral white
> 255 250 240             FloralWhite
> 253 245 230             old lace
> 253 245 230             OldLace
> 250 240 230             linen
> 250 235 215             antique white
> 250 235 215             AntiqueWhite
> 255 239 213             papaya whip
> 255 239 213             PapayaWhip
> 255 235 205             blanched almond
> 255 235 205             BlanchedAlmond
> 255 228 196             bisque
> 255 218 185             peach puff
> 255 218 185             PeachPuff
> 255 222 173             navajo white
> 255 222 173             NavajoWhite
> 255 228 181             moccasin
> 255 248 220             cornsilk
> 255 255 240             ivory
> 255 250 205             lemon chiffon
> 255 250 205             LemonChiffon
> 255 245 238             seashell
> 240 255 240             honeydew
> 245 255 250             mint cream
> 245 255 250             MintCream
> 240 255 255             azure
> 240 248 255             alice blue
> 240 248 255             AliceBlue
> 230 230 250             lavender
> 255 240 245             lavender blush
> 255 240 245             LavenderBlush
> 255 228 225             misty rose
> 255 228 225             MistyRose
> 255 255 255             white
>   0   0   0             black
>  47  79  79             dark slate gray
>  47  79  79             DarkSlateGray
>  47  79  79             dark slate grey
>  47  79  79             DarkSlateGrey
> 105 105 105             dim gray
> 105 105 105             DimGray
> 105 105 105             dim grey
> 105 105 105             DimGrey
> 112 128 144             slate gray
> 112 128 144             SlateGray
> 112 128 144             slate grey
> 112 128 144             SlateGrey
> 119 136 153             light slate gray
> ...                     ...
>
> Rather, IMHO there should be only one entry for each color like
>
> 255 250 250             snow
> 248 248 255             ghost white
> 245 245 245             white smoke
> 220 220 220             gainsboro
> 255 250 240             floral white
> ...                     ...
>
> Also, the entries should be displayed in alphabetical order (why not)?
>
> I suggest that the showrgb database be modified to make more sense.
>
> Neil
>
> --
> Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
> To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
> message to [email-masked].
> To report problems, send mail to [email-masked].

--
-Chad Fors
     Phone   (847)632-5270
     Maildrop  IL27 / 2-E5

---

From: Neil Zanella <[email-masked]>
Date: Fri, 5 Jun 1998 22:33:04 -0230 (NDT)

On Fri, 5 Jun 1998, Chad Fors wrote:

> "ghost white" or "GhostWhite" (no spaces in the latter).  

Actually, as someone already pointed out, Ghost White and ghOsT WHITe work as
well.

Neil