Subject: FVWM: launching multiple application

From: Neil Zanella <[email-masked]>
Date: Fri, 5 Jun 1998 11:23:23 -0230 (NDT)

Hi,

How can I launch multiple applications through the menu bars (for
example three xterms covering my window workspace)?

Also, how can I have a maximized window pop up from a menu without having
to use the monitor size dependant geometry options.

Thanks,

Neil

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Fri, 5 Jun 1998 10:02:46 -0400 (EDT)

> example three xterms covering my window workspace)?

AddToFunction	SpawnThreeXterms \
  "I"	/usr/bin/X11/xterm -T "xterm1"
+ "I"	/usr/bin/X11/xterm -T "xterm2"
+ "I"	/usr/bin/X11/xterm -T "xterm3"

AddToMenu "ButtonMenu"
+ "Launch Three XTerms"	SpawnThreeXterms

> to use the monitor size dependant geometry options.

AddToFunction	SpawnMaximizedXterm \
  "I"	/usr/bin/X11/xterm -T "maximizedXterm"
+ "I"	Wait maximizedXterm
+ "I"	Next ["maximizedXterm"] Maximize

> Thanks,

Some of the beauties of using functions...!

-- 
(void) lar3ry();                                      [email-masked]

     "Sometimes it happens.  People just explode.  Natural causes."

---

From: "A. van Werven" <[email-masked]>
Date: Fri, 5 Jun 1998 17:13:20 +0200 (DST)

> example three xterms covering my window workspace)?

Make a function for it.
Something like
AddToFunc foo
"I" xterm -geometry .....
+ "I" xterm -geometry ...
etc.

And then
AddToMenu Whatever "Foo" Title
+ "3 xterms" Function foo

> to use the monitor size dependant geometry options.

For a window called foo, something like
Next [foo] Maximize 100 100

Hope this helps.

-- 

A. van Werven
Dept. of Computer Science, Leiden University, The Netherlands
E-mail: [email-masked]
URL: http://www.wi.leidenuniv.nl/~avwerven

Life would be easier if I had the source code.