Subject: FVWM: Re: fvwm and colors, please help

From: Neil Zanella <[email-masked]>
Date: Fri, 5 Jun 1998 18:06:22 -0230 (NDT)

> > 
> 	Well, carelessly listed. I've seen colors that *should've* been grouped
> together at opposite ends of the showrgb list.
> 

The colors are indeed carelessly listed.
What bothers me the most is that some colors have multiple entries whereas 
others don't. Here is part of my showrgb output:

Note that "snow" appears once, "ghostwhite" appears twice as "ghost white"
and "GhostWhite", and "slategray" apperas four times as "slate gray", "SlateGrey", and then once more "slate grey", and "SlateGrey".

255 250 250             snow
248 248 255             ghost white
248 248 255             GhostWhite
245 245 245             white smoke
245 245 245             WhiteSmoke
220 220 220             gainsboro
255 250 240             floral white
255 250 240             FloralWhite
253 245 230             old lace
253 245 230             OldLace
250 240 230             linen
250 235 215             antique white
250 235 215             AntiqueWhite
255 239 213             papaya whip
255 239 213             PapayaWhip
255 235 205             blanched almond
255 235 205             BlanchedAlmond
255 228 196             bisque
255 218 185             peach puff
255 218 185             PeachPuff
255 222 173             navajo white
255 222 173             NavajoWhite
255 228 181             moccasin
255 248 220             cornsilk
255 255 240             ivory
255 250 205             lemon chiffon
255 250 205             LemonChiffon
255 245 238             seashell
240 255 240             honeydew
245 255 250             mint cream
245 255 250             MintCream
240 255 255             azure
240 248 255             alice blue
240 248 255             AliceBlue
230 230 250             lavender
255 240 245             lavender blush
255 240 245             LavenderBlush
255 228 225             misty rose
255 228 225             MistyRose
255 255 255             white
  0   0   0             black
 47  79  79             dark slate gray
 47  79  79             DarkSlateGray
 47  79  79             dark slate grey
 47  79  79             DarkSlateGrey
105 105 105             dim gray
105 105 105             DimGray
105 105 105             dim grey
105 105 105             DimGrey
112 128 144             slate gray
112 128 144             SlateGray
112 128 144             slate grey
112 128 144             SlateGrey
119 136 153             light slate gray
...                     ...

Rather, IMHO there should be only one entry for each color like

255 250 250             snow
248 248 255             ghost white
245 245 245             white smoke
220 220 220             gainsboro
255 250 240             floral white
...                     ...

Also, the entries should be displayed in alphabetical order (why not)?

I suggest that the showrgb database be modified to make more sense.

Neil

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Patrick K." <[email-masked]>
Date: Fri, 5 Jun 1998 17:37:04 -0700 (PDT)

> and "GhostWhite", and "slategray" apperas four times as "slate gray", "SlateGrey", and then once more "slate grey", and "SlateGrey".

[dd]

> Rather, IMHO there should be only one entry for each color like

   Why?!?

   I like to have the choice to type "slategray" on Tuesdays and
   "SlateGray" on every Saturday, not to mention my Wednesday
   habbit to type "slate grey" and my ritual of typing
   "SlateGrey" every 2nd Monday of the month.

   So unless you want to make the parser for the RGB db accept
   *and* understand all the different ways of representing a
   colour using english text... don't bother!

> Also, the entries should be displayed in alphabetical order (why not)?

   Why again?  Do you visit this file so often that you need
   to have it in alpha order?

   If you are concerened about finding certain text in there
   and do not want to be scrolling up and down so much, then
   I must wonder why you are not using '/usr/bin/grep' to list
   the entries for you?

   Just my 2 cents on the matter,   :>

Patrick K.

P.S.  Also see `man sort' for more options to sort your `showrgb'
      output.

---

From: Neil Zanella <[email-masked]>
Date: Fri, 5 Jun 1998 22:27:31 -0230 (NDT)

Hi,

I don't want to make a big deal out of this and I think it's OK to have the 
choice of whether to type "wHATevErColor" or "whatever CoLoR" though I would
like to see some consistency in the datafile. I just thought that the output
of showrgb looked sloppy since some entries are listed in both uppercase and 
lowercase and some are not. This hints to the novice that there are some 
differences between the ones that are listed twice and the ones that aren't.
Perhaps some of you don't agree with me that the output of rgb is sloppy.
Mine was only a minor suggestion: if no one modifies it to look better I can 
certainly live with that and shall fuss no more ;-) .

Best regards,

Neil

---

From: jim <[email-masked]>
Date: Sat, 6 Jun 1998 16:46:43 -0400 (EDT)

1. At least some X applications that I've encountered over the years
   don't accept color specifications with spaces in them. From thens
   cometh "Slate Grey", "slategray", etc.

2. If rgb.txt must be sorted, it probably makes more sense to sort it
   on the values rather than the text (ie, it makes more sense to me
   for "off white" and "old lace" to appear between "white" and
   "yellow" than between "orange" and "purple".

3. showrgb dumps the table. If you don't like the output, 
   perl/sed/awk/grep/cut are your friends. TTWWDTIU.*

4. This isn't exactly the right forum for discussing the organization
   of X color name to value mapping. rgb.txt and showrgb are part of
   X, not fvwm; last I looked, fvwm2 ran fine on a mono server.

- Jim

----
* (That's The Way We Do Things In UNIX.)

---

From: Neil Zanella <[email-masked]>
Date: Sat, 6 Jun 1998 18:55:49 -0230 (NDT)

>    cometh "Slate Grey", "slategray", etc.

This reinforces my point that consistency helps avoiding compatibility issues.

>    "yellow" than between "orange" and "purple".

This is what I intended to suggest in the first place.

>    perl/sed/awk/grep/cut are your friends. TTWWDTIU.*

Sure, I wonder why whoever made the table wasn't friends with them.
If I had root permissions I'd probably use these tools to change the table
except for I don't feel it's worth it when I'm only doing it on my sytem.
That's the responsability of the person who made up the table. If I ever 
will need to make a table be reassured that it will look nice.

>    X, not fvwm; last I looked, fvwm2 ran fine on a mono server.

OK, I just could not find anything on the colors in man fvwm, that's all.
My own room is a complete mess, and I couldn't care less, but I do believe 
in keeping Unix neat and tidy. ;-)

Best Regards,

Neil

---

From: [email-masked] (Stefan Hermes)
Date: Mon, 8 Jun 1998 14:28:59 +0200

On Jun 6, 12:37am, <[email-masked]> wrote:
> Subject: Re: FVWM: Re: fvwm and colors, please help
>
> > and "GhostWhite", and "slategray" apperas four times as "slate gray",
"SlateGrey", and then once more "slate grey", and "SlateGrey".
>    I must wonder why you are not using '/usr/bin/grep' to list
don't forget to pipe though sort +3 , for that matter..

Sorry, could't resist.

>-- End of excerpt from <[email-masked]>

-- 
Stefan Hermes                   Front Office Technical Services
Phone: +49 (69) 7538 2246       Credit Suisse First Boston
Fax  : +49 (69) 7538 2700       Frankfurt Messeturm

earth:~# shutdown --apocalypse 5 `/bin/cat ~/apocalype.msg`

Broadcast message from god (console) Wed May 16 13:45:22 2000...

Earth is shutting down in 5 minutes for a system upgrade.  All users please
log out or transfer to heaven.god.net or hell.god.net.  Thank you.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].