Subject: FVWM: nice feature needed

From: Neil Zanella <[email-masked]>
Date: Fri, 19 Jun 1998 17:05:17 -0230 (NDT)

Hi,

I think this is present in Afterstep to some extent but I am not sure.

This is a pager:

|-----|
|     |
|     |
|-----|
|     |
|     |
|-----|
|     | <---- clicking on this button with mouse 1 launches an application
|     | <---- clicking this button with mouse 3 causes the following ....
|-----|                                            see below
|     |
|     |
|-----|
|     |
|     |
|-----|
|     |
|     |
|-----|

...

|-----|
|     |
|     |
|-----|
|     |
|     |
|-----|-----|-----|-----|-----|
|     |     |     |     |     |
|     |     |     |     |     | < hey, we can now choose from 4 other things
|-----|-----|-----|-----|-----|
|     |
|     |
|-----|
|     |
|     |
|-----|
|     |
|     |
|-----|

The purpose of this is:

1) we can save desktop space and avoid cluttering

2) we can group applications of similar functionality together on the pager

Neil

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Joe <[email-masked]>
Date: Fri, 19 Jun 1998 15:16:13 +0000

> 2) we can group applications of similar functionality together on the pager

Since Afterstep is fvwm-1.x based, perhaps Afterstep 1.0's Wharf bar will work
with one of the fvwm-1.x releases?

I know the FvwmTaskBar from fvwm95 works on fvwm-2.0.46 or whatever.

Besides, you can probably have FvwmButtons call another FvwmButtons and
position it where you want a flyout menu to go. Then have the button kill that
flyout menu after executing the command chosen. I'm sure it's possible to make
a Wharf replica that way, at least something similar.

-Joe

---

From: Jay Donoghue <[email-masked]>
Date: Fri, 19 Jun 1998 16:28:38 -0400

This module has been ported for FVWM v2.0.46

Its FvwmWharf, and you can find here in the tarball:
./fvwm-2.0.46/extras/FvwmWharf/ASSound/README

It doesnt compile automatically... you have to do it manually

 - J

-- 
     Jay  Donoghue        ##|`#####
  Analog Devices, Inc.    ##|  `###
    (781) 937-2295        ##|    >#
                          ##|  ,###   PGP Key available: 
[email-masked]   ##|,#####     Email with subject "PGP_key"

---

From: Jim Knoble <[email-masked]>
Date: Fri, 19 Jun 1998 17:14:06 -0400 (EDT)

Actually, that's not a pager.  It's a button bar, called `Wharf' in
AfterStep.  A pager allows navigation of a virtual desktop, not
starting of programs.

The functionality you're asking about has already been done.  FvwmWharf
is a module that comes with fvwm2, but doesn't compile by default.  The
recent Red Hat Linux releases include FvwmWharf as part of the fvwm2
package.

--jim

%%%%%%%%%%%%%%% jim knoble %%%%%%%% [email-masked] %%%%%%%%%%%%%%%%%

On Fri, 19 Jun 1998, Neil Zanella wrote:

: I think this is present in Afterstep to some extent but I am not sure.
: 
: This is a pager:

---

From: Richard Lister <[email-masked]>
Date: Tue, 23 Jun 1998 12:03:29 -0400

On Fri, 19 Jun 1998 17:05:17 -0230 (NDT)
Neil Zanella <[email-masked]> 

Neil

I use FvwmWharf for this. I stuck up a couple of screenshots at
  http://www.giccs.georgetown.edu/~ric/software/fvwm/wharf/
The colours look pretty crappy in my browser, but you get the idea.

Cheers
Ric

Richard J Lister, Georgetown Institute for Cognitive and Computational Sciences
Georgetown University Medical Center, Washington, DC 20007, USA
Phone: +1 202-687 2878
Email: [email-masked] 
Web: http://www.giccs.georgetown.edu/~ric/
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].