Subject: FVWM: trouble with pager

From: Neil Zanella <[email-masked]>
Date: Thu, 18 Jun 1998 16:24:49 -0230 (NDT)

Hi,

How do I change the size of the pager in fvwm1?

So far I have been quite insuccessful though I have managed to position the 
pager in the upper left hand corner.

Thanks,

Neil

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Sam Krishnabhat <[email-masked]>
Date: Thu, 18 Jun 1998 12:06:47 -0700 (PDT)

Neil Zanella sez...
> pager in the upper left hand corner.

I have a related question. Can I make FvwmPager desktop window appear and
dis-appear with the hit of a key, say Esc or Meta-Esc etc., Are there any
performance concerns, would it work. I want to hear from experts before
trying, if they had tried anything like this.

-sam

---

From: Dan Espen <[email-masked]>
Date: Thu, 18 Jun 1998 15:44:07 -0400

> > pager in the upper left hand corner.

Sorry Neal, can't answer any fvwm1 questions, its been too long.
Maybe someone else...

> trying, if they had tried anything like this.

You could create and kill it but I think that would be too slow.

Try to set its style to "NoIcon",
use one keystroke to iconify it, 
the other keystroke to de-iconify it.

--
Dan Espen                                Phone: (732) 699-5570
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Fri, 19 Jun 1998 09:05:55 -0400 (EDT)

> trying, if they had tried anything like this.

    Key Escape	A	M	TogglePager

    DestroyFunc	"TogglePager"
    AddToFunc	"TogglePager"
      "I"	Next ["Fvwm Pager" CirculateHit] Close
    + "I"	None ["Fvwm Pager" CirculateHit] Module FvwmPager 0 3

This will cause the Meta-Escape key to be interpreted as follows:

- If FvwmPager is running, remove it from the screen.
- If FvwmPager is not running, start it up with four desktops

This can be easily modified for your own situation.

-- 
(void) lar3ry();                                      [email-masked]

     "Sometimes it happens.  People just explode.  Natural causes."

---

From: "A. van Werven" <[email-masked]>
Date: Tue, 30 Jun 1998 21:18:15 +0200 (DST)

> Sorry Neal, can't answer any fvwm1 questions, its been too long.

Don't know if it works in Fvwm 1, but shouldn't
*FvwmPagerGeometry axb+c+d do the trick ?

Good luck,

-- 

A. van Werven
Dept. of Computer Science, Leiden University, The Netherlands
E-mail: [email-masked]
URL: http://www.wi.leidenuniv.nl/~avwerven

Life would be easier if I had the source code.

---

From: Neil Zanella <[email-masked]>
Date: Tue, 30 Jun 1998 19:35:19 -0230 (NDT)

> *FvwmPagerGeometry axb+c+d do the trick ?
No, it doesn't do the trick, and I don't know why.

I am thinking that the command might be misplace within the file.

Thanks,

Neil

---

From: Bob Woodside <[email-masked]>
Date: Tue, 30 Jun 1998 22:55:04 -0400 (EDT)

On 30-Jun-98 Neil Zanella wrote:
> A. van Werven...
>> Dan Espen...
>>  ...shouldn't *FvwmPagerGeometry axb+c+d do the trick ?
>> 
> No....

        If it's Fvwm version 1, the command is

              DeskTopScale <divisor>

and for version 2 it's
 
             *FvwmPagerDeskTopScale <divisor> 

where the reduction factor is 1/divisor. In other words, to show
things in the pager at 1/36 the size of the actual desktop, you'd
specify "DeskTopScale 36".

        Specifying the width and height in the geometry command 
is rather iffy, and the man page recommends against it if you want
to keep the aspect ratio undisturbed. This is because the pager has
no fixed width - it shows as many desktops as you specify in the
pager invocation. (I'm not sure you could specify the width+height
in FvwmPagerGeometry in version 1.)