Subject: FVWM: xterm fonts

From: Neil Zanella <[email-masked]>
Date: Wed, 10 Jun 1998 14:46:17 -0230 (NDT)

I have a feeling that fvwm cannot help me select the font for my xterms.
Am I correct?
That is, the only way to specify what fonts an xterm will use is to give the xterm/remoteXterm command the right argument.

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jim Knoble <[email-masked]>
Date: Wed, 10 Jun 1998 13:37:45 -0400 (EDT)

Dude, read the xterm man page.  You can set resources in your
~/.Xdefaults file to specify the default font for xterm. 

Man pages are your friend.  Please use them before asking questions
here.

--jim

%%%%%%%%%%%%%%% jim knoble %%%%%%%% [email-masked] %%%%%%%%%%%%%%%%%

On Wed, 10 Jun 1998, Neil Zanella wrote:

: I have a feeling that fvwm cannot help me select the font for my
: xterms. Am I correct? That is, the only way to specify what fonts an
: xterm will use is to give the xterm/remoteXterm command the right
: argument.

---

From: Joe <[email-masked]>
Date: Fri, 02 Jan 1998 18:57:17 +0000

> That is, the only way to specify what fonts an xterm will use is to give the xterm/remoteXterm command the right argument.

You can get XTerm menus by holding down the Control Key and pressing buttons 1, 2 or 3.

Button 3 will give you a font selection menu, which you can customize in /usr/X11/lib/X11/app-defaults/XTerm

You can customize 6 fonts I think, plus the default you specified on the command line.

FVWM wouldn't have anything to do with xterm, as far as the system is concerned FVWM is just another program like xterm. It
only handles decorations for the window borders, and modules for other features. It can't normally change features of other
programs I don't think.

---

By the way, this has got to still be the best WM. It's still the easiest to configure. After using all the others, it's still
the only one that does everything I want. Kudos to the developers over the years and the countless hours of work they've done
to bring us something we can actually use. =)

-Joe

---

From: Richard Lister <[email-masked]>
Date: Wed, 10 Jun 1998 15:04:32 -0400

From: Neil Zanella <[email-masked]>
Subject: FVWM: xterm fonts
Date: Wed, 10 Jun 1998 14:46:17 -0230 (NDT)

> I have a feeling that fvwm cannot help me select the font for my xterms.

Correct, for all applications. In general the window manager does the
following things:

1. Draw borders around windows.
2. Allow resizing and movement of windows.
3. Allow iconifying of windows.
4. Provide other services, such as menus, button bars, virtual desks, etc.

The window manager doesn't affect what happens *inside* the window. That
is up to the application itself.

> That is, the only way to specify what fonts an xterm will use is to
> give the xterm/remoteXterm command the right argument.

Or set the X resource. I have the following in .Xdefaults:

XTerm*font: -b&h-lucidatypewriter-medium-r-normal-sans-12-120-*-*-m-*-iso8859-1

This is read when X starts up, or can be reloaded by:

  xrdb -load .Xdefaults

Ric

Richard J Lister, Georgetown Institute for Cognitive and Computational Sciences
Georgetown University Medical Center, Washington, DC 20007, USA
Phone: +1 202-687 2878
Email: [email-masked] 
Web: http://www.giccs.georgetown.edu/~ric/

---

From: Neil Zanella <[email-masked]>
Date: Wed, 10 Jun 1998 16:55:44 -0230 (NDT)

Thanks,

That was quite a neat trick.

There are quite a lot of dot files on the unix tree and their function is not at all 
that clear to me. All of this must be documented somewhere better than man.
Perhaps I will get myseld one or more of O'Reilly's X manuals.
I'm sure I would find them quite useful.
What I don't know is whether they will answer all of my questions or not.

Thanks,

Neil Zanella
[email-masked]

---

From: Richard Lister <[email-masked]>
Date: Wed, 10 Jun 1998 15:44:59 -0400

From: Neil Zanella <[email-masked]>
Subject: Re: FVWM: xterm fonts
Date: Wed, 10 Jun 1998 16:55:44 -0230 (NDT)

> that clear to me. All of this must be documented somewhere better than man.

Yes. This is exactly the sort of question I plan to answer in my proposed
FAQ.

> Perhaps I will get myseld one or more of O'Reilly's X manuals.

The O'Reilly X manuals are very good, but are generally aimed at programmers.

> What I don't know is whether they will answer all of my questions or not.

Probably not at your level. You need an intro to X, what it is and does,
some terminology, and what some of the more common programs do. Again,
this is what my FAQ will achieve, I hope. You can be a beta tester :-)

Ric