Subject: FVWM: running fvwm2 on a remote system

From: Neil Zanella <[email-masked]>
Date: Sun, 7 Jun 1998 13:35:45 -0230 (NDT)

Hi,

I have access to the fvwm2 binary on a remote FreeBSD system on the same LAN.
Can I configure my .fvwmrc to have an entry in the pop-up menu sying
"switch to fvwm2" that will work by using the fvwm2 program on the remote 
machine and how can I do this?

Thanks,

Neil

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "A. van Werven" <[email-masked]>
Date: Tue, 9 Jun 1998 15:33:49 +0200 (DST)

> machine and how can I do this?

As far as I am concerned, you will have to quit X and do an rsh/remsh/whatever_
the_remote_command_is_on_your_machine to start fvwm2 on the other machine with
the -d (display) option.

Hope this helps,

-- 

A. van Werven
Dept. of Computer Science, Leiden University, The Netherlands
E-mail: [email-masked]
URL: http://www.wi.leidenuniv.nl/~avwerven

Life would be easier if I had the source code.

---

From: [email-masked] (Graeme McCaffery)
Date: Tue, 9 Jun 1998 15:01:35 +0100 (BST)

> As far as I am concerned, you will have to quit X and do an rsh/remsh/whatever_

you need to have a function that will allow you to quit fvwm, then rsh (exchanging xauth)
to the remote machine, perhaps copy the desired fvwmrc file over and run fvwm.
you could prolly do this with a script on the other machine.

hope this helps, it's not impossible just difficult.

Graeme

---

From: Richard Lister <[email-masked]>
Date: Tue, 09 Jun 1998 11:08:33 -0400

From: [email-masked] (Graeme McCaffery)
Subject: Re: FVWM: running fvwm2 on a remote system
Date: Tue, 9 Jun 1998 15:01:35 +0100 (BST)

> hope this helps, it's not impossible just difficult.

I generally recommend the use of the 'xsession' program, which you can
obtain from any X ftp mirror.

This is a simple client which you run as the last program in your X startup
script (.xinitrc, .Xclients, .xsession, or whatever) instead of the
window manager.

xsession starts the window manager for you, then provides a menu of
different window managers to switch between. I find it very useful
to debug different versions of fvwm. It also make a great failsafe ...
if you mess up your fvwmrc and fvwm fails you will still get the
xsession window, and can switch to twm or something else, fire up
an editor, fix the fvwmrc, and test it.

When you want to leave X, just quit the xsession program.

You could set it up with menu entries for:

  fvwm
  rsh host fvwm2
  twm

and so on.

Ric

Richard J Lister, Georgetown Institute for Cognitive and Computational Sciences
Georgetown University Medical Center, Washington, DC 20007, USA
Phone: +1 202-687 2878
Email: [email-masked] 
Web: http://www.giccs.georgetown.edu/~ric/
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].