Subject: FVWM: Can we change the Title of a opened Xterm window ?

From: Sam Krishnabhat <[email-masked]>
Date: Fri, 19 Jun 1998 00:14:07 -0700 (PDT)

Hi,

Is it possible to change the Title of a Xterm window
while it is already open ?

-sam
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Guangyong Xu <[email-masked]>
Date: Fri, 19 Jun 1998 10:00:55 -0400 (EDT)

Yes, I read about this in the Linux Journal. This is the part of my .cshrc
file which makes the title to be "UserID@HOST:DIRECTORY"

...
switch ($TERM)
      case "xterm*":
          set prompt="%{\033]0;%n@%m:%~\007%}I Love %m: "
          breaksw
...

You can certainly change it to fit your needs. I am using tcsh. I don't
remember exactly how to change the title of the xterm if you are using
other shells though. 
-Guangyong

---

From: patrick finerty <[email-masked]>
Date: Fri, 19 Jun 1998 11:55:24 -0600 (MDT)

yes,

echo "\033]2;CONSOLE\007\c"

does the trick for me. replace 'CONSOLE' with whatever text string you 
want to use...

-pjf
-- 
       "There is only one aim in life and that is to live it."
 Karl Shapiro,(1959) from an essay on Henry Miller's Tropic of Cancer
	  finger [email-masked] for PGP key
		    http://zifi.genetics.utah.edu
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].