Subject: FVWM: creating a pixmap

From: Neil Zanella <[email-masked]>
Date: Mon, 29 Jun 1998 22:40:41 -0230 (NDT)

Hi,

I would like to create a pixmap (.xpm) so that I can perhaps use it with 
FvwmButtons. How do I go about doing this?

Thanks,

Neil

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "A. van Werven" <[email-masked]>
Date: Tue, 30 Jun 1998 21:32:04 +0200 (DST)

> FvwmButtons. How do I go about doing this?

1) xpm files are in very simple format. Just look at some xpm files and you'll
be able to make simple .xpm files with just a text editor like Vim.

2) For more complex icons, create them with a drawing utility (xpaint is usually
available on Linux boxes) and then use XV to load it and convert it to xpm.
I used this trick to convert jpg images (portraits of certain female
humanoids, for example) to xpm icons.

3) There should be xpm creation utilities out there somewhere, try asking on IRC
channel #linux.

4) Search the web and be amazed about how many icons you'll find.
Don't use too many if you're not running 16-bit colors or better, though...
I can do whatever I want on my friend's Linux box, but on the SGI machines
at the university I can only run 8-bit colors so I don't even think about using
a buttonbar anyway :-(

Hope this helps,

-- 

A. van Werven
Dept. of Computer Science, Leiden University, The Netherlands
E-mail: [email-masked]
URL: http://www.wi.leidenuniv.nl/~avwerven

Life would be easier if I had the source code.

---

From: Tomi Sarvela <[email-masked]>
Date: Wed, 1 Jul 1998 07:35:58 +0300 (EEST)

> 4) Search the web and be amazed about how many icons you'll find.

	Now, if a little advertising is allowed ...
	(not very off-topic, I like and use fvwm2 ;)

	Check http://nether.tky.hut.fi/iconstore/

	I've collected 48x48 icons from the net, and you
	can preview them, pick them one at a time or a
	pack at a time. Copyrights belong to the respective
	authors, but as far as I know, all the icons there
	are at least freely distributable.

	Format is jpg, tif or xpm, and when converting, use
	something like GIMP or ImageMagick, XV leaves the
	transparency information out of the saved xpm:s.
	If you use that you must edit the background color
	to transparency color by hand (which isn't terribly
	hard if you take a look in a xpm where transparency
	info exists).

	All the best,

	Tomi

[email-masked]  Ideas and thoughts expressed herein are mine, all mine!
[email-masked]  An NT server can be run by an idiot, and usually is.