Subject: FVWM: ClickToFocus

From: Felix Klee <[email-masked]>
Date: Sun, 10 May 1998 11:56:54 +0200

Hi,

I am using fvwm2 with XFree86 and LINUX. I enabled ClickToFocus
on all windows. However when I click on a window with a modifier key
activated (often Num lock) it does not receive focus. How can
I change the behaviour of ClickToFocus to ignore modifier keys?

Thanks,

Felix
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Manfred Bartz <[email-masked]>
Date: 10 May 1998 20:23:44 +1000

> I change the behaviour of ClickToFocus to ignore modifier keys?

Hmm, I think there might be something else wrong here but I can't tell 
you exactly what.  Check your ``Xmodmap'' for key mappings.

I experienced a similar problem once when I used an incorrect mouse
protocol.  See ``/etc/X11/XF86Config''.

Anyway, on my system I have the mouse buttons configured like this:

## MouseButton: 0=any, 1, 2 or 3
## \      Context: R=RootWdw,  W=AppsWdw, T=TitleBar, S=Sides
##  \    /         F=Frame (corners), I=IconWdw, 0..9=WdwButtons
##   \  |              Wdw Button order: 1 3 5 7 9    0 8 6 4 2
##    | |      Modifiers: None,Control,Shift,Meta,Any,3=super,4=hyper
##    | |      \        Function
## ---+-+-------+-------+-----------
Mouse 1	R   	A       Menu Main Nop
Mouse 2	R    	A      	Menu Module-Popup
Mouse 3	R    	A      	WindowList

Mouse 0	1    	A      	Menu Window-Ops2 Close
Mouse 0	3    	A     	Delete
Mouse 0	8    	A     	Stick
Mouse 0	6    	A     	Iconify
Mouse 0	4    	A     	Maximize-Func
Mouse 0	2    	A     	Delete
Mouse 0	W	4	Menu Window-Ops2 Nop

Mouse 1	F	A	Resize-or-Raise
Mouse 1	TS	N	Move-or-Raise
Mouse 1	TSF	4	WindowShadeAndRaise
Mouse 1	I	A	Move-or-Iconify
Mouse 2	I	A	Iconify
Mouse 2	FST	A	Menu Window-Ops2 Nop
Mouse 3	TSIF	A	RaiseLower

Hope this helps
-- 
Manfred Bartz <[email-masked]>
---------------------------------------------------------------
"Power corrupts.  Absolute power is kind of neat"
                -- John Lehman, Secretary of the Navy 1981-1987
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].