Subject: FVWM: double click to close window?

From: Kin Cho <[email-masked]>
Date: Wed, 27 May 1998 20:35:40 -0700

I wanted to be able to double click on the button on the top left
corner of a window to close it.

I tried this in my .fvwmrc but it doesn't work:

Mouse 0         1       N       Function "window_ops_func"

Function "window_ops_func"
        PopUp   "Click"         Window Ops2
        PopUp   "Motion"        Window Ops2
        Delete  "DoubleClick"  
EndFunction

-kin

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tomi Sarvela <[email-masked]>
Date: Thu, 28 May 1998 19:17:38 +0300 (EEST)

>         PopUp   "Motion"        Window Ops2

# some simple default mouse bindings:
# ...
#   for the title bar buttons:
Mouse 0 1       A       Menu Corner-Ops Close

----------------------------------clip

# menu for window left corner-button
# 
AddToMenu Corner-Ops    "(Un)&Stick"    Stick           
+                       "(Un)Ma&ximize" Maximize
+                       ""              Nop             
+                       "&Delete"       Delete  
+                       "&Close"        Close
+                       "Destroy"       Destroy         

---------------------------------clip

	This makes the left corner of the window act as a
	little menu, and double-click closes the window.

	Tomi

[email-masked]  Ideas and thoughts expressed herein are mine, all mine!
[email-masked]  An NT server can be run by an idiot, and usually is.