Subject: FVWM: Anyone want my FvwmTaskBar improvements?

From: [email-masked] (Michael L. Raymer)
Date: Tue, 12 May 1998 09:46:32 -0400

I have written a patch for FvwmTaskBar which allows the following behavior:
  - Only windows on the current desk (including sticky windows)
    show up in the taskbar
  - When the desktop is switched, the taskbar updates to show only windows which
    are associated with the new desk

This allows the taskbar to be much less crowded, and I find this behavior to be
more useful than having taskbar entries for every window known to FVWM.

If there is any interest in this patch, I'd be happy to make the above behavior
optional and then submit the patch to the public domain.  I have two questions:

1) Is there any interest?
2) Who would be the appropriate person to send such a submission to?  I checked
   the source code, but none of the email addresses listed there exist anymore.
   I also checked the FAQ, which said that the mailing lists were the current
   forum for new code submissions.

Thanks for any info,

Michael L. Raymer
Depts. of Computer Science and Biochemistry
Michigan State University
[email-masked]

p.s. - I'm not subscribed to the mailing lists, but I check the archive regularly,
 for a faster response, email me directly.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: John Culleton <[email-masked]>
Date: Tue, 12 May 1998 09:56:32 -0400

--

To taskbar or not depends in part on your previous experience. I use three entities
instead:
1. A horizontal (bottom) buttonbar with my frequently used programs.
2. A vertical (lower left) buttonbar with raise, lower resize etc. functions. This
forms a "lazy L" configuration with the other button bar.
3. an FVWMPager (upper right) with four desktops, each with four pages.

Thie pager is really my task bar. The tasks are shown as tiny windows on the desktop
and page where I started them. To switch to that task I just click on the little page
image.
If a particular page gets busy I can move a window to another page or desktop by
using the middle mouse button and dragging it on the pager. This is also a useful way
to center a window on a page.

The three entities described above are sticky on all pages.

There are two advantages to my setup as I see it. The bottom bar remains static. I
know what is on it and where it is indicated. The tasks themselves are never
iconified once started. They just reside on different pages. To move to that task I
move to that page.

John R. Culleton, Jr.  [email-masked]
2401 Haight Avenue
Sykesville, MD 21784 U. S. A.
(410) 795-1159

---

From: Danius Michaelides <[email-masked]>
Date: Tue, 12 May 1998 20:56:15 +0100 (BST)

> To taskbar or not depends in part on your previous experience. I use three
> entities instead:
> 2. A vertical (lower left) buttonbar with raise, lower resize etc. functions.
> This forms a "lazy L" configuration with the other button bar.

I have similiar thing, but i also use FvwmIconMan. I have a two column
buttonbar, with a 3x4 pager swallowed at the two, then working down,
asclock and xload, netscape and xterm, followed by raise and lower,
resize and move, iconify and kill, all 1/3 the height of a normal
icon. Below that i've got a tiny xterm swallowed (I was forever
opening an xterm just to run some xapp, so i thought i'd have a tiny
one there instead). Finally xpostit and lock,restart,exit. This is
sticky, in the topleft. Botton right i have an iconmanager growing
upwards. I tend to prefer having any static 'clutter' on the left hand
of the screen, letting things (long xterms and especially xdvi) run
off the bottom and off to the right.

Why am i telling everybody this? well, i think its interesting to see
how people set their desktops out. I've seen a couple of pages with a
number of .fvwmrcs but most of them seem to be abit out of date.
Certainly they arent in the numbers that you see in other
windowmanagers (perhaps this is a good thing).

Also, i feel that users actually talking about how they use fvwm is a
good thing. User-pull and all that.

Danius

ps: .fvwm2rc available if anybody is interested
    screen shot at http://www.duff.org/~danius/fvwm-danius.gif

---

From: Scott Scriven <[email-masked]>
Date: Tue, 12 May 1998 18:54:10 -0600

> windowmanagers (perhaps this is a good thing).

Interesting setup.  I've got mine set up much to my liking also..

I don't like to use the mouse, so I've got plenty of keyboard shortcuts,
including a pop-up "start menu" and lots of other things which work
without the mouse.  The most noticable thing, though, is the different
visual themes...

There are screenshots available at:
http://www.vis.colostate.edu/~scriven/Linux/fvwm/

 _  _ _  _ ___ ___  -----------"Use the source, Luke!"---------
( \/ ( \/ (__ (__ ) | ~  Scott Scriven (Toy Keeper / XYZZ)    |
 \  / \  /  //  //  | mailto:[email-masked]           |
 /  \ / /  //_ //_  | mailto:[email-masked]         |
(_/\_(_/  (___(___) | http://www.vis.colostate.edu/~scriven/  |
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Nathan Clegg <[email-masked]>
Date: Tue, 12 May 1998 20:33:10 -0700 (MST)

>   - Only windows on the current desk (including sticky windows)

I don't know about everybody else, but I think a far more useful property
of a task bar would be one that only included iconized applications.  If
they aren't iconized, they are easy to find.

---

From: Brian Sayatovic <[email-masked]>
Date: Wed, 13 May 1998 07:47:00 -0400

Actually, I for one do like to include all of my windows.  That way, if one
window is mostly or completely obscured by another, I can still get to it
without rearranging the positions of my windows.

Brian.