Subject: FVWM: 2.0.64 coredump in CaptureAllWindows

From: Muth Robert <[email-masked]>
Date: Tue, 26 May 1998 19:52:17 -0400 (EDT)

Hi:

I just downloaded and compiled the latest version
of fvwm on an IRIX64 machine.
Unfortunately, it coredumps somewhere in
CaptureAllWindows before it gets to execute
the InitFunction.
Does anybody know how to fix this problem?
(I tried different and no config files)

Robert

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Muth Robert <[email-masked]>
Date: Thu, 28 May 1998 14:41:15 -0400 (EDT)

Scott:

I compiled it off the shelf without any modification.
I am running fvwm2 for an Xterminal so I do not know
in how far  your color comments apply.
I finally downloaded the source for 2.0.38 which works fine.

Robert

On Wed, 27 May 1998, ToyKeeper wrote:

> Muth Robert wrote:
> I've been using it on irix machines for the last few months, and it
> works fine.  I suspect the problem might be the compiler or bit-depth
> you're using.
> 
> For my setup, I compiled it with gcc-2.8.0 with the regular "-32"-bit
> ABI (not "-n32" or "-64".  It works on the 32-bit and 64-bit machines I
> use (irix 6.2, 6.3, and 6.4).  If you used the 64-bit model, or used cc
> instead of gcc, that may be the source of the problem.
> 
> It may also be an X server problem.  Xsgi runs by default in pseudocolor
> mode.  Its real display depth is 24-bit or 32-bit, but it acts like an
> 8-bit server so that it will be compatible with older programs.  To get
> truecolor, programs have to ask for it specifically, in some sort of
> non-standard way.  You can fix this by modifying the startup script for
> the X server.  I forget what you need to modify right now, but I can
> mail you instructions later this week when I go back to work.
> 
> Oh, yeah.  It might be the distribution you're using.  The plain 2.0.46
> from the Fvwm page worked for me; I haven't tried fvwm-smr-2.0.46.4 yet.
> 
> 
>  _  _ _  _ ___ ___  -----------"Use the source, Luke!"---------
> ( \/ ( \/ (__ (__ ) | ~  Scott Scriven (Toy Keeper / XYZZ)    |
>  \  / \  /  //  //  | mailto:[email-masked]           |
>  /  \ / /  //_ //_  | mailto:[email-masked]         |
> (_/\_(_/  (___(___) | http://www.vis.colostate.edu/~scriven/  |
>