Subject: FVWM: as-style EdgeScroll

From: Linus Nilsson <[email-masked]>
Date: Thu, 23 Apr 1998 16:26:10 +0200 (MET DST)

Howdy boys 'n girls.

	I think fvwm2 is the best windowmanager ever but
there is one thing that annoys me. That is the way
EgdeScroll works. I started to look around the source
a little. What i would like to do is to make EdgeScroll
only change desktop when the pointer is on the edge of
the screen AND i'm "carrying" a window with me. I don't
like scrolling of the screen accentially and I don't think
EdgeResistance is a good enough tool to solve it.

What i've been looking at is virtual.c and move.c.
I tried some changes and i succeeded in doing the opposite
thing that i wanted. :P That is scrolling only when i'm NOT
"carrying" a window, but i've not succeeded with what i want.

If anyone on this mailinglist know the sourcecode good or
would like to help me solve this little problem i'd be
very greatful. I guess it should be rather easy if you
know the source well.

Greatful for any help i can get with this.

Laters dudes.

/Linus Nilsson, [email-masked]

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Manfred Bartz" <[email-masked]>
Date: 24 Apr 1998 08:33:32 +1000

> EdgeResistance is a good enough tool to solve it.
<snip> 

Sorry, can't help with the source.

However, are you aware that you can move windows around on the pager's 
display by grabbing them with the middle mouse button?  This is usually
simulated by pressing both buttons on 2-button mice.

Combined with ``EdgeScroll 0 0'' that should be very close to what you 
want to achieve.

Regards
-- 
Manfred Bartz <[email-masked]>
---------------------------------------------------------------
Things are more like they are today than they ever were before.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].