Subject: FVWM: fvwm: close window w/ single click

From: "Frank Wilcox, Jr." <[email-masked]>
Date: Thu, 23 Apr 1998 22:34:26 -0400

In fvwm95, u can close a window by clicking on the 'x' in the corner.  Is it
possible to emulate this behavior in fvwm2?  (the exact location of the
button is irrelevant, what's important is tto be able to single-click rather
than double-click.)

-- 
Frank Wilcox, Jr. (a.k.a. _____)

can be found in #Friends on the undernet

------------------------------------------------------
Safe upon the solid rock the ugly houses stand:
Come and see my shining palace built upon the sand!
		-Edna St. Vincent Millay

Matt 8:24-7
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: William Denton <[email-masked]>
Date: Thu, 23 Apr 1998 23:10:10 -0400 (EDT)

On Thu, 23 Apr 1998, Frank Wilcox, Jr. wrote:

: In fvwm95, u can close a window by clicking on the 'x' in the
: corner.  Is it possible to emulate this behavior in fvwm2?  (the
: exact location of the button is irrelevant, what's important is tto
: be able to single-click rather than double-click.)

>From the "Mouse Bindings" part of my .fvwm2rc:

# Now the title bar buttons.
# Any button in the left title-bar button gives the window ops menu.
# Any button in the first right title-bar button Iconifies the window.
# Any button in the second title-bar button full-maximizes.
# Any button in the third (rightmost) title-bar button closes.
# Note the use of "Mouse 0" for AnyButton..

#     Button    Context Modif   Function
Mouse 0         1       A       Function "window_ops_func"
Mouse 1         2       A       Delete
Mouse 0         4       A       Maximize 100 100
Mouse 0         6       A       Iconify

The "Delete" function is what does the job.

Bill
-- 
William Denton | Toronto, Canada | http://www.vex.net/~buff/ | Caveat lector.
  "It is better to incur a mild rebuke than to perform an onerous task."
                                   -- "Uncle" Oswald Hendryks Cornelius