Subject: FVWM: fvwm2: numlock

From: "Frank Wilcox, Jr." <[email-masked]>
Date: Tue, 21 Apr 1998 16:22:52 -0400

here's a puzzler.  fvwm2 reacts differently to mouse and keyboard inputs
depending on whether or not num lock is on.

when numlock is ON, '^ + arrow keys' moves me around the virtual desktop and
'^ s' saves my document (in a text editor/word processor--which is what it's
supposed to do).

when num lock is OFF, '^ + arrow keys' moves me around my document (like it's
"supposed" to [at least imo]), and '^ s' prints '<dc3>' to screen at the spot
where my cursor is.

also, FvwmIconMan doesn't work when num lock is on.

is all this normal behavior?  if not, how could it have happened, and how can
i fix it?

-thanx

-- 
Frank Wilcox, Jr. (a.k.a. _____)

can be found in #Friends on the undernet

------------------------------------------------------
Safe upon the solid rock the ugly houses stand:
Come and see my shining palace built upon the sand!
		-Edna St. Vincent Millay

Matt 8:24-7
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: patrick finerty <[email-masked]>
Date: Tue, 21 Apr 1998 18:58:31 -0600 (MDT)

-----BEGIN PGP SIGNED MESSAGE-----

it's not much of a puzzler. fvwm2 does not handle the keyboard itself, 
X does. how your X server sends keypress events is dependent on the
server. with XFree86, the num lock key does modify some keys, usually
the other modifiers: alt, ctrl, etc.

so, yes it's normal.

- -pjf

 > is all this normal behavior?  if not, how could it have happened, and how can

- -- 
       "There is only one aim in life and that is to live it."
 Karl Shapiro,(1959) from an essay on Henry Miller's Tropic of Cancer
	  finger [email-masked] for PGP key
		    http://zifi.genetics.utah.edu