Subject: FVWM: Updating rxvt titlebars

From: "A. van Werven" <[email-masked]>
Date: Thu, 16 Apr 1998 12:08:33 +0200 (DST)

Here's another titlebar question:

I'd like to have the current user, current hostname and current working
directory displayed in the titlebar of an rxvt/xterm/whatever.
Of course, this title should be updated after every cd, login/-out, su
etc.

Any suggestions ?

-- 

A. van Werven
Dept. of Computer Science, Leiden University, The Netherlands
E-mail: [email-masked]
URL: http://www.wi.leidenuniv.nl/~avwerven

Life would be easier if I had the source code. 

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Stew Benedict <[email-masked]>
Date: Thu, 16 Apr 1998 03:30:22 -0700 (PDT)

try this (I've got this in my .bashrc):

#set the title of an xterm to show $PWD

if [ "$TERM" = "xterm" ]; then
  function cd ()
  {
    builtin cd $*
    xtitle "`whoami`@${HOSTNAME%%.*}:$PWD (`date`)"
  }
  else
  function cd ()
  {
    builtin cd $*
  }
fi

xtitle()
{
    echo -e -n "\033]2;$*\007"
}

---

From: Pete Forman <[email-masked]>
Date: Thu, 16 Apr 1998 11:40:23 +0100

You may prefer to narrow your question.  There are different solutions 
according to your shell (sh, ksh, csh, bash, etc.) and OS.

For one answer, see the X faq subject 32 at
<URL:http://www.cis.ohio-state.edu/hypertext/faq/usenet/x-faq/top.html>

If you'd like a complex .profile which works across several shells and 
OS's then email me off this list.
-- 
Pete Forman
Western Geophysical
[email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Patrick K." <[email-masked]>
Date: Thu, 16 Apr 1998 13:05:58 -0400 (EDT)

> Of course, this title should be updated after every cd, login/-out, su

   Yes.  See Richard Lister's page on this at:

      http://www.giccs.georgetown.edu/~ric/howto/Xterm-Title.html

Patrick ...

---

From: Richard Lister <[email-masked]>
Date: Thu, 16 Apr 1998 14:14:41 -0400

On Thu, 16 Apr 1998 12:08:33 +0200 (DST)
"A. van Werven" <[email-masked]> 
> Of course, this title should be updated after every cd, login/-out, su

Yup ... see:

or
  http://sunsite.unc.edu/LDP/HOWTO/mini/Xterm-Title.html
(may be older, depending on when Greg last updated).

I'm working on a newer version with more terminal types and a clearer
layout, so check my site again in a week or so.

Ric

Richard J Lister, Georgetown Institute for Cognitive and Computational Sciences
Georgetown University Medical Center, Washington, DC 20007, USA
Phone: +1 202-687 2878
Email: [email-masked] 
Web: http://www.giccs.georgetown.edu/~ric/
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].