Subject: FVWM: Newbie question

From: Maurice Lafleur <[email-masked]>
Date: Fri, 3 Apr 1998 14:07:23 -0500 (EST)

I am new at using fvwm. My system is running Slackware Linux 2.0.30 and I
installed and started to run X only a month or so ago. 

My question is the following: is there a way to make fvwm start a lock
screen program automatically after a certain period of inactivity at the
console (something similar to a password-protected screen saver in
windoze).

Thank you,

MGL
--
Maurice Lafleur     
Teacher,             
Heritage College     
325 Cite des Jeunes 
Hull. Qc.            
Canada               Voice: +1(819).778.2270 x1412
J8Y 6T3              Fax: +1(819)778.7364

mailto: [email-masked]
Visit my home page at:  <http://ommadawn.cegep-heritage.qc.ca>

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (A. van Werven)
Date: Fri, 3 Apr 1998 20:10:32 +0100 (MET)

> console (something similar to a password-protected screen saver in

To be short: nope.
This can probably be done with X somehow, but it is not an Fvwm feature.

CIAO,

-- 

A. van Werven
Dept. of Computer Science, Leiden University, The Netherlands
E-mail: [email-masked]
URL: http://www.wi.leidenuniv.nl/~avwerven

Life would be easier if I had the source code.

---

From: Guangyong Xu <[email-masked]>
Date: Fri, 03 Apr 1998 14:18:05 -0500 (EST)

This is not a FVWM issue, but you can use xautolock to invoke xlock after
a certain period. Both programs (xautolock and xlock) can be found at
sunsite (sunsite.unc.edu). You can start xautolock using your .fvwmrc file
so that everytime you log in, xautolock is run automatically:
...
AddToFunc InitFunction
...
+       "I"     Exec    xautolock 
...

-Guangyong Xu

---

From: "Donald H. Locker" <[email-masked]>
Date: Fri, 3 Apr 1998 14:45:13 -0500

Shorter answer "archie xautolock"

Donald.

---

From: Richard Lister <[email-masked]>
Date: Fri, 03 Apr 1998 14:51:53 -0500

On Fri, 3 Apr 1998 14:07:23 -0500 (EST)
Maurice Lafleur <[email-masked]> 
> console (something similar to a password-protected screen saver in

Maurice

This is nothing to do with the window manager. You want to get
xscreensaver, from http://people.netscape.com/jwz/xscreensaver/.

Can Slackware do RPMs? If so you could try the precompiled RPM from
ftp://ftp.redhat.com/pub/redhat/redhat-5.0/i386/RedHat/RPMS/.

Cheers
Ric

Richard J Lister, Georgetown Institute for Cognitive and Computational Sciences
Georgetown University Medical Center, Washington, DC 20007, USA
Phone: +1 202-687 2878
Email: [email-masked] 
Web: http://www.giccs.georgetown.edu/~ric/

---

From: Kendrick Vargas <[email-masked]>
Date: Fri, 3 Apr 1998 17:19:10 -0500 (EST)

> This can probably be done with X somehow, but it is not an Fvwm feature.

xset

or

man xset 

might help... 
			-peace

--- BEGIN GEEK CODE BLOCK ------------+-----------
GAT d- s:+ !a C+(+++) UI/L/S/B++(+++) | "In the morning glad I see
P>+ L+(++) E---- W+++ N+ o? K? w++++  |  My foe outstrech'd beneath the tree."
O--- M-- V PS+++@ PE Y-- PGP+ t++ 5   |               -The Poison Tree
X++ R- tv+ b DI++ D+ G e>*  h*(!) r-  |                William Blake
y*(+) ------ END GEEK CODE BLOCK -----+