Subject: FVWM: shells and programs

From: [email-masked] (Graeme McCaffery)
Date: Fri, 24 Apr 1998 12:27:04 +0100 (BST)

why is it that when i want to execute a program I end up with the shell
that did it still running too?

eg

spxgm    27881   S 12:21:02  0:20 netscape -install 
spxgm    27880   S 12:21:01  0:00 /bin/tcsh -c netscape -install
spxgm    27735   S 11:47:25  0:00 /bin/tcsh -c xbiff
spxgm    27747   S 11:47:31  0:00 xbiff

Graeme

p.s. anyone out there working on getting buttons to swallow the pager iconified
or the pager to have an option the show only current desk?
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Fri, 24 Apr 1998 09:10:34 -0400 (EDT)

> spxgm    27747   S 11:47:31  0:00 xbiff

Try something like this:

DestroyFunc	"RunExec"
AddToFunc	"RunExec" \
  "I"	Exec exec $0 $1 $2 $3 $4 $5 $6 $7 $8 $9

DestroyMenu	"Applications"
AddToMenu	"Applications" \
  "I"	"Netscape"	RunExec "netscape -install -display $HOSTDISPLAY"
+ "I"	"xbiff"		RunExec "xbiff -display $HOSTDISPLAY"
+ "I"	"YadaYada"	RunExec yada yada yada

-- 
(void) lar3ry();                                      [email-masked]

     "Sometimes it happens.  People just explode.  Natural causes."

---

From: Brad Giaccio <[email-masked]>
Date: Mon, 27 Apr 1998 08:17:43 -0400 (EDT)

when you start an app in your rc file does it say

"I" netscape 
	or
"I" Exec netscape

	the second is the one you should be using.

> or the pager to have an option the show only current desk?

--- There are two kinds of knowledge, you either know the answer or
			you know where to find it
		      -Kane, Johnson, and anonymous