Subject: FVWM: Cannot make a window of particular TITLE not appear

From: Sam Krishnabhat <[email-masked]>
Date: Fri, 3 Apr 1998 11:43:10 -0800 (PST)

Hi good people,

Is it possible to make a window of particular TITLE say "Error in Save"
not appear on the fvwm manager. I mean, either the window should
not be displayed OR let it be displayed, but FVWM should close
it automatically.

Can I do it ? I appreciate your help.

-sam
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Toshi Isogai <[email-masked]>
Date: Tue, 7 Apr 1998 12:19:16 -0600 (MDT)

> Can I do it ? I appreciate your help.

Try the following shell command with FvwmCommand. 

FvwmCommand -i3 -m </dev/null | perl -ne '$|=1;print "windowid $1 close\n"
if /^(0x[0-9a-f]+)\s+window\s+Error in Save/;' > ~/.FvwmCommandC 

In order to run this command on background, you need the latest version
1.4.4. You can find it at http://www.concentric.net/~isogai/fvwm2

-----------------------------------------------------
Toshi Isogai    �볭����

KENTEK Information Systems
[email-masked]

---

From: Sam Krishnabhat <[email-masked]>
Date: Tue, 7 Apr 1998 16:00:06 -0700 (PDT)

Toshi Isogai sez...
> >=20
> >=20
> >=20
> >=20
> Try the following shell command with FvwmCommand.=20
> 
> FvwmCommand -i3 -m </dev/null | perl -ne '$|=3D1;print "windowid $1 close\n=
> "
> if /^(0x[0-9a-f]+)\s+window\s+Error in Save/;' > ~/.FvwmCommandC=20

Toshi,

I thank you for the response. But I get the following message.

/users/samk/tar/FvwmCommand>xmkmf
mv Makefile Makefile.bak
imake -I/usr/openwin/lib/config
Warning:  'LocalRoot' not set - will default to '/usr/local'
"./Imakefile", line 34: Can't find include file ../../Fvwm.tmpl
/usr/openwin/bin/imake: Exit code 2.  Stop.
/users/samk/tar/FvwmCommand>

Where can I find the Fvwm.tmpl file.

BTW, where do I find the FvwmCommand executable. Or is it a module in FVWM ?

-sam

---

From: Toshi Isogai <[email-masked]>
Date: Tue, 7 Apr 1998 18:05:42 -0600 (MDT)

> Where can I find the Fvwm.tmpl file.

You must have fvwm2 source first.  Un-tar FvwmCommand on "extras" 
directory to do compilation.

This explanation is not in INSTALL file because FvwmCommand is a part of
fvwm2 distribution but I guess I should add this file since it can be
downloaded all by itself too.

> BTW, where do I find the FvwmCommand executable. Or is it a module in FVWM ?

I can send you excutables if your system is either HPUX 9.05 or Linux
2.0.33. Otherwise, you have to ask other people.

---

From: Sam Krishnabhat <[email-masked]>
Date: Tue, 7 Apr 1998 17:09:21 -0700 (PDT)

Toshi,

OK. I am one step ahead now. I built the executable. But I get the following
error message. Could you help. Do I have to be root.

/users/samk/tar/FvwmCommand>./FvwmCommand
FvwmCommand error in opening message fifo
--No such file or directory--
Exiting...
/users/samk/tar/FvwmCommand>

---

From: Toshi Isogai <[email-masked]>
Date: Tue, 7 Apr 1998 18:23:07 -0600 (MDT)

> /users/samk/tar/FvwmCommand>

This occurs when either FvwmCommand server is not running or fifos 
~/.FvwmCommandM is not created or deleted. Usually the former.
Insert  
  +  "I" Module  FvwmCommandS

in InitFunction and RestartFunction in your .fvwm2rc