Subject: FVWM: clean up before quiting

From: "Look, Joseph" <[email-masked]>
Date: Wed, 8 Apr 1998 17:48:01 -0700

I would like to know is it possible to do some cleanup (running my own
script) before executing the built-in Quit when the user select to quit
fvwm.
For example, in the .fvwmrc file the Quit selection look like this
AddToMenu "Shutdown" \
  "Quit fvwm%mini-exclam.xpm%"        Quit

Can I do something like:
AddToMenu "Shutdown" \
  "Quit fvwm%mini-exclam.xpm%"        Exec my-program , Quit

Any help will be appreciated.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "A. van Werven" <[email-masked]>
Date: Thu, 9 Apr 1998 08:59:04 +0200 (DST)

>   "Quit fvwm%mini-exclam.xpm%"        Exec my-program , Quit

AddToFunc Byebye "I" Exec (command 1)
+ "I" Command 2
+ "I" Etc...
+ "I" Quit

AddToMenu "Shutdown" Quit fvwm%min-exclam.xpm%" Function Byebye

Hope you get the idea,

-- 

A. van Werven
Dept. of Computer Science, Leiden University, The Netherlands
E-mail: [email-masked]
URL: http://www.wi.leidenuniv.nl/~avwerven

Life would be easier if I had the source code.

---

From: H}vard Fosseng <[email-masked]>
Date: Thu, 9 Apr 1998 20:12:14 +0200 (MET DST)

>From my .fvwm2rc:

AddToFunc Terminer
+ I Exec sh -c "rsh tag gnudoit \'\(hf-save-all-and-terminate\)\'; exec xlogo"
+ I Wait xlogo
+ I Quit

[...]

AddToMenu Session	Session		Title
+			&Quit		Terminer

- Håvard Fosseng