Subject: FVWM: Selecting Buttons

From: Jin Ko <[email-masked]>
Date: Wed, 29 Apr 1998 16:56:54 +0900 (KST)

Hi all,

  I have three buttons on my fvwm title bar: 
(1)Function, (4)Iconify, (2)Close.
I'd like to omit some of them for certain applications or
modules like:

Defaults: 1, 4, 2
FvwmButtons: none
TkDesk: 1, 4
Xclock: 1, 2
...

How can I do this?

Thanks in advance!

-jin

-----------------------------------------------------------------
Jin Ko                                        mailto:[email-masked]
Network Engineer                           http://ghost.nuri.net/
Inet, Inc.              phone:+82-2-531-7924 (fax:+82-2-555-8127)

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Martin Cartwright <[email-masked]>
Date: Wed, 29 Apr 1998 09:42:01 +0100 (BST)

On Wed, 29 Apr 1998, Jin Ko wrote:

->Hi all,
->
->  I have three buttons on my fvwm title bar: 
->(1)Function, (4)Iconify, (2)Close.
->I'd like to omit some of them for certain applications or
->modules like:
->
->Defaults: 1, 4, 2
->FvwmButtons: none
->TkDesk: 1, 4
->Xclock: 1, 2
->...
->
->How can I do this?
->

Use the Style NoButton option. Edit your .fvwmrc (or .fvwm2rc or
whatever it's called) and add/modify the following lines:

Style "FvwmButtons" NoButton 1, NoButton 2, NoButton 4
Style "TkDesk" NoButton 2
Style "XClock" NoButton 4

Cheers

Martin

--
[email-masked] --- http://star.pst.qub.ac.uk/~imc/vom.htm

    "Sponges grow in the ocean ... I wonder how much deeper    
          the ocean would be if that didn't happen."