Subject: FVWM: Bool != Boolean

From: Chris Siebenmann <[email-masked]>
Date: Mon, 13 Apr 1998 18:58:02 -0400

Compiling fvwm2 on a SGI Irix machine, I discovered a small mistake in
the fvwm2 code: it incorrectly assumes that a Bool is the same as a
Boolean, by declaring the same variable as 'Bool' in some places and as
'Boolean' in others. The simple fix:

--- 1.1	1998/04/13 21:42:34
+++ fvwm/fvwm.c	1998/04/13 21:42:59
@@ -83,9 +83,10 @@
 int JunkX = 0, JunkY = 0;
 Window JunkRoot, JunkChild;		/* junk window */
 unsigned int JunkWidth, JunkHeight, JunkBW, JunkDepth, JunkMask;
 
-Boolean debugging = False,PPosOverride,Blackout = False;
+Boolean debugging = False, Blackout = False;
+Bool PPosOverride;
 
 char **g_argv;
 int g_argc;

 I believe this mistake can cause mysterious memory corruption and/or
core dumps in some situations.

	- cks
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Pete Forman <[email-masked]>
Date: Tue, 14 Apr 1998 09:17:06 +0100

FVWM uses Xlib but not Xt, so it ought to be restricted to using Bool, 
False, and True for binary logic.  Boolean, FALSE and TRUE are defined
for use in the Intrinsics toolkit.  As cks points out, Bool and
Boolean are different underlying types, int and char (or long)
respectively.
-- 
Pete Forman
Western Geophysical
[email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].