Subject: FVWM: fvwm language

From: "Michael Corrieri" <[email-masked]>
Date: Thu, 30 Apr 1998 18:26:56 -0600

Is there any consideration of java as the language for the fvwm? Our company would make great use of such a feature.

The entire industry seems to be waiting for something like this. I could see a Java based Windows Manager quickly becoming the de facto standard.

With the Java VM the windows manager could become platform independent.

Sorry to jump in, and I won't do it again. Just a suggestion.

Michael Corrieri
Imagine Sofware Corporation
[email-masked]

---

From: Brady Montz <[email-masked]>
Date: 30 Apr 1998 20:18:11 -0700

"Michael Corrieri" <[email-masked]> writes:

> Is there any consideration of java as the language for the fvwm? Our =
> company would make great use of such a feature.
> 
> The entire industry seems to be waiting for something like this. I could =
> see a Java based Windows Manager quickly becoming the de facto standard.
> 

I'd like to make the point that java is not the only platform independant
language out there. Python and tcl in particular have strong constituencies. 

Also, as far as I know the discussion so far is about various degress of an
extension language, not rewriting fvwm entirely in a new language. And even if 
we did, I don't know if we would want to use awt (or tk) for the graphical
components of fvwm (and I don't know, but kinda doubt, that awt allows for the 
gory X stuff a window manager needs, like reparenting windows).

-- 
 Brady Montz
 [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].