Subject: FVWM: While switching to different windows on fvwm2 2.0.46

From: Sam Krishnabhat <[email-masked]>
Date: Wed, 15 Apr 1998 13:53:55 -0700 (PDT)

Hi folks,

I have got a really annoying problem with fvwm2.

When I switch from one window to another, on the same screen
some I get a "think black round" shaped cursor. That happens when
I launch a xterm, or when I launch a 'Preferences' window on
netscape etc., all the time....

Till I click one or two times, that curser does not vanish. And
nothing happens, no window comes when it is of that shape.

Does anybody know how do I solve the problem. I really appreciate
your time in hepling me.

I use SUN Solaris Ultra system.

-sam
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Kai Grossjohann <[email-masked]>
Date: 16 Apr 1998 12:58:36 +0200

> netscape etc., all the time....

What do you do to `switch from one window to another'?  Keybinding?
With the mouse?  Do you have focus follows mouse or do you have click
to focus?

kai
-- 
Have you been LJBF'd this week?

---

From: Dan Espen <[email-masked]>
Date: Thu, 16 Apr 1998 08:51:45 -0400

> some I get a "think black round" shaped cursor. That happens when
      ^ times?
> Does anybody know how do I solve the problem. I really appreciate

I  don't think you've provided  enough   information for a  definitive
answer, so what  I can tell you   in general is,  fvwm uses  the round
cursor to indicate that it wants you to click somewhere.

For example, if you select "resize" from a pull down menu on the root,
it doesn't  know  which window  you want to  resize.  It   changes the
cursor to a round dot until you click on a window.

--
Dan Espen                                Phone: (732) 699-5570
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Sam Krishnabhat <[email-masked]>
Date: Thu, 16 Apr 1998 11:02:01 -0700 (PDT)

Kai Grossjohann sez...
> With the mouse?  Do you have focus follows mouse or do you have click

I have focus follows mouse. No Keybinding that I know of.

Following is my .fvwm2rc
~~~~~~~~~~~~~~~~~~~~~~~~

##########################################################################
# FVWM - F? Virtual Window Manager, Version 2.x (fvwm2) Configuration File
# Created April 1996
#

##########################################################################
# PATH Setup 
#
# Colon seperated unix directory paths for Modules, xpm files, and bitmaps
ModulePath /usr/local/packages/fvwm/fvwm-2.0.46/modules
PixmapPath /usr/local/include/X11/pixmaps
IconPath   /usr/local/include/X11/bitmaps

############################################################################
# COLORS and FONTS
#
# Set the fore and back border colors for the window that has focus
#HilightColor		linen SteelBlue4
HilightColor		linen VioletRed4

# Set fore/back border colors for all other windows 
#Style "*" Color linen/VioletRed4
Style "*" Color linen/SteelBlue4

# Set colors/font for pop-up menus
# Syntax: MenuStyle forecolor backcolor shadecolor font style(fvwm/mwm)
MenuStyle maroon grey60 grey40 -adobe-times-bold-r-*-*-14-*-*-*-*-*-*-* fvwm
#MenuStyle black grey slategrey 7x13bold fvwm

# Set fonts to use on title bar and icon label
#SAM: Made fonts from 9x15 to 10x20
#WindowFont              9x15
WindowFont              10x20
# WindowFont              -adobe-times-bold-r-*-*-18-*-*-*-*-*-*-*
#IconFont                9x15
IconFont                10x20
# IconFont                -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*

############################################################################
# ICON Setup
#
# Auto Place Icons is a nice feature (Left Top Right Bottom)
Style "*" IconBox -215 200 -1 -100 

# If you don't want icons for some or all windows (or all of them!)
# Style "*" NoIcon

# If you want ALL icons to follow you around the desktop (Sticky)
#Style "*" StickyIcon

############################################################################
# FOCUS Setup
#
# Does the window with focus control the colormap, or the one under the mouse
#SAM: Uncommented this; donno what exactly it is.
ColormapFocus FollowsFocus
# ColormapFocus FollowsMouse
#SAM: Added this; don't know what it does
#WindowShadeAnimate 10

# SAM: Gave me errors for both of these
#GlobalOpts SmartPlacementIsReallySmart, MouseFocusRaises
#GlobalOpts SmartPlacementIsReallySmart, MouseFocus
GlobalOpts SmartPlacementIsReallySmart

Style "*"	FocusFollowsMouse
Style "*"	RandomPlacement, SmartPlacement
#SAM: Added !!!
Style "*"	DecorateTransient

# Uncomment this to force you to click in a window to give it focus
# SAM: Uncommented it. didn't really work
#Style "*" ClickToFocus

# default: focus follows mouse
# SAM: This is how MouseFocus and SloppyFocus work. I commented Sloppy part
#      and enabled MouseFocus. See man pages for details. A practical
#      explanation can be: You have a netscape window. You another netscape
#      window. Now, do a Edit/Find in the second netscape window. Now, if
#      the sloppy is enabled it brings up the main (first) netscape window
#      keeping the focus on Find window, which is disturbing.

#Style "*term" MouseFocus
Style "*" MouseFocus
ChangeDefaultFocus FocusFollowsMouse

# If you knock your mouse out of the xterm, it keeps focus while in root window
#Style "*term"		SloppyFocus

# SAM: Does not work with fvwm2. Works only with fvwm
#AutoRaise 800

############################################################################
# MISC Setup
#
# click/release must occur in <n milliseconds to be a "click"
ClickTime 250

# if the window occupies less than n% of the screen, draw it opaque
OpaqueMoveSize 5

# flip by whole pages on the edge of the screen, but delay for a half second
#EdgeScroll 100 100
#SAM: I did this since I don't it to go over to next page.
EdgeScroll 0 0
EdgeResistance 500 20

# MWM Emulation: Don't ignore hints for functions and transient decoration
Style "*" MWMFunctions, MWMDecor
# Changes the look of the "rubberband" you see when moving windows (0 - 255) #XORvalue 100
###########################################################################
# PAGER Setup
#
# set the desk top size in units of physical screen size (width x height)
DeskTopSize 3 3

############################################################################
# WINDOW Placement
#
# SmartPlacement makes new windows pop-up in blank regions of screen 
Style "*" SmartPlacement

# If SmartPlacement fails, this places it randomly instead of making you do it
Style "*" RandomPlacement

############################################################################
# STYLE Flag Setup
#
# (decorations and window options) 
# Note: Order is important!! If compatible styles are set, styles are ORed
# together. If conflicting styles are set, the last one specified is used.

# change the default width, set a global icon, and give borders to popups
Style "*" BorderWidth 7, HandleWidth 7, Icon x.xpm, DecorateTransient

Style "Fvwm*"		NoTitle, Sticky, WindowListSkip, NoPPosition
Style "Fvwm*"       BorderWidth 2, CirculateSkipIcon, CirculateSkip
Style "FvwmPager"   StaysOnTop
Style "FvwmBanner"  StaysOnTop
Style "*lock"		NoTitle, Sticky, WindowListSkip
Style "xbiff"		NoTitle, Sticky, WindowListSkip
Style "xload"		NoTitle, Sticky, WindowListSkip, ClickToFocus
Style "xsession"	NoTitle, Sticky, WindowListSkip, ClickToFocus
Style "xconsole"	NoTitle, Sticky, WindowListSkip, ClickToFocus
Style "xfsm"		NoTitle, Sticky, WindowListSkip, ClickToFocus
Style "xdaliclock"	NoTitle, Sticky, WindowListSkip, ClickToFocus
Style "Netscape*"	ClickToFocus, MouseFocus, NoPPosition
#Style "Netscape"	MouseFocus
Style "FrameReader"	ClickToFocus
Style "FrameMaker"	ClickToFocus
Style "FvwmButtons"	ClickToFocus
Style "Time 3D"		NoTitle, Sticky
Style "*term"		Icon NeXT.xpm
Style "xcalc"		Icon xcalc.xpm
Style "xbiff"		Icon mail1.xpm
Style "xman"		Icon xman.xpm
Style "Demineur"	Icon jolifond.xpm
Style "xneko"		Icon xnekocat.xpm
Style "emacs"		NoPPosition
Style "Mosaic"		NoPPosition
Style "xmh"		Icon mail2.xpm StartsOnDesk 2
# SAM: Added
Style "Mail"		NoTitle
Style "mailbox"		NoTitle, Sticky, WindowListSkip, ClickToFocus
Style "xmailwatcher" NoTitle, Sticky, WindowListSkip, ClickToFocus

#############################################################################
# START-UP Functions
#
AddToFunc "InitFunction" "I" Module FvwmButtons
+		"I" Module FvwmPager 0 0
+		"I" Module FvwmAudio
+		"I" Next [!iconic CurrentScreen xterm] Focus
+		"I" CursorMove 30 40
+		"I"	Exec /users/samk/bin/xautolock -time 3 -locker /usr/openwin/bin/xlock &
+		"I" Module FvwmAuto 800 raise lower
# Above works too OR refer SAM1234

AddToFunc "RestartFunction" "I" Module FvwmButtons
+		"I" Module FvwmPager 0 0
+		"I" Module FvwmAudio
+		"I" Next [!iconic CurrentScreen xterm] Focus
+		"I" CursorMove 30 40

# Uncomment this to make windows auto-raise after [x] milliseconds 
#AddToFunc "InitFunction" "I" Module FvwmAuto 0

# SAM1234: I prefer this. Do man FvwmAuto if interested.
AddToFunc "InitFunction" "I" Module FvwmAuto 800 raise lower

############################################################################
# BUTTON Setup
#

## Buttons actually being used (duplicated below)
# small up triangle
ButtonStyle 2 4 50x35@1 65x65@0 35x65@0 50x35@1
# small down triangle
ButtonStyle 4 4 50x65@1 35x35@1 65x35@1 50x65@0
# Stylized X
ButtonStyle 3 16 20x20@1 30x20@1 50x40@1 70x20@1 80x20@1 80x30@0 60x50@0 80x80@0 70x80@0 50x60@0 30x80@0 20x80@0 20x70@0 40x50@1 20x30@0 20x20@1

## Triangles
#
# Small up Triangle
#ButtonStyle * 4 50x35@1 65x65@0 35x65@0 50x35@1
# Small down Triangle
#ButtonStyle * 4 50x65@1 35x35@1 65x35@1 50x65@0
# Large up Triangle
#ButtonStyle 6 4 50x25@1 75x75@0 25x75@0 50x25@1
# Large down Triangle
#ButtonStyle 8 4 50x75@1 25x25@1 75x25@1 50x75@0

## Boxes
#
# Big Box 
#ButtonStyle 0 5 25x25@1 25x75@1 75x75@0 75x25@0 25x25@1
# Little Box
#ButtonStyle 9 5 40x40@1 60x40@1 60x60@0 40x60@0 40x40@1
# Tall Box
#ButtonStyle 7 5 40x25@1 60x25@1 60x75@0 40x75@0 40x25@1
# Dot
#ButtonStyle 5 5 45x45@1 55x45@1 55x55@0 45x55@0 45x45@1
# Big Box with arrow to little box (iconify)
#ButtonStyle 4 14 20x20@1 20x70@1 70x70@0 70x20@0 20x20@1 60x60@0 60x50@0 60x60@0 50x60@0 60x60@0 60x80@0 80x80@0 80x60@0 60x60@0

## X's
#
# Standard X
#ButtonStyle 3 17 20x20@1 30x20@1 50x40@1 70x20@1 80x20@1 80x30@0 60x50@0 80x70@1 80x80@0 70x80@0 50x60@0 30x80@0 20x80@0 20x70@0 40x50@1 20x30@0 20x20@1
# Funky X 
#ButtonStyle 3 13 26x29@1 34x21@1 50x35@1 70x21@1 79x29@1 63x48@0 79x65@1 70x75@0 50x61@0 34x75@0 26x65@0 44x48@1 26x29@0
# Stylized X
#ButtonStyle 3 16 20x20@1 30x20@1 50x40@1 70x20@1 80x20@1 80x30@0 60x50@0 80x80@0 70x80@0 50x60@0 30x80@0 20x80@0 20x70@0 40x50@1 20x30@0 20x20@1

## Lightning Bolts
#
# Small Lightning Bolt (skinny at both ends)
#ButtonStyle 5 7 70x15@0 30x55@1 50x55@0 40x85@1 80x45@0 60x45@1 70x15@0
# Big Lighting Bolt (Fat at top, comes to a point)
#ButtonStyle 6 8 35x15@1 20x50@1 40x50@0 30x80@1 75x40@0 50x40@1 75x15@0 35x15@1

## Miscellaneous Buttons
#
# Nested Right Angles (looks kinda crappy)
#ButtonStyle 5 13 10x0@1 80x0@1 80x10@1 80x80@0 0x80@0 0x60@1 10x65@1 70x65@0 70x0@0 55x0@1 55x10@1 55x55@0 10x55@0
# Nested Right Angles (looks nice)
#ButtonStyle 6 14 0x0@1 0x20@1 20x20@0 20x0@0 0x0@1 0x25@1 25x25@1 25x0@1 55x0@1 55x55@0 0x55@0 0x60@1 60x60@1 60x0@1
# 4 Horizontal bars (sticky)
#ButtonStyle 7 12 10x23@0 90x23@0 90x28@0 10x28@1 10x47@1 90x47@0 90x52@0 10x52@1 10x70@2 90x70@0 90x76@0 10x76@1
# Expanding Windows (iconify -- looks NICE)
#ButtonStyle 8 16 60x40@1 60x80@0 15x80@0 15x40@1 60x40@1 40x40@1 40x25@1 75x25@1 75x60@0 60x60@0 75x60@0 75x40@0 85x40@0 85x15@0 60x15@1 60x25@1

## Arrows Galore
#
# Up Arrow
#ButtonStyle 3 8 40x80@1 40x50@1 20x50@1 50x20@1 80x50@0 60x50@0 60x80@0 40x80@0
# Down Arrow
#ButtonStyle 3 8 40x20@1 40x50@1 20x50@1 50x80@1 80x50@0 60x50@0 60x20@0 40x20@1
# Left arrow  ( <- )
#ButtonStyle 7 8 80x40@1 50x40@1 50x20@1 20x50@1 50x80@0 50x60@0 80x60@0 80x40@0
# Right arrow ( -> )
#ButtonStyle 8 8 20x40@1 50x40@1 50x20@1 80x50@1 50x80@0 50x60@0 20x60@0 20x40@1
# Horizontal Line with arrowheads on left and right ( <-> )
#ButtonStyle * 12 10x50@1 35x25@1 35x40@1 65x40@1 65x25@1 90x50@1 65x75@0 65x60@0 35x60@0 35x75@0 10x50@0 10x50@1
# Vertical Line with arrowheads on top and bottom
#ButtonStyle * 12 50x10@1 25x35@1 40x35@1 40x60@1 25x60@1 50x85@1 75x60@0 60x60@0 60x35@0 75x35@0 50x10@0 50x10@1
# Diagonal Line with arrowheads on top and bottom ( / )
#ButtonStyle 5 11 80x15@1 45x15@1 55x25@1 25x55@1 15x45@1 15x80@1 50x80@0 40x70@0 70x40@0 80x50@0 80x15@0
# Diagonal Line with arrowheads on top and bottom ( \ )
#ButtonStyle 6 12 55x15@0 45x25@0 75x55@0 85x45@0 85x80@0 50x80@0 60x70@1 30x40@1 20x50@1 20x15@1 55x15@1 55x15@0
#
# the number "2"
#ButtonStyle 8 12 80x80@0 22x80@0 80x40@0 70x25@0 30x25@0 20x35@0 20x30@1 30x20@1 70x20@1 80x30@1 20x75@1 80x75@1

# SAM: I found Window-Ops totally useless. So, replacing that with some useful
# menu list. I will call it "SamApps"

AddToMenu SamApps		"Applicaions" Title

+	"samk-con 2001:samk-con1"		Exec exec $HOME/bin/xt.samk-con 2001 samk-con1 2500
+	"samk-con 2002:samk_4k_1"		Exec exec $HOME/bin/xt.samk-con 2002 samk_4k_1 4500
#+	"samk-con 2003:samk_2k_1"		Exec exec $HOME/bin/xt.samk-con 2003 samk_2k_1 2500
+	"samk-con 2003:samk_38k_3"		Exec exec $HOME/bin/xt.samk-con 2003 samk_38k_3 3810
+	"samk-con 2004:samk_4k_2"		Exec exec $HOME/bin/xt.samk-con 2004 samk_4k_2 4000
+	"samk-con 2005:samk_4k_3"		Exec exec $HOME/bin/xt.samk-con 2005 samk_4k_3 4000
+	"samk-con 2006:samk_2k_2"		Exec exec $HOME/bin/xt.samk-con 2006 samk_2k_2 2500
+	"samk-con 2007:samk_16k_1"		Exec exec $HOME/bin/xt.samk-con 2007 samk_16k_1 1600
+	"samk-con 2008:samk_7k_1"		Exec exec $HOME/bin/xt.samk-con 2008 samk_7k_1 7500
+	"samk-con 2009:samk_52k_1"		Exec exec $HOME/bin/xt.samk-con 2009 samk_52k_1 5200
+	"samk-con 2010:samk_36k_1"		Exec exec $HOME/bin/xt.samk-con 2010 samk_36k_1 3640
+	"samk-con 2011:samk_4k_4"		Exec exec $HOME/bin/xt.samk-con 2011 samk_4k_4 4500
+	"samk-con 2012:samk_7k_2"		Exec exec $HOME/bin/xt.samk-con 2012 samk_7k_2 7200
+	"samk-con 2013:samk_7k_3"		Exec exec $HOME/bin/xt.samk-con 2013 samk_7k_3 7200
+	"samk-con 2014:samk_38k_2"		Exec exec $HOME/bin/xt.samk-con 2014 samk_38k_2 3810
+	"samk-con 2015:samk_53k_1"		Exec exec $HOME/bin/xt.samk-con 2015 samk_53k_1 5300
+	"samk-con 2016:samk_38k_1"		Exec exec $HOME/bin/xt.samk-con 2016 samk_38k_1 3810
#+	"" Nop
#+	"MS CALLBACK"		Popup 	mscallbackmenu
#+	"D1DT"		Popup 	d1dtmenu
+	"" Nop
+	"samk-con1 2001:samk-con"		Exec exec /users/$USER/bin/xt.samk-con1 2001 "samk-con"
+	"Calendars"		Popup 	CalendarsMenu
+	"Calculators"	Popup 	Calculators
+	"Dictionary"		Exec	exec xwebster
+	"Copy/Paste Tool"	Exec	exec $HOME/bin/xcb -n 3 -l vertical
+	"Mailtool"		Exec	exec /usr/openwin/bin/mailtool  -Mi 1 -Mf $HOME/Mail/nothing
+	"Documentation"		Popup DocumentationMenu
+	"Font Utilities"	Popup FontsMenu
+	"Games"				Popup GameMenu
+	"Mamatha"			Popup MamathaStuff
+	"MeetingMaker"		Exec exec xon mmxp-unix-248-1 mmxp
+	"XLock"				Exec exec /usr/openwin/bin/xlock -mode flame

AddToMenu Calculators "Calculators" Title
+	"Calctool"		Exec	exec /usr/openwin/bin/calctool
+	"Xcalc"			Exec	rsh trix /usr/local/X11R5/bin/xcalc

AddToMenu CalendarsMenu "CalendarsMenu" Title
+	"cm"		Exec	exec /usr/openwin/bin/cm
#+	"xkal"		Exec	exec xkal

AddToMenu DocumentationMenu "DocumentationMenu" Title
+	"ctopic"		Exec	exec ctopic
+	"UniverCD"		Exec	 exec krsm
+	"/csc/Docs"		Exec	bell
+	"/ecs/docs"		Exec	bell

AddToMenu FontsMenu "FontsMenu" Title
+	"xfd"		Exec exec xfd
+	"xfontsel"	Exec exec xfontsel

#		Exec	"Xsol"		exec /usr/openwin/demo/xsol -nodrag
AddToMenu GameMenu "Games" Title
+	"Xsol"		Exec exec $HOME/bin/xx -nodrag
+	"spider"	Exec exec $HOME/games/spider
+	"puzzle"	Exec exec $HOME/games/puzzle
+	"Hack"		Exec exec xterm -T \"hack\" -e hack
+	"Tetris"	Exec exec xtetris
+	"xmille"	Exec exec xmille
+	"xmines"	Exec exec xmines
 
AddToMenu PostscriptMenu "PostscriptMenu" Title
+	"pageview"	Exec exec pageview
+	"Ghostscript"	Exec exec gs
+	"Ghostview"	Exec exec ghostview
 
AddToMenu X-Windows "X-Windows" Title
+	"XCalc"		Exec exec xcalc -rpn
+	"XSnap"		Exec exec xsnap
+	"Xpr"		Exec exec (sleep 2; xwd | xpr -dev ps | lpr)
+	"XMag"		Exec exec xmag
+	"Gaintool"	Exec exec x_gaintool
+	"XKill"		Exec exec xkill
+	"XMan"		Exec exec xman
+	"XLock"		Exec exec /usr/openwin/bin/xlock -mode qix
+	"Xrn"		Exec exec xrn

##############################################################################
# MENU Setup
#

# This defines the most common window operations
AddToMenu Window-Ops    "Window Ops"    Title
+                       "Refresh Screen" Refresh
+                       "Move"          Move-or-Raise2
+                       "Resize"        Resize-or-Raise2
+                       "Raise"         Raise
+                       "Lower"         Lower
+                       "(De)Iconify"   Iconify
+                       "(Un)Stick"     Stick
+                       "(Un)Maximize"  maximize_func
+                       ""              Nop
+                       "Delete"        Delete
+                       "Close"         Close
+                       "Destroy"       Destroy
+                       ""              Nop

# A trimmed down version of "Window Ops", good for binding to decorations
AddToMenu Window-Ops2   "Refresh"		Refresh
+                       "(Un)Stick"     Stick
+                       "Resize"        Resize-or-Raise
+                       "Raise/Lower"   RaiseLower
+                       "Iconify"       Iconify
+                       ""              Nop
+                       "Delete"        Delete
+                       ""              Nop
+                       "Move"          Move-or-Raise
+                       "ScrollBar"     Module FvwmScroll 2 2
+                       "Print"         PrintFunction
+                       "Close"         Close
+                       "Destroy"       Destroy

AddToMenu FvwmCommands	"Fvwm Commands" Title
+			"Restart Fvwm2" Restart fvwm2
+			"Fvwm Setup"	Popup FvwmSetup
+ 			"Fvwm Modules"  Popup FvwmModules
+			"Fvwm Simple Config Ops"  Popup Misc-Ops
+			"" Nop
+			"Exit Fvwm"     Quit

AddToMenu FvwmSetup	"Fvwm Setup" Title
+			"Change Scrolling"	Popup FvwmScroll

AddToMenu FvwmScroll	"Change Scroll Behavior" Title
+			"OFF"   EdgeScroll 0 0
+			"ON"    EdgeScroll 100 100
+			"Horizontal Only"       EdgeScroll 100 0
+			"Vertical Only"         EdgeScroll 0 100
+			"Partial"               EdgeScroll 50 50

AddToMenu FvwmModules	"Fvwm Modules" Title
+                       "Pager"         Module  FvwmPager 0 0
+                       "Button-Bar"    Module  FvwmButtons
+                       "WinList"       Module  FvwmWinList
+                       "Identify"      Module  FvwmIdent
+			""		Nop
+                       "Clean-Up"      Module  FvwmClean
+                       "SaveDesktop"   Module  FvwmSave
+                       "Debug"         Module  FvwmDebug
+                       "Background"    Module  FvwmBacker
+                       "IconBox"       Module  FvwmIconBox
+                       "Banner"        Module  FvwmBanner
+                       "Talk"          Module  FvwmTalk
+                       "Prompt"        Module  FvwmPrompt "hello" raise

AddToMenu Misc-Ops "Misc Config Opts" Title
+                  "Sloppy Focus"        ChangeDefaultFocus SloppyFocus
+                  "Click To Focus"      ChangeDefaultFocus ClickToFocus
+                  "Focus Follows Mouse" ChangeDefaultFocus FocusFollowsMouse
+                  "" Nop
+                  "Colormap Follows Mouse" ColormapFocus FollowsMouse
+                  "Colormap Follows Focus" ColormapFocus FollowsFocus
+                  "" Nop
+                  "Full Paging ON"         EdgeScroll 100 100
+                  "All Paging OFF"         EdgeScroll 0 0
+                  "Horizontal Paging Only" EdgeScroll 100 0
+                  "Vertical Paging Only"   EdgeScroll 0 100
+                  "Partial Paging"         EdgeScroll 50 50
+                  "Full Paging && Edge Wrap" EdgeScroll 100000 100000

# This is the root menu
AddToMenu RootMenu "Root Menu"  Title
+	"Xterms"	Popup	ColouredWindows1
+	"Trix Xterms"	Popup	ColouredWindows2
+	"Netscape 4.05"	Exec exec /auto/usrlocal/bin/cnetscape.beta
+	"IE 4.0"		Exec exec /usr/ie/bin/iexplorer
+	"" Nop
#+	"Netscape 4.02"	Exec	exec /usr/local/bin/cnetscape
#+	"Samk:10x20"	Exec	exec /users/$USER/bin/xt.samk
+	"Samk:10x20"	remote_login samk-ultra 98x49 MidnightBlue LightGoldenrod 10x20
+	"Samk:9x15"		remote_login samk-ultra 80x40 black white 9x15
+	"Samk:7x14"		remote_login samk-ultra 100x52 black white 7x14
+	"Samk:Default"	Exec	exec /users/$USER/bin/xt.samk.default
+	"" Nop
+	"Xterm:10x20"	local_login 98x49	MidnightBlue LightGoldenrod 10x20
+	"Xterm:9x15"	local_login 80x40	MidnightBlue LightGoldenrod 9x15
+	"Xterm:7x14"	local_login 100x52	MidnightBlue LightGoldenrod 7x14
+	"" Nop
+	"Trix:10x20"	remote_login trix 98x49 MidnightBlue LightGoldenrod 10x20
+	"Trix:9x15"		remote_login trix 80x40 black white 9x15
+	"Trix:7x14"		remote_login trix 100x52 black white 7x14
+	"Trix:Default"	Exec	exec /users/$USER/bin/xt.trix.default
+	"Fvwm Xterm" Exec exec xterm -sb -sl 2048 -font 9x15 -geometry =81x35+50+50 -s -rw &
+	"" Nop
+	"" Nop
+	"FrameMaker"	Exec	exec /usr/frame5.1/bin/maker -console_geometry +2+800
+	"PDF Reader"	Exec	exec $HOME/Acrobat3/bin/acroread
+	"MailBox"		Exec	exec /users/$USER/bin/MailBox
+	"iwan-view4"	Exec	exec /users/$USER/bin/xt.view4.9x15
#+	"wan-core2"		Exec	exec /usr/openwin/bin/xterm -e rsh wan-core2
+	"Elm"			Exec	exec  /users/$USER/bin/xt.trix.elm
+	"" Nop
+	"" Nop
+	"Fvwm"			Popup FvwmCommands
+	"Editors"		Popup	EditorsMenu
+	"Lock Screen"	Popup XlockMenu
#+	"Setup autons"	Exec  	exec setupat
#+	"XLock"			Exec exec /usr/openwin/bin/xlock -mode flame
#+	"GNU Emacs"		Exec  	exec gnuemacs
#+	"Mail to Sam"	Exec  	/usr/openwin/bin/xterm -e /usr/local/packages/elm/current/bin/elm -s "Hello" samk
+	"Utilities"		Popup Utilities
+	"trix"	Exec xterm -sb -sl 2048 -font 8x13 -geometry =80x35+50+50 -n "trix" -T "trix" -s -rw -e telnet trix &
#SAM: This is not for fvwm. It is for openwindows manager.
#+	"Properties"	Exec	exec /usr/openwin/bin/props
+	"Refresh"		Refresh
#+	"Leisure"		Popup Leisure

AddToMenu	EditorsMenu "Text Editors" Title
+	"textedit"	Exec	exec /usr/openwin/bin/textedit
+	"Emacs"		Exec	exec /sw/current/solaris2bin/emacs
+	"Xemacs"	Exec	exec /usr/local/packages/xemacs/xemacs-19.14/bin/xemacs
+	"vi"		Exec	/usr/openwin/bin/xterm -e vi
+	"xedit"		Exec	exec /usr/openwin/bin/xedit
#+	"dtpad"		Exec	exec rsh samk-ultra $HOME/bin/dt/dtpad

AddToMenu MamathaStuff "Mamatha\'s"	Title	
+	"mailtool"	Exec	exec /users/$USER/msk/MailTool
+	"mailwatcher"	Exec	exec /usr/local/contrib/bin/xmailwatcher mailbox $HOME/Mail/mamathasampath -poll 5 -silent -fn fixed -title Mail -geometry 150x60+775+690 -j

AddToMenu ColouredWindows2 "trix logins" Title
+	"" Nop
+	"trix:10x20" Nop
+	"" Nop
+	"DarkSlateGrey.GhostWhite" Exec exec $HOME/bin/xt.generic trix DarkSlateGrey GhostWhite 10x20
+	"turquoise4.darksalmon" Exec exec $HOME/bin/xt.generic trix turquoise4 darksalmon 10x20
+	"SlateGray.yellow" Exec exec $HOME/bin/xt.generic trix SlateGray yellow 10x20
+	"CadetBlue.white" Exec exec $HOME/bin/xt.generic trix CadetBlue white 10x20
+	"RosyBrown.cyan" Exec exec $HOME/bin/xt.generic trix RosyBrown cyan 10x20
+	"MidnightBlue.LightGoldenrod" Exec exec $HOME/bin/xt.generic trix MidnightBlue LightGoldenrod 10x20
+	"LightCoral.cyan" Exec exec $HOME/bin/xt.generic trix LightCoral cyan 10x20
+	
+	"" Nop
+	"trix:7x14" Nop
+	"" Nop
+	"DarkSlateGrey.GhostWhite" Exec exec $HOME/bin/xt.generic trix DarkSlateGrey GhostWhite 7x14
+	"turquoise4.darksalmon" Exec exec $HOME/bin/xt.generic trix turquoise4 darksalmon 7x14
+	"SlateGray.yellow" Exec exec $HOME/bin/xt.generic trix SlateGray yellow 7x14
+	"CadetBlue.white" Exec exec $HOME/bin/xt.generic trix CadetBlue white 7x14
+	"RosyBrown.cyan" Exec exec $HOME/bin/xt.generic trix RosyBrown cyan 7x14
+	"MidnightBlue.LightGoldenrod" Exec exec $HOME/bin/xt.generic trix MidnightBlue LightGoldenrod 7x14
+	"LightCoral.cyan" Exec exec $HOME/bin/xt.generic trix LightCoral cyan 7x14
+	

AddToMenu ColouredWindows1 "samk-ultra logins" Title
#+	"" Nop
+	"samk-ultra: 10x20" Nop
+	"" Nop
+	"DarkSlateGrey.GhostWhite" Exec exec $HOME/bin/xt.generic samk-ultra DarkSlateGrey GhostWhite 10x20
+	"turquoise4.darksalmon" Exec exec $HOME/bin/xt.generic samk-ultra turquoise4 darksalmon 10x20
+	"SlateGray.yellow" Exec exec $HOME/bin/xt.generic samk-ultra SlateGray yellow 10x20
+	"CadetBlue.white" Exec exec $HOME/bin/xt.generic samk-ultra CadetBlue white 10x20
+	"RosyBrown.cyan" Exec exec $HOME/bin/xt.generic samk-ultra RosyBrown cyan 10x20
+	"MidnightBlue.LightGoldenrod" Exec exec $HOME/bin/xt.generic samk-ultra MidnightBlue LightGoldenrod 10x20
+	"LightCoral.cyan" Exec exec $HOME/bin/xt.generic samk-ultra LightCoral cyan 10x20
+	"DarkSalmon.blueviolet" Exec exec $HOME/bin/xt.generic samk-ultra DarkSalmon blueviolet 10x20
+	"DarkGoldenrod.blueviolet" Exec exec $HOME/bin/xt.generic samk-ultra DarkGoldenrod blueviolet 10x20
+	"LightSteelBlue.blueviolet" Exec exec $HOME/bin/xt.generic samk-ultra LightSteelBlue blueviolet 10x20
+	"LightSeaGreen.blueviolet" Exec exec $HOME/bin/xt.generic samk-ultra LightSeaGreen blueviolet 10x20
+	"tan.red" Exec exec $HOME/bin/xt.generic samk-ultra tan red 10x20
+	"DeepPink3.cyan" Exec exec $HOME/bin/xt.generic samk-ultra DeepPink3 cyan 10x20
+	"LightPink.black" Exec exec $HOME/bin/xt.generic samk-ultra LightPink black 10x20
+	"PaleVioletRed.GhostWhite" Exec exec $HOME/bin/xt.generic samk-ultra PaleVioletRed GhostWhite 10x20
+	"BlueViolet.GhostWhite" Exec exec $HOME/bin/xt.generic samk-ultra BlueViolet GhostWhite 10x20
+	"" Nop
+	"samk-ultra: 7x14" Nop
+	"" Nop
+	"DarkSlateGrey.GhostWhite" Exec exec $HOME/bin/xt.generic samk-ultra DarkSlateGrey GhostWhite 7x14
+	"turquoise4.darksalmon" Exec exec $HOME/bin/xt.generic samk-ultra turquoise4 darksalmon 7x14
+	"SlateGray.yellow" Exec exec $HOME/bin/xt.generic samk-ultra SlateGray yellow 7x14
+	"CadetBlue.white" Exec exec $HOME/bin/xt.generic samk-ultra CadetBlue white 7x14
+	"RosyBrown.cyan" Exec exec $HOME/bin/xt.generic samk-ultra RosyBrown cyan 7x14
+	"MidnightBlue.LightGoldenrod" Exec exec $HOME/bin/xt.generic samk-ultra MidnightBlue LightGoldenrod 7x14
+	"LightCoral.cyan" Exec exec $HOME/bin/xt.generic samk-ultra LightCoral cyan 7x14
+	"DarkSalmon.blueviolet" Exec exec $HOME/bin/xt.generic samk-ultra DarkSalmon blueviolet 7x14
+	"DarkGoldenrod.blueviolet" Exec exec $HOME/bin/xt.generic samk-ultra DarkGoldenrod blueviolet 7x14
+	"LightSteelBlue.blueviolet" Exec exec $HOME/bin/xt.generic samk-ultra LightSteelBlue blueviolet 7x14
+	"LightSeaGreen.blueviolet" Exec exec $HOME/bin/xt.generic samk-ultra LightSeaGreen blueviolet 7x14
+	"tan.red" Exec exec $HOME/bin/xt.generic samk-ultra tan red 7x14
+	"DeepPink3.cyan" Exec exec $HOME/bin/xt.generic samk-ultra DeepPink3 cyan 7x14
+	"LightPink.black" Exec exec $HOME/bin/xt.generic samk-ultra LightPink black 7x14
+	"PaleVioletRed.GhostWhite" Exec exec $HOME/bin/xt.generic samk-ultra PaleVioletRed GhostWhite 7x14
+	"BlueViolet.GhostWhite" Exec exec $HOME/bin/xt.generic samk-ultra BlueViolet GhostWhite 7x14
#+	"" Nop
+	"" Nop
+	"Testing" Exec exec /users/$USER/bin/xt.trix.testing
+	"vi Testfile" Exec /usr/openwin/bin/xterm -e vi /users/$USER/bin/xt.trix.testing
	
# This menu will fire up some often used programs
AddToMenu Utilities 	"Choose one:" Title
+	                "emacs" Exec emacs -geometry 81x35+150+34 -fn 9x15 &
+			"xv" Function warp-or-run xv "Exec xv -ncols 240 -geometry +0+0 &"
+	                "xfig" Exec exec xfig &
+	                "xpaint" Exec exec xpaint &
+	                "Top"    Exec  exec rxvt -T Top -n Top -e top &
+	                "xMan" Exec exec xman -notopbox -geometry +150+102 &
+	                "xloaD" Exec exec xload -geometry =136x136+0+0 &
+	                "xcalc" Exec exec xcalc &
+	                "calc" Exec exec calc &
+	                "xclipboard" Exec exec xclipboard &
+	                "xclock" Exec exec xclock &
+	                "clock" Exec exec clock &

# Leisure stuff that doesn't go anywhere else..
AddToMenu Leisure   "Time for Fun!" Title
+	                "xboing" Exec exec xboing -sound &
+	                "xevil" Exec exec xevil &
+	                "xsnow" Exec exec xsnow &
+	                "xjewel" Exec exec xjewel &
+	                "Minesweeper" Exec exec xdemineur -ouvre &

# A wide variety of screenlocking options...
AddToMenu XlockMenu	"Choose one:" Title
+	                "Flame" Exec /usr/openwin/bin/xlock -mode flame &
+	                "Pyro" Exec /usr/openwin/bin/xlock -mode pyro &
+	                "Swarm" Exec /usr/openwin/bin/xlock -mode swarm &
+	                "Qix" Exec /usr/openwin/bin/xlock -mode qix &
+	                "Rotor" Exec /usr/openwin/bin/xlock -mode rotor &
+	                "Worms" Exec /usr/openwin/bin/xlock -mode worm &
+	                "Blank" Exec /usr/openwin/bin/xlock -mode blank &
#+	                "" Nop
#+	                "Just Kidding" Exec /usr/local/bin/mb &

############################################################################
# COMPLEX FUNCTIONS
#
AddToFunc warp-or-run		"I" Next [$0 CirculateHit] Iconify -1
+				"I" Next [$0 CirculateHit] Focus
+				"I" None [$0] $1

AddToFunc MailFunction		"I" Next [$0] Iconify -1
+				"I" Next [$0] focus
+				"I" None [$0] Exec $0 $1

AddToFunc Move-or-Raise		"I" Raise
+				"M" Move
+				"D" Lower

AddToFunc Move-or-Raise2        "M" Raise
+				"M" Move
+				"D" Lower

AddToFunc Maximize-Func         "C" Maximize     0 100
+                               "D" Maximize     100 100

AddToFunc Move-or-Iconify       "I" Raise
+                               "M" Move
+                               "D" Iconify

AddToFunc Resize-or-Raise       "I" Raise
+                               "M" Resize
+                               "D" Lower

AddToFunc Resize-or-Raise2      "M" Raise
+                               "M" Resize
+                               "D" Lower

AddToFunc PrintFunction         "I" Raise
+                               "I" Exec xdpr -id $w

AddToFunc Iconify-and-Raise     "I" Iconify
+                               "I" Raise

# RLOGIN machine fg bg
AddToFunc RLOGIN "I" Exec xterm -fg $1 -bg $2 -e rlogin $0 -8

# TELNET machine fg bg
AddToFunc TELNET "I" Exec xterm -fg $1 -bg $2 -e telnet $0

# remote_login host geom bg fg font
# remote_login samk-ultra 98x49 MidnightBlue LightGoldenrod 10x20
AddToFunc remote_login "I" Exec xterm +j -ms red -ah -fn $4 -ls -geom $1 +si -bg $2 -fg $3 -T "$0:$USER" -sl 5000 -sb -rw -e rlogin $0

# local_login geom bg fg font (HOST is the default)
AddToFunc local_login "I" Exec xterm +j -ms red -ah -fn $3 -ls -geom $0 +si -bg $1 -fg $2 -T "`uname -n`:$USER" -sl 5000 -sb -rw

AddToFunc FocusAndWarp "I" Focus
+                      "I" WarpToWindow 2p 2p

AddToFunc DeiconifyFocusAndWarp "I" Iconify -1
+                               "I" FocusAndWarp

AddToFunc ChangeDefaultFocus "I" Style "*" $0
+                            "I" Recapture

############################################################################
# MOUSE Setup
#
# First, the root window. Button 1 brings up the Main Menu. B2 is the
# window operations list, and B3 is the winlist module
#     Button	Context Modifi 	Function
Mouse 1		R   	A       Menu RootMenu Nop
Mouse 2		R    	A      	WindowList
Mouse 3		R    	A       Menu SamApps Nop

# Now, title bar buttons
# Left button is the Window-Ops2 menu, right is iconify, rightmost is maximize
#     Button	Context Modifi 	Function
Mouse 0		1       A       Menu Window-Ops2 Close
Mouse 0		2    	A     	Maximize-Func
Mouse 0		4    	A     	Iconify
Mouse 0		3       A       Stick

# Button 1 in Frame or Sides is a resize-or-raise, in Icons is a move or 
# de-iconify, and on Top does a move-or-raise
#     Button	Context Modifi 	Function
Mouse 1 	FS      A       Resize-or-Raise
Mouse 1		I       A       Move-or-Iconify
Mouse 1		T       A       Move-or-Raise

# Button 2 in an Icon is de-iconify, in Corners/Sides/Titlebar gets Ops Menu
#     Button	Context Modifi 	Function
Mouse 2 	I       A       Iconify
Mouse 2 	FST     A       Menu Window-Ops2 Nop

# Button 3 does a raise-lower on anything
Mouse 3 	TSIF    A       RaiseLower

############################################################################
# KEYBOARD Setup
#
# press arrow + control anywhere, and scroll by 1 page
Key Left	A	C	Scroll -100 +0
Key Right	A	C	Scroll +100 +0
Key Up		A	C	Scroll +0   -100
Key Down	A	C	Scroll +0   +100

# press arrow + meta key, and scroll by 1/10 of a page
Key Left	A	M	Scroll -10   +0
Key Right	A	M	Scroll +10   +0
Key Up		A	M	Scroll  +0  -10
Key Down	A	M	Scroll  +0  +10

# press shift arrow + control anywhere, and move the pointer by 1% of a page
Key Left	A	SC	CursorMove -1  +0
Key Right	A	SC	CursorMove +1  +0
Key Up		A	SC	CursorMove +0  -1
Key Down	A	SC	CursorMove +0  +1

# press shift arrow + meta key, and move the pointer by 1/10 of a page
Key Left	A	SM	CursorMove -10  +0
Key Right	A	SM	CursorMove +10  +0
Key Up		A	SM	CursorMove +0  -10
Key Down	A	SM	CursorMove +0  +10

# Keyboard accelerators
# Exchanged F2 and F3
Key F1		A	MC	Popup "RootMenu"
Key F2		A	MC	Module FvwmWinList 
Key F3		A	MC	Popup "SamApps"
Key F4		A	MC	Iconify
Key F5		A	MC	Move
Key F6		A	MC	Resize
Key F7		A	MC	Next [*] focus
Key F8		A	MC	Prev [*] focus

############################################################################
# FvwmButtons
#
# Colors
*FvwmButtonsFore Black
*FvwmButtonsBack #908090

# Font 
*FvwmButtonsFont	5x8

# Geometry-- really likes to pick its own size, but giving a position is OK
*FvwmButtonsGeometry -0+100

# Layout: specify rows or columns, not both
#*FvwmButtonsColumns 1
*FvwmButtonsRows 1

# Define the buttons to use.....
# SAM: Commented 3 buttons below
#*FvwmButtons Move		arrows2.xpm	Move
#*FvwmButtons Kill		skull.xpm	Destroy
#*FvwmButtons Quit		nuke.xpm	Popup "Quit-Verify"

#*FvwmButtons (de)Iconify	eyenew.xpm	Iconify
#*FvwmButtons Restart eye2.xpm     Restart
#*FvwmButtons Xcalc   rcalc.xpm   Exec "Calculator" xcalc &
#*FvwmButtons junk   3dx.xpm     Swallow "xload"  xload -bg \#908090
#*FvwmButtons xmter x.xpm	     Swallow "xmter" xmter &
#*FvwmButtons ""  clock.xpm   Swallow "xclock" xclock -bg \#908090 -padding 0 &
#*FvwmButtons "" 3dx.xpm Swallow "Time 3D" t3d -fg \#908090 -mag .3 -wobber 0 &

############################################################################
# FvwmIdent
#
# Give us colors and a fonts
*FvwmIdentBack MidnightBlue
*FvwmIdentFore Yellow
*FvwmIdentFont -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*

############################################################################
# FvwmPager
#
#*FvwmPagerBack #5c54c0
#*FvwmPagerFore black

#SAM: Existing colors
#*FvwmPagerBack #A0A0A0
#*FvwmPagerFore midnight blue

#SAM: Commented. 'none' argument will take out the FvwmPager label.
#*FvwmPagerFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmPagerFont none

#SAM: Commented and added the following
#*FvwmPagerHilight \#6b64b0
#*FvwmPagerHilight 		yellow
#*FvwmPagerHilight 		rgb:ca/b3/ca

*FvwmPagerHilight	GhostWhite
*FvwmPagerBack		moccasin
#	PeachPuff1
*FvwmPagerFore		IndianRed

# SAM: Original value which is positioning in TOP RIGHT.
#*FvwmPagerGeometry -0+0
#*FvwmPagerGeometry 92x80-0+935
#SAM: +0+0 is upper left corner; -0+0 upper right; -0-0 lower right; +0-0 lower left
*FvwmPagerGeometry 92x80-0-0
# SAM: I don't want the label; did not work
*FvwmPagerLabel 0 samk

# Setting the font to 0x0 or nil2 results in no text
#*FvwmPagerSmallFont 0x0
#SAM: Let me try this to see if I can remove the label.
*FvwmPagerSmallFont 5x8

############################################################################
# FvwmWinList
#
*FvwmWinListBack #908090
*FvwmWinListFore Black
*FvwmWinListFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmWinListAction Click1 Iconify -1,Focus
*FvwmWinListAction Click2 Iconify
*FvwmWinListAction Click3 Module "FvwmIdent" FvwmIdent
*FvwmWinListUseSkipList
*FvwmWinListGeometry +62+176

############################################################################
# FvwmBacker
#
*FvwmBackerDesk 0 -solid steelblue
*FvwmBackerDesk 1 -solid midnightblue

############################################################################
# FvwmIconBox
#
# NOTE: Icons will only be shown in module if Style "??" NoIcon is set
*FvwmIconBoxIconBack    #cfcfcf
*FvwmIconBoxIconHiFore  black
*FvwmIconBoxIconHiBack  LightSkyBlue
*FvwmIconBoxBack        #5f9ea0
#*FvwmIconBoxFore       blue
*FvwmIconBoxGeometry    5x1+0+0
*FvwmIconBoxMaxIconSize 64x38
*FvwmIconBoxFont        -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*
*FvwmIconBoxSortIcons   IconName
*FvwmIconBoxPadding     4
*FvwmIconBoxLines       10
*FvwmIconBoxSBWidth     11
*FvwmIconBoxPlacement   Left Top
*FvwmIconBoxPixmap      fvwm.xpm
#*FvwmIconBoxHideSC Horizontal
*FvwmIconBoxSetWMIconSize
*FvwmIconBoxHilightFocusWin
#*FvwmIconBoxResolution          Desk
*FvwmIconBoxMouse       1       Click           RaiseLower
*FvwmIconBoxMouse       1       DoubleClick     Iconify
*FvwmIconBoxMouse       2       Click           Iconify -1, Focus
*FvwmIconBoxMouse       3       Click           Module FvwmIdent
*FvwmIconBoxKey         r       RaiseLower
*FvwmIconBoxKey         space   Iconify
*FvwmIconBoxKey         d       Close
*FvwmIconBoxKey         n       Next
*FvwmIconBoxKey         p       Prev
*FvwmIconBoxKey         h       Left
*FvwmIconBoxKey         j       Down
*FvwmIconBoxKey         k       Up
*FvwmIconBoxKey         l       Right

############################################################################
# FvwmScrollBack
#
*FvwmScrollBack grey40
*FvwmScrollFore green

############################################################################
# FvwmAudio
#
#SAM: Commented it.
#*FvwmAudioPlayCmd /usr/local/bin/AF/aplay -d 0 -t -.05
#*FvwmAudioDir /usr/local/sound/fvwm

#*FvwmAudio startup goodmorning.au
#*FvwmAudio shutdown destruct.au
#*FvwmAudio unknown cat-1.au
#*FvwmAudio destroy_window oh_my_god.au
*FvwmAudio iconify flush.au
#*FvwmAudio deiconify eject.au

#*FvwmAudio add_window    ??
#*FvwmAudio toggle_paging ??

#*FvwmAudioDelay 3

#*FvwmAudio focus_change goodmorning.au
#*FvwmAudio raise_window goodmorning.au
#*FvwmAudio lower_window goodmorning.au

############################################################################
# FvwmForm
#
# FvwmForm alias - rlogin to host via xterm
*RloginWarpPointer
*RloginFont         *helvetica*m*r*n*14*
*RloginButtonFont   *helvetica*m*o*n*14*
*RloginInputFont    *cour*m*r*n*14*
*RloginFore         Black
*RloginBack         Light Gray
*RloginItemFore          Wheat
*RloginItemBack          Gray50
# begin items
*RloginLine         center
*RloginText         "Login to Remote Host"
*RloginLine         center
*RloginText         "Host:"
*RloginInput        HostName  20   ""
*RloginLine         center
*RloginSelection    UserSel   single
*RloginChoice       Default   Default   on   "same user"
*RloginChoice       Custom    Custom    off  "user:"
*RloginInput        UserName  10   ""
*RloginLine         expand
*RloginButton       quit "Login" ^M
*RloginCommand Exec xterm  -T xterm@$(HostName) -e rlogin $(HostName) $(Custom?-l $(UserName))
*RloginButton       restart   "Clear"
*RloginCommand Beep
*RloginButton       quit "Cancel"
*RloginCommand Nop
#
# FvwmForm alias - query exit ala mwm
*QuitVerifyGrabServer
*QuitVerifyWarpPointer
*QuitVerifyFont          *helvetica*m*r*n*14*
#*QuitVerifyButtonFont    *helvetica*m*o*n*14*
*QuitVerifyButtonFont    7x13bold
*QuitVerifyFore          Black
*QuitVerifyBack          Light Gray
*QuitVerifyItemFore Wheat
*QuitVerifyItemBack Gray50
# begin items
*QuitVerifyLine          center
*QuitVerifyText          "Do you really want to exit FVWM?"
*QuitVerifyLine          expand
*QuitVerifyButton   quit      " Exit "
*QuitVerifyCommand  Quit
*QuitVerifyButton   quit      "Cancel"
*QuitVerifyCommand  Nop

#
# MyTalk & MyFvwmTalk from Dave Goldberg
# MyTalk Form - dissappears after use
*MyTalkWarpPointer
*MyTalkFont *helvetica*m*r*n*14*
*MyTalkButtonFont *helvetica*m*o*n*14*
*MyTalkInputFont *cour*m*r*n*14*
*MyTalkFore Red
*MyTalkBack Gray
*MyTalkItemFore Blue
*MyTalkItemBack Gray
*MyTalkLine center
*MyTalkText "Fvwm Function"
*MyTalkInput Func 40 ""
*MyTalkLine expand
*MyTalkButton quit "Run" ^M
*MyTalkCommand $(Func)
*MyTalkButton restart "Clear" ^R
*MyTalkButton quit "Cancel" ^C
*MyTalkCommand Nop
#
# MyFvwmTalk Form - sticks around
*MyFvwmTalkWarpPointer
*MyFvwmTalkFont *helvetica*m*r*n*14*
*MyFvwmTalkButtonFont *helvetica*m*o*n*14*
*MyFvwmTalkInputFont *cour*m*r*n*14*
*MyFvwmTalkFore Red
*MyFvwmTalkBack Gray
*MyFvwmTalkItemFore Blue
*MyFvwmTalkItemBack Gray
*MyFvwmTalkLine center
*MyFvwmTalkText "Fvwm Function"
*MyFvwmTalkInput Func 40 ""
*MyFvwmTalkLine expand
*MyFvwmTalkButton restart "Run" ^M
*MyFvwmTalkCommand $(Func)
*MyFvwmTalkButton restart "Clear" ^R
*MyFvwmTalkCommand Nop
*MyFvwmTalkButton restart "Iconify" ^Z
*MyFvwmTalkCommand Next [MyFvwmTalk] Iconify
*MyFvwmTalkButton quit "Quit" ^C
*MyFvwmTalkCommand Nop

---

From: Sam Krishnabhat <[email-masked]>
Date: Thu, 16 Apr 1998 11:27:35 -0700 (PDT)

Dan Espen sez...
> > some I get a "think black round" shaped cursor. That happens when
Right
> > I use SUN Solaris Ultra system.

That was a good example and I understand now the concept behind the
cursor type. I appreciate your initiative to help me out.

Let me explain the problem that occurs very consistently in two scenarios.

Scenario 1:
~~~~~~~~~~~~
Say, I invoke a xterm from the command line, say like this:
/users/samk/mib/isdn>xterm
So now a small window appears on my existing window. I hit exit on the small
window, window gets CLOSED and now cursor becomes 'round'. Then I have to
hit TWO mouse clicks, even if the mouse is right on the original window.

Scenario 2:
~~~~~~~~~~~~
I invoke 'Preferences' menu item in Netscpape. A window pops up. Then I hit
'Cancel' button. The Preferences window closes and cursor becomes ROUND. I have
to hit mouse button twice in order to do anything.

It always takes TWO clicks; I don't know why ? Hope you can help me thro' this.

Following is my .fvwm2rc:
~~~~~~~~~~~~~~~~~~~~~~~~~~
##########################################################################
# FVWM - F? Virtual Window Manager, Version 2.x (fvwm2) Configuration File
# Created April 1996
#

## Triangles
#
# Small up Triangle

## Boxes
#
# Big Box 

## X's
#
# Standard X

## Lightning Bolts
#

## Miscellaneous Buttons
#

## Arrows Galore
#
# Up Arrow

 

# This is the root menu

	

# RLOGIN machine fg bg

# TELNET machine fg bg

# Now, title bar buttons

# Keyboard accelerators
# Exchanged F2 and F3

# Font 
*FvwmButtonsFont	5x8

#SAM: Existing colors
#*FvwmPagerBack #A0A0A0

#*FvwmAudioDelay 3

#

---

From: Trent Piepho <[email-masked]>
Date: Thu, 16 Apr 1998 13:10:45 -0700 (PDT)

> Let me explain the problem that occurs very consistently in two scenarios.

This sounds like a known fvwmauto problem.  What happens is that fvwmauto
tells fvwm to raise the new xterm or the preferences window, but it's no
longer there because you closed it.  So fvwm gives you that round "select a
window" cursor.  You will probably find that if you click on a window with it,
that window will get raised.

> Following is my .fvwm2rc:

Looks to me like you're starting TWO FvwmAuto modules, so that's why you
get two clicks.  You should only start one.

|Gazing up to the breeze of the heavens \ on a quest, meaning, reason  |
|came to be, how it begun \ all alone in the family of the sun         |
|curiosity teasing everyone \ on our home, third stone from the sun.   |
|Trent Piepho ([email-masked])                   -- Metallica  |