Subject: FVWM: fvwm: FvwmIconMan loads twice

From: "Frank Wilcox, Jr." <[email-masked]>
Date: Fri, 24 Apr 1998 02:34:29 -0400

ok, this is gettin' downright irritatin'.  FvwmIconMan loads twice whenever i
reload fvwm2, and sometimes even when i log on.  Any ideas?

-- 
Frank Wilcox, Jr. (a.k.a. _____)

can be found in #Friends on the undernet

------------------------------------------------------
Safe upon the solid rock the ugly houses stand:
Come and see my shining palace built upon the sand!
		-Edna St. Vincent Millay

Matt 8:24-7
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Brady Montz <[email-masked]>
Date: 25 Apr 1998 22:01:37 -0700

> reload fvwm2, and sometimes even when i log on.  Any ideas?

What's your InitFunction and RestartFunction look like?

-- 
 Brady Montz
 [email-masked]

---

From: "Frank Wilcox, Jr." <[email-masked]>
Date: Sun, 26 Apr 1998 12:34:21 -0400

On Apr 25, 22:01, Brady Montz wrote:
> Subject: Re: FVWM: fvwm: FvwmIconMan loads twice
>-- End of excerpt from Brady Montz

AddToFunc "InitFunction" "I" Module FvwmAuto 750

AddToFunc "InitFunction" "I" Module FvwmAuto 750
+		"I" Module FvwmButtons
+		"I" Wait FvwmButtons

AddToFunc "RestartFunction" "I" Module FvwmAuto 750
+		"I" Module FvwmButtons
+		"I" Wait FvwmButtons

and here's iconMan, too:

#############################################

Module FvwmIconMan
# Make FvwmIconMan title-bar-less, sticky, and give it an icon
#Style "Fvwm*"      Icon toolbox.xpm,NoTitle,NoHandles,Sticky
#Style "FvwmIconMan" HandleWidth 5, Handles, BorderWidth 5

#Definitions used by the modules

*FvwmIconMan*nummanagers        1
*FvwmIconMan*resolution         global
*FvwmIconMan*background         DeepSkyBlue4
*FvwmIconMan*foreground         white
*FvwmIconMan*font               7x10
*FvwmIconMan*buttongeometry     85x0
*FvwmIconMan*managergeometry    2x6-0+788
#*FvwmIconMan*rows               7
#*FvwmIconMan*columns            2

#############################################

*FvwmButtons(4x3,Swallow "FvwmIconMan" "FvwmIconMan")

Matt 8:24-7