Subject: FVWM: FVWM and colorCursor

From: Senthil Kamireddy <[email-masked]>
Date: Mon, 13 Apr 1998 13:05:55 -0400

Hi,
I would like to know where to send questions about FVWM.

Problem descripton: We have a veriety of sparc stations running solaris
(2.5,2.5.1 and 2.6) and FVWM. Eventhough I have XTERM*colorCursor
defined in my .Xdefaults and .fvwmrc the cursor is always black. Also,
How do I change my prompt color in my xterm? 

Appreciate you help.
Thanks,
Senthil.
[email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Richard Lister <[email-masked]>
Date: Tue, 14 Apr 1998 11:47:13 -0400

On Mon, 13 Apr 1998 13:05:55 -0400
Senthil Kamireddy <[email-masked]> 
> How do I change my prompt color in my xterm? 

Senthil

If you are talking about the text cursor in an xterm, this is nothing
to do with the window manager.

However, the class for xterms is "XTerm", and the resource is "cursorColor"
so try this in your .Xdefaults instead (don't forget to run
'xrdb -load .Xdefaults'):

  XTerm*cursorColor: LimeGreen

This works for me (and yes, I like LimeGreen :-)

To change the prompt colour you need a terminal that supports ANSI
colour escapes, such as color-xterm (I think the xterm with X11R6.3
does this) or rxvt. You should get the GNU version of 'ls' (comes
with the GNU fileutils package) and read the docs, especially
the 'dircolors' program and rc file.

For reference, I use zsh and in my .zshrc file I have something
similar to this:

  ## make some human-readable variables of the ANSI escape sequences
  NORMAL="%{[0m%}"
  BOLD="%{[01m%}"
  RED="%{[31m%}"
  GREEN="%{[32m%}"
  YELLOW="%{[33m%}"
  BLUE="%{[34m%}"
  MAGENTA="%{[35m%}"
  CYAN="%{[36m%}"
  WHITE="%{[37m%}"

  ## blue for me, red for root
  if [ "`whoami`" = "root" ] ; then
    NAMECOLOR=${RED}
  else
    NAMECOLOR=${BLUE}
  fi

  ## set left and right prompts
  PS1="${NAMECOLOR}%m${NORMAL}%(#.#.$) "
  RPS1="${YELLOW}%~${NORMAL}"

Also take a look at  http://sunsite.unc.edu/LDP/HOWTO/mini/Colour-ls.html.

Ric

Richard J Lister, Georgetown Institute for Cognitive and Computational Sciences
Georgetown University Medical Center, Washington, DC 20007, USA
Phone: +1 202-687 2878
Email: [email-masked] 
Web: http://www.giccs.georgetown.edu/~ric/
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].