Subject: FVWM: Problems with FvwmIconBox (Sun Solaris 2.6)

From: Alberto Moral Beneitez <[email-masked]>
Date: Wed, 25 Mar 1998 18:26:12 +0100

Hi,

I have a problem with FvwmIconBox in Sun Solaris 2.6:
I've compiled fvwm-2.0.46 with GNU gcc, and FvwmIconBox
doesn't work: it only shows an empty window (no icons in it).

I've tried with my .fvwm3rc, sample.fvwm2rc, ...

What's the problem? (with fvwm 1.xx, it works OK).

Thanks in advance.

--
J. Alberto Moral Beneitez		     Tlf: (91) 550 40 03
mailto:[email-masked] 		     	         +34 1 550 40 03
SdB-ALTRAN  C/Ramirez de Arellano 29, 6-Sur  28043 Madrid (Spain)
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Wed, 25 Mar 1998 12:55:39 -0500

> What's the problem? (with fvwm 1.xx, it works OK).

This is  a pretty common question, its  easy to overlook.  It may seem
counterintuitive, but  icons will only  go into FvwmIconBox  when they
are associated with "styles" that have the "NoIcon" attribute.

Something like:

Style "*" Icon myicon.xpm, NoIcon

It was  years ago,   but once again,    I suggest this  change  to the
"system.fvwmrc" that is distributed with fvwm2:

Around line 192:
OLD:
+			"IconBox"	Module	FvwmIconBox
NEW:
+			"IconBox"	ConfigFvwmIconBox

AddToFunc ConfigIconBox "I" Module FvwmIconBox
+                       "I" Style     "*"  NoIcon
+                       "I" Recapture

(This might help to make FvwmIconBox work out-of-the-box.)

--
Dan Espen                                Phone: (732) 699-5570
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].