Subject: FVWM: fvwm-2.0.46, truecolor and netscape 4.04us

From: Tomasz Orzechowski <[email-masked]>
Date: Sun, 1 Mar 1998 20:53:45 -0600 (CST)

Hello

Perhaps this falls under the 'Need to fix to work correctly under 24bit
(TrueColor) displays' in TODO, but whenever I run Netscape on a Ultra30
+ Creator 3d on fvwm2 .0.46 I see all the graphics, but no or little of
text.  Usually I just get horizontal blue lines where the text should
be; sometimes I see something (like stuff in <pre></pre> or
<strong></strong>).

Or perhaps the problem is with Netrape, but it works under CDE.  And I
refuse to submit more bug reports to Netscape, since ever since I did
that they keep sending me some htmlized crap by email.

Any fvwm-related clues for me?

T
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Mon, 02 Mar 1998 10:54:19 +0100

Hi.

[email-masked] said:
> Perhaps this falls under the 'Need to fix to work correctly under 
> 24bit (TrueColor) displays' in TODO, but whenever I run Netscape on a 
> Ultra30 + Creator 3d on fvwm2 .0.46 I see all the graphics, but no or 
> little of text.  Usually I just get horizontal blue lines where the 
> text should be; sometimes I see something (like stuff in <pre></pre> 
> or <strong></strong>). 

This sounds more like the X-font bug included in Solaris2.6,
which Netscape happily triggers. Try changing your font in
Netscape into one of the linotypes (type 1 fonts are the problem).

Sooner or later Sun might post a patch for this, in the meantime
I'm quite happy using palatino as main font in Netscape.

/Mattias
----------------------------------------------------------
Mattias Borell, Software Engineer at NetLab, R&D dept. of:
Lund University Library, P.O.Box 3, S-221 00  Lund, Sweden
Tel: int+46 46 2220481     Email: [email-masked]
Fax: int+46 46 2223682   URL: http://www.ub.lu.se/~mattias

---

From: Michael Hucka <[email-masked]>
Date: Mon, 2 Mar 1998 05:23:36 -0500 (EST)

>>>>> On 02 Mar 1998, [email-masked] wrote:

  MB> This sounds more like the X-font bug included in Solaris2.6, which
  MB> Netscape happily triggers. Try changing your font in Netscape into one
  MB> of the linotypes (type 1 fonts are the problem).

That's one option; another option is to try the workaround explained below,
posted on comp.sys.sun.admin.  (There are 2 messages explaining different
ways of implementing the same workaround.)  Caveat: I haven't tried this
myself (yet).

> ============================================================================
> From: Juergen Keil <[email-masked]>
> Newsgroups: comp.sys.sun.admin,comp.unix.solaris
> Message-ID: <[email-masked]>
> Subject: Re: Solaris 2.6 and Fonts in Communicator4.x
> Date: 26 Jan 1998 16:36:42 +0100
> 
> Bernie Harris <[email-masked]> writes:
> 
> > From Known Issues In This Release/General and Setup, Netscape Communicator
> > 4.0 Unix Release Notes:
> > 
> > Solaris 2.6 only: Solaris 2.6/Communicator 4.0x does not render fonts
> > properly. To fix the problem, add the following line to your ~/.xinitrc
> > file:
> >       xset +fp /usr/openwin/lib/X11/fonts/75dpi/
> >       xset fp rehash
> > 
> > If you are using CDE, I believe that the xset commands should go in
> > ~/.dt/sessions/sessionetc instead of ~/.xinitrc.
> 
> A better workaround is to add the following 'xlsfonts' command
> in your ~/.dt/sessions/sessionetc (or ~/.xinitrc)
> 
> 	xlsfonts -o utopia-regular
> 
> 
> The Solaris 2.6 Type1 font rendering problem is triggered when the
> type1 font rasterizer gets initialized because of an XListFonts call.
> 
> The rasterizer gets correctly initialized due to XLoadFont requests,
> so explicitly *loading* any type1 font (like 'utopia-regular' or
> '-adobe-utopia-medium-r-normal--0-0-0-0-p-0-iso8859-1' above) early in
> the X session avoids the bug.
> 
> 
> Btw., the bug can be triggered with the following simple program.  If
> this is the first client that touches type1 fonts, the type1 font
> rasterizer is hosed (any type1 fonts come up blank afterwards) until
> the X server is reset.
> 
> 
> #include <stdio.h>
> #include <X11/Xlib.h>
> 
> 
> int main(int argc, char **argv) {
>         Display *dpy;
>         int max_fonts;
> 
>         dpy = XOpenDisplay(argv[1] ? argv[1] : ":0");
>         if (dpy == NULL) {
>                 fprintf(stderr, "Can't open display\n");
>                 exit(1);
>         }
>         XListFonts(dpy, "*", 32767, &max_fonts);
> }
> 
> 
> ============================================================================
> From: Juergen Keil <[email-masked]>
> Newsgroups: comp.sys.sun.admin,comp.unix.solaris
> Message-ID: <[email-masked]>
> Subject: Re: Solaris 2.6 and Fonts in Communicator4.x
> Date: 07 Feb 1998 18:29:17 +0100
> 
> James Dehnert <[email-masked]> writes:
> 
> > Anthony Talltree wrote:
> > > 
> > > >The system wide solutions is to put the xlsfonts call into either
> > > >/usr/dt/config/sessionetc
> > > >or
> > > >/etc/dt/config/sessionetc
> > > 
> > > The former has never been read on my machine; the latter doesn't
> > > exist, so it looks to me as though this is a DTE-only kinda deal,
> > > and thus isn't really system-wide.
> > 
> >   Opps. I missed the begining of this thread.
> > 
> >   Was there a syntax to the addition of xlsfonts to the sessionetc
> >   file?
> 
> To work around the problem with netscape v4.x (and a few other
> applications) sometimes not showing certain type1 fonts under
> solaris 2.6, install the following executable shell script as
> /etc/dt/config/sessionetc:
> 
> 	#!/bin/sh
> 	xlsfonts -o utopia-regular
> 
> and insert the same xlsfonts command just before the final exit 0
> in /usr/openwin/lib/openwin-sys:
> 
> 	...
> 	if [ -x $OPENWINHOME/bin/speckeysd ] ; then
> 	        $OPENWINHOME/bin/speckeysd  1> /dev/console 2>&1
> 	fi
> 
> 	xlsfonts -o utopia-regular	# added command
> 
> 	exit 0
> 
> [ The /etc/dt/config/sessionetc file fixes the type1 font problem for
> CDE desktop users, the modification of openwin-sys fixes it for
> openlook users ]
>
> ============================================================================

-- 
Mike Hucka   --   [email-masked]   --   PhD student, UNIX admin & programmer
  Read about how Microsoft really achieved its position of dominance in
  software and then think about what it means for you if they are allowed 
  to monopolize the industry: http://www.netaction.org/msoft/world/
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tomasz Orzechowski <[email-masked]>
Date: Mon, 2 Mar 1998 10:58:33 -0600 (CST)

> Netscape into one of the linotypes (type 1 fonts are the problem).

Which indeed it is, and all for the better because it made me finally
install the iso8859-2 fonts on the machine and make them the default.

> I'm quite happy using palatino as main font in Netscape.

Maybe, then maybe not.  It works like a charm now, thanks to Jakob
Thorell, Mattias Borell and Michael Hucka for suggestions that helped me
right away.

Thank you,

T