Subject: FVWM: Fvwm icons disappear after RedHat 5.0 upgrade.

From: Robert Estes <[email-masked]>
Date: Mon, 02 Feb 1998 07:38:33 -0800

Hi,

I'm using the same ~/.fvwmrc file as before my upgrade from RedHat 4.2 to
5.0.  I had it set up so that only the titles of the icons were used, and
so that they stacked up in the lower right part of the screen.  After the
upgrade, when I iconify windows, they disappear - I don't have any icons at
all, so there is no way to recall a window.  It's kind of annoying.  I
noticed a few other messages about fvwm here, and changed:

PixmapPath /usr/include/X11/pixmaps/
IconPath   /usr/include/X11/bitmaps/

to

PixmapPath /usr/share/icons
IconPath   /usr/share/icons

in both the system.fvwmrc and ~/.fvwmrc with no luck.  I'm using version
1.24r, and my .fvwmrc file is included below.

Any suggestions?

Thanks,

-R

 --------------------- ------------------------------------------------------ 
| Robert Estes        | CIPIC - University of California, Davis              | 
| Qualimage, Inc.     | Center for Image Processing and Integrated Computing | 
| (916) 759-9016      | (916) 752-8224                                       | 
| [email-masked] | [email-masked]                              | 
 --------------------- ------------------------------------------------------ 

----------------------.fvwmrc---------------
# Unfortunately, order does matter in this file
# The correct order for inserting configurations is:

# 1. Colors
# 2. Assorted configuration paramters such as ClickToFocus, or MWMBorders
# 3. Path setup (ModulePath, PixmapPath, IconPath)
# 4. Style settings, including the default style Style "*" ...
# 5. InitFunction and ResetFunction definitions.
# 6. Other Functions. Functions cannot be forward referenced from
#	other functions, but they can be backward referenced.
# 7. Menus definitions. Same caveats about forward referencing
# 8. Key and Mouse Bindings.
# 9. Module options.

# The order of steps 5, 6, and 7 is not critical, as long as there are
# no forward references to functions or menus.

#
# set up the colors
#

RandomPlacement
SmartPlacement

#
# Modules
#

ModulePath /usr/X11/lib/X11/fvwm:/usr/X11/bin:/usr/local/bin
Module FvwmWinList

# Colors for selected window.

HiForeColor Black
HiBackColor #299029

PagerBackColor grey10
PagerForeColor #F7F
PagerFont -misc-fixed-medium-*-normal-*-8-*-*-*-*-*-iso8859-1
Pager -2 58

# Menu colors.

MenuForeColor    Black
MenuBackColor    grey
MenuStippleColor SlateGrey

#
# Set up the fonts.
#

Font	   -*-helvetica-medium-o-*-*-12-*-*-*-*-*-*-*
WindowFont -*-helvetica-bold-r-*-*-12-*-*-*-*-*-*-*
IconFont   -*-helvetica-medium-r-*-*-10-*-*-*-*-*-*-*

AutoRaise 500

# ClickTime 150

ButtonStyle 1 50x22
ButtonStyle 2 50x50
ButtonStyle 4 22x22

#
# Set up the virtual desktop and pager
#

DeskTopSize 1x6
DeskTopScale 25
EdgeResistance 10000 10000
EdgeScroll 0 0
OpaqueMove 100
OpaqueResize
SloppyFocus

#
# Icon paths
#

PixmapPath /usr/share/icons
IconPath   /usr/share/icons

#
# Set the decoration styles and window options
# 

Style "*" BorderWidth 6, HandleWidth 6, Color Yellow/RoyalBlue, NoIcon
Style "*Pager" NoTitle, NoHandles, Sticky, WindowListSkip
Style "FvwmWinList" NoTitle, NoHandles, BorderWidth 0, Sticky, WindowListSkip 
Style "*lock" NoTitle, NoHandles, Sticky, WindowListSkip
Style "*load" NoTitle, NoHandles, Sticky, WindowListSkip
Style "*osview" NoTitle, NoHandles, Sticky, WindowListSkip
Style "XMailbox" NoTitle, Sticky, WindowListSkip

#
# Define the menus.
#

Popup "Remote"
  Exec "fly" exec nxterm -e rlogin fly &
  Exec "vision" exec nxterm -e rlogin vision &
  Exec "maize" exec nxterm -e rlogin maize &
  Exec "melvyl" exec nxterm -e telnet melvyl.ucop.edu &
End Popup

PopUp "Tetris"
  Exec "Tetris" exec xtetris &
  Exec "Hextris" exec xhextris &
  Exec "Jewel" exec xjewel &
EndPopUp

Popup "MineSweeper"
  Exec "15x15/30" exec xdemineur -l 15 -c 15 -m 30 -ouvre &
  Exec "15x15/40" exec xdemineur -l 15 -c 15 -m 40 -ouvre &
  Exec "15x15/50" exec xdemineur -l 15 -c 15 -m 50 -ouvre &
  Exec "15x15/60" exec xdemineur -l 15 -c 15 -m 60 -ouvre &
  Exec "15x15/65" exec xdemineur -l 15 -c 15 -m 65 -ouvre &
  Exec "15x15/70" exec xdemineur -l 15 -c 15 -m 65 -ouvre &
  Exec "20x20/120" exec xdemineur -l 20 -c 20 -m 120 -ouvre &
EndPopUp

PopUp "Games"
  Popup "MineSweeper" MineSweeper
  Exec "Solitare(s)" exec xpat2 &
  Exec "MilleBournes" exec xmille &
  Exec "Battle Zone" exec cbzone &
  Exec "Chess" exec xboard -sd 2 -xclock &
  Exec "xBill" exec xbill &
  Exec "Mahjongg" exec xmahjongg &
  Exec "Score Four" exec xvier &
EndPopUpxpuzzles  xpuzzles  

PopUp	"Programs"
  Title "Programs"
  Nop ""
  Exec "Xemacs" exec xemacs &
  Exec "Netscape" exec netscape -install &
  Exec "Tgif" exec tgif &
  Exec "PostScript Previewer" exec ghostview &
  Exec "Audio CD" exec xplaycd &
  Exec "Seyon" exec seyon &
  Exec "Calendar" exec ical &	
  Popup "Games" Games
EndPopUp

Popup "WindowOps"
  Move "Move"
  Resize "Resize"
  Iconify "Minimize"
  Maximize "Maximize"
  Raise "Raise"
  Lower "Lower"
  Nop ""
  Delete "Delete"
  Destroy "Destroy"
EndPopup

PopUp "RootMenu"
  Title "Root Menu"
  Exec "New Window" nxterm &
  Popup "Remote" Remote
  Exec "Lock" exec xlock -mode random &
  Refresh "Refresh"
  Restart "Restart" fvwm
  Quit "Quit"
EndPopUp

#
# Define some handy (more) complex functions
#

#
# This one moves and then raises the window if you drag the mouse,
# only raises the window if you click,  or does a RaiseLower if you double 
# click
#

Function "Move-or-Raise"
  Move "Motion"
  Raise "Motion"
  Raise "Click"
  RaiseLower "DoubleClick" 
EndFunction

#
# This one moves and then lowers the window if you drag the mouse,
# only lowers the window if you click,  or does a RaiseLower if you double 
# click
#

Function "Move-or-Lower"
  Move "Motion"
  Lower "Motion"
  Lower "Click"
  RaiseLower "DoubleClick"
EndFunction

#
# This one resizes and then raises the window if you drag the mouse,
# only raises the window if you click,  or does a RaiseLower if you double 
# click
#

Function "Resize-or-Raise"
  Resize "Motion"
  Raise "Motion"
  Raise "Click"
  RaiseLower "DoubleClick"
EndFunction

Function "Move-or-Iconify"
  Move "Motion"
  PopUp "Click" WindowOps
  Iconify "DoubleClick"
EndFunction

Function "Die-on-DoubleClick"
  Destroy "DoubleClick"
  PopUp "Click" WindowOps
EndFunction

#
# Define mouse bindings
#

# Root window bindings.

Mouse 1	R A PopUp "RootMenu"
Mouse 3	R A PopUp "Programs"

# Title bar

Mouse 0	1 A Function "Die-on-DoubleClick"
Mouse 0	2 A Maximize
Mouse 0	4 A Iconify

# The rest of the frame.

Mouse 1	FS A Function "Resize-or-Raise"
Mouse 2	FS A Function "Resize-or-Raise"
Mouse 1 T  A Function "Move-or-Raise"
Mouse 2 T  A Function "Move-or-Raise"
Mouse 1	I  A Function "Move-or-Iconify"
Mouse 2	I  A Function "Move-or-Iconify"

#
# Now some keyboard shortcuts.
#

#
# Arrow Keys
# press arrow + meta key, and scroll by a page
#

Key Left  A M Scroll -100000 0
Key Right A M Scroll 100000 0
Key Up    A M Scroll 0 -100000
Key Down  A M Scroll 0 +100000

# press shift arrow + control anywhere, and move the pointer by 1% of a page
Key Left  A SC CursorMove -1 0
Key Right A SC CursorMove +1 +0
Key Up    A SC CursorMove +0   -1
Key Down  A SC CursorMove +0   +1

# press shift arrow + meta key, and move the pointer by 1/10 of a page
Key Left  A SM CursorMove -10 +0
Key Right A SM CursorMove +10 +0
Key Up    A SM CursorMove +0 -10
Key Down  A SM CursorMove +0 +10

#
# Keyboard accelerators
#

Key F1  WFST N Move
Key F2  WFST N Resize
Key F3  WFST N Iconify
Key F4  WFST N Maximize
Key F5  WFST N Raise
Key F6  WFST N Lower
Key F9  WFST N Delete
Key F10 WFST N Destroy

#
# WinList options.
#

*FvwmWinListAction Click1 Iconify -1,Raise
*FvwmWinListAction Click2 Module "FvwmIdent" FvwmIdent
*FvwmWinListAction Click3 Iconify
*FvwmWinListFore Yellow
*FvwmWinListBack RoyalBlue
*FvwmWinListFont -*-helvetica-bold-r-*-*-12-*-*-*-*-*-*-*
*FvwmWinListGeometry -5-5
*FvwmWinListUseSkipList
*FvwmWinListUseIconnames

#
# Ident options
#

*FvwmIdentFore Yellow
*FvwmIdentBack Blue
*FvwmIdentFont -*-helvetica-bold-r-*-*-12-*-*-*-*-*-*-*
--------------------end------------------
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Bruce Stephens <[email-masked]>
Date: Mon, 02 Feb 1998 16:00:18 +0000

[email-masked] said:
> I'm using the same ~/.fvwmrc file as before my upgrade from RedHat 4.2
> to 5.0.  I had it set up so that only the titles of the icons were
> used, and so that they stacked up in the lower right part of the
> screen.  After the upgrade, when I iconify windows, they disappear - I
> don't have any icons at all, so there is no way to recall a window.

Try checking colour availability.  I've found that in most cases where icons 
were disappearing, it was because I'd run out of colours.  Run xdpyinfo, and 
make sure you're getting the right kind of screen depth (this'll probably be 
16, 24 or 32 bits truecolor; if it's only 8 bits pseudocolor, then that's 
probably your problem).  It may be something else, of course, but it's easy to 
check for colours.