Subject: FVWM: fvwm2 startup problem from xdm

From: C R Johnson <[email-masked]>
Date: Wed, 11 Feb 1998 02:10:09 +0000

I am using Fvwm Version 2.0.46 on linux.

I can login from the console and startx, and fvwm2 with no
problem.

When I set the runlevel to 5, and try to use xdm for login,
I cannot login to my user accounts - fvwm fails to start.

An .FVWM2-errors file is generated with a bunch 
of cryptic errors like this:

[FVWM][executeModule]: <<ERROR>> No such module
'^?ELF^A^A^A' in ModulePath '/usr/X11R6/lib/X11/fvwm2'

and on and on with random non-printable garbage as non found
modules.

Can somebody here tell me whats going on and how to fix it?

thank you,

cliff
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Greg Fall <[email-masked]>
Date: Tue, 10 Feb 1998 22:32:45 -0500 (EST)

> I cannot login to my user accounts - fvwm fails to start.

This is probably not your problem, but one thing you should check is your
/etc/X11/xdm/Xsession, which might be looking for a file called .xsession
in your home directory.  Back in the day (pre RH 5.0) .xsession was a
symbolic link to .Xclients.  Now, depending on what you've been up to
there, you might have to create that link yourself.  Assuming you are
using .Xclients as your startup file for X.

cd
ln -s .Xclients .xsession

--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--

Greg Fall
[email-masked]
http://www-personal.engin.umich.edu/~gmfall

---

From: [email-masked]
Date: Wed, 11 Feb 1998 00:50:10 -0500 (EST)

: I am using Fvwm Version 2.0.46 on linux.
: 
: I can login from the console and startx, and fvwm2 with no
: problem.
: 
: When I set the runlevel to 5, and try to use xdm for login,
: I cannot login to my user accounts - fvwm fails to start.
: 
: An .FVWM2-errors file is generated with a bunch 
: of cryptic errors like this:
: 
: [FVWM][executeModule]: <<ERROR>> No such module
: '^?ELF^A^A^A' in ModulePath '/usr/X11R6/lib/X11/fvwm2'
   ^^^^^^^^^^^^
   /
This looks suspiciously like fvwm is reading an executable file or a
module as if it were a config file.  Look for something like `fvwm -f
<blah>', where <blah> is a file or module name.  I suspect there's an
older version of fvwm (or perhaps fvwm95) that uses `fvwm -f FvwmCpp
<filename>' or `fvwm -f FvwmM4 <filename>'; this use is old syntax
(deprecated as of fvwm-2.0.43).  You may need to replace this with
`fvwm -cmd FvwmCpp <filename>' or `fvwm -cmd FvwmM4 <filename>'.

: and on and on with random non-printable garbage as non found
: modules.

--jim

%%%%%%%%%%%%%%% jim knoble %%%%%%%% [email-masked] %%%%%%%%%%%%%%%%%