Subject: FVWM: Odd behavior of Swallowed Pager

From: Wesley Hart <[email-masked]>
Date: Wed, 25 Feb 1998 14:44:30 -0600

This is on fvwm2.0.46 running under HP-UX 10.01.

I've recenly noticed an annoying interaction between FvwmButtons
and FvwmPager that I'm hoping someone can help me clear up.

I have a single FvwmPager running which is swallowed by my button
bar my the following:

(4x3 Padding 2 0 Swallow (UseOld,Close,NoKill,Respawn) FvwmPager "FvwmPager 0 0")

I noticed the other day that I had a whole bunch of (like 10)
FvwmPager processes running.  I killed off the extras, but a few 
hours later, I again saw more than one process running.  After
a little digging, I discovered that every time I use button 2 in the
pager to change the location of a window, a new instance of the
pager gets spawned even though the old one hasn't died.

I just brought up a non-swallowed pager and didn't see this behavior,
so I assume FvwmButtons is the culprit.  Can anyone shed any light
on why this might be happening?

TIA!
-- 
Wesley Hart
		Pretty much anytime someone uses a phrase like "great
		piece of work about an important period in underground
		culture", you can usually substitute "doofy".
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Paul vdM)
Date: Thu, 26 Feb 1998 09:10:32 +0100 (MET)

> (4x3 Padding 2 0 Swallow (UseOld,Close,NoKill,Respawn) FvwmPager "FvwmPager 0 0")

It looks pretty much like what I'm using:
*FvwmButtons(2x2, Swallow (Close, NoHints, Kill, Respawn, NoOld, NoTitle) "Desktop" "Module FvwmPager 0 0")

therefore, I think it's just a matter of toying with interpunction a bit.

Try using the interpunction I've been using here.

Hope this helps,

CIAO.

-- 

A. van Werven
Dept. of Computer Science, Leiden University, The Netherlands
Phone: +31 6 54212683
E-mail: [email-masked]
URL: http://www.wi.leidenuniv.nl/~avwerven

Life would be easier if I had the source code.

---

From: "Robert H. Ford II" <[email-masked]>
Date: Thu, 26 Feb 1998 09:56:14 -0600

> Try using the interpunction I've been using here.

I am having the same problem.  Here is my entry:
(1x6,Swallow (Respawn) "FvwmPager" "FvwmPager 0 5",Frame 0,Back firebrick3)

When ever I move a window from one desktop to another, a new pager is created.

I tired the following:
(1x6,Swallow (Close,NoHints,Respawn,NoOld,Notitle) "FvwmPager" "FvwmPager 0
5",Frame 0,Back firebrick3)

but received the same results.

Now my FvwmButtons configurations are in a file, but I don't think this has
anything to do with this problem.

I have had this problem ever since I went to fvwm2 (it sure seems like its been
decades ;-{}) ).

Any and all help would be greatly appreciated.

-- 
    _/_/_/     _/  _/   _/_/_/_/   _/_/_/_/_/_/ Robert H. Ford II
   _/   _/    _/  _/   _/           _/    _/    Lucent Technologies
  _/_/_/     _/_/_/   _/_/_/       _/    _/     Bell Labs Innovations
 _/   _/    _/  _/   _/           _/    _/      Naperville IL, 60566-7045
_/    _/   _/  _/   _/         _/_/_/_/_/_/     Email: [email-masked]
                                                Voice: (630) 713-4957
__________________________________________________
|  M R spiders!                    |      |   |  |
|  M N O spiders!                  |      |   |  |
|  O S A R - C D E D B D I's?      |      |   |  |
|  Y I B, M R spiders...           |      |   *  |
|                                  *      |      |
|                                         *      |
--------------------------------------------------
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].