Subject: FVWM: FvwmIconMan: bug in resorting on changed window label

From: Chris Siebenmann <[email-masked]>
Date: Mon, 9 Feb 1998 19:08:54 -0500

If you have FvwmIconMan's sort option turned on, and the second window
in the icon manager's current order changes its icon name (or whatever
one is using as the label) such that it should be first, it is not
resorted into the front position; it stays where it is. This doesn't
happen for the third and subsequent windows, and I think it's due to an
off-by-one bug in modules/FvwmIconMan/xmanager.c. Patch enclosed.

 While we're on the subject of FvwmIconMan, it would be nice if
there was an option for whether to make the sort order comparison
case dependant or independant. At the moment it is hardcoded to be
case-independant.

	- cks
*** modules/FvwmIconMan/xmanager.c	1998/02/05 23:44:02	1.1
--- modules/FvwmIconMan/xmanager.c	1998/02/09 23:57:10
***************
*** 1424,1430 ****
        /* start search from our current location */
        cur = win->button->index;
  
!       if (cur - 1 > 0 && 
  	  strcasecmp (ds, bp[cur - 1]->drawn_state.win->display_string) < 0) {
  	start = cur - 1;
  	finish = -1;
--- 1424,1430 ----
        /* start search from our current location */
        cur = win->button->index;
  
!       if (cur - 1 >= 0 && 
  	  strcasecmp (ds, bp[cur - 1]->drawn_state.win->display_string) < 0) {
  	start = cur - 1;
  	finish = -1;

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Brady Montz <[email-masked]>
Date: 09 Feb 1998 22:04:56 -0700

> off-by-one bug in modules/FvwmIconMan/xmanager.c. Patch enclosed.

I've put it into my copy of the source. Thanks.

> case dependant or independant. At the moment it is hardcoded to be

seems reasonable.

-- 
 Brady Montz
 [email-masked]