Subject: FVWM: specific placement

From: James J Stewart <[email-masked]>
Date: Mon, 23 Feb 1998 19:58:41 -0500 (EST)

hi everyone, i've got a question that i can't find a good answer to on the
webpage.

i'm using fvwm1, and i'd like to have it perform SmartPlacement on my ICQ,
but if i try to define it as a style using the window title (my icq#), it
tells me that SmartPlacement is a bad style command.

any suggestions would be appreciated because ICQ launches WAY more windows
than i'd like to drop by hand (all other placements are commented out.)

thanks

jon

******************************************************************
 	There is a chasm
 	of carbon and silicon
 	the software can't bridge
	- if Confucius was a programmer...
******************************************************************

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Kai Grossjohann <[email-masked]>
Date: 24 Feb 1998 09:50:14 +0100

>>>>> On Mon, 23 Feb 1998, James J Stewart said:

  James> i'm using fvwm1, and i'd like to have it perform
  James> SmartPlacement on my ICQ, but if i try to define it as a
  James> style using the window title (my icq#), it tells me that
  James> SmartPlacement is a bad style command.

AFAIK, fvwm-1.X doesn't grok SmartPlacement; it was something added to
fvwm-2.0.40+.

kai
-- 
A large number of young women don't trust men with beards.
(BFBS Radio)

---

From: [email-masked]
Date: Wed, 25 Feb 1998 02:59:09 -0500 (EST)

On 24 Feb 1998, Kai Grossjohann wrote:

: >>>>> On Mon, 23 Feb 1998, James J Stewart said:
: 
:   James> i'm using fvwm1, and i'd like to have it perform
:   James> SmartPlacement on my ICQ, but if i try to define it as a
:   James> style using the window title (my icq#), it tells me that
:   James> SmartPlacement is a bad style command.
: 
: AFAIK, fvwm-1.X doesn't grok SmartPlacement; it was something added to
: fvwm-2.0.40+.

Zzzzzzzzzzzttttttt!  Thanks for playing.  fvwm-1.2x groks
SmartPlacement as a top-level config directive, but not as a style, e.g.:

    # (in .fvwmrc)
    # This is all-or-nothing; you can't have SmartPlacement for
    # some windows and `active placement' for others.
    SmartPlacement
    RandomPlacement

while fvwm2 groks this:

    # (in .fvwm2rc, or whatever you've chosen to call it)
    # You can restrict this to only the windows you want in fvwm2,
    # unlike in fvwm-1.2x.
    Style * SmartPlacement
    Style * RandomPlacement
    Style

--jim

%%%%%%%%%%%%%%% jim knoble %%%%%%%% [email-masked] %%%%%%%%%%%%%%%%%