Subject: FVWM: Click to bring to front?

From: Mark Fardal <[email-masked]>
Date: Wed, 25 Feb 1998 19:06:25 -0500 (EST)

Hi,

I'd like my windows to behave somewhat more like the Mac, in that when
clicked they come to the front.  Can anyone tell me how to customize
my .fvwm2rc so that this happens?

thanks,
Mark Fardal
UMass

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Manfred Bartz <[email-masked]>
Date: 26 Feb 1998 11:53:08 +1100

> my .fvwm2rc so that this happens?

1. Check your GlobalOpts.
2. You may also want to look at what your mouse button are defined to
   do.
3. The functions associated with mouse clics are defined elsewhere in
   the init file.  Use your editor to search.

An extract from my .fvwm2rc:

# GlobalOpts:
#   SmartPlacementIsReallySmart SmartPlacementIsNormal
#   ClickToFocusDoesntPassClick ClickToFocusPassesClick
#   ClickToFocusDoesntRaise ClickToFocusRaises
#   MouseFocusClickDoesntRaise MouseFocusClickRaises
GlobalOpts ClickToFocusPassesClick MouseFocusClickRaises

#..
#  ..
#    ..

## MouseButton: 0=any, 1, 2 or 3
## \      Context: R=RootWdw,  W=AppsWdw, T=TitleBar, S=Sides
##  \    /         F=Frame (corners), I=IconWdw, 0..9=WdwButtons
##   \  |              Wdw Button order: 1 3 5 7 9    0 8 6 4 2
##    | |      Modifiers: None,Control,Shift,Meta,Any,3=super,4=hyper
##    | |      \        Function
##---+-+-------+-------+-----------
Mouse 1	R   	A       Menu Main Nop
Mouse 2	R    	A      	Menu Module-Popup
Mouse 3	R    	A      	WindowList

Mouse 0	1    	A      	Menu Window-Ops2 Close
Mouse 0	8    	A     	Stick
Mouse 0	6    	A     	Iconify
Mouse 0	4    	A     	Maximize-Func
Mouse 0	2    	A     	Delete
Mouse 0	W	4	Menu Window-Ops2 Nop

Mouse 1	F	A	Resize-or-Raise
Mouse 1	TS	N	Move-or-Raise
Mouse 1	TSF	4	WindowShadeAndRaise
Mouse 1	I	A	Move-or-Iconify
Mouse 2	I	A	Iconify
Mouse 2	FST	A	Menu Window-Ops2 Nop
Mouse 3	TSIF	A	RaiseLower

#..
#  ..
#    ..

######################################################################
## Section 5: Functions. 
######################################################################
##  "I" stands for Immediate, and is executed as soon as the function is invoked.
##  "M" stands for Motion, i.e. if the user starts moving the mouse.
##  "C" stands for Click, i.e., if the user presses and releases the mouse in a 
##      short period of time (ClickTime milliseconds).
##  "D" stands for double-click.  The action "I" will cause an action to be 
##      performed on the button-press, if the function is invoked with prior knowledge 
##      of which window to act on.

AddToFunc Resize-or-Raise
+	"I" Raise
+	"M" Resize
+	"D" Lower

Hope this helps
-- 
Manfred Bartz <[email-masked]>
---------------------------------------------------------------
Things are more like they are today than they ever were before.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].