Subject: FVWM: MiniIcon Question

From: "A. Leidenfrost" <[email-masked]>
Date: Tue, 06 Jan 1998 23:15:35 +0100 (CET)

-----BEGIN PGP SIGNED MESSAGE-----

Hi everybody,

I am using fvwm2 and I really like it!

However, I have a slight problem with MiniIcons. What I would like is that the
main window of an application and all children get the same MiniIcon regardless
of the window name. E.g. gimp's main window is named 'THE GIMP' but a child
window containing and image might be called 'Unnamed something'. How do I
achieve that they get the same MiniIcon?

Many thanks for your time!

Regards,

        Andree
- ---
Andree Leidenfrost, GEOPHYSICIST

Institute of Geophysics, Hamburg University
Bundesstrasse 55, 20146 Hamburg, Germany
phone +49 40 4123 2984, fax +49 40 4123 5441
http://www.app-geoph.dkrz.de/andree

finger [email-masked] for PGP public key
PGP fingerprint = 5F FC 44 FF 84 71 C4 46  72 64 9A F0 EF 99 89 7C

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Kai Grossjohann <[email-masked]>
Date: 07 Jan 1998 12:14:09 +0100

>>>>> On Tue, 06 Jan 1998, A Leidenfrost said:

  Andree> However, I have a slight problem with MiniIcons. What I
  Andree> would like is that the main window of an application and all
  Andree> children get the same MiniIcon regardless of the window
  Andree> name. E.g. gimp's main window is named 'THE GIMP' but a
  Andree> child window containing and image might be called 'Unnamed
  Andree> something'. How do I achieve that they get the same
  Andree> MiniIcon?

Use FvwmIdent (or something) to find out more about the windows.
Maybe they share a common resource class?  Then, you might want to use
that in the Style command.

kai
-- 
Kai Grossjohann, Informatik VI        [email-masked]
Uni Dortmund, D-44221 Dortmund        http://ls6-www.cs.uni-dortmund.de/
                                      Vox +49 231 755 5670, Fax -2405
I like both kinds of music.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "A. Leidenfrost" <[email-masked]>
Date: Mon, 12 Jan 1998 12:07:04 +0100 (CET)

-----BEGIN PGP SIGNED MESSAGE-----

Hi Kai, hi Michael

thanks a lot for your replies!

Unfortunately, gimp sets neither the class name nor the resource name, at least
this is what FvwmIdent says. But I presume they can be defined in gimp source
rather easily. I think I'l ask the the gimp people if they could do this.

Regards,

        Andree 
- ---