Subject: FVWM: CustomPlacement

From: [email-masked] (A.J.vanWerven)
Date: Fri, 30 Jan 1998 13:37:41 +0100 (MET)

Hi there.

Fvwm always places my windows for me.
is there a way (I was thinking of a Style property) to realize
that I can manually place a window when it comes up ?

I couldn't find such a thing in the man pages.

Thanks in advance,

A. van Werven
Dept. of Computer Science, Leiden University, The Netherlands
Phone: +31 6 54212683
E-mail: [email-masked]
URL: http://www.wi.leidenuniv.nl/~avwerven

Life would be easier if I had the source code. 

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Bob Woodside <[email-masked]>
Date: Fri, 30 Jan 1998 09:17:06 -0500 (EST)

> that I can manually place a window when it comes up ?

        Try

            Style  "*"  DumbPlacement, ActivePlacement

If you like to use both on occasion, you can create a couple of functions
in your fvwm2rc, like these that I use, so you can switch back and forth:

    AddToFunc  SetSmart
    +                    "I"  Style "*" SmartPlacement, RandomPlacement
    +                    "I"  Recapture

    AddToFunc  SetDumb
    +                    "I"  Style "*" DumbPlacement, ActivePlacement
    +                    "I"  Recapture

        Cheers,
        Bob