Subject: FVWM: decorations

From: [email-masked] (Graeme McCaffery)
Date: Fri, 30 Jan 1998 17:11:03 +0000 (GMT)

Hello to all

I've been experimenting with decors. I now have 3 very sightly
different styles. obviously I would like all the common stuff
to only be written once.

I tried to add to decor default but the other decors don't pick
this up and instead used some other (inexplicable) defaults.

does anyone know how to do this, or does the code need changing.

I'm using Fvwm Version 2.0.46

thanks
Graeme
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Andrew Veliath <[email-masked]>
Date: Fri, 30 Jan 1998 14:16:12 -0500

There is no facility for copying decors directly in fvwm2, and it
would really need code modification.  Maybe something along the lines
of (I think a copy would be more appropriate than something like
InheritDecor since changing the common decor later would not modify
any intended descendents, that would require major restructuring):

AddToDecor "MyNewDecor"
+ CopyDecor "CommonDecor"

--
Regards,
Andrew Veliath
[email-masked], [email-masked]

>>>>> Graeme McCaffery writes:

    Graeme> Hello to all I've been experimenting with decors. I now
    Graeme> have 3 very sightly different styles. obviously I would
    Graeme> like all the common stuff to only be written once.

    Graeme> I tried to add to decor default but the other decors don't
    Graeme> pick this up and instead used some other (inexplicable)
    Graeme> defaults.

    Graeme> does anyone know how to do this, or does the code need
    Graeme> changing.

    Graeme> I'm using Fvwm Version 2.0.46

---

From: Richard Lister <[email-masked]>
Date: Fri, 30 Jan 1998 14:32:47 -0500

On Fri, 30 Jan 1998 17:11:03 +0000 (GMT)
[email-masked] (Graeme McCaffery) 

Graeme

I do something like this using FvwmM4:

## define a decor ... DECOR(name, dark_colour, light_colour, marble)

m4_define(DECOR, `AddToDecor $1
+ WindowFont WINDOWFONT
+ HilightColor Yellow $2

+ BorderStyle Active -- HiddenHandles
+ BorderStyle InActive (TiledPixmap MARBLES/$4 -- HiddenHandles)

+ TitleStyle RightJustified
+ TitleStyle Inactive   (VGradient 32 $3 Black -- Raised)
+ TitleStyle ActiveUp   (VGradient 32 $3 Black -- Raised)
+ TitleStyle ActiveDown (VGradient 32 Black $3 -- Flat)

+ ButtonStyle All Simple
+ ButtonStyle All InActive (VGradient 32 $3 Black -- Raised)
+ ButtonStyle All ActiveUp (VGradient 32 $3 Black -- Raised)
+ ButtonStyle All ActiveDown (Pixmap mini-exp.xpm -- Flat)

+ AddButtonStyle 1 ActiveUp (Pixmap mini-cross.xpm)
+ AddButtonStyle 1 InActive (Pixmap mini-cross.xpm)
+ AddButtonStyle 2 ActiveUp (MiniIcon)
+ AddButtonStyle 2 InActive (MiniIcon)
+ AddButtonStyle 3 ActiveUp (Pixmap mini-exclam.xpm)
+ AddButtonStyle 3 InActive (Pixmap mini-exclam.xpm)
+ AddButtonStyle 5 ActiveUp (Pixmap jline.xpm)
+ AddButtonStyle 5 InActive (Pixmap jline.xpm)
')

DECOR(default, DEFAULT_COLOUR, DEFAULT_COLOUR, pur5mrb.xpm)
DECOR(emacs, EMACS_COLOUR, LightGoldenRod, yel5mra.xpm)
DECOR(network, NETWORK_COLOUR, aquamarine, gree5mrb.xpm)
DECOR(xterm, XTERM_COLOUR, Cyan, cyan5mrb.xpm)

You can see my full M4 config at
  http://www.giccs.georgetown.edu/~ric/software/fvwm/config/

Cheers
Ric

Richard J Lister, Georgetown Institute for Cognitive and Computational Sciences
Georgetown University Medical Center, Washington, DC 20007, USA
Phone: +1 202-687 2878
Email: [email-masked] 
Web: http://www.giccs.georgetown.edu/~ric/
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Fri, 30 Jan 1998 15:08:18 -0500

> I'm using Fvwm Version 2.0.46

I haven't tested this, but wouldn't something like this work?

AddToFunc DefaultDecor "I" DestroyDecor $0
+ "I" AddToDecor $0 WindowFont	-adobe-helvetica-bold-r-*-120-*
+ "I" AddToDecor $0 HilightColor	white grey60
...

Function DefaultDecor FirstDecor
AddToDecor FirstDecor ButtonStyle ....

Function DefaultDecor SecondDecor
AddToDecor SecondDecor ButtonStyle ....

--
Dan Espen                                Phone: (732) 699-5570
444 Hoes Lane  Room RRC 1C-214           E-mail: [email-masked]
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].