Subject: Re: FVWM: Killing Extra Button Bars

From: [email-masked] (A.J.vanWerven)
Date: Mon, 5 Jan 1998 10:09:49 +0100 (MET)

Near 2000, Brian Schroeder mumbled something about:
> 
> FvwmButtons.  They work fine, and do exactly what I want.  However, I want
> to be able to remove them with a single mouse click.

As far as I'm aware of, you cannot specifically target one of the buttonbars.
Perhaps there is some way to retrieve the process id of the currently focused window ?
Then, you could do an exec (kill ....).

Another thing might be to iconify the buttonbar of your choice and set style NoIcon.
It then disappears, but you can still de-iconify (thus retrieving) it.

Hope this helps,

CIAO di Al Grandi.

-- 
God is real, unless declared integer.

A. van Werven
Dept. of Computer Science, Leiden University, The Netherlands
Phone: +31 6 54212683
E-mail: [email-masked]
URL: http://www.wi.leidenuniv.nl/~avwerven

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Robert H. Ford II" <[email-masked]>
Date: Mon, 05 Jan 1998 10:52:25 -0600

> It then disappears, but you can still de-iconify (thus retrieving) it.

I used to use a main button bar that could spawn secondary buttons bars when the
particular button was pressed.  To close the secondary button bar I had button
on that bar that executed a "Close".

For example I had a secondary button bar called "XtoolsBar" to close it once I
opened it I used the following line:

*XtoolsBar(Title close,Icon Yarw05rt.xpm,Action Close)

This always worked for me.

-- 
    _/_/_/     _/  _/   _/_/_/_/   _/_/_/_/_/_/ Robert H. Ford II
   _/   _/    _/  _/   _/           _/    _/    Lucent Technologies
  _/_/_/     _/_/_/   _/_/_/       _/    _/     Bell Labs Innovations
 _/   _/    _/  _/   _/           _/    _/      Naperville IL, 60566-7045
_/    _/   _/  _/   _/         _/_/_/_/_/_/     Email: [email-masked]
                                                Voice: (630) 713-4957
__________________________________________________
|  M R spiders!                    |      |   |  |
|  M N O spiders!                  |      |   |  |
|  O S A R - C D E D B D I's?      |      |   |  |
|  Y I B, M R spiders...           |      |   *  |
|                                  *      |      |
|                                         *      |
--------------------------------------------------
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].