Subject: FVWM: Disable Edge Scrolling

From: Wayne Ling <[email-masked]>
Date: Sat, 24 Jan 1998 19:55:06 +0000

Hi,

I am running fvwm2 on RedHat 5.0 with MetroX and I have
problem trying to disable the edge scrolling feature.

It appeared to me that .fvwm2rc in my home directory is
not used at all as changing the file has no impact at all.
I was able to reconfigure the window manager by copying
the following files from /etc/X11/AnotherLevel/ to my 
home directory and make changes to them:
  .fvwm2rc.defines
  .fvwm2rc.defstyles

However, I have not been able to disable edge scroll.  When 
the mouse pointer goes to the edge of a page, it just goes
right to the next page without any hesitation.  After each
restart of X, the edge scroll feature is disabled but 
the edge scroll is enabled by itself after a couple of minutes
of use.

I have been playing around with with the numbers from zero to
very large numbers in the following lines without any success:
  define(`EDGE_SCROLL_RESISTANCE',400)
  define(`EDGE_MOVE_RESISTANCE',40)

Does anyone know how I can get around the problem ?
Thank you very much for your help.

Regards,
Wayne Ling
[email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Wayne Ling <[email-masked]>
Date: Sat, 24 Jan 1998 19:59:10 +0000

I forgot to mention that the fvwm version I am running
is 2.0.46.

Regards,
Wayne Ling
[email-masked]

---

From: Jason L Tibbitts III <[email-masked]>
Date: 24 Jan 1998 16:00:42 -0600

>>>>> "WL" == Wayne Ling <[email-masked]> writes:

WL> Hi, I am running fvwm2 on RedHat 5.0 with MetroX and I have problem
WL> trying to disable the edge scrolling feature.

If you mean the smooth scrolling that happens because you have the X server
configured to use a larger virtual size than display size, then you won't
be able to turn it off from FVWM because it has nothing to do with FVWM.
read the documentation for your X server and figure out how to turn it off
there.

 - J<

---

From: Wayne Ling <[email-masked]>
Date: Sat, 24 Jan 1998 23:47:41 +0000

> read the documentation for your X server and figure out how to turn it off

No, I do not mean scrolling on a virtual desktop which area is
larger than the display area.  I mean that the desktop is has
several virtual pages and I do not want to go to another page
when the mouse pointer reaches the edge of a page.  I have done
my reading already.  The disabling of edge scroll can be done with
.fwm2rc but my win manager does not appear to take the cue from
the .fvwm2rc file at all.

---

From: Guangyong Xu <[email-masked]>
Date: Sat, 24 Jan 1998 19:01:52 -0500 (EST)

> the .fvwm2rc file at all.

That is quite strange. Just my suggestion, try play with your .fvwm2rc
file and change other settings to see if they have any effect at all. If
not, try running fvwm by "fvwm -f ~/.fvwm2rc". "Edgescroll 0 0" in
.fvwm2rc shold fix the problem. If still not, maybe you need to recompile
your fvwm...
 -GXu

---

From: Wayne Ling <[email-masked]>
Date: Sun, 25 Jan 1998 07:10:59 +0000

> .fvwm2rc shold fix the problem. If still not, maybe you need to recompile

I copied  /usr/X11R6/lib/X11/xinit/Xclients to ~/.Xclients and
changed the following line
    FVWMOPTIONS="-cmd 'FvwmM4 -debug $RCFILE'"
to
    FVWMOPTIONS="-f ~/.fvwm2rc'"

Now .fvwm2rc has effect. but with "Edgescroll 0 0", I still see
the scroll over to the next page.
-- 
Wayne Ling
[email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Guangyong Xu <[email-masked]>
Date: Sun, 25 Jan 1998 02:34:26 -0500 (EST)

> the scroll over to the next page.

I use slackware instead of redhat so that I don't have the file Xclients
in effect. But I suppose the variable FVWMOPTIONS is just the options
being passed to fvwm when it is called. I still don't understand why your 
fvwm does not know to use your .fvwm2rc file when not using this option.
It should be the default resource file. But that is a little off the
thread.
 
As for the problem of scrolling, I suspect you may have redefined 
EdgeScroll somewhere else in your .fvwm2rc file, try look for it. If not,
try using "EdgeResistance 10000 0", see if it helps. 

Best wishes,
G.Xu

---

From: Wayne Ling <[email-masked]>
Date: Tue, 27 Jan 1998 06:14:53 +0000

> try using "EdgeResistance 10000 0", see if it helps.

I finally stumbled to the right place.  When I press the left button,
there is a menu for "preferences" and I can disable edge scroll under
the "Scroll Setup" submenu.

---

From: Wayne Ling <[email-masked]>
Date: Tue, 27 Jan 1998 06:14:53 +0000