Subject: FVWM: FvwmPager - won't take focus bug + patch

From: [email-masked] (Greg Klanderman)
Date: Thu, 11 Dec 1997 19:46:05 -0500

Hi,

It is not possible for FvwmAuto to auto-raise the FvwmPager, because
the pager is never given input focus.  The patch below fixes this bug.
I needed it for the perl module I wrote for raising specific windows
to work for the one window I most wanted auto-raised.

I submitted another patch a couple weeks ago - should I expect a
confirmation on whether these will actually get incorporated?  

thanks,
Greg

--- /local/mstar/.backups/!local!mstar!software!fvwm!fvwm-2.0.46!modules!FvwmPager!x_pager.c.~2~	Tue Nov 25 15:30:50 1997
+++ x_pager.c	Mon Dec  8 18:37:44 1997
@@ -309,7 +309,7 @@
       wmhints.flags = IconPositionHint;
     }
   wmhints.icon_window = icon_win;
-  wmhints.input = False;
+  wmhints.input = True;
 
   wmhints.flags |= InputHint | StateHint | IconWindowHint;
 
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (A.J.vanWerven)
Date: Fri, 12 Dec 1997 09:15:43 +0100 (MET)

Near 2000, Greg Klanderman mumbled something about:
> the pager is never given input focus.

Don't want to sound silly or something, but why not just
Style "FvwmPager" AlwaysOnTop ?

CIAO di Al Grandi.

-- 
God is real, unless declared integer.

A. van Werven
Dept. of Computer Science, Leiden University, The Netherlands
Phone: +31 6 54212683
E-mail: [email-masked]
URL: http://www.wi.leidenuniv.nl/~avwerven