Subject: FVWM: errors caused by fvwmbuttons

From: Viorel ANGHEL <[email-masked]>
Date: Mon, 17 Nov 1997 12:19:48 -0500

Sometimes, my FvwmButtons crahs on startup (init or restart) with errors
like:

X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  18 (X_ChangeProperty)
  Resource id in failed request:  0x3400002
  Serial number of failed request:  41
  Current serial number in output stream:  46
X Error of failed request:  BadDrawable (invalid Pixmap or Window parameter)
  Major opcode of failed request:  62 (X_CopyArea)
  Resource id in failed request:  0x1000020
  Serial number of failed request:  119
  Current serial number in output stream:  124              

What's that?

-- 

Viorel ANGHEL <[email-masked]>                "World domination. Fast!"
http://www.pub.ro/~vang/                          (Linus Torvalds)
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: David Jones <[email-masked]>
Date: Mon, 17 Nov 1997 17:50:11 -0500

>   Current serial number in output stream:  124

I used to get similar error messages when starting up FvwmButtons,
except with me it happened every time. I finally traced my problem to
the version of libXpm that I was using, it was libXpm-4.7. When I
replaced this version of libXpm with the earlier 4.6 version,
FvwmButtons worked fine, and I never had any mor eproblems with it.

You can, of course, check the version of libXpm that your FvwmButtons is
using by "ldd FvwmButtons"

Hope this helps.

-- 
===========================================================
|                                                         |
|   David Jones          E-Mail:  [email-masked]     |
|   ===========                   [email-masked]   |
|                                                         |
|   Phone: 905-856-9172 (h)       PGP public key is       |
|          416-375-3492 (w)       available on request    |
|                                                         |
|   http://home.sprynet.com/sprynet/davej                 |
|   http://www.geocities.com/TheTropics/6313              |
|                                                         |
===========================================================
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Viorel ANGHEL <[email-masked]>
Date: Tue, 18 Nov 1997 09:35:32 -0500

> FvwmButtons worked fine, and I never had any mor eproblems with it.

	errr, i have libXpm.so.4.9 !

Aniway, i eliminate buttons one by one and the errors is caused by

*FvwmButtons(4x4, Swallow(Close, UseTitle) "rclock" \
    xec rclock -bg '#0c5a87' -geometry -10000-10000 &, \
    Action xec x-cal)

More help?

--