Subject: FVWM: 800x600 = 805x600 :(

From: Adam Kopacz <[email-masked]>
Date: Thu, 13 Nov 1997 11:37:21 +0100

hi,

i use 800x600x32bpp and fvwm2.00.46 under linux (XFree86 3.3.1) .
but the screensize is 805x600 !! :(
why ???
when i maximize a window using:
AddToFunc "maximize_func" "M" Maximize 100 90
(10% left for my FvwmButtons) then there are some (5) pixels free at the
right side :( is this a bug in fvwm2 ??

-- 
Bye,                                          Linux/Babes
  Adam Kopacz (kLoGraFX / klospatz)      http://www.rat.de/Adam

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Greg Fall <[email-masked]>
Date: Thu, 13 Nov 1997 10:46:35 -0500 (EST)

> right side :( is this a bug in fvwm2 ??

Nope, you need to get your XFree86 setup adjusted.  fvwm just handles
windows; it does not set up those aspects of your X display.  Sorry I
can't tell you much else -- XFree86 has about a thousand README - type
files.  Dig around in there to find out how to adjust your XF86Config.

--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--=--

Greg Fall
[email-masked]
http://www-personal.engin.umich.edu/~gmfall

---

From: Jim Knoble <[email-masked]>
Date: Thu, 13 Nov 1997 13:46:11 -0500 (EST)

Adam--

If you're maximizing an xterm or similar window (rxvt, xjed, &c.) you
can easily get this sort of behavior, since xterms contrain their size
to an integral multiple of their character cell size.  If you try a
`Maximize 100 100' on an xterm, you may find that it doesn't fill the
full height of the viewport either.

--jim

%%%%%%%%%%%%%%% jim knoble %%%%%%%% [email-masked] %%%%%%%%%%%%%%%%%

: i use 800x600x32bpp and fvwm2.00.46 under linux (XFree86 3.3.1) .
: but the screensize is 805x600 !! :(
: why ???
: when i maximize a window using:
: AddToFunc "maximize_func" "M" Maximize 100 90
: (10% left for my FvwmButtons) then there are some (5) pixels free at the
: right side :( is this a bug in fvwm2 ??

---

From: Adam Kopacz <[email-masked]>
Date: Thu, 13 Nov 1997 19:36:12 +0100

Jim Knoble wrote:
hi,

> to an integral multiple of their character cell size.  If you try a

yes, but i have this prob with all apps :(
i must use :
Geometry 805x57+0-0
in my fvwmButtonsrc that FvwmButtons fill aout the whole Y of the screen
:(

ps: my Modeliens are ok.. 800x600..