Subject: FVWM: Key Pause = xlock ?

From: Adam Kopacz <[email-masked]>
Date: Wed, 12 Nov 1997 20:42:42 +0100

hi,

how can i bind CTRL-Pause with the 'xlock' app ????
i have tried :
Key Pause       A       C      Exec xlock &
but this shows me only 'Module "&" not found' and without the "&" i see
no error msg but after closing XFree86 3.3.1 my consoles are dead :((
all characters (without 0-9) are demaged :(
what do i wrong ? 

-- 
Bye,                             Linux/Babes
  Adam Kopacz (kLoGraFX)    http://www.rat.de/Adam

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (A.J.vanWerven)
Date: Wed, 12 Nov 1997 21:12:47 +0100 (MET)

> after closing XFree86 3.3.1

What is that ? Xlock ???

> Key Pause       A       C      Exec xlock &

Perhaps you could first try mapping another command to this key, for example

Key Pause A C FvwmBanner

And tell us what happens then.

This might tell us wether there's something wrong with XLock or with mapping the pause key.

CIAO di Al Grandi.

--------------------------------------------------------------------------

Beam me up Scotty, this planet sucks !

A. van Werven
Dept. of Physics, Leiden University
Huygens Laboratory, Leiden, Holland
Phone: +31 6 54212683
E-mail: [email-masked]
URL: http://www.wi.leidenuniv.nl/~avwerven

---

From: Adam Kopacz <[email-masked]>
Date: Wed, 12 Nov 1997 21:43:40 +0100

A.J.vanWerven wrote:
hi,

> What is that ? Xlock ???

       xlock  -  Locks  the  local  X display until a password is
       entered.

its a great 'screensaver'-pack :)
 
> And tell us what happens then.

nothing :(
the error (probs with &) wasn't from this action.. it was something
another 
("I" + module + & != good)
 
> This might tell us wether there's something wrong with XLock or with mapping the pause key.

i have tested with the A-ke.. it works.. only Pause don't work in
FVWM2.. in all another apps (Tcl/tk or so) it works fine..

---

From: Adam Kopacz <[email-masked]>
Date: Wed, 12 Nov 1997 21:46:20 +0100

A.J.vanWerven wrote:

hi again,

key bindings with ESC don't work too :(( why ?????
arror-keys or so works fine..

---

From: "Charles Hines" <[email-masked]>
Date: Wed, 12 Nov 1997 17:13:21 -0500

>>>>> "Adam" == Adam Kopacz <[email-masked]> writes:

....
>> And tell us what happens then.

Adam> nothing :(
....
Adam> i have tested with the A-ke.. it works.. only Pause don't work in
Adam> FVWM2.. in all another apps (Tcl/tk or so) it works fine..

I just tried the above example, and it worked just fine for me (at
work under AIX).  If you entered it in FvwmTalk, you'll need to do a
Recapture to get it to take effect.

Adam> key bindings with ESC don't work too :(( why ?????
Adam> arror-keys or so works fine..

I also tried:

Key Escape A C Module FvwmBanner

and that worked fine for me here too.

Chuck

--
*******************************************************************************
Charles K. Hines <[email-masked]>
IBM Logic Synthesis Developer [BooleDozer (TM)]
Martial Arts Instructor [Modern Arnis, Presas Style Filipino Martial Arts]

         "Go back to sleep, Chuck.  You're just havin' a nightmare
             -- of course, we ARE still in Hell." (Gary Larson)
*******************************************************************************
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: David Wren-Hardin <[email-masked]>
Date: Wed, 12 Nov 1997 14:21:00 -0800 (PST)

Well, it turns out that indeed the version of FvwmIconMan I had was
incompatible with the version of fvwm I'm running. Looks like a lot
of the time the generic fvwm2 distribution ships with a version of
FvwmIconMan made for the version or two before. So I was running
.9 which was meant for fvwm-2.0.43 or so. I recompiled it from the
fvwm-2.0.46 distribution (which says it is for 2.0.45) and now the
commands work.

What I haven't done is install fvwm-2.0.46. Once I do so (I'm going to
add the startsonpage patch), can I expect FvwmIconMan to break again? 

David Wren-Hardin 		| People are more violently opposed to fur
[email-masked]	| than leather because it's safer to harass
http://weber.u.washington.edu	| rich women than motorcycle gangs.
      /~dwrenhar/              	| 				  -Unknown

---

From: Mark J Hewitt <[email-masked]>
Date: Wed, 12 Nov 1997 22:30:31 +0000

> its a great 'screensaver'-pack :)

Provided you mean 'xlockmore' of course!
-- 
Mark J. Hewitt      at home           [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Viorel ANGHEL <[email-masked]>
Date: Thu, 13 Nov 1997 09:47:58 -0500

> but this shows me only 'Module "&" not found' and without the "&" i see
[...]
> what do i wrong ? 

I try

Key Pause       A       A       Exec xlock -nolock&

and works!

-- 

Viorel ANGHEL <[email-masked]>                "World domination. Fast!"
http://www.pub.ro/~vang/                          (Linus Torvalds)
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Adam Kopacz <[email-masked]>
Date: Thu, 13 Nov 1997 10:19:19 +0100

Viorel ANGHEL wrote:
Hi,

> Key Pause       A       A       Exec xlock -nolock&

thanx. this works with the Pause-Key, but why this don't work with
CTRL-PAUSE ?
i don't want to bind only the Pause key because meybe some apps need
this (?).. ctrl+pause would be better i think..

-- 
Bye,                                          Linux/Babes
  Adam Kopacz (kLoGraFX / klospatz)      http://www.rat.de/Adam

---

From: Viorel ANGHEL <[email-masked]>
Date: Thu, 13 Nov 1997 13:17:25 -0500

> thanx. this works with the Pause-Key, but why this don't work with

xev says that the key PAUSE generate
...
keycode 110 (keysym 0xff13, Pause)
...

but CTRL+PAUSE generate 
...
(keysym 0xffe3, Control_L)
...
(keysym 0x0, NoSymbol)
...

SO ctrl+pause won't work...

> this (?).. ctrl+pause would be better i think..

none!

--

---

From: Thomas Rausch <[email-masked]>
Date: Thu, 13 Nov 1997 11:36:30 GMT

> and that worked fine for me here too.

Key     Pause   A       A       exec xlock -nolock -mode dclock
Key     Pause   A       SM      exec xlock -mode dclock

This works fine, but

Key     Pause   A       C       exec xlock -nolock -mode dclock

don't work. Why?

Thomas

---

From: Thomas Rausch <[email-masked]>
Date: Thu, 13 Nov 1997 11:54:01 GMT

> Key     Pause   A       C       exec xlock -nolock -mode dclock

But:

Key     Break   A       A       Module FvwmBanner

works fine!!!

PS: Thanks to Viorel and xev.

---

From: Walter Truitt <[email-masked]>
Date: Thu, 13 Nov 1997 09:22:22 -0600

>>>>> In <[email-masked]> 
>>>>>	Viorel ANGHEL <[email-masked]> wrote:

VA> On Thu, Nov 13, 1997 at 10:19:19AM +0100, Adam Kopacz wrote:
Adam> Viorel ANGHEL wrote:
Adam> Hi,
Adam> 
VA> > > Key Pause       A       A       Exec xlock -nolock&
VA> > > and works!
Adam> 
Adam> thanx. this works with the Pause-Key, but why this don't work with
Adam> CTRL-PAUSE ?

VA> xev says that the key PAUSE generate
VA> ...
VA> keycode 110 (keysym 0xff13, Pause)
VA> ...

VA> but CTRL+PAUSE generate 
VA> ...
VA> (keysym 0xffe3, Control_L)
VA> ...
VA> (keysym 0x0, NoSymbol)
VA> ...

VA> SO ctrl+pause won't work...

Now that you have reminded me the name of the tool xev:  On the sun
keyboard it is as so:

PAUSE:

KeyPress event ...   keycode 28 (keysym 0xffd2, F21)

and

CTRL + PAUSE:

 keycode 83 (keysym 0xffe3, Control_L)
 keycode 28 (keysym 0xffd2, F21)

So it should work for me, if I give it a try.  I think xlock is
a good choice for the key.  Thanks.  Sorry it won't help anyone
not on a Sun, but I was happy to learn.

 -walter

---

From: Kendrick Vargas <[email-masked]>
Date: Thu, 13 Nov 1997 13:30:51 -0500 (EST)

> this (?).. ctrl+pause would be better i think..

Some games do use the pause key to suspend the game (MAelstrom, Doom)... I
know I've gotten older fvwm2 configurations to work with CTRL+ALT+PAUSE or
some variation of that... However, this didn't seem to work across all
platforms....
			-peace

--- BEGIN GEEK CODE BLOCK ------------+-----------
GAT d- s:+ !a C+(+++) UI/L/S/B++(+++) | "In the morning glad I see
P>+ L+(++) E---- W+++ N+ o? K? w++++  |  My foe outstrech'd beneath the tree."
O--- M-- V PS+++@ PE Y-- PGP+ t++ 5   |               -The Poison Tree
X++ R- tv+ b DI++ D+ G e>*  h*(!) r-  |                William Blake
y*(+) ------ END GEEK CODE BLOCK -----+

---

From: Brady Montz <[email-masked]>
Date: 13 Nov 1997 14:22:48 -0700

> add the startsonpage patch), can I expect FvwmIconMan to break again? 

fvwm2.0.46 should have the latest version. I wouldn't expect it to break.

-- 
 Brady Montz
 [email-masked]