Subject: FVWM: Window resize by the edges.

From: John Marconi <[email-masked]>
Date: Mon, 24 Nov 1997 06:56:44 -0600 (CST)

Hi all,

This question has probably already been asked (100 times)...
I would like to have Mouse 1 on the window sides cause the
window to resize instead of to move.  I have looked through
the Faq and the man pages to some extent but haven't been
able to figure it out.  Currently, only the corners of the
window cause the window to resize for me.

Thank you,
John

-- 
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (A.J.vanWerven)
Date: Mon, 24 Nov 1997 14:17:48 +0100 (MET)

> This question has probably already been asked (100 times)...

But not to you, apparently. So, never mind asking.

> window to resize instead of to move.

In your rc-file, you probably have this:

: Mouse 1 S A Move

or something quite similar.

Just change "Move" to "Resize".
Or, alternatively, delete the entire line and change the line

: Mouse 1 F A Resize

into

: Mouse 1 FS A Resize

(you'd better not change that A, because if you do, the mouse probably only obeys when you
simultaneously click and hold the Alt or Ctrl key <GRIN>)

CIAO di Al Grandi.

--------------------------------------------------------------------------

God is real, unless declared integer.

A. van Werven
Dept. of Computer Science, Leiden University, The Netherlands
Phone: +31 6 54212683
E-mail: [email-masked]
URL: http://www.wi.leidenuniv.nl/~avwerven

---

From: Broc Stirton <[email-masked]>
Date: Mon, 24 Nov 1997 08:24:33 -0600

I think you want:
Mouse 1 SF      A       Resize-or-Raise   (or whatever your Resize
function is)
You'll probably just have to add the S (for side) to an existing line
(the one that defines resize on the corners).  Don't forget to remove
the S from the Move line:
E.g.:
Change:
Mouse 1 TS       A       Move-or-Raise2
To:
Mouse 1 T       A       Move-or-Raise2

Hope that helps,
		Broc
-- 
						--------------------
						    Broc Stirton
						  [email-masked] 
						--------------------