Subject: FVWM: Pager

From: Jerry Ingerman <[email-masked]>
Date: Mon, 17 Nov 1997 17:27:42 -0500 (EST)

Hi. I would like to set up a Pager the size of a
full screen that would only display on that screen and
have a sticky button bar with one of the buttons being a
transfer to the screen with the Pager.
	I first thought that the way to do this was have
a second pager swallowed in one of the buttons. But I'm
not interested in the whole pager grid in the case of the
second Pager swallowed in the button but only the part of
it that transfers control to the desktop with the full
screen pager.
	I hope i said that clearly! 
	Is there a better way to make a button that transfers
to only one specific desktop in the 'grid'?

thank you in advance.

	-- Jerry Ingerman
	  ([email-masked])
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (A.J.vanWerven)
Date: Tue, 18 Nov 1997 09:14:56 +0100 (MET)

> to only one specific desktop in the 'grid'?

A bit of a freaky idea, but it's your choice :-)

Ehmz...try something like starting the Pager in the Init function on a certain screen

AddToFunc InitFunc
...blabla...your own stuff...
+ "I" Desk 0 0 (or whatever other desk - if necessary)
+ "I" GotoPage 0 0 (or whereever you want your pager)
+ "I" FvwmPager

Don't Forget to add
FvwmPagerGeometry ... (whatever is needed to provide a full-screen)

And then, Make a button like this (on the sticky buttonbar)

*FvwmButtons (1x1, Title Pager, Icon blabla.xpm, Action "GotoPage 0 0")

I didn't test it, but the idea should be right.

CIAO di Al Grandi.

--------------------------------------------------------------------------

God is real, unless declared integer.

A. van Werven
Dept. of Computer Science, Leiden University, The Netherlands
Phone: +31 6 54212683
E-mail: [email-masked]
URL: http://www.wi.leidenuniv.nl/~avwerven

---

From: Brad Giaccio <[email-masked]>
Date: Tue, 18 Nov 1997 08:01:04 -0500 (EST)

> *FvwmButtons (1x1, Title Pager, Icon blabla.xpm, Action "GotoPage 0 0")
Not bad or you could do something like 
 Next [FvwmPager*] Iconify -1
	so your not locked into having the pager in a specific location.
plus that won't work if it is on a different desk
I map something like that to the help button to get me to my tkman 
with the added line
Next [Man*] WarpToWindow 32 9
  so my cursor will actually be somewhere useful in the window