Subject: FVWM: no sound

From: Klaus Neumann <[email-masked]>
Date: Sun, 26 Oct 1997 23:49:05 +0100 (MET)

Hi,

I just upgraded to fvwm-2.0.43. 
My sound, that I configured in .fvwm2rc does not work at all, and I've no
idea why not. (Other programs like tkdesk do produce sound, so nothing wrong
with my system!) The elevant part of my .fvwm2rc looks like this:

----------- cut -----------
# START-UP Functions
#
AddToFunc "InitFunction" "I" Module FvwmButtons
+               "I" Module FvwmPager 0 0
+               "I" Module FvwmAudio
#+               "I" Module FvwmForm
+               "I" Next [!iconic CurrentScreen xterm] Focus
+               "I" CursorMove 30 40
+               "I" exec xsetroot -solid wheat

AddToFunc "RestartFunction" "I" Module FvwmButtons
+               "I" Module FvwmPager 0 0
+               "I" Module FvwmAudio
#+               "I" Module FvwmForm
+               "I" Next [!iconic CurrentScreen xterm] Focus
+               "I" CursorMove 30 40
+               "I" exec xsetroot -solid wheat

# FvwmAudio
#
*FvwmAudioPlayCmd  cat %s > /dev/audio    

# builtin-rplay doesn't work either!

*FvwmAudioDir /root/sounds
*FvwmAudio startup meepmeep.au
*FvwmAudio shutdown cowbell.au
#*FvwmAudio unknown glas.wav
*FvwmAudio destroy_window crash.au
*FvwmAudio iconify clink.au
*FvwmAudio deiconify monkey.au

*FvwmAudio add_window bong.au
*FvwmAudio toggle_paging train.au

#*FvwmAudioDelay 3

*FvwmAudio focus_change drip.au
*FvwmAudio raise_window drip.au
*FvwmAudio lower_window drip.au
------------- cut ------------------

Any idea what I'm doing wrong?

Cheers!

Klaus  
------------------------------
E-mail: [email-masked]
Motala / Sweden,  26-Oct-97 at  23:35:17
------------------------------
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: David Jones <[email-masked]>
Date: Mon, 27 Oct 1997 17:12:56 -0500

> with my system!) The elevant part of my .fvwm2rc looks like this:

I had problems with the sound in one of the earlier versions of fvwm2
(like 2.0.42 I think). Just like you, it never worked at all. However,
when I upgraded to 2.0.45, it suddenly starting working okay. Thus. I
recommend you to upgrade to either 2.0.45 or 2.0.46. Hopefully, that
should solve your problems.

===========================================================
|                                                         |
|   David Jones          E-Mail:  [email-masked]     |
|   ===========                   [email-masked]   |
|                                                         |
|   Phone: 905-856-9172 (h)       PGP public key is       |
|          416-375-3492 (w)       available on request    |
|                                                         |
|   http://home.sprynet.com/sprynet/davej                 |
|   http://www.geocities.com/TheTropics/6313              |
|                                                         |
===========================================================
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Klaus Neumann <[email-masked]>
Date: Tue, 28 Oct 1997 13:54:53 +0100 (MET)

Hello David,

> should solve your problems.

You mean, I can find higher versions than 2.0.43 on
http://www.hpc.uh.edu/fvwm? I don't remember from where I got my version, but
I'm pretty sure, I picked the latest there was. 
I'll take a look at it tonight. Thanks a lot for the hint! Have a nice day!

Cheers!

Klaus  
------------------------------
E-mail: [email-masked]
Motala / Sweden,  28-Oct-97 at  13:48:19
------------------------------
Once, adv.:
        Enough.
                -- Ambrose Bierce, "The Devil's Dictionary"