Subject: FVWM: Selected menus disappear?

From: Thomas Voss <[email-masked]>
Date: Wed, 3 Sep 1997 12:12:25 +0200 (MSZ)

Hello,

please excuse me if this message really reaches you the second time now. 
My first subscription to the mailing list from yesterday was in error, and
unfortunately crossed with my first message. But finally, now I am really
subscribed. :-)

Ok, here's my message again:

I often remark following behaviour of fvwm2:
When clicking on the menu bar of an application, the pull-down menu
appears for a tenth of a second or so, and afterwards disappears 
directly. No, it does not disappear in reality - as one can see if
the application window is very small and the pull-down menu is very 
big (bigger than the window), the pull-down menu appears *behind* the
application's window!

This appears to happen with almost any application I use.
What can I do to prevent this?

I use fvwm-2.0.45.

Ciao, Thomas

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Bob Plester" <[email-masked]>
Date: Wed, 3 Sep 1997 11:17:09 +0100 (BST)

> 
> On Tue, 2 Sep 1997 09:16:06 -0600 (CST)
> Merlin Hansen <[email-masked]> 
> wrote concerning 'Re: FVWM: Selected menus disappear?':
> > Hi,  I noticed this also and did a little experimenting to come up with a
> > theory...
> > 
> > Do you run autoraise?  I do.  I believe what is happening in my case is
> > that I mouse to a new window and hit a button.  The pull-pull down menu
> > appears, then the auto-raise timer expires and raises the main window above
> > (infront) of the pull-down menu.  
> > 
> > How do I support this theory... if I click anywhere in the main window that
> > cancels the button then hit the button again the pull-down appears and
> > stays there.  
> > 
> > My solution : with my autoraise set to .5 seconds I usually wait out the
> > timer whenever I switch windows before hitting a button.
> > 
> > Do you notice the same pattern as I do (menu never disappears if main
> > window has focus for longer than autoraise timer)?
> 
> 
> You're correct.
> 
> This definitely occurs as a result of using FvwmAuto with a reasonably
> large timeout. I've been experimenting with this as a result of the
> same problem occuring with the Pager balloons. The only solution so far
> is to keep the FvwmAuto timeout small (order of 100 msec), or wait a bit
> longer before pulling down a menu immediately after entering the window.
> 
> Ric
> 
> Richard J Lister, Georgetown Institute for Cognitive and Computational Sciences
> Georgetown University Medical Center, Washington, DC 20007, USA
> Phone: +1 202-687 2878
> Email: [email-masked] 
> Web: http://www.giccs.georgetown.edu/~ric/
> --
My solution is as follows:
	As a menu is just a special window use editres to get the window name
        Use Style to make them StayOnTop

This is not exactly an "elegant" solution but it seems to work.

Regards,

**********************************************************************************
* Bob Plester,                          Email:   [email-masked]            *
* Western Atlas International Inc.      Office:  +44 (0) 181 560 3160  Ext 4208  *
* 455 London Road                       DDI:     +44 (0) 181 585 4208            *
* Isleworth                             Fax:     +44 (0) 181 847 3131            * 
* Middlesex                                                                      *
* TW7 5AB England.                                                               *
**********************************************************************************