Subject: FVWM: Better autoraise anyone?

From: Alain Picard <[email-masked]>
Date: Wed, 3 Sep 1997 09:32:17 +1000

Greetings!  This is my de-lurking post.  Do with it
what you must... :-)

I think fvwm needs a better, more customizable method for
doing autoraising.  In particular, I'm thinking of a Style
entry

e.g.

Style "emacs" Icon emacs.xmp, Nohandles, Autoraise 300
...
Style "pager" Autolower 100

The point is that it would be nice to be able to control
the (auto) raising and lowering of windows on a window by
window basis.  I seem to remember using a WM which did this
(ctwm perhaps?) and it was very useful.

Any comments?  Is this a useful feature?
Anybody want to have a shot at implementing it?? :-)

				--ap

p.s. Let me say that fvwm is a joy to use, and it seems
     to be getting better every release.  I really like
     the color shading in title bars!  Very snazzy.
--
It would be difficult to construe        Larry Wall, in  article
this as a feature.			 <[email-masked]>
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Elad Eyal <[email-masked]>
Date: Thu, 4 Sep 1997 13:21:59 +0300 (IDT)

Good morning,

> Style "emacs" Icon emacs.xmp, Nohandles,Autoraise 300
> ...

This would mean implementing AutoRaise inside fvwm core (boo! If I wanted
someone else to touch my windows I'd buy another mouse). Or - and this
sounds better - extending the "Style" flag to support modules'
configuration. Maybe something into that big style rewrite I hear
is planned.
 _
(_  /  _    /          ( E-mail pigeons nest in binary trees )
(__/__(/\_(/