Subject: FVWM: I love FvwmButtons! :)

From: Adam Kopacz <[email-masked]>
Date: Fri, 08 Aug 1997 23:04:17 +0200

hi,

check this out! :)
(Module FvwmButtons File .fvwmtb_inet)

-- 

Bye,                        klospatz's Linux-Place (Babes/Files)
    Adam Kopacz (klospatz)       http://www.rat.de/Adam

# FvwmButtons ConfigFile

Fore Black
Back gray70
Font -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
Geometry 805x57+0-0
Rows 1
Padding 0 0
Frame 1

(Container)
  (1x2) -  klo_inet.xpm Function fvwm2b_nrm
  (2x1, Title Menue, Action(mouse1) 'PopUp Main-Menu', Action(mouse2) Nop, Action(mouse3) 'WindowList')
    - mini-display.xpm Refresh
    - /root/_pixmaps/bar/max.xpm Function "maximize_func"
(End)

#- Shell2.linux.xpm Exec xterm -sb -sl 200 -bg gray80 -fg black &

(1x1, Container(Rows 3))
 xterm - Exec xterm -T xterm &
 ftp - Exec exec xterm -T ftp -e ftp &
 telnet - Exec xterm -T telnet -e telnet &
(End)

- mc.xpm          Exec xterm -T mc -n mc -e mc -c &
- netscape_3d.xpm  Popup FvwmNetscape

(5x1, Container(Rows 3))
 (3x1, Frame 1, Back grey78, Fore darkblue,Title (Left)" PPPCOSTS :") - 
 (1x1) ppp-GO - Exec /root/bin/scripts/ppp-go &
 (1x1) ppp-OFF - Exec /root/bin/scripts/ppp-off &
 (5x2, Frame 1, Back grey78) - - Swallow "pppcosts" Exec rxvt -fn fixed -bg grey78 -cr grey78 -fg darkblue +sb -geometry 56x2+100+650 -e pppcosts &
(End)
 
(2x1) - whatever Swallow "FvwmPager" Module FvwmPager 0 0 &

- whatever Swallow "asclock" Exec exec asclock -shape -led yellow -noblink -position +100+650 &

---

From: Tim Phipps <[email-masked]>
Date: Tue, 12 Aug 1997 14:22:40 +0100 (BST)

> 
> OK guys, I'm impressed!  How about a copy of your Buttons script?
> 
> Stew Benedict

Here's my FvwmButtons chunk.  I use FvwmCpp to define a few things

/* Module FvwmButtons FrontPanel */
/* use Style FrontPanel BorderWidth 0, HandleWidth 0 */
*FrontPanelBack BG
*FrontPanelFont BOLD_MEDIUM
*FrontPanelFore FG
*FrontPanelGeometry 1280x144+0+880
*FrontPanelPadding 0 0

*FrontPanelRows 1
*FrontPanel(3x1 Container(Columns 1))
   *FrontPanel(1x3 Swallow asclock "Exec asclock -12 -noblink -shape -exe xcal" Padding 0 2)
   *FrontPanel(1x1 Title Start Action "Menu menu_main")
   *FrontPanel(1x2 Swallow xload "Exec xload" Padding 12 4)
*FrontPanel(End) 
*FrontPanel(61x1 Container(Columns 1))
   *FrontPanel(1x1 Swallow(Respawn) FvwmIconMan FvwmIconMan Frame 0)
   *FrontPanel(1x5 Container(Rows 1)
      *FrontPanel(55x1 Swallow(NoClose, Respawn, UseOld) xmcd "Exec xmcd" Frame 0)
      *FrontPanel(10x1 Container(Columns 1))
         *FrontPanel(1x1 Title Mail Action my_post)
         *FrontPanel(1x4 Swallow xbuffy "Exec xbuffy -boxfile .xbuffyrc" Frame 0)
      *FrontPanel(End)
      *FrontPanel(100x1 Swallow(UseOld NoClose Respawn) term-fp "Exec sh -c 'sleep 5; dtterm -name term-fp -C'" Frame 0)
      *FrontPanel(45x1 Swallow cutview "Exec cutview")
      *FrontPanel(34x1 Swallow(Respawn) FvwmPager "FvwmPager 0 3")
   *FrontPanel(End)
*FrontPanel(End)

/* Desktop viewer */
*FvwmPagerRows 2
*FvwmPagerColumns 2
*FvwmPagerFont none
*FvwmPagerSmallFont TINY
*FvwmPagerFore FG
*FvwmPagerBack BG
*FvwmPagerHilight HL

/* task bar */
*FvwmIconMan*NumManagers 1
*FvwmIconMan*Background BG
*FvwmIconMan*ButtonGeometry 1220x24
*FvwmIconMan*DrawIcons TRUE
*FvwmIconMan*FocusButton Up FG HL
*FvwmIconMan*FocusAndSelectButton SunkEdge FG HL
*FvwmIconMan*Font BOLD_MEDIUM
*FvwmIconMan*Foreground FG
*FvwmIconMan*Format "%i"
*FvwmIconMan*ManagerGeometry 1x1+0-0
*FvwmIconMan*PlainButton Up FG BG
*FvwmIconMan*Resolution desk
*FvwmIconMan*SelectButton SunkEdge FG BG
*FvwmIconMan*Shape TRUE
*FvwmIconMan*Title "Icon Manager"
*FvwmIconMan*TitleButton Up BG BG
*FvwmIconMan*FollowFocus TRUE
*FvwmIconMan*Sort FALSE

*FvwmIconMan*Action Mouse 1 N SendCommand my_focus
*FvwmIconMan*Action Mouse 2 N Bif Next 3, GotoButton 0, Select, Ret, GotoButton Next, Select
*FvwmIconMan*Action Mouse 3 N Bif Prev 3, GotoButton -1, Select, Ret, GotoButton Prev, Select

*FvwmIconMan*1*DontShow icon=FvwmIconMan
*FvwmIconMan*1*DontShow title=coverDialog
*FvwmIconMan*1*DontShow title=*Panel
*FvwmIconMan*1*DontShow title=SoftBench*-*Tool*Manager
*FvwmIconMan*1*DontShow title=xv*controls
*FvwmIconMan*1*DontShow class=XLoad
*FvwmIconMan*1*DontShow title=FrameMaker
*FvwmIconMan*1*DontShow title=FrameMaker*-*
*FvwmIconMan*1*DontShow resource=cCatalog
*FvwmIconMan*1*DontShow resource=pCatalog
*FvwmIconMan*1*DontShow title=FvwmIdent
*FvwmIconMan*1*DontShow title=Visual*Thought*tm*
*FvwmIconMan*1*DontShow title=Inspector
*FvwmIconMan*1*DontShow title=basic.vpalette*
*FvwmIconMan*1*DontShow title=
*FvwmIconMan*1*DontShow title=*NoIconMan*

=====

Plus here's my .xbuffyrc

box Mail/arrivals
title Me
command FvwmCommand "my_mail Mail/arrivals"
box Mail/hp-spam
title HP
command FvwmCommand "my_mail Mail/hp-spam"
box Mail/palmtop
title LX
command FvwmCommand "my_mail Mail/palmtop"
box Mail/fvwm
title FV
command FvwmCommand "my_mail Mail/fvwm"

===

Cheers,
Tim.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].