Subject: Re: FVWM: xpmroot

From: Martin Cartwright <[email-masked]>
Date: Mon, 25 Aug 1997 17:02:11 +0100 (BST)

On Mon, 25 Aug 1997, Charles Hines wrote:

->>>>>> "Martin" == Martin Cartwright <[email-masked]> writes:
->
->Martin> I have a program for my Windows 3.1 machine at home that sets the root
->Martin> window to an image chosen randomly from a preset list. I was just
->Martin> wondering if anyone had thought of adding something like this to
->Martin> xpmroot.
->
->Martin> Just an idea ;)
->
->Actually, XV can do this, I believe.
->
->Chuck
->

Aha yes.. I can't find any xv documentation here you see. Still, half
an hours investigation proves Chuck right. Cheers. 

xv -random -root image1.xpm image2.gif image3.tif image4.jpg ... -quit

for those who are wondering.. I always found xv to be a bit slow
compared to xpmroot tho'.

[email-masked] --- http://star.pst.qub.ac.uk/~imc/vom.htm
-/-------------------------------------------------------------\-
|     	    "As private parts to the Gods are we...		|
|	      they play with us for their sport!"	      	|
-\-------------------------------------------------------------/-

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Adam Kopacz <[email-masked]>
Date: Mon, 25 Aug 1997 20:52:36 +0200

Martin Cartwright wrote:
hi,

> ->Actually, XV can do this, I believe.
[...]

try this cool script. it shows 4 images in 24h .. start it with & in the
background.
ps: morgen = morning / mittag = afternoon / anacht = night ..

---cut---
#! /bin/sh
#
# ROOTIMG anhand der uhrzeit setzen.
# + setting ROOTIMG with the time (sorry my bad english)

APP="/usr/X11R6/bin/xli -onroot -quiet"
MORGEN="/root/Privat/Pictures/backgrounds/wolken_800x600.jpg"
MITTAG="/root/Privat/Pictures/backgrounds/wolken1_800x600.jpg"
NMITTAG="/root/Privat/Pictures/backgrounds/y-clouds_800x600.jpg"
NACHT="/root/Privat/Pictures/backgrounds/daemmerung_800x600.jpg"

j=25

while true
do
  # Hat sich seit der letzten Pruefung die Stunde veraendert?
  if [ $j != `date +%H` ]
  then
    j=`date +%H`
    case `date +%H` in
      0[6-9])           $APP $MORGEN ;;
      1[0-7])           $APP $MITTAG ;;
      1[8-9]|2[0])      $APP $NMITTAG ;;
      2[123]|0[0-5])    $APP $NACHT ;;
    esac
  fi
  # Nur alle 5 Minuten pruefen, um CPU-Zeit zu sparen:
  sleep 300 # + checking every 5 mins (low cpu usage)
done
---cut---

-- 

Bye,                        klospatz's Linux-Place (Babes/Files)
    Adam Kopacz (klospatz)       http://www.rat.de/Adam

---

From: Eric Brandwine <[email-masked]>
Date: Mon, 25 Aug 1997 16:42:14 -0400 (EDT)

Something like this is better done with cron.  Schedule the job when you
log in, unschedule it when you log out.

Then you do not have a sleeping shell script in the process table.

ericb

---

From: Adam Kopacz <[email-masked]>
Date: Tue, 26 Aug 1997 08:51:35 +0200

Eric Brandwine wrote:
hi,

> log in, unschedule it when you log out.
why ?

> Then you do not have a sleeping shell script in the process table.
root       214  0.0  0.4   0   804   276   216   1 S      0:00 sleep 300 

0.4% of 64 MB is ok... :)

--