Subject: FVWM: fvwm2 + enlightenment = ?-)

From: Adam Kopacz <[email-masked]>
Date: Fri, 22 Aug 1997 21:22:24 +0200

Hi,

i'm using fvwm 2.00.45 + all modules from 2.00.46 because i have some
great patches for fvwm2.

i have just tried enlightenment and it looks GREAT! :-)
i love the window_sytles.. but i want to use my FvwmButtons (..) 
is there any patch for fvwm2 that allowes me to use the 'crazy' styles
from enlightenment ????

-- 

Bye,                        klospatz's Linux-Place (Babes/Files)
    Adam Kopacz (klospatz)       http://www.rat.de/Adam

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Anders Lannerback <[email-masked]>
Date: Sat, 23 Aug 1997 14:58:33 +0200

> is there any patch for fvwm2 that allowes me to use the 'crazy' styles

No, it is not possible, because E doesn't support
any modules (yet) :(

---

From: Adam Kopacz <[email-masked]>
Date: Sat, 23 Aug 1997 15:50:04 +0200

Anders Lannerback wrote:
hi,

> No, it is not possible, because E doesn't support

nono :) i don't want to use 'E', i only want the styles for my windows.
like =>

 ~~~~~~~~~\_____/~|
|-----------------|
|                 |
|                 |
|                 |

the windows like in mac/win/os/2 => 
 --
|  |
 --

sucks <g>.. its time for something new i think..

---

From: Eric Brandwine <[email-masked]>
Date: Sat, 23 Aug 1997 16:53:50 -0400 (EDT)

If you really want to have fun with windows, look into DPS.  If you have
Solaris or SGI, or better yet, NeXT, you are set.

Since there is a full PostScript interpreter on board the display server,
anything that you can do in PS you can put on screen, even to animating
the window decorations (Shaped!).  Mostly useless when it comes down to
it.

If you just want the funky decorations, look into ImLib, the image
processing engine that E uses.  It is easy enough to create shaped windows
in X.  It would be easier to add shaped borders to Fvwm than it would be
to fold the two together.

I am sure that if you get a framework going, folks will want to jump in
and help coding.  One big problem you are going to have: Fvwm has only 1
border width, not seperate widths for top/bottom/left/right...  Also, the
positions of reparented client windows are hard coded in many places in
the code.

Also, you are going to have to be able to specify each border seperately,
and turn off the top border.  Corner handles will have to have independent
sizes.

This is not an easy task, and may have to wait for 3.x, but probably well
worth doing.

ericb

On Sat, 23 Aug 1997, Adam Kopacz wrote:

> From [email-masked] Sat Aug 23 14:12:27 1997
> Return-Path: <[email-masked]>
> Received: from mwunix.mitre.org by maestro.mitre.org (4.1/SMI-4.1)
> 	id AB00361; Sat, 23 Aug 97 14:04:36 EDT
> Received: from mbunix.mitre.org (mbunix.mitre.org [129.83.20.100])
> 	by mwunix.mitre.org (8.8.6/8.8.6/mitre.0) with ESMTP id NAA24797
> 	for <[email-masked]>; Sat, 23 Aug 1997 13:50:27 -0400 (EDT)
> Received: from farabi.hpc.uh.edu (farabi.hpc.uh.edu [129.7.102.2])
> 	by mbunix.mitre.org (8.8.6/8.8.6/mitre.0) with ESMTP id NAA16836
> 	for <[email-masked]>; Sat, 23 Aug 1997 13:50:26 -0400 (EDT)
> Received: from sina.hpc.uh.edu (lists@[10.1.1.1]) by farabi.hpc.uh.edu (8.7.3/8.7.3) with ESMTP id MAO09514; Sat, 23 Aug 1997 12:44:23 -0500 (CDT)
> Received: by sina.hpc.uh.edu (TLB v0.09a (1.20 tibbs 1996/10/09 22:03:07)); Sat, 23 Aug 1997 12:46:36 -0500 (CDT)
> Received: from main.zoo-gate.fi (zoo-gate.fi [194.252.183.2]) by sina.hpc.uh.edu (8.7.3/8.7.3) with ESMTP id MAA21435 for <[email-masked]>; Sat, 23 Aug 1997 12:46:28 -0500 (CDT)
> Received: from zoo-gate.fi (zebra.zoo-gate.fi [194.252.183.19])
>           by main.zoo-gate.fi (8.8.4/8.8.4) with ESMTP
> 	  id UAA05280 for <[email-masked]>; Sat, 23 Aug 1997 20:49:45 +0300
> Message-Id: <[email-masked]>
> Date: Sun, 24 Aug 1997 20:47:03 +0300
> From: "Ville P\dtsi" <[email-masked]>
> Organization: -
> X-Mailer: Mozilla 4.02b7 [en] (X11; I; Linux 2.0.30 i586)
> Mime-Version: 1.0
> To: [email-masked]
> Subject: FVWM: Netscape and fvwm2.0.46
> Content-Type: text/plain; charset=iso-8859-1
> Sender: [email-masked]
> Precedence: list
> X-Majordomo: 1.94.1
> Content-Transfer-Encoding: quoted-printable
> X-Mime-Autoconverted: from 8bit to quoted-printable by mwunix.mitre.org id NAA24797
> 
> I dont seem to get Netscape to work with the new version of fvwm. It
> just starts the program half way and stops. PS shows netscape is running
> but it is loaded only half way. I putted 2.0.45 back and it's working
> again.=20
> 
> --=20
> Ville "Drc" P=E4tsi -- [email-masked]
> --