Subject: FVWM: Menu/Popup Errors - Unexplainable

From: Christopher Wolf <[email-masked]>
Date: Thu, 14 Aug 1997 10:12:49 -0500 (CDT)

I have a root menu that I display using Popup on the left mouse
button.  This menu has two bars at the top, then the title, then one
more bar before the menu items.

AddToMenu MainMenu
+       "Main Menu"                             Title
+       "Xterms"                                Popup Xterm-Menu
+       "FVWM Modules"                          Popup Module-Menu
+       "Configure Menu"                        Popup Config-Menu
+       "Quit"                                  Quit

Mouse   1       R       A       Popup    "MainMenu"

------------------
------------------
   Main  Menu
------------------
 Xterms
 FVWM Modules
 Configure Menu
 Quit
------------------

If I pop up the menu, and then move my mouse between the top two bars,
FVWM generates the following message, every time:

[FVWM][executeModule]: <<ERROR>> Execution of module failed: /db/sds/bin/bin5/fvwm45/modules/
Permission denied

This only occurs when the mouse is left between those two bars.  I'm
running FVWM 2.0.45 with the animate window patch and the patch to
rearrange the window list using Focus Follows Mouse in the manner
similar to Click to Focus (so FlipFocus works).

By the way, where can one find all these patches?

-Wolf

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Thu, 14 Aug 1997 14:22:40 -0400 (EDT)

Christopher--

I've underlined the place where your problem is occurring with carets
(^) below.  Try defining the menu using the following:

    AddToMenu MainMenu "Main Menu" Title
    +       "Xterms"                                Popup Xterm-Menu
    +       "FVWM Modules"                          Popup Module-Menu
    +       "Configure Menu"                        Popup Config-Menu
    +       "Quit"                                  Quit

Are you using mwm-style menus?  Sounds like you are.  You should see
the `Main Menu' appearing before the top two bars.

--jim

############### jim knoble ######## [email-masked] #################

On Thu, 14 Aug 1997, Christopher Wolf wrote:

: I have a root menu that I display using Popup on the left mouse
: button.  This menu has two bars at the top, then the title, then one
: more bar before the menu items.
: 
: AddToMenu MainMenu
                     ^^^^^^^^^^^^^^
: +       "Main Menu"                             Title
: +       "Xterms"                                Popup Xterm-Menu
: +       "FVWM Modules"                          Popup Module-Menu
: +       "Configure Menu"                        Popup Config-Menu
: +       "Quit"                                  Quit
: 
: Mouse   1       R       A       Popup    "MainMenu"

  [...]

: If I pop up the menu, and then move my mouse between the top two bars,
: FVWM generates the following message, every time:
: 
: [FVWM][executeModule]: <<ERROR>> Execution of module failed: /db/sds/bin/bin5/fvwm45/modules/
: Permission denied
: 
: This only occurs when the mouse is left between those two bars.

  [...]

: -Wolf

---

From: Christopher Wolf <[email-masked]>
Date: Fri, 15 Aug 1997 13:23:36 -0500 (CDT)

On Thu, 14 Aug 1997 [email-masked] wrote:

#> I've underlined the place where your problem is occurring with carets
#> (^) below.  Try defining the menu using the following:
#> 
#>     AddToMenu MainMenu "Main Menu" Title
#>     +       "FVWM Modules"                          Popup Module-Menu
#>     +       "Quit"                                  Quit
#> 
#> Are you using mwm-style menus?  Sounds like you are.  You should see
#> the `Main Menu' appearing before the top two bars.

Thanks, your suggestion seemed to fix the problem, but it still seems
like this should be caught somewhere rather than generating an error.

#> On Thu, 14 Aug 1997, Christopher Wolf wrote:
#> 
#> : I have a root menu that I display using Popup on the left mouse
#> : button.  This menu has two bars at the top, then the title, then one
#> : more bar before the menu items.
#> : 
#> : AddToMenu MainMenu
#>                      ^^^^^^^^^^^^^^
#> : +       "Main Menu"                             Title
#> : +       "FVWM Modules"                          Popup Module-Menu
#> : +       "Quit"                                  Quit
#> : 
#> : Mouse   1       R       A       Popup    "MainMenu"
#> 
#>   [...]
#> 
#> : If I pop up the menu, and then move my mouse between the top two bars,
#> : FVWM generates the following message, every time:
#> : 
#> : [FVWM][executeModule]: <<ERROR>> Execution of module failed: /db/sds/bin/bin5/fvwm45/modules/
#> : Permission denied
#> : 
#> : This only occurs when the mouse is left between those two bars.