Subject: FVWM: installing...

From: [email-masked] (David Kennedy)
Date: Fri, 22 Aug 1997 14:51:25 +0100

A simple suggestion for those, like me, who compile FVWM
for personal use only. Note that I've no idea about
syntax etc, I'm making a general suggestion.

Could we have a line in the Fvwm.tmpl file like:

#define USER_DIR = /home/dcjk/

Allowing something like 
#ifdef USER_DIR
#define FvwmBinDir $USER_DIR/bin
#define FvwmDir    $USER_DIR/bin/modules
etc
else
normal default setup for system wide installation.

Then I wouldn't have to define the same path over and over...
and I always spell one of them wrongly!
-- 
David Kennedy, Dept. of Pure & Applied Physics, Queen's University of Belfast
Email: [email-masked] | URL: http://star.pst.qub.ac.uk/~dcjk/
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Martin Cartwright <[email-masked]>
Date: Fri, 22 Aug 1997 15:03:06 +0100 (BST)

On Fri, 22 Aug 1997, David Kennedy wrote:

->A simple suggestion for those, like me, who compile FVWM
->for personal use only. Note that I've no idea about
->syntax etc, I'm making a general suggestion.
->
->Could we have a line in the Fvwm.tmpl file like:
->
->#define USER_DIR = /home/dcjk/
->
->Allowing something like 
->#ifdef USER_DIR
->#define FvwmBinDir $USER_DIR/bin
->#define FvwmDir    $USER_DIR/bin/modules
->etc
->else
->normal default setup for system wide installation.
->
->Then I wouldn't have to define the same path over and over...
->and I always spell one of them wrongly!

Sounds like Dave.. 

But seriously folks.. He's got a point. But isn't it planned to switch
to GNU autoconf??? If this is done properly, we can run it with 

configure --prefix /home/imc

and it'll do all that automagically.. 

[email-masked] --- http://star.pst.qub.ac.uk/~imc/vom.htm
-/-------------------------------------------------------------\-
|     	    "As private parts to the Gods are we...		|
|	      they play with us for their sport!"	      	|
-\-------------------------------------------------------------/-