Subject: FVWM: FvwmAudio not working?

From: Stew Benedict <[email-masked]>
Date: Sat, 9 Aug 1997 09:14:24 -0400 (EDT)

I've just upgraded to fvwm2.  Compile went fine.  I used to use FvwmAudio
under fvwm1, but it doesn't seem to be working for me now.  Here's my 
segment under .fvwm2rc:

############################################################################
# FvwmAudio
#
*FvwmAudioPlayCmd /usr/local/bin/play
*FvwmAudioDir /usr/local/lib/sounds
*FvwmAudio startup roadrunner.au
*FvwmAudio shutdown homer-doh-echo.au
#*FvwmAudio unknown cat-1.au
*FvwmAudio destroy_window barney-awww.au
*FvwmAudio iconify homer-wohoo.au
*FvwmAudio deiconify no_prob.au
*FvwmAudio delete_window barney-belch.au
#*FvwmAudio add_window    ??
#*FvwmAudio toggle_paging ??

*FvwmAudioDelay 10

play does work, and the .au files I've listed are in the directory shown.

I also have it enabled under init and restart:

AddToFunc "InitFunction" "I" Module FvwmButtons
#+              "I" Module FvwmPager 0 0
+               "I" Module FvwmAudio
+               "I" Next [!iconic CurrentScreen xterm] Focus
+               "I" CursorMove 30 40

AddToFunc "RestartFunction" "I" Module FvwmButtons
#+              "I" Module FvwmPager 0 0
+               "I" Module FvwmAudio
+               "I" Next [!iconic CurrentScreen xterm] Focus
+               "I" CursorMove 30 40

I've also tried manually running it under FvwmTalk.  So far I get nothing,
no messages in the tty I started X from, nothing in syslog or messages,
and no listing of FvwmAudio under ps.  Any suggestions?

Oh yes, I'm running Linux 2.0.30, kernel sound drivers,  and XFree 3.2.

Thanks!
Stew Benedict

~~ Stew Benedict  ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~    AYS Enterprises ~~
[email-masked]        http://www.geocities.com/SiliconValley/8608
~~~~~~      "It's not just shy sluggin' gorms neemer!"          ~~~~~~

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Adam Kopacz <[email-masked]>
Date: Sun, 10 Aug 1997 12:45:39 +0200

Stew Benedict wrote:
hi,

..
> +               "I" Next [!iconic CurrentScreen xterm] Focus

whats this (2) ???

> Oh yes, I'm running Linux 2.0.30, kernel sound drivers,  and XFree
why ? upgrade to 3.3 (ftp.XFree86.org)

ps: sorry, i can't help you with your audio problem :(

-- 

Bye,                        klospatz's Linux-Place (Babes/Files)
    Adam Kopacz (klospatz)       http://www.rat.de/Adam