Subject: FVWM: clipboard and restarting

From: Linux-Debian Team <[email-masked]>
Date: Sun, 17 Aug 1997 11:15:55 +0200

I have been using fvwm2 for several months; here are some
remarks about its performace. Could they be bugs in window
manager or naively due to inexperience.

- copying to clipboard.
  while highlighting text (that is copying window buffer to the
  clipboard) in xterm, I cannot scroll the window to go beyond
  its borders.

- restarting fvwm2
  windows that have been set sticky, do not preserve
  their status as fvwm has been restarted during the same
  session.

  while windows preserve their page-position within their
  desktop, a window that has been moved to a next desktop
  does not recover the change, after restarting fvwm2.
  At the restart, windows return to the desktop where they
  had been created from.

  Focus is correctly set to the current desktop, yet the
  pointer forgets its last cohordinates before restarting,
  being always placed in the first page.

thank you

Paolo Pumilia

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Richard Lister <[email-masked]>
Date: Mon, 18 Aug 1997 11:00:16 -0400

On Sun, 17 Aug 1997 11:15:55 +0200
Linux-Debian Team <[email-masked]> 
>   clipboard) in xterm, I cannot scroll the window to go beyond

This is nothing to do with the window manager, but is a shortfall
of xterm. Highlight as much as you want from the current page, then
use the scrollbar to scroll down, and use the right mouse button
to click on the position you want the highlight extended to.

>   their status as fvwm has been restarted during the same

This is because the sticky attribute is unknown to the X server ... it
is an artifact of fvwm2. If you want the same windows to always
be sticky you can say
    Style "foo"  Sticky

>   At the restart, windows return to the desktop where they

A window's coordinates are maintained by the X server, so
they are not forgotten when the window manager quits. Desks, however,
are not known to the server. 

Ric

Richard J Lister, Georgetown Institute for Cognitive and Computational Sciences
Georgetown University Medical Center, Washington, DC.
Phone: 202-687 2878
Email: [email-masked] 
Web: http://www.giccs.georgetown.edu/

---

From: [email-masked]
Date: Mon, 18 Aug 97 11:11:36 -0400

> are not known to the server. 

That's funny... all my apps reappear on the correct screen and desktop
every time.  How is fvwm managing that since the server does not know?

I think this could be done for window attributes as well.  If you have to, 
store status in a temporary file.  I think Sun's window manager did/does
that.

Of course, wanting this should be pretty rare except when debugging an
fvwm setup, so you could always just wait till you are done before
worrying about sticky windows.