Subject: FVWM: pager balloons

From: Martin Cartwright <[email-masked]>
Date: Wed, 27 Aug 1997 14:54:40 +0100 (BST)

Hi, 
I just noticed a minor thing about the new balloons.. If you move the
pointer from another window straight onto a window in the pager and
the balloons get hidden under the pager. I use SloppyFocus for most
windows so I guess this could be something to do with it...

[email-masked] --- http://star.pst.qub.ac.uk/~imc/vom.htm
-/-------------------------------------------------------------\-
|     	    "As private parts to the Gods are we...		|
|	      they play with us for their sport!"	      	|
-\-------------------------------------------------------------/-

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Richard Lister <[email-masked]>
Date: Wed, 27 Aug 1997 12:37:42 -0400

On Wed, 27 Aug 1997 14:54:40 +0100 (BST)
Martin Cartwright <[email-masked]> 
> windows so I guess this could be something to do with it...

I tried to recreate this, but can't. I doubt that it's a focus issue: I use
SloppyFocus myself, but anyway, the balloons should be completely ignored
by the window manager.

I tried playing around with StaysOnTop, but that made no difference. Can you
send me the relevant bits of config, and system info.

Ric

Richard J Lister, Georgetown Institute for Cognitive and Computational Sciences
Georgetown University Medical Center, Washington, DC.
Phone: 202-687 2878
Email: [email-masked] 
Web: http://www.giccs.georgetown.edu/

---

From: Martin Cartwright <[email-masked]>
Date: Thu, 28 Aug 1997 09:39:38 +0100 (BST)

On Wed, 27 Aug 1997, Richard Lister wrote:

->
->I tried playing around with StaysOnTop, but that made no difference. Can you
->send me the relevant bits of config, and system info.
->
->Ric

Sure, I've attached my entire .fvwmrc. I was chatting to another user
here and he suggested it could be due to AutoRaise being on. But if as
you say they shoud be ignored by FVWM then that doesn't make sense
either.

I'm running fvwm 2.0.46 on a Sparc Ultra 1 with Solaris 2.5. As far as
I know we've only got X11R5 here...

[email-masked] --- http://star.pst.qub.ac.uk/~imc/vom.htm
-/-------------------------------------------------------------\-
|     	    "Alright! Let battle commence! Wine and ... 	|
|	     bananas! Bring on the dancing girls!"      	|
-\-------------------------------------------------------------/-

#FVWM Config file

ModulePath /home/imc/bin/
PixmapPath /home/imc/icons/
IconPath   /home/imc/icons/

# Set-up buttons for titlebars.
#ButtonStyle    All ActiveDown VGradient 8 2 #330866 50 #8822aa 50 #330866
#ButtonStyle    All Inactive   VGradient 8 2 #8822aa 50 #330866 50 #8822aa

# Lightning Strike
#ButtonStyle 1 8  35x15@1 20x50@1 40x50@0 30x80@1 75x40@0 50x40@1 75x15@0 35x15@1
# multiple-stacked window
#ButtonStyle 3 16 60x40@1 60x80@0 15x80@0 15x40@1 60x40@1 40x40@1 40x25@1 75x25@1 75x60@0 60x60@0 75x60@0 75x40@0 85x40@0 85x15@0 60x15@1 60x25@1
# a / arrow button
#ButtonStyle 5 11 80x15@1 45x15@1 55x25@1 25x55@1 15x45@1 15x80@1 50x80@0 40x70@0 70x40@0 80x50@0 80x15@0

ButtonStyle 1 MiniIcon
ButtonStyle 3 Pixmap dnt_mico.xpm
ButtonStyle 5 Pixmap upt_mico.xpm
ButtonStyle 7 Pixmap box_mico.xpm

BorderStyle -- HiddenHandles NoInset
WindowFont	-b&h-lucida-bold-r-normal-*-*-180-*-*-p-*-iso8859-*
IconFont	-b&h-lucida-bold-r-normal-*-*-140-*-*-p-*-iso8859-*

TitleStyle   LeftJustified Height 25 -- Flat
AddTitleStyle   ActiveUp   VGradient 5 black blue4 
AddTitleStyle   ActiveDown   VGradient 5 black blue4 
AddTitleStyle   Inactive   VGradient 5 blue4 black 

ButtonStyle    All -- UseTitleStyle Flat

DeskTopSize 	8x1
ClickTime 	750
OpaqueMoveSize 	1
EdgeResistance 	300 10
EdgeScroll 	100 100
XORValue 	1

#		fg     bg        null    font
MenuStyle 	white grey15  grey20 -b&h-lucida-bold-r-normal-*-*-140-*-*-p-*-iso8859-* mwm
# active window colours   fg      bg
HilightColor 		white   blue3

############################## Styles ####################
#general styles
#				fg    bg
Style "*"           	Color white/blue4
Style "*"           	BorderWidth 5, HandleWidth 5
Style "*"            	StickyIcon, UsePPosition 
Style "*"           	RandomPlacement, SmartPlacement
Style "*"           	MWMFunctions,MWMDecor,HintOverride
Style "*"          	DecorateTransient, IconBox +0 +66 +1072 +200
Style "*"           	Icon ques_ico.xpm, SloppyFocus, MiniIcon tor_mico.xpm

#styles for FVWM modules, popups etc..
Style "Fvwm*"	   	NoButton 3, NoButton 5, NoButton 7, MiniIcon f_mico.xpm 
Style "Fvwm*"		NoHandles, BorderWidth 3, HandleWidth 3
Style "Fvwm*" 		Icon fvwm_ico.xpm, Sticky, Color white/#000055
Style "Fvwm*"	   	CirculateSkipIcon, UseDecor sticky, WindowListSkip
Style "FvwmButtons"	NoTitle, Sticky, NoHandles
Style "FvwmButtons"	BorderWidth 0, CirculateSkip
Style "Bar"	NoTitle, Sticky, NoHandles
Style "Bar"	BorderWidth 0, CirculateSkip
Style "FvwmWharf"	NoTitle, Sticky, NoHandles
Style "FvwmWharf"	BorderWidth 0, CirculateSkip

#other styles
Style "asclock"		UseDecor sticky, NoHandles, NoButton 5, NoButton 7
Style "asmail"		NoTitle, Sticky, UseDecor sticky, NoHandles
Style "Confirm"        	StaysOnTop, UseDecor sticky, NoHandles
Style "editss"		NoButton 1, NoButton 5
Style "Error"	       	StaysOnTop, UseDecor sticky, NoHandles
Style "File"	       	NoTitle
Style "File Manager"   	StickyIcon
Style "GWM*"		ClickToFocus, NoButton 5
Style "gwm*"		ClickToFocus, NoButton 5
Style "IBM*"		Sticky, UseDecor sticky, NoHandles
Style "IRAF"		SlipperyIcon
Style "*Helper"		SlipperyIcon
Style "mailtool"	NoButton 3, NoButton 5, NoIconTitle, SlipperyIcon
Style "Netscape"       	SkipMapping, SlipperyIcon, Icon net_but.xpm, MiniIcon net_mico.xpm
Style "perfmeter"	Sticky, UseDecor sticky, BorderWidth 3, HandleWidth 3
Style "Pine"		SlipperyIcon, Color white/red4
Style "Pine"		NoButton 1, NoButton 5, NoButton 7
Style "QuitVerify"  	NoHandles, StaysOnTop, UseDecor sticky  
Style "QuitVerify"  	NoButton 1, NoButton 3, NoButton 5, NoButton 7, BorderWidth 3, HandleWidth 3
Style "Rlogin"  	NoHandles, BorderWidth 5, UseDecor sticky
Style "Rlogin"  	NoButton 1, NoButton 3, NoButton 5, NoButton 7, BorderWidth 3, HandleWidth 3
Style "Tk*"		NoButton 1, NoButton 5, NoButton 7
Style "xbiff*"	       	NoTitle, Sticky, WindowListSkip, BorderWidth 3, HandleWidth 3
Style "xbiff*"		BorderWidth 5, SkipMapping, CirculateSkip, UseDecor sticky
Style "XBlast"		NoButton 1, NoButton 5, NoButton 7
Style "XCal"		NoTitle, UseDecor sticky
Style "xconsole"	Sticky, UseDecor sticky
Style "xephem Object Prompt" StaysOnTop
Style "xeyes" 		NoButton 3, NoButton 5, NoButton 7, Sticky, BorderWidth 3, HandleWidth 3
Style "xeyes"		WindowListSkip, UseDecor sticky 
Style "XFaces"          Sticky, WindowListSkip, UseDecor sticky
Style "XFaces"          NoButton 1, NoButton 3, NoButton 5, NoButton 7, NoTitle, BorderWidth 5 
Style "xgterm"          MWMButtons, UseDecor terms, Color white/red4
Style "XImtool"		SlipperyIcon
Style "XMapEdit"	NoButton 1, NoButton 5
Style "xmessage"	StaysOnTop
Style "XPilot"		NoButton 1, 
Style "XPostit" 	Sticky, UseDecor sticky, BorderWidth 3, HandleWidth 3
Style "XPostit" 	NoButton 3, NoButton 5, NoButton 7
Style "*XScreenSaver*"  NoButton 3, NoButton 5, NoButton 7
Style "XTerm"		BorderWidth 3, HandleWidth 3
Style "XTerm"	        Icon term_ico.xpm,  MWMButtons, UseDecor terms, Color white/red4     
Style "xticktalk" 	Sticky, UseDecor sticky
	       
############   Decor statements  #################
AddToDecor sticky
+ ButtonStyle 1 MiniIcon
+ ButtonStyle 3 Pixmap dnt_mico.xpm
+ ButtonStyle 5 Pixmap upt_mico.xpm
+ ButtonStyle 7 Pixmap box_mico.xpm
+ BorderStyle   -- HiddenHandles NoInset
+ ButtonStyle	All -- UseTitleStyle Flat
+ HilightColor 	white blue4
+ WindowFont 	-b&h-lucida-bold-r-normal-*-*-180-*-*-p-*-iso8859-*
+ TitleStyle 	Height 25 -- Flat
+ AddTitleStyle VGradient 5 blue4 black  

AddToDecor terms
+ ButtonStyle 1 MiniIcon
+ ButtonStyle 3 Pixmap dnt_mico.xpm
+ ButtonStyle 5 Pixmap upt_mico.xpm
+ ButtonStyle 7 Pixmap box_mico.xpm
+ BorderStyle    -- HiddenHandles NoInset
+ ButtonStyle  All -- UseTitleStyle Flat
+ HilightColor 	 white red3
+ WindowFont 	 -b&h-lucida-bold-r-normal-*-*-180-*-*-p-*-iso8859-*
+ TitleStyle  	 Height 25 -- Flat
+ AddTitleStyle  ActiveUp VGradient 7 black red4
+ AddTitleStyle  ActiveDown VGradient 7 black red4
+ AddTitleStyle  Inactive VGradient 7 red4 black

#   Get icons from file 
Read /home/imc/.fvwmicons
	
#Setup key shortcuts
#Bind desktop pages to F-keys..
Key F1		RTSF	A	GotoPage 0 0
Key F2 		RTSF	A	GotoPage 1 0
Key F3 		RTSF	A	GotoPage 2 0
Key F4 		RTSF	A	GotoPage 3 0
Key F5 		RTSF	A	GotoPage 4 0
Key F6  	RTSF	A	GotoPage 5 0
Key F7 		RTSF	A	GotoPage 6 0
Key F8 		RTSF	A	GotoPage 7 0
#Key F9 		RTSF	A	GotoPage 8 0
#Key F10 	RTSF	A	GotoPage 9 0
#make use of that bunch of keys to the left of the keyboard...
Key Help	A	A	LockScreen random
Key F11		A	A	Warp Pine
Key F12		A	A	WindowList
Key F13		A	A	Prev [CurrentDesk] Focus
Key F14		A	A	Next [CurrentDesk] Focus
Key F15		A	A	Iconify
Key F16		A	A	Maximize 100 100
Key F17		A       A	Raise
Key F18		A	A	Lower
Key F19		A	A	Stick
Key F20		A	A	Module FvwmIdent
Key F21		A	A	Menu Utilities Nop
Key F22		W	A	PrintFunction
#enable desktop scrolling with ALT+left&right
Key Left	A	M	Scroll -100000 0
Key Left	A	M3	Scroll -100000 0
Key Right	A	M	Scroll +100000 0
Key Right	A	M3	Scroll +100000 0
#alt q to close
Key q		A	M	Close
Key q		A	M3	Close
#alt w to iconify
#Key w		A	M	Iconify 
#Key w		A	M3	Iconify
#mouse button definitions
Mouse 1	R   	A      	Menu Utilities Nop
Mouse 2	R    	A       Menu Window-Ops Nop
Mouse 3	R    	A      	WindowList
Mouse 0	1    	A      	Menu Window-Ops2 Close
Mouse 0	3   	A     	Iconify
Mouse 0	5    	A     	Maximize 100 100
Mouse 0 7 	A	WindowShade
Mouse 1	FS	A	Resize-or-Raise
Mouse 1	I	A	Iconify
Mouse 1 T       A       Move
Mouse 2	FTS	A	Lower
Mouse 3	IT	A	Stick

########################Initialization Functions ############################
# what to do on startup
AddToFunc InitFunction  "I" Module FvwmAuto 100
+		        "I" Module FvwmButtons StatusBar 
+			"I" Module FvwmWharf
+		        "I" exec /home/imc/bin/rxvt -pixmap /home/imc/nwrm/pics/pixmaps/scream.xpm -scale T -display $DISPLAY -title "$HOST : ArghTerm" -n Aargh -geometry 80x45+560+260 & 
+		        "I" exec /home/imc/bin/rxvt -pixmap /home/imc/nwrm/pics/pixmaps/Elite.xpm -scale T -T "Pine" -geometry 95x40+5+170 -ls -n Pine -e pine -i & 
+		        "I" exec /home/imc/bin/xfaces -geometry 70x700-0+64 & 
+			"I" Module FvwmAudio
+		        "I" exec /home/imc/bin/xscreensaver & 
#+			"I" exec xsetroot -solid black
+		        "I" exec xv -random -root -quit /scratch/imc/nwrm/pics/root/*.*

#what to do on restart
AddToFunc RestartFunction "I" Module FvwmAuto 100
+			  "I" Module FvwmAudio
+			  "I" Module FvwmButtons StatusBar 
+			  "I" Module FvwmWharf
+		          "I" exec xv -random -root -quit /scratch/imc/nwrm/pics/root/*.*

########################Menus ########################################
AddToMenu Utilities	"Utilities"*f_mico.xpm* 		Title 	
+                       "&Apps ................."%sph_mico.xpm% Popup  Apps
+			"&Remote ............"%sph_mico.xpm%  	Popup  Remote
+			"&Modules .........."%sph_mico.xpm%	Popup  Module-Popup
+			""					Nop
+			"&Games .............."%smi_mico.xpm%	Popup Games
+			"&Lock Screen ..."%loc_mico.xpm%	Popup ScreenLock
+			""					Nop
+			"Re&Start"				Restart
+			"E&xit Fvwm"%skull.xpm% 		Module FvwmForm QuitVerify	

AddToMenu Apps		"Applications"*f_mico.xpm* 	Title 	
+               	"&Calculator"%cal_mico.xpm%	Exec xcalc -geometry 235x250+100+160 &
+			"&File Manager"			Exec $OPENWINHOME/bin/xview/filemgr -scale small -iconic &
+			"&Knews"%nws_mico.xpm%		Exec /usr/openwin/bin/xview/knews -fn fixed  -geometry 650x600+160+0 &
+               	"&Mailtool"%ltr_mico.xpm%	Exec $OPENWINHOME/bin/xview/mailtool -scale small -iconic -geometry +50+170 &
+			"&NEdit"			Exec /home/imc/bin/nedit -geometry +450+130 &
+			"&Pine"				Exec /home/imc/bin/rxvt -pixmap /home/imc/nwrm/pics/pixmaps/Elite.xpm -T "Pine" -scale T -geometry 95x40+5+170 -ls -n Pine -e /usr/local/bin/pine -i &
+			"&Textedit"%txt_mico.xpm%	Exec /usr/openwin/bin/xview/textedit -scale small &
+			"X&Ephem"			Exec /usr/local/bin/xephem &
+               	"XPaint"%pai_mico.xpm%		Exec /home/imc/bin/xpaint &
+			"&XTerm"%x_mico.xpm%		Popup Terms

AddToMenu Remote	"Remote"*telnet.xpm*  		Title
+			"&APM "%ter_mico.xpm%		Exec /usr/lib/X11/xterm -title "Telnet : APM" -geometry 90x42+70+150 -n APM -e telnet 131.111.68.56 &
+			"&CFAPS "%ter_mico.xpm%		Exec /usr/lib/X11/xterm -title "Telnet : CFAPS" -geometry 90x42+90+160 -n CFAPS -e telnet cfaps1.harvard.edu &
+			"&BIDS "%ter_mico.xpm%		Exec /usr/lib/X11/xterm -title "Telnet : BIDS" -geometry 90x42+110+170 -n BIDS -e telnet bids &
+			"&Library "%ter_mico.xpm%	Exec /usr/lib/X11/xterm -title "Telnet : Library" -geometry 75x25+50+180 -n Library -e telnet lib.qub &
+			"&Netscape "%net_mico.xpm%	StartNetscape
+                       ""              Nop
+                       "&Rlogin..."%x_mico.xpm%        Module FvwmForm Rlogin

AddToMenu Module-Popup	"Modules"*f_mico.xpm* 		Title	
+			"&Bar"%bal_mico.xpm%		Module  FvwmButtons StatusBar 
+			"Ca&scade"%bal_mico.xpm%	Module  FvwmCascade -incx 10p -incy 10p 320p 140p
+			"&Identify"%bal_mico.xpm%	Module  FvwmIdent 
+			"&Pager"%bal_mico.xpm%		Module  FvwmPager 0 0
+			"&Talk"%bal_mico.xpm%  		Module	FvwmTalk 
+			"TaskBar"%bal_mico.xpm%		Module  FvwmTaskBar
+			"&Wharf"%bal_mico.xpm%		Module  FvwmWharf
+			"WinList"%bal_mico.xpm%		Module  FvwmWinList

AddToMenu ExitRestart	"Exit?"*exit_but.xpm* 		Title
+			"E&XIT"%skull.xpm%		Quit
+			"&Restart"			Restart

AddToMenu Window-Ops	"Window Operations"*f_mico.xpm* Title		
+                       ""              		Nop
+			"Move"%mov_mico.xpm%		Move-or-Raise2
+			"Resize"%res_mico.xpm%		Resize-or-Raise2
+			"Raise"%rai_mico.xpm%		Raise
+			"Lower"%low_mico.xpm%		Lower 
+		 	"Iconify"%ify_mico.xpm%		Iconify
+			"Shade-ify"%sha_mico.xpm%	WindowShade
+			"(Un)Stick"%sti_mico.xpm%	Stick		
+			"Maximize/Reduce"%max_mico.xpm%	Maximize 100 100
+			"Identify"%qu_mico.xpm%		Module FvwmIdent
+			"Print"%printer2_small.xpm%	PrintFunction
+			""				Nop  	 
+			"Close"				Close	 
+			"Kill (!)"%skull.xpm%		Destroy
+			""				Nop		
+			"Refresh Screen" 		Refresh
+			"Recapture Windows"		Recapture		

AddToMenu Window-Ops2	"Move"%mov_mico.xpm%		Move-or-Raise
+			"Resize"%res_mico.xpm%		Resize-or-Raise
+			"Raise"%rai_mico.xpm%		Raise   	
+			"Lower"%low_mico.xpm%		Lower   	
+			"Stick"%sti_mico.xpm%		Stick
+			""				Nop     	
+			"Close"				Close	  	
+			"Kill (!)"%skull.xpm%		Destroy 	
+			""				Nop 		
+			"Print"%printer2_small.xpm% 	PrintFunction

AddToMenu Terms		"Xterm Type Stuff"*term_ico.xpm* 	Title
+			"&XTerm"%x_mico.xpm%		Exec /usr/lib/X11/xterm -ls -display $DISPLAY -T "$HOST : The Square Window" -geometry 80x32 &
+			"X&GTerm"%x_mico.xpm%		Exec /usr/local/bin/xgterm -ls -T "$HOST : XGTerm" -n XGTerm -fn fixed -geometry 80x32+200+200 &	
+			""*rxvt_but.xpm* 		Nop
+			"&RXVT"%x_mico.xpm%		Exec /home/imc/bin/rxvt -title "$HOST : RXVT" -n RXVT -geometry 80x30 &
+			"&ABCTerm"%x_mico.xpm%		Exec /home/imc/bin/rxvt -pixmap /home/imc/nwrm/pics/pixmaps/joe01.xpm -scale T -title "$HOST : ABCTerm" -n ABC -geometry 80x30 &
+			"&QTerm"%x_mico.xpm%		Exec /home/imc/bin/rxvt -pixmap /home/imc/nwrm/pics/pixmaps/qdigi.xpm -scale T -title "$HOST : QuakeTerm" -n QTerm -geometry 80x45 &
+			"&AlienTerm"%x_mico.xpm%	Exec /home/imc/bin/rxvt -pixmap /home/imc/nwrm/pics/pixmaps/alien01.xpm -scale T -title "$HOST : AlienTerm" -n AlienTerm -geometry 80x25 &
+			"D&MTerm"%x_mico.xpm%		Exec /home/imc/bin/rxvt -pixmap /home/imc/nwrm/pics/pixmaps/dmlogo.xpm -scale T -title "$HOST : DMTerm" -n DM -geometry 80x32 &
+			"&DeadTerm"%x_mico.xpm%		Exec /home/imc/bin/rxvt -pixmap /home/imc/nwrm/pics/pixmaps/dead01.xpm -scale T -title "$HOST : DeadTerm" -n Deadlock -geometry 80x32 &
+			"&EliteTerm"%x_mico.xpm%	Exec /home/imc/bin/rxvt -pixmap /home/imc/nwrm/pics/pixmaps/Elite.xpm -scale T -title "$HOST : EliteTerm" -n EliteTerm -geometry 80x32 &
+			"&TestTerm"%x_mico.xpm%		Exec /home/imc/bin/rxvt -pixmap /home/imc/nwrm/pics/pixmaps/tcf.xpm -scale T -title "$HOST : TestTerm" -n TestTerm -geometry 80x32 &
+			"&StarTerm"%x_mico.xpm%		Exec /home/imc/bin/rxvt -title "star : ABCTerm" -n "star:ABC" -geometry 80x30 -e rlogin star&

AddToMenu Games		"Games 'n' stuff.."*xbla_but.xpm* 	Title
+			"XAsteroids"%smi_mico.xpm%		Exec /home/imc/bin/xast.exe &
+			"XBattle"%cnq_mico.xpm%			Exec /home/imc/scripts/xbattle_start &
+			"XBill"%smi_mico.xpm%			Exec /home/imc/bin/xbill &
+			"X&Blast"%smi_mico.xpm%			Exec /home/imc/bin/rxvt -pixmap /home/imc/icons/xbla_but_dim.xpm -scale T -title "$HOST : XBlast" -n XBlastRunner -e /home/imc/bin/xblast &
+			"XChess"%smi_mico.xpm%			Exec /home/imc/scripts/chess_start &
+			"XChomp"%smi_mico.xpm%			Exec /home/imc/bin/xchomp &
+			"XConq"%cnq_mico.xpm%			Exec /home/imc/scripts/xconq_st &
+			"XMinesweeper"%smi_mico.xpm%		Exec /home/imc/bin/xdemineur -ouvre &
+			"XMr.Is"%smi_mico.xpm%			Exec /home/imc/bin/xmris &
+			"X&Pilot"%smi_mico.xpm%			Exec /home/imc/bin/xpilot -join &
+			"X&Scrabble"%smi_mico.xpm%		Exec /home/imc/bin/xscrabble &
+			"Rocks'N'Diamonds"%smi_mico.xpm%	Exec /home/imc/scripts/rnd_start &
+			""			Nop
+			"&Tetris"%smi_mico.xpm%			Popup Tetris
+			""			Nop
+			"XSwarm"%smi_mico.xpm%			Exec /home/imc/bin/xswarm &
+			"XRoach"%smi_mico.xpm%			Exec /home/imc/bin/xroach &
+			"XRipple"%smi_mico.xpm%			Exec /home/imc/bin/xripple &

AddToMenu Tetris	"Tetris Games"*tet_ico.xpm* 		Title
+			"Te&tris"%smi_mico.xpm%			Exec /home/imc/bin/tetris &
+			"Te&rtris"%smi_mico.xpm%		Exec /home/imc/bin/tertris &
+			"He&xtris"%smi_mico.xpm%		Exec /home/imc/bin/hextris &
+			"We&lltris"%smi_mico.xpm%		Exec /home/imc/bin/welltris &
+			"&3D Tetris"%smi_mico.xpm%		Exec /home/imc/bin/bl &

#   Get extensive screenlock/savers from file 
# Read /home/imc/.fvwmssmenu

AddToMenu ScreenLock 	"Lock Screen"*lock_but.xpm* 	Title
+ 			"&Blank"%loc_mico.xpm%		LockScreen blank
+		 	"&Random"%loc_mico.xpm%		LockScreen random
+			"&ScreenSaver"%bal_mico.xpm%	Exec /home/imc/bin/xscreensaver &

#######################Functions ########################################
AddToFunc Move-or-Raise		"I" Raise
+				"M" Move
+  				"D" Lower

AddToFunc Warp       "I" Next [$0] Iconify -1
+                    "I" Next [$0] Focus

AddToFunc Move-or-Raise2	"M" Raise
+				"M" Move
+  				"D" Lower

AddToFunc Resize-or-Raise	"I" Raise
+				"M" Resize
+				"D" Lower

AddToFunc Resize-or-Raise2	"M" Raise
+				"M" Resize
+				"D" Lower

AddToFunc PrintFunction	 	"I" Raise
+				"I" Exec xdpr -id $w

AddToFunc Iconify-and-Raise	"I" Iconify
+				"I" Raise

AddToFunc Raise-Lower		"I" Lower
+				"D" Raise

#start netscape on last page.
AddToFunc StartNetscape	 	"I" Desk 0 0
+				"I" GotoPage 7 0
+				"I" exec /usr/local/bin/netscape -install -geometry 705x705+340-0 &

#only works properly without going through .xsession don't know why.. 
#have changed it to just start up windows. type cl yourself 
AddToFunc StartIRAF		"I" Desk 0 0
+				"I" exec /usr/local/bin/xgterm -ls -title IRAF -n IRAF -fn fixed -geometry 90x42+550+300 -sb -sl 2000  & # -e /home/imc/scripts/iraf_startup
+				"I" exec /home/imc/bin/rxvt -title "$HOST : IRAF Helper" -n "IRAF Helper" -geometry 80x40+50+150 &
+				"I" exec /usr/local/bin/ximtool &

AddToFunc StartXconq		"I" Desk 0 0
+				"I" exec /home/imc/scripts/xconq_st &

AddToFunc StartTex		"I" Desk 0 0
+				"I" exec /home/imc/scripts/tex_stuff &

AddToFunc QueueCheck		"I" exec lpq -P ps_sun2 > /dev/console

AddToFunc LockScreen		"I" exec /home/imc/bin/xscreensaver-command -exit 
+				"I" exec /home/imc/bin/xlock -remote -mode $0 

#Module properties
#
########################### Audio ############################
*FvwmAudioPlayCmd /usr/bin/audioplay -v 35
*FvwmAudioDir /home/imc/nwrm/sound
*FvwmAudio shutdown sub_dive_horn.au
*FvwmAudio destroy_window squish.au
#*FvwmAudio startup CavalryCall.au

############StatusBar setup  #######
#FvwmButtons purely for swallowed apps

*StatusBarFore black
*StatusBarBack grey15
*StatusBarFont -adobe-times-medium-i-normal--14-140-75-75-p-73-iso8859-1
*StatusBarGeometry 768x64-0+0
*StatusBarRows 2
*StatusBar(15x2, Frame 2, Container(Rows 8))
*StatusBar(7x4, Frame  0, Swallow(UseOld) "perfmeter"  	`Exec /usr/openwin/bin/xview/perfmeter -bg grey15 -fg grey80  &`)
*StatusBar(8x1, Frame  0, Padding 2 2, Swallow(UseOld) "xpostit"  `Exec /home/imc/bin/xpostit &`)
*StatusBar(8x7, Frame  0, Swallow(UseOld) "xconsole"  	`Exec /usr/openwin/bin/xview/xconsole -fn 5x8 -verbose  -fg white -bg grey15 &`)
*StatusBar(7x4, Frame  0, Swallow "FvwmPager" "FvwmPager 0 0")
*StatusBar(End)

########################## Window-Identifier ###############################
# Just choose colors and a fonts
*FvwmIdentBack  blue4
*FvwmIdentFore  white
*FvwmIdentFont  -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*

########################### Pager #########################################
*FvwmPagerBack 	 grey15
*FvwmPagerFore 	 black
*FvwmPagerFont 	 none
*FvwmPagerHilight	 grey50
*FvwmPagerGeometry	 -0-0
#name for desktop - insert comedy phrase here...
#*FvwmPagerLabel	 0	 I like to expand my horizons
*FvwmPagerSmallFont	 5x8
#if Geometry specified next line unnecessary
*FvwmPagerDeskTopScale	 20
#patched stuff to give ToolTips-like popups...
*FvwmPagerBalloons 
#if fore and back not specified it uses the window colour set by Color fg/bg
#*FvwmPagerBalloonBack blue4
#*FvwmPagerBalloonFore white
*FvwmPagerBalloonFont -sun-serif-medium-r-normal-serif-10-100-72-72-m-70-iso8859-1

##########################FvwmWinList##################################
*FvwmWinListBack	 blue4
*FvwmWinListFore	 white
*FvwmWinListFont	 -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmWinListAction	 Click1 Iconify -1, Focus
*FvwmWinListAction	 Click2 Iconify
*FvwmWinListAction	 Click3 Module "FvwmIdent" FvwmIdent
*FvwmWinListUseSkipList
*FvwmWinListGeometry	 -0-0

#Fvwm scroll bar stuff.. not likely used...
*FvwmScrollBack grey40
*FvwmScrollFore grey10

# FvwmForm logout confirmation popup
*QuitVerifyGrabServer
*QuitVerifyWarpPointer
*QuitVerifyFont          -adobe-times-bold-r-normal-*-*-240-*-*-p-*-iso8859-*
*QuitVerifyButtonFont    -adobe-times-bold-r-normal-*-*-240-*-*-p-*-iso8859-*
*QuitVerifyFore     white
*QuitVerifyBack     #000084
*QuitVerifyItemFore white
*QuitVerifyItemBack #0000d2
# begin items
*QuitVerifyLine     center
*QuitVerifyText     "This will end your FVWM session."
*QuitVerifyLine     expand
*QuitVerifyButton   quit      "OK"  ^M
*QuitVerifyCommand  Quit
*QuitVerifyButton   quit      "Cancel"  ^[
*QuitVerifyCommand  Nop
 
# FvwmForm Remote Login PopUp

*RloginWarpPointer
*RloginFont	    -adobe-times-bold-r-normal-*-*-240-*-*-p-*-iso8859-*
*RloginButtonFont   -adobe-times-bold-r-normal-*-*-240-*-*-p-*-iso8859-*
*RloginInputFont    -adobe-courier-medium-r-normal--14-100-100-100-m-90-iso8859-1
*RloginFore	    white
*RloginBack	    #000084
*RloginItemFore     white
*RloginItemBack     #0000d2
# begin items
*RloginLine	    center
*RloginText	    "Login to Remote Host"
*RloginLine	    center
*RloginText	    "Host:"
*RloginInput	    HostName  20   ""
*RloginLine	    center
*RloginLine	    expand
*RloginButton	    quit "Login"	^M
*RloginCommand      exec   rsh $(HostName) /usr/lib/X11/xterm -ls -sb -sl 2000 -T $(HostName):Xterm -display $HOSTDISPLAY &
*RloginButton	    restart   "Clear"
*RloginButton	    quit "Cancel"  ^[
*RloginCommand      Nop

#Wharf test
# Animate Wharf's folders
*FvwmWharfAnimate
*FvwmWharfAnimateMain
*FvwmWharfGeometry      +0+0
*FvwmWharfRows       	1
*FvwmWharfTextureType   1
#*FvwmWharfPixmap 	/home/imc/icons/backdrops/grey5mrb.xpm
*FvwmWharfMaxColors     10
*FvwmWharfBgColor       grey25
*FvwmWharfTextureColor  grey50 black
#put in folders and stuff
*FvwmWharf FVWM 	fvwm_ico.xpm	Folder
*FvwmWharf Shutdown  	exit_but.xpm  	Module FvwmForm QuitVerify
*FvwmWharf restart	recy_but.xpm	Restart
*FvwmWharf xlock 	lock_but.xpm 	LockScreen random
*Fvwmwharf cascade	cas_but.xpm	Module FvwmCascade -incx 10p -incy 10p 320p 140p
*FvwmWharf bar		butt_ico.xpm	Module FvwmButtons StatusBar 
#*FvwmWharf talk 	talk_but.xpm	Module	FvwmTalk
#*FvwmWharf closewharf	cls_but.xpm	KillModule FvwmWharf
*FvwmWharf queue	prn_but.xpm	QueueCheck
*FvwmWharf ~Folders
*FvwmWharf Terms 	term_ico.xpm	Folder
*FvwmWharf DeadTerm 	dead_ico.xpm	Exec rxvt -pixmap /home/imc/nwrm/pics/pixmaps/dead01.xpm -scale T -title "$HOST : DeadTerm" -n Deadlock -geometry 80x32 &   
*FvwmWharf QuakeTerm 	q_ico.xpm	Exec rxvt -pixmap /home/imc/nwrm/pics/pixmaps/qdigi.xpm -scale T -title "$HOST : QuakeTerm" -n QTerm -geometry 80x45 &      
*FvwmWharf ABCTerm 	kchk_ico.xpm 	Exec rxvt -pixmap /home/imc/nwrm/pics/pixmaps/joe01.xpm -scale T -title "$HOST : ABCTerm" -n ABC -geometry 80x30 &	    
*FvwmWharf Star 	rlog_but.xpm 	Exec rxvt -title "$HOST : star" -n "star" -geometry 80x30 -e rlogin star&
*FvwmWharf RXVT 	rxvt_but.xpm 	Exec rxvt -title "$HOST : RXVT" -n RXVT -geometry 80x30 &								    
*FvwmWharf XGTerm	xg_but.xpm	Exec xgterm -ls -T "$HOST : XGTerm" -n XGTerm -fn fixed -geometry 80x32+200+200 &
*FvwmWharf Xterm	x_but.xpm    	Exec xterm -ls -display $DISPLAY -T "$HOST : The Square Window" -geometry 80x32 &
*FvwmWharf ~Folders
*FvwmWharf PxTerms 	term_ico.xpm	Folder
*FvwmWharf SmaugTerm 	fire_ico.xpm 	Exec rxvt -pixmap /home/imc/nwrm/pics/pixmaps/smaug.xpm -scale T -title "$HOST : SmaugTerm" -n SmaugTerm -geometry 80x25 &	    
*FvwmWharf ShelobTerm 	sam_ico.xpm 	Exec rxvt -pixmap /home/imc/nwrm/pics/pixmaps/shelobx.xpm -scale T -title "$HOST : ShelobTerm" -n ShelobTerm -geometry 80x25 &	    
*FvwmWharf CliffTerm 	clf_ico.xpm 	Exec rxvt -pixmap /home/imc/nwrm/pics/pixmaps/cliff.xpm -scale T -title "$HOST : CliffTerm" -n CliffTerm -geometry 80x25 &	    
*FvwmWharf FordTerm 	hrd_ico.xpm 	Exec rxvt -pixmap /home/imc/nwrm/pics/pixmaps/fordx.xpm -scale T -title "$HOST : FordTerm" -n FordTerm -geometry 80x25 &	    
*FvwmWharf MinasTerm 	gan_ico.xpm 	Exec rxvt -pixmap /home/imc/nwrm/pics/pixmaps/tirdawn.xpm -scale T -title "$HOST : MinasTerm" -n MinasTerm -geometry 80x25 &	    
#*FvwmWharf DMTerm 	dm_but.xpm 	Exec rxvt -pixmap /home/imc/nwrm/pics/pixmaps/dmlogo.xpm -scale T -title "$HOST : DMTerm" -n DM -geometry 80x32 &	    
#*FvwmWharf AlienTerm 	alien_but.xpm	Exec rxvt -pixmap /home/imc/nwrm/pics/pixmaps/alien01.xpm -scale T -title "$HOST : AlienTerm" -n AlienTerm -geometry 80x25 &
#*FvwmWharf TestTerm 	test_but.xpm	Exec rxvt -pixmap /home/imc/nwrm/pics/pixmaps/tcf.xpm -scale T -title "$HOST : TestTerm" -n TestTerm -geometry 80x32 &
*FvwmWharf ~Folders
*FvwmWharf Applications tool_ico.xpm Folder
*FvwmWharf Netscape 	net_but.xpm 	StartNetscape
*FvwmWharf FileManager	fm_but.xpm	Exec $OPENWINHOME/bin/xview/filemgr -scale small -iconic &
*FvwmWharf Calculator	calc_but.xpm	Exec xcalc -geometry 235x250+100+160 &
*FvwmWharf Pine		pine_ico.xpm	Exec rxvt -pixmap /home/imc/nwrm/pics/pixmaps/Elite.xpm -T "Pine" -scale T -geometry 95x40+5+170 -ls -n Pine -e /usr/local/bin/pine -i &
*FvwmWharf tex		tex_but.xpm	StartTex
*FvwmWharf Nedit 	ned_but.xpm 	Exec /home/imc/bin/nedit -geometry +450+130 &
*FvwmWharf DIPSO	dip_but.xpm	Exec /home/imc/scripts/dipstart &
*FvwmWharf IRAF		iraf_but.xpm	StartIRAF
*FvwmWharf ~Folders
*FvwmWharf Xeyes	xeyes.xpm	Swallow "xeyes" /opt/X11R5/bin/xeyes &
*FvwmWharf asclock	clock.xpm	MaxSwallow "asclock" asclock -shape &

#------------------------------------ taskbar
*FvwmTaskBarStartName Start
*FvwmTaskBarStartMenu StartMenu
*FvwmTaskBarStartIcon f_mico.xpm
*FvwmTaskBarFont -b&h-lucida-bold-r-normal-*-*-140-*-*-p-*-iso8859-*
*FvwmTaskBarFore white
*FvwmTaskBarBack blue4
AddToMenu StartMenu	"Start Stuff"*f_mico.xpm* 		Title 	
+                       "&Apps ................."%sph_mico.xpm% Popup  Apps
+			"&Remote ............"%sph_mico.xpm%  	Popup  Remote
+			"&Modules .........."%sph_mico.xpm%	Popup  Module-Popup
+			""					Nop
+			"&Games .............."%smi_mico.xpm%	Popup Games
+			"&Lock Screen ..."%loc_mico.xpm%	Popup ScreenLock
+			""					Nop
+			"Re&Start"				Restart
+			"E&xit Fvwm"%skull.xpm% 		Module FvwmForm QuitVerify

---

From: Richard Lister <[email-masked]>
Date: Fri, 29 Aug 1997 00:48:13 -0400

> windows so I guess this could be something to do with it...

OK, this is to do with AutoRaise. A free-floating Pager never gets the
focus (this can be changed with Style "FvwmPager" Lenience) and is thus
unaffected by AutoRaise and the problem doesn't arise.

However, if you swallow the Pager into FvwmButtons the buttons *can* get
focus. Make another window overlap the swallowed pager. Move into this
window so it gets focus and AutoRaises. Then move directly into a little
application window in the Pager. The Pager pops up the balloon, but then
some short time later AutoRaise raises the whole FvwmButtons over
the balloon. Curses!

One way to get round it would be to make the FvwmButtons ClickToFocus.
But, of course, you may not like that.

I'll work on it :-)

Ric

Richard J Lister, Georgetown Institute for Cognitive and Computational Sciences
Georgetown University Medical Center, Washington, DC 20007, USA
Phone: +1 202-687 2878
Email: [email-masked] 
Web: http://www.giccs.georgetown.edu/~ric/
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Martin Cartwright <[email-masked]>
Date: Fri, 29 Aug 1997 11:48:39 +0100 (BST)

On Fri, 29 Aug 1997, Richard Lister wrote:

->One way to get round it would be to make the FvwmButtons ClickToFocus.
->But, of course, you may not like that.
->

That sounds like the best solution.. O hang on I don't have Buttons
set as StaysOnTop as I use lots of big plotting windows and it gets in
the way sometimes... I also don't like it staying on top of title bars
(it's at the top of the screen.. Well, I'll give it a try it should
work... 

cheers,

Martin.