Subject: FVWM: Problems with TheNextLevel and fvwm2

From: Carter Bond <[email-masked]>
Date: Sat, 19 Jul 1997 21:24:16 -0600

Red Hat 4.2/XFree86 3.3/fvwm2/TheNextLevel/what does it all mean?

Having downloaded and installed Red Hat 4.2(XF86Free 3.3) for the i386
platform. My system:

Pentium 133/48megs memory
two 1.6 gig hard drives
Diamond Stealth 3000 3d/4megs(S3 Virge VX)
Sony Multiscan 15sx monitor

Now the trouble that I(and a number of Linux freaks in Albuquerque New
Mexico, many of whom proported to be paid to deal with X-windows systems)
have had is with the configuration of the X-windows system(XFree86 3.3 that
comes with Red Hat 4.2). 

Problem #1
"What resources are used with TheNextLevel"

Take the following .Xclients config file that is the default set up that
Red Hat 4.2 comes with:

#!/bin/bash

########################################################################
# -*- sh -*-                                                           #
#                                                                      #
# ~/.Xclients: used by startx (xinit) to start up a window manager and #
# any other clients you always want to start an X session with.        #
#                                                                      #
# feel free to edit this file to suit your needs.                      #
########################################################################

# these files are left sitting around by TheNextLevel.
rm -f $HOME/Xrootenv.0
rm -f /tmp/fvwmrc*

# first, find an M4-enabled config file (such as 
# the one from TheNextLevel) for fvwm2 or fvwm95.
RCFILE=""
for tryfile in "$HOME/.fvwm2rc.m4" "/etc/X11/TheNextLevel/.fvwm2rc.m4"; do
    if [ -f "$tryfile" ]; then
        RCFILE="$tryfile"
        break
    fi
done

# if it really exists, use it; if not, fvwm2 or fvwm95 will
# automagically look for a config file in the regular places.
if [ -n "$RCFILE" ]; then
    FVWMOPTIONS="-f 'FvwmM4 -debug $RCFILE'"
else
    FVWMOPTIONS=""
fi

# TheNextLevel is supposed to work
# with both fvwm95 and fvwm2
# (try fvwm95 first, then fvwm2).
for FVWMVER in 95 95-2 2; do
    if [ -n "$(type -path fvwm${FVWMVER})" ]; then
        env > "$HOME"/Xrootenv.0
        # if this works, we stop here
        eval "exec fvwm${FVWMVER} ${FVWMOPTIONS}" >
"$HOME"/.FVWM${FVWMVER}-errors 2>&1
    fi
done

# gosh, neither fvwm95 nor fvwm2 is available;
# let's try regular fvwm (TheNextLevel doesn't
# work with fvwm1).
if [ -n "$(type -path fvwm)" ]; then
    # if this works, we stop here
    exec fvwm
fi

# wow, fvwm isn't here either ... 
# use twm as a last resort.
xterm &
exec twm
------------

By default, this sets up fvwm95 as the default windows manager for X-windows. 

The Question:
Starting the window manager fvwm95-2 as show above, does fvwm95-2 use the
system default file /etc/X11/fvwm95-2/fvwm2rc95  or, does TheNextLevel
configure everything from the various files in the /etc/X11/TheNextLevel/
directory?

Problem #2:
"Getting TheNextLevel to work with fvwm2"

Fvwm95 was interesting for about 10 minutes. But I'm want a more
traditional X-windows look, specifically fvwm2. But I also want the great
features of TheNextLevel. This shouldn't be a problem, because TheNextLevel
works with fvwm2(theoretically). I have re-written the above .Xclients file:

-------------------------------------------
#!/bin/bash

########################################################################
# -*- sh -*-                                                           #
#                                                                      #
# ~/.Xclients: used by startx (xinit) to start up a window manager and #
# any other clients you always want to start an X session with.        #
#                                                                      #
# feel free to edit this file to suit your needs.                      #
########################################################################

# these files are left sitting around by TheNextLevel.
rm -f $HOME/Xrootenv.0

# first, find an M4-enabled config file (such as 
# the one from TheNextLevel) for fvwm2 or fvwm95.
RCFILE=""
for tryfile in "$HOME/.fvwm2rc.m4" "/etc/X11/TheNextLevel/.fvwm2rc.m4"; do
    if [ -f "$tryfile" ]; then
        RCFILE="$tryfile"
        break
    fi
done

# if it really exists, use it; if not, fvwm2 or fvwm95 will
# automagically look for a config file in the regular places.
if [ -n "$RCFILE" ]; then
    FVWMOPTIONS="-f 'FvwmM4 -debug $RCFILE'"
else
    FVWMOPTIONS=""
fi

# TheNextLevel is supposed to work
# with both fvwm95 and fvwm2
# (try fvwm95 first, then fvwm2).
for FVWMVER in 2; do
    if [ -n "$(type -path fvwm${FVWMVER})" ]; then
        env > "$HOME"/Xrootenv.0
        # if this works, we stop here
        eval "exec fvwm${FVWMVER} ${FVWMOPTIONS}" >
"$HOME"/.FVWM${FVWMVER}-errors 2>&1
    fi
done

# gosh, neither fvwm95 nor fvwm2 is available;
# let's try regular fvwm (TheNextLevel doesn't
# work with fvwm1).
if [ -n "$(type -path fvwm)" ]; then
    # if this works, we stop here
    exec fvwm
fi

# wow, fvwm isn't here either ... 
# use twm as a last resort.
xterm &
exec twm
---------------------------------

When I do the startx command, the whole thing crashes horribly. The
following .FVWM2-error file is created:

----------------------------------

[FVWM][executeModule]: <<ERROR>> No such module 'ELF' in ModulePath
'/usr/lib/fvwm2'
[FVWM][executeModule]: <<ERROR>> No such module 'ÿÿÿƒÄèjýÿÿèU' in
ModulePath '/usr/lib/fvwm2'
[FVWM][executeModule]: <<ERROR>> No such module 't€ù' in ModulePath
'/usr/lib/fvwm2'
[FVWM][executeModule]: <<ERROR>> No such module '‹…ÿÿÿÆ' in ModulePath
'/usr/lib/fvwm2'
[FVWM][executeModule]: <<ERROR>> No such module 'ëv' in ModulePath
'/usr/lib/fvwm2'
[FVWM][executeModule]: <<ERROR>> No such module 'jèµýÿÿƒÄ9órÊë¶' in
ModulePath '/usr/lib/fvwm2'
[FVWM][executeModule]: <<ERROR>> No such module 'ÆÌÂ' in ModulePath
'/usr/lib/fvwm2'
[FVWM][executeModule]: <<ERROR>> No such module '¾Á‹@ºë´&' in
ModulePath '/usr/lib/fvwm2'
[FVWM][executeModule]: <<ERROR>> No such module '¾ÁöDC' in ModulePath
'/usr/lib/fvwm2'
[FVWM][executeModule]: <<ERROR>> No such module 'ué1Û‰Uü€:' in ModulePath
'/usr/lib/fvwm2'
[FVWM][executeModule]: <<ERROR>> No such module 'tv' in ModulePath
'/usr/lib/fvwm2'
[FVWM][executeModule]: <<ERROR>> No such module 'uôJŠ' in ModulePath
'/usr/lib/fvwm2'
[FVWM][executeModule]: <<ERROR>> No such module '¾Á‹5@ºë' in ModulePath
'/usr/lib/fvwm2'
[FVWM][executeModule]: <<ERROR>> No such module '¾ÁöDF' in ModulePath
'/usr/lib/fvwm2'
[FVWM][executeModule]: <<ERROR>> No such module 'ÿMGFë«v' in ModulePath
'/usr/lib/fvwm2'
[FVWM][executeModule]: <<ERROR>> No such module 'täGPè+' in ModulePath
'/usr/lib/fvwm2'
----------------------------------

The /usr/lib/fvwm2   path is the correct ModulePath. But where does it get
the "ModulePath" from? Is it using the files in the /etc/X11/TheNextLevel
directory? Or is it using the system default /etc/X11/fvwm2/system.frwm2rc
file?

Any help on this would be greatly appreciated.

Carter Bond 
[email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Kendrick Vargas <[email-masked]>
Date: Sat, 19 Jul 1997 23:41:57 -0400 (EDT)

> "What resources are used with TheNextLevel"

Way too many... I think that TheNextLevel makes a mockery of fvwm95 and
redhat in general, I have no idea why they like it so much. 

> works with fvwm2(theoretically). I have re-written the above .Xclients file:
                  ^^^^
change this to -cmd

This was a mistake that hasn't been fixed in the man pages yet... The -cmd
option should be used to invoke commands or modules from the command line.

> following .FVWM2-error file is created:

that's precisely what the problem looks like :)
			-peace

--- BEGIN GEEK CODE BLOCK ------------+-----------
GAT d- s:+ !a C+(+++) UI/L/S/B++(+++) | "In the morning glad I see
P>+ L+(++) E---- W+++ N+ o? K? w++++  |  My foe outstrech'd beneath the tree."
O--- M-- V PS+++@ PE Y-- PGP+ t++ 5   |               -The Poison Tree
X++ R- tv+ b DI++ D+ G e>*  h*(!) r-  |                William Blake
y*(+) ------ END GEEK CODE BLOCK -----+

---

From: Carter Bond <[email-masked]>
Date: Sat, 19 Jul 1997 21:56:36 -0600

>option should be used to invoke commands or modules from the command line.

Are you sure about this? It works for fvwm95-2, its only when I change it
to fvwm2 that the problems occure. Also, that runs contrary to the comments
in the .fvwm2rc.m4 file:

# $Id: .fvwm2rc.m4,v 1.50 1996/06/13 21:28:09 gjb Exp $
# Resource file for version >=2.0.42 of FVWM,
# the F? Virtual Window Manager
#
# .fvwm2rc 
# (C)1996 By Greg J. Badros <[email-masked]>
# You may use this file as specified under the GNU
# public license (GPL).
# I am not responsible for this file's use, misuse, or anything.
# Use at your own risk.
#
# NOTE: This must be preprocessed w/m4
# use: fvwm95 -f "FvwmM4 -debug .fvwm2rc"
#
# You may choose to grab the post-processed file, and use it
# as your permanent .fvwm2rc file. If you give the -debug option
# to FvwmM4, /tmp/fvwmrc* will have the file-- just cp it to ~/.fvwm2rc
# and you're all set.  You'll of course lose the fvwm2rc's ability to
# dynamically change options based on the machine or its configurarion
#
# Generally, I'd just let FvwmM4 parse this each time-- it's not a
# huge hit on a personal machine, since you hopefully aren't starting
# and restarting X all that much... you may want to temporarily use
# the static /tmp/fvwmrc* file while playing with configurations
# or if you're having problems.  It's always a good place to look to
# figure out problems with the settings.
#
#
# This should be run with something like:
# exec fvwm2 -f "FvwmM4 -debug .fvwm2rc.m4" -display :0 > .FVWM2-errors 2>&1
# in your .xinitrc file
#
# It is very helpful to use "tail -f .FVWM2-errors" to see what's happening,
# and what errors occured
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Kendrick Vargas <[email-masked]>
Date: Sun, 20 Jul 1997 00:03:21 -0400 (EDT)

> to fvwm2 that the problems occure. Also, that runs contrary to the comments

Well... I think it was changed recently in a version after 2.0.43 (which
is what fvwm95 is based on). I can guarentee you that it will work... It
was the source of many questions from many people :)
			-peace

---

From: Carter Bond <[email-masked]>
Date: Sun, 20 Jul 1997 07:21:40 -0600

>was the source of many questions from many people :)

It worked! Thanks I appreciate it!

Re: TheNextLevel

The reason I trying to get it to work with fvwm2 is that it dynamically
allocates icons on the menus. Example: I installed Netscape 3.01 Gold the
other day. When I restarted fvwm2, a "Netscape" icon was added to my
"applications" menu. In theory, this makes life a whole lot easier if your
looking after a couple of Line X-window boxes. However, the reality is
seeming to be a little more fickle. 

I'll probably use TheNextLevel to produce a skeleton .fvwm2rc file and then
edit it from their.

Carter Bond