Subject: FVWM: environment problem

From: stefano lacaprara <[email-masked]>
Date: Wed, 18 Jun 1997 11:54:09 +0200 (MET DST)

Dear fvwm user,
	i use fvwm2 win. manager with an alpha/UNIX station.
I use the FvwmButtons to launch some program, e.g. netscape,
using the following command:
*FvwmButtons WWW  ghost.xbm Exec "" /usr/local/bin/netscape-gold3.0 -display $HOST':0.' &

Netscape starts correctly, but some environment that is set in my .login is not present,
e.g. the PATH variable. This causes some trouble because netscape fails 
to find some applications such as ghostview, gunzip and other.

My question is: it is possible to start direcly netscape (or other applications)
preserving the settings done in .login and co.?   

			thanx Ciao Stefano

                \\\|/// 
              \\  - -  //
               (  0 0  )
+------------oOOo-(_)-oOOo------------+
|          Stefano Lacaprara          |
|         [email-masked]        |
+-------------------------------------+

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Larry Gensch <[email-masked]>
Date: Wed, 18 Jun 1997 10:36:34 -0400 (EDT)

> preserving the settings done in .login and co.?   

Yes.  In your .xsession file (or whatever file you use to start up
fvwm2), source the .login file BEFORE calling fvwm2.  That way, the
environment variables are inherited by fvwm2, which will be passed
along to whatever applications are started by fvwm2.

-- 
(void) lar3ry();                                      [email-masked]

     "Sometimes it happens.  People just explode.  Natural causes."

---

From: "Lars Uffmann" <[email-masked]>
Date: Thu, 19 Jun 1997 00:10:48 +0200 (MET DST)

On Wed, 18 Jun 1997, Larry Gensch wrote:

> Date: Wed, 18 Jun 1997 10:36:34 -0400 (EDT)
> From: Larry Gensch <[email-masked]>
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: FVWM: environment problem
> 

By the way, last days I tried to figure out what a shell startet
from fvwm would inherit. So I defined a Menu entry like this:

+  "show env"                     Exec typeset

I then get a list of env vars to fvwms standart out. Can I be sure this
is the environment fvwm inherits from xinit ?

Lars

Lars Uffmann, [email-masked], fon: +49 5202 15372
Public Key available, send in e-mail, Subject: Your Key, Please