Subject: FVWM: AIX xmkmf error

From: "Paul Bennett" <[email-masked]>
Date: Fri, 30 May 1997 10:37:51 +0000

I am trying to compile fvwm 2.0.45 and 2.0.44 on a AIX 4.1 machine.  
I am getting the following error.

[ena2] </home/users/paulb/fvwm-2.0.44>xmkmf
mv Makefile Makefile.bak
imake -DUseInstalled -I/usr/lib/X11/config
"./Fvwm.tmpl", line 439.27: 1506-234 (W) Expecting a newline 
character on #ifndef directive. "./Imakefile", line 51.1: 1506-215 
(E) Too many arguments specified for macro NamedTargetSubdirs. [ena2] 
</home/users/paulb/fvwm-2.0.44>

I have tried compiling it on four of the AIX machines around here, 
but two of them, 3.2s,  do not have xmkmf on it.  It could be that 
both of the 4.1 machines were not setup properly and that could be 
causing the error.  
Thanks for your help.

Paul Bennett
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Charles Hines" <[email-masked]>
Date: Fri, 30 May 1997 12:06:56 -0400

>>>>> "Paul" == Paul Bennett <[email-masked]> writes:

Paul> I am trying to compile fvwm 2.0.45 and 2.0.44 on a AIX 4.1 machine.
Paul> I am getting the following error.

Paul> [ena2] </home/users/paulb/fvwm-2.0.44>xmkmf
Paul> mv Makefile Makefile.bak
Paul> imake -DUseInstalled -I/usr/lib/X11/config
Paul> "./Fvwm.tmpl", line 439.27: 1506-234 (W) Expecting a newline
Paul> character on #ifndef directive. "./Imakefile", line 51.1: 1506-215
Paul> (E) Too many arguments specified for macro NamedTargetSubdirs. [ena2]
Paul> </home/users/paulb/fvwm-2.0.44>

Paul> I have tried compiling it on four of the AIX machines around here,
Paul> but two of them, 3.2s,  do not have xmkmf on it.  It could be that
Paul> both of the 4.1 machines were not setup properly and that could be
Paul> causing the error.

I was able to reproduce this.  At work I normally build under AIX
3.2.5, which doesn't show these problems, but all of our machines are
being upgraded to AIX 4.1, so this would have hit me eventually...

Try this patch, which I don't think will affect anyone in a bad way,
but can't check another OS (eg Linux) until I get home tonight:

------------------------------>8 cut here 8<------------------------------
--- fvwm-2.0.45/Imakefile       Mon Dec 23 17:07:44 1996
+++ development/Imakefile       Fri May 30 12:00:47 1997
@@ -48,7 +48,7 @@
  */
 #define PassCDebugFlags 'CDEBUGFLAGS=$(CDEBUGFLAGS)'

-MakeSubdirs($(SUBDIRS))
+MakeSubdirs

 DependSubdirs($(BUILDSUBDIRS) $(XPMSUBDIRS))

--- fvwm-2.0.45/Fvwm.tmpl       Wed Jan 22 08:38:49 1997
+++ development/Fvwm.tmpl       Fri May 30 11:58:58 1997
@@ -428,7 +428,7 @@
 #define InstallNamedNonExec(what,as,where) InstallNonExec(what,where/as)
 #endif /* InstallNamedNonExec() */

-#ifndef InstallNonExecFile()
+#ifndef InstallNonExecFile
 #define InstallNonExecFile(file,dest) InstallNonExec(file,dest)
 #endif /* InstallNonExecFile() */

------------------------------>8 cut here 8<------------------------------

Chuck

---

From: "Paul Bennett" <[email-masked]>
Date: Fri, 30 May 1997 12:54:53 +0000

> being upgraded to AIX 4.1, so this would have hit me eventually...

Thanks for the patch.  I am having trouble applying it though.  Patch 
keeps telling me that it can't find the patch, even if I past it into 
standard in.  
 
If I am in ../fvwm-2.0.45 I run
patch -p 0 < patchfile

correct?  i have tried various versions of being inthe directory, or 
out of it, with -p 1,0, etc.
 
Any ides?  
 
Thanks.

-- Paul