Subject: FVWM: My fvwm audio problems

From: Marco Solari <[email-masked]>
Date: Thu, 01 May 1997 17:40:02 +0200

Thank You, David:
my problem was just the one You pointed out: I did not figured out that
I needed an rplay daemon ... now everything works just quite fine, but I
still got a couple of problems ;-).
	Where can I find a collection of good short sounds to attach to fvwm
events ? And, more important: where can I find the full list of fvwm
events ?
	I could neither understand if I can use this (rplay) good package as a
mime audio-type application: if yes, how ? if not, what can I use ? (We
are speaking about Linux and Netscape, of course ...). Thanks to You an
to everybody who will like to answer me (if any) in advance, and sorry
for the silly questions ...

	Marco Solari
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: David Nugent <[email-masked]>
Date: Fri, 02 May 1997 02:48:50 +1000

>  Where can I find a collection of good short sounds to attach to fvwm

I believe there are some on the fvwm home site; I remember having
read that at some point. If you use tkdesk, there's quite a few
that come with that as well, and some packages a bundled with
sound files. Other than that, there's always the web - one of the
search engines will turn up something.

I found that some of the sounds that come with various packages aren't
all that suitable for a desktop. I eventually used mxv to edit the
sounds to taste, reducing volume where necessary, chopping out rough
bits and crackles, reducing their length and so on. I'm sure you can
spend years doing this sort of thing, but there comes a point where
you have to say 'good enough'. :-)

>  And, more important: where can I find the full list of fvwm
>  events ?

I had problems with this too, so I did what comes naturally and
consulted the source. :-) The FvwmAudio manpage isn't all that
helpful. In addition, there seem to be some mysteries involved
as well; it appears that there are hooks to make sounds on very
specific events, like icons by name, windows and resources by
name or class, mini_icons. use of the default icon, and some
(apparently debugging) events to do with configuration (FvwmConfig?).
I have no idea how all of that works, and even the source doesn't
appear to be that helpful to teh casual browser. Perhaps most of
this is intended to be handled outside of fvwm itself, and won't
help if you're running with the builtin-rplay as I am. If someone
can shed some light on these things, I'm certainly interested.

Anyway, here's how I configure FvwmAudio, and I find it works
quite well. The sounds do add something to the look and feel of
the desktop.

*FvwmAudioPlayCmd               builtin-rplay
*FvwmAudioDelay                 0
*FvwmAudioDir                   /usr/local/lib/sounds
*FvwmAudioRplayHost             localhost
*FvwmAudioRplayPriority         0
*FvwmAudioRplayVolume           32
# Seldom events
*FvwmAudio      startup         start
*FvwmAudio      shutdown        level_up
# Frequent events
*FvwmAudio      focus_change    quiet-beep
*FvwmAudio      raise_window    metal
*FvwmAudio      lower_window    drum-beep
*FvwmAudio      iconify         bass-snap
*FvwmAudio      deiconify       computer
# Occasional events
*FvwmAudio      unknown         clunk
*FvwmAudio      new_page        hammer
*FvwmAudio      new_desk        doorclose
# Infrequent events
*FvwmAudio      add_window      click
*FvwmAudio      destroy_window  return
*FvwmAudio      map             whip
*FvwmAudio      error           beep3
# Special - I have no idea what most of these do, or how to use
# any additional information I guess might # be available. They
# are commented out and included only for completeness.
#*FvwmAudio     configure_window  miss2
#*FvwmAudio     window_name       imarker
#*FvwmAudio     icon_name         yeep
#*FvwmAudio     icon_file         yeep
#*FvwmAudio     icon_location     yeep
#*FvwmAudio     default_icon      yeep
#*FvwmAudio     mini_icon         yeep
#*FvwmAudio     string            yeep
#*FvwmAudio     windowshade       yeep
#*FvwmAudio     dewindowshade     yeep
#*FvwmAudio     config_info       drum-beep
#*FvwmAudio     end config_info   drum-beep
#*FvwmAudio     res_class         drum-beep
#*FvwmAudio     res_name          drum-beep
#*FvwmAudio     end_windowlist    imarker

> mime audio-type application: if yes, how ?

Yes, it can be done. Make sure you have write access to the
rplay server, and edit your mime.types configuration to run
rplay with the file on the command line for each of the audio
types it knows about.

> (We are speaking about Linux and Netscape, of course ...).

["Of course"? I don't use either. :-)]

Regards,
David