Subject: FVWM: swallowing iconified apps

From: "Mike Campbell" <[email-masked]>
Date: 29 May 97 09:20:04 -0700

Did anyone get an answer to how to make FvwmButtons swallow an iconified 
application??? 
 
I'd like to swallow rclock iconified so that it will display the clock as well 
as the date. 
 
Thanks, 
 
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ 
Mike Campbell 
Oracle Technical Support Analyst		Phone: 407-888-3786 
5955 T.G. Lee Blvd., Suite 400		Fax:   407-851-9093 
Orlando, FL 32822				Email: [email-masked] 
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (David S. Goldberg)
Date: 29 May 1997 12:38:17 -0400

>>>>> Mike Campbell writes:
> Did anyone get an answer to how to make FvwmButtons swallow an
> iconified application???

Currently it can't.  At one point it was on the FvwmButtons todo list,
but the FvwmButtons home page seems to no longer exist.  If Jarl is
still reading this, perhaps he can help.
 
> I'd like to swallow rclock iconified so that it will display the
> clock as well as the date.

You can have FvwmButtons swallow an instance of FvwmIconBox that only
displays the icon you want.  This is pretty ugly, but it does work.

--
Dave Goldberg
Post: The Mitre Corporation\MS B305\202 Burlington Rd.\Bedford, MA 01730
Phone: 617-271-3887
Email: [email-masked]

---

From: Morsy Cheikhrouhou <[email-masked]>
Date: Fri, 30 May 1997 09:00:14 +0200

> I'd like to swallow rclock iconified so that it will display the clock as well 

Hello,

I have the following in my .fvwmrc 

*FvwmButtons(Swallow(UseOld,NoClose) "xclock" `Exec xclock -title xclock -bg rgb:90/80/90 -geometry 98x98-256-2 &`)

if you just change xclock by rclock and some parameters, it should work.

---

From: Gary Sargent <[email-masked]>
Date: Fri, 30 May 1997 08:43:55 +0100

> I'd like to swallow rclock iconified so that it will display the clock as well 

I needed to do this because we use a mail program called 'Mailworks', which when
iconified shows you a dog with mail in its mouth if you get new mail (!!??!!).
The only way I could think to do it is to use an FvwmIconBox. I swallow this in
my FvwmButtons and ensure that only the one icon I want is present in the
icon box. Here's what I used (fvwm 2.0.45):

  For my button bar:

     *IconBar(Frame 0, Swallow(Respawn) "IMailBox" "IMailBox")

  For my FvwmIconBox (called IMailBox ie I have a soft link from IMailBox to
  FvwmIconBox):

     *IMailBox "nedit*" -

and styles:

     Style "*"                       Icon xterm.xpm
     Style "MailWorks*Browser*"      NoIcon
     Style "nedit"                   NoIcon

nedit and mailworks are the only two apps I have in iconbox's. I disclude the nedit
ones from my IMailBox and the mailworks ones from the other to ensure I don't
have duplicates.

Now when I double click on the icon (in the button bar) the icon remains iconified
but the window expands - so I have the icon and the window. I only ever start the
program once (done in a seperate script - but this could be done within a function
or something).

I suppose you could use "*" to disclude all icons and then add a specific one
(rclock).

Hope this helps,

Gary Sargent.