Subject: FVWM: Installation-beginner

From: Lewis Jones <[email-masked]>
Date: Fri, 23 May 1997 16:23:12 +1000 (EST)

Hello there,

	I am trying to install fvwm-1.24r to see how it all works and I 
am running into a couple of errors which may either be symptomatic of a 
deeper, darker dilemma, or may, in fact, be simply my own incompetence.  
I am using a Sparc4 running solaris2.5.

	Following the installation script in README.Install I have 
managed the following:

xmkmf  - works without a hitch

make Makefiles  - every time it starts into a new directory I get the 
following message (this is specifically for the xpmroot directory):

+ make Makefiles 
making Makefiles in ./xpmroot...
rm -f xpmroot/Makefile.bak
+ mv xpmroot/Makefile xpmroot/Makefile.bak 
+ cd xpmroot 
+ imake -DUseInstalled -I/usr/openwin/lib/config -DTOPDIR=../. 
-DCURDIR=./xpmroot 
"/usr/openwin/lib/config/site.def", line 30: macro UseInstalled redefines 
previous macro at "command line"

make all  - this is where things get catastrophic, below is the last few 
lines before total failure, but the previous many lines are identical in 
that the complaint is always language F not recognized.  The only thing 
different at the end is that it fails to make target icons.omaking all in 
./fvwm...
gcc -O -xF -DSYSV -DSVR4 -xF -Wa,-cg92   -I/usr/openwin/include  -DSVR4 
-DSYSV     -c  icons.c
gcc: language F not recognized
icons.c:27: X11/xpm.h: No such file or directory
*** Error code 1
make: Fatal error: Command failed for target `icons.o'
Current working directory /export/home/lewis/fvwm-1.24r/fvwm
*** Error code 1
make: Fatal error: Command failed for target `all'

-----------------------------------------------------------------------

Any suggestions would be much appreciated.  I've used fvwm before and 
loved it, but never had to install it.

Thanks,
Lewis Jones
Department of Astrophysics
University of New South Wales
Sydney, Australia
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Kai Grossjohann <[email-masked]>
Date: 23 May 1997 09:35:57 +0200

>>>>> Lewis Jones writes:

  Lewis> gcc -O -xF -DSYSV -DSVR4 -xF -Wa,-cg92   -I/usr/openwin/include  -DSVR4 
  Lewis> -DSYSV     -c  icons.c
  Lewis> gcc: language F not recognized
  Lewis> icons.c:27: X11/xpm.h: No such file or directory
  Lewis> *** Error code 1
  Lewis> make: Fatal error: Command failed for target `icons.o'
  Lewis> Current working directory /export/home/lewis/fvwm-1.24r/fvwm
  Lewis> *** Error code 1
  Lewis> make: Fatal error: Command failed for target `all'

Have you got the XPM library installed?  If not, you might need to
fetch and install it.  You can probably get it from an x.org mirror.

The "language F not recognized" stems from the fact that your Imake
setup is tuned for the Sun C compiler but you use gcc.  "-xF" is a
meaningful switch for the Sun compiler but gcc thinks you're trying to
tell it about the language.  I think you can mostly ignore this message.

kai
-- 
Life is hard and then you die.