Subject: FVWM: FvwmButtons home site.

From: "Herve DEBAR" <[email-masked]>
Date: Wed, 14 May 1997 14:42:34 +0200

Hi,

I would like to find if there is a new home site for FvwmButtons,
the one given in the distribution's README seems to be out of
business. Also, has this module been updated since the last
Fvwm packing (2.0.45).

Thanks

Herve

-- 
Herve Debar
IBM Zurich Research Laboratory
Saumerstrasse 4
CH-8803 Rueschlikon/Switzerland
Tel.  +41-1-724-84-99     Fax.   +41-1-710-36-08

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: James Frost <[email-masked]>
Date: Sat, 17 May 1997 18:25:42 +0100 (BST)

I have added a bit to the functionality of fvwm2, both to the icon code 
and the menu code. I have written them as patches yet ;-) but if there's 
any interest then I'll get patches written and post them somewhere.

I haven't been subscribed to this news group for very long, so for all I 
know there could already be patches to do this. If there are, there is 
every chance that they will have been better put together than mine, 
since my X11 programming experience isn't great. But if not....

Basically I have added these new commands:
	
	*IconStyle flat | raised | sunk
	*IconColor foregroundcolor backgroundcolor

	*MenuTitleStyle forecolor backcolor font

To see what they look like in action, point your browser at
	
	http://www.ecs.soton.ac.uk/~jaf195/desktop.htm

		James Frost

---

From: [email-masked]
Date: Sat, 17 May 1997 15:04:59 -0400 (EDT)

What do the raised/sunk icons look like?  Do they work also with
MiniIcons?

--jim

############### jim knoble ######## [email-masked] #################

On Sat, 17 May 1997, James Frost wrote:

: 
: I have added a bit to the functionality of fvwm2, both to the icon code 
: and the menu code. I have written them as patches yet ;-) but if there's 
: any interest then I'll get patches written and post them somewhere.
: 
: I haven't been subscribed to this news group for very long, so for all I 
: know there could already be patches to do this. If there are, there is 
: every chance that they will have been better put together than mine, 
: since my X11 programming experience isn't great. But if not....
: 
: Basically I have added these new commands:
: 	
: 	*IconStyle flat | raised | sunk
: 	*IconColor foregroundcolor backgroundcolor
: 
: 	*MenuTitleStyle forecolor backcolor font
: 
: To see what they look like in action, point your browser at
: 	
: 	http://www.ecs.soton.ac.uk/~jaf195/desktop.htm
: 
: 
: 		James Frost
: 	
: --
: Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
: To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
: message to [email-masked].
: To report problems, send mail to [email-masked].
:

---

From: James Frost <[email-masked]>
Date: Sun, 18 May 1997 11:19:21 +0100 (BST)

> What do the raised/sunk icons look like?  Do they work also with

All I have done for the raised/sunk icons is reversed the colours for the 
shadow and relief of the icon. The icons are for iconified windows, so 
specifying mini icons for icons will not do anything special. I'll grab a 
couple more screenshots and show you what I mean sometime today or 
tomorrow, and post them on the web URL given before.

		James Frost

	o 34 Blenheim Gardens, Highfield, Soton, S017 3RQ
            
	o http://www.ecs.soton.ac.uk/~jaf195