Subject: FVWM: Fvwm2 Key Bindings

From: FRBall <[email-masked]>
Date: Thu, 15 May 1997 20:46:15 -0500

I can't seem to get keybindings to work on teh numpad when numlock is on, the lines I have are:

############################################################################
# press arrow + control anywhere, and scroll by 1 page                     #
############################################################################

Key KP_Left        A       C       Scroll -100 +0
Key KP_Right       A       C       Scroll +100 +0
Key KP_Up          A       C       Scroll +0   -100
Key KP_Down        A       C       Scroll +0   +100
Key KP_Begin       A       C       Refresh

## let's try it with the numbers

Key KP_4           A       C       Scroll -100 +0
Key KP_6           A       C       Scroll +100 +0
Key KP_8           A       C       Scroll +0   -100
Key KP_2           A       C       Scroll +0   +100
Key KP_5           A       C       Refresh

while numlock is off, control-numpad-arrow works fine, but when numlock is on, nothing happens.

Is there something I missed, or is this a "feature" in fvwm-2.0.45 ?

Franklin Belew
[email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Kai Grossjohann <[email-masked]>
Date: 16 May 1997 08:48:17 +0200

>>>>> FRBall  writes:

  FRBall> while numlock is off, control-numpad-arrow works fine, but
  FRBall> when numlock is on, nothing happens.

This is because numlock is a modifier.  Try xmodmap -pm to see which
one it is.  Include key bindings in your .fvwmrc with that modifier in
addition to the ones you already have.

Does this work?
kai
-- 
Life is hard and then you die.