Subject: Re: FVWM: Netscape and colormaps/ FvwmBacker/ resize borders

From: Andreas Schumann <[email-masked]>
Date: Mon, 26 May 1997 13:28:26 -0400 (EDT)

On Mon, 26 May 1997, Armin Richter wrote:

> > When I start Netscape on my LINUX-Box (2.27, Redhat 4.1, fvwm2 as
> > window manager)  I get the Error Message: We were only able to allocate
> > 12 cells for the color cube... although there are no other applications
> > running which could "consume" the colormap. Netscape runs but with messed
> > up colors.

> why don't you just run X with more color-depth?
> Sounds like you use an 8 bit screen. 
> On my system, this can be achieved by starting X with 
> startx -- -bpp16 (or was it -bpp 16?).

I run the Xserver under xdm. 
In /usr/X11R6/lib/X11/xdm/Xserver I define
	
	:0 local /usr/X11R6/bin/X -bpp 16

Netscape works now (thanks for the hint), however, FvwmBacker doesn't. 
In my .fvwm2rc file I define two desks:

	*FvwmBackerDesk 0 -solid steelblue
	*FvwmBackerDesk 1 -midnightblue

All what I get is a light green background on both desks. If I set the
background anew using: xsetroot -solid steelblue I can change the
colour to steelblue but when  I switch the desks I get the light green
colour again. 

Also the border I normally got when I tried to resize windows is gone. 

I thought I already run in a higher mode, because everything is
defined in my /etc/X11/XF86Config file (the Depth-line in the Screen
Section). Is this file read at all when using -bpp, or is the -bpp
16 option used as an alternative to the XF86Config?

Thanks for any clearifying support!

Andreas

+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Andreas Schumann
Department of Mechanical Engineering
Queen's University
Kingston, Ontario, Canada
K7L 3N6

Telephone: 1-613-545-6685
Telefax:   1-613-545-6015
e-mail:    [email-masked]
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: zinc <[email-masked]>
Date: Mon, 26 May 1997 13:18:36 -0600

-----BEGIN PGP SIGNED MESSAGE-----

i noticed the same problem with FvwmBacker.  ie, using it as the
manual suggests does not work.

i had to call explicitly call xsetroot like this:

*FvwmBackerDesk 0 xsetroot -solid gray13
*FvwmBackerDesk 1 xsetroot -solid midnightblue
*FvwmBackerDesk 2 xsetroot -solid darkslategray

 > Thanks for any clearifying support!
- -- 
"Those that give up essential liberty to obtain a little temporary
safety deserve neither liberty nor safety." -- Benjamin Franklin (1773)
		   finger zinc-pgp@zifi for PGP key
zifi runs LINUX 2.0.30  -=-=-=WEB=-=-=->  http://zifi.genetics.utah.edu