Subject: FVWM: Numllock-Problem

From: Carsten Hatger <[email-masked]>
Date: Sat, 10 May 1997 18:59:54 +0200 (CEST)

Hello,

I'm in trouble with fvwm2  2.0.43 and  NumLock set to ON.
It is not possible to change the focus between any window if Numlock is
set to on. Maybe this might be a general prob with my xmodmap, but
actually I don't know how to resolve the puzzle.

here's an excerpt of my fvwm2rc
--- snip
##########################################################################
# FVWM - F? Virtual Window Manager, Version 2.x (fvwm2) Configuration File
# Created May 1996
#

# Uncomment this to force you to click in a window to give it focus
Style "*" ClickToFocus

# default: focus follows mouse
#Style "*" MouseFocus

# click/release must occur in <n milliseconds to be a "click"
ClickTime 250

# if the window occupies less than n% of the screen, draw it opaque
# opaque meint " mit inhalt !! "
OpaqueMoveSize 5
############################################################################
# WINDOW Placement
#
# SmartPlacement makes new windows pop-up in blank regions of screen 
Style "*" SmartPlacement

# If SmartPlacement fails, this places it randomly instead of making you do it
Style "*" RandomPlacement

Style "*" MWMFunctions, MWMDecor, MWMButtons, MWMBorder, HintOverride

# change the default width, set a global icon, and give borders to popups
Style "*" BorderWidth 7, HandleWidth 7, Icon x.xpm, DecorateTransient

Style "Fvwm*"		NoTitle, Sticky, WindowListSkip, NoHandles
Style "Fvwm Pager"   	StaysOnTop, NoHandles
Style "FvwmButtons"	ClickToFocus
Style "FvwmButtons"	BorderWidth 5
Style "FvwmButtons"  NoHandles, Sticky
Style "FvwmButtons"  CirculateHitIcon,WindowListSkip

AddToFunc Move-or-Raise		"I" Raise
+				"M" Move
+				"D" Lower

AddToFunc Move-or-Raise2        "M" Raise
+				"M" Move
+				"D" Lower

AddToFunc Maximize-Func_All	"C" Maximize     100 100

AddToFunc Maximize-Func_Height	"C" Maximize     0 100

AddToFunc Maximize-Func_Width	"C" Maximize     100 0

AddToFunc Move-or-Iconify       "I" Raise
+                               "M" Move
+                               "D" Iconify

AddToFunc Resize-or-Raise       "I" Raise
+                               "M" Resize
+                               "D" Lower

AddToFunc Resize-or-Raise2      "M" Raise
+                               "M" Resize
+                               "D" Lower

############################################################################
# MOUSE Setup
#
# First, the root window. Button 1 brings up the Main Menu. B2 is the
# window operations list, and B3 is the winlist module
#     Button	Context Modifi 	Function
Mouse 1		R   	A       Menu RootMenu Nop
Mouse 2		R    	A       WindowList
Mouse 3		R    	A      	Menu Window-Ops Nop

# Now, title bar buttons
# Left button is the Window-Ops2 menu, right is iconify, rightmost is maximize
#     Button	Context Modifi 	Function
Mouse 0		1       A       Menu Window-Ops2 Close
Mouse 0		2    	A     	Maximize-Func_All
Mouse 0		2    	C     	Maximize-Func_Height
Mouse 0		2    	M     	Maximize-Func_Width
Mouse 0		4    	A     	Iconify
Mouse 0		3       A       Stick

# Button 1 in Frame or Sides is a resize-or-raise, in Icons is a move or 
# de-iconify, and on Top does a move-or-raise
#     Button	Context Modifi 	Function
Mouse 1 	FS      A       Resize-or-Raise
Mouse 1		I       A       Move-or-Iconify
Mouse 1		T       A       Move-or-Raise

# Button 2 in an Icon is de-iconify, in Corners/Sides/Titlebar gets Ops Menu
#     Button	Context Modifi 	Function
Mouse 2 	FST    A	Menu Window-Ops2 

# Button 3 does a raise-lower on anything
Mouse 3 	TSF	A       RaiseLower
Mouse 3 	I	A       Menu Window-Ops2 

---- snap

and my modifier-map 
--- snip
xmodmap:  up to 2 keys per modifier, (keycodes in parentheses):

shift       Shift_L (0x32),  Shift_R (0x3e)
lock        Caps_Lock (0x42)
control     Control_L (0x25),  Multi_key (0x6d)
mod1        Meta_L (0x40)
mod2        Num_Lock (0x4d)
mod3        Mode_switch (0x71)
mod4        Super_L (0x73),  Super_R (0x74)
mod5        Scroll_Lock (0x4e),  Hyper_R (0x75)

--- snap
can anybody help me ?

thanks in advance 
Carsten

---
Carsten Hatger                     fon ++49-511-762-2467
Universitaet Hannover              fax ++49-511-762-2468 
Geodaetisches Institut             mail [email-masked]

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mark Krischer <[email-masked]>
Date: Mon, 12 May 1997 09:30:41 -0400

i've noticed this problem with fvwm2 as well.  with numlock on, none of
my key or mouse bindings work; however, i can still move to different
pages with the mouse (not, with my keybindings though.)

--mark