Subject: FVWM: No FvwmButtons displayed

From: Jean-Paul Le Fevre <[email-masked]>
Date: Tue, 6 May 1997 11:29:52 +0100

Greetings,

Last week I made the decision to move from fvwm 1.xx to 2.xx.
I dowloaded the latest version fvwm-2.0.45 and I upgraded
my config file as explained in the doc.

Everything works fine except the FvwmButtons. I had
a couple of GoodStuff buttons which I want to convert
into FvwmButtons. But whatever I try in the .fvwm2rc
I cannot get any buttons displayed on my screen.

Looking at the source directory in modules/FvwmButtons,
I recompiled the module with the various debug flags
set. The output is as follow :

FvwmButtons: Parsing...OK
FvwmButtons: Shuffling...OK
FvwmButtons: Loading data...
FvwmButtons: Loading: Button 0x804bf00: colors, colors2

Well, it seems correct !

After having launched the FvwmTalk I tried the
example samplebuttonrc given with the module.
The only thing I got was a xclock located
at a strange position in a right hand desktop.
If I moved into this desktop, the clock escaped
further to the right !

Similarly, if I make use of the system.fvwm2rc provided
with the package, I got a FvwmTalk window when I fired
up the Buttons module. It's very confusing !

I have tried to check out the page at the specified URL in
the README : http://www.fm.unit.no/~jatotal/fvwm.html.
Unfortunately the link is out of date :-(

I browsed the archive of the mailing list looking for
articles about Buttons but the output of the
search engine is not easy to manage.

Here are the spec of my configuration :

Linux 2.1.26
gcc version 2.7.2
XFree86 11.0 vendor release number:    3120

And last, the paragraph in my .fvwm2rc dealing with
the buttons :

#  				FvwmButtons button-bar

*FvwmButtonsFore 	Black
*FvwmButtonsBack 	Red
*FvwmButtonsFont 	-adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmButtonsGeometry 	-5-10
*FvwmButtonsColumns 	1

*FvwmButtonsGeometry -135-5
*FvwmButtonsRows 1
*FvwmButtonsFont -*-helvetica-medium-r-*-*-12-*
*FvwmButtonsPadding 2 2

*FvwmButtons(Title Kill, Icon rbomb.xpm, Action Destroy)

*FvwmButtons(Title Mail, Icon mail.xpm , Action \
	'Exec "Mail" /usr/local/bin/ml &')
*FvwmButtons(Title Netscape, Icon spider.xbm, Action \
   	'Exec "Netscape" netbrowser &')
*FvwmButtons(Title Xcalc, Icon rcalc.xpm, Action \
	'Exec "Calculator" xcalc &')
*FvwmButtons(Title  Xpal, Icon xpaint.xpm, Action \
  	'Exec "Palette" xpal &')

Thanks in advance for your help,

-- 
____________________________________________________________________________

Jean-Paul Le Fèvre                      	CISI
E-mail : [email-masked]         	Tel : (33) [0]1 41 80 44 57
____________________________________________________________________________
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Patrice Fortier <[email-masked]>
Date: Tue, 6 May 1997 12:01:19 +0200 (MET DST)

> *FvwmButtonsRows 1

There's something wrong here...
You ask for a buttonbar with 1 button width, and 1 button height...

I don't know if it'll solve your problem, but I do know that this is
wrong ;).

Lokh.

---

From: [email-masked] (sumeet singh)
Date: Tue, 6 May 1997 19:06:15 +0800 (SGT)

Hi,
	I have faced the same problem with FvwmButtons of version
2.0.45 and hence now, run FvwmButtons 2.0.40 with fvwm 2.0.45 to
get the best of both worlds.
	However FvwmButtons 2.0.40 is primitive compared with the
2.0.45 version :( By the way, if you compile FvwmButtons 2.0.40
with the XPM flag turned OFF, it works fine, but alas you can't
display colour buttons. I had posted similar queries on this
mailing list, but got no solution.

regards,
sumeet

-- 
Sumeet Singh, [email-masked], Institute of Systems Science, N.U.S.,
Singapore - 119597,Ph: 65-772 6728 (o),Fax: 65-7744990 (o).
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jean-Paul Le Fevre <[email-masked]>
Date: Tue, 6 May 1997 14:04:51 +0100

Following your suggestion, I've installed the 2.0.40 version
of the Buttons modules and I've now my set of buttons
available as with fvwm 1.xx. Great !

However, it would be nice to fix the problem to take full
advantage of the last release.

Thank you very much for your advice,

Jean-Paul Le Fèvre                      	CISI