Subject: FVWM: xinitrc

From: Stuart Clark <[email-masked]>
Date: Wed, 21 May 1997 07:15:07 -0400

I have the following in my xinitrc:

twm &
xclock -geometry 50x50-1+1 &
xterm -geometry 80x50+494+51 &
xterm -geometry 80x20+494-0 &
exec xterm -geometry 80x66+0+0 -name login

If I am trying to call my fvwmrc file, what do I do, or where do I put the
command.  I tried deleting that section, then putting the full path to the
.fvwmrc file, but that got me nowhere.

As you probably inferred, this is my first attempt at setting up X, and am
having a hell of time getting this to work.

Thanks in advance,
Stu
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Bruce Stephens <[email-masked]>
Date: Wed, 21 May 1997 12:22:44 +0100

> exec xterm -geometry 80x66+0+0 -name login 

fvwm is a window manager: you must run it instead of twm, so change the first 
line to "fvwm &", or more safely "(fvwm2 || fvwm || twm) &" or something.  
fvwm will automatically read .fvwmrc (fvwm2 will read .fvwm2rc, by default).

---

From: "Jacob Morzinski" <[email-masked]>
Date: Wed, 21 May 1997 12:20:23 EDT

>fvwm will automatically read .fvwmrc (fvwm2 will read .fvwm2rc, by default).

That may not do what you want.  The || will cause fvwm to run if
fvwm2 is not found, but will also run fvwm if fvwm2 exits with a
non-zero exit status.

If you know where the fvwm2 program is, another way to test for
its existance is

# or, sh code
if [ -r /the/path/to/fvwm2 ]; then
    fvwm2 &
elif [ -r /the/path/to/fvwm ]; then
    fvwm &
else
    twm &
fi

# csh code
if ( -r /the/path/to/fvwm2 ) then
    fvwm2 &
else if ( -r /the/path/to/fvwm ) then
    fvwm &
else
    twm &
endif

Sincerely,
-- 
 Jacob Morzinski                                [email-masked]