Subject: FVWM: New fvwm packet request

From: Brady Montz <[email-masked]>
Date: 13 May 1997 10:06:25 -0700

Here I go again with another module packet suggestion. This time if it gets
added I promise to document it in the modules.tex :-). 

I've had a request to make is so that FvwmIconMan could follow the fvwm window
list order exactly. This is currently quite difficult to do as the list order
changes silently at various times, and there's no way to really tell from
outside of fvwm. For example, my perusal of the fvwm code shows that FlipFocus
changes the window list order, while Focus does not. There's no way for a
module to tell which of these happened from watching the messages from fvwm.

So, my proposal is a new packet type which keeps modules informed of any
changes to the window list order. 

Other modules, current and potential, could benefit from this as well.

This brings up a more general class of features. Fvwm maintains some important
data structures, and it would be nice if modules could be able to access them,
either in a read-only or read-write fashion. A packet listing whatever changes
have occured to the window list order is a simple way of implementing
read-only access to a portion of the window list. Can anyone think of other
things in this class?

-- 
 Brady Montz
 [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (sumeet singh)
Date: Wed, 14 May 1997 09:53:28 +0800 (SGT)

It would be a good thing if FvwmIconMan could display icons
horizontally also, rather than vertically only (as it does now). This
would enable one to stick a task bar sort of thing at the bottom of
the page.

thanks,
-- 
Sumeet Singh, [email-masked], Institute of Systems Science, N.U.S.,
Singapore - 119597,Ph: 65-772 6728 (o),Fax: 65-7744990 (o).
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Tue, 13 May 1997 22:53:50 -0400 (EDT)

Ummm .... FvwmIconMan *does* allow you to display icon-buttons
horizontally; i've got it doing that right now.  I'm using
FvwmIconMan-0.9.8 with the following sort of configuration:

 *FvwmIconMan*nummanagers	1
 *FvwmIconMan*buttongeometry	m4_eval(WIDTH / 8)x24
 *FvwmIconMan*1*managergeometry	8x1+0-0
 *FvwmIconMan*font		helvetica-12
 *FvwmIconMan*format		"%i"
 *FvwmIconMan*background		DarkGray
 *FvwmIconMan*foreground		Black
 *FvwmIconMan*plainbutton	up
 *FvwmIconMan*focusbutton	down
 *FvwmIconMan*focusandselectbutton	down
 *FvwmIconMan*selectbutton	up
 *FvwmIconMan*1*title		{TaskBar}
 *FvwmIconMan*1*iconname		{TaskBar}
 *FvwmIconMan*drawicons		true
 *FvwmIconMan*followfocus	true
 *FvwmIconMan*sort		true
 *FvwmIconMan*usewinlist		false
 *FvwmIconMan*1*dontshow		resource=FvwmIconMan resource=FvwmPager resource=FvwmButtons resource=asclock resource=xmailbox resource=xeyes resource=NoResource
 *FvwmIconMan*resolution		desk
 *FvwmIconMan*action		Mouse 1 A sendcommand "Iconify -1", sendcommand "Focus", sendcommand "Raise"
 *FvwmIconMan*action		Mouse 2 A sendcommand "Iconify"
 *FvwmIconMan*action		Mouse 3 A sendcommand "Iconify -1", sendcommand "Focus", sendcommand "Lower"
 *FvwmIconMan*action		Mouse 1 S sendcommand "Iconify -1", sendcommand "Focus", sendcommand "Raise", sendcommand "WindowShade 2"
 *FvwmIconMan*action		Mouse 3 S sendcommand "Iconify -1", sendcommand "Focus", sendcommand "Raise", sendcommand "WindowShade 1"

Note that `WIDTH' is something defined by FvwmM4, which is called with
the -m4-prefix argument.  `helvetica-12' is aliased to the local
variant of helvetica 12 point in a local fonts.alias file.

--jim

############### jim knoble ######## [email-masked] #################

On Wed, 14 May 1997, sumeet singh wrote:

: 	It would be a good thing if FvwmIconMan could display icons
: horizontally also, rather than vertically only (as it does now). This
: would enable one to stick a task bar sort of thing at the bottom of
: the page.
: -- 
: Sumeet Singh, [email-masked], Institute of Systems Science, N.U.S.,