Subject: FVWM: Resize $1 $2 not working

From: Tim Phipps <[email-masked]>
Date: Fri, 2 May 1997 11:18:32 +0100 (BST)

I've just moved to 2.0.45 and am taking the opportunity to rationalize my 
functions.  One of the changes was to make my window warping function generic:

	AddToFunc my_cursorwarp		"I" WarpToWindow 50p 50p

	AddToFunc my_warp		"I" Resize $1 $2
	+				"I" Move $3 $4
	+				"I" my_cursorwarp

	AddToFunc my_topleft		"I" my_warp 616p 400p 0p 0p

When I bind a key thus

	Key KP_7	A	N	my_topleft

It doesn't work, it starts an interactive resize.  When I recode my_topleft to:

	AddToFunc my_topleft	"I" Resize 616p 400p
	+			"I" Move 0p 0p
	+			"I" my_cursorwarp

It works! What's going on?

BTW This is unpatched 2.0.45 (so far;-) on HP-UX 10.20 with only the following 
change to Fvwm.tmpl necessary to get it to compile (all the goodies are in)
#define FvwmCompiler c89
#define FvwmCompilerFlags -D_INCLUDE_HPUX_SOURCE -D_INCLUDE_POSIX_SOURCE 
-D_INCLUDE_XOPEN_SOURCE -D_INCLUDE_XOPEN_SOURCE_EXTENDED

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tim Phipps <[email-masked]>
Date: Fri, 2 May 1997 12:30:51 +0100 (BST)

Oh good grief! What a donkey I am.  $0 is the first arg to a function not $1.
	AddToFunc my_warp		"I" Resize $0 $1
	+				"I" Move $2 $3
	+				"I" my_cursorwarp
Works very nicely thank you.