Subject: Re: FVWM: FVWM does not draw window decoration around certain windows ....

From: [email-masked] (sumeet singh)
Date: Fri, 4 Apr 1997 15:31:25 +0800

Hi,
	The generic Style (*) is overridden by specific styles for windows.	
e.g. if I have a style called (*lock) all my windows like xlock, oclock will 
follow this style and other windows that don't have a specific style assigned to 
them will follow the (*) style. So, check up if you have a special style for the 
purify window type.

regards,	
sumeet
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Leitner <[email-masked]>
Date: Fri, 4 Apr 1997 09:32:43 +0200 (MET DST)

Hi Sumeet,

Thanks for your fast reply.

> them will follow the (*) style. So, check up if you have a special style for the 

I've already checked that but this is not the reason. The Purify window's
title is "Purify: xxxx" where "xxxx" is the exe I'm debugging. I did not
find any style in my .fvwm2rc file which matches that.

Maybe Purify uses some weird internal name which causes the fvwm style
mechanism to fail and not to match *any* of its styles including the "*"
style? Could this be the reason?

Thanks -- Tom

--------------------------------------------------------------------------
T o m   L e i t n e r                       Dept. of Communications
                                            Graz University of Technology, 
e-mail    : [email-masked]      Inffeldgasse 12
Phone     : +43-316-873-7455                A-8010 Graz / Austria / Europe
Fax       : +43-316-463-697
Home page : http://wiis.tu-graz.ac.at/people/tom.html
PGP public key on : ftp://wiis.tu-graz.ac.at/pgp-keys/tom.asc or send 
mail with subject "get Thomas Leitner" to [email-masked]
--------------------------------------------------------------------------

---

From: Kai Grossjohann <[email-masked]>
Date: 04 Apr 1997 11:36:50 +0200

>>>>> Thomas Leitner writes:

  Thomas> I've already checked that but this is not the reason. The
  Thomas> Purify window's title is "Purify: xxxx" where "xxxx" is the
  Thomas> exe I'm debugging. I did not find any style in my .fvwm2rc
  Thomas> file which matches that.

Use the FvwmIdentify module to see not only the window name but also
the resource name and class.  Fvwm matches all of those.

kai
-- 
A large number of young women don't trust men with beards.
(BFBS Radio)

---

From: Thomas Leitner <[email-masked]>
Date: Fri, 4 Apr 1997 12:17:50 +0200 (MET DST)

Hi Kai,

> the resource name and class.  Fvwm matches all of those.

Just tried it. It gives:

          Name:            Purify: xxxxx
          Icon Name:       Purify: xxxxx
          Class:           Purify
          Resource:        purify
          Window ID:       0x800001f
          Desk:            1
          Width:           519
          Heigth:          441
          BoundaryWidth:   0
          Sticky:          No
          OnTop:           No
          NoTitle:         Yes
          Iconified:       No
          Gravity:         NorthWest
          Geometry:        149x280+621+0

I think the suspicious entries are "BoundaryWidth" and "NoTitle".

I've just tried to override that in the .fvwm2rc file with:

          Style "Purify*"  BorderWidth 8, Title, Handles, StartsOnDesk2

The "StartsOnDesk 2" works, but I still got no window decorations.

Any ideas?

Thanks -- Tom