Subject: Re: FVWM: FVWM does not draw window decoration around certain windows ....

From: [email-masked] (sumeet singh)
Date: Fri, 4 Apr 1997 19:48:56 +0800

> From [email-masked] Fri Apr  4 18:27 GMT 1997
> Date: Fri, 4 Apr 1997 12:17:50 +0200 (MET DST)
> From: Thomas Leitner <[email-masked]>
> X-Sender: [email-masked]
> To: Kai Grossjohann <[email-masked]>
> Cc: sumeet singh <[email-masked]>, [email-masked]
> Subject: Re: FVWM: FVWM does not draw window decoration around certain windows 
....
> Mime-Version: 1.0
> 
> 
> Hi Kai,
> 
> On 4 Apr 1997, Kai Grossjohann wrote:
> 
> > >>>>> Thomas Leitner writes:
> > 
> >   Thomas> I've already checked that but this is not the reason. The
> >   Thomas> Purify window's title is "Purify: xxxx" where "xxxx" is the
> >   Thomas> exe I'm debugging. I did not find any style in my .fvwm2rc
> >   Thomas> file which matches that.
> > 
> > Use the FvwmIdentify module to see not only the window name but also
> > the resource name and class.  Fvwm matches all of those.
> 
> Just tried it. It gives:
> 
>           Name:            Purify: xxxxx
>           Icon Name:       Purify: xxxxx
>           Class:           Purify
>           Resource:        purify
>           Window ID:       0x800001f
>           Desk:            1
>           Width:           519
>           Heigth:          441
>           BoundaryWidth:   0
>           Sticky:          No
>           OnTop:           No
>           NoTitle:         Yes
>           Iconified:       No
>           Gravity:         NorthWest
>           Geometry:        149x280+621+0
> 
> I think the suspicious entries are "BoundaryWidth" and "NoTitle".
> 
> I've just tried to override that in the .fvwm2rc file with:
> 
>           Style "Purify*"  BorderWidth 8, Title, Handles, StartsOnDesk2
> 
> The "StartsOnDesk 2" works, but I still got no window decorations.
> 
> Any ideas?
> 
> Thanks -- Tom
> 

Hi Tom,
	Can you try the foll. ?
	
	Style "Purify*" UseStyle "*"
	
	Theoretically this should work - but I ain't confident at all, because I 
have faced many problems with fvem2.0.45
	
sumeet
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Thomas Leitner <[email-masked]>
Date: Fri, 4 Apr 1997 14:05:16 +0200 (MET DST)

> have faced many problems with fvem2.0.45

No. This does not work either. Apparently the Purify window explicitly 
turns off its decorations or something.

Any more ideas anyone?

Thanks -- Tom

--------------------------------------------------------------------------
T o m   L e i t n e r                       Dept. of Communications
                                            Graz University of Technology, 
e-mail    : [email-masked]      Inffeldgasse 12
Phone     : +43-316-873-7455                A-8010 Graz / Austria / Europe
Fax       : +43-316-463-697
Home page : http://wiis.tu-graz.ac.at/people/tom.html
PGP public key on : ftp://wiis.tu-graz.ac.at/pgp-keys/tom.asc or send 
mail with subject "get Thomas Leitner" to [email-masked]
--------------------------------------------------------------------------

---

From: Kai Grossjohann <[email-masked]>
Date: 04 Apr 1997 14:08:54 +0200

>>>>> Thomas Leitner writes:

  Thomas> No. This does not work either. Apparently the Purify window
  Thomas> explicitly turns off its decorations or something.

  Thomas> Any more ideas anyone?

There is stuff about MWM specific settings in Fvwm.  Try those?

kai
-- 
A large number of young women don't trust men with beards.
(BFBS Radio)

---

From: Thomas Leitner <[email-masked]>
Date: Fri, 4 Apr 1997 14:11:51 +0200 (MET DST)

> There is stuff about MWM specific settings in Fvwm.  Try those?

I've already turned on almost all MWM lookalike settings in fvwm
but I'll check them out again.

Thanks -- Tom

---

From: Thomas Leitner <[email-masked]>
Date: Fri, 4 Apr 1997 14:23:20 +0200 (MET DST)

Hi everybody,

> > There is stuff about MWM specific settings in Fvwm.  Try those?

This was the problem. I had the following setting:

Style "*" MWMDecor

because I thought it would make Fvwm more compatible to MWM which does
not seem to be the case. After commenting it out, Purify comes up with a
standard window decoration as well.

Thanks to Kai Grossjohann <[email-masked]> and
          sumeet singh <[email-masked]>

for their help.

Tom