Subject: FVWM: Fvwm Audio problems

From: Marco Solari <[email-masked]>
Date: Wed, 16 Apr 1997 14:27:08 +0200

I'm quite a newbe, by the way ... I am
experiencing some problems with FvwmAudio
module under Linux (Linux 2.0.0, fvwm95-2 is
2.0.41f).
	Everything seems working fine, but I really
can't hear no sound at all (and I'm not getting
deaf, I hope ... ;-).
	The Audio module is up, after fvwm95-2 has
started; if I "cat sing.au > /dev/audio" my old
good 8 bits soundblaster chirps happily; the
device I use in the module setup section is (as
You guessed) "/dev/audio"; the player I use is
"rplay" (but I also tryed the internal player,
with not more luck).

	Can anybody suggest what am I doing wrong ?
Which test could I play ? which sort of debug
could I try ? Any advise is obviously welcome.
Thank You all in advance for boring You. Best
regards from Italy (o) .

	Marco Solari
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mark Boyns <[email-masked]>
Date: 16 Apr 1997 07:09:09 -0700

On 16 Apr 1997, Marco Solari wrote:

> I'm quite a newbe, by the way ... I am experiencing some problems
> with FvwmAudio module under Linux (Linux 2.0.0, fvwm95-2 is
> 2.0.41f).
> can't hear no sound at all (and I'm not getting deaf, I hope
> ... ;-).
> started; if I "cat sing.au > /dev/audio" my old good 8 bits
> soundblaster chirps happily; the device I use in the module setup
> section is (as You guessed) "/dev/audio"; the player I use is
> "rplay" (but I also tryed the internal player, with not more luck).
> 
> Which test could I play ? which sort of debug could I try ? Any
> advise is obviously welcome.  Thank You all in advance for boring
> You. Best regards from Italy (o) .

Show us your *FvwmAudio entries in your .fvwmrc.

---

From: David Nugent <[email-masked]>
Date: Thu, 17 Apr 1997 23:30:25 +1000

> 	Can anybody suggest what am I doing wrong ?

Is the rplayd daemon running? Is it configured correctly with
all of the sound files named in rplay.conf? Does "rplay <sound>"
play ok from the command line?

Regards,

David Nugent - Unique Computing Pty Ltd - Melbourne, Australia
Voice +61-3-9791-9547  Data/BBS +61-3-9792-3507  3:632/348@fidonet
[email-masked] [email-masked] http://www.blaze.net.au/~davidn/
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Richard A. Guay" <[email-masked]>
Date: Thu, 17 Apr 1997 12:03:29 +0000

> play ok from the command line?

More importantly, does the sound devices have the proper permissions. 
 The largest problem I keep having is the sound devices always coming 
up with read and write privalage only for root and the rplay daemon 
not running as root!

Richard A. Guay
Network Administrator and ASIC Design Engineer
ASIC International Inc.
[email-masked]
http://www.asicint.com