Subject: Re: FVWM: Compiling 2.0.45 on SCO 5.0.2

From: Jeff Zimmerman <[email-masked]>
Date: Mon, 28 Apr 1997 06:44:23 -0500 (CDT)

Your first problem may be the -Dsco define in your cc line?

(if you are on a sun)

Jeff Zimmerman
[email-masked]

>From [email-masked] Fri Apr 25 11:41 CDT 1997
>X-Authentication-Warning: explorer2.clark.net: maxwell owned process doing -bs
>Date: Fri, 25 Apr 1997 12:30:47 -0400 (EDT)
>From: Maxwell Spangler <[email-masked]>
>To: [email-masked]
>Subject: FVWM: Compiling 2.0.45 on SCO 5.0.2
>MIME-Version: 1.0
>X-Majordomo: 1.94.1
>
>
>I'm stuck on fvwm/add_window.c, anyone care to offer advice ? THANKS
>
>	cc  -b elf -X a -a ansi   -I. -I../libs    -Dsco -DSYSV   -DSHAPE -DACTIVEDOWN_BTNS -DINACTIVE_BTNS -DMINI_ICONS -DVECTOR_BUTTONS -DPIXMAP_BUTTONS -DGRADIENT_BUTTONS -DMULTISTYLE -DEXTENDED_TITLESTYLE -DBORDERSTYLE -DUSEDECOR -DWINDOWSHADE -DXPM  -c add_
>window.c
>"add_window.c", line 225: error: invalid token: ->TitleHeight
>"add_window.c", line 225: warning: improper pointer/integer combination: op "="
>"add_window.c", line 252: warning: integer overflow detected: op "<<"
>"add_window.c", line 380: error: invalid token: ->BorderStyle
>"add_window.c", line 380: error: left operand of "." must be struct/union object
>"add_window.c", line 382: error: invalid token: ->BorderStyle
>"add_window.c", line 382: error: left operand of "." must be struct/union object
>"add_window.c", line 477: error: invalid token: ->left_buttons
>"add_window.c", line 477: error: improper member use: flags
>"add_window.c", line 493: error: invalid token: ->left_buttons
>"add_window.c", line 493: error: improper member use: flags
>"add_window.c", line 506: error: invalid token: ->right_buttons
>"add_window.c", line 506: error: improper member use: flags
>"add_window.c", line 525: error: invalid token: ->right_buttons
>"add_window.c", line 525: error: improper member use: flags
>*** Error code 1 (bu21)
>
>
>Maxwell Spangler, Software Developer, One Call Concepts LS, Inc. Hanover, MD
>
>--
>Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
>To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
>message to [email-masked].
>To report problems, send mail to [email-masked].
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Maxwell Spangler <[email-masked]>
Date: Tue, 29 Apr 1997 15:26:35 -0400 (EDT)

Actually, I'm not on a SUN, but an SCO system.