Subject: FVWM: FVWM 2.0.45 & Solaris 2.5.1 (sparc)

From: [email-masked] (Brian Hechinger)
Date: Thu, 3 Apr 1997 09:10:01 -0500 (EST)

here is my problem, right out of the FAQ:

33) I'm compiling under SunOS/Solaris with gcc, but it's complaining
    that "Language 'F' is unknown".  What's the problem?

and here is the FAQ answer:

A: Your Imake setup is not right for using gcc.  It's trying to use
   some flags for the native compilers that gcc interprets
   differently.  Get your system admin to "fix" your setup for use
   with gcc, or try using the FvwmCompiler and FvwmCompilerFlags
   defines in the Fvwm.tmpl file to get it to work for you.

i tried FvwmCompiler and FvwmCompilerFlags and that didn't fix anything.
i can't exactly ask my sysadmin to "fix" the problem since this is my
personal SPARCstation 5 at home.  i'm the sysadmin there, and i'll be 
damned if i know how to fix it.  i looked through the mailing list archives
and didn't find anything that helped me.  if there is a web page that someone
has with the solution that would be great.  if not, i'll put the instructions
for getting it to work on Solaris on my web page (with the how to get Doug
Jones' PDP-8 emulator working under Solaris) and you can point the FAQ or the
FVWM home page to there.

thanks for the help...

oh, i'm a long time FVWM 1.x user (linux) and am curious what major changes
i'll have to make to my lifestyle to start using 2.x

thanks again,

-brian

Brian Hechinger					Email: [email-masked]
Customer Support				Phone: 614.575.6350 x 140
AIC Projects CSF				Pager: 614.250.7076
Columbus, Ohio					FAX:   614.224.1935
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Kai Grossjohann <[email-masked]>
Date: 03 Apr 1997 16:25:11 +0200

>>>>> Brian Hechinger writes:

  Brian> i tried FvwmCompiler and FvwmCompilerFlags and that didn't
  Brian> fix anything.  i can't exactly ask my sysadmin to "fix" the
  Brian> problem since this is my personal SPARCstation 5 at home.
  Brian> i'm the sysadmin there, and i'll be damned if i know how to
  Brian> fix it.

I think you have to twiddle the DefaultCCOptions "#define" in sun.cf
or somesuch file in /usr/openwin/lib/X11/config.  A good value seems
to be "-DSYSV -DSVR4".

kai
-- 
A large number of young women don't trust men with beards.
(BFBS Radio)

---

From: [email-masked] (Graeme McCaffery)
Date: Thu, 3 Apr 1997 15:55:51 +0100 (BST)

to solve the imake problem I just insert the following lines to the imake file
I'm using:

#define USE_GCC
 
#ifdef USE_GCC
CC = gcc
CCOPTIONS = -Wall
CDEBUGFLAGS = -O2 -fomit-frame-pointer
#endif

----------
just put the above at the beginning of the imake file and continue as normal.
I never really bothered with trying to get my systems admin to change the 
system settings

hope this helps
Graeme

-- 
email: [email-masked]