Subject: FVWM: (no subject)

From: Jane Doe <[email-masked]>
Date: Wed, 16 Apr 1997 12:42:20 +0900

>                  Welcome to the Official FVWM Homepage
> 
>         Created: Jan 31, 1996 ----- Last Updated: Mar 27, 1997
> 
>                   (WARNING: still under construction)
> 
> 
>          -----------------------------------------------------
> 
> FVWM is an ICCCM compliant multiple virtual desktop window manager for
> X11 created by by Robert Nation and derived originally from twm code.
> THANKS ROB!!!
> 
> Rob has decided to pass the torch on though, so FVWM is now maintained
> by Charles Hines (me) with the help of various people all over the
> internet who are kind enough to use FVWM and submit patches,
> suggestions, etc.
> 
> Also, the mailing list and official ftp site have moved with the
> change in maintainer (see below).
> 
> ----------------------------------------------------------------------
> 
> Table Of Contents
> 
>    * Version Info
>    * Features
>    * FTP and Mailing List Info
>    * Mailing List Archive
>    * Docs, FAQ, & Other Info
>    * Other FVWM Related WWW Sites, etc
>    * LATEST FVWM NEWS (patches, announcements, etc)
> 
> ----------------------------------------------------------------------
> 
> Version Info
> 
>    * Last Official 1.xx Version: 1.24r
>    * Latest Official 2.xx Version: N/A (still in beta)
>    * Latest Beta Release: 2.0.45
> 
> Just click on the version numbers above to download them.
> 
> And please keep in mind that the Beta code can potentially become
> unstable or buggy at any time, so USE AT YOUR OWN RISK. You will of
> course find bugs in the more stable Officially released versions too
> (see the man page for a note on this). Please report new bugs to the
> FVWM Mailing List (see below).
> 
> I hope to have the First Official 2.xx Version (it'll be 2.1.0) out
> "Real Soon Now". It requires a little more polishing, like Doc
> updates, Compile/Install procedure fixes, some more bugfixes, etc.
> 
> ----------------------------------------------------------------------
> 
> Features
> 
> Features Common to 1.xx and 2.xx (quick list):
> 
>    * Multiple Disjoint Large Virtual Desktops
>    * Smaller memory usage (more so in 1.xx)
>    * Dynamically extensable via modules
>    * Recognizes Motif MWM hints
> 
> Features New to 2.xx (quick list):
> 
>    * New more powerful and sensible rc file format
>    * Change more features on per-window basis
>    * Change many features on the fly
> 
> ----------------------------------------------------------------------
> 
> FTP and Mailing List Info
> 
> The new Official FTP site for fvwm is
> 
>                     ftp://ftp.hpc.uh.edu/pub/fvwm/
> 
> and the new mailing list addresses are:
> 
>            [email-masked] (Discussion and questions list)
>                                   and
>           [email-masked] (Announcement only list)
>                                   and
>      [email-masked] (Beta testers and contributors list)
> 
> They are maintained by Jason Tibbitts, and are Majordomo based mailing
> lists. To subscribe to the list, send "subscribe fvwm" in the body of
> a message to [email-masked]. To unsubscribe from the list, send
> "unsubscribe fvwm" in the body of a message to [email-masked].
> 
> SUBSCRIPTION REQUESTS SENT TO THE LIST WILL BE IGNORED!!!! PLEASE
> FOLLOW THE ABOVE INSTRUCTIONS FOR SUBSCRIBING PROPERLY!!!!
> 
> To report problems with any of the mailing lists, send mail to
> [email-masked].
> 
> Also the mailing lists are now archived!
> 
> ----------------------------------------------------------------------
> 
> Docs, FAQ, & Other Info
> 
>    * FAQ (Frequently Asked Questions)
>    * Mailing List Archives
>    * The TO-DO list
>    * Manual Pages
>    * ChangeLog for current 2.xx Beta
> 
> ----------------------------------------------------------------------
> 
> Other FVWM Related WWW Sites, etc
> 
> Here's a few other sites (besides the official one) that have FVWM
> info:
> 
>    * T.J. Kelly's FVWM HomePage
>    * Liem Bahneman's
>    * Jens Frank's FVWM Page (Man Pages for 1.xx)
>    * Eric Kahler's FVWM Page
>    * Todd Gilmann's Collection of fvwmrc's (an ftp site)
> 
> And here's a few others that have info on programs that are designed
> to work with FVWM in some manner:
> 
>    * The Dotfile Generator Home Page - A program that helps you
>      generate .emacs, .cshrc, .fvwmrc, etc.
>    * The TkGoodStuff Home Page - A Tcl/Tk Program that performs like
>      GoodStuff/FvwmButtons.
> 
> And here's some window managers that were created from fvwm source,
> but PLEASE DON'T ASK QUESTIONS ABOUT THEM ON THE FVWM LIST, BUT RATHER
> CONTACT THE PARTIES RESPONSIBLE FOR THEM:
> 
>    * Bowman - A NeXT Lookalike created from 1.24r (gone?)
>    * AfterStep - A continuation of Bowman
>    * Fvwm95 - A hack of an fvwm2 beta that looks more like (shudder)
>      Win95
> 
> And here's an excellent site with all sorts of window manager
> information and comparisons:
> 
>    * Window Managers for X
> 
> Be sure to vote for FVWM in the voting section! :)
> 
> And don't forget about Newsgroups:
> 
>    * comp.windows.x.apps - for discussing and announcing apps like
>      FVWM.
>    * comp.windows.x - for general X11 discussions and advice.
> 
> ----------------------------------------------------------------------
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Thu, 17 Apr 1997 10:03:53 -0400 (EDT)

Hi
Sorry I am sure I am asking something that is well documented, but as yet I     
havntfound out where! 
I want to switch desktops from an external ( to fvwm2 (or fvwm) command , say 
from within another application or from an xterm session. For example I may want
to spawn an image that is being raytraced on Desk 0 1 whilst editing that file 
on Desk 0 0.
Can this be done? 
Phil
 
      ________________________________________________________                  

     E-Mail: [email-masked] or [email-masked]                           

     Time: 10:03:53                                                             
                    
     Date  17-Apr-97                                                            
                                   
     This message was sent by XF-Mail without the aid of MicroSoft!  
     _______________________________________________________
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Randy J. Ray" <[email-masked]>
Date: Thu, 17 Apr 1997 11:55:45 -0600

> to spawn an image that is being raytraced on Desk 0 1 whilst editing that file 

I have been playing around with the Desk command, but I am stumped on a few
things:

* How do you change between virtual screens on the same desk? "Desk 0 1" sends
  me to Desk 1.

* Is there a way to do any bounds checking on the desktop number? I don't use
  virtual desktops, just a 3x3 grid of virtual screens. "Desk 1" should cause
  an error, not spontaneously create Desk 1 and send me there.

Randy
--
===============================================================================
Randy J. Ray -- U S WEST Technologies IAD/CSS/DPDS         Phone: (303)595-2869
                Denver, CO                                     [email-masked]
"It's not denial. I'm just very selective about the reality I accept." --Calvin
===============================================================================
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Steve Fuhrman <[email-masked]>
Date: Thu, 17 Apr 1997 14:52:49 -0500 (CDT)

> * How do you change between virtual screens on the same desk? "Desk 0 1" sends

GotoPage row col 

worked just fine for me.  I found this info in the fvwm2-man.html documentation.

I bound these to F1-F4 for my 2x2 Desktop.

Note:  "EdgeScroll 100 100"  probably helps makes this work as you would expect.

-- 
===============================================================================
Steve Fuhrman                                     Work  : 214-860-6837
i2 Technologies, Inc.                             Fax   : 214-860-6067
1603 LBJ Freeway, Suite 780
Dallas, TX 75234                                  E-Mail: [email-masked]
===============================================================================
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].