Subject: Re: FVWM: FVWM 2.0.45 & Solaris 2.5.1 (sparc)

From: [email-masked] (Brian Hechinger)
Date: Thu, 3 Apr 1997 12:28:19 -0500 (EST)

[email-masked] said...
> 
> to solve the imake problem I just insert the following lines to the imake file
> I'm using:
> 
> 
> #define USE_GCC
>  
> #ifdef USE_GCC
> CC = gcc
> CCOPTIONS = -Wall
> CDEBUGFLAGS = -O2 -fomit-frame-pointer
> #endif
> 
> 
> ----------
> just put the above at the beginning of the imake file and continue as normal.
> I never really bothered with trying to get my systems admin to change the 
> system settings

hmm, your solution gave me an idea, sun.cf has an #ifdef section for HasGcc,
i tried putting #define HasGcc YES in several of FVWM's files, but nothing
seems to get through to sun.cf to tell it what to do.  my original solution
(it works, but is a pain) is to manually got through sun.cf and yank out
any non-gcc #define's.  works, but a pain.  anybody have an idea where i could
either define HasGcc or define it as YES and get it to sun.cf??  it really
doesn't matter since we don't have SUN's cc here at work or at my house (thank
the GODs) so mashing sun.cf into line is no problem, i'm just trying to work
on a general solution so we can get some better help into the FAQ for all 
future solaris/fvwm users.

-brian

Brian Hechinger					Email: [email-masked]
Customer Support				Phone: 614.575.6350 x 140
AIC Projects CSF				Pager: 614.250.7076
Columbus, Ohio					FAX:   614.224.1935
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tom Julien <[email-masked]>
Date: Thu, 03 Apr 1997 14:13:51 -0500

[email-masked] (Brian Hechinger) writes:
[...]
>seems to get through to sun.cf to tell it what to do.  my original solution

Unfortunately, imake parses these config files prior to
the fvwm Imakefile and template, so this won't help you
(as you've witnessed ;-).

>future solaris/fvwm users.

I would recommend putting "#define HasGcc YES" in site.def.
This file is read both before and after a specific <vendor>.cf,
so you'll want it to put it within the "BeforeVendorCF" ifdef.

The MIT/XC man page for imake shows a good rundown on the order
that it parses templates and rule files.  The whole Imake process
can be a little intimidating at first, especially with limited
documentation on some platforms, but it can be great tool with
it's own share of strengths.

Best of luck.

/*************************************************************
Thomas J. Julien                     E-Mail: [email-masked]
Enterprise Information Systems          Tel: 407-306-2685
Lockheed Martin Corp, Orlando, FL       Fax: 407-306-1881
*************************************************************/