Subject: Re: FVWM: Exec wasteful

From: "Randy J. Ray" <[email-masked]>
Date: Thu, 27 Mar 1997 17:30:15 -0700

> I use:
> 
> + "Terminal"          Exec exec xterm
> 
> Which seem to do what you want?

That will work, yes, but it seems like Fvwm should prepend "exec" automatically
when processing an Exec command. I understand using a shell (environment
variable expansions, etc.), but you don't expect to be using that top-level
shell for anything afterwards-- why not always use exec?

Randy
--
===============================================================================
Randy J. Ray -- U S WEST Technologies IAD/CSS/DPDS         Phone: (303)595-2869
                Denver, CO                                     [email-masked]
"It's not denial. I'm just very selective about the reality I accept." --Calvin
===============================================================================
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tobias Oetiker <[email-masked]>
Date: Fri, 28 Mar 1997 09:03:20 +0100 (MET)

> shell for anything afterwards-- why not always use exec?

you can use structures with several commands, then an exec would not ake
sens ... 

eg what should fvwm do to this menu entry ?

+ "netscape (WWW)"      Exec FVB_WWW=${FVB_WWW:-${WEBBROWSER:-'netscape -install'}}; exec ${FVB_WWW} &

cheers
tobi

PS this tries several environment variable to find the users favorite
webbrowser and if its not successfull it uses netscape

cheers
tobi

--
 ______    __   _
/_  __/_  / /  (_) Oetiker, Timelord & SysMgr @ EE-Dept ETH-Zurich
 / // _ \/ _ \/ / TEL:+41(0)1-6325286  FAX:+41(0)1-6321194
/_/ \___/_.__/_/ [email-masked] http://www.ee.ethz.ch/~oetiker

---

From: "Josh M. Osborne" <[email-masked]>
Date: Fri, 28 Mar 1997 09:58:13 -0500

In message <[email-masked]>, "Randy
>shell for anything afterwards-- why not always use exec?

If the user wants to do more then one action, like

Exec xset s blank ; xset s activate ; xlock ; xset s noblank

If you don't have anything like that you could try
doing:

ExecUseShell sh exec

I'm not sure if it would work, because I'm not sure if fvwm will
look for a shell named sh space exec, or for a shell called sh
and pass it exec and whatever comes on the Exec line.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Randy J. Ray" <[email-masked]>
Date: Fri, 28 Mar 1997 09:54:17 -0700

> + "netscape (WWW)"      Exec FVB_WWW=${FVB_WWW:-${WEBBROWSER:-'netscape -install'}}; exec ${FVB_WWW} &

Which supports my argument that there should be an alternate command (Execv,
perhaps) for executions that can safely skip the shell level. :-)

Randy