Subject: FVWM: Deiconifying windows

From: [email-masked] (Ross McCoy)
Date: Mon, 10 Mar 1997 08:34:32 -0600 (CST)

Hi,

I am new to this list, so forgive me if something like this has already
been asked. I have just switched from tvtwm to fvwm and am trying to use
the FvwmWindowList module to manage windows across all of my desktops. 
In tvtwm, when you deiconify a window through the window list, the window 
manager will pop you to the desktop which contains the icon of that window 
and you are set to do work. So far, I have only been able to get fvwm to pop
the window up into my active desktop. Is there anyway to get the same
effect as tvtwm i.e. change the desktop and deiconify the window?

Thanks,

Ross
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Kai Grossjohann <[email-masked]>
Date: 10 Mar 1997 15:52:53 +0100

>>>>> Ross McCoy writes:

  Ross> I am new to this list, so forgive me if something like this
  Ross> has already been asked. I have just switched from tvtwm to
  Ross> fvwm and am trying to use the FvwmWindowList module to manage
  Ross> windows across all of my desktops.

If you come from twm and go to fvwm, you'll love the FvwmIconMan
module (which is expressly built to be a replacement for the icon
manager for fvwm).

http://www.cs.arizona.edu/people/bradym/software/
ftp://ftp.cs.arizona.edu/people/bradym/FvwmIconMan

hth,
kai
-- 
because I couldn't think of a good beginning.

---

From: Jim Knoble <[email-masked]>
Date: Mon, 10 Mar 1997 15:41:13 -0500 (EST)

ross--

suggest you use FvwmIconMan instead.  there's been some recent mail on
the list indicating where to get the latest version (works only with
fvwm-2.0.45 and later).  it includes the functionality you ask about
below, with the addition of being significantly more configurable.  for
instance, this weekend i set up a task-bar-style icon managaer (complete
with mini-icons) using FvwmIconMan.  my config is below.

--jim

*FvwmIconMan*nummanagers	1
*FvwmIconMan*buttongeometry	128x24
*FvwmIconMan*managergeometry	8x1+0-0
*FvwmIconMan*font		helvetica-12
*FvwmIconMan*format		"%i"
*FvwmIconMan*background		DarkGray
*FvwmIconMan*foreground		Black
*FvwmIconMan*plainbutton	up
*FvwmIconMan*focusbutton	down
*FvwmIconMan*focusandselectbutton	down
*FvwmIconMan*selectbutton	up
*FvwmIconMan*title		{TaskBar}
*FvwmIconMan*iconname		{TaskBar}
*FvwmIconMan*drawicons		true
*FvwmIconMan*followfocus	true
*FvwmIconMan*sort		true
*FvwmIconMan*usewinlist		false
*FvwmIconMan*dontshow		resource=FvwmIconMan resource=FvwmPager resource=FvwmButtons resource=asclock resource=xmailbox resource=xeyes resource=NoResource
*FvwmIconMan*resolution		desk
*FvwmIconMan*action		Mouse 1 A sendcommand "Iconify -1", sendcommand "Focus", sendcommand "Raise"
*FvwmIconMan*action		Mouse 2 A sendcommand "Iconify"
*FvwmIconMan*action		Mouse 3 A sendcommand "Iconify -1", sendcommand "Focus", sendcommand "Lower"
*FvwmIconMan*action		Mouse 1 S sendcommand "Iconify -1", sendcommand "Focus", sendcommand "Raise", sendcommand "WindowShade 2"
*FvwmIconMan*action		Mouse 3 S sendcommand "Iconify -1", sendcommand "Focus", sendcommand "Raise", sendcommand "WindowShade 1"

##############  jim knoble  ######  [email-masked] ################

On Mon, 10 Mar 1997, Ross McCoy wrote:

: Hi,
: 
: I am new to this list, so forgive me if something like this has already
: been asked. I have just switched from tvtwm to fvwm and am trying to use
: the FvwmWindowList module to manage windows across all of my desktops. 
: In tvtwm, when you deiconify a window through the window list, the window 
: manager will pop you to the desktop which contains the icon of that window 
: and you are set to do work. So far, I have only been able to get fvwm to pop
: the window up into my active desktop. Is there anyway to get the same
: effect as tvtwm i.e. change the desktop and deiconify the window?
: 
: Thanks,
: 
: Ross
: --
: Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
: To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
: message to [email-masked].
: To report problems, send mail to [email-masked].
: