Subject: FVWM: startup window placement

From: John Harres <[email-masked]>
Date: Thu, 27 Mar 1997 15:09:12 -0700

When I log in and fvwm starts, it starts all of my applications first, then
finally, fvwm.  Since fvwm isn't around to handle the placement of the windows,
I get a big pile of windows in the upper left of my screen.

I realize that I could painstakingly put -geometry into the startup line for
each program, but I was wondering if there's any way to take advantage of the
SmartPlacement function of fvwm.

An acceptable alternative might be a way to tell fvwm to re-place all the
windows on the current screen.

Suggestions?

John Harres
[email-masked]
-- 
John Harres <[email-masked]>        http://horseman.uwyo.edu/~harres
<A HREF="http://www.uwyo.edu">University of Wyoming</A> 
Finger [email-masked] for PGP public key.
Key fingerprint =  FC B4 72 D6 37 A7 A1 73  BE 8B F3 E2 99 68 BF 5A 

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Kai Grossjohann <[email-masked]>
Date: 28 Mar 1997 12:04:36 +0100

>>>>> John Harres writes:

  John> When I log in and fvwm starts, it starts all of my
  John> applications first, then finally, fvwm.  Since fvwm isn't
  John> around to handle the placement of the windows, I get a big
  John> pile of windows in the upper left of my screen.

You could start Fvwm first then the other programs then a "logout"
client, such as xlogout.  On my University account I do this:

    xconsole -geoemtry -0-0 &
    fvwm &
    xterm &
    ...
    exec xlogout -geometry +0+0

Xlogout is a little program that displays a window with a button in
it.  When you click the button, it terminates.

hth,
kai
-- 
I wish my mouth had a backso^Hpace key.

---

From: "Josh M. Osborne" <[email-masked]>
Date: Fri, 28 Mar 1997 10:05:32 -0500

>I get a big pile of windows in the upper left of my screen.

If you don't mind making your startup fvwm dependent you could
start just fvwm from your .xinitrc (or .xsession), and
use the InitFunction to start all your apps.

If you want a non-fvwm specific solution, and you want exiting
fvwm to end you X session there is still a way.

You can do something more like this in your .xinitrc/.xsessionrc
(NOTE: the delay factors were hand tuned for a Sun3/50 with 4M of
RAM, no disk, X11R3, and twm; they could probbabably be made
smaller!!!):

# Stuff to start before the window manager
xrdb -load -retain $HOME/.Xresources
xconsole -geometry 450x120+0+0 -iconic &

# Set the window manager
TWM=fvwm

# Wait for the console to start
sleep 3

$TWM &
TWMNO=$!

# Wait for the window manager to start
sleep 6

# Now start as much cruft as you like
xload &
repeat 500 xterm &
netscape &

# This waits untill the windows manager exits.  As long as you
# don't add more stuff after it when you exit the window manager
# your X session will end.

wait $TWMNO