Subject: FVWM: How to run fvwm on an HP

From: "Michael J. Carter" <[email-masked]>
Date: Wed, 19 Mar 1997 09:26:51 -0700 (MST)

Anyone have a recipe for starting fvwm instead of VUE? Our HP's seem
to ignore my .xsession file.

Thanks in advance!

mjc

-- 
Michael J. Carter              | As the trials of life continue to take
[email-masked]               | their toll, remember that there is always a
Space Data Systems (NIS-3)     | future in Computer Maintenance. -- National
Los Alamos National Laboratory | Lampoon, "Deteriorada"
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Olivier Devaux <[email-masked]>
Date: Wed, 19 Mar 1997 17:38:44 +0100 (MET)

Hi,

Easy, but hard to find ... :

If your hp starts VUE then put :

exec /your/fvwm/command

at the beginning of your .vueprofile in your home directory

If your hp starts CDE then put :

exec /your/fvwm/command

at the beginning of your .dtprofile in your home directory

Olivier DEVAUX

[email-masked]

---

From: Jim Searle <[email-masked]>
Date: Wed, 19 Mar 1997 08:38:56 -0800 (PST)

>>>>> "Michael" == Michael J Carter <[email-masked]> writes:

    Michael> Anyone have a recipe for starting fvwm instead of VUE? Our HP's seem
    Michael> to ignore my .xsession file.

Yes they do ignore the .xsession by default, to change that you have to
modify /usr/vue/config/Xsession, or just put something like this at the
bottom of your .vueprofile:

exec $HOME/.xsession >&! $HOME/.xsessionlog

Jim

-- 
| Jim Searle, Design Engineer,   E-mail: [email-masked]     |
| Broadcom Corporation           Phone:  714-450-8700    __ O  |
| 16251 Laguna Canyon Road    Irvine, CA   92718       _ \ <_  |
| ____________________________________________________( )/ ( )_|

---

From: LAURENT DEGEILH <[email-masked]>
Date: Wed, 19 Mar 1997 17:52:34 +0100 (MET)

-> Michael J. Carter writes:
->  > 
->  > Anyone have a recipe for starting fvwm instead of VUE? Our HP's seem
->  > to ignore my .xsession file.
->  > 
->  > Thanks in advance!
->  > 
->  > mjc
->  > 

Le 19 Mar, Olivier Devaux a ecrit:
-> 
-> 
-> Hi,
-> 
-> 
-> Easy, but hard to find ... :
-> 
-> If your hp starts VUE then put :
-> 
-> exec /your/fvwm/command
-> 
-> at the beginning of your .vueprofile in your home directory
-> 
-> 
-> If your hp starts CDE then put :
-> 
-> exec /your/fvwm/command
-> 
-> at the beginning of your .dtprofile in your home directory
-> 

I start it another way.

I use a no-window session and run the x11start command whith
the following .x11start file...

# PMS Laurent DEGEILH       METEOFRANCE/SCEM/PREVIMAR #
# 42,Av G. Coriolis        Tel = (33/0) 5 61 07 82 63 #
# 31057 TOULOUSE           Fax = (33/0) 5 61 07 82 09 #
# FRANCE            e-mail = [email-masked] #
#! /bin/sh
#####################################################
### X Window System Starting-Configuration Script ###
#####################################################
###
###  This shell script sets initial X11 clients.  It is
###  passed as a parameter to xinit and run by xinit along with the 
###  X11 server.  When this script terminates the X Window System will
###  terminate.
###
###  1) Standard output and error output for programs started by this script
###  are redirected to $HOME/.x11startlog.  This avoids output to the screen
###  that would detract from the window display.  If an error occurs starting
###  X11, the logfile would be a good place to look for a clue to the problem.
###  You can view the file by typing ``more .x11startlog'' at the command
###  prompt of your home directory.

exec >$HOME/.x11startlog 2>$HOME/.x11startlog

###  2) Setup a default WMDIR if it is not set (for use by HP Windows/9000).

: ${WMDIR:="/dev/screen"}; export WMDIR

# if there was no $HOME/.Xdefaults, $doxrdb is set to
#    'xrdb -nocpp -load /usr/lib/X11/sys.Xdefaults'
# otherwise this is a nop.

$doxrdb
unset doxrdb 

###  4) The following X clients start as part of the initial window
###  system environment.  Users can change or add to these default clients
###  to set up a custom environment.  All clients started in this script
###  should be run in the background.
###
###  x11start can pass global parameters to this script.  For example,
###  it can pass a ``hostname:display.screen'' for all clients to use.
###  Another use would be to pass an additional parameter that
### all of the clients accept, such as "-xrm *foreground blue".  If the
### user does not pass in a parameter, '$@' is null.

/opt/hppd/bin/X11/fvwm2 $@ &   	# Start the Motif-based Window Manager.
#/usr/local/X11R5/bin/afterstep $@ &    # Start the Motif-based Window Manager.

sleep 5     # Allow time for initializing mwm before starting other clients.
hpterm -C -geometry 80x24+1+1 $@ &

###  Add client commands below, one command per line.
###  End each command line with an ampersand (&).

###  5) The following "wait" call ensures that all terminated
###  child processes are cleaned up (i.e., no <defunct> processes are
###  left around).

wait

###  6) All X clients started by this script have terminated at this point.
###  Now sleep forever (if this script terminates the window system will
###  be terminated).  When the window system is terminated with
###  [Shift][CTRL][Reset] this script will be killed.

exec sleep 2000000000

###  The window system is terminated when this script is terminated. ###

---

From: Henry McNair <[email-masked]>
Date: Wed, 19 Mar 1997 09:11:11 -0800

Unofficially speaking, I managed to change the /usr/vue/config/Xconfig file
on HPUX 10.10. I changed the line about Vuelogin*xdmMode. These lines now
look like:

############################################################################
#  To set a display to run the user's XDM $HOME/.xsession script as the
#  default session. Ensure that the $HOME/.xsession script is executable.
#
#  Vuelogin*xdmMode:           True
Vuelogin*xdmMode:           True

############################################################################

-------------------------------------------------------------------
Henry McNair                               [email-masked]
Hewlett-Packard 
11000 Wolfe Road, MS-42U5                  (408)447-1967 - voice
Cupertino, CA 95014                        (408)447-4924 - FAX
-------------------------------------------------------------------
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].