Subject: FVWM: Mapping win95 keys to FVWM functions

From: Jim Nicholson <[email-masked]>
Date: Sun, 16 Mar 1997 21:41:50 -0500

Sorry for a slightly off-topic post. I'd like to map the dead keys on
my new "natural" keyboard to fvwm actions. I understand the "key"
directive, and I have xkeycaps to help, but I can't seem to come up
with a xmodmap that will use the keys w/o some modifier (Alt, shift,
etc.) I remember a post about this, and I've been searching the web'd
archives for a while, but I can't seem to find this. Can someone help
out?

- Jim

-- 
- Jim Nicholson                        [email-masked]
- I spend 5 hours a day reading email and Usenet. Don't expect me to
- remember everything.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: James Frost <[email-masked]>
Date: Mon, 17 Mar 1997 10:53:43 +0000 (GMT)

I wanted to do the same thing. Its setup on my machine at home. I can't 
remember exactly what the codes were, but here is how to find out:

	1/ Run 'xev' in an xterm
	
	2/ Click on the xev window and hit the key you want to find
	   Note the keycode for the key
	
	3/ open .xinitrc in an editor and type the following

		xmodmap -e "keycode <one noted above> = Fxx"
	
	where xx is say 13 ('cos most PC keyboards only have function 
	keys up to F13')

	4/ open .fvwm2rc and add the following line

	Key F13 A A Menu Root Nop

	or whatever

Hope this helps....

		James Frost

	o 34 Blenheim Gardens, Highfield, Soton, S017 3RQ
	o Tel: (01703) 583 717
            
	o http://www.ecs.soton.ac.uk/~jaf195

---

From: Eric Kahler <[email-masked]>
Date: Mon, 17 Mar 1997 08:38:20 -0500

> archives for a while, but I can't seem to find this. Can someone help

	The following lines appear in a file called ".Xmodmap" which resides in
my home directory.  115 is the left window key, 116 is the right window
key, 117 is the "right click" key:

keycode 115 = Kanji
keycode 116 = Henkan
keycode 117 = Muhenkan
keycode 22 = BackSpace

	Then I have the following line in my .Xclients file.  It should go into
a file which is read upon startup of your X session.  This executes
xmodmap, and has it read the above keycodes, assigning them to usable
names:

xmodmap .Xmodmap
	
	Now the names can be bound to any functions or events in your .fvwmrc. 
I have my 2 window keys doing different things.

### Microsoft Keyboard special Keys and their Functions
Key Kanji       A       A       PopupUtils Utilities
Key Henkan      A       A       Prev [*] focus
Key Muhenkan    A       A       PopupOps Window-Ops

Luck++;
Eric.

-- 
From:  Eric Kahler.
[email-masked] 
http://mars.superlink.net/ekahler/index.html
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Niles <[email-masked]>
Date: Mon, 17 Mar 1997 07:52:50 -0600

First, you will need to use xev to find out the keycode of the win95
keys, as someone else mentioned.  The actual value of the keys will not
necessarily be the same on all computers.  My work and home computers
have different keycodes.

Another poster mentioned how to bind a function key to a win95 key.
I find it more useful to use the win95 keys as a modifiers.  What I do
is hit the win95 key (like a shift key) and then some other key to 
have it do window operations.

Here is my .xmodmaprc file

--------------- .xmodmaprc -------------------
! Add mod5 (Windows '95 icon key)
clear mod5
keycode 115 = Super_L
keycode 116 = Super_R
add mod5 = Super_L Super_R
--------------- End .xmodmaprc -------------------

The 115 and 116 will probably be different on your system. Then in my
.xesssion file (ran automaticaly), I put

xmodmap $HOME/.xmodmaprc

Now the win95 keys are mod 5.  Here are some lines from my .fvwm2rc.

# press arrow + Mod5 anywhere, and scroll by 1 page
Key Left	A	5	Scroll -100 0
Key Right	A	5	Scroll +100 +0
Key Up		A	5	Scroll +0   -100
Key Down	A	5	Scroll +0   +100

Key i	A	5	Iconify
Key l	A	5	Lower
Key q	A	5	Popup Quit-Verify
Key r	A	5	Raise
Key t	A	5	RaiseLower
Key x	A	5	Exec xlock -mode random

Hope you find this useful.

Dan Niles

-- 
#--------------------------------#
# Dan Niles      Signatures      #
# [email-masked]   should be small #
#--------------------------------#
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Kendrick Vargas <[email-masked]>
Date: Mon, 17 Mar 1997 10:41:33 -0500 (EST)

> archives for a while, but I can't seem to find this. Can someone help

Well, I know that under X (on my machine), the key with the arrow
pointing at a menu is called "Menu", and the Windows Icon keys are called
"Meta-R" and "Meta-L" depending on Left or Right... I have "Menu" bound to
bring up a list of window-ops if pressed within a window... And Although
this prolly isn't too great of an idea, I have Meta-L bound to a
RaiseLower if pressed within a window.. Hope this helps...
			-peace

-----BEGIN GEEK CODE BLOCK-----
GAT d- s:+ !a C+(+++) UI/L/S/B++(+++) P>+ L+(++) E---- W+++ N+ o? K?
w++++ O--- M-- V PS+++@ PE Y-- PGP+ t++ 5 X++ R- tv+ b DI++ D+ G e>* 
h*(!) r- y*(+)
------END GEEK CODE BLOCK------
"Life is when you shake it" -- me