Subject: FVWM: FvwmIconMan 0.9.7 bug?

From: [email-masked]
Date: Sun, 9 Mar 1997 02:24:45 -0500 (EST)

fvwm-2.0.45, FvwmIconMan-0.9.7:  anyone else experiencing the following?

have FvwmIconMan configured horizontally (to act similar to TaskBar in
fvwm95), with fixed geometry.  far right 20 or 25 pixels appear to be
cut off (i.e., root window shows through).  relevant configuration is
attached.

other than that, it appears to work quite nicely (thanks, Brady!).

--jim

##############  jim knoble  ######  [email-masked]  ################

AddToFunc "InitFunction"	"I" Module FvwmPager 0 0
+				"I" Module FvwmIconMan

AddToFunc "RestartFunction"	"I" Module FvwmPager 0 0
+				"I" Module FvwmIconMan

Style "FvwmIconMan"				NoBorder, NoHandles, NoTitle, StaysOnTop, Sticky

*FvwmIconMan*nummanagers	1
## the below evaluates to 96x20 for a screen resolution of 1024x768
*FvwmIconMan*buttongeometry	m4_eval(_WIDTH_ / 8)x20
*FvwmIconMan*managergeometry	8x1+0-0
## helvetica-12 is an alias for the appropriate helvetica font
*FvwmIconMan*font		helvetica-12
*FvwmIconMan*format		"%i"
*FvwmIconMan*background		DarkGray
*FvwmIconMan*foreground		Black
*FvwmIconMan*plainbutton	up
*FvwmIconMan*focusbutton	down
*FvwmIconMan*focusandselectbutton	down
*FvwmIconMan*selectbutton	up
*FvwmIconMan*title		{TaskBar}
*FvwmIconMan*iconname		{TaskBar}
*FvwmIconMan*drawicons		true
*FvwmIconMan*followfocus	true
*FvwmIconMan*sort		true
*FvwmIconMan*usewinlist		false
*FvwmIconMan*dontshow		resource=FvwmIconMan resource=FvwmPager resource=FvwmButtons resource=asclock resource=xmailbox resource=xeyes
##                              ^^^^^^^^^^^^^^^^^^^^
##  could this be the culprit? ___/
##
*FvwmIconMan*resolution		desk
*FvwmIconMan*action		Mouse 1 A sendcommand "Iconify -1", sendcommand "Focus", sendcommand "Raise"
*FvwmIconMan*action		Mouse 2 A sendcommand "Iconify"
*FvwmIconMan*action		Mouse 3 A sendcommand "Iconify -1", sendcommand "Focus", sendcommand "Lower"
*FvwmIconMan*action		Mouse 1 S sendcommand "Iconify -1", sendcommand "Focus", sendcommand "Raise", sendcommand "WindowShade 2"
*FvwmIconMan*action		Mouse 3 S sendcommand "Iconify -1", sendcommand "Focus", sendcommand "Raise", sendcommand "WindowShade 1"

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Sun, 9 Mar 1997 04:47:22 -0500 (EST)

On Sun, 9 Mar 1997 [email-masked] wrote:

: fvwm-2.0.45, FvwmIconMan-0.9.7:  anyone else experiencing the following?

  [...]

: *FvwmIconMan*nummanagers	1
: ## the below evaluates to 96x20 for a screen resolution of 1024x768
                          ^^^^^^^^^
: *FvwmIconMan*buttongeometry	m4_eval(_WIDTH_ / 8)x20

ack!  i mean, it evaluates to 128x20 for 1024x768.  sheesh.

--jim

---

From: Allen Brady Montz <[email-masked]>
Date: 09 Mar 1997 09:58:17 -0700

> ack!  i mean, it evaluates to 128x20 for 1024x768.  sheesh.

You're going to love this (or maybe not). With a screen size of 1024x768 you
will have exactly 24 pixels left over, since the FvwmIconMan that you have is
limited to a max width of 1000 pixels. It was left over from when FvwmIconMan
could only be one column, and then 1000 seemed like a fine limitation. I
haven't released another version since then, but since you've already been
editing the code, you should change line 718 of x.c from:

 sizehints.max_width = 1000;
to
 sizehints.max_width = globals.screenx;

There you go. I'll release a 0.9.7a which has this soon.

-- 
 Brady Montz
 [email-masked]

---

From: Allen Brady Montz <[email-masked]>
Date: 09 Mar 1997 10:06:03 -0700

Allen Brady Montz <[email-masked]> writes:

FvwmIconMan 0.9.7a is out. The only change is that the maxmimum width is no
longer 1000 pixels. It now is the screen width. If you haven't noticed this
limitation, there's no need to download.

As always, you can get it from:

http://www.cs.arizona.edu/people/bradym/software/
        or
ftp://ftp.cs.arizona.edu/people/bradym/FvwmIconMan