Subject: FVWM: Feature: Relative Resize

From: "Grochtmann Raphael M." <[email-masked]>
Date: Mon, 24 Mar 1997 16:49:00 -0000

Hi,

I recently changed from t(v)twm to fvwm2 and now I'm wondering
how it can be that such an extremely usefull feature like twm's
relative resize has been forgotten :-?
Twm is more open-minded than fvwm in not dictating the user where
to go with his mouse-pointer when he wants to resize a window.

Here's an excerpt from twm's manual page describing
  AutoRelativeResize
    This variable indicates that dragging out a window
    size (either when initially sizing the window with
    pointer Button2 or when resizing  it)  should  not
    wait  until  the  pointer  has  crossed the window
    edges.  Instead, moving the pointer  automatically
    causes  the  nearest  edge or edges to move by the
    same amount.  This allows the resizing of  windows
    that  extend  off  the edge of the screen.  If the
    pointer is in the center of the window, or if  the
    resize  is  begun  by  pressing a titlebutton, twm
    will still wait for the pointer to cross a  window
    edge  (to prevent accidents).  This option is par-
    ticularly useful for people who  like  the  press-
    drag-release  method of sweeping out window sizes.

So what do you think?

Gruesse aus Deutschland
     Raphael M. Grochtmann

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Kai Grossjohann <[email-masked]>
Date: 24 Mar 1997 16:50:42 +0100

>>>>> Grochtmann Raphael M writes:

  RG> I recently changed from t(v)twm to fvwm2 and now I'm wondering
  RG> how it can be that such an extremely usefull feature like twm's
  RG> relative resize has been forgotten :-?

I noticed that it isn't in fvwm, but I don't miss it.  Maybe this is
because, in W context, I have bound a mouse button to do resize.  In
particular:

,-----
| Mouse 3 WFSIT   4       Resize-or-Maximize
`-----

Where Resize-or-Maximize is the following function:

,-----
| AddToFunc Resize-or-Maximize	"M" Resize        
| +                               "D" Maximize 0 100
`-----

Btw, X modifier 4 is bound to my Alt key -- I've got a keyboard with
both Meta and Alt keys.  I have reserved Alt for the window manager
and never use it for any application.

kai
-- 
Life is hard and then you die.