Subject: FVWM: pixmap fvwmbuttons

From: [email-masked] (Graeme McCaffery)
Date: Wed, 12 Mar 1997 14:38:25 +0000 (GMT)

I've just patched the button module to allow pixmaps, unfortunately the whole
bar is not filled with the background pixmap.

where there are no icons the normal colour appears and i notice that when somthing is swallowed the border around it is the original colour

would it be possible to stop the module drawing the colour in the first place and drawing the pixmap instead.

nonetheless it does look great!.

p.s. are the fvwm icons standardised to a particular colour map? if so could a collection of backgrounds conform to this map and be available on the fvwm site?

Graeme

-- 
email: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Martin Cartwright SGC <[email-masked]>
Date: Wed, 12 Mar 1997 15:11:36 +0000 (GMT)

On Wed, 12 Mar 1997, Graeme McCaffery wrote:

> where there are no icons the normal colour appears and i 
> notice that when somthing is swallowed the border around it is the
> original colour
> 
Yeah I noticed this, but when I lock and then unlock the screen the pixmap 
fills in the spaces around swallowed apps. 

> nonetheless it does look great!.
Yes Indeedy!

> p.s. are the fvwm icons standardised to a particular colour map? if so
> could a collection of backgrounds conform to this map and be available
> on the fvwm site? 
> 

No they're not, at least the standard distribution ones aren't. 

And if you're on an 8-bit display like me then this can be a problem. 
If you have a set of icons like mine that share only 16 colours, then you
have more to spare for backdrops.

[email-masked] - http://star.pst.qub.ac.uk/~imc/vom.htm
-/-----------------------------------------------------------\-
|  "No challenge should be faced without a little charm,      |
|   and a lot of style."				      |
-\-----------------------------------------------------------/-

---

From: Dan Espen <[email-masked]>
Date: Wed, 12 Mar 1997 10:20:39 -0500

[email-masked] (Graeme McCaffery) writes:
> where there are no icons the normal colour appears and i notice that when som
> thing is swallowed the border around it is the original colour
> 
> p.s. are the fvwm icons standardised to a particular colour map? if so could 
> a collection of backgrounds conform to this map and be available on the fvwm 
> site?

I don't believe the icons have  been changed to  use a standard set of
colors, but I  recently submitted a patch  to the  "workers list" that
change's the icons colors to a "standard" set as they are displayed.

This would allow users  with 24 bit  color to display icons as-is, and
users with 8 bit color to restrict colors as desired.

I think   this is a  superior  solution,  and  hope that my  patch  is
included in the next release.

--
Dan Espen                                    Phone: (908) 699-5570
[email-masked]
444 Hoes Lane  Room RRC 1C-214
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].