Subject: FVWM: constantly switching logical screens in the FVWM desktop

From: Subodh Sharma <[email-masked]>
Date: Fri, 7 Feb 1997 16:21:22 -0500 (EST)

To all:

   - Here is something nifty I am trying to accomplish:

   - In fvwm, I want to go through all logical screens of 
     the desktop, one at a time, sleeping 10 seconds in betwwen
     switching logical screens.  I also want to have this continuously
     running.
   - In summary, The window manager should constantly keep on switching 
     through all the logical screens, with a 10 second delay.

   - Can someone please guide me in making this work!!

All help would be greatly appreciated!!

[email-masked]

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jamie Sparks <[email-masked]>
Date: Fri, 07 Feb 1997 16:32:04 -0500

> All help would be greatly appreciated!!

sorry to answer a ? with a ?, but...

How do you do this manually?  Ctrl-arrow?  I cannot get that to
work on mine...

jamie

---

From: Toshi Isogai <[email-masked]>
Date: Fri, 7 Feb 1997 16:04:14 -0700 (MST)

> All help would be greatly appreciated!!

If you have FvwmCommand working, a simple shell script like this will do
what you are looking for. You need to set FVWMLIB as your fvwm lib
directory and might need to use Desk command if you are using desks
instead of pages. 

Hope it helps.

-------------------------
#!/bin/sh
. $FVWMLIB/FvwmCommand.f
while [ "1" ] ; do
GotoPage 0 0 
sleep 10
GotoPage 0 1
sleep 10
GotoPage 1 0
sleep 10
GotoPage 1 1
sleep 10
done 
-----------------------------------------------------
Toshi Isogai   
KENTEK Information Systems
[email-masked]