Subject: FVWM: Trouble making fvwm-2.0.45 on Sol2.4

From: Leo Weijs <[email-masked]>
Date: Thu, 13 Feb 1997 14:18:59 +0000

Help!

It tried to make fvwm-2.0.45 on under Solaris2.4. Compilation goes
fine. However, if I do a Make install, everything goes wrong. The make
script executes the install command, of which the Solaris2.4 version has
the following syntax.

SYNOPSIS
     /usr/sbin/install -c dira [ -m mode ] [ -u user ]
          [ -g group ] [ -o ] [ -s ] file
     /usr/sbin/install -f dirb [ -m mode ] [ -u user ]
          [ -g group ] [ -o ] [ -s ] file
     /usr/sbin/install -n dirc [ -m mode ] [ -u user ]
          [ -g group ] [ -o ] [ -s ] file
     /usr/sbin/install -d|-i [ -m mode ] [ -u user ]
          [ -g group ] [ -o ] [ -s ] dirx ...
     /usr/sbin/install [ -m mode ] [ -u user ]
          [ -g group ] [ -o ] [ -s ] file [ dirx ...  ]

The makefile however, executes install -c file directory, so the order
of the two arguments is wrong.

Anybody recognizes this problem and knows how to solve it?
Perhaps someone has rewritten the MakeMakefiles for Solaris 2.4?

Leo Weijs.

-- 
******************************************************

  L.E. Weijs
  Groningen University Hospital (AZG)
  PET - Center
  Hanzeplein 1
  Groningen

  tel. 0031-50-3611360

  e-mail: [email-masked]

******************************************************
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Kai Grossjohann <[email-masked]>
Date: 13 Feb 1997 15:12:16 +0100

>>>>> Leo Weijs writes:

  Leo> It tried to make fvwm-2.0.45 on under Solaris2.4. Compilation
  Leo> goes fine. However, if I do a Make install, everything goes
  Leo> wrong. The make script executes the install command, of which
  Leo> the Solaris2.4 version has the following syntax.

You can set INSTALL to /usr/ucb/install in Fvwm.tmpl or Imakefile.  Or
you can correct it in your X setup.

kai
-- 
The arms should be held in a natural and unaffected way and never
be conspicuous. -- Revised Technique of Latin American Dancing
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].