Subject: FVWM: Move-or-Raise loses focus for ~1 sec.

From: Charles Karney <[email-masked]>
Date: Wed, 19 Feb 1997 16:09:11 -0500 (EST)

I'm running fvwm 2.0.45 on Solaris and Linux systems.  I have a vanilla
setup with .fvwm2rc containing:

    Mouse 1	TS	A	Move-or-Raise

    AddToFunc Move-or-Raise	"I" Raise
    +				"M" Move
    +  				"D" Lower

My problem is that a click of Mouse 1 on the title bar (to bring the window
up) causes the window to lose focus for about a second.

I'm a recent convert from twm, and this is something that twm did "right"
with 
          Function "move-or-raise" { f.move f.deltastop f.raise }

Any suggestions?

-- 
   Charles Karney
   Plasma Physics Laboratory	  E-mail:  [email-masked]
   Princeton University		  Phone:   +1 609 243 2607
   Princeton, NJ 08543-0451	  FAX:	   +1 609 243 3438
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Kai Grossjohann <[email-masked]>
Date: 20 Feb 1997 11:26:50 +0100

>>>>> Charles Karney writes:

  Charles>     Mouse 1	TS	A	Move-or-Raise

  Charles>     AddToFunc Move-or-Raise	"I" Raise
  Charles>     +				"M" Move
  Charles>     +  				"D" Lower

  Charles> My problem is that a click of Mouse 1 on the title bar (to
  Charles> bring the window up) causes the window to lose focus for
  Charles> about a second.

Fvwm waits to see if the click is a double click.  There's a timeout
for that which is by default set to 750 ms, I believe.  You can try to
click then immediately move the mouse a few pixels, focus should
return to the window quickly.

I think.

kai
-- 
A large number of young women don't trust men with beards.
(BFBS Radio)

---

From: Charles Karney <[email-masked]>
Date: Thu, 20 Feb 1997 10:24:25 -0500 (EST)

> From: Kai Grossjohann <[email-masked]>
> Date: 20 Feb 1997 11:26:50 +0100
> 
> >>>>> Charles Karney writes:
> 

Thanks.  Your suggestion leads to a reasonable (for me) solution: just
delete the "D" option of Move-or-Raise.

		--Charles Karney