Subject: FVWM: Trouble running fvwm under sol2.4

From: Leo Weijs <[email-masked]>
Date: Mon, 17 Feb 1997 11:08:09 +0000

I compiled and installed fvwm-2.0.45 on a Sun system with Solaris 2.4.
So far it went fine.
I work on an X-terminal, and use xdm to start X. I edited my .xinitrc to
start fvwm2 in stead of olwm, but fvwm2 won't start.
If I examine the /var/tmp/xdm-errors file I see the following error
message:

 System warning: Object 0x251b0, Permission denied, open of /dev/console
failed  (Tty package)
 fbconsole: open /dev/console: Permission denied
 ld.so.1: /usr/local/bin/fvwm2: fatal: libXpm.so.4.10: can't open file:
errno=2
 dsdm: another DSDM is already running
 896 Killed
 System warning: Object 0x251b0, Permission denied, open of /dev/console
failed  (Tty package)

So, it seems there is a problem opening libXpm, the library is in
/usr/openwin/lib.
My fvwm2 is in /usr/local/bin.

Anyone's got a clue?

Leo.
-- 
******************************************************

  L.E. Weijs
  Groningen University Hospital (AZG)
  PET - Center
  Hanzeplein 1
  Groningen

  tel. 0031-50-3611360

  e-mail: [email-masked]

******************************************************
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Kai Grossjohann <[email-masked]>
Date: 17 Feb 1997 11:19:49 +0100

>>>>> Leo Weijs writes:

  Leo> So, it seems there is a problem opening libXpm, the library is in
  Leo> /usr/openwin/lib.
  Leo> My fvwm2 is in /usr/local/bin.

(1) Start fvwm with the right LD_LIBRARY_PATH, like so:
    env LD_LIBRARY_PATH=/usr/openwin/lib:/usr/local/lib fvwm2 &
    Of course, you might need to change your LD_LIBRARY_PATH.  The
    output of "ldd /usr/local/bin/fvwm2" might give you a clue.

(2) Use the -R option to ld so that the library search path is
    recorded in the executable.  This needs to be done in the final
    linking step to produce the fvwm executable.

kai
-- 
The arms should be held in a natural and unaffected way and never
be conspicuous. -- Revised Technique of Latin American Dancing
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].