Subject: FVWM: FvwmWinList

From: Jochen Hayek <[email-masked]>
Date: 13 Feb 1997 13:45:33 +0100

Fvwm95's FvwmWinList (`FWL') is not behaving properly,
it's not strictly fixed to the left bottom of the screen,
instead it's also extending sometimes beyond the bottom.

And it's continuously moving to the right:
whenever you have a title longer than the ones used so far,
it's certainly resizing (i.e. growing) to the right _and_ to the left (1).
But if it's shrinking,
it's shrinking centerwards.
So you get a gap on its left side.
I think it should shrink on its right side.

Fvwm2's FvwmWinList behaves mostly properly.
(Although it's quite messy,
when you run the Tk installation tests,
where you also get many messages from the test scripts
about unexpected behaviour.)

Perhaps I shouldn't use FvwmWinList at all / any longer,
because WinList also does a quite good job.

But I like this batch of bars
listing those programs I'm interested in
(I'm using WindowListSkip)
since I used twm then.

I even suggest a strict left alignment for the strings listed there.

----

(1) to the left probably only,
    if there is (already) free space
    between the FWL and the left edge of the screen.

----

cheers

jh
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Kai Grossjohann <[email-masked]>
Date: 13 Feb 1997 13:55:55 +0100

>>>>> Jochen Hayek writes:

  jh> Perhaps I shouldn't use FvwmWinList at all / any longer, because
  jh> WinList also does a quite good job.

You want FvwmIconMan.  It's everything that twm-to-fvwm converts have
been waiting for.  New versions support MiniIcons.  Yay Brady!

kai
-- 
The arms should be held in a natural and unaffected way and never
be conspicuous. -- Revised Technique of Latin American Dancing
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].