Subject: FVWM: Autoraise or FvwmAuto?

From: "David P. Ihnen" <[email-masked]>
Date: Tue, 25 Feb 1997 15:45:30 -0800

One of my users wishes to have windows automatically raise when she moves
the mouse into them.  This sounds like FvwmAuto to me, so I tried
experimenting with it.  the result was the error:

FvwmAuto requires one arugument.

The syntax: (in my module menu definition)

+       "FvwmAuto"      Module FvwmAuto 200 raise lower

I can't comprehend what is going wrong here...

David

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (David Kennedy)
Date: Wed, 26 Feb 1997 00:20:08 GMT

>  I can't comprehend what is going wrong here...

Try simply having:
+	"FvwmAuto" 	Module FvwmAuto 200 

Like the error said, FvwmAuto only needs one argument.

In my init function I have the line:
+	"I" 		Module FvwmAuto 150

This is what you want. Starting it off a menu every
session is inconvenient.
-- 
David Kennedy, Dept. of Pure & Applied Physics, Queen's University of Belfast
Email: [email-masked] | URL: http://star.pst.qub.ac.uk/~dcjk/
      Hi! I'm a .signature virus! Copy me into yours and join the fun!       
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "David P. Ihnen" <[email-masked]>
Date: Tue, 25 Feb 1997 16:27:56 -0800

>This is what you want. Starting it off a menu every

Yes, that works... current problem solved.  

HOWEVER - this brings up the issue that according to the man page and
definition of FvwmAuto, you can have an optional additional two arguments
that will execute any valid operation on the window you're now in.  Like,
raise on enter and iconify on leave (Module FvwmAuto 0 raise iconify) - Why
does this feature not work?

I understand about starting it every session - I just testing at this point.

David

---

From: [email-masked] (David Kennedy)
Date: Wed, 26 Feb 1997 00:46:52 GMT

>  From [email-masked] Wed Feb 26 00:39:18 1997
>  Return-Path: <[email-masked]>
>  Message-Id: <[email-masked]>
>  X-Sender: [email-masked]
>  X-Mailer: Windows Eudora Pro Version 2.2 (32)
>  Mime-Version: 1.0
>  Date: Tue, 25 Feb 1997 16:27:56 -0800
>  To: [email-masked], [email-masked]
>  From: "David P. Ihnen" <[email-masked]>
>  Subject: Re: FVWM: Autoraise or FvwmAuto?
>  X-Lines: 38
>  Status: RO
>  

Ah, sorry. I misunderstood your question (I'd forgotten about the other params to
be honest). I assumed you were just having a 'Doh!' day and had misread the man
page or something.

I've just tried
+ 	"I"	Module FvwmAuto 150 Nop Iconify

and while it was very confusing (it uniconfied icons when I moved over them
for example) it worked fine.

Maybe its simply being very picky in syntax,
'raise'/'Raise'? 

I'd test it more but its time I went home!