Subject: FVWM: Re: [2.0.44/2.0.45] Bugs ??

From: [email-masked] (David S. Goldberg)
Date: 03 Feb 1997 11:16:15 -0500

>>>>> "NS" == Nadim Saeed <[email-masked]> writes:

NS> The 'EdgeScroll 0 0' works fine UNLESS you are moving a window in
NS> which case the scrolling is enabled.  I am not sure if this
NS> enabling of scrolling upon moving windows is intentional or
NS> whether this is a bug (I tend to believe its the later).

No, it's not a bug.  RTFM, particularly the section on EdgeResistance.

--
Dave Goldberg
Post: The Mitre Corporation\MS B305\202 Burlington Rd.\Bedford, MA 01730
Phone: 617-271-3887
Email: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Albrecht Kadlec)
Date: Tue, 4 Feb 97 18:05:21 +0100

>>>>> Nadim Saeed writes:

N> I'm a BIG fan of FVWM 
N>  (the Father-of-all Virtual Window Managers - isn't that what the F meant :-)

N> Here are a few things that I've noticed (bugs ?) using 2.0.45

Can't comment on the other ones, but:

N> 2. I have seen the same problem that Lance Brown ([email-masked])
N>    mentioned in his email about FvwmAuto (not being able to focus); I've been
N>    at times unable to focus on xterms when I was previously focused in some 
N>    application window such as Netscape/emacs.  I would have to leave the 
N>    xterm and enter it a few times before it finally focuses.  I know this is 
N>    not much of a description, but I can't really place it myself - it seems
N>    rather random.

Did you use the 2.0.45 FvwmAuto ?
Try my latest update at <URL:http://www.auto.tuwien.ac.at/~albrecht/fvwm2.html>
If you still have troubles with this version, tell me.

N>    I've also seen a problem with rxvt losing/recapturing focus.  If you 
N>    overlap your rxvt with any other window - say by 10% and briefly go to 
N>    the rxvt and return back, you'll notice that the focus keeps shifting 
N>    from the rxvt to the other window until you move your mouse deeper into
N>    one window or the other (if you don't move the mouse this shifting stays
N>    indefinitely).  Since I haven't been able to replicate this problem on 
N>    two normal xterms (ie. not involving rxvt), I'm assuming this is more a 
N>    problem with rxvt rather than FvwmAuto

think so, too.
can't imagine how this could be happening.

add this to your .fvwm2rc:

*FvwmAudioPlayCmd echo

*FvwmAudio new_page        "new page"        
*FvwmAudio new_desk	   "new desk"        
*FvwmAudio add_window	   "add window"      
*FvwmAudio raise_window	   'raise window'    
*FvwmAudio lower_window	   'lower window'    
*FvwmAudio configure_window "configure window"
*FvwmAudio focus_change	   "focus change"
*FvwmAudio destroy_window  "destroy window"  
*FvwmAudio iconify	   iconify         
*FvwmAudio deiconify	   deiconify       
*FvwmAudio window_name	   "window name"     
*FvwmAudio icon_name	   'icon name'       
*FvwmAudio res_class	   `res class`       
*FvwmAudio res_name	   'res name'        
*FvwmAudio end_windowlist  end_windowlist  
*FvwmAudio icon_location   icon_location   
*FvwmAudio map		   map             
*FvwmAudio error	   error           
*FvwmAudio config_info	   "config info"  
*FvwmAudio end_config_info "end config info"
*FvwmAudio icon_file	   "icon file"   
*FvwmAudio default_icon	   "default icon"
*FvwmAudio string	   string
*FvwmAudio beep		   beep
*FvwmAudio mini_icon  	   mini_icon
*FvwmAudio startup	   "Welcome to the Machine"
*FvwmAudio shutdown	   "I am rebooting now"
*FvwmAudio unknown	   "goofed up"

Start FvwmAudio.

this will show you all events in fvwm2 stdout (written).
start fvwm2 from an xterm in foreground and watch the events, as you do the
above mouse movements again on an rxvt.

Also try with an xterm.

What's the difference?
Does rxvt generate additional focus events ?

albrecht
-- 
Another Holiday Inn, another temporary home,
  and an interviewer threatening me with a microphone,
  'Talk to me, won't you tell me your stories.'
So I talked about conscience and I talked about pain,
  and he looked out of the window and it started to rain,
  and I thought maybe I've already gone crazy.
So I reached for the bottle and he reached for the door,
  and I picked up the sleeping pills crushed on the floor.
  Inviting me to casual obscenity.			-- Marillion
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].