Subject: Re: FVWM: Autoraise or FvwmAuto?

From: "David P. Ihnen" <[email-masked]>
Date: Tue, 25 Feb 1997 16:56:49 -0800

At 12:46 AM 2/26/97 GMT, David Kennedy wrote:
>
>>  From [email-masked] Wed Feb 26 00:39:18 1997
>>  At 12:20 AM 2/26/97 GMT, David Kennedy wrote:
>>  >David said:
>>  >>  One of my users wishes to have windows automatically raise when she
moves
>>  >>  the mouse into them.  This sounds like FvwmAuto to me, so I tried
>>  >>  experimenting with it.  the result was the error:
>>  >>  
>>  >>  FvwmAuto requires one arugument.
>>  >>  
>>  >>  The syntax: (in my module menu definition)
>>  >>  
>>  >>  +       "FvwmAuto"      Module FvwmAuto 200 raise lower
>>  >>  
>>  >>  I can't comprehend what is going wrong here...
>>  >
>>  >Try simply having:
>>  >+	"FvwmAuto" 	Module FvwmAuto 200 
>>  >
>>  >
>>  >Like the error said, FvwmAuto only needs one argument.
>>  >
>>  >In my init function I have the line:
>>  >+	"I" 		Module FvwmAuto 150
>>  >
>>  >This is what you want. Starting it off a menu every
>>  >session is inconvenient.
>>  
>>  Yes, that works... current problem solved.  
>>  
>>  HOWEVER - this brings up the issue that according to the man page and
>>  definition of FvwmAuto, you can have an optional additional two arguments
>>  that will execute any valid operation on the window you're now in.  Like,
>>  raise on enter and iconify on leave (Module FvwmAuto 0 raise iconify) - Why
>>  does this feature not work?
>>  
>>  I understand about starting it every session - I just testing at this point.
>
>Ah, sorry. I misunderstood your question (I'd forgotten about the other
params to
>be honest). I assumed you were just having a 'Doh!' day and had misread the man
>page or something.
>
>I've just tried
>+ 	"I"	Module FvwmAuto 150 Nop Iconify
>
>and while it was very confusing (it uniconfied icons when I moved over them
>for example) it worked fine.
>
>Maybe its simply being very picky in syntax,
>'raise'/'Raise'? 
>
>I'd test it more but its time I went home!

It doesn't work for me... I get the same error again.

Why would I get that error?

David

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Albrecht Kadlec <[email-masked]>
Date: Thu, 27 Feb 97 00:34:32 +0100

> X-Sender: [email-masked]
> Sender: [email-masked]
> Precedence: list
> X-Majordomo: 1.94.1
> 

old versions. now one to three args are ok.

from the code: (last version, I submitted)

    if(argc < 7 || argc > 9)
    {
	fprintf(stderr,"FvwmAuto for fvwm-" VERSION " can use one to three arguments.\n");
	exit(1);
    }

so you must have an old version around.
maybe check your ModulePath (did you compile 2.0.45 locally and is
there a global path still in your ModulePath ?

> >>  does this feature not work?

should work, works for me & others.

> >Maybe its simply being very picky in syntax,

No. it sends the command to fvwm for execution and fvwm2 isn't picky
at all (strcasecmp's)

> >I'd test it more but its time I went home!

mee too.

> Why would I get that error?

as I said: old version. (maybe check your ModulePath)

albrecht
--
Home is where the heart lies, but if the heart lies ? -- Marillion