Subject: FVWM: config file organisation

From: [email-masked] (Graeme McCaffery)
Date: Wed, 26 Feb 1997 15:05:26 +0000 (GMT)

I hope that this request could be considered.

after using CDE for a while (I had no choice and have now resolved this) I find that it would be preferable to have a .fvwm directory in home that contains fvwmrc rather than the present situation.

it would be nice if fvwm seached first for $HOME/.fvwmrc
then $HOME/.fvwm/fvwmrc

and if the second was the case, then set an internal variable FVWMHOME to $HOME/.fvwm

this would make the spliting of a monlithic fvwmrc file an easier task both for users and administrators!

for instance each user would only have to create a .fvwm directory and copy a style file to change the colours of windows.
all other settings would remain unaffected and under the control of the administrator.

the present behaviour would be unaffected and I'm sure the change would require little overhead or code bloating.

Graeme

-- 
email: [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mike Dennison <[email-masked]>
Date: Wed, 26 Feb 1997 15:31:39 +0000 (GMT)

> all other settings would remain unaffected and under the control of the administrator.

We do something similar already here, using the standard .fvwm2rc, 
but using it as a very small file that reads site files:

----------- example .fvwm2rc start -------------------
 
# FVWM - F? Virtual Window Manager, Version 2.x (fvwm2) Configuration File
# Created April 1996
#  - Mike Dennison
 
# ====================================================================
# PATH Setup 
# Colon seperated unix directory paths for Modules, xpm files, and bitmaps
ModulePath /usr/local/lib/fvwm2
PixmapPath /wai/common/setups/pixmaps:/usr/include/X11/pixmaps:/usr/local/include/X11/pixmaps
IconPath   /usr/local/lib/fvwm2/icons:/usr/include/X11/bitmaps
# ====================================================================

Read /usr/common/setups/fvwm/styles
Read /usr/common/setups/fvwm/functions
Read /usr/common/setups/fvwm/modules
Read /usr/common/setups/fvwm/bindings
Read /usr/common/setups/fvwm/menus
Read /home/nav2/fvwm.extras

----------- example .fvwm2rc end -------------------

Any changes can either be made in the users fvwm.extras file, or
they can copy any of the other files and change their .fvwm2rc to
point to the right place. 

best wishes

Mike

----------------------------------------------------------------------
Mike Dennison,                           email: [email-masked]
Western Geophysical Company
Field Services, LONDON, England
Tel: 0181 585 4302
Fax: 0181 231 7152
----------------------------------------------------------------------

---

From: Dan Espen <[email-masked]>
Date: Wed, 26 Feb 1997 11:39:07 -0500

[email-masked] (Graeme McCaffery) writes:
> after using CDE for a while (I had no choice and have now resolved this) I fi
> nd that it would be preferable to have a .fvwm directory in home that contain
> s fvwmrc rather than the present situation.
> 
> for instance each user would only have to create a .fvwm directory and copy a
>  style file to change the colours of windows.

You can  get  this without change  to  fvwm2 by starting  fvwm2 with a
shell  that supplies the -f argument  to fvwm2.  In  the shell you can
even create the $HOME/.fvwm/fvwmrc files that you  want for first time
users.

--
Dan Espen                                    Phone: (908) 699-5570
[email-masked]
444 Hoes Lane  Room RRC 1C-214
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].