Subject: FVWM: Init function problem

From: [email-masked] (Igor Vaysenberg)
Date: Mon, 20 Jan 1997 16:52:12 +0000

Hi!
I jusst installed fvwm2.44 on SunOs 4.1.3_U1.

And there is a problem when fvwm started...
I mean that when fvwm started no one window is shown, and no one menu command
could be executed.
The screen is filled with default color, menu could be seen, but results of any
exec command from menu is unavaluable.
When I do restart fvwm everithing is return and works fine.

Here is InitFunction:

######################## Initialization Functions ############################
AddToFunc InitFunction 	"I" Module FvwmButtons
+ "I" Exec /usr/local/bin/zmail -gui -zcnlserv andromeda
+ "I" Exec $XPATH/plan -iconic
+ "I" Wait plan
+ "I" Desk 0 1
+ "I" run_emacs_sol fogo
+ "I" Wait Emacs
+ "I" Desk 0 0

The help is required ;)

-- 
+-----------------------------------------------------------------------+
| Igor Vaysenberg                    | Motorola Israel Ltd.             |
|   phone: +972-3-565-9849 (office)  | Cellular Software Engineering    |
|          +972-3-961-7155 (home)    | 3 Kremenetski St.                |
|     fax: +972-3-565-8424           | Tel-Aviv 67899                   |
|  e-mail: [email-masked] | Israel                           |
+-----------------------------------------------------------------------+
Why does man kill?  He kills for food.  And not only food: frequently
there must be a beverage.
		-- Woody Allen, "Without Feathers"
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Bill Perkins <[email-masked]>
Date: Mon, 20 Jan 1997 12:56:58 -0500 (EST)

> Hi!
Hi.
> + "I" Exec $XPATH/plan -iconic
^^^^^^^^^^^^^^^^^
remove this and all _should_ be fine.
I had the same problem when I first upgraded, and I had seen something about
"the infamouse Wait bug". When I removed the "Wait" statements from my startup,
everything worked just dandy.

Funny, I never tried the restart. Oh well. Live and learn!

			Regards,
			Bill

-------------------------------------------------------------------------------
________				 | Bill Perkins
       /  "Ship Arriving Too Late to     | [email-masked]
      /    Save a Drowning Witch"	 | programmer-at-large
     /  /\	        F. Zappa	 | ALL assembly languages done here.
-------------------------------------------------------------------------------