Subject: FVWM: M4 n' stuff...

From: Kendrick Vargas <[email-masked]>
Date: Fri, 31 Jan 1997 16:38:12 -0500 (EST)

I looked at the FvwmM4 manpage as well as the m4 man page... and I have
never used m4 before in my life. I tried incorporating it into my .fvwm2rc
file and I also called fvwm2 in my .xsession as:

	fvwm2 -f "FvwmM4 .fvwm2rc"

as ddescribed... I don't seem to be doing something correctly, either in
my .fvwm2rc or somewhere... I tried using the m4_ifelse thingy for
XORValue just to test... but I keep getting these errors:

[FVWM][executeModule]: <<ERROR>> No such module 'ELF' in ModulePath '/depot/fvwm-2.0.45/lib'
[FVWM][executeModule]: <<ERROR>> No such module '¼|3' in ModulePath '/depot/fvwm-2.0.45/lib'
[FVWM][executeModule]: <<ERROR>> No such module '§d' in ModulePath '/depot/fvwm-2.0.45/lib'
[FVWM][executeModule]: <<ERROR>> No such module '¹J' in ModulePath '/depot/fvwm-2.0.45/lib'
...<<<SNIP-OLA>>>...
[FVWM][executeModule]: <<ERROR>> No such module 'p_disp' in ModulePath '/depot/fvwm-2.0.45/lib'
[FVWM][executeModule]: <<ERROR>> No such module '@�' in ModulePath '/depot/fvwm-2.0.45/lib'
[FVWM][executeModule]: <<ERROR>> No such module '_prefix' in ModulePath '/depot/fvwm-2.0.45/lib'
[FVWM][executeModule]: <<ERROR>> No such module 'ð@à ( àð à(' in ModulePath '/depot/fvwm-2.0.45/lib'

What could I possibly be doing wrong? Is there an example .fvwm2rc
available which properly uses m4? The system I am running on is:

	SGI, IRIX 5.3, 32 RAM
	FVWM 2.0.45

Thanx for any help... and sorry for this newbie question :)
			-peace

-----BEGIN GEEK CODE BLOCK-----
GAT d- s:+ !a C+(+++) UI/L/S/B++(+++) P>+ L+(++) E---- W+++ N+ o? K?
w++++ O--- M-- V PS+++@ PE Y-- PGP+ t++ 5 X++ R- tv+ b DI++ D+ G e>* 
h*(!) r- y*(+)
------END GEEK CODE BLOCK------
"Life is when you shake it" -- me

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Eddy J. Gurney" <[email-masked]>
Date: Fri, 31 Jan 1997 16:50:20 -0500

> XORValue just to test... but I keep getting these errors:

Try using '-cmd' instead of '-f'.

I spent *days* trying to figure this out under 2.0.43...

Eddy

---

From: Makoto MATSUSHITA <[email-masked]>
Date: Sat, 01 Feb 1997 06:56:52 +0900

kvarga01> I looked at the FvwmM4 manpage as well as the m4 man page... 

Oh, manpage of FvwmM4 is too old... anyway, try

	fvwm2 -cmd "FvwmM4 .fvwm2rc"

'-f' option is only for file (like 'fvwm -f .fvwm2rc.modified'), not
for module execution. See manpage of fvwm also (section 'M4 PREPROCESSING').

-- -
Makoto `MAR_kun' MATSUSHITA