Subject: FVWM: faults in FVWM -- exits

From: Christopher Wolf <[email-masked]>
Date: Mon, 20 Jan 1997 18:33:56 -0600 (CST)

All,

While playing around with windowshade and decors, when I try to active
a windowshade setup, as below, FVWM faults and shuts down.  Anyone
know why?

Mouse   0       5       A       DoWindowShade
 
DestroyFunc DoWindowShade
AddToFunc   DoWindowShade
+       "I"     DoWindowShadeUp
 
DestroyFunc DoWindowShadeUp
AddToFunc   DoWindowShadeUp
+       "I"     WindowShade 1
+       "I"     ChangeDecor Up
+       "I"     DestroyFunc DoWindowShade
+       "I"     AddToFunc DoWindowShade "I" DoWindowShadeDown
 
DestroyFunc DoWindowShadeDown
AddToFunc   DoWindowShadeDown
+       "I"     WindowShade 2
+       "I"     ChangeDecor Down
+       "I"     DestroyFunc DoWindowShade
+       "I"     AddToFunc DoWindowShade "I" DoWindowShadeUp

DestroyDecor Up
AddToDecor   Up
+       ButtonStyle 5 Vector 4 50x75@1 25x25@1 75x25@1 50x75@0
+       ButtonStyle 2 Vector 5 45x45@1 55x45@1 55x55@0 45x55@0 45x45@1
+       ButtonStyle 4 Vector 5 45x45@1 55x45@1 55x55@0 45x55@0 45x45@1
+       ButtonStyle 6 Vector 5 45x45@1 55x45@1 55x55@0 45x55@0 45x45@1
 
DestroyDecor Down
AddToDecor   Down
+       ButtonStyle 5 Vector 4 50x75@1 25x25@1 75x25@1 50x75@0
+       ButtonStyle 2 Vector 16 20x20@1 30x20@1 50x40@1 70x20@1 80x20@1 80x30@0 60x50@0 80x80@0 70x80@0 50x60@0 30x80@0 20x80@0 20x70@0 40x50@1 20x30@0 20x20@1
+       ButtonStyle 4 Vector 12 50x10@1 25x35@1 40x35@1 40x60@1 25x60@1 50x85@1 75x60@0 60x60@0 60x35@0 75x35@0 50x10@0 50x10@1
+       ButtonStyle 6 Vector 12 10x50@1 35x25@1 35x40@1 65x40@1 65x25@1 90x50@1 65x75@0 65x60@0 35x60@0 35x75@0 10x50@0 10x50@1

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Andrew Veliath <[email-masked]>
Date: Mon, 20 Jan 1997 19:52:28 -0500 (EST)

> a windowshade setup, as below, FVWM faults and shuts down.  Anyone

Just to let you know, I can reproduce the core dump with the following:

DestroyFunc DoWindowShade
AddToFunc   DoWindowShade "I"     DoWindowShadeUp

I've examined the crash and there is some problem with ComplexFunction.
In other words, it has nothing to do with Decors or WindowShade (just to
let you know).  I'll look into the problem further if I have some time.

--
Andrew Veliath <[email-masked]>        http://www.rpi.edu/~veliaa
One day, all forms of communication will be superseded by a FAQ.
Finger for PGP Public Key
Key fingerprint =  51 56 5D 3E 51 43 8B 74  7C B2 E4 B6 84 8E 8B 08

---

From: Andrew Veliath <[email-masked]>
Date: Mon, 20 Jan 1997 20:14:47 -0500 (EST)

To follow-up, I'm not going to look into this further, but I think your
crashing it by destroying a function you are currently calling (i.e. your
mouse binding is bound to DoWindowShade which calls a function which
destroys DoWindowShade -- what does the function return to :-) !).  This
to me seems like a faulty rc setup (in the same vein as if you call a
function recursively).