Subject: FVWM: Out of date FvwmIconMan version if fvwm 2.0.44

From: Allen Brady Montz <[email-masked]>
Date: 16 Jan 1997 17:34:57 -0700

I've been told that the FvwmIconMan in fvwm 2.0.44 is version 0.8, which is
exactly 0.1 out of date. If you have a burning need, you can get the latest
from:

http://www.cs.arizona.edu/people/bradym/software/

The only changes are a new option which specifies whether to honor the window
list that fvwm maintains when deciding which windows to manage, and I fixed a
probable coredump-inducing bug. 

-- 
 Brady Montz
 [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tobias Oetiker <[email-masked]>
Date: Fri, 17 Jan 1997 06:14:39 +0100 (MET)

> probable coredump-inducing bug. 

a request:

I would like to have my iconman swallowed in the toolbar ... but as it keeps
changing size this is difficult ... wouldn't it be possible to have it
assume a fixed size and scrollbar for inclusion in the toolbar ?

I am no X programmer, otherwise I would send you a patch ... 

cheers
tobi

--
 ______    __   _
/_  __/_  / /  (_) Oetiker, Timelord & SysMgr @ EE-Dept ETH-Zurich
 / // _ \/ _ \/ / TEL:+41(0)1-6325286  FAX:+41(0)1-6321194
/_/ \___/_.__/_/ [email-masked] http://www.ee.ethz.ch/~oetiker

---

From: Allen Brady Montz <[email-masked]>
Date: 17 Jan 1997 10:57:47 -0700

Tobias Oetiker <[email-masked]> writes:

> > The only changes are a new option which specifies whether to honor the
> > window list that fvwm maintains when deciding which windows to manage, and
> > I fixed a probable coredump-inducing bug.
> 
> a request:
> 

I'm currently rewriting all of the X code for FvwmIconMan, firstly so that
it's as optimal as I can humanly make it with respect to redrawing, secondly
so that I can make it not keep unmapping and mapping itself, and thirdly to add
multiple columns, and the ability to grow horizontally as well as vertically. 

With multiple columns, and horizontal growth, it's very simple to bound the
size of the window, and have it just keep adding columns (which get
progreessively narrower, like the windows95 taskbar) as it adds icons. As with
any rewrite though, it's taking an unbounded amount of time as other things
have higher priority. I'm going to get back to it this weekend though.

As for a scrollbar, I hadn't thought of that. I'm not using any sort of widget
library though, so that could get tricky. I'll have to ponder the options.

---

From: Tobias Oetiker <[email-masked]>
Date: Fri, 17 Jan 1997 22:36:27 +0100 (MET)

> library though, so that could get tricky. I'll have to ponder the options.

the reason I am asking is, that I have found the following setup to be very
conveniant ...

[...]
*FvwmButtons(2x13, Frame 0, Padding 0 0,\
	Swallow(NoHints) FvwmIconBox FvwmIconBox)

[...]
# FvwmIconBox
*FvwmIconBoxPlacement left top
*FvwmIconBoxHilightFocusWin
*FvwmIconBoxBack        gray74
*FvwmIconBoxIconBack    LightSteelBlue3
*FvwmIconBoxIconFore    Black
*FvwmIconBoxIconHiBack  PaleVioletRed3
*FvwmIconBoxIconHiFore  Black
*FvwmIconBoxHideSC horizontal
*FvwmIconBoxMaxIconSize 69x0
*FvwmIconBoxSetWMIconSize       48x48
*FvwmIconBoxLines	1
*FvwmIconBoxPadding     1
*FvwmIconBoxSBWidth     8
*FvwmIconBox "Fvwm*" -
*FvwmIconBoxFont	10x9
*FvwmIconBoxMouse       1 Click RaiseLower
*FvwmIconBoxMouse       1 DoubleClick Iconify
*FvwmIconBoxFrameWidth	0 0
*FvwmIconBoxSortIcons	ResName

unfortuantely the IconBox does not like it, when its icon size is set to 0.
it complains loudly on every new window ... I have sent a bug report to the
list about this, but nobody seems to care ...

and looking at the diffs ftom 43 to 44 the code for the IconBox seems not to
ahve been changed much ... 

well that's why I thought your tool might prove to be more suited to the
task ...

cheers
tobi

---

From: Allen Brady Montz <[email-masked]>
Date: 17 Jan 1997 15:48:43 -0700

> the reason I am asking is, that I have found the following setup to be very

...

> well that's why I thought your tool might prove to be more suited to the

Yeah, I think it would be pretty conveniant too, but have never gotten around
to doing it.