Subject: FVWM: fvwm-2.0.44 problem on Solaris-x86-2.5.1

From: [email-masked] (William W. Austin)
Date: Mon, 20 Jan 1997 15:38:32 -0500

(I hope this is the right mailing list -- apologies if it is not...)

I retrieved the 2.0.44 on Friday of last week and have it compiled and running on both
Sparc and Intel Solaris-2.5.1.  On the Sparc side, no problems (yet, anyway); however,
on the Intel platform (same .fvwm2rc file on both, same locations, etc.), the "rubber
bands" which used to show up under 2.0.43 and earlier versions are gone.  This includes both
the outlines which appear when moving and the outline+"grid" which appears when resizing a
window such as an xterm.

On the x86 machine, I first compiled with the SunPro compiler (-xO3 for optimization) and then
discovered the problem.  So I went back and compiled without optimization to see if I was getting
an optimizer bug, and the results were identical.  Finally, I used gcc-2.7.2 with no optimization
and the same thing still occurs.  On the solaris-x86 platform the results are the same whether
I am running the Openlook server or XFree86 (x11r6.3).

I have not been able to track this one down yet -- has anyone seen this one before, and/or does
anybody have any suggestions?

Thanks,

William W. Austin		[email-masked]
				770 750-6954 voice // 770 750-7321 fax
===============================================================================
 "Correct usage is the dialect of the class that has the army.
          -- Robert A. Heinlein"
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Charles Hines" <[email-masked]>
Date: Mon, 20 Jan 1997 15:51:21 -0500

>>>>> "WA" == William W Austin <[email-masked]> writes:

WA> (I hope this is the right mailing list -- apologies if it is not...)

Yup - you got it right.

WA> I retrieved the 2.0.44 on Friday of last week and have it compiled
WA> and running on both Sparc and Intel Solaris-2.5.1.  On the Sparc
WA> side, no problems (yet, anyway); however, on the Intel platform
WA> (same .fvwm2rc file on both, same locations, etc.), the "rubber
WA> bands" which used to show up under 2.0.43 and earlier versions are
WA> gone.  This includes both the outlines which appear when moving
WA> and the outline+"grid" which appears when resizing a window such
WA> as an xterm.
....
WA> I have not been able to track this one down yet -- has anyone seen
WA> this one before, and/or does anybody have any suggestions?

I made a change to the default XORValue (from 255 to 1, which works a
little better when visual depth == 8), and visuals that are depth > 8
apparently like 255 better...

Just put the old value into your .fvwm2rc file to take care of that
little problem (XORValue 255).

Chuck