Subject: FVWM: EdgeScroll confusion

From: [email-masked] (Jeff Magill)
Date: Tue, 21 Jan 97 10:24:14 PST

I checked the todo list and FAQ, but I can't seem to find any mention of
how EdgeScroll affects move operations on windows.

Specifically, I have EdgeScroll set to "0 0" because I don't want to
change pages on my desktop when the mouse pointer hits the edge of the
screen (page).

I don't get any scrolls _except_ for when the mouse pointer hits the edge
of the screen when I'm moving a window.

Is this behavior some problem with EdgeScroll, and intended behavior, or
is it possible for the move function to bypass the EdgeScroll
restrictions?

Jeff
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Jeff Magill)
Date: Tue, 21 Jan 97 10:58:28 PST

Oops.  Forgot to mention that I'm using fvwm 2.0.43 on SunOs 4.1.4.

In case it's relevant, the way I start the move operation is either
using a menu or mouse-button bound to the Move function (I've been
assuming that was pretty standard):

----------.fvwm2rc

# This one moves and then raises the window if you drag the mouse,
# only raises the window if you click,  or does a RaiseLower if you double
# click
AddToFunc "Move-or-Raise" "M" Move
+              "M" Raise
+              "C" Raise
+              "D" RaiseLower

# This defines the most common window operations for the desktop
AddToMenu "desktop-window-ops" "Window Ops" Title
+              "Resize" Function Resize-or-Raise
+              "" Nop
+              "(De)Iconify Open (F17)" Iconify
+              "Quit" Close
+              "Destroy" Destroy
+              "" Nop
+              "(Un)Stick" Stick
+              "Move (Meta-F5)" Function Move-or-Raise
+              "Raise Front (F15)" Raise
+              "Lower Front (F15)" Lower
+              "(Un)Maximize" Function maximize_func
+              "" Nop
+              "ScrollBar" Module FvwmScroll 2 2

-----------