Subject: FVWM: fvwm 2.0.45 -- possible bug with title bar mouse bindings

From: Kai Grossjohann <[email-masked]>
Date: 26 Jan 1997 21:09:10 +0100

Hi there,

using 2.0.44, the following lines in .fvwmrc did what they should:

Mouse 1 T       A       Move-or-RaiseLower
Mouse 1 FS      A       Resize-or-RaiseLower

The "Mouse 1 T" line doesn't seem to take effect in 2.0.45, though --
hitting the left mouse button in the title bar invokes the
Resize-or-RaiseLower function.

Btw, I'm using a Win95 like look, i.e. I have NoInset and
HiddenHandles.  If that makes any difference...

Has anybody else seen this problem?
kai
-- 
I like both kinds of music.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Andrew Veliath <[email-masked]>
Date: Sun, 26 Jan 1997 15:16:10 -0500 (EST)

> Has anybody else seen this problem?

For what it's worth, on my setup (2.0.45), I can't seem to move my
undecorated transient windows, where with 2.0.43 I can.  btw, the Win95
look almost certainly makes no difference AFAIK... I know some stuff with
regards to moving windows has changed, but don't know what.

--
Andrew Veliath <[email-masked]>        http://www.rpi.edu/~veliaa
I'm not scared of anything because I'm scared of everything.
Finger for PGP Public Key
Key fingerprint =  51 56 5D 3E 51 43 8B 74  7C B2 E4 B6 84 8E 8B 08

---

From: Kai Grossjohann <[email-masked]>
Date: 27 Jan 1997 11:11:49 +0100

>>>>> Kai Grossjohann writes:

  Kai> Hi there, using 2.0.44, the following lines in .fvwmrc did what
  Kai> they should:

  Kai> Mouse 1 T       A       Move-or-RaiseLower
  Kai> Mouse 1 FS      A       Resize-or-RaiseLower

  Kai> The "Mouse 1 T" line doesn't seem to take effect in 2.0.45,
  Kai> though -- hitting the left mouse button in the title bar
  Kai> invokes the Resize-or-RaiseLower function.

The above is true for my Debian GNU/Linux system at home.  Here at
work, I've got a Solaris 2.5 machine.  And it's different: the two
lines work just fine, but the MouseFocusClickRaises option doesn't do
anything.

kai
-- 
Signature?  What signature?

---

From: Makoto MATSUSHITA <[email-masked]>
Date: Mon, 27 Jan 1997 19:41:10 +0900

grossjohann> And it's different: the two lines work just fine, but the
grossjohann> MouseFocusClickRaises option doesn't do anything.

Apply following patch (it was posted before to this list).

-- -
Makoto `MAR_kun' MATSUSHITA

Subject: Re: fvwm 2.0.45 ready -- first patch.
From: "Randall S. Winchester" <[email-masked]>
To: Charles Hines <[email-masked]>
Cc: The FVWM Discussion List <[email-masked]>, The FVWM Announce List <[email-masked]>, The FVWM Workers List <[email-masked]>
Date: Wed, 22 Jan 1997 17:59:15 -0500 (EST)

I have to apologize for not catching this. I neglected to send in a patch to
add_window.c for:
       12. Patch to make CLICKTORAISE define be GlobalOpts
           MouseFocusClickRaises option, from Randal Winchester

****Also the credit for this should not go to me. It should be given to;
Markus Gutschke <[email-masked]>

I just tried to make it easier for Chuck to put in the release...

Randall

diff -u -r1.2 add_window.c
--- 1.2 1997/01/22 22:31:52
+++ add_window.c        1997/01/22 22:34:34
@@ -622,10 +622,8 @@
                        &a,&b,&JunkChild);
   tmp_win->xdiff -= a;
   tmp_win->ydiff -= b;
-#ifndef CLICKTORAISE
-  if(tmp_win->flags & ClickToFocus)
+  if((tmp_win->flags & ClickToFocus) || Scr.MouseFocusClickRaises)
     {
-#endif
      /* need to grab all buttons for window that we are about to
        * unhighlight */
       for(i=0;i<3;i++)
@@ -638,9 +636,7 @@
                        ButtonPressMask, GrabModeSync,GrabModeAsync,None,
                        Scr.FvwmCursors[SYS]);
          }
-#ifndef CLICKTORAISE
     }
-#endif
   BroadcastConfig(M_ADD_WINDOW,tmp_win);
 
   BroadcastName(M_WINDOW_NAME,tmp_win->w,tmp_win->frame,

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm-workers" in the
body of a message to [email-masked].
To report problems, send mail to [email-masked].