Subject: FVWM: CleverPlacement Window Placement

From: Christopher Wolf <[email-masked]>
Date: Fri, 24 Jan 1997 17:40:10 -0600 (CST)

Re: fvwm-45

Not only do I see CleverPlacement avoiding the space once occupied by
iconified windows, but if I open a series of small windows on a
almost-blank screen, I notice CleverPlacement likes to stack them
against the most-right and most-bottom areas of the screen, making
them all look like the classic wind-blown snow in a large pane of
glass view.

Very pretty, but annoying.

-Wolf 
                     [[email-masked]]      
      Life would be so much easier if everyone read the manual. 

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Anthony Martin <[email-masked]>
Date: Fri, 24 Jan 1997 23:34:26 -0800 (PST)

> them all look like the classic wind-blown snow in a large pane of

CleverPlacement places windows so that there is a minimum amount of
overlap, so since you have (or had before iconifying) windows in the upper
left corner of the window, the place with the least amount of overlap is
in the lower right corner.  The real bug is that CleverPlacement doesn't
see that your window is iconified.  It seems that somehow the ICONIFIED
flag isn't getting set.

Again, I can't duplicate this myself, so if anyone who sees this problem
can send me their .fvwm2rc file that would help greatly.  (Hey, this is a
great way to collect some cool .fvwm2rc files :-))

Tony.

---

From: Ian Spielman <[email-masked]>
Date: Fri, 24 Jan 1997 20:56:25 +0000 (GMT)

Ok; here is my .fvwm2rc

# this is a sample .fvwmrc file for fvwm-2.
# Apparantly, you can retrieve sample .fvwmrc's from 
# 	ftp://ftp.best.com/pub/tdgilman/Fvwmrcs
# you can also submit your favourite .fvwmrc to
#	[email-masked] 
# if you want to.

# small up triangle
ButtonStyle 2 4 50x35@1 65x65@0 35x65@0 50x35@1
# small down triangle
ButtonStyle 4 4 50x65@1 35x35@1 65x35@1 50x65@0
# an X
ButtonStyle 6 13 26x29@1 34x21@1 50x35@1 70x21@1 79x29@1 63x48@0 79x65@1 70x75@0 50x61@0 34x75@0 26x65@0 44x48@1 26x29@0

XORvalue 4
#EdgeResistance 250 10
WindowFont		-adobe-times-bold-r-*-*-14-*-*-*-*-*-*-*
IconFont		-adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
#EdgeScroll 100 100

ModulePath /usr/lib/X11/fvwm2
PixmapPath /usr/include/X11/pixmaps/:/X11/fvwm2/pixmaps/
IconPath   /usr/include/X11/bitmaps/

HilightColor black  #005a5a
DeskTopSize 1x1
MenuStyle black grey60 grey40 -*-courier-medium-r-normal-*-*-120-*-*-m-*-iso8859-* fvwm 
ClickTime 750

ColormapFocus FollowsMouse
GlobalOpts SmartPlacementIsReallySmart

# define some new and cool styles...

AddToDecor Applications
	+ BorderStyle -- HiddenHandles NoInset
	+ TitleStyle LeftJustified Solid navy -- Flat
	+ TitleStyle Inactive Solid grey55 -- Flat
	+ ButtonStyle 1 MiniIcon -- Flat UseTitleStyle
	+ ButtonStyle 2 Pixmap buttons/w95_max.xpm -- Flat UseTitleStyle
	+ ButtonStyle 4 Pixmap buttons/w95_min.xpm -- Flat UseTitleStyle
	+ ButtonStyle 6 Pixmap buttons/mini-cross.xpm -- Flat UseTitleStyle
	+ HilightColor white navy

AddToDecor Utilities
	+ BorderStyle -- HiddenHandles NoInset
	+ TitleStyle LeftJustified Solid #005a5a -- Flat 
	+ TitleStyle Inactive Solid #005a5a  -- Flat
	+ ButtonStyle 1 MiniIcon -- Flat UseTitleStyle
	+ ButtonStyle 2 Pixmap buttons/w95_max.xpm -- Flat UseTitleStyle
	+ ButtonStyle 4 Pixmap buttons/w95_min.xpm -- Flat UseTitleStyle
	+ ButtonStyle 6 Pixmap buttons/mini-cross.xpm -- Flat UseTitleStyle
	+ HilightColor white #005a5a

# set the different styles for different applications

Style	"*"		UseDecor Applications, handlewidth 6, SmartPlacement
Style	"*"		color white/gray55,ClickToFocus
Style	"*"		IconBox 0 705 -1 768, ClickToFocus, DecorateTransient

Style	"Fvwm*"		NoTitle, NoHandles, Sticky, WindowListSkip,
Style	"Fvwm*"		BorderWidth 0,CirculateSkipIcon
Style	"FvwmPager"	BorderWidth 8, ClickToFocus 
Style	"FvwmTaskBar"	BorderWidth 4,HandleWidth 4
Style	"Wharf"		NoTitle, NoHandles, Sticky, WindowListSkip,
Style	"Wharf"		BorderWidth 0,CirculateSkipIcon

# set the styles for Utilities

Style	"xcalc"		UseDecor Utilities, NoButton 2, color white/#005a5a
Style	"xman"		UseDecor Utilities, NoButton 2, color white/#005a5a
#Style	"*mixer"	UseDecor Utilities, NoButton 2, color white/#005a5a
Style	"XPlaycd"	UseDecor Utilities, NoButton 2, color white/#005a5a
Style	"*clock"	UseDecor Utilities, NoButton 2, color white/#005a5a
Style	"*load"		UseDecor Utilities, NoButton 2, color white/#005a5a
Style	"xpost*"	UseDecor Utilities, NoButton 2, color white/#005a5a

#set the different icons for different applications

Style	"*"		Icon CheckMarkMonitor.xpm
#Style	"*mixer"	Icon xmixer.xpm
Style	"*nuplot*"	Icon graphs.xpm
#Style	"Seyon*"	Icon DFUe.xpm
Style	"Wine*"		Icon WindowsLogoMonitor.xpm
Style	"emacs*"	Icon PlainTextOnPaper.xpm
Style	"TkMan*"	Icon BooksSideBySide.xpm
Style	"xldlas*"	Icon xldlas_logo.xpm
Style	"XMathemati*"	Icon mathematica.xpm
Style	"executor"	Icon Executor.xpm
Style	"rxvt"		Icon IntelInsideMonitor.xpm
Style	"XTerm"		Icon IntelInsideMonitor.xpm
Style	"xcalc"		Icon CPUChip.xpm
Style	"xman"		Icon BooksSideBySide.xpm
Style	"xgraph"	Icon StackedBlocksBehindRedBarsLetterQ.xpm
Style	"Pine" 		Icon LetterEnvelopeWithPencilAndPaper.xpm
Style	"ghostview"	Icon ghostview.xpm
Style	"xpaint"	Icon PaintBrushSplash.xpm
#Style	"ftp"		Icon ftp.xpm
Style	"Netscape"	Icon netscape3.xpm
#Style	"telnet"	Icon telnet.xpm
#Style	"xv"		Icon xv.xpm
Style	"xfig"		Icon BlueFeltDrawLetterD.xpm
Style	"XPlaycd"	Icon ColoredCompactDisc.xpm
Style	"nedit"		Icon text.xpm

#Style	"*"		NoIcon

#set the MiniIcons for applications

Style	"*"		MiniIcon buttons/mini-bx2.xpm
Style	"*Gimp*"	MiniIcon buttons/mini-paint.xpm
Style	"*load"		MiniIcon buttons/mini-perf.xpm
Style	"*clock"	MiniIcon buttons/mini-clock.xpm
Style	"xcmap"		MiniIcon buttons/mini-colors.xpm
Style	"XPlaycd"	MiniIcon buttons/mini-cdlabel.xpm
Style	"Netscape"	MiniIcon buttons/mini-nscape.xpm
Style	"rxvt"		MiniIcon buttons/mini-term.xpm
Style	"XTerm"		MiniIcon buttons/mini.xterm.xpm
Style	"xcalc"		MiniIcon buttons/mini-calc.xpm
Style	"pppload"	MiniIcon buttons/mini-perf.xpm
Style	"nedit"		MiniIcon buttons/mini-edit.xpm
Style	"xv"		MiniIcon buttons/mini-paint.xpm
Style	"xpost*"	MiniIcon buttons/mini.stick.xpm

#Ian's Desk Switching Keys.

Key F9          A       A       Desk 0 0
Key F10         A       A       Desk 0 1

Key F11         A       A       WindowsDesk 0
Key F12         A       A       WindowsDesk 1

Mouse 3	R   	A       Menu Utilities Nop
Mouse 2	R    	A      	Menu Window-Ops Nop
Mouse 1	R    	A      	WindowList
Mouse 1	1    	A      	Menu Window-Ops2 Close
Mouse 2 1       A       WindowList
Mouse 1 2       A       Maximize
Mouse 1	4    	A     	Iconify
Mouse 1 6       A       Close
Mouse 1	F	A	Resize-or-Raise
Mouse 1	S	A	Resize-or-Raise
Mouse 1	I	A	Move-or-Iconify
Mouse 1 T	A	Move-or-Raise
Mouse 2	I	A	Iconify
Mouse 2	FST	A	Menu Window-Ops2 Nop
Mouse 3	TSIF	A	RaiseLower

########################Initialization Functions ############################

AddToFunc InitFunction  
+                       "I"     Module  Wharf
+			"I"	Module	FvwmIconBox
+                       "I"     Exec    xmodmap -e 'clear lock'
+                       "I"     Exec    xmodmap -e 'add Mod2 Caps_Lock'
+			"I"	Exec    xmodmap -e 'remove mod1 = Alt_R' -e 'add mod3 = Alt_R'
+			"I"	Exec	xmodmap -e "keycode 107 = 0xffff"
+			"I" 	Exec	xmodmap -e "keycode 22 = 0xff08"
+			"I"	Exec	xsetroot -solid DarkSlateBlue
#+			"I"	Module	FvwmIconBox

#set right alt so I can use executor better
#I hate cap locks

AddToFunc RestartFunction       
+                       "I"     Module Wharf
#+			"I"	Module	FvwmIconBox

########################Menus ########################################
AddToMenu Utilities	"Utilities"	Title 	
+			"Xterm"		Exec  exec xterm &
+			"Rxvt"		Exec  exec rxvt &
+			"Remote Logins"	Popup Remote-Logins
+			"Top"		Exec  exec rxvt -T Top -n Top -e top &
+			"Calculator"	Exec  exec xcalc &
+			"Xman"		Exec  exec xman &
+			"Xmag"		Exec  exec xmag &
+			"emacs"		Exec  exec xemacs &
+                       "Mail"          MailFunction xmh "-font fixed"
+			""		Nop
+			"Modules"	Popup Module-Popup
+			""		Nop		
+			"Exit Fvwm"	Popup Quit-Verify
AddToMenu Window-Ops	"Window Ops"	Title		
+			"Move"		Move-or-Raise
+			"Resize"	Resize-or-Raise2
+			"Raise"		Raise
+			"Lower"		Lower 
+		 	"(De)Iconify"	Iconify
+			"(Un)Stick"	Stick		
+			"(Un)Maximize"	maximize_func
+			"Tile"		TileMenu
+			""		Nop  
+			"Delete"	Delete	 
+			"Close"		Close	 
+			"Destroy"	Destroy
+			""		Nop		
+			"Refresh Screen" Refresh		

AddToMenu Window-Ops2	"(Un)Stick"	Stick		
+			""		Nop     	
+			"Delete"	Delete	
+			"Close"		Close	  	
+			"Destroy"	Destroy

AddToMenu Remote-Logins	"hepserver"	Exec rsh hepserver rxvt -display $HOSTDISPLAY &
+			"snoopy" 	Exec rsh snoopy rxvt -display $HOSTDISPLAY &
+			"grumpy" 	Exec rsh grumpy rxvt -display $HOSTDISPLAY &
+			"happy"	 	Exec rsh happy rxvt -display $HOSTDISPLAY &
+			"bailey" 	Exec rsh bailey rxvt -display $HOSTDISPLAY &
+			"barnum" 	Exec rsh barnum rxvt -display $HOSTDISPLAY &
+			"joker"	 	Exec rsh joker rxvt -display $HOSTDISPLAY &
+			"signal" 	Exec rxterm signal

AddToMenu Module-Popup	"Modules"	Title	
+			"TaskBar"	Module	FvwmTaskBar
+			"Button-Bar"	Module	FvwmButtons
+			"Clean-Up"	Module	FvwmClean
+			"Identify"	Module	FvwmIdent
+			"SaveDesktop"	Module  FvwmSave
+			"Debug"		Module	FvwmDebug
+			"Pager"		Module  FvwmPager 0 1
+			"WinList"	Module  FvwmWinList
+			"Background"	Module  FvwmBacker
+			"IconBox"	Module	FvwmIconBox
+			"Banner"	Module	FvwmBanner
+			"Talk"  	Module	FvwmTalk
+			"Prompt"	Module	FvwmPrompt "hello" raise
+			"Backer"	Module  FvwmBacker
+			"Wharf"		Module  Wharf
+			"Wharf2"	Module  Wharf2

AddToMenu Quit-Verify 	"Really Quit Fvwm?" Title	
+		      	"Yes, Really Quit"  Quit	
+		      	"Restart Fvwm"	    Restart fvwm2
+		      	""		    Nop	
+		      	"No, Don't Quit"    Nop	

########################Function Menus ###################################

AddToMenu TileMenu
+       "&Horizontally"         FvwmTile -h -mn
+       "&Vertically"           FvwmTile -mn 
+       "&Cascade"              FvwmCascade -resize 0 0 90 90

########################Functions ########################################

AddToFunc MailFunction	   "I" Next [$0] Iconify -1
+		           "I" Next [$0] focus
+			   "I" None [$0] Exec $0 $1

AddToFunc Goto-Desk		"I" WindowsDesk $0

AddToFunc Move-or-Raise		"I" Raise
+				"M" Move
+  				"D" Lower

AddToFunc Move-Raise-Big	"M" Raise
+				"M" Move
+  				"D" Maximize

AddToFunc Move-or-Shade		"M" Raise
+				"M" Move
+  				"D" WindowShade

AddToFunc Maximize-Func		"M" Maximize

AddToFunc Move-or-Iconify	"I" Raise
+				"M" Move
+				"D" Iconify

AddToFunc Resize-or-Raise	"I" Raise
+				"M" Resize
+				"D" Lower

AddToFunc Resize-or-Raise2	"M" Raise
+				"M" Resize
+				"D" Lower

AddToFunc PrintFunction		"I" Raise
+				"I" Exec xdpr -id $w

################## Wharf button-bar ################################

# Start on the right top side of the screen
*WharfGeometry +960+0
*WharfColumns 1

# Change the textures

*WharfTextureType       1
*WharfTextureColor      #b3b3b3  #333333
*WharfMaxColors         32
*WharfAnimate

# Create a pullout "Folder" as the first button on Wharf
*Wharf  -		AfterStep.xpm	Folder
        *Wharf  Recycler        recycler.xpm    Restart fvwm2
        *Wharf  xlock           KeysOnChain.xpm Exec "-" xlock -mode random -duration 0 -allowroot -usefirst &
        *Wharf  Shutdown        shutdown.xpm    Quit
*Wharf  ~Folder

*Wharf	-		SciMath.xpm	Folder				
	*Wharf  mathematica     mathematica.xpm	Exec            exec mathematica &
	*Wharf  xldas           xldlas_logo.xpm	Exec            exec xldlas &
*Wharf	~Folder

*Wharf  -               FileFolders.xpm 		Folder
	*Wharf  pine            writeletter.xpm         Exec            exec rxvt -T "pine" -e pine &
	*Wharf  ical		MaelstromInFrame.xpm	Exec		exec ical &
*Wharf  ~Folder

*Wharf  Executor        Executor2.xpm           Exec            exec executor -nosplash -memory 10M -size 900x700 &
*Wharf  xplaycd         ColoredCompactDisc.xpm  Exec            exec xplaycd &
*Wharf  tkdesk          BWDialogEdit.xpm        Exec            exec tkdesk &
*Wharf  rxvt            IntelInsideMonitor.xpm  Exec            exec rxvt &
*Wharf  nil             nil                     DropExec        exec nedit %s
*Wharf  nedit           text.xpm                Exec            exec nedit &
*Wharf  nil             nil                     DropExec        exec gimp %s

*Wharf	-		Monalisa.xpm	Folder
	*Wharf  gimp            3dpaint.xpm             Exec            exec gimp &
	*Wharf	xv		xv.xpm			Exec		exec xv &
	*Wharf	xfig		BlueFeltDrawLetterD.xpm	Exec		exec xfig
*Wharf	~Folder	
	
*Wharf  nil             nil                     DropExec        exec netscape %s
*Wharf  Netscape        netscape3.xpm           Exec            exec x-exec &
*Wharf  config          Setup.xpm		Exec            exec nedit /X11/fvwm2/system.fvwm2rc &

########################## Window-Identifier ###############################
# Just choose colors and a fonts
*FvwmIdentBack MidnightBlue
*FvwmIdentFore Yellow
*FvwmIdentFont -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*

########################### Pager #########################################
*FvwmPagerBack #908090
*FvwmPagerFore #484048
*FvwmPagerFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmPagerHilight #cab3ca
*FvwmPagerGeometry -1-1
*FvwmPagerLabel 0 Misc
*FvwmPagerLabel 1 Maker
*FvwmPagerLabel 2 Mail
*FvwmPagerLabel 3 Matlab
*FvwmPagerSmallFont 5x8
#*FvwmPagerCall 0 xsetroot -solid steelblue
#*FvwmPagerCall 1 xsetroot -solid midnightblue
#*FvwmPagerCall 2 xsetroot -solid yellow
#*FvwmPagerCall 3 xpmroot /usr/include/X11/pixmaps/time.xpm

##########################FvwmWinList##################################
*FvwmWinListBack #908090
*FvwmWinListFore Black
*FvwmWinListFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmWinListAction Click1 Iconify -1,Focus
*FvwmWinListAction Click2 Iconify
*FvwmWinListAction Click3 Module "FvwmIdent" FvwmIdent
*FvwmWinListUseSkipList
*FvwmWinListGeometry +0-1

*FvwmBackerDesk 0 -solid steelblue
*FvwmBackerDesk 1 -solid midnightblue

#########################FvwmIconBox####################################
*FvwmIconBoxIconBack    Gray50
*FvwmIconBoxIconHiFore  black
*FvwmIconBoxIconHiBack  Gray50
*FvwmIconBoxBack        DarkSlateBlue
#*FvwmIconBoxFore       DarkSlateBlue
*FvwmIconBoxGeometry    12x1+0-0
*FvwmIconBoxMaxIconSize 64x64
*FvwmIconBoxFont        -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*
*FvwmIconBoxSortIcons   IconName
*FvwmIconBoxPadding     1
*FvwmIconBoxLines       12
*FvwmIconBoxSBWidth     11
*FvwmIconBoxPlacement   Left Top
*FvwmIconBoxPixmap      fvwm.xpm
*FvwmIconBoxHideSC Horizontal
*FvwmIconBoxSetWMIconSize
#*FvwmIconBoxHilightFocusWin
#*FvwmIconBoxResolution          Desk
*FvwmIconBox Wharf* -
*FvwmIconBoxMouse       1       Click           RaiseLower
*FvwmIconBoxMouse       1       DoubleClick     Iconify
*FvwmIconBoxMouse       2       Click           Iconify -1, Focus
*FvwmIconBoxMouse       3       Click           Popup Window-Ops
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].