Subject: FVWM: Re: your mail

From: "H. Otsu" <[email-masked]>
Date: Sat, 18 Jan 1997 07:57:09 +0900

Dear everyone, nice to meet you all.

  I have one bug-report for WindowShade on fvwm-2.0.44 recently
distributed.  

[PROBLEM]
A problem occurs when shading a window whose border 
width less than 1.  Error messages as follow are shown 
in console where fvwm2 is running.

----- error -----
[FVWM][FvwmErrorHandler]: <<ERROR>> *** internal error ***
[FVWM][FvwmErrorHandler]: <<ERROR>> Request 12, Error 2, EventType: 4
-----------------

Although the error messages are shown, everything does 
not look so bad.  

In addition, this problem does not occur on un-shading.

[TO BE FIXED]
After looking the source files on, I found inconsistency in
borders.c.
The file ./fvwm-2.0.44/fvwm/borders.c should be fixed at 
around 1500 line as:
-----
[original]
  cy = tmp_win->title_height + tmp_win->boundary_width-tmp_win->bw;
 
#ifdef WINDOWSHADE
  if (!shaded)
#endif
      XResizeWindow(dpy, tmp_win->w, tmp_win->attr.width,
                    tmp_win->attr.height);
  XMoveResizeWindow(dpy, tmp_win->Parent, cx,cy,
                    tmp_win->attr.width, tmp_win->attr.height);
[fixed]
  cy = tmp_win->title_height + tmp_win->boundary_width-tmp_win->bw;
 
#ifdef WINDOWSHADE
  if (!shaded) {
#endif
      XResizeWindow(dpy, tmp_win->w, tmp_win->attr.width,
                    tmp_win->attr.height);
  XMoveResizeWindow(dpy, tmp_win->Parent, cx,cy,
                    tmp_win->attr.width, tmp_win->attr.height);
#ifdef WINDOWSHADE
  }
#endif
-----
After patching these lines, shading runs good without
any errors.

--
	Hideaki Otsu	(大津 秀暁)  \  [email-masked]
      Nuclear Experiment Group, School of Science, University of Tokyo
    Tel/Fax:    048-467-9457 /  048-461-5301 (in RIKEN)

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Andrew Veliath <[email-masked]>
Date: Fri, 17 Jan 1997 18:13:22 -0500 (EST)

>   Dear everyone, nice to meet you all.
...

> After patching these lines, shading runs good without

Thanks.  I've tried it and it does exactly as you say.  I've made this
change to my all changes diff and put it in andrew5.2.0.44.diff.gz (with
change diff) in: 

http://www.rpi.edu/~veliaa/projects/fvwm_patches/dist/

--
Andrew Veliath <[email-masked]>        http://www.rpi.edu/~veliaa
One day, all forms of communication will be superseded by a FAQ.
Finger for PGP Public Key
Key fingerprint =  51 56 5D 3E 51 43 8B 74  7C B2 E4 B6 84 8E 8B 08