Subject: FVWM: Win'95 look to 2.0.44

From: Kai Grossjohann <[email-masked]>
Date: 17 Jan 1997 19:01:02 +0100

Hi,

I thought I'd tell y'all what I use to get a kinda-like Win'95 look.

Here's what I use:

,-----
| # Global styles				
| TitleStyle LeftJustified ActiveUp (Solid midnightblue -- flat) \
| 	  ActiveDown (Solid midnightblue -- flat) \
| 	  Inactive (Solid lightgrey -- flat)
| BorderStyle -- HiddenHandles, NoInset	
| ButtonStyle 1 MiniIcon -- UseTitleStyle flat
| ButtonStyle 2 Pixmap win95-maximize-full.xpm -- UseTitleStyle flat
| ButtonStyle 4 Pixmap win95-minimize-full.xpm -- UseTitleStyle flat
| 					  
| # Colors				
| HilightColor lightgrey grey45		
| #HilightColor black cornflowerblue	
| MenuStyle black lightgrey slategrey -adobe-helvetica-bold-r-normal--12-120-75-75-p-70-iso8859-1
| 					  
| WindowFont      -adobe-helvetica-bold-r-normal--11-80-100-100-p-60-iso8859-1
| IconFont        -adobe-helvetica-bold-r-normal--11-80-100-100-p-60-iso8859-1
| 					  
| #					
| # Style section				
| #					
| Style "*"		Color black/grey
| Style "*"		BorderWidth 5, HandleWidth 5
`-----

I also use the helvetica-11 and helevtica-12 fonts in a couple of
other places.  I'm not quite happy with the Pager and the IconMan
setup, though, and I'd appreciate any comments on the look that you
might have.  Here are the relevant lines:

,-----
| ########################### Pager #########################################
| *FvwmPagerBack lightgray   
| *FvwmPagerFore black	   
| *FvwmPagerFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
| #*FvwmPagerHilight slategray1
| *FvwmPagerHilight grey40   
| *FvwmPagerSmallFont 5x8	   
| 			     
| ##########################FvwmIconMan##################################
| *FvwmIconMan*resolution desk
| *FvwmIconMan*font -adobe-helvetica-bold-r-normal--12-120-75-75-p-70-iso8859-1
| *FvwmIconMan*format %t	   
| *FvwmIconMan*foreground black
| *FvwmIconMan*background lightgrey
| *FvwmIconMan*plainbutton up
| *FvwmIconMan*selectbutton flat white grey40
| *FvwmIconMan*focusbutton down white grey40
| *FvwmIconMan*focusandselectbutton flat black cornflowerblue
| *FvwmIconMan*followfocus true
| *FvwmIconMan*sort true	   
| *FvwmIconMan*drawicons true
`-----

In particular, I'd like the Pager to show in midnightblue the window
that currently has focus.

The dark grey colors don't look well (in the Pager and in the IconMan).

Why doesn't the focusandselectbutton line ever take effect?

Looking forward to your comments,
kai
-- 
Country music's here to stay!
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Andrew Veliath <[email-masked]>
Date: Fri, 17 Jan 1997 07:05:26 -0500 (EST)

> | TitleStyle LeftJustified ActiveUp (Solid midnightblue -- flat) \

You might want to try my Color buttons patch, which you could say (Color
midnightblue) so you will have matching relief and shadow colors. 

http://www.rpi.edu/~veliaa/projects/fvwm_patches/dist/ \
fvwm-2.0.44.av.colorbtns.diff.gz

Also, I have all of the Windows NT 4.0 color schemes on a menu for 2.0.44
(but the look is not Win95)  You can grab my genscheme 1.1 package off of
sunsite.unc.edu:/pub/Linux/Incoming to generate these.

Later,
Andrew