Subject: FVWM: tbsp8 Borderstyle/Multistyle/Uselook patch

From: Andrew Veliath <[email-masked]>
Date: Sun, 8 Dec 1996 17:41:21 -0500

I have a new patch, tbsp8 available.  First, it adds a new borderstyle
flag which supplements the HiddenHandles, NoInset (with this, you can
nearly duplicate fvwm95 look).  Also, *much* more code can now be
compiled out.  

Then, there is a new thing.  In response to people wanting different
"looks," there is a compile-time option to add code for general style
tagging which can be applied with the Style command to particular
windows.  Although it uses the Style command, it doesn't use a style
flag (but because of this even the *new* MiniIcons patch won't
patch... Brady? :) As a compile time option you can also disable the
use of multistyles (add/button/title styles).

After a lot of sweat here, with this, you have this new ability for
fvwm-2.0.43:

AddToLook CustomLook1
+ <button/border/titlestyle/hilight color command>
+ <etc.>
Style "-CustomLook1-" UseLook CustomLook1,HandleWidth 1,NoButton 2

AddToLook CustomLook2
+ <button/border/titlestyle/hilight color command>
+ <etc.>
Style "-CustomLook2-" UseLook CustomLook2,HandleWidth 4

Then you can do:

Style "*rxvt*" UseStyle -CustomLook1-
Style "*xterm*" UseStyle -CustomLook2-

I played around briefly and in about 10 minutes had an xterm which
look similar to NeXT and an rxvt which looked like W95 and a Netscape
which looked mwm, but the idea is that you can compile in USELOOK
support even without pixmap buttons/titlebars/borders/gradients and
at least use it to define window classes.

Here is an excerpt from the patched Fvwm.tmpl:

 * -DPIXMAP_TITLEBARS		!!!PATCH ADDITION!!!!
 * 
 * Allows use of the styled title-bars using the TitleStyle 
 * command in a similar fashion to the ButtonStyle command.
 * If Xpm support and PIXMAP_BUTTONS is compiled in,
 * then you can also use pixmaps on title-bars.
 *
 *
 * -DBORDERSTYLE		!!!PATCH ADDITION!!!!
 *
 * This compiles in support for different border styles using 
 * the BorderStyle command. See the man page entries for BorderStyle 
 * for detailed usage information.
 *
 *
 * -DGRADIENTS			!!!PATCH ADDITION!!!!
 *
 * Compiles in support for the use of both horizontal and 
 * vertical, linear and nonlinear gradients for buttons and 
 * title-bars. See the man page button style entries for
 * HGradient and VGradient for more information.
 *
 *
 * -DMULTISTYLE			!!!PATCH ADDITION!!!!
 *
 * Allows the use of stacked styles for buttons and title-bars.
 * There is a slight memory penalty for each stacked style
 * over the default ones. See AddButtonStyle and AddTitleStyle 
 * for more information.
 *
 * 
 * -DUSELOOK			!!!PATCH ADDITION!!!!
 * 
 * Allows the creation of tagged looks, any of which can be
 * assigned to a window using the UseLook Style command.  To create
 * "look" definitions, see the man page entries for AddToLook 
 * and DestroyLook.  There is a slight memory penalty for each added
 * look, probably at least 10k (more or less depending on previous
 * compile setings and individual styles).
 * 
 ***************************************************************************/

OPTION_DEFINES  = -DSHAPE
OPTION_DEFINES += -DPIXMAP_BUTTONS -DPIXMAP_TITLEBARS -DGRADIENTS
OPTION_DEFINES += -DMULTISTYLE -DUSELOOK

--
Andrew Veliath <[email-masked]>        http://www.rpi.edu/~veliaa
One day, all forms of communication will be superseded by a FAQ.
Finger for PGP Public Key
Key fingerprint =  51 56 5D 3E 51 43 8B 74  7C B2 E4 B6 84 8E 8B 08
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Allen Brady Montz <[email-masked]>
Date: 08 Dec 1996 17:40:38 -0700

> nearly duplicate fvwm95 look).  Also, *much* more code can now be

A miniicon patch for this is at:

http://www.cs.arizona.edu/people/bradym/software/miniicons.tbsp8.patch
	or
ftp://ftp.cs.arizona.edu/people/bradym/miniicon_patch/miniicons.tbsp8.patch

The patches for version 7 of the borderstyle patch are there as well.

-- 
 Brady Montz
 [email-masked]