Subject: FVWM: fvwm-2.0.43 "Style" with Icon breaks Iconbox

From: "David M. Meyer 541/346-1747" <[email-masked]>
Date: Thu, 19 Dec 1996 10:05:44 -0800 (PST)

If I have a style like this: 

		Style "XTerm" SloppyFocus,DecorateTransient,IconBox

	then xterms go into the Iconbox, but without an Icon. If
	I do this:

		Style "XTerm"   SloppyFocus, Icon xterm.xpm, IconBox

	then xterms get an icon, but they won't go into the
	IconBox. Is this a bug or just my misunderstanding of how
	this should work?

	Thanks,

	Dave

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jamie Sparks <[email-masked]>
Date: Thu, 19 Dec 1996 13:22:48 -0500 (EST)

Hello, 

  I'd like to stick my pager at a specific geometry,
so I set the FvwmGeometry variable to what I want,
but the pager is nevertheless "SmartPlace" 'd   
because I state I want SmartPlacement.  Is there
any way to get smart placement for all the windows
except the pager?

thanks, 

jamie

---

From: Jamie Sparks <[email-masked]>
Date: Thu, 19 Dec 1996 13:41:36 -0500 (EST)

One more thing,

  Whenever I invoke the pager, I'm always denied scrolling
access to half of it.  Does anyone know how to get rid of
this?

I.E. :

If this is my pager (representing 18 virtual desktops),
then I cannot scroll over the line consisting of d's
from either side of it.  I have to click with the pager.

-------------------------------------------------
|	|	|	d	|	|	|
|	|	|	d	|	|	|
|	|	|	d	|	|	|
|	|	|	d  	|	|	|
|	|	|	d	|	|	|
|	|	|	d	|	|	|
-------------------------------------------------
|	|	|	d	|	|	|
|	|	|	d	|	|	|
|	|	|	d	|	|	|
|	|	|	d	|	|	|
|	|	|	d	|	|	|
-------------------------------------------------
|	|	|	d	|	|	|
|	|	|	d	|	|	|
|	|	|	d	|	|	|
|	|	|	d	|	|	|
|	|	|	d	|	|	|
-------------------------------------------------

How do I get rid of this?

thanks,

jamie

---

From: Dan Espen <[email-masked]>
Date: Thu, 19 Dec 1996 14:04:36 -0500

> 	IconBox. Is this a bug or just my misunderstanding of how

Stange as it may seem, along with the name of the icon, you need NoIcon:

  Style "XTerm"   SloppyFocus, Icon xterm.xpm, NoIcon IconBox

This is in the man page.

--
Dan Espen                                    Phone: (908) 699-5570
[email-masked]
444 Hoes Lane  Room RRC 1C-214
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Charles Hines" <[email-masked]>
Date: Thu, 19 Dec 1996 16:58:42 -0500

>>>>> "JS" == Jamie Sparks <[email-masked]> writes:

JS> Hello,

JS>   I'd like to stick my pager at a specific geometry, so I set the
JS> FvwmGeometry variable to what I want, but the pager is
JS> nevertheless "SmartPlace" 'd because I state I want
JS> SmartPlacement.  Is there any way to get smart placement for all
JS> the windows except the pager?

Something like:

  *FvwmPagerGeometry -1-1

Should work fine for you (and not use SmartPlacement).  Works for me.

JS>   Whenever I invoke the pager, I'm always denied scrolling
JS> access to half of it.  Does anyone know how to get rid of
JS> this?

JS> I.E. :

JS> If this is my pager (representing 18 virtual desktops), then I
JS> cannot scroll over the line consisting of d's from either side of
JS> it.  I have to click with the pager.
....
JS> How do I get rid of this?

This is the difference between desktops and pages - the desktops are
disjoint so you cannot get to them via edge scrolling.

The next version of the FAQ contains the following description, to
clarify what is meant by a Desktop, a Page, and a Screen:

----------------------------------------------------------------------

27) What exactly is the differenct between a DESK, a PAGE, and the
    SCREEN?

A: Our naming convention is sometimes a source of confusion, and when
   discussing problems and the like it's good to maintain a consistent
   meaning.  To illustrate how features of fvwm should be referred to
   - fvwm has multiple disjoint DESKTOPS, each of which is comprised
   of M by N PAGES, which are each the size of the physical SCREEN.
   The physical SCREEN acts as a viewport over one of the PAGES of the
   current DESK.  Here's a picture to clarify (also, take a look at
   the FvwmPager module):

             Desk 0                     Desk 1
     +----------+----------+    +----------+----------+
     |          |          |    |          |          |
     | Page 0 0 | Page 1 0 |    |          |          |
     |          |          |    |          |          |
     |          |          |    |          |          |
     +----------+----------+    +----------+----------+
     |+--------+|          |    |          |          |
     ||Page 0 1|| Page 1 1 |    |          |          |
     ||        ||          |    |          |          |
     |+--------+|          |    |          |          |
     +----------+----------+    +----------+----------+

   It shows two 2 x 2 DESKTOPS.  If the current DESK were number 0,
   and the current PAGE were 0 1, the SCREEN would show only the
   windows located there, plus any sticky ones.

----------------------------------------------------------------------

If you want one big desk, change your DeskTopSize:

  DeskTopSize 6 3

Chuck

---

From: Jamie Sparks <[email-masked]>
Date: Thu, 19 Dec 1996 18:35:02 -0500 (EST)

> Should work fine for you (and not use SmartPlacement).  Works for me.

But how do I specify the specific position in which I want the pager
to appear?

thanks,

jamie