Subject: Re: FVWM: How to "ignore" application-specified icons?

From: [email-masked] (Martin Cartwright)
Date: Fri, 13 Dec 1996 15:51:05 +0000 (GMT)

=> From [email-masked] Fri Dec 13 15:46:49 1996
=> 
=> Is it possible to get FVWM to ignore application-specified icons? I
=> don't use FvwmIconBox or FvwmIconMan, just the standard "iconbox" Style
=> -- my icons end up on the desktop. 
=> 
=> The problem is that I really don't like big 24x24 or 32x32 icons. I much
=> prefer a simple box with just the window name in it (no graphics). This
=> is how my XTerms iconify. I want to force my XEmacs's and Netscapes to
=> do the same, but can't figure out how. 
=> 
=> Is there something I can set in my .fvwm2rc?  Maybe in my .Xdefaults?
=> I've tried to RTFM, but I can't find anything in the fvwm man page.
=> 
What you could try is creating a small blank xpm icon, say 10x1 pixels
and make all the pixels transparent. Call it blank.xpm or something similar 
and then override Netscape's icons with a line like

Style "Netscape" Icon blank.xpm 

in your .fvwm2rc.
Then when you restart you'll just have a little text box.

Good Luck

Martin. 

[email-masked] - http://star.pst.qub.ac.uk/~imc/vom.htm
-/===========================================================\-
|          "How the hell do you expect me to fly	      | 
|               if me rigger's in chokey?"    		      |
-\===========================================================/-
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Steve Tynor <[email-masked]>
Date: Fri, 13 Dec 96 11:38:17 EST

[email-masked] (Martin Cartwright) suggested:

| => From [email-masked] Fri Dec 13 15:46:49 1996
| => 
| => Is it possible to get FVWM to ignore application-specified icons? I
| => don't use FvwmIconBox or FvwmIconMan, just the standard "iconbox" Style
| => -- my icons end up on the desktop. 
| => 
| => The problem is that I really don't like big 24x24 or 32x32 icons. I much
| => prefer a simple box with just the window name in it (no graphics). This
| => is how my XTerms iconify. I want to force my XEmacs's and Netscapes to
| => do the same, but can't figure out how. 
| => 
| => Is there something I can set in my .fvwm2rc?  Maybe in my .Xdefaults?
| => I've tried to RTFM, but I can't find anything in the fvwm man page.
| => 
| What you could try is creating a small blank xpm icon, say 10x1 pixels
| and make all the pixels transparent. Call it blank.xpm or something similar 
| and then override Netscape's icons with a line like
| 
| Style "Netscape" Icon blank.xpm 
| 
| in your .fvwm2rc.
| Then when you restart you'll just have a little text box.

Thanks for the suggestion, but it didn't work. Here's the .xpm file I
created: 

	/* XPM */
	static char * transparent_xpm[] = {
	"40 1 1 1",
	" 	s None	c none",
	"                                        "};

and it's in my PixmapPath.

I set: 
	Style "*" Icon transparent.xpm

yet both my Netscape and XEmacs icons end up with big (64x64?) icons. 

For what it's worth, the XEmacs icons initially start out as I want them
(but then they did even before I specified this transparent.xpm icon),
but right after startup (after parsing the .emacs file), it seems that
XEmacs installs a new icon which overrides the original.  

I _can_, however, add this to my .emacs: 

 (if (boundp 'frame-icon-glyph)
    ;; XEmacs 19.14 installs a huge icon by default (19.13 and earlier didn't...)
    (set-glyph-image frame-icon-glyph "~/bin/transparent.xpm"))

to override Emacs's override.  But that still leaves me with big
Netscape icons.

Also: with a transparent XEmacs icon, if I try to move the icon, it goes
completely invisible -- not even the title is visible during the
move. This is different than my Xterm icons (which stay visible during a
move), so I guess this isn't exactly the same as whatever FVWN us doing
by default...

More ideas?

Steve