Subject: Re: FVWM: Reparent-bug in fvwm2

From: "Richard A. Guay" <[email-masked]>
Date: Mon, 11 Nov 1996 09:26:20 -0500

Actually, I made a mistake.  It is blt2.1 that is giving the recompile 
problem under tcl7.6/tk4.2.  Has anyone a fix for this app yet?

----------
> From: Richard A. Guay <[email-masked]>
> To: Michael Schumacher <[email-masked]>; [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Re: FVWM: Reparent-bug in fvwm2
> Date: Monday, November 11, 1996 9:08 AM
> 
> > Well, it will affect all applications based on TkSteal (and generally
> every
> > application which tries to reparentize other windows in a similar way
> > as TkSteal), but it seems this extension is rarely used in Tcl-land,
and
> > folks who use it probably still use fvwm1, mwm or any other window
> manager
> > which doesn't show this bug.
> 
> I would beg to differ with your opinion.  Anyone who uses TkDesk or
> tkgoodstuff also
> uses TkSteal.  These are fairly popular programs used with fvwm 2.43.  I
> use it all of 
> the time (but only with tcl 7.5/tk 4.1 since the version of TkSteal that
I
> have will not
> compile with the new tcl/tk release).  I have never had any problems with
> TkSteal, but
> I have never tried to swallow an xterm before.
> 
> Richard A. Guay
> Network Administrator and ASIC Design Engineer
> ASIC International Inc.
> [email-masked]
> http://www.asicint.com
> --
> Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
> To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
> message to [email-masked].
> To report problems, send mail to [email-masked].
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Michael Schumacher <[email-masked]>
Date: Mon, 11 Nov 1996 15:47:26 +0100 (MET)

Hi,
 
> problem under tcl7.6/tk4.2.  Has anyone a fix for this app yet?

Yep, just get a copy of an older Tcl release (7.5 and 7.6b1 are okay) and
add the function Tcl_CreatePipeline (from unix/tclUnixPipe.c) to BLT's
sources. Works fine for me.
 
> > Date: Monday, November 11, 1996 9:08 AM
[...]
> > I have never tried to swallow an xterm before.

I haven't used TkDesk or tkgoodstuff yet, but I doubt they use TkSteal to
incorporate the toplevel windows of external applications. If they did,
they'd be bitten by the reparent bug, just as "tkemacs" (a demo app
which comes with TkSteal and which runs Emacs in a Tk toplevel window).

Cheers,
mike