Subject: FVWM: inconify

From: Jamie Sparks <[email-masked]>
Date: Tue, 26 Nov 1996 12:26:36 -0500 (EST)

How does one cause a window to be automatically iconified upon login?

thanks,

jamie

---

From: Kai Grossjohann <[email-masked]>
Date: 26 Nov 1996 19:13:32 +0100

>>>>> Jamie Sparks writes:

  Jamie> How does one cause a window to be automatically iconified
  Jamie> upon login?

Either add the StartIconic option or start it like this:

    xterm -iconic &

The "-iconic" option is the trick.  Some programs do not grok this
option.  For those, you need StartIconic (that's an option in .fvwmrc
-- ``Style "xterm" StartIconic'').

kai
-- 
I wonder why nobody don't like me,
or is it de fact dat I'm ugly? -- Harry Belafonte
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: lar3ry gensch <[email-masked]>
Date: Tue, 26 Nov 1996 13:12:05 -0500

> How does one cause a window to be automatically iconified upon login?

AddToFunction "IconifyOrElse"
+	"I"	Next ["$0" !iconic] Iconify 1

AddToFunction "InitFunction"
+	"I"	IconifyOrElse WindowName

Where 'WindowName' is the name of the window you want to iconify.  You
can get the windowname using the FvwmIdentify Module.

-- 
(void) lar3ry();                                      [email-masked]

  "I'm sorry you saw me, Billy.  Now I'll have to kill you." -- Santa