Subject: FVWM: unable to compile without strerror

From: Jason Wong <[email-masked]>
Date: Thu, 14 Nov 1996 07:56:31 -0800

This may be a dumb question, but I am having problems compiling FVWM95  all 
the modules compile and even the fvwm95-2 however when I go to launch the 
app it reports that ld: undefined error strerror

Does anyone know where strerror can be found???

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Cameron Simpson <[email-masked]>
Date: Fri, 15 Nov 1996 09:33:58 +1100 (EST)

Jason Wong <[email-masked]> writes:
| This may be a dumb question, but I am having problems compiling FVWM95  all 
| the modules compile and even the fvwm95-2 however when I go to launch the 
| app it reports that ld: undefined error strerror
| Does anyone know where strerror can be found???

If there's not one ifdeffed into the source, use the one below.
But _all_ ANSI C implementations are required to supply this - what
platform are you compiling this on?
	- Cameron Simpson
	  [email-masked], DoD#743
	  http://www.zip.com.au/~cs/
--
I've seen things you people wouldn't believe.  Attack ships on fire off the
shoulder of Orion. I've watched C-beams glitter in the dark near the
Tannhauser Gate.  All these memories will be lost in time, like tears in rain.
	- Roy Baty, _Blader Runner_

#include	<errno.h>

/* inline strerror() routine for UNIX beasts - needs POSIXising, etc */
#define		Strerror(n)	(((n) < 0 || (n) >= sys_nerr) \
					? "error number out of range" \
					: sys_errlist[n])

#ifdef		cs_STDC_strerror

char *
strerror(       size_t	n)
{
	return Strerror(n);
}

#endif