Subject: FVWM: FvwmIconMan ftp site has moved to http

From: Allen Brady Montz <[email-masked]>
Date: 19 Nov 1996 13:42:50 -0700

Until this week, you could ftp the latest version of FvwmIconMan and
my MiniIcons patch to fvwm2.0.43 from mahler.cs.arizona.edu. 

Now, mahler has been decomissioned, and I don't have easy access to an
anonymous ftp server here (I'd have to actually ask somebody to get something
put there!) so I've moved all that to my webpage. You can find the latest
FvwmIconMan and whatever at:

http://www.cs.arizona.edu/people/bradym/software/

It seems to work for me, but if it doesn't work, please send me email and 
i'll fix it. 

-- 
 Brady Montz
 [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jason L Tibbitts III <[email-masked]>
Date: 19 Nov 1996 18:15:10 -0600

>>>>> "ABM" == Allen Brady Montz <[email-masked]> writes:

ABM> Now, mahler has been decomissioned, and I don't have easy access to an
ABM> anonymous ftp server here (I'd have to actually ask somebody to get
ABM> something put there!) so I've moved all that to my webpage.

So everyone knows, you can also upload things to
ftp.hpc.uh.edu:/pub/incoming/fvwm and let me know there's something new
there and I'll move it into the main distribution.  I think perhaps that
I'll set up something to mail me automatically.

 - J<

---

From: Jamie Sparks <[email-masked]>
Date: Wed, 20 Nov 1996 10:02:52 -0500 (EST)

Hello,

  I'm running fvwm95-2 and am having a config problem.

1. I would like my 3X2 virtual desktop to be sticky, but my attempts
   to add the "Sticky" param in the .fvwmrc file don't take.

2. I would also like to be able to move the virtual desktop window like
   I would an xterm.

3. Also, as it stands now, I have to move my mouse to one side to pull
   the virtual desktop in view, and once it's in view, any xterm I open
   up is halfway off the screen so I have to move it fully view both.
   It's as if each monitor-full of background screen is too small...
   How do I fix this?

my .fvwmrc file follows:         

thanks,

jamie

-----------------------------------------------------------------

#
# .fvwm2rc95 example configuration file for fvwm95-2.0.41
#

#======================================================================

#
# Fonts - one for window titles, another for icons, and another for the
#
WindowFont      -adobe-helvetica-bold-r-*-*-12-*-*-*-*-*-*-*
IconFont        fixed
MenuFont        -adobe-helvetica-medium-r-*-*-*-120-*-*-*-*-*-*

#
# Set the default window colors. The syntax is:
#  DefaultColors winforecolor winbackcolor titleforecolor titlebackcolo
# where:
#  winbackcolor    is the background (border) color of all windows,
#                  including the menu windows 
#
# Text and background color for the title bar of sticky windows
#
StickyColors    Red SteelBlue 

# You can also use the Style command to set the colors of individual
# title bars of some non-selected windows

#Style "*" ForeColor #c3c3c3
#Style "*" BackColor grey51

#======================================================================

#
# Set up the major operating modes
#

Style "*" ClickToFocus
Style "*" NoIcon
Style "*" MWMFunctions
Style "*" HintOverride
Style "*" MWMDecor

OpaqueMoveSize 100
#EdgeScroll 100 100
EdgeScroll 30 30
#EdgeResistance 10000 0
EdgeResistance 0 0

#
# RandomPlacement prevents user interaction while placing windows:
#
Style "*" RandomPlacement

#

DeskTopSize 3x2

#======================================================================

#
# Module path and paths to the icons
# ModulePath is a colon-separated list, just like regular unix PATH
#
ModulePath /usr/X11R6/lib/X11/fvwm95-2/
PixmapPath /usr/include/X11/pixmaps/:/usr/local/mini-icons/
IconPath   /usr/include/X11/bitmaps/:/usr/local/icons/

#======================================================================

# Set the decoration styles and window options
# Order is important!!!!
# If compatible styles are set for a single window in multiple Style
# commands, then the styles are ORed together. If conflicting styles
# are set, the last one specified is used.
# These commands should command before any menus or functions are defin
# and before the internal pager is started.

#
# Default border and handle widths
#
#Style "*" BorderWidth 5, HandleWidth 5
Style "*" BorderWidth 2, HandleWidth 2 

Style "Fvwm*"        NoTitle, Sticky, WindowListSkip
Style "Fvwm Pager"   NoTitle, StaysOnTop, NoHandles
#Style "FvwmButtons"  NoTitle, NoHandles, Sticky, WindowListSkip,Border
Style "FvwmButtons"  NoTitle, NoHandles, Sticky, WindowListSkip,BorderW
Style "*lock"        NoTitle, NoHandles, Sticky, WindowListSkip
Style "xbiff"        NoTitle,            Sticky, WindowListSkip

#
# Some mini-icons for the title bar
#
Style "*"         TitleIcon mini-x2.xpm
Style "*xterm*"   TitleIcon mini-term.xpm
Style "rxvt"      TitleIcon mini-term.xpm
Style "xcalc"     TitleIcon mini-calc.xpm
Style "xsession"  TitleIcon mini-bx2.xpm
Style "xv"        TitleIcon mini-xv.xpm
Style "Netscape"  TitleIcon mini-nscape.xpm
Style "xmag"      TitleIcon mini-zoom.xpm
Style "textedit"  TitleIcon mini-edit.xpm
Style "tkps"      TitleIcon mini-run.xpm
Style "Ghostview" TitleIcon mini-gv.xpm
Style "Xcolorsel" TitleIcon mini-colors.xpm
Style "IDL*"      TitleIcon mini-zoom.xpm
Style "xeyes"     TitleIcon mini-eyes.xpm
Style "*fm*"      TitleIcon mini-filemgr.xpm
# xman resource names
Style "topBox"    TitleIcon mini-book1.xpm
Style "help"      TitleIcon mini-book2.xpm
Style "manualBrowser" TitleIcon mini-book2.xpm
# xpaint resource names
Style "xpaint"    TitleIcon mini-paint.xpm
Style "Canvas"    TitleIcon mini-paint.xpm
Style "fatbits"   TitleIcon mini-paint.xpm
Style "filebrowser" TitleIcon mini-paint.xpm

#Style "rxvt"       Icon  term.xpm
#Style "xterm"      Icon xterm.xpm
#Style "color_xterm" Icon rterm.xpm
#Style "Appointment" Icon datebook.xpm
#Style "xcalc"      Icon Rcalc.xpm
#Style "xbiff"      Icon mail1.xpm
#Style "xmh"        Icon mail1.xpm, StartsOnDesk 2
#Style "xman"      Icon xman.xpm
#Style "xvgr"      Icon graphs.xpm
#Style "matlab"    Icon math4.xpm
#Style "xmag"      Icon mag_glass.xpm
#Style "xgraph"    Icon graphs.xpm
#Style "xv"         Icon xview.xpm
#Style "FvwmButtons"  Icon toolbox.xpm
#Style "xconsole"   Icon koala.xpm
#Style "xsession"   Icon koala.xpm
#Style "textedit"   Icon textedit.xpm
#Style "ghostview"  Icon gv.xpm

#======================================================================

#
# Stuff to do at start-up
#

AddToFunc "InitFunction"    "I" Exec xsetroot -solid cyan4 &
AddToFunc "InitFunction"    "I" Exec xsetroot -solid Blue &
#+                          "I" Module FvwmBanner
#+                           "I" Module FvwmButtons
#+                           "I" Module FvwmTaskBar
+                          "I" Module FvwmPager 0 0 

AddToFunc "RestartFunction" "I" Module FvwmButtons
#+                           "I" Module FvwmTaskBar
+                          "I" Module FvwmPager 0 3

#======================================================================

# Now define some handy complex functions

#
# This one moves and then raises the window if you drag the mouse,
# only raises the window if you click, or does a full maximize if 
# you double click
#
AddToFunc "Move-or-Raise" "M" Move
+                         "M" Raise
+                         "C" Raise
+                         "D" Maximize 100 100

AddToFunc "Move-or-Lower" "M" Move
+                         "M" Lower
+                         "C" Lower
+                         "D" RaiseLower

#
# This one moves or (de)iconifies:
#
AddToFunc "Move-or-Iconify" "M" Move
+                           "D" Iconify

AddToFunc "Resize-or-Raise" "M" Resize
+                           "M" Raise
+                           "C" Raise
+                           "D" RaiseLower

#======================================================================

#
# Now define the menus - defer bindings until later
#

# This is for the Start menu of the FvwmTaskBar

AddToMenu "StartMenu"
+ "New shell        %mini-sh1.xpm%"         Exec    color_xterm -ls -sb
+ "Manual pages     %mini-book1.xpm%"       Exec    xman &
+ "Magnifying glass %mini-zoom.xpm%"        Exec xmag &
+ "Applications     %mini-x2.xpm%"          Popup   Applications

.
.
.

---

From: lar3ry gensch <[email-masked]>
Date: Wed, 20 Nov 1996 10:31:23 -0500

>    to add the "Sticky" param in the .fvwmrc file don't take.

Add this style flag to your .fvwm2rc95 file:

Style "Fvwm Pager"   StaysOnTop, Sticky

> 2. I would also like to be able to move the virtual desktop window like

Same change.  You currently have the style "NoTitle" and "NoHandles"
applying to the FVWM Pager.  The line I gave you above should fix that.

>    It's as if each monitor-full of background screen is too small...

I think the one style line above will prevent you from having to switch
desktops in order to get your pager, making the question moot.

-- 
(void) lar3ry();                                      [email-masked]

  "I'm sorry you saw me, Billy.  Now I'll have to kill you." -- Santa

---

From: [email-masked] (Rick Jones)
Date: Wed, 20 Nov 1996 11:56:16 -0600 (CST)

>    to add the "Sticky" param in the .fvwmrc file don't take.

Maybe this was just an oversight on your part but the fvwm95-2 rc file is 
not fvwmrc it is fvwm2rc95.  Putting changes in the fvwmrc file won't 
effect fvwm95.

>    It's as if each monitor-full of background screen is too small...

You have a virtual screen in your xf86config file.  comment out the 
virtual line in the screen section of your server entry in the 
/etc/xf86config fil and the whole desktop will be in view at once.

I see you have the proper file inserted here.  Try moving it to your root 
directory with a dot (.) in front of it to insure it is being read.

==========================
Rick Jones
[email-masked]
==========================

---

From: Allen Brady Montz <[email-masked]>
Date: 20 Nov 1996 12:18:29 -0700

> I'll set up something to mail me automatically.

Quite true. Jason was very prompt on this if anybody is wanting to release
stuff via ftp. Anything that's not officially part of the fvwm distribution
should be here. the misc directory is really way too sparse given the amount
of stuff that people have released (the various titlebar patches, xpm patches,
the python module). 

Personally, since FvwmIconMan went into the standard fvwm distribution, I've
only been using my ftp site (and now http site) for beta releases that are
newer than the latest fvwm. As such, I would rather keep tight control over
the README so that people know which version of fvwm was current when the beta
was released (since whenever I put a version on my site I usually send a copy
to Chuck, you can assume that when a fvwm release occurs, it always has the
latest version). 

This reminds me. Jason could you please remove FvwmIconMan 0.2 and 0.3 from
the misc directory? Thanks. Also, perhaps you could set up a directory
specifically for patches? If you want one to start with, the miniicon patch
and its README is in: 
ftp://ftp.cs.arizona.edu/people/bradym/miniicon_patch/

Patches really shouldn't go directly into the misc directory I think.
Perhaps in a subdirectory of /pub/fvwm/version-2?

---

From: Jason L Tibbitts III <[email-masked]>
Date: 20 Nov 1996 16:44:35 -0600

>>>>> "ABM" == Allen Brady Montz <[email-masked]> writes:

ABM> This reminds me. Jason could you please remove FvwmIconMan 0.2 and 0.3
ABM> from the misc directory?

Done.

ABM> Patches really shouldn't go directly into the misc directory I think.
ABM> Perhaps in a subdirectory of /pub/fvwm/version-2?

Sounds good to me.  I don't currently have the time to track down patches,
so if anyone wants to contribute theirs to /pub/incoming/fvwm, just let me
know when they're there.

 - J<

---

From: [email-masked] (Albrecht Kadlec)
Date: Fri, 22 Nov 96 17:43:43 +0100

>>>>> Jason L Tibbitts writes:

J> So everyone knows, you can also upload things to
J> ftp.hpc.uh.edu:/pub/incoming/fvwm and let me know there's something new
J> there and I'll move it into the main distribution.  I think perhaps that
J> I'll set up something to mail me automatically.

Where do those things go ?
Is this the place to put patches (even BIG ones) to?

albrecht
-- 
If it was hard to write, it should be hard to understand.
                                        -- A Unix programmer

---

From: "Charles Hines" <[email-masked]>
Date: Fri, 22 Nov 1996 11:50:48 -0500

>>>>> "A" == Albrecht Kadlec <[email-masked]> writes:

A> Where do those things go ?
A> Is this the place to put patches (even BIG ones) to?

On that note: Jason, I think that any patch directory created should
probably be named something like UNOFFICIAL_PATCHES or something like
that...

Chuck

---

From: Jason L Tibbitts III <[email-masked]>
Date: 22 Nov 1996 13:01:38 -0600

Well, if they're patches, I'll put them in an unofficial_patches directory.
if they're not patches, I'll put them in the misc directory unless they
don't fit there either, in which case I'll put them somewhere else.

Well, don't fill the partition with gigabyte patches.  Otherwise anything
goes.

 - J<