Subject: FVWM: SloppyFocus and Auto (Raise)..

From: Jason Holloway <[email-masked]>
Date: Tue, 8 Oct 1996 17:26:02 +0100

Hi,

Under FVMW v1.x I could use AutoRaise and SloppyFocus to
achieve something which I found quite useful.

Most of the time, I required the focused window to be
topmost (easy enough - keep the mouse pointer in the window
until it auto raised). Sometimes though, especially when
copying things between windows, I needed to keep the focused
window stacked *lower* than the other window. (see figure) 

In order to achieve this, I used to move the mouse pointer
into and then straight out of the other window, thereby
gaining focus, but not auto-raising the window.

  X  <- mouse pointer outside all windows

    +==============+
    |$ cat > file  | <- window with focus, but lower (data now
    |copied info.. |    visible in other window)
    |^D       +--------------+
    |$        | info..       |  <- Window with data (still
    |         | info..       |     on top)
    |         | info..       |
    +---------| info..       |
              +--------------+

So far so good. Unfortunately, I can't seem to replicate
this within FVWM2. I've tried FvwmAuto and SloppyFocus
together, but even when the mouse pointer is out of the
window, the window autoraises after the required time.

Any suggestions?

Thanks.

Regards,
        Jason.

PS. I hope this makes sense.. Please let me know if either
copies of my configs are required, or I haven't made myself
clear.

-----------------------------------------------------------------
Jason Holloway                  UUNET PIPEX 
[email-masked]          332, Cambridge Science Park
Phone: +44 (1223) 250-100       Cambridge, CB4 4BZ, UK
Fax:   +44 (1223) 250-101       http://www.uunet.pipex.com/

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (David S. Goldberg)
Date: 08 Oct 1996 13:11:07 -0400

> Most of the time, I required the focused window to be topmost (easy
> enough - keep the mouse pointer in the window until it auto
> raised). Sometimes though, especially when copying things between
> windows, I needed to keep the focused window stacked *lower* than
> the other window. (see figure)

> In order to achieve this, I used to move the mouse pointer into and
> then straight out of the other window, thereby gaining focus, but
> not auto-raising the window.

[This doesn't work with FvwmAuto because it raises based on Focus
rather than where the mouse is]

> Any suggestions?

I found this annoying also, except in revers.  I normally hate
AutoRaise, but there are times I want it.  In one of my menus I have
two items, one for turing FvwmAuto on, the other off.  It looks
something like this:

* "&AutoRaise On" Module FvwmAuto 500
* "AutoRaise &Off" KillModule FvwmAuto

This is certainly not exactly what you want, but it will work in a
pinch.

--
Dave Goldberg
Post: The Mitre Corporation\MS B305\202 Burlington Rd.\Bedford, MA 01730
Phone: 617-271-3887
Email: [email-masked]