Subject: FVWM: FvwmPager (fvwm 2.0.43) bug

From: [email-masked]
Date: Mon, 14 Oct 1996 12:49:46 -0400 (EDT)

I can get the FvwmPager module to die fairly consistently by moving
an xterm from some other virtual desktop to the currently selected one
with middle-mouse.  The xterm shows up, the pager window vanishes, and
I get this error message in my xconsole:

X Error of failed request:  BadMatch (invalid parameter attributes)
  Major opcode of failed request:  42 (X_SetInputFocus)
  Serial number of failed request:  3025
  Current serial number in output stream:  3025

I'm not certain, but it only seems to happen with xterm.

zw

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Charles Hines" <[email-masked]>
Date: Mon, 14 Oct 1996 12:57:56 -0400

>>>>> "zack" == zack  <[email-masked]> writes:

zack> I can get the FvwmPager module to die fairly consistently by moving
zack> an xterm from some other virtual desktop to the currently selected one
zack> with middle-mouse.  The xterm shows up, the pager window vanishes, and
zack> I get this error message in my xconsole:

zack> X Error of failed request:  BadMatch (invalid parameter attributes)
zack>   Major opcode of failed request:  42 (X_SetInputFocus)
zack>   Serial number of failed request:  3025
zack>   Current serial number in output stream:  3025

zack> I'm not certain, but it only seems to happen with xterm.

Known problem, fixed in the next beta.  Try this patch:

----------------------------------------------------------------------
diff -ru x_pager.c.orig x_pager.c
--- x_pager.c.orig    Mon May  6 15:51:02 1996
+++ x_pager.c Fri Sep 27 14:08:45 1996
@@ -1437,6 +1437,9 @@
        }
       if(Scr.CurrentDesk == t->desk)
        {
+          XSync(dpy,0);
+          sleep_a_little(5000);
+          XSync(dpy,0);
          if(t->flags & ICONIFIED)
            XSetInputFocus (dpy, t->icon_w, RevertToParent, Event->xbutton.time);
          else
----------------------------------------------------------------------

Chuck

--
*******************************************************************************
Charles K. Hines <[email-masked]>
IBM Logic Synthesis Developer [BooleDozer (TM)]
Martial Arts Instructor [Modern Arnis, Presas Style Filipino Martial Arts]

         "Go back to sleep, Chuck.  You're just havin' a nightmare
             -- of course, we ARE still in Hell." (Gary Larson)
*******************************************************************************
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Ondrej Popp <[email-masked]>
Date: Mon, 14 Oct 1996 19:44:54 +0100

> I'm not certain, but it only seems to happen with xterm.

Well, I tried it several times myself
moved xterm to almost every workspace I had, and back to
the selected one. Nothing happened... Everything works fine here...

Ondrej

---

From: [email-masked] (Walter Truitt from SPD)
Date: Mon, 14 Oct 1996 13:23:54 -0500 (CDT)

I don't get this error, but then, I wasn't able to compile the xterm that
came with X11R6.  I am using the one that came on the Solaris system I 
am using.

Walter