Subject: FVWM: FVWM2: FvwmButtons and per mouse 1,2,3 options...

From: (^8= Eric T. Sylvain =8^) <[email-masked]>
Date: Mon, 28 Oct 1996 08:31:07 -0500

Hi All,

Has anyone used the "Mouse" option with FvwmButtons
I would like to make a button that brings up an
80x24 xterm with mouse1 click and an 80x64 xterm
with mouse2 click, etc.  The man page I have is
not too clear on this.  I have tried various things
without any luck...

Version Info:
[FVWM][main]:  Fvwm Version 2.0.43 compiled on Sep 26 1996 at 15:47:48

Platform: 
Solaris 2.4, Sparc 20

I am currently not subscribed to the list, so can
you copy me and "[email-masked]" on the responses...

-Eric

-----------------------------------------------------
Eric Sylvain                     Direct (603)337-7014
Cabletron Systems, Inc.          Fax    (603)337-7784
35 Industrial Way, PO Box 5005
Rochester, NH 03866-5005            [email-masked]
-----------------------------------------------------
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Drew Lebauer <[email-masked]>
Date: Mon, 28 Oct 1996 07:12:34 -0700

Sure. here is the relevant section from my .fvwm2rc file. It is set up
so that the left mouse button opens an 80x25 xterm, the middle button
opens an 160x25
 window, and the right button opens an 80x60 xterm.

(^8= Eric T. Sylvain =8^) wrote:*FvwmButtons(1x1, Container(Rows 2,
Columns 2))
*FvwmButtons(Title Peb, \
    Action(Mouse 1) 'Exec "Aixterm" $SHLPEBB aixterm -g 80x25 -d
$DISPLAY -T pebbles', \
    Action(Mouse 2) 'Exec "Aixterm" $SHLPEBB aixterm -g 160x25 -d
$DISPLAY -T pebblesw', \
    Action(Mouse 3) 'Exec "Aixterm" $SHLPEBB aixterm -g 80x60 -d
$DISPLAY -T pebblest')
*FvwmButtons(Title Rob, \
    Action(Mouse 1) 'Exec "Aixterm" $SHLROBN aixterm -g 80x25 -d
$DISPLAY -T robin', \
    Action(Mouse 2) 'Exec "Aixterm" $SHLROBN aixterm -g 160x25 -d
$DISPLAY -T robinw', \
    Action(Mouse 3) 'Exec "Aixterm" $SHLROBN aixterm -g 80x60 -d
$DISPLAY -T robint')
*FvwmButtons(Title Bet, \
    Action(Mouse 1) 'Exec "Aixterm" $SHLBETT aixterm -g 80x25 -d
$DISPLAY -T betty', \
    Action(Mouse 2) 'Exec "Aixterm" $SHLBETT aixterm -g 160x25 -d
$DISPLAY -T bettyw', \
    Action(Mouse 3) 'Exec "Aixterm" $SHLBETT aixterm -g 80x60 -d
$DISPLAY -T bettyt')
*FvwmButtons(Title Bam, \
    Action(Mouse 1) 'Exec "Aixterm" $SHLBAMB aixterm -g 80x25 -d
$DISPLAY -T bambam', \
    Action(Mouse 2) 'Exec "Aixterm" $SHLBAMB aixterm -g 160x25 -d
$DISPLAY -T bambamw', \
    Action(Mouse 3) 'Exec "Aixterm" $SHLBAMB aixterm -g 80x60 -d
$DISPLAY -T bambamt')
*FvwmButtons(End)

-- 
  ) *=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=
 (  | Drew Lebauer | Phone: (303) 802-1416 | Fax: (303) 802-1420
  ) |    Evolving Systems, Inc.   |   mailto:[email-masked]
c[] *=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Nick Cross <[email-masked]>
Date: Tue, 29 Oct 1996 08:55:43 +0000

Hi,
I was advised to foward this question to the mailing list in case anyone
out there has any other ideas concerning it...

[various previous bits from me cut out!]

> >Thinking on those lines can buttons resize themselves?
> 
> I don't think so. You may want to forward this question to the mailing
> list.
> 
> > In other words would it be possible to have, say three horizontal
> > buttons, first and last being fixed, the first containing a menu and 
> > the last, say a swallowed clock, while the second resizes to fill 
> > remaining screen. This contains the swallowed winlist module - this i
> > is where my knowledge again fails - as its a swallowed module is it 
> > possible to click upon the individual windows in the list? Hopefully
> > this is 'slightly' clearer!
> >
> -- 

Originally I tried something like:

*FvwmButtonsGeometry 1030x32+0+1
*FvwmButtonsColumns     27
*FvwmButtonsFont  -*-helvetica-medium-r-*-*-*-120-*-*-*-*-*-*
*FvwmButtonsFore        Black
*FvwmButtonsBack        LightSlateGray
#*FvwmButtons (2x1, Icon mini-exp.xpm, Action 'PopUp "Start" Start')
*FvwmButtons (25x1, Swallow "FvwmWinList" `FvwmWinList`)
#*FvwmButtons (2x1)       - whatever      Swallow "xclock" xclock
-digital -bg LightSlateGray  -padding 0 &

*FvwmWinListBack LightSlateGray
*FvwmWinListFore Black
*FvwmWinListFont  -adobe-helvetica-medium-r-*-*-14-*-*-*-*-*-*-*
*FvwmWinListAction Click1 Iconify -1, Raise
*FvwmWinListAction Click2 Iconify
*FvwmWinListAction Click3  Popup "Window Ops"
*FvwmWinListUseSkipList
*FvwmWinListUseIconNames
*FvwmWinListGeometry +10

...but that didn't work; buttons merely crashed out while the winlist
process remained but disappeared also. 
Any help would be *much* appreciated!!!

Thanks,
NIck