Subject: FVWM: fvwm2 starts up multiple copies

From: Sean Lehman at IDP <[email-masked]>
Date: Fri, 11 Oct 1996 15:18:19 -0700

MACHINE : Sun
OS      : SunOS 5.5.1
uname -a: SunOS pinkpanther.llnl.gov 5.5.1 Generic sun4c sparc SUNW,Sun_4_40
X11     : X11R6.1
COMPILER: /opt/SUNWspro/bin/cc
FVWM    : fvwm-2.0.43

When fvwm2 starts up, it always creates double copies of the modules
(I have selected to run) and itself:

pinkpanther(58> ps -fu lehman | grep -i fvwm
  lehman  2396  2359  0 13:03:34 console  0:06 /usr/X11R6.1/lib/X11/fvwm2/FvwmWinList 11 4 /usr/X11R6.1/lib/X11/fvwm2/.fvwm2rc
  lehman  2392  2362  0 13:03:33 console  0:01 /usr/X11R6.1/lib/X11/fvwm2/FvwmWinList 11 4 /usr/X11R6.1/lib/X11/fvwm2/.fvwm2rc
  lehman  2391  2359  0 13:03:33 console  0:01 /usr/X11R6.1/lib/X11/fvwm2/FvwmButtons 7 4 /usr/X11R6.1/lib/X11/fvwm2/.fvwm2rc 
  lehman  2388  2362  0 13:03:31 console  0:01 /usr/X11R6.1/lib/X11/fvwm2/FvwmButtons 7 4 /usr/X11R6.1/lib/X11/fvwm2/.fvwm2rc 
  lehman  2359  2340  1 13:02:56 console  0:32 fvwm2
  lehman  2390  2362  0 13:03:32 console  0:01 /usr/X11R6.1/lib/X11/fvwm2/FvwmPager 9 4 /usr/X11R6.1/lib/X11/fvwm2/.fvwm2rc 0 
  lehman  2362  2359  0 13:03:09 console  0:02 fvwm2
  lehman  2393  2359  0 13:03:33 console  0:08 /usr/X11R6.1/lib/X11/fvwm2/FvwmPager 9 4 /usr/X11R6.1/lib/X11/fvwm2/.fvwm2rc 0 
  lehman  2490  2421  1 15:11:15 pts/4    0:00 grep -i fvwm
pinkpanther(59> 

When I perform a restart it complains there is another window manager
running:

[FVWM][Done]: <<ERROR>> Call of 'fvwm' failed!!!!
[FVWM][CatchRedirectError]: <<ERROR>> another WM is running

It occasionally crashes after a restart.

Do you have any tips, solutions, or suggestions?

-- 

 +------------------------------------------------------------------------+
 | Sean K. Lehman, [email-masked]                                       |
 | Lux et Veritas                                                         |
 | "Looking toward the sky waiting for my next operating instructions."   |
 |                                   -Anne Lamott                         |
 +------------------------------------------------------------------------+
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Guenther Grau <[email-masked]>
Date: Mon, 14 Oct 1996 19:04:18 +0100

> (I have selected to run) and itself:

start fvwm with -s and see if the problem persists.
I had the same problem, because the X server from sun
creates to displays and fvwm forks of a copy for each
display. the option -s prevents this.
I didn't have any problems restarting fvwm, though. Maybe
this is another problem. Please test and report.

  Guenther