Subject: FVWM: Invoking fvwm (Solaris)

From: [email-masked] (Keith Nichol)
Date: Thu, 17 Oct 1996 14:13:52 +1000

Hi all,

I'm new on this list, though I used to read it a while back.  I'm a long-time
user of fvwm and now find myself in a Solaris shop.

I've got and compiled the 2.0.43 version (almost hitch-free) but when it comes
to invoking it I hit problems: viz. it seems even the X-server doesn't start.

I'm trying it from the console screen and entering the command:

	xinit /usr/local/bin/fvwm --

The Solaris banner shows then the whole thing seems to hang -- nothing further
happens (thinks: maybe the banner is Solaris' way of starting the server ...
ordinarily I'd expect the stippled background with the "X" cursor.  If this is
true, maybe it's not getting to fvwm.).

Any and all pointers as to how to start it up under Solaris 2.5 would be ap-
preciated.

Thanks

Keith

Keith Nichol
Syscorp Pty Ltd
Sydney, Australia
[email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Kai Grossjohann <[email-masked]>
Date: 17 Oct 1996 11:14:26 +0200

>>>>> Keith Nichol writes:

  Keith> I'm trying it from the console screen and entering the command:

  Keith> 	xinit /usr/local/bin/fvwm --

Here's what I do:

I've got a shell script with the following contents which I invoke:

    #!/bin/sh
    exec openwin -ar1 400 -ar2 25 -dur 200 -nobanner

I've got a file .xinitrc which starts up whatever clients I like, fvwm
being one of them.  I think .xinitrc should be chmod u+x.

"-ar1 400" means wait 400 ms before autorepeat of keys cuts in.  "-ar2
25" means repeat every 25 ms.  "-dur 200" means a BEL lasts 200 ms.
"-nobanner" means start up without the usual OW banner.

IMHO using the openwin script has the advantage that you automagically
use MIT-Magic-Cookie-1 rather than xhost authorization, which is more
secure.

regards,
kai
-- 
Life is hard and then you die.

---

Date: Thu, 17 Oct 1996 09:35:02 +0200 (MET DST)

> Any and all pointers as to how to start it up under Solaris 2.5 would be ap-

	Hi,
	We start fvwm2 from the (modifed, originally SUN-supplied-)
	user .profile, where we export the Variable OW-WINDOW_MANAGER
	which is then evaluated in the Xinitrc. 

stty istrip

#
# If possible, start the windows system
#
	  if [ `tty` = "/dev/console" ] ; then
	  if [ "$TERM" = "sun" -o "$TERM" = "AT386" ] ; then

		if [ ${OPENWINHOME:-""} = "" ] ; then
			OPENWINHOME=/usr/openwin
			export OPENWINHOME
		fi

#		FVWM2 als Window-Manager und benutze system.fvwm2rc
		export OW_WINDOW_MANAGER="fvwm2 -f 'FvwmM4 -m4-prefix -m4opt -I$HOME /usr/local/X11/lib/X11/fvwm2/system.fvwm2rc'"
# 		benutze eigene .fvwm2rc
#		export OW_WINDOW_MANAGER="fvwm2 -f 'FvwmM4 -m4-prefix -m4opt -I$HOME $HOME/.fvwm2rc'"

		echo ""
		echo "Starting OpenWindows in 5 seconds (type Control-C to interrupt)"
		sleep 5
		echo ""
		$OPENWINHOME/bin/openwin

		clear		# get rid of annoying cursor rectangle
		exit		# logout after leaving windows system

	  fi
	  fi;;
#
# das gilt fuer Linux
	Linux*)	
		export PATH=$PATH:.
		cd $HOME
		case $TERM in
			console*) 	
				echo "  Aufruf von XWindows mit -> startx <-"
				echo "" ;;
			linux*)
				echo "  Aufruf von XWindows mit -> startx <-"
				echo "" ;;
		esac ;;
esac

# Prompt definieren (\h=hostname; \w=directory; \$=Standardprompt)
PS1='\h:\w\$>'

# wechsle in HOME-Verz.
cd

# Abkuerzungen werden in der .bashrc definiert
source .bashrc

	and our (/usr/openwin/lib/)Xinitrc has been modified also:

# @(#)Xinitrc	1.22 93/05/14	OpenWindows startup script.

# wird in der ~/.profile definiert
#OW_WINDOW_MANAGER="fvwm2 -f 'FvwmM4 -m4-prefix -m4opt -I$HOME /usr/local/X11/lib/X11/fvwm2/system.fvwm2rc'"

xrdb $OPENWINHOME/lib/Xdefaults		# Load Default X11 resource database
if [ -f $HOME/.Xdefaults ]; then
    xrdb -merge $HOME/.Xdefaults	# Load Users X11 resource database
fi

$OPENWINHOME/lib/openwin-sys 		# OpenWindows system initialization

eval `locale_env -env`			# Set Locale Environment

if [ "$OW_WINDOW_MANAGER" ]; then	# Alternate Window Manager
    xsetroot -def			# Clear root window
#
	xhost -
#
#	starte Window-manager... (fvwm2)
	eval $OW_WINDOW_MANAGER
#
#	geht nicht!
#   $OW_WINDOW_MANAGER & wmpid=$!	# Start Alt Window Manager
#    wmpid=$! 	
#    dsdm &				    # OpenLook Drop Site Database
#    unset OW_WINDOW_MANAGER
#
else
    sleep 15 & pid=$!			# OpenLook Window Manager
    olwm -syncpid $pid & wmpid=$!
    wait $pid				# Pause until olwm inits

    if [ -x $HOME/.openwin-init ]; then
        $HOME/.openwin-init			# Custom OpenWindows tools
    else
        $OPENWINHOME/lib/openwin-init   	# Default OpenWindows tools
    fi

    wait $wmpid				# Wait for wm (key client) to exit
fi

	In the HOME-dir. there's a .fvwm2desk (as we use the SaveDesk 
	module) which is included into the system.fvwm2rc
	I guess, you should start with 
	export OW-WINDOW_MANAGER=fvwm2
	only. before adding M4-preprocessing (I could also give you
	our system.fvwm2rc and a .fvwm2desk if you want it)

	good luck! 
		Ditmar.

-- 
                                 \\\|///
                                \\ ~ ~ //
                                (/ @ @ /)
  ----------------------------oOOo-(_)-oOOo-------------------------------
|                                                                        |
|   Ditmar Unger                           E-mail:                       |
|   Fachgebiet Turbomaschinen              [email-masked]     |
|   und Fluidantriebstechnik                                             | 
|   TH Darmstadt                           Tel.  +49  (0) 6151 16-2603   |
|   Petersenstr. 30                        Fax.                16-5559   |
|   D - 64287 Darmstadt                                                  |
|                                                                        |
|   WWW:	http://www.th-darmstadt.de/fb/mb/tfa/Welcome.html        |
  ------------------------------------------------------------------------

-- 
                                 \\\|///
                                \\ ~ ~ //
                                (/ @ @ /)
  ----------------------------oOOo-(_)-oOOo-------------------------------
|                                                                        |
|   Ditmar Unger                           E-mail:                       |
|   Fachgebiet Turbomaschinen              [email-masked]     |
|   und Fluidantriebstechnik                                             | 
|   TH Darmstadt                           Tel.  +49  (0) 6151 16-2603   |
|   Petersenstr. 30                        Fax.                16-5559   |
|   D - 64287 Darmstadt                                                  |
|                                                                        |
|   WWW:	http://www.th-darmstadt.de/fb/mb/tfa/Welcome.html        |
  ------------------------------------------------------------------------
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mark Boyns <[email-masked]>
Date: 17 Oct 1996 09:11:01 -0700

> Any and all pointers as to how to start it up under Solaris 2.5 would be ap-

Put the following in your .xinitrc and run `startx' or `openwin'.

#!/bin/sh

if [ -f $HOME/.Xdefaults ]
then
	xrdb -load $HOME/.Xdefaults
fi

if [ -f $HOME/.Xmodmap ]
then
	xmodmap $HOME/.Xmodmap
fi

fvwm