Subject: FVWM: Re: MANDIR vs. MANPATH in Fvwm.tmpl

From: [email-masked] (Albrecht Kadlec)
Date: Sat, 5 Oct 96 15:57:09 +0200

>>>>> David Starks-Browning writes:

D> Hello Albrecht,
D> I just found this in the fvwm mailing list archives:

> To: FVWM-Workers mailing list <[email-masked]> 
> Subject: X11R4 install process 
> From: [email-masked] (Albrecht Kadlec) 
> Date: Fri, 21 Jun 96 16:01:41 +0200 
> 
> . . .
> 
> also the Bug I reported already twice, but nobody ever answered :-(
> 
> MANPATH is settable in Fvwm.tmpl (~ Line 278) but in Line 414 
> InstallManPage(program,$(MANDIR))
> is used to install the pages.
> 
> in the generated Makefile, I find:
> DESTDIR = /XTech
> MANDIR = $(DESTDIR)/man/mann
> which tries to install them globally (which is not permitted to me!)
> 
> so I see three possibilities:
> 
> 1.) maybe our (X11R4) setup is ruined, if so the tell me what is wrong, please.
> Should I mail the generated Makefile here?
> 
> 2.) Fvwm.tmpl messes up MANDIR & MANPATH
> (it seems to me that FvwmManPath should be FvwmManDir, and
> MANPATH should be MANDIR throughoutall of Fvwm.tmpl)
> 
> 3.) MANDIR should also be configurable in Fvwm.tmpl,
> for those who want to install Fvwm binary & documentation in ~/anyname/
> 
> 
> I think it's 2) at least all things went smooth when I did this.
> 
> cheers,
> albrecht

D> I guess this was for fvwm-2.0.42?  Well, I have the same problem with
D> 2.0.43, and I found no "official" solutions to this problem in the
D> archives.  Are we really the only two who require this feature?  Or
D> are we the only ones doing it wrong?  If it is indeed a mistake in
D> Fvwm.tmpl then they ought to fix it for 2.0.44, don't you think?

I've had this problem since 2.0.41 (up to now : 2.0.43!)

D> What do you know about the disposition of this problem?
nobody ever seemed to notice this message.
(I only have a dim memory of this, though. But I described it pretty
accurately in the message above.) 

D> (I am just starting with fvwm today.)

D> Regards,
D> David

regards,
albrecht
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Guenther Grau <[email-masked]>
Date: Sun, 06 Oct 1996 19:32:30 +0200

Hi,

> > also the Bug I reported already twice, but nobody ever answered :-(

Ok, I'll try this time :-)

> > which tries to install them globally (which is not permitted to me!)

Hmm, by accident I had to look a little deeper into this. In my setup
DESTDIR is empty. The rest of the variables are defined like this

          MANPATH = /tools/X11R6/man
    MANSOURCEPATH = $(MANPATH)/man
           MANDIR = $(MANSOURCEPATH)$(MANSUFFIX)

And later on in the fvwm-specific section, MANPATH is overridden.

        MANPATH = /my/home/fvwm-2.0.43/man

which I specified in the Fvwm.tmpl.

And even later you find this:

install.man:: fvwm2.man
        @if [ -d $(DESTDIR)$(MANDIR) ]; then set +x; \
        else (set -x; $(MKDIRHIER) $(DESTDIR)$(MANDIR)); fi
        $(INSTALL) $(INSTALLFLAGS) $(INSTMANFLAGS) fvwm2.man
$(DESTDIR)$(MANDIR)
/fvwm2.$(MANSUFFIX)

As DESTDIR is empty, it installes it exactly where I wanted.
This is X11R6.

> > Should I mail the generated Makefile here?

Hmm, I cannot really say this, as I don't know enough of it. I just know
how it works
at our site with R6.

> > MANPATH should be MANDIR throughoutall of Fvwm.tmpl)

No answer to this one, too. I don't know if it is legal to rely on the
above setup,
which happens to be at our site. All I can say, it works for me and
probably for others :-)
Maybe the R4 imake setup was different and doesn't work with current
fvwm?

> > for those who want to install Fvwm binary & documentation in ~/anyname/

I think it uses MANPATH, because it wants to preserve a specific
directory structure
within the MANPATH, but I might be wrong.

Any Imake.conf setup gurus around to give us a definite answer? Should
we switch
to autoconf? :-)

  Guenther

---

From: [email-masked] (Albrecht Kadlec)
Date: Mon, 14 Oct 96 20:17:09 +0200

>>>>> Guenther Grau writes:

G> Hi,
> also the Bug I reported already twice, but nobody ever answered :-(

G> Ok, I'll try this time :-)

> which tries to install them globally (which is not permitted to me!)

G> Hmm, by accident I had to look a little deeper into this. In my setup
G> DESTDIR is empty. The rest of the variables are defined like this

G>           MANPATH = /tools/X11R6/man
G>     MANSOURCEPATH = $(MANPATH)/man
G>            MANDIR = $(MANSOURCEPATH)$(MANSUFFIX)

G> And later on in the fvwm-specific section, MANPATH is overridden.

G>         MANPATH = /my/home/fvwm-2.0.43/man

G> which I specified in the Fvwm.tmpl.

G> And even later you find this:

G> install.man:: fvwm2.man
G>         @if [ -d $(DESTDIR)$(MANDIR) ]; then set +x; \
G>         else (set -x; $(MKDIRHIER) $(DESTDIR)$(MANDIR)); fi
G>         $(INSTALL) $(INSTALLFLAGS) $(INSTMANFLAGS) fvwm2.man
G> $(DESTDIR)$(MANDIR)
G> /fvwm2.$(MANSUFFIX)

G> As DESTDIR is empty, it installes it exactly where I wanted.
G> This is X11R6.

> Should I mail the generated Makefile here?

G> Hmm, I cannot really say this, as I don't know enough of it. I just know
G> how it works
G> at our site with R6.

> MANPATH should be MANDIR throughoutall of Fvwm.tmpl)

G> No answer to this one, too. I don't know if it is legal to rely on the
G> above setup,
G> which happens to be at our site. All I can say, it works for me and
G> probably for others :-)
G> Maybe the R4 imake setup was different and doesn't work with current
G> fvwm?

> for those who want to install Fvwm binary & documentation in ~/anyname/

G> I think it uses MANPATH, because it wants to preserve a specific
G> directory structure
G> within the MANPATH, but I might be wrong.

G> Any Imake.conf setup gurus around to give us a definite answer? Should
G> we switch
G> to autoconf? :-)
:-)
not now, when almost everything is working at last !!!

ok an answer at last, thanks, I thought I'd talked to a wall on this topic.

hmm, now since this was the only answer to the 3rd question on the topic,
I have to think, that the imake gurus have died out with the dinosaurs.

Could anybody please take the time to clear this up for now & ever?
(I simply don't know where to start. And it would take very long for me,
since I never tackled with differences between X11 releases before)

albrecht
-- 
Give a man a fish and he has a meal for one day.
Teach a man to fish and he has meals for the rest of his life.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].