Subject: FVWM: pixmap borders patch

From: [email-masked] (David Kennedy)
Date: Thu, 26 Sep 1996 11:04:11 +0100

Hi,

I had a  quick think re: my gripe about pixmap borders and 
highlight colours. Basically my problem is that I use the same
pixmap for active/inactive windows (I just rely on titlebar
colour to indicate focus). The highlight and ordinary 
style "*" colour must be set in such a way that it doesn't look
terrible against the chosen pixmap. So I use the same colour for
highlight and inactive borders (the titlebar indicates focus
anyway).

The problem is that when scooting over my icons its not very
obvious which one has the focus as the colours don't change.
The functionality of a highcolour is still needed in this case.

I'd like a very different colour for highlighted icons while
retaining the same highlighted/ordinary colour for pixmaped
border windows. Might I suggest extending (and slightly
complicating, but only slightly) the pixmap borders patch to
include a config file line like "Icon highlight colour"
or something. Most fvwm users will be fine with this, but
for "pixmap border patch" users this would be useful.
I reckon this would be very simple to implement.

/end{rant}
-- 
David Kennedy, The Queen's University of Belfast.
" I come from a hungry family - my mother used to
  count us after every meal. " Bob Shaw
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Martin Cartwright)
Date: Thu, 26 Sep 1996 16:57:42 +0100

=> From: [email-masked] (Albrecht Kadlec)

=> M> I have 90 Style lines in my .fvwmrc. About half of these are exclusively
=> 
=> Quite a lot, how may windows do you have open, under normal conditions ?
=> You must have a 10:1 ratio between active windows and style definitions ...
=> Do you _really_ need another icon for each and every window ? ... alas, it
      ^^^^^^^^^^^^^^^^^^^
To be honest I could shift a whole bundle completely, but I'd still use
a whole lot of icons for things. When I'm working (as opposed to just 
sitting here playing with the pretty borders) I'll have about ten or so windows
up (couple of Xterms, an XGterm running IRAF with a Tek Window open, XImtool, 
a Nedit's or two, probably mailtool half the time...)  Then I'll open something else and, because I'm on a fairly small screen here, I'll have to iconify
something to find a space to put it, and then do it in reverse to switch 
back.... 
If they're all question marks then it _looks_ bad. Icons are cosmetic
measures,  you could easily have just the title-bar sat there but who
wants that?

I guess this big active:style ratio must be a Boy Scout thing... 
Be Prepared! Dib! Dib! Dib!.     ;)  
 
=> lookup table. You can
=> 	Read ~/.icons

Doh! That'll do. 

[email-masked] - http://star.pst.qub.ac.uk/~imc/vom.htm
-/-----------------------------------------------------------\-
|  "No challenge should be faced without a little charm,      |
|   and a lot of style."				      |
-\-----------------------------------------------------------/-
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].