Subject: FVWM: [2.0.43] DecorateTransient functional?

From: Mark Borges <[email-masked]>
Date: Thu, 12 Sep 1996 16:45:27 -0600

I just noticed that

	Style "*" DecorateTransient

doesn't do what I thought, namely it doesn't put all the titlebar
buttons in dialog boxes. Should it? Or did I miss something? Can you
not have more than two right buttons?

I have:

# Mouse Bindings
#-----------------------------------------------------------------------------
# Button        Context         Modifiers       Function
Mouse 0         1               A               Menu Window-Ops2 Close

Mouse 0         2               A               Close
Mouse 0         4               A               Maximize-Func
Mouse 0         6               A               Iconify
Mouse 0         8               A               Lower
#-----------------------------------------------------------------------------

to get 1 left titlebar button and 4 right titlebar buttons. But on the
dialog boxes (which I thought would be considered transient) I only
see the left button and two right buttons (context 6 and 8). I also
have 

     Style "*"           MWMFunctions,MWMDecor,HintOverride

set, in case it matters.

Here is what xprop/xwininfo says about an example dialog box:
----------------------------------------------------------------------------
$ xprop
WM_STATE(WM_STATE):
                window state: Normal
                icon window: 0x0
WM_TRANSIENT_FOR(WINDOW): window id # 0x2c0023c
_MOTIF_WM_MESSAGES(ATOM) = _MOTIF_WM_OFFSET
WM_PROTOCOLS(ATOM): protocols  _MOTIF_WM_MESSAGES, WM_DELETE_WINDOW
_MOTIF_WM_HINTS(_MOTIF_WM_HINTS) = 0x4, 0xffffffff, 0xffffffff, 0x1, 0x5a7230
WM_CLASS(STRING) = "fileSelector_popup", "Netscape"
WM_HINTS(WM_HINTS):
                Client accepts input or input focus: True
                Initial state is Normal State.
                window id # of group leader: 0x2c0023c
WM_NORMAL_HINTS(WM_SIZE_HINTS):
                program specified location: 268, 246
                program specified size: 500 by 430
                program specified base size: 0 by 0
                window gravity: NorthWest
WM_CLIENT_MACHINE(STRING) = "rossby"
WM_NAME(STRING) = "Save As..."

$ xwininfo
xwininfo: Window id: 0x2c002ef "Save As..."
  Absolute upper-left X:  793
  Absolute upper-left Y:  444
  Relative upper-left X:  0
  Relative upper-left Y:  0
  Width: 500
  Height: 430
  Depth: 8
  Visual Class: PseudoColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x21 (installed)
  Bit Gravity State: ForgetGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: no
  Map State: IsViewable
  Override Redirect State: no
  Corners:  +793+444  --141+444  --141-26  +793-26
  -geometry 500x430+788-21
$
------------------------------------------------------------------------------

Thanks.
-- 
  -mb-
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Brady Montz <[email-masked]>
Date: 13 Sep 1996 12:02:20 -0700

Man, I started up gnus all set to send in basically the same question!
Except in my case, I only get one right button (I should have 3).

> not have more than two right buttons?
...

-- 
 Brady Montz
 [email-masked]

---

From: Dan Espen <[email-masked]>
Date: Fri, 13 Sep 1996 15:23:37 -0400

> > not have more than two right buttons?

Decorate transient works fine.
Perhaps you also have:

Style "*" OLDecor

somewhere in your .fvwm2rc file.  This will cause the symptom you describe.

If not be more specific about which application's transients are undecorated.

--
Dan Espen                                    Phone: (908) 699-5570
[email-masked]
444 Hoes Lane  Room RRC 1C-214
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Brady Montz <[email-masked]>
Date: 13 Sep 1996 13:48:46 -0700

> If not be more specific about which application's transients are undecorated.

No, I don't have OLDecor. But I did have MWMFunctions, which also seems to
have that affect.

---

From: Mark Borges <[email-masked]>
Date: 13 Sep 1996 15:11:53 -0600

>> On 13 Sep 1996 13:48:46 -0700,
>> Brady Montz(B) wrote:
>> somewhere in your .fvwm2rc file.  This will cause the symptom you describe.

B> No, I don't have OLDecor. But I did have MWMFunctions, which also seems to
B> have that affect.

Yep. Dan prompted me to fiddle with my MWM* settings, and that's the
one for me, too. I thought MWMDecor would be the culprit, but that had
no effect. I don't understand why 

          MWMFunctions  makes  fvwm  attempt  to  recognize   and
          respect the mwm prohibited operations hints that appli-
          cations  occasionally  use.   HintOverride  makes  fvwm
          shade  out  operations  that mwm would prohibit, but it
          lets you perform the operation anyway.

would affect titlebar buttons. BTW, 

	Style "*" MWMFunctions,HintOverride

does _not_ change things -- you have to get rid of the MWMFunctions
altogether.

Anyway, I think I can live without MWMCrap ;-).
 
>> If not be more specific about which application's transients are undecorated.

The example I posted earlier was the Netscape "Save As..." dialog box
(but this isn't critical, as it has a Cancel button). Of more concern
was a FrameMaker spell-check box, which lost the ability to dismiss
itself.

Here's what xprop/xwininfo says about this particular window, though I
can't decipher it myself. Although this is resolved, it's not _really_
resolved for me until I understand what's going on.

Thanks again for pointing me in the right direction.

----------------------------------------------------------------------------
$ xprop
WM_STATE(WM_STATE):
                window state: Normal
                icon window: 0x0
WM_TRANSIENT_FOR(WINDOW): window id # 0x4400087
_MOTIF_WM_MESSAGES(ATOM) = _MOTIF_WM_OFFSET
WM_PROTOCOLS(ATOM): protocols  _MOTIF_WM_MESSAGES, WM_DELETE_WINDOW
_MOTIF_WM_HINTS(_MOTIF_WM_HINTS) = 0x5, 0x9, 0xffffffff, 0x0, 0x0
WM_CLASS(STRING) = "edit_spell", "Maker"
WM_HINTS(WM_HINTS):
                Client accepts input or input focus: True
                Initial state is Normal State.
                window id # of group leader: 0x44001ec
WM_NORMAL_HINTS(WM_SIZE_HINTS):
                program specified location: 545, 445
                program specified size: 477 by 188
                program specified minimum size: 477 by 188
                window gravity: NorthWest
WM_CLIENT_MACHINE(STRING) = "revelle"
WM_NAME(STRING) = "FrameMaker - Spelling Checker"

$ xwininfo
xwininfo: Please select the window about which you
          would like information by clicking the
          mouse in that window.
xwininfo: Window id: 0x44001ec "FrameMaker - Spelling Checker"
  Absolute upper-left X:  476
  Absolute upper-left Y:  221
  Relative upper-left X:  0
  Relative upper-left Y:  0
  Width: 477
  Height: 188
  Depth: 8
  Visual Class: PseudoColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x21 (installed)
  Bit Gravity State: ForgetGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: yes
  Map State: IsViewable
  Override Redirect State: no
  Corners:  +476+221  -199+221  -199-491  +476-491
  -geometry 477x188+471+193
$
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].