Subject: FVWM: Problems with fvwm install on SGI...help?

From: Jonobie D Baker <[email-masked]>
Date: Mon, 30 Sep 1996 11:07:47 -0400 (EDT)

Script of install to follow... sorry if it's too long!
Not being a old hand at installing things, I've probably missed something
obvious. :) Any ideas would be wonderful.

Script started on Thu Sep 26 11:50:33 1996
borusa 1% xmkmf
imake -DUseInstalled -I/usr/lib/X11/config
borusa 2% make Makefiles
making Makefiles in libs...
making Makefiles in fvwm...
making Makefiles in modules/GoodStuff...
making Makefiles in modules/FvwmIdent...
making Makefiles in modules/FvwmDebug...
making Makefiles in modules/FvwmBacker...
making Makefiles in modules/FvwmClean...
making Makefiles in modules/FvwmPager...
making Makefiles in modules/FvwmAudio...
making Makefiles in modules/FvwmScroll...
making Makefiles in modules/FvwmIconBox...
making Makefiles in modules/FvwmSave...
making Makefiles in modules/FvwmSaveDesk...
making Makefiles in modules/FvwmAuto...
making Makefiles in modules/FvwmWinList...
making Makefiles in xpmroot...
making Makefiles in modules/FvwmBanner...
borusa 3% make all
making all in ./libs...
        gcc -O2 -xansi -32 -mips2  -Wf,-XNh2000     -nostdinc -I/usr/include -DSYSV -DSVR4  -DFUNCPROTO=7 -DNARROWPROTO   -c CatString3.c
gcc: unrecognized option `-32'
gcc: language ansi not recognized
cc1: Invalid option `-Wf,-XNh2000'
*** Error code 1 (bu21)
*** Error code 1 (bu21)
borusa 4% exit
script done on Thu Sep 26 11:59:36 1996

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Lance A. Brown" <[email-masked]>
Date: Mon, 30 Sep 1996 11:41:57 -0400

> cc1: Invalid option `-Wf,-XNh2000'

You've got the Makefiles using gcc with the SGI cc's command line
options.  Make sure you have the correct setttings for FvwmCompiler
and FvwmCompilerFlags in Fvwm.tmpl

--[Lance]

---

From: Guenther Grau <[email-masked]>
Date: Mon, 30 Sep 1996 18:58:40 +0200

> cc1: Invalid option `-Wf,-XNh2000'

Correct your imake-setup. These strange compile options come
from your local setup, not from fvwm.

  Guenther

P.S.: Imake could be a great help, if it were installed properly
at every site, but it can also be a nightmare if it isn't :-/
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Richard Lister <[email-masked]>
Date: Mon, 30 Sep 1996 17:09:26 +0100

From: Jonobie D Baker <[email-masked]>
Subject: FVWM: Problems with fvwm install on SGI...help?
Date: Mon, 30 Sep 1996 11:07:47 -0400 (EDT)

> making Makefiles in libs...
[...]
> cc1: Invalid option `-Wf,-XNh2000'

Try doing xmkmf -a instead of the make Makefiles. But the real problem
is that your imake setup is trying to use gcc (GNU C) instead of cc
(SGI C). The options passed to gcc here are really for cc. You really
need to correct your imake setup, but you *might* get away with
saying
    % xmkmf -a
    % make CC=cc

I get fvwm2 to compile very cleanly using cc on Irix 5.3/6.1/6.2.

Ric