Subject: Re: FVWM: pixmap borders patch

From: [email-masked] (Martin Cartwright)
Date: Thu, 26 Sep 1996 15:48:52 +0100

=> From: [email-masked] (Albrecht Kadlec)
=> Subject: Re: FVWM: pixmap borders patch
=> 
=> >>>>> Martin Cartwright writes:
=> 
<snip>
=> a switch FvwmLanguage= English/American English ;^)
=> I guess "Color" would be more consistent :-( - 'though I like Oxford english
=> 
=> 
\begin{comedy}
Well how about an e-mail widget that scans the e-mail address of the sender 
looking for .uk and then deletes all the extra "u" s from words like "colour"
and "flavour" and convert all the other erm.. "eccentricities" of English.
It could also move all the text to the other side of the screen. ;)
\end{comedy}

Back to FVWM.... 

I have 90 Style lines in my .fvwmrc. About half of these are exclusively
Icon definitions  The others all define various properties for the windows
along the lines of Stickyness, BorderWidth and the rest.  If I could set 
different windows to have different title styles I would. If I could do it
with less memory usage, so much the better. However, I'm not really 
going to push for anything, just suggest possible enhancements. 

Incidentally...

As I said, I define a large number of icons. This takes up a large chunk
of my .fvwmrc file. Can anybody suggest how I could remove the icon 
defintions to another file (.icons  ?) ??   

[email-masked] - http://star.pst.qub.ac.uk/~imc/vom.htm
-/-----------------------------------------------------------\-
|  "No challenge should be faced without a little charm,      |
|   and a lot of style."				      |
-\-----------------------------------------------------------/-

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Albrecht Kadlec)
Date: Thu, 26 Sep 96 17:17:10 +0200

>>>>> Martin Cartwright writes:

M> => From: [email-masked] (Albrecht Kadlec)
M> => Subject: Re: FVWM: pixmap borders patch

M> => a switch FvwmLanguage= English/American English ;^)
M> => I guess "Color" would be more consistent :-( - 'though I like Oxford english

M> \begin{comedy}

M> Well how about an e-mail widget that scans the e-mail address of the sender 
M> looking for .uk and then deletes all the extra "u" s from words like "colour"
M> and "flavour" and convert all the other erm.. "eccentricities" of English.
M> It could also move all the text to the other side of the screen. ;)

Shall I do an elisp function to be put into 'gnus-split-mesage-hook'
and post it here ?
Maybe just run ispell on incoming articles, with an american english dictionary.
This is Unix/Emacs, everything is all possible, you know. 

M> \end{comedy}

M> Back to FVWM.... 

M> I have 90 Style lines in my .fvwmrc. About half of these are exclusively

Quite a lot, how may windows do you have open, under normal conditions ?
You must have a 10:1 ratio between active windows and style definitions ...
Do you _really_ need another icon for each and every window ? ... alas, it
should be possible. (those, who want bloatage, will get bloatage, anyway.)
- no offense intended, I use Monet jpegs as X background, it sure makes my
sun IPC slower, when moving/redrawing, but I sure like it ....

AddToFunc NewBackground	"I"	X nice "xv +noresetroot -root -random
				-noqcheck -ncols 100 -max -smooth -quit 
				~/public_html/Pictures/*
				~/public_html/Pictures/hubble/* 
				~/public_html/Pictures/*/*/*"

M> Icon definitions  The others all define various properties for the windows
M> along the lines of Stickyness, BorderWidth and the rest.  If I could set 
M> different windows to have different title styles I would. If I could do it
M> with less memory usage, so much the better. However, I'm not really 
M> going to push for anything, just suggest possible enhancements. 

I don't think there's no tradeoff to be made.
One unsigned long for frequently used binary options,
and two pointers for icons should be affordable in the basic window
structure (I myself only use icons/miniicons to make the application class
visible at first glance.)

Or one separate pointer to a

struct IconPointers
{	IconPtr,
	MiniIconPtr, 
	Border_XPM_Ptr, 
	ButtonPixmapPtrs[10]
}
so the memory usage scales with your usage of different icons again.

M> Incidentally...

M> As I said, I define a large number of icons. This takes up a large chunk
M> of my .fvwmrc file. Can anybody suggest how I could remove the icon 
M> defintions to another file (.icons  ?) ??   

There doesn't seem to be any support for this in X.
Dare I say, Windows-95 is miles ahead, with each Application supporting
it's icon & miniicon. :-)

So Fvwm has to supply the icons to the applications, so it has to have a
lookup table. You can
	Read ~/.icons
	do an FvwmIconHandler module
	tweak m4
	is there an *icon resource this would move the stuff to .Xdefaults.

but you won't get around the lookuptable, untill every application supplies
it's icons.

cheers,
albrecht
-- 
Jesus, Mother Mary and a cloaked man are playing golf. Jesus tees off
and gets a hole-in-one. Mother Mary tees off and gets a hole-in-one.
The cloaked man tees off and misses the green completely and goes into
the water-trap. A fish spurts the ball out of the water, a bird
catches it and gives it to a squirrel, who drops it in the hole. Jesus
says "Dad, are you going to play golf, or what?"
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Patrice Fortier <[email-masked]>
Date: Thu, 26 Sep 1996 18:18:44 +0200 (MET DST)

> it's icon & miniicon. :-)

hmmm... The directory trees are not the same. If you want to set up a
FvwmIconHandler, you'll quickly see that all your .icon files will be
in /bin/ /usr/bin/ /usr/local/bin/ or /usr/X11/bin directories and not
in c:/gimp/ or /utils/seyon/...

Lokh.

---

From: Richard Lister <[email-masked]>
Date: Thu, 26 Sep 1996 17:35:26 +0100

From: [email-masked] (Martin Cartwright)
Subject: Re: FVWM: pixmap borders patch
Date: Thu, 26 Sep 1996 15:48:52 +0100

> defintions to another file (.icons  ?) ??   

I have the following in .fvwm2rc:

Read lib/fvwm/titlebar
Read lib/fvwm/keys
Read lib/fvwm/styles
Read lib/fvwm/menus
Read lib/fvwm/functions
Read lib/fvwm/buttonbar
Read lib/fvwm/modules

Ric

Richard J. Lister, Research Assistant    
Neural Computing Research Group, Aston University
[email-masked] 
http://www.ncrg.aston.ac.uk/~listerrj/ 
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].