Subject: FVWM: processes

From: "John Dawkins" <[email-masked]>
Date: Mon, 12 Aug 1996 10:46:28 -0400

everytime i restart fvwm2, i keep getting another running copy of swallowed
apps.  i am using the UseOld and NoClose options in my configuration file.
 what am i doing wrong??  i forgot to include some info yesterday.  i'm using a
Sun SparcStation 5.  i'm using fvwm2.0.43

*FvwmButtons(6x2, Swallow "FvwmPager" "FvwmPager 0 3")
*FvwmButtons(3x1, Swallow(UseOld,NoClose) "xdaliclock"  `Exec
/afs/eos/project/goodies/bin/xdaliclock &`)
*FvwmButtons(3x1, Swallow(UseOld,NoClose) "xload" `Exec xload -fg white -bg
gray55 -nolabel -scale 3 -update 5 &`)

thanks.

-- 

==================================================
||John Dawkins II                               ||
||Electrical & Computer Engineering             ||
||601A Bowen Hall -- Box 22781                  ||
||Raleigh, NC  27606                            ||
||(919)512-4584                                 ||
[email-masked]                         ||
||http://www4.ncsu.edu/~jjdawkin/www            ||
==================================================
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Albrecht Kadlec)
Date: Tue, 13 Aug 96 08:57:56 +0200

>>>>> John Dawkins writes:

J> everytime i restart fvwm2, i keep getting another running copy of swallowed
J> apps.  i am using the UseOld and NoClose options in my configuration file.
J>  what am i doing wrong??  i forgot to include some info yesterday.  i'm using a
J> Sun SparcStation 5.  i'm using fvwm2.0.43

J> *FvwmButtons(6x2, Swallow "FvwmPager" "FvwmPager 0 3")
J> *FvwmButtons(3x1, Swallow(UseOld,NoClose) "xdaliclock"  `Exec
J> /afs/eos/project/goodies/bin/xdaliclock &`)
J> *FvwmButtons(3x1, Swallow(UseOld,NoClose) "xload" `Exec xload -fg white -bg
J> gray55 -nolabel -scale 3 -update 5 &`)

try this:

AddToFunc ExitFunction	"I"	KillModule FvwmButtons
+			"I"	FvwmBanner
+			"I"	Wait FvwmBanner

this provides time to the FvwmButton module to unswallow the windows,
before the new one starts up.

albrecht
-- 
You say the hill's too steep to climb, Climb it!
You say you'd like to see me try, Climb it!
You pick the place and I'll choose the time
And I'll climb the hill in my own way
just wait a while, for the right day
And as I rise above the treeline and the clouds
I look down hear the sound of the things you said today	-- Pink Floyd
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].