Subject: FVWM: Focus and Warp with FvwmIconMan in fvwm2.0.43

From: [email-masked]
Date: Wed, 14 Aug 1996 22:27:08 -0600

I recently upgraded to fvwm2.0.43 from fvwm2.0.42,
and I'm having trouble getting the same behavior with
the FvwmIconMan module as I had before.

I want to have mouse button 1, when clicked on
an entry in the FvwmIconMan table, deiconify the window
if necessary, switch focus to
the selected window, and warp the cursor to that window.

In fvwm2.0.42, with a patch to the focus code,
I could do this via the following line in my .fvwm2rc file:

	*FvwmIconMan*action      click1 Iconify -1, Focus 1

Is there a way to get this same behavior in fvwm2.0.43?

Is a patch needed?

Thanks,

-- 
	Ron Olsen
	[email-masked]
	Boulder Colorado
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Charles Hines" <[email-masked]>
Date: Thu, 15 Aug 1996 08:45:32 -0400

>>>>> "Ron" == rgo  <[email-masked]> writes:

Ron> I recently upgraded to fvwm2.0.43 from fvwm2.0.42,
Ron> and I'm having trouble getting the same behavior with
Ron> the FvwmIconMan module as I had before.

Ron> I want to have mouse button 1, when clicked on
Ron> an entry in the FvwmIconMan table, deiconify the window
Ron> if necessary, switch focus to
Ron> the selected window, and warp the cursor to that window.

Ron> In fvwm2.0.42, with a patch to the focus code,
Ron> I could do this via the following line in my .fvwm2rc file:

Ron>    *FvwmIconMan*action      click1 Iconify -1, Focus 1

Ron> Is there a way to get this same behavior in fvwm2.0.43?

Ron> Is a patch needed?

Read the ChangeLog and you'll see that the Focus behavior has changed
to no longer warp the cursor (coincidentally, it was at the request of
FvwmIconMan's author, among many other people) and that was part of
what his patch covered.

Basically, you should be able to get the same behavior by calling a
function instead of the builtin Focus, which could be defined like so:

AddToFunc FocusAndWarp "I" Iconify -1
+                      "I" Focus
+                      "I" WarpToWindow 2p 2p

Chuck

*******************************************************************************
Charles K. Hines <[email-masked]>
IBM Logic Synthesis Developer [BooleDozer (TM)]
Martial Arts Instructor [Modern Arnis, Presas Style Filipino Martial Arts]

         "Go back to sleep, Chuck.  You're just havin' a nightmare
             -- of course, we ARE still in Hell." (Gary Larson)
*******************************************************************************
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Thu, 15 Aug 1996 15:24:23 -0600

>>>>> "Chuck" == Charles Hines <[email-masked]> writes:

>>>>> "Ron" == rgo  <[email-masked]> writes:

    Ron> I want to have mouse button 1, when clicked on an entry in
    Ron> the FvwmIconMan table, deiconify the window if necessary,
    Ron> switch focus to the selected window, and warp the cursor to
    Ron> that window.

    Chuck> Basically, you should be able to get the same behavior by
    Chuck> calling a function instead of the builtin Focus, which
    Chuck> could be defined like so:

    Chuck> AddToFunc FocusAndWarp "I" Iconify -1
    Chuck> +                      "I" Focus
    Chuck> +                      "I" WarpToWindow 2p 2p

Thanks! This does exactly what I want.
Now I have a new problem:

With fvwm2.0.42 (with focus patch),
I had the following line in my .fvwm2rc:

*FvwmIconMan*action      select Focus 0

This allowed sweeping the mouse down the FvwmIconMan table,
and input focus would be given to the selected window,
without changing the current viewport or raising the window.

With fvwm2.0.43, I tried the following:

*FvwmIconMan*action      Select    sendcommand select select Focus

Unfortunately, if the window is not iconified,
this causes the selected window to be raised,
and the viewport is warped to that of the selected window. 
This is very disconcerting and not at all what I want.

Is there a way to get the old behavior in fvwm2.0.43?
Is a patch needed? 

Brady Montz suggested changing
builtins.c to delete lines 204 (RaiseWindow) and
perhaps line 205 (KeepOnTop).  This fixes the problem
with the window getting raised, but I still get the
warping to the viewport that contains the window.

What can I do to eliminate the warping to another viewport?

Thanks,