Subject: FVWM: building fvwm 2.043

From: Henry McNair <[email-masked]>
Date: Mon, 12 Aug 1996 15:14:48 -0700

Hello:
  I am a novice at building fvwm and X in general; so please excuse any
  question that might seem trival or can be answered with "RTFM". :-)

  When I am building fvwm, I am asked to enter the command 
               "xmkmf;;make Makefiles"
  I have access to imake, but what is xmkmf? How can I get it? Can
  I use imake instead? The command ./MakeMakefile also uses xmkmf. So
  I am stumped. (I have modified the configuration files correctly,
  I hope. :-)

  I would really like to try using the new version. So any help
  you can give would be appreciated. I am trying to build on an
  HPUX 9.x system. 

-------------------------------------------------------------------
Henry McNair                               [email-masked]
Hewlett-Packard 
11000 Wolfe Road, MS-42U5                  (408)447-1967 - voice
Cupertino, CA 95014                        (408)447-4924 - FAX
-------------------------------------------------------------------
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Eric J. Betzler" <[email-masked]>
Date: Mon, 12 Aug 1996 17:27:51 -0500 (CDT)

>   you can give would be appreciated. I am trying to build on an

xmkmf is an imake command.
You should check to see that your OPENWINHOME environment variable is set 
to /usr/openwin.
I'm no expert, but this is what I had to do.
Also, if possible, type: make Makefiles 
instead of using the MakeMakefile script.

-Eric-

                         ''~''                                               
Eric J. Betzler         ( o o )          University of Minnesota-Duluth 
--------------------ooOo--(_)--oOoo------------------------------------

	"I can picture in my mind a world without war, a world
	 without hate.  And I can picture us attacking that world,
	 because they'd never expect it."
		- Jack Handey
WWW:                                     http://www.d.umn.edu/~ebetzler
EMail:               .oooO                           [email-masked]
Telephone:           (   )   Oooo.                       (218) 727-1458
----------------------\ (----(   )-------------------------------------
		       \_)    ) /
			     (_/

---

From: Kai Grossjohann <[email-masked]>
Date: 15 Aug 1996 11:31:20 +0200

>>>>> Henry McNair writes:

  Henry>   When I am building fvwm, I am asked to enter the command 
  Henry>                "xmkmf;;make Makefiles"
  Henry>   I have access to imake, but what is xmkmf?

Usually, X11 distributions have this xmkmf which is just a shell
script.  Maybe your X11 distribution is broken and doesn't have it.  I
include the one from Sun Solaris 2.5 OpenWindows below and you could
just adapt it to your machine (path settings and suchlike).

hth,
kai
-- 
What's a signature?

----------------------------------------------------------------------
#!/bin/sh

#
# generate a Makefile from an Imakefile from inside or outside the sources!
#

usage="usage:  $0 [top_of_sources_pathname [current_directory]]"

topdir=
curdir=.

case $# in 
    0) ;;
    1) topdir=$1 ;;
    2) topdir=$1  curdir=$2 ;;
    *) echo "$usage" 1>&2; exit 1 ;;
esac

case "$topdir" in
    -*) echo "$usage" 1>&2; exit 1 ;;
esac

if [ -f Makefile ]; then 
    echo mv Makefile Makefile.bak
    mv Makefile Makefile.bak
fi

if   [ -n "$topdir" ]; then
	args="-I$topdir/config -DTOPDIR=$topdir -DCURDIR=$curdir"

elif [ -n "$OPENWINHOME" ]; then
	args=" "-I$OPENWINHOME/lib/config

else
	args=" "-I/usr/lib/X11/config

fi

echo imake $args
imake $args