Subject: FVWM: window raising control

From: Alfred Leach <[email-masked]>
Date: Mon, 29 Jul 1996 17:45:36 -0400 (EDT)

How can I get fvwm to raise a window whenever there's a click anywhere in
the window (rather than only in the title bar)?  If this is not possible,
then is it at least possible to make it raise if you click on any part of
the border (sides, bottom, top, or title bar)?

Thanks in advance for any suggestions anyone can offer...

- Al Leach

     |      |                    Al Leach, Summer Intern
    |||    |||                   desk:  (919)472-2281
  .|||||..|||||.                 pager: 800-796-7363 pin# 100-0396
cisco Systems, Inc.              email: [email-masked]

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Kai Grossjohann <[email-masked]>
Date: 30 Jul 1996 12:02:36 +0200

>>>>> Alfred Leach writes:

  Al> How can I get fvwm to raise a window whenever there's a click
  Al> anywhere in the window (rather than only in the title bar)?

I have in my .fvwmrc (or .fvwm2rc):

Mouse 1 WFSIT   4       Move-or-RaiseLower

Just say `Raise' instead of `Move-or-RaiseLower'.  And use a different
modifier than 4 (which is the Alt key on my Sun Type 5 keyboard
running under Solaris 2.5/OpenWindows).  S (Shift) or C (Ctrl) might
be good values.

I don't advise you to use N (No modifier) or A (Any modifier) as that
would mean that Fvwm grabs your mouse click and it isn't passed on to
the application any longer.

Another approach is to use ClickToFocus where the default is to raise
the window when you click in it.

hth,
kai
-- 
Life is hard and then you die.

---

From: "Randall S. Winchester" <[email-masked]>
Date: Tue, 30 Jul 1996 11:00:52 -0400 (EDT)

Good luck! The real problem is that you will loose your cut/paste capability
if you do this with just a Click, along with messing up alot of other
applications. If you make it Control-Click, you will not be able to alter
your xterm settings and such. 

What I have settled with is to bind it to Meta-Click (The diamonds on my
Sparc5 keyboard by the space bar). This was the best compromise I could
find.

I use this:
Mouse 1         W       M       Raise

Not exactly the convienience of Win95, but still alot better then hunting
for a window border.

Randall

On 30 Jul 1996, Kai Grossjohann wrote:

: >>>>> Alfred Leach writes:
: 
:   Al> How can I get fvwm to raise a window whenever there's a click
:   Al> anywhere in the window (rather than only in the title bar)?
: 
: I have in my .fvwmrc (or .fvwm2rc):
: 
: Mouse 1 WFSIT   4       Move-or-RaiseLower
: 
: Just say `Raise' instead of `Move-or-RaiseLower'.  And use a different
: modifier than 4 (which is the Alt key on my Sun Type 5 keyboard
: running under Solaris 2.5/OpenWindows).  S (Shift) or C (Ctrl) might
: be good values.
: 
: I don't advise you to use N (No modifier) or A (Any modifier) as that
: would mean that Fvwm grabs your mouse click and it isn't passed on to
: the application any longer.
: 
: Another approach is to use ClickToFocus where the default is to raise
: the window when you click in it.
: 
: hth,
: kai
: -- 
: Life is hard and then you die.
: --
: Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
: To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
: message to [email-masked].
: To report problems, send mail to [email-masked].
: 
: