Subject: FVWM: 2.0.43 dies horribly

From: Marco Mariani <[email-masked]>
Date: Tue, 16 Jul 1996 12:52:52 -0100 (GMT-0100)

Hi all!

The following worked perfectly under 2.0.40, but kills 2.0.43 horribly.

AddToFunc RxvtSmall
+                          "I" exec rxvt -ls -fat -bg Black -fg White -font -b\&h-lucidatypewriter-medium-*-*-*-12-*-*-*-*-*-*-* -8 -sl 512 &

AddToFunc RxvtMedium
+                          "I" exec rxvt -ls -fat -bg Black -fg White -font -b\&h-lucidatypewriter-medium-*-*-*-14-*-*-*-*-*-*-* -8 -sl 512 &

AddToFunc RxvtLarge
+                          "I" exec rxvt -ls -fat -bg Black -fg White -font 10x20 -8 -sl 512 &

AddToMenu Rxvt          "Rxvt"          Title
+                       "%small.xpm%"   RxvtSmall
+                       "%medium.xpm%"  RxvtMedium
+                       "%large.xpm%"   RxvtLarge

Fvwm does not even launch the init function, just exists without any message.

This is under Linux 2.0.5 ELF + XFree 3.1.2E.

All The Best,
 Marco

640ktons ought to be enough for any William III.

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Charles Hines" <[email-masked]>
Date: Tue, 16 Jul 1996 16:41:45 -0400

>>>>> "Marco" == Marco Mariani <[email-masked]> writes:

Marco> Hi all!
Marco> The following worked perfectly under 2.0.40, but kills 2.0.43 horribly.

Marco> AddToFunc RxvtSmall
Marco> +                          "I" exec rxvt -ls -fat -bg Black -fg White -font -b\&h-lucidatypewriter-medium-*-*-*-12-*-*-*-*-*-*-* -8 -sl 512 &
....
Marco> AddToMenu Rxvt          "Rxvt"          Title
Marco> +                       "%small.xpm%"   RxvtSmall
....
Marco> Fvwm does not even launch the init function, just exists
Marco> without any message.

Well, although it shouldn't die (and I'll look into that when I get a
chance), you really have a syntax error there.  The first entry of the
function belongs on the the AddToFunc line, like so:

AddToFunc RxvtSmall "I" exec rxvt -ls -fat -bg Black -fg White -font -b\&h-lucidatypewriter-medium-*-*-*-12-*-*-*-*-*-*-* -8 -sl 512 &

Or, since those functions are only doing one thing anyways, why not
have the menu items just call the 'exec rxvt' directly instead of a
function call?  Or perhaps better, set up a function that takes font
to use as a parameter and have the menu call that passing in the font
size?

Chuck

---

From: Marco Mariani <[email-masked]>
Date: Wed, 17 Jul 1996 13:19:27 -0100 (GMT-0100)

On Tue, 16 Jul 1996, Charles Hines wrote:

> Marco> +                    "I" exec rxvt -ls -fat -bg Black -fg White -font
> ....
> chance), you really have a syntax error there.

Actually, it's the "%small.xpm%" which makes it die.

[FVWM][main]: <<DEBUG>> Entered, about to parse args
[FVWM][main]: <<DEBUG>> Done parsing args
[FVWM][main]: <<DEBUG>> Installing signal handlers
[FVWM][main]: <<DEBUG>> Setting up rc file defaults...
[FVWM][main]: <<DEBUG>> Running config_command...

waiting for X server to shut down

The same icons I used with 2.0.40 kept working.

> function call?

Because I also use a menu which is identical to the one above, but without
the title, and have put it into FvwmButtons. I also have an hotkey associated
with RxvtLarge and RxvtMedium.

> Or perhaps better, set up a function that takes font to use as a parameter
> and have the menu call that passing in the font size?

This is a good point :-)

Also, I tried to use FvwmButtons with both the config files you ship, but
the button bar simply doesn't appear.
The module tries to load, because it complains if there are syntax errors,
otherwise it silently does nothing.

The same goes for FvwmConfig and WinList.

Pager works, and also Identify, IconBox, Banner, Talk.

All The Best,
 Marco

---

From: Hector Peraza <[email-masked]>
Date: Wed, 17 Jul 1996 21:15:04 +0200 (MET DST)

Hi,

> Actually, it's the "%small.xpm%" which makes it die.

Are you using libXpm-4.7 by any chance? That version seems to have a bug
or incompatibility that causes fvwm to die when a pixmap cannot be found
or is corrupt. Version 4.3 or 4.6 works OK. 

Regards,
Hector.