Subject: FVWM: FvwmConsole

From: Grant McDorman <[email-masked]>
Date: Wed, 10 Jul 1996 15:09:59 -0400 (EDT)

One of the most likely reasons it doesn't work is that it is
running wildly off the end of a malloc'd array (by about two
elements), and thus stomping memory.

There are also some initializers that are illegal (but presumably
accepted by gcc).

With those two problems fixed, it ran fine on Solaris 2.4 (with
Sun's compiler, not gcc).

I can send the patches if anyone is interested.

Grant McDorman <[email-masked]>
				ISG Technologies, Inc.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Grant McDorman <[email-masked]>
Date: Wed, 10 Jul 1996 16:19:58 -0400 (EDT)

On 10-Jul-96 19:50:47 [email-masked] wrote:
> > ===>Grant McDorman writes:
> 
>     Grant> One of the most likely reasons it doesn't work is that it is running
>     Grant> wildly off the end of a malloc'd array (by about two elements), and
>     Grant> thus stomping memory.
> 
>     Grant> There are also some initializers that are illegal (but presumably
>     Grant> accepted by gcc).
> 
>     Grant> With those two problems fixed, it ran fine on Solaris 2.4 (with
>     Grant> Sun's compiler, not gcc).
> 
> I tried building it using gcc 2.7.2.  Does not seem to work.  When I start it,
> it just freezes up my computer (I have to remember where the hell is the off
> switch, just to show that I seldom close it). Did you have the same kind of
> problem(s)?  I do have Solaris 2.4 running on a Sparc 5.

No, but the result of memory corruption is unpredictable. It may be that
something (malloc heap management?) gets into a tight loop with this
corruption on your system.

I just got a SIGSEGV in malloc.

>     Grant> I can send the patches if anyone is interested.
> 
> I'm definitely interrested!
> 
> 
> Thanks and my best regards

Okay, here you go.