Subject: FVWM: how do I change circulate list dynamically ?

From: Jan Vicherek <[email-masked]>
Date: Tue, 2 Jul 1996 21:05:07 -0400 (EDT)

PS : I'm not subscribed. reply to [email-masked]. I'll also check the archives.

 Hi.

  First of all, I would appreciate any answers that would even get me
started in the right direction. 

   Is there a way to dynamicaly (w/out reloading the config file) assign a
key shortcut to a window ? (e.g. upon pressing a the shortcut, fvwm jumps
to the section of vitual desktop where the window is)

   Is there a way to do it statically ? (by reloading the config file)
E.g. have certain viewports into a desktop on the Alt-Shift-F<n> keys.

      Thanx,

           Jan

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Kai Grossjohann <[email-masked]>
Date: 03 Jul 1996 11:27:14 +0200

>>>>> On Tue, 2 Jul 1996 21:05:07 -0400 (EDT), Jan Vicherek
>>>>> <[email-masked]> said:

  Jan> Is there a way to dynamicaly (w/out reloading the config file)
  Jan> assign a key shortcut to a window ? (e.g. upon pressing a the
  Jan> shortcut, fvwm jumps to the section of vitual desktop where the
  Jan> window is)

The following is not what you asked for, but may be useful
nevertheless.  When you bind `Module FvwmForm SelWin' to a key, that
key pops up a window.  You can enter the name of a window in there (or
a substring thereof), hit enter, and you'll be warped to the first
window that matches this substring.  (You may also be able to use `*'
as a wildcard, but I'm not sure.)

Add the following to your .fvwm2rc:

##########################FvwmForm#Select#Window########################
*SelWinWarpPointer
*SelWinFont         *helvetica*m*r*n*14*
*SelWinButtonFont   *helvetica*m*o*n*14*
*SelWinInputFont    *cour*m*r*n*14*
*SelWinFore         Black
*SelWinBack         Light Gray
*SelWinItemFore          Wheat
*SelWinItemBack          Gray50
# begin items
*SelWinLine         center
*SelWinText         "Select Window"
*SelWinLine         center
*SelWinText         "Pattern:"
*SelWinInput        WinPat  20   ""
*SelWinLine         expand
*SelWinButton       quit "Go"        ^M
*SelWinCommand      Next [*$(WinPat)*] Function GoThere
*SelWinButton       restart   "Clear"
*SelWinButton       quit "Cancel"  ^[
*SelWinCommand Nop

All of this has been shamelessly stolen from some FvwmForm example.
If forget which one, though.

I use this often.
kai
-- 
Life is hard and then you die.