Subject: FVWM:2.0.43 does not compile under Linux/AXP

From: [email-masked] (Francois Jaccard)
Date: Wed, 10 Jul 1996 19:44:04 GMT

Hi,

I tried to compile Fvwm 2.0.43 under my Red Hat 3.0.3 linux running on an Dec
Alpha Cabriolet (kernel 2.0.4) without success.

I had to remove the KLUDGE_LIBS = -ldnet_stub (I don't have a libdnet_stub.a)
in Fvwm.tmpl and also remove the two prototypes for bzero and gethostname in
fvwm/alpha_header.h and it then compiled and it seems to run ok.

Any comment on this?

-- 
Francois Jaccard
PGP Key ID: 0x3D7B9109
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Todd Tyrone Fries <[email-masked]>
Date: Sun, 14 Jul 1996 16:00:34 -0500 (CDT)

[FVWM][main]:  Fvwm Version 2.0.43 compiled on Jul 14 1996 at 15:00:03
Linux LightHouse 2.0.6 #11 Sun Jul 14 14:31:13 CDT 1996 i586

A small suggestion, though:

The 'Dir' #defines would be helped, imho, if the following were used:

/***************************************************************************
 * The following line only needs to be uncommented if you do not want
 * Imake's default behavior.
 * Uncomment and edit to suit your requirements.
 ***************************************************************************/
/* #define FvwmPREFIX /usr/local/X11R6 */

#ifdef FvwmPREFIX
/* Where do you want the fvwm binaries installed */
#define FvwmBinDir FvwmPREFIX/bin

/* Where do you want the fvwm modules installed. */
#ifdef RenameFVWM2
#define FvwmDir FvwmPREFIX/lib/X11/fvwm2
#else
#define FvwmDir FvwmPREFIX/lib/X11/fvwm
#endif

/* Where do you want the fvwm libraries installed. */
#define FvwmLibDir FvwmPREFIX/lib

/* Where do you want the fvwm man pages installed */
#define FvwmManPath FvwmPREFIX/man
#define FvwmManSuffix 1

#endif /* FvwmPREFIX */

Notice this changes nothing from the current behavior (except correctly
handle the case if I don't rename fvwm to fvwm2 <grin>)...but does make
it considerably easier to change the default location...

My purpose in suggesting the above is threefold:

1) single line uncomment vs 5
2) singe line edit (in most cases) vs 5
3) get people used to the idea of a 'prefix', for easy introduction to
   autoconf's '--prefix=' command line option.

Comments?
--
Todd Fries .. [email-masked]