Subject: FVWM: 'module failed:' ??

From: [email-masked] (Todd Fries)
Date: Thu, 25 Jul 1996 20:48:32 -0500 (CDT)

I have a menu that appears when I click with my right button on the
background:

AddToMenu "DeskMenu"
+ "Grab a Shell%mini-term.xpm%" Exec rxvt
+ "" Nop

are the first items added.

If I click once, let the menu show up, I'm guessing if I let greater than
0.5s pass between the time I click to bring the menu up and the time I click
on this button to 'grab a shell' I get no error messages.

However, if I click quickly, which is the reason I have it as the first
item on the menu, then I get the following errors from fvwm:

[FVWM][executeModule]: <<ERROR>> Execution of module failed: /usr/local/lib/fvwm/
Permission denied

This is with fvwm 2.0.43.  I have no clue why this would happen, but it
doesn't seem like the right behavior to me!

-- 
Todd Fries .. [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Chris Laas <[email-masked]>
Date: Fri, 26 Jul 1996 01:03:20 -0400

Todd Fries wrote:
>[snip]
> [snip]

Your problem is on the first line of your menu definition, AddToMenu "DeskMenu".
Fvwm expects an item and command of some sort after each AddToMenu command, so the
way you have it now, Fvwm interprets there being some sort of null command there,
and tries to execute it, failing of course.  At least, that's the way I interpreted
it when I got the same errors.  The way to fix it is to move the first line of you
menu definition to the AddToMenu line, like this:
    AddToMenu "DeskMenu" "Grab a Shell%mini-term.xpm%" Exec rxvt &
It's ugly, yes, but it works.  The Fvwm developers should fix this for 2.1.0, if
they can.  It's not so bad if you do something like:
    AddToMenu "DeskMenu" "Desk Menu" Title
Then you can pretend that the Title is meant to go in the AddToMenu line :)

Hope this helps!

--Xris

-- 
"If A equals success, then the formula is A = X + Y + Z.  X is work.  Y is
play.  Z is keep your mouth shut." -- Albert Einstein

"I'm not like John Lennon, who thought he was the Almighty.  I just think I'm
John Lennon." -- Noel Gallagher, lead singer, guitarist, and songwriter of
Oasis, on the importance of remaining humble despite great fame.

Chris "Xris" Laas (that's me!) can be found lurking at [email-masked] or
[email-masked].  If I say something wrong, don't hold Dream Communications
responsible; however, if I have an idea inspired by genius, Dreamcom owns it.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].