Subject: FVWM: Problems doing make Makefiles

From: Joel Young <[email-masked]>
Date: Sun, 14 Jul 1996 01:48:57 -0400 (EDT)

Howdy,

  When I try to compile fvwm-2.0.43, I get 
Makefile:683: *** missing separator.  Stop.

If I look at line 683 I see:

    679 tags::
    680          $(TAGS) -w *.[ch]
    681          $(TAGS) -xw *.[ch] > TAGS
    682
    683 ManKeywordsTarget($(MANPATH))
    684
    685 # ----------------------------------------------------
    686 # rules for building in SUBDIRS - do not edit
    687
    688 install::
    689          @case '${MFLAGS}' in *[ik]*) set +e;; esac; \
    690

If I try to comment this out, then I get 

make Makefiles
Makefile:798: *** missing separator.  Stop.   

    791          do \
    792          (cd $$i ; echo including "in $(CURRENT_DIR)/$$i..."; \
    793          $(MAKE) $(MFLAGS)  includes); \
    794          done
    795
    796 # -------------------------------------------------
    797 # dependencies generated by makedepend
    798 IncludeMakefile(Makefile.dep)
    799

commenting out this gives me many missing separator messages all over
the place.

I am using Linux kernel 2.0.6 with XFree86 3.1.2E.

Any suggestions?

Joel
[email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Karl M. Hegbloom" <[email-masked]>
Date: Sun, 14 Jul 1996 11:48:20 -0700

>>>>> "Joel" == Joel Young <[email-masked]> writes:

    Joel>   When I try to compile fvwm-2.0.43, I get Makefile:683: ***
    Joel> missing separator.

 Missing separator means that a tab got converted to spaces, probably
in the Imakefile.

target: <tab> dependancy
<tab>	commandline	@\\
<tab>	commandline	@\\

not

target: <spaces> dependancy
<spaces> commandline @\\
<spaces> commandline @\\

 Convert the spaces back to tabs and it should work again.

--
Karl M. Hegbloom <[email-masked]>
http://www.teleport.com/~karlheg
(K0D) AYG-GE01  Portland, OR, USA
Proudly running Linux 2.0.5 and GNU public software!
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Joel Young <[email-masked]>
Date: Sun, 14 Jul 1996 17:11:01 -0400 (EDT)

Thanks for the response,

   I figured out the problem...

About a week ago, I upgraded my Motif to Red Hat Motif 2.0.
During the install, Red Hat overwrote several of the files
in /usr/X11R6/lib/X11/config, particularly

Imake.rules
Project.tmpl
linux.cf
site.def

By putting these back to the originals, I was able to 
compile with no problems.  I am running XFree86 3.1.2E
which is X11R6.1.  I suspect that imake may be slightly 
incompatible with previous versions, thus the motif changes
(dated Jan and Mar 1995) did not work.  Have contacted
Red Hat.

Thanks...

Joel