Subject: Re: FVWM: compilation problems

From: Peter Jeremy <[email-masked]>
Date: Tue, 30 Jul 1996 07:14:17 +1000 (EST)

On Mon, 29 Jul 1996, Kai Grossjohann <[email-masked]> wrote:
>>>>>> James A Basilio writes:
>
>  JAB> can anyone give me a tip as to how to fix this error message?
>  JAB> ld: Undefined symbol
>  JAB>    _strerror
>
>You get 2.0.43 where this is fixed (I think) or you just fix it
>yourself:  strerror(x) can be substituted with sys_errlist[x] on
>SunOS.  Just:
>
>    #ifdef <Variable_that_sez_SunOS_goes_here>
>    #define strerror(x) sys_errlist[x]
>    #endif
>
>somewhere.

Actually the above #define is not safe.  Consider what happens when (x)
is outside the range [0..sys_nerr).  A better choice is to get a copy of
strerror(3) from 4.4BSD, FreeBSD2.x, Linux, bind-4.9.[34] or similar.

Peter
----
Peter Jeremy (VK2PJ)                    [email-masked]
Alcatel Australia Limited
41 Mandible St                          Phone: +61 2 690 5019
ALEXANDRIA  NSW  2015                   Fax:   +61 2 690 5247
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Kai Grossjohann <[email-masked]>
Date: 30 Jul 1996 11:59:07 +0200

>>>>> Peter Jeremy writes:

  Peter> Actually the above #define is not safe.  Consider what
  Peter> happens when (x) is outside the range [0..sys_nerr).

You're right.  But this very quick and very dirty solution has been
working for me for the past few months.  Your suggestion is prolly
better, but then there's 2.0.43 where this is fixed (isn't it?)...

kai
-- 
Life is hard and then you die.

---

From: "James A. Basilio" <[email-masked]>
Date: Tue, 30 Jul 1996 07:53:13 -0400 (EDT)

It's all fixed now.  I did the responsible thing and deleted the line.  :)
Thanks to everyone for making me realize what it was.

-Jim