Subject: FVWM: Problem with fvwm2 and nethack/X11

From: Alan Shutko <[email-masked]>
Date: Tue, 18 Jun 1996 18:34:59 -0500

Nethack does something which seems to display a problem in fvwm,
versions 1.24 and 2.0.42.

Nethack/X11 displays a lot of small windows (eg 266x18) to ask about
actions, to display more input, etc.  In some cases, it pops up
several of these windows in succession, for further input.  When it
does this, there is a large pause between the windows.  (The main
nethack window doesn't refresh, NH seems stuck.)  If I cause NH to
open a larger window (like an inventory window) to break up a sequence
of smaller windows, there is no such problem.

There is no such problem with twm.  What information would be useful
in debugging this?  I'm including below a commented typescript of
xwininfo and xprop for a typical window sequence.  I can reproduce
this problem at will, so I can look at anything needed.

Script started on Tue Jun 18 17:53:14 1996

#
# Win 1 up
#

[17:53:14] hubert:~ $ xprop
WM_STATE(WM_STATE):
		window state: Normal
		icon window: 0x0
WM_PROTOCOLS(ATOM): protocols  WM_DELETE_WINDOW
WM_TRANSIENT_FOR(WINDOW): window id # 0x4c00020
WM_CLIENT_LEADER(WINDOW): window id # 0x4c00020
WM_CLASS(STRING) = "query", "NetHack"
WM_HINTS(WM_HINTS):
		Client accepts input or input focus: True
		Initial state is Normal State.
		window id # of group leader: 0x4c00020
WM_NORMAL_HINTS(WM_SIZE_HINTS):
		program specified location: 333, 439
		program specified size: 266 by 17
		window gravity: NorthWest
WM_CLIENT_MACHINE(STRING) = "hubert"
WM_NAME(STRING) = "query"
[17:53:24] hubert:~ $ xwininfo

xwininfo: Please select the window about which you
          would like information by clicking the
          mouse in that window.

xwininfo: Window id: 0x4c0007e "query"

  Absolute upper-left X:  338
  Absolute upper-left Y:  461
  Relative upper-left X:  0
  Relative upper-left Y:  0
  Width: 266
  Height: 17
  Depth: 8
  Visual Class: PseudoColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x21 (installed)
  Bit Gravity State: NorthWestGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: yes
  Map State: IsViewable
  Override Redirect State: no
  Corners:  +338+461  -420+461  -420-290  +338-290
  -geometry 266x17+333+439

#
# Win 2 up
#

[17:53:34] hubert:~ $ xwininfo[3Pprop
WM_STATE(WM_STATE):
		window state: Normal
		icon window: 0x0
WM_PROTOCOLS(ATOM): protocols  WM_DELETE_WINDOW
WM_TRANSIENT_FOR(WINDOW): window id # 0x4c00020
WM_CLIENT_LEADER(WINDOW): window id # 0x4c00020
WM_CLASS(STRING) = "query", "NetHack"
WM_HINTS(WM_HINTS):
		Client accepts input or input focus: True
		Initial state is Normal State.
		window id # of group leader: 0x4c00020
WM_NORMAL_HINTS(WM_SIZE_HINTS):
		program specified location: 327, 450
		program specified size: 266 by 17
		window gravity: NorthWest
WM_CLIENT_MACHINE(STRING) = "hubert"
WM_NAME(STRING) = "query"
[17:54:58] hubert:~ $ xpropwininfo

xwininfo: Please select the window about which you
          would like information by clicking the
          mouse in that window.

xwininfo: Window id: 0x4c00080 "query"

  Absolute upper-left X:  332
  Absolute upper-left Y:  472
  Relative upper-left X:  0
  Relative upper-left Y:  0
  Width: 266
  Height: 17
  Depth: 8
  Visual Class: PseudoColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x21 (installed)
  Bit Gravity State: NorthWestGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: yes
  Map State: IsViewable
  Override Redirect State: no
  Corners:  +332+472  -426+472  -426-279  +332-279
  -geometry 266x17+327+450

#
# Win 3 up
#

[17:55:04] hubert:~ $ xwininfo

xwininfo: Please select the window about which you
          would like information by clicking the
          mouse in that window.

xwininfo: Window id: 0x4c00082 "query"

  Absolute upper-left X:  363
  Absolute upper-left Y:  469
  Relative upper-left X:  0
  Relative upper-left Y:  0
  Width: 266
  Height: 17
  Depth: 8
  Visual Class: PseudoColor
  Border width: 0
  Class: InputOutput
  Colormap: 0x21 (installed)
  Bit Gravity State: NorthWestGravity
  Window Gravity State: NorthWestGravity
  Backing Store State: NotUseful
  Save Under State: yes
  Map State: IsViewable
  Override Redirect State: no
  Corners:  +363+469  -395+469  -395-282  +363-282
  -geometry 266x17+358+447

[17:55:22] hubert:~ $ xwininfo[3Pprop
WM_STATE(WM_STATE):
		window state: Normal
		icon window: 0x0
WM_PROTOCOLS(ATOM): protocols  WM_DELETE_WINDOW
WM_TRANSIENT_FOR(WINDOW): window id # 0x4c00020
WM_CLIENT_LEADER(WINDOW): window id # 0x4c00020
WM_CLASS(STRING) = "query", "NetHack"
WM_HINTS(WM_HINTS):
		Client accepts input or input focus: True
		Initial state is Normal State.
		window id # of group leader: 0x4c00020
WM_NORMAL_HINTS(WM_SIZE_HINTS):
		program specified location: 358, 447
		program specified size: 266 by 17
		window gravity: NorthWest
WM_CLIENT_MACHINE(STRING) = "hubert"
WM_NAME(STRING) = "query"

--
Alan Shutko <[email-masked]> - The Few, the Proud, the Remaining.
"I am BillDCat of Borg. You will be ass--<Acckk! Thbbbpt!&lt;--imilated!"
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Markus Gutschke <[email-masked]>
Date: Wed, 19 Jun 1996 07:19:33 +0200

> versions 1.24 and 2.0.42.

This is not entirely helpful to your problem, but have you had a look
at Nethack/Qt as available from
"http://student.uq.edu.au/~s002434/nhqt/"? It looks a lot better than
standard Nethack/Xt.

Markus