Subject: FVWM: Fvwm2 Audio ?

From: [email-masked] (Ray Curtis)
Date: Mon, 24 Jun 1996 21:33:58 -0400

I am using fvwm2 and have been using Fvwm-Audio to play sound
files for some things in the past. I recently installed
'rsynth' on my system and would like to make Fvwm-Audio play
messages using 'say' from the 'rsynth' package. Has anyone
tried this, or know if this is possible ? This would be real
neat to be able to play any message you wanted. Rsynth seems
to work pretty well using the British dictionary.

Any info or pointers appreciated, thanks,

--------------------------------------------------------------------
** When you can keep your head and all about are losing theirs...
 maybe you just don't understand the situation **

   __   _
  / /  (_)__  __ ____  __        Linux Host 'Ray'
 / /__/ / _ \/ // /\ \/ /        Ray Curtis 
/____/_/_//_/\___/ /_/\_\        e-mail: [email-masked]

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mark Boyns <[email-masked]>
Date: 24 Jun 1996 21:43:56 -0700

> to work pretty well using the British dictionary.

That sounds possible.  Do you want it to say things like "open",
"close", etc?

Try something like this:

*FvwmAudioPlayCmd /usr/local/bin/say
*FvwmAudio deiconify open
*FvwmAudio iconify close
*FvwmAudio raise_window raise
*FvwmAudio lower_window lower

This will invoke say as `say open', `say close', `say raise', and 
`say lower'.

-- 
Mark Boyns <[email-masked]> <URL:http://www.sdsu.edu/~boyns/>
PGP fingerprint = D3 28 A2 F7 D1 4C F8 EE  BF 7A 11 54 1C E5 6E CC
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Ray Curtis)
Date: Tue, 25 Jun 1996 10:03:48 -0400

>>>>> "MB" == Mark Boyns <[email-masked]> writes:

This works great for single words, however does not work
for statements enclosed in quotes, such as "open window". This works
in a xterm as:  say "open window".
Any other ideas ?
Thanks,

    >> to work pretty well using the British dictionary.

    MB> That sounds possible.  Do you want it to say things like "open",
    MB> "close", etc?

    MB> Try something like this:

    MB> *FvwmAudioPlayCmd /usr/local/bin/say
    MB> *FvwmAudio deiconify open
    MB> *FvwmAudio iconify close
    MB> *FvwmAudio raise_window raise
    MB> *FvwmAudio lower_window lower

    MB> This will invoke say as `say open', `say close', `say raise', and 
    MB> `say lower'.

   __   _

---

From: [email-masked] (Albrecht Kadlec)
Date: Tue, 25 Jun 96 16:39:30 +0200

>>>>> Ray Curtis writes:

>>>>> "MB" == Mark Boyns <[email-masked]> writes:
R> This works great for single words, however does not work
R> for statements enclosed in quotes, such as "open window". This works
R> in a xterm as:  say "open window".

if you need quotes on the xterm command line, you'll need a second pair of
quotes for fvwm2 to use it as a single "filename" :-)
like:
*FvwmAudio iconify '"Mission accomplished"'

sorry, can't test it, no "say" command :-(
albrecht

R> Any other ideas ?
R> Thanks,

-- 
Life is like a hot bath, feels great while you are in it.
But the longer you stay, the more wrinkled you get.	-- Garfield
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Albrecht Kadlec)
Date: Tue, 25 Jun 96 16:56:26 +0200

sorry, forget my previous post, sugesting quote-layers:
I tried

*FvwmAudioPlayCmd playaudio
*FvwmAudio deiconify open
*FvwmAudio iconify close
*FvwmAudio raise_window '\"Mission accomplished\"'

with playaudio being:

#!/usr/local/lbin/tcsh
echo ${argv[1-]} > /dev/console

;-)

how is an underline pronounced by "say" ?

id est: can you say Mission_accomplished ?

BTW: I think it's a bug. A quoted parameter to FvwmAudion should be treated
as ONE parameter.
Maybe someone has a "These were the times.au" file?
It's possible in unix, so it should be possible to play it.

cheers,
albrecht
-- 
I was in the kitchen		Seamus, that's the dog was outside
Well, I was in the kitchen	Seamus, my old hound was outside
Well, you know the sun was sinking slowly
But my hound just sat right down and cried	-- Pink Floyd, "Seamus"
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Ray Curtis)
Date: Tue, 25 Jun 1996 14:33:55 -0400

>>>>> "A" == Albrecht Kadlec <[email-masked]> writes:

>>>>> Ray Curtis writes:
Sorry, this doesn't work either. What is the reason for the second
set of quotes? Any other ideas ?
Thanks,

    A> if you need quotes on the xterm command line, you'll need a second pair of
    A> quotes for fvwm2 to use it as a single "filename" :-)
    A> like:
    A> *FvwmAudio iconify '"Mission accomplished"'

    A> sorry, can't test it, no "say" command :-(
    A> albrecht

    R> Any other ideas ?
    R> Thanks,

   __   _

---

From: [email-masked] (Ray Curtis)
Date: Tue, 25 Jun 1996 15:03:43 -0400

To use rsynth, you use the command 'say'. From a xterm if you
use "say Mission accomplished", it will pronounce it correctly
with no quotes at all. If I try say _ it will pronunce the
word "underscore".
It works pretty well, except I can't get it to work with fvwm2.
Any other ideas ?
This is a sample of my fvwm audio, do you see anything wrong here ?
It will pronounce all these words in a xterm shell.

# FvwmAudio
#
*FvwmAudioPlayCmd /usr/bin/say 
*FvwmAudio startup '"Welcome to Ray's Linux Machine !"' 
*FvwmAudio shutdown '"I am shutting down now !"' 
*FvwmAudio unknown '"goofed up"'
*FvwmAudio destroy_window '"destroy window'"
*FvwmAudio iconify '"lower window"'
*FvwmAudio deiconify '"open window"'
*FvwmAudio add_window '"Add new window now !"'
*FvwmAudio toggle_paging '"toggle paging"'
*FvwmAudioDelay 3
*FvwmAudio focus_change '"focus window"'
*FvwmAudio raise_window '"Raise window"'
*FvwmAudio lower_window '"Lower window"'

    A> sorry, forget my previous post, sugesting quote-layers:
    A> I tried

    A> *FvwmAudioPlayCmd playaudio
    A> *FvwmAudio deiconify open
    A> *FvwmAudio iconify close
    A> *FvwmAudio raise_window '\"Mission accomplished\"'

    A> with playaudio being:

    A> #!/usr/local/lbin/tcsh
    A> echo ${argv[1-]} > /dev/console

    A> ;-)

    A> how is an underline pronounced by "say" ?

    A> id est: can you say Mission_accomplished ?

    A> BTW: I think it's a bug. A quoted parameter to FvwmAudion should be treated
    A> as ONE parameter.
    A> Maybe someone has a "These were the times.au" file?
    A> It's possible in unix, so it should be possible to play it.

   __   _

---

From: Matt Estela <[email-masked]>
Date: Wed, 26 Jun 1996 10:51:59 +1000 (EST)

Did you try removing the quotes completely? I remember I had a similar
problem getting fvwm to spawn an xterm running lynx with a specific URL.
I was trying

Exec xterm -e "lynx http://www.blah" &

which failed miserably, but when I tried

Exec xterm -e lynx http://www.blah &

it worked fine.

Yours etc,

Matthew Estela /Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/
[email-masked]             http://www.progsoc.uts.edu.au/~mestela
Research is what I'm doing when I don't know what I'm doing.
		-- Wernher von Braun

---

From: [email-masked] (Ray Curtis)
Date: Tue, 25 Jun 1996 21:55:49 -0400

-----BEGIN PGP SIGNED MESSAGE-----

Yes, that is all it was. The quotes were not needed. 
Thanks for the help.

>>>>> "ME" == Matt Estela <[email-masked]> writes:

    ME> Did you try removing the quotes completely? I remember I had a similar
    ME> problem getting fvwm to spawn an xterm running lynx with a specific URL.
    ME> I was trying

    ME> Exec xterm -e "lynx http://www.blah" &

    ME> which failed miserably, but when I tried

    ME> Exec xterm -e lynx http://www.blah &

    ME> it worked fine.

    ME> Yours etc,

    ME> Matthew Estela /Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/Z/
    ME> [email-masked]             http://www.progsoc.uts.edu.au/~mestela
    ME> Research is what I'm doing when I don't know what I'm doing.
    ME> 		-- Wernher von Braun

- --------------------------------------------------------------------
** When you can keep your head and all about are losing theirs...
 maybe you just don't understand the situation **

   __   _

---

From: [email-masked] (Albrecht Kadlec)
Date: Wed, 26 Jun 96 10:30:05 +0200

>>>>> Ray Curtis writes:

R> Yes, that is all it was. The quotes were not needed. 
R> Thanks for the help.

I tried it without quotes, but it doesn't work.
For me it looks, like FvwmAudio only uses the first word as a
parameter.

try the followin Patch
FvwmAudio: Line 302

	      else  {
		message = strtok(NULL, " \t");
-		sound = strtok(NULL, " \t");
+		sound = strtok(NULL, "\n");
	    
		if (!message || !*message || !sound || !*sound)

this worked for me.

albrecht
-- 
On the outskirts of nowhere,
On the ringroad to somewhere,
On the verge of indecision,
I'll always take the roundabout way.	-- Marillion
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].