Subject: Re: FVWM: Fvwm2 Question

From: Dan Espen <[email-masked]>
Date: Thu, 20 Jun 1996 10:51:20 -0400

[email-masked] (Ray Curtis) writes:
> 
> Hi Guys,
> 	I am new to this list, however I have a question about fvwm2.
> I don't seem to be able to have (2) two commands on the same line in
> a menu. In the old fvwm I was able to do this:
> 
> +	"Pine" 	Exec /usr/bin/popclient -3 -u XXXXX -p XXXXXXX bigdog\ 
> -o /var/spool/mail/ray;xterm -fg black -bg white -fn 10x20\ 
> -geometry 82x27+16+32 -ls -e pine &
> 
> Note the semi-colon where I seperate the (2) commands.
> This is all one line, but doesn't work. I hope this isn't a dumb
> question asked all the time, but I can't seem to find anything
> on it. 
> 
> Any info or pointers appreciated and thanks for your patience,

2 commands to an Exec stopped working in 2.0.42.  The workaround
is to enclose the command in a '/bin/sh -c <cmd>' like this:

+	"Pine" 	Exec /bin/sh -c '/usr/bin/popclient -3 -u XXXXX -p XXXXXXX \
 bigdog\
-o /var/spool/mail/ray;xterm -fg black -bg white -fn 10x20\ 
-geometry 82x27+16+32 -ls -e pine'

Whether this will change in 2.0.43 is not clear to me.

> --------------------------------------------------------------------
> ** When you can keep your head and all about are losing theirs...
>  maybe you just don't understand the situation **
> 
>    __   _
>   / /  (_)__  __ ____  __        Linux Host 'Ray'
>  / /__/ / _ \/ // /\ \/ /        Ray Curtis 
> /____/_/_//_/\___/ /_/\_\        e-mail: [email-masked]
> --

--
Dan Espen                                    Phone: (908) 699-5570
[email-masked]
444 Hoes Lane  Room RRC 1C-214
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Emilio Lopes)
Date: Thu, 20 Jun 96 12:23 EST

>>>>> "DE" == Dan Espen <[email-masked]> wrote:

DE> 2 commands to an Exec stopped working in 2.0.42.  The workaround
DE> is to enclose the command in a '/bin/sh -c <cmd>' like this:

DE> +	"Pine" 	Exec /bin/sh -c '/usr/bin/popclient -3 -u XXXXX -p XXXXXXX \
DE>  bigdog\
DE> -o /var/spool/mail/ray;xterm -fg black -bg white -fn 10x20\ 
DE> -geometry 82x27+16+32 -ls -e pine'

I've not tested it, but I think it'll work if you surround the
commands with parenthesis:

+       "Something" Exec (first_command; second_command)&

Emilio.

-- 
 Emilio C. Lopes <mailto:[email-masked]>
 FINPE, Instituto de Fisica      E-mail: [email-masked]
 Universidade de Sao Paulo       Phone : (+55 11) 818-6724 (Voice)
 Caixa Postal 66318                      (+55 11) 818-6715 (Fax)
 05389-970  Sao Paulo - SP
 BRAZIL
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].