Subject: FVWM: FvwmPager linestyles

From: Yujong Kim <[email-masked]>
Date: Fri, 14 Jun 1996 10:09:37 +0900

Hi! This is from Yujong Kim, a graduate student of POSTECH, KOREA.
I want to know how I can make columns and rows's line of FvwmPager solid line.
I make my DeskTopSize 3x3 ( FvwmPager # 0 ). but at that FvwmPager, 
lines which separate coloums and rows are dotted lines not solid lines.
I want to be those line soild.  How  can I make cure that problem ?
My machine is SUN sparc station. OS is solaris 2.5 with X11R5.  
My fvwm version is fvwm-2.0.42.  I don't use 3d_pixmaps_1.0.tar.gz.
In my fvwm version 1 case, those lines are  solid line. 
So I think that the problem maybe a bug of fvwm-2.0.42.
Please, Help me !
Below file is my ".fvwm2rc" file. Please search for what problem is 
there at that file.
I hope to receive your answer soon. 

from Yujong Kim.
[email-masked]

####  Yujong Kim's fvwm2rc file  ############################################
# This is a fvwmrc file for fvwm-2, it WILL NOT WORK with older versions
# I have attempted to document this fairly well, so a basic knowledge of
# how it works is all that is required to change it. however the man page
# is there, read it and learn a lot.

#####  FVWMM4  ############################################################## 
# m4 requires undefine
#undefine(`include')

#####  ICONS & MODULES PATHS  ###############################################   
# ModulePath is a colon-separated list, just like regular unix PATH
# Pixmap and icon paths are also colon separated lists
ModulePath	/usr/local/lib/X11/fvwm2
PixmapPath	/usr/local/include/X11/pixmaps
IconPath	/usr/local/include/X11/bitmaps

#####  MAJOR OPERATING MODES  ############################################### 
# Set up the major operating modes
# I find scrolling off the edge like that annoying, use the pager
#EdgeScroll 0 0
EdgeScroll 100 100

# Thresh in a 50 pixel move resistance
#EdgeResistance 250 50
EdgeResistance 10000 0

# Time for a single click in ms
#ClickTime 150

# set up the colors
HilightColor  white 	#b43060

#####  ICONS, WINDOWS' FONTS  ###############################################  
# Now the fonts - one for icons, another for window titles
WindowFont		-*-helvetica-medium-r-*-*-10-*-*-*-*-*-*-*
#IconFont		-*-helvetica-medium-r-*-*-11-*-*-*-*-*-*-*
IconFont        -*-lucida-medium-r-*-*-11-*-*-*-*-*-*-*
#WindowFont      -*-lucida-medium-r-*-*-10-*-*-*-*-*-*-*
OpaqueMoveSize  100

#####  STYLES  ##############################################################
# Set the decoration styles and window options
# Order is important!!!!
# If compatible styles are set for a single window in multiple Style
# commands, then the styles are ORed together. If conflicting styles
# are set, the last one specified is used.
# Menu style
MenuStyle black gray70 gray60 -adobe-helvetica-medium-r-*-*-*-120-*-*-*-*-*-* fvwm
#MenuStyle black ivory2 SlateGrey -*-lucida-medium-r-*-*-14-*-*-*-*-*-*-* fvwm
# Button and curses styles
#ButtonStyle 1 9 50x25@0 67x33@0 75x50@0 67x67@0 50x75@0 33x67@0 25x50@0 33x33@1
ButtonStyle 2 7 70x0@0 70x70@0 0x70@0 0x40@1 40x40@0 40x0@0 70x0@1

# set up the default style
# change the default width.
Style "*"            BorderWidth 3, HandleWidth 3, Color Black/#60a0c0, Icon unknown1.xpm
Style "Fvwm*"        NoTitle, Sticky, WindowListSkip
Style "FvwmPager"    StaysOnTop, Sticky, BorderWidth 3, NoHandles
Style "FvwmBanner"   StaysOnTop
Style "FvwmButtons"  NoTitle, NoHandles, Sticky, WindowListSkip, BorderWidth 3, StaysOnTop
Style "*lock"        NoTitle, NoHandles, Sticky, WindowListSkip, BorderWidth 3
Style "xbiff"        NoTitle, NoHandles, Sticky, WindowListSkip, BorderWidth 3, StaysOnTop
Style "xconsole"     NoTitle, NoHandles, Sticky, WindowListSkip, BorderWidth 3 
Style "xterm"        Icon xterm.xpm
Style "hanterm"      Icon xterm.xpm, BorderWidth 3 
Style "Appointment"  Icon datebook.xpm
Style "xcalc"        Icon xcalc.xpm
Style "xbiff"        Icon mail1.xpm
Style "xmh"          Icon mail1.xpm
Style "xman"         Icon xman.xpm
Style "xvgr"         Icon graphs.xpm
Style "matlab"       Icon math4.xpm
Style "xmag"         Icon mag_glass.xpm
Style "xgraph"       Icon graphs.xpm
Style "FvwmButtons"  Icon toolbox.xpm

#####  KEYBOARD BINDINGS  ###################################################
# Keyboard Bindings
Key Left	A	C	Scroll -100 0
Key Right	A	C	Scroll +100 +0
Key Up		A	C	Scroll +0   -100
Key Down	A	C	Scroll +0   +100

# press arrow + meta key, and scroll by 1/10 of a page
Key Left        A       M       Scroll -10 +0
Key Right       A       M       Scroll +10 +0
Key Up          A       M       Scroll +0   -10
Key Down        A       M       Scroll +0   +10

# press shift arrow + control anywhere, and move the pointer by 1% of a page
Key Left        A       SC      CursorMove -1 0
Key Right       A       SC      CursorMove +1 +0
Key Up          A       SC      CursorMove +0   -1
Key Down        A       SC      CursorMove +0   +1

# press shift arrow + meta key, and move the pointer by 1/10 of a page
Key Left        A       SM      CursorMove -10 +0
Key Right       A       SM      CursorMove +10 +0
Key Up          A       SM      CursorMove +0   -10
Key Down        A       SM      CursorMove +0   +10

# Keyboard accelerators
Key F1          A       M       Popup "Utilities"
Key F1          A       M       Popup "Utilities"
Key F2          A       M       Popup "Window Ops"
Key F3          A       M       Module "WindowList" FvwmWinList 
Key F4          A       M       Iconify
Key F5          A       M       Move
Key F6          A       M       Resize
Key F7          A       M       CirculateUp
Key F8          A       M       CirculateDown

#Page Up/Dapge Down keys are used to scroll by one desktop page
# in any context, press page up/down + control
# in root context, just pressing page up/down is OK
# 
# I prefer the non-wrapping scroll. These are for example purposes only
#Key Next       A       C       Scroll 100000 0
#Key Next       R       N       Scroll 100000 0  
#Key Prior      A       C       Scroll -100000 0
#Key Prior      R       N       Scroll -100000 0

#####  MOUSE BINDINGS  ######################################################
# Mouse Bindings
# Root Window mouse
# left button brings up a list of Applications
# middle button brings up a list of Window commands
# right button brings up a window list
# button,   context, modifiers, function
Mouse 1		R       A       Menu App-Menu #Nop
Mouse 2		R       A       Menu Window-Ops #Nop
Mouse 3 	R       A       WindowList

# Title Bar Buttons
# left title bar button brings up menu on click, closes on double click
# far right button does a full maximize
# near right button iconifies
Mouse 0 	1       A       Menu Window-Ops2 #Close
Mouse 0 	2       A       Maximize #100 #100
Mouse 0 	4       A       Iconify

# Title bar
# left button raises, on drag it moves
# rightt button lowers, on drag it moves
Mouse 1		T       A       Move-or-Iconify-Raise-Func
Mouse 3 	T       A       Move-or-Iconify-Lower-Func

# Sidebars and FrameGs
# left button raises, on drag it resizes
# rightt button lowers, on drag it resizes
Mouse 1 	FS      A       Resize-Raise-Func
Mouse 3 	FS      A       Resize-Lower-Func

# Main Window
# Meta left click raises window
# Meta right click lowers
Mouse 1 	W       M       Raise
Mouse 3 	W       M       Lower

# Iconic
# Left button moves on drag and un-iconifies on double click
# Right button moves
Mouse 1 	I       A       Move-or-Iconify
Mouse 3 	I       A       Move

############################################################################
# Function Definitions
# Initialization Functions
#sinclude(`.fvwmdesk')

# Run on start (not restart)
AddToFunc InitFunction	"I" Module FvwmButtons
+			"I" Module FvwmPager 0 0
+                       "I" exec xconsole -fn lucidasans-10 -geometry +1+746
#+			"I" exec xv -noresetroot -root -quit -random /usr/X11/lib/X11/backgrounds/*

# Run on restart
AddToFunc RestartFunction "I" Module FvwmButtons
+			"I" Module FvwmPager 0 0
#+			"I" exec xv -noresetroot -root -quit -random /usr/X11/lib/X11/backgrounds/*

############################################################################
# Handy Complex Functions

# Auto-raise, resize on motion
AddToFunc Resize-Raise-Func	"I" Raise
+				"M" Resize

# Auto-lower, resize on motion
AddToFunc Resize-Lower-Func	"I" Lower
+				"M" Resize

# Auto-raise, move on motion, iconify on double-click
AddToFunc Move-or-Iconify-Raise-Func	"I" Raise
+					"M" Move
+					"D" Iconify

# Auto-Lower, move on motion, iconify on double-click
AddToFunc Move-or-Iconify-Lower-Func	"I" Lower
+					"M" Move
+					"D" Iconify

# Move on motion, iconify on double-click
AddToFunc Move-or-Iconify	"M" Move
+				"D" Iconify

# Auto-raise then print
AddToFunc PrintFunction		"I" Raise
+				"I" Exec xdpr -id $w

############################################################################
# Menu Definitions

# Commonly used applications
# This menu will fire up some very common utilities
AddToMenu App-Menu	"App-Menu"		Title
#+			""			Nop
+			"pilgi"			Exec hanterm -T "Hanterm (pilgi)" -sb +rv -ls &
+			"Xterm"	        	Exec xterm -font 7x14 &
+			""			Nop
+			"Applications"		Popup Apps-Popup
+			""			Nop
+			"Utilities"		Popup Utilites
+			""			Nop
+			"Screen Savers"		Popup ScreenSaver
+			""			Nop
+			"Lock Screen"		Popup ScreenLock
+			""			Nop
+			"Modules"		Popup Module-Popup
+			""			Nop
+			"Exit Fvwm"		Popup Quit-Verify

############################################################################
# Heavily used applications
AddtoMenu Apps-Popup	"Applications"		Title
#+			""			Nop
+			"Internet Stuff"	Popup	Net-Popup
+			""			Nop
+			"Graphics/Sound"	Popup	Graphics
+			""			Nop
+			"Programming"		Popup	Programming
+			""			Nop
+			"Communication"		Popup	Comm-Popup
+			""			Nop
+			"Games"			Popup	Games-Popup

############################################################################
# Internet `Surfing' apps
AddToMenu Net-Popup	"Internet Utilities"	Title
#+			""			Nop
+			"Netscape"		Exec netscape &
+			"XViewNews"		Exec xvnews &
+			"X3270 Telnet"		Exec x3270 &
+			"LLNL Ftp"		Exec xftp -geometry 800x600 &

# Graphics and sound manipulation
AddToMenu Graphics	"Graphics"		Title
#+			""			Nop
+			"XV 3.01"		Exec xv &
+			"XPaint"		Exec xpaint &
+			"Magnifying Glass"	Exec xmag &
+			"XFig"			Exec xfig &
+			"Fractint"		Exec xfractint &
+			"Sound"			Title
+			"Motif Audio CD Player"	Exec xmcd &
+			"Workman (CD Player)"	Exec workman &
+			"RPlayTool"		Exec rplaytool &
+			"XVmixer"		Exec xvmixer &

############################################################################
# Programming Tools
AddtoMenu Programming	"Programming"		Title
#+			""			Nop
+			"X Windows GNU Debugger"	Exec xxgdb &
+			"X Windows Progamming Environment"	Exec xwpe &

############################################################################
# Communications
AddtoMenu Comm-Popup	"Communication"		Title
#+			""			Nop
+			"Seyon"			Exec seyon &
+			"C-Kermit"		Exec color_xterm -font 7x14 -T C-Kermit -n C-Kermit -e kermit &

############################################################################
# Games, and neat stuff
AddtoMenu Games-Popup	"Games"			Title
#+			""			Nop
+			"DOOM"			Exec xdoom &
+			"XBoing II"		Exec xboing -grab &
+			"Hextris"		Exec xhextris &
+			"Tetris"		Exec xtetris &
+			"Jewel Box"		Exec xjewel &
+			"Lander"		Exec xlander &
+			"Mahjongg"		Exec xmahjongg &
+			"Roach"			Exec xroach &
+			"Connect IV"		Exec xvier &
+			"Fishtank"		Exec xfishtank &
+			"Neko (Full Screen)"	Exec oneko &
+			"Neko (Window)"		Exec xneko &
+			"Sokoban"		Exec xsok &
+			"Eyes"			Exec xeyes &

############################################################################
# Handy utilities
AddToMenu Utilites	"Utilities"		Title
#+			""			Nop
+			"Save Desktop"		Module	FvwmSaveDesk
+			"Window Identify"	Module	FvwmIdent
+			"Window List"		Module	FvwmWinList
+			""			Nop
+			"Manual Pages"		Exec xman &
+			"Memory Info"		Exec meminfo &
+			"Calculator"		Exec xcalc &
+			"Clock"			Exec oclock &

############################################################################
# Screen Savers
AddToMenu ScreenSaver	"Screen Savers"		Title
#+			""			Nop
+                       "Galaxy"                Exec xlock -nolock -mode galaxy &
+			"Splines"		Exec xlock -nolock -mode spline &
+			"Hyper Cube"		Exec xlock -nolock -mode hyper &
+			"Helix"			Exec xlock -nolock -mode helix &
+			"Asteroids"		Exec xlock -nolock -mode rock &
+			"Grav"	        	Exec xlock -nolock -mode grav &
+			"Bouncing Ball"		Exec xlock -nolock -mode bounce &
+			"Swarm"			Exec xlock -nolock -mode swarm &
+			"Rotor-Rooter"		Exec xlock -nolock -mode rotor &
+			"Pyro"			Exec xlock -nolock -mode pyro &
+                       "Clock"                 Exec xlock -nolock -mode clock & 

############################################################################
# Screen Lockers
AddToMenu ScreenLock	"Screen Lockers"	Title
#+			""			Nop
+                       "Galaxy"                Exec xlock -mode galaxy &
+                       "Splines"               Exec xlock -mode spline &
+                       "Hyper Cube"            Exec xlock -mode hyper &
+                       "Helix"                 Exec xlock -mode helix &
+                       "Asteroids"             Exec xlock -mode rock &
+                       "Grav"                  Exec xlock -mode grav &
+                       "Bouncing Ball"         Exec xlock -mode bounce 
+                       "Swarm"                 Exec xlock -mode swarm &
+                       "Rotor-Rooter"          Exec xlock -mode rotor &
+                       "Pyro"                  Exec xlock -mode pyro &
+                       "Clock"                 Exec xlock -mode clock &

############################################################################
# Fvwm Modules
AddToMenu Module-Popup	"Modules"	Title	
#+			""		Nop
+			"Button-Bar"	Module	FvwmButtons
+			"Clean-Up"	Module	FvwmClean
+			"Debug"		Module	FvwmDebug
+			"Background"	Module  FvwmBacker
+			"Pager"		Module  FvwmPager 0 0
+			"IconBox"	Module	FvwmIconBox
+			"Banner"	Module	FvwmBanner
+			"Talk"  	Module	FvwmTalk
+			"Prompt"	Module	FvwmPrompt "hello" raise

############################################################################
# Exit menu
AddToMenu Quit-Verify	"Really Quit?"	Title	
#+			""		Nop
+			"Really Quit"	Quit	
+			"Restart Fvwm"	Restart fvwm2	
+			"Start twm"	Restart twm
+			"Start olvwm"	Restart /usr/openwin/bin/olvwm
+			"Start dummy"	Restart xterm
+			""		Nop	
+			"Don't Quit"	Nop	

############################################################################
# Generic window ops
AddToMenu Window-Ops	"Window Ops"	Title		
+			"Move"		Move
+			"Resize"	Resize
+			"Raise"		Raise
+			"Lower"		Lower 
+		 	"(De)Iconify"	Iconify
+			"(Un)Stick"	Stick		
+			""		Nop  
+			"Destroy"	Destroy
+			"Close"		Close	 
+			""		Nop		
+			"Refresh Screen" Refresh		

############################################################################
# Specific window ops
AddToMenu Window-Ops2	"Move"		Move
+			"Resize"	Resize
+			"Raise"		Raise   	
+			"Lower"		Lower   	
+			"Iconify"	Iconify 	
+			"(Un)Stick"	Stick		
+			""		Nop     	
+			"Destroy"	Destroy 	
+			"Close"		Close	  	
+			""		Nop 		
+			"ScrollBar" 	Module FvwmScroll 2 2	
+			"Print"         PrintFunction

############################################################################
# Module Definitions

# FvwmButtons (the button bar)
# Colors
*FvwmButtonsFore Black
*FvwmButtonsBack gray60

# Font
*FvwmButtonsFont fixed
# Geometry - really likes to pick its own size, but giving a position is OK
*FvwmButtonsGeometry 630x70+1+822 

# Layout: specify rows or columns, not both
#*FvwmButtonsColumns 1
*FvwmButtonsRows 1

*FvwmButtons Stop         stopsign.xpm    Quit &
*FvwmButtons Kill         rbomb.xpm       Destroy
*FvwmButtons Move         arrows2.xpm     Move
#*FvwmButtons Lower        arrdown2.xpm    Lower
*FvwmButtons Raise        arrup2.xpm      Raise
*FvwmButtons amangs       xterm.xpm       Exec "amangs" exec hanterm -fb 7x14 -sb -T amangs -e rlogin amangs -l yjkim & 
*FvwmButtons anyon        xterm.xpm       Exec "anyon"  exec hanterm -fb 7x14 -sb -T anyon -e rlogin anyon -l yjkim & 
*FvwmButtons Netscape     netscape.xpm       Exec "Netscape" netscape
*FvwmButtons Xcalc        xcalc.xpm       Exec "Calculator" xcalc
*FvwmButtons Xman         xman.xpm        Exec "Man Page" xman

############################################################################
# FvwmNoClutter (clears up windows)
# I only wrote NoClutter as a simple test case, but maybe some big sites like
# universities really have usage problems (too many open windows)....
# Time delays are in seconds.
*FvwmNoClutter 3600 Iconify 1
*FvwmNoClutter 86400 Delete
*FvwmNoCLutter 172800 Destroy

############################################################################
# FvwmClean (same as FvwmNoClutter)
*FvwmClean 36000 Iconify 1
*FvwmClean 86400 Iconify -1
*FvwmClean 172800 Move 100p 100p

############################################################################
# FvwmIdent (Window Identifier)
# Just choose colors and a fonts
*FvwmIdentBack MidnightBlue
*FvwmIdentFore Yellow
*FvwmIdentFont -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*

#####  DESKTOP, FVWMPAGER SIZE COLOR & SCALE  ###############################
# Set up the virtual desktop and pager
#set the desk top size in units of physical screen size
DeskTopSize 3x3
*FvwmPagerDeskTopScale 35
*FvwmPagerGeometry +1044+813
*FvwmPagerFont          none
*FvwmPagerHilight       DeepSkyBlue4

############################################################################
# FvwmWinList (Window List)
*FvwmWinListBack #908090
*FvwmWinListFore Black
*FvwmWinListFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmWinListAction Click1 Iconify -1,Focus
*FvwmWinListAction Click2 Iconify
*FvwmWinListAction Click3 Module "FvwmIdent" FvwmIdent
*FvwmWinListUseSkipList
*FvwmWinListGeometry +0-1

############################################################################
# FvwmBacker (Changes background depending on desktop)
*FvwmBackerDesk 0 -solid steelblue
#*FvwmBackerDesk 1 -solid midnightblue

############################################################################
# FvwmScroll (ScrollBar)
#*FvwmScrollBack grey40
#*FvwmScrollFore green
	
############################################################################
# FvwmIconBok (Iconize to Box instead of Desktop)
# If you are going to use this, set `Style "*" NoIcon'
*FvwmIconBoxIconBack	#cfcfcf
*FvwmIconBoxIconHiFore	black
*FvwmIconBoxIconHiBack	LightSkyBlue
*FvwmIconBoxBack	#5f9ea0
*FvwmIconBoxFore	ivory1
*FvwmIconBoxGeometry	5x1+0+0
*FvwmIconBoxMaxIconSize	64x38
*FvwmIconBoxFont	-adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*
*FvwmIconBoxSortIcons
*FvwmIconBoxPadding	4
*FvwmIconBoxLines	10
*FvwmIconBoxPlacement	Left Top
#
# mouse bindings
#
*FvwmIconBoxMouse	1 Click		RaiseLower
*FvwmIconBoxMouse	1 DoubleClick	Iconify
*FvwmIconBoxMouse	2 Click		Iconify -1, Focus
*FvwmIconBoxMouse	3 Click		Module FvwmIdent
#
# Key bindings
#
*FvwmIconBoxKey		r	RaiseLower
*FvwmIconBoxKey		space	Iconify
*FvwmIconBoxKey		d	Close
#
# FvwmIconBox built-in functions
#
*FvwmIconBoxKey		n	Next
*FvwmIconBoxKey		p	Prev
*FvwmIconBoxKey		h	Left
*FvwmIconBoxKey		j	Down
*FvwmIconBoxKey		k	Up
*FvwmIconBoxKey		l	Right
#
# Icon file spcifications
#
*FvwmIconBox		"*"		unknown1.xpm
#*FvwmIconBox		"Fvwm*"		-
*FvwmIconBox		"rxvt"		term.xpm
*FvwmIconBox		"xterm"		xterm.xpm
*FvwmIconBox		"editres"	editres.xpm
*FvwmIconBox		"xman"		xman.xpm
*FvwmIconBox		"xbiff"		mail1.xpm
*FvwmIconBox		"xmh"		mail1.xpm
*FvwmIconBox		"xcalc"		xcalc.xpm
*FvwmIconBox		"FvwmButtons"	toolbox.xpm
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Richard Lister <[email-masked]>
Date: Fri, 14 Jun 1996 10:10:01 +0100

On Fri, 14 Jun 1996 10:09:37 +0900
Yujong Kim <[email-masked]> 
> So I think that the problem maybe a bug of fvwm-2.0.42.

No, I believe it's a feature which came with 2.0.42. I suppose the idea is
to make it easier to distinguish pages from desks in the pager. 

Ric

---

From: <[email-masked]> (Charles Hines)
Date: Fri, 14 Jun 1996 08:49:07 -0400

>>>>> "Ric" == Richard Lister <[email-masked]> writes:

Ric> On Fri, 14 Jun 1996 10:09:37 +0900
Ric> Yujong Kim <[email-masked]>
Ric> wrote concerning 'nil':

>> I want to know how I can make columns and rows's line of FvwmPager
>> solid line.  I make my DeskTopSize 3x3 ( FvwmPager # 0 ). but at
>> that FvwmPager, lines which separate coloums and rows are dotted
>> lines not solid lines.  I want to be those line soild.  How can I
>> make cure that problem ?  My machine is SUN sparc station. OS is
>> solaris 2.5 with X11R5.  My fvwm version is fvwm-2.0.42.  I don't
>> use 3d_pixmaps_1.0.tar.gz.  In my fvwm version 1 case, those lines
>> are solid line.  So I think that the problem maybe a bug of
>> fvwm-2.0.42.

Ric> No, I believe it's a feature which came with 2.0.42. I suppose
Ric> the idea is to make it easier to distinguish pages from desks in
Ric> the pager.

Yup - that was the idea.  There was no way to truly distinguish
between pages and full desks.  Now there's two - dashed lines and
optional colored backgrounds for each desk.

There is currently no way to control this in the .fvwm2rc file - it's
hard coded into the FvwmPager module, and I didn't really have any
intention on making it an option.  If you (Yujong) would like to
change it back to being solid, you only have to change like one line -
check out line 390 of x_pager.c in the FvwmPager directory.  If you
change that LineOnOffDash to LineSolid, it'll look like it did before.

Chuck

---

From: Austin Donnelly <[email-masked]>
Date: Fri, 14 Jun 96 16:14 BST

> change that LineOnOffDash to LineSolid, it'll look like it did before.

Ok, I've added an option to control it.

*FvwmPagerInterPageLineStyle <linestyle>

Changes the style of lines drawn between individual pages on the same
desk. The default is to have inter-desk boundaries drawn with solid
lines, and inter-page boundaries dotted. However, if you only use a
single desk, you might want to set the line style some something
else. Possible values for <linestyle> are "Solid",
"OnOffDash" (the default), or "DoubleDash".

The patch follows. I've included a change to FvwmPager.man, so it even
comes ready-documented.

Chuck, any chance of this going into the next beta?  :>

Austin
------------------------------------------------------------
diff -u --recursive fvwm-2.0.42.orig/modules/FvwmPager/FvwmPager.c fvwm-2.0.42/modules/FvwmPager/FvwmPager.c
--- fvwm-2.0.42.orig/modules/FvwmPager/FvwmPager.c	Mon Mar 25 16:29:37 1996
+++ fvwm-2.0.42/modules/FvwmPager/FvwmPager.c	Fri Jun 14 16:02:03 1996
@@ -73,6 +73,11 @@
 int Rows = -1, Columns = -1;
 int desk1=0, desk2 =0;
 int ndesks = 0;
+
+int InterPageLineStyle=LineOnOffDash;  /* default line style */
+static char *lineStyleDesc[] = {"Solid", "OnOffDash", "DoubleDash"};
+static int lineStyleNum[] = {LineSolid, LineOnOffDash, LineDoubleDash};
+
 /***********************************************************************
  *
  *  Procedure:
@@ -971,6 +976,27 @@
 			     Clength+8)==0))
 	{
 	  sscanf(&tline[Clength+8],"%d",&Columns);
+	}
+      else if((strlen(&tline[0])>1)&&
+	      (mystrncasecmp(tline,CatString3("*",MyName,"InterPageLineStyle"),
+			     Clength+19)==0))
+	{
+	  n = 0;
+	  while(isspace(tline[Clength+19+n]))n++;
+	  tmp = &tline[Clength+19+n];
+	  n = 0;
+	  while (n<sizeof(lineStyleDesc)/sizeof(char *))
+	    {
+	      if (mystrncasecmp(tmp, lineStyleDesc[n],
+				strlen(lineStyleDesc[n]))==0)
+		{
+		  InterPageLineStyle = lineStyleNum[n];
+		  break;
+		}
+	      n++;
+	    }
+	  if (n==sizeof(lineStyleDesc)/sizeof(char *))
+	    fprintf(stderr, "[FvwmPager]: unknown line style '%s'\n", tmp);
 	}
         else if((strlen(&tline[0])>1)&&
               (mystrncasecmp(tline,CatString3("*",MyName,"DeskTopScale"),
diff -u --recursive fvwm-2.0.42.orig/modules/FvwmPager/FvwmPager.man fvwm-2.0.42/modules/FvwmPager/FvwmPager.man
--- fvwm-2.0.42.orig/modules/FvwmPager/FvwmPager.man	Sun Mar 24 17:41:05 1996
+++ fvwm-2.0.42/modules/FvwmPager/FvwmPager.man	Fri Jun 14 15:28:19 1996
@@ -167,6 +167,14 @@
 FvwmCpp (or FvwmM4) and FvwmBacker to assign identical
 colors to your various desktops and the pager representations.
 
+.IP "*FvwmPagerInterPageLineStyle \fIlinestyle\fP"
+Changes the style of lines drawn between individual pages on the same
+desk. The default is to have inter-desk boundaries drawn with solid
+lines, and inter-page boundaries dotted. However, if you only use a
+single desk, you might want to set the line style some something
+else. Possible values for \fIlinestyle\fP are \fISolid\fP,
+\fIOnOffDash\fP (the default), or \fIDoubleDash\fP.
+
 .IP "*FvwmPagerDeskTopScale \fInumber\fP"
 If the geometry is not specified, then a desktop reduction factor is
 used to calculate the pager's size. Things in the pager window
Only in fvwm-2.0.42/modules/FvwmPager: Makefile
diff -u --recursive fvwm-2.0.42.orig/modules/FvwmPager/x_pager.c fvwm-2.0.42/modules/FvwmPager/x_pager.c
--- fvwm-2.0.42.orig/modules/FvwmPager/x_pager.c	Sun Mar 24 17:33:47 1996
+++ fvwm-2.0.42/modules/FvwmPager/x_pager.c	Fri Jun 14 15:19:10 1996
@@ -44,6 +44,7 @@
 
 extern int desk1, desk2, ndesks;
 extern int Rows,Columns;
+extern int InterPageLineStyle;
 extern int fd[2];
 
 int desk_w = 0;
@@ -387,7 +388,7 @@
   gcm = gcm | GCLineStyle;
   gcv.foreground = fore_pix;
   gcv.background = back_pix;
-  gcv.line_style = LineOnOffDash;
+  gcv.line_style = InterPageLineStyle;
   DashedGC = XCreateGC(dpy, Scr.Root, gcm, &gcv);
 }