Subject: Re: Re: FVWM: Swallow and Exec from one FvwmButton

From: Tim Phipps <[email-masked]>
Date: Thu, 13 Jun 1996 16:14:33 +0100

> Reply-To: [email-masked] (Albrecht Kadlec)
> 
> Unswallowing only works correctly, if I do a killmodule FvwmButtons from
> FvwmTalk. 
> 

My restart function now looks like this:

AddToFunc QuitFvwm
+ "I" KillModule *
+ "I" FvwmBanner
+ "I" Wait FvwmBanner
+ "I" Quit

The wait is necessary to allow time for the regurgitation to complete.

Cheers,
Tim Phipps.

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Albrecht Kadlec)
Date: Fri, 14 Jun 96 15:48:52 +0200

>>>>> Tim Phipps writes:

> Unswallowing only works correctly, if I do a killmodule FvwmButtons from

T> My restart function now looks like this:

T> AddToFunc QuitFvwm
T> + "I" KillModule *
T> + "I" FvwmBanner
T> + "I" Wait FvwmBanner
T> + "I" Quit

T> The wait is necessary to allow time for the regurgitation to complete.

oops, I never thought of a timing bug.
the wait really solves this problem:
I now have:

AddToFunc Restart-fvwm2
+ 	"I"	KillModule FvwmButtons
+	"I"	FvwmBanner
+	"I"	Wait FvwmBanner
+	"I"	Restart /net/vta_host/home/vta_host/albrecht/bin/fvwm2

instead of:
+	"I"	Next [FvwmButtons] Close
+	"I"	Restart /net/vta_host/home/vta_host/albrecht/bin/fvwm2

thanks,
albrecht
-- 
Should I sing until I can't sing any more
Play these strings until my fingers are raw
You're so hard to please -
What do you want from me	-- Pink Floyd
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].