Subject: FVWM: proctool & fvwm2.0.42

From: [email-masked] (bpm)
Date: Tue, 4 Jun 1996 12:38:37 -0500

Hello, I am running solaris 2.4 & fvwm2.0.42.  I just got proctool to
use and I get the following X error:

vlad: proctool
ProCtool, reading init file "/home/bpm/.proc.init" ...
X Error of failed request:  BadAccess (attempt to access private resource denied)
  Major opcode of failed request:  28 (X_GrabButton)
  Serial number of failed request:  1594
  Current serial number in output stream:  1595

Any ideas?  Is this conflicting with FvwmButtons?

Thanks

---
Brian Millett                    
Technology Applications Inc.     "Heaven can not exist,
(314) 530-1981                          If the family is not eternal"
[email-masked]                   F. Ballard Washburn
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (bpm)
Date: Tue, 4 Jun 1996 16:00:57 -0500

Michael Tiefenback writes:
 |X_GrabButton access violations are generally due to hot keys defined in
 |the .fvwmrc which conflict with those used by the process which failed to
 |run.  You probably should disable each of your shift/alt mousebutton
 |options in fvwm in turn, and hunt down which of them is the conflicting
 |item. 
 |
 |Michael Tiefenback
 |

Thanks!  That was it.  The problem was:

# Button 3 in the window, with the Modifier-1 key (usually alt or diamond)
# gives Raise-Lower. Used to use control here, but that interferes with xterm
Mouse 3         W       M       RaiseLower

But I in trying to determine the problem, I think I have found a bug!

Scenario:
 I am using a DeskTopSize 2x1.
 Take a normal window (xterm 80x24) and place it about 5 or less
pixels from the left edge.  Select the left edge of the window and try
to drag the left edge even further/closer to the desktop edge.
Release and whamo!  The window is now 224x24 in size!  Kind of cool.

Thanks

---
Brian Millett

---

From: <[email-masked]> (Charles Hines)
Date: Tue, 4 Jun 1996 17:25:34 -0400

>>>>> "bpm" == bpm  <[email-masked]> writes:

....
bpm> But I in trying to determine the problem, I think I have found a bug!

bpm> Scenario:
bpm>  I am using a DeskTopSize 2x1.
bpm>  Take a normal window (xterm 80x24) and place it about 5 or less
bpm> pixels from the left edge.  Select the left edge of the window and try
bpm> to drag the left edge even further/closer to the desktop edge.
bpm> Release and whamo!  The window is now 224x24 in size!  Kind of cool.

Known problem introduced in 2.0.42, already fixed for the next beta
(2.0.43).  Just avoid resizing and touching the absolute edges of the
virtual desktop until then... :)

Chuck