Subject: Re: FVWM: Keyboard accelerators in menus

From: Dan Espen <[email-masked]>
Date: Fri, 24 May 1996 13:45:05 -0400

Tim Phipps <[email-masked]> writes:
> Is it possible to navigate around the menus using keyboard shortcuts?
> 
> I'm moving from ctwm and this is the only thing I can't replicate.  With ctwm
> once a menu is popped from the keyboard you can move to the menu items and
> select them just by typing the first letter of the item name.  I have gotten
> into this and it is very fast for going down three or four levels of menu
> nesting.

Yes.  An ampersand in the menu item name indicates the hot letter:

AddToMenu Window-Ops "--Window Operations--" Title
+  "&Destroy" Destroy
+  "D&elete" Delete

I think you need  fvwm2, I'm not  sure, but I  don't think this was in
fvwm (1).

> Cheers,
> Tim Phipps.
> --
> Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
> To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
> message to [email-masked].
> To report problems, send mail to [email-masked].

--
Dan Espen                                    Phone: (908) 699-5570
[email-masked]
444 Hoes Lane  Room RRC 1C-214
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: <[email-masked]> (Charles Hines)
Date: Fri, 24 May 1996 14:55:42 -0400

>>>>> "Dan" == Dan Espen <[email-masked]> writes:

Dan> Tim Phipps <[email-masked]> writes:
>> I'm moving from ctwm and this is the only thing I can't replicate.
>> With ctwm once a menu is popped from the keyboard you can move to
>> the menu items and select them just by typing the first letter of
>> the item name.  I have gotten into this and it is very fast for
>> going down three or four levels of menu nesting.

Dan> Yes.  An ampersand in the menu item name indicates the hot letter:

Dan> AddToMenu Window-Ops "--Window Operations--" Title
Dan> +  "&Destroy" Destroy
Dan> +  "D&elete" Delete

Dan> I think you need  fvwm2, I'm not  sure, but I  don't think this was in
Dan> fvwm (1).

I believe the ampersand works in 1.xx as well.

Chuck

---

From: Andrew Veliath <[email-masked]>
Date: Sat, 25 May 1996 02:55:25 -0400

Dan> Yes.  An ampersand in the menu item name indicates the hot
    Dan> letter:

    Dan> AddToMenu Window-Ops "--Window Operations--" Title +
    Dan> "&Destroy" Destroy + "D&elete" Delete

Speaking of menu text, I was dying to know how to right justify
partial text in menus (e.g. for things like Alt-Q) for a long time.
When finally I dug a bit a few days ago I found that you have to
insert an actual tab character in the text.  Coolness :) !

Is this documented (other than source code :) or did I overlook it?