Subject: FVWM: compiling 1.24r on HPUX 10.01

From: Dan Norris <[email-masked]>
Date: Thu, 30 May 1996 09:38:19 -0500

I can't do it!  I follow the instructions and get this error:

making all in ./libs...
make[1]: Entering directory `/scratch/fvwm/v1/fvwm-1.24r/libs'
gcc -O -Aa      -Dhpux -DSYSV -D_HPUX_SOURCE       -c CatString3.c -o 
CatString3.o
*Initialization*:1: missing token-sequence in `#assert'
make[1]: *** [CatString3.o] Error 1
make[1]: Leaving directory `/scratch/fvwm/v1/fvwm-1.24r/libs'
making all in ./fvwm...
make[1]: Entering directory `/scratch/fvwm/v1/fvwm-1.24r/fvwm'
gcc -O -Aa      -Dhpux -DSYSV -D_HPUX_SOURCE       -c fvwm.c -o fvwm.o
*Initialization*:1: missing token-sequence in `#assert'
make[1]: *** [fvwm.o] Error 1
make[1]: Leaving directory `/scratch/fvwm/v1/fvwm-1.24r/fvwm'
making all in ./modules/GoodStuff...
make[1]: Entering directory `/scratch/fvwm/v1/fvwm-1.24r/modules/GoodStuff'
....

and that same error appears a ton of times before the make finally gives an 
error and fails.

I even compiled 2.0 with little trouble, but I need to get 1.24 working.  Has 
anyone done this?

Dan
-- 
Dan Norris                  Computer Science 
[email-masked]      University of Illinois
http://www.uiuc.edu/ph/www/d-norri/

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Emilio Lopes)
Date: Thu, 30 May 96 13:04 EST

>>>>> "DN" == Dan Norris <[email-masked]> wrote:

DN> gcc -O -Aa -Dhpux -DSYSV -D_HPUX_SOURCE ...
           ~~~

This set of option is designed for the HP C compiler, where "-Aa"
means "be ansi".

Be coherent all will be fine.

Emilio.

-- 
 Emilio C. Lopes <mailto:[email-masked]>
 FINPE, Instituto de Fisica      E-mail: [email-masked]
 Universidade de Sao Paulo       Phone : (+55 11) 818-6724 (Voice)
 Caixa Postal 66318                      (+55 11) 818-6715 (Fax)
 05389-970  Sao Paulo - SP
 BRAZIL
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Nathaniel Anderson <[email-masked]>
Date: Thu, 30 May 1996 12:41:04 -0500 (EDT)

> and that same error appears a ton of times before the make finally gives an 
I had this same problem compiling 2.0.42 on HPUX 10.01.  The problem seemed to be
the '-Aa' option for gcc.  It has been a while since I compiled fvwm, but I think
if you change your compiler in Fvwm.tmpl to cc, it should take care of the 
problem.  If it doesn't, there is probably a way to tell the Imakefile or Fvwm.tmpl
not to use the -Aa option.

--Nat

---

From: <[email-masked]> (Charles Hines)
Date: Thu, 30 May 1996 11:48:51 -0400

>>>>> "Dan" == Dan Norris <[email-masked]> writes:

Dan> I can't do it!  I follow the instructions and get this error:
Dan> making all in ./libs...
Dan> make[1]: Entering directory `/scratch/fvwm/v1/fvwm-1.24r/libs'
Dan> gcc -O -Aa      -Dhpux -DSYSV -D_HPUX_SOURCE       -c CatString3.c -o
Dan> CatString3.o
Dan> *Initialization*:1: missing token-sequence in `#assert'
Dan> make[1]: *** [CatString3.o] Error 1
Dan> make[1]: Leaving directory `/scratch/fvwm/v1/fvwm-1.24r/libs'
Dan> making all in ./fvwm...
Dan> make[1]: Entering directory `/scratch/fvwm/v1/fvwm-1.24r/fvwm'
Dan> gcc -O -Aa      -Dhpux -DSYSV -D_HPUX_SOURCE       -c fvwm.c -o fvwm.o
Dan> *Initialization*:1: missing token-sequence in `#assert'
Dan> make[1]: *** [fvwm.o] Error 1
Dan> make[1]: Leaving directory `/scratch/fvwm/v1/fvwm-1.24r/fvwm'
Dan> making all in ./modules/GoodStuff...
Dan> make[1]: Entering directory `/scratch/fvwm/v1/fvwm-1.24r/modules/GoodStuff'
Dan> ....

Dan> and that same error appears a ton of times before the make
Dan> finally gives an error and fails.

Dan> I even compiled 2.0 with little trouble, but I need to get 1.24
Dan> working.  Has anyone done this?

I haven't, but my guess is that the '-Aa' flag is bugging gcc.  That
flag is used for the native HP compiler to tell it to be an ansi
compiler.  Gcc already is, and must be interpreting that flag
differently.  It's probably defined in CDEBUGFLAGS - remove it and try
again.

Chuck