Subject: FVWM: HOSTDISPLAY variable

From: [email-masked] (Albrecht Kadlec)
Date: Thu, 30 May 96 00:33:55 +0200

well, HOSTDISPLAY is apparently set to `hostname`,
which doesn't include the domain in our domain.
(and I can't change that)

Any way to tell fvwm the missing domain once and forever?

albrecht
-- 
Little ice bear comes up to his mother and asks: "Mom, I'm really an
ice bear, am I?" "Of course you are." So the little ice bear goes up
to his father: "Dad, I'm really an ice bear, not a brown bear, or a
kodiak bear?" "Yes, of course you're an ice bear" - "Absolutly sure,
I'm not a grizzly?" "Absolutely - why?" "Because it's fucking cold!"
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: greg haygood <[email-masked]>
Date: Thu, 30 May 1996 17:49:42 -0500 (CDT)

> Any way to tell fvwm the missing domain once and forever?

phantom% hostname
phantom

phantom% hostname -f
phantom.rh.uchicago.edu

phantom% export HOSTDISPLAY=`hostname -f`   # note backticks
phantom% echo $HOSTDISPLAY
phantom.rh.uchicago.edu

does this work for you?  it works under linux, but not with
/usr/ucb/hostname on Solaris.  there may be another cmd that does this
though.  

if not, and it's one machine, just use

phantom% export HOSTDISPLAY='your.domain.here'   # quotes, not backticks

hope this helps,
greg

***** ***** ***** ***** ***** ***** ***** ***** ***** ***** ***** ***** 
greg haygood          	
[email-masked]  
http://bsdac.uchicago.edu/~g-haygood/ 

Solo to Jordan and Bird: "Watch this: Off the skiff, into the air, off 
the sail barge, into the Sarlaac...nothing but Fett."

---

From: [email-masked] (Albrecht Kadlec)
Date: Fri, 31 May 96 13:18:40 +0200

>>>>> greg haygood writes:

 
> Any way to tell fvwm the missing domain once and forever?

g> phantom% hostname
g> phantom

g> phantom% hostname -f
g> phantom.rh.uchicago.edu

g> phantom% export HOSTDISPLAY=`hostname -f`   # note backticks
g> phantom% echo $HOSTDISPLAY
g> phantom.rh.uchicago.edu

g> does this work for you?  it works under linux, but not with
g> /usr/ucb/hostname on Solaris.  there may be another cmd that does this
g> though.  

13:12 vta_host:~> /bin/hostname
vta_host
13:13 vta_host:~> /bin/hostname -f
sethostname: Not owner
Exit 1

no, sorry.
sunos 4.1.3 or apollo Domain OS.

g> if not, and it's one machine, just use

g> phantom% export HOSTDISPLAY='your.domain.here'   # quotes, not backticks

I'd like to do this in my .xsession, prior to exec'ing fvwm2

does fvwm use HOSTDISPLAY, or does it overwrite it, if it exists.

I just play with a personalized hostname now (still untested):

	#!/usr/local/lbin/tcsh
	echo `/bin/hostname`.auto.tuwien.ac.at

g> hope this helps,
g> greg

thanks,
albrecht
-- 
We have an outdoor composting toilet which works great and was quite
inexpensive. The view is much better than any indoor job too.
				-- Sue Robishaw on her environmental toilet
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].