Subject: FVWM: FvwmConsole patch for everybody

From: Toshi Isogai <[email-masked]>
Date: Thu, 9 May 1996 14:24:00 -0600 (MDT)

FvwmConsole in 2.0.42 distribution has a bug (what a surprise). Even if it is
working currently for you, I suggest you apply this patch since the bug was
not allocating enough memory to variables. 

This patch should also help some of machines you could not run FvwmConsole on
before. I confirmed it ran on SunOS 4.1.4 and Sparc Solaris 2.3. 

I am currently working on a module FvwmCommand, which let user to issue fvwm
commands from shell or perl, or many other things. I have a prototype
working. It has the same code stem as in FvwmConsole, so any comments or
running confirmation will be appreciated. Although I can't answer anything
from 10th through 19th. 

Happy fvwming.

----------------patch begin----------------
diff FvwmConsole-dist/FvwmConsole.c FvwmConsole/FvwmConsole.c
60c60
<   if( ( eargv =(char **)safemalloc((argc-2)*sizeof(char *)) ) == NULL ) 
{
---
>   if( ( eargv =(char **)safemalloc((argc+12)*sizeof(char *)) ) == NULL 
) {
---------------patch end-------------------

~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Toshi Isogai   磯貝利明

-- I am an ASIC engineer, not a sick engineer --

‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾‾
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: John Williams <[email-masked]>
Date: Thu, 9 May 1996 16:31:17 -0600 (MDT)

One of the items on the fvwm2-TO.DO list is:

  - Make left justified pixmaps in menus center align vertically w/
    any text displayed?

It seems that small pixmaps are already centered with larger text, but
text is not centered with larger pixmaps.
So here is a small patch to fix the vertical alignment.

~John Williams

--- 1.1	1996/05/09 21:41:26
+++ menus.c	1996/05/09 22:06:27
@@ -179,6 +179,14 @@
   text_y = y_offset + Scr.StdFont.y;
   if(mi->picture)
     text_y+=mi->picture->height;
+  if (mi->lpicture)
+  {
+    y = mi->lpicture->height - Scr.StdFont.height;
+    if (y>1)
+      text_y += y>>1;
+  }    
 
   ShadowGC = Scr.MenuShadowGC;
   if(Scr.d_depth<2)