Subject: FVWM: keypad, linux, fvwm

From: raku <[email-masked]>
Date: Tue, 21 May 1996 22:56:12 -0400

I'm a big fan of fvwm on my system at work (IBM RISC/6000 AIX 3.xxxx,
fvwm 1.x).  I'm running linux on a Pentium system at home and I'm having
trouble getting some parts of my work configuration to work at home.  

Most notably, I use key mappings similar to some discussed in the fvwm
mailing list archives to move about using the keypad:

Key KP_7  	A	CS	GotoPage 0 0
Key KP_8	A	CS	GotoPage 1 0
Key KP_9	A	CS	GotoPage 2 0
Key KP_4	A	CS	GotoPage 0 1
Key KP_5	A	CS	GotoPage 1 1
Key KP_6	A	CS	GotoPage 2 1
Key KP_1	A	CS	GotoPage 0 2
Key KP_2	A	CS	GotoPage 1 2
Key KP_3	A	CS	GotoPage 2 2

However, I haven't been able to get these mappings to work on either
fvwm 1.24 or fvwm 2.0.  I can get the GotoPage function to work when
mapped to another key, so I'm suspicious of my
/usr/include/X11/keysymdef.h.  The relevant lines from this file are:

#define XK_KP_0			0xFFB0
#define XK_KP_1			0xFFB1
#define XK_KP_2			0xFFB2
#define XK_KP_3			0xFFB3
#define XK_KP_4			0xFFB4
#define XK_KP_5			0xFFB5
#define XK_KP_6			0xFFB6
#define XK_KP_7			0xFFB7
#define XK_KP_8			0xFFB8
#define XK_KP_9			0xFFB9

I don't completely understand what these lines represent.  Is it
possible that there is a mismatch between this file and my keyboard (an
early IBM 101 key keyboard originally from an XT-286)?

I am a nearly the latest linux kernal, but I'm probably a bit back level
on both fvwm versions.  

I can't think of anything else, which is, of course, why I'm asking.

Thanks in advance.

-Dave

[email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Niles <[email-masked]>
Date: Wed, 22 May 1996 07:54:43 -0500

[clip]

> early IBM 101 key keyboard originally from an XT-286)?

Use xev to verify that the keys are mapped correctly.  If they are not,
you can remap them with xmodmap.

Dan Niles
[email-masked]