Subject: FVWM: Pager

From: Jamie <[email-masked]>
Date: Mon, 20 May 1996 23:23:24 -0400 (EDT)

A user I am helping has lost the ability to use her pager. I believe the 
problem is somewhere in her .fvwm2rc file, which I am including here, 
but for the life of me I can't find the error.

Any help greatly appreciated,

- Jamie

Begin file:

# Trying to compile an old .fvwrc to the  new fvwm-2.0 Format
# Unfortunately, order does matter in this file
# The correct order for inserting configurations is:
# 1. Colors
# 2. Assorted configuration paramters such as ClickToFocus, or MWMBorders
# 3. Path setup (ModulePath, PixmapPath, IconPath)
# 4. Style settings, including the default style Style "*" ...
# 5. InitFunction and ResetFunction definitions.
# 6. Other Functions. Functions cannot be forward referenced from
#	other functions, but they can be backward referenced.
# 7. Menus definitions. Same caveats about forward referencing
# 8. Key and Mouse Bindings.
# 9. Module options.

# The order of steps 5, 6, and 7 is not critical, as long as there are
# no forward references to functions or menus.

# If you get it wrong, the most common problem is that color or font settings
# are ignored

###########################################################################
# set up the colors
#
#!StdForeColor 		Black (new command=Style "*" Color f/b)
Style "*" ForeColor Black
#!StdBackColor		#006080 (new command=Style "*" Color f/b)

Style "*" BackColor #006080
#!HiForeColor 		#008080 (new command=HilightColor)
#!HiBackColor 		#600080 (new command=HilightColor)

#Set the foreground and background color for selected windows
HilightColor   #008080 #600080
#!PagerForeColor		orchid (new command=Style FvwmPager)
#!PagerBackColor		BlanchedAlmond (new command=Style FvwmPager)
#!StickyForeColor		Black (no sticky foreground color in fvwm2)
#!StickyBackColor		#60c0a0 (no sticky background color in fvwm2)
#!MenuForeColor           #008080 (new command=MenuStyle)
#!MenuBackColor           #600080 (new command=MenuStyle)
#!MenuStippleColor        SlateGrey (new command=MenuStyle)

############################################################################
# Now the fonts - one for menus, another for window titles, another for icons
#!Font			-adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-* (new command=MenuStyle)
WindowFont		-adobe-helvetica-bold-r-*-*-12-*-*-*-*-*-*-*
IconFont		-adobe-helvetica-medium-r-*-*-11-*-*-*-*-*-*-*

###########################################################################
# Set up the major operating modes
#
########################      FOCUS STUFF     ##############################
# Set windows to auto-raise after 750 milliseconds if you like it.
# Autoraise can sometimes obscure pop-up windows. Performance is now
# similar to olvwm's auto-raise feature.
#AutoRaise 750

# Normally, we'll be in focus-follows mouse mode, but uncomment this 
# for mwm-style click-to-focus
#ClickToFocus

########################      ICON STUFF     ##############################
# Auto Place Icons is a nice feature....
# This creates two icon boxes, one on the left side, then one on the
# bottom. Leaves room in the upper left for my clock and xbiff,
# room on the bottom for the Pager.
#IconBox -150 90 -5 -140
#IconBox 5 -140 -140 -5
Style "*" IconBox -70 1 -1 -140

# If you uncomment this, and make sure that the WindowList is bound to
# something, it works pretty much like an icon manager.
Style "*" NoIcon

# StubbornIcons makes icons de-iconify into their original position on the
# desktop, instead of on the current page.
#StubbornIcons

# With AutoPlacement, icons will normally place themselves underneath active
# windows. This option changes that.
#StubbornIconPlacement

# If you want ALL you icons to follow you around the desktop (Sticky), try
# this
#StickyIcons

########################      MWM EMULATION     #######################
#
# My feeling is that everyone should use MWMDecorHints and MWMFunctionHints,
# since some applications depend on having the window manager respect them

# MWMFunction hints parses the function information in the MOTIF_WM_HINTS
# property, and prohibits use of these functions on the window. Appropriate
# portions of the window decorations are removed.
#MWMFunctionHints

# MWM is kinda picky about what can be done to transients, and it was keeping
# me from iconifying some windows that I like to iconify, so here's an
# over-ride that will allow me to do the operation, even tough the menu
# item is shaded out.
#MWMHintOverride

# MWMDecor hints parses the decoration information in the MOTIF_WM_HINTS
# property, and removes these decoratons from the window. This does not affect
# the functions that can be performed via the menus.
#MWMDecorHints

Style "*" MWMButtons
########################      MISCELLANEOUS STUFF     #######################
# If you don't like the default 150 msec click delay for the complex functions
# change this and uncomment it.
ClickTime 10

# OpaqueMove has a number (N) attached to it (default 5).
# if the window occupies less than N% of the screen, 
# then opaque move is used. 0 <= N <= 100
OpaqueMoveSize 5

# flip by whole pages on the edge of the screen.
EdgeScroll 100 100

# A modest delay before flipping pages seems to be nice...
# I thresh in a 50 pixel Move-resistance too, just so people
# can try it out.
EdgeResistance 250 50

########################      WINDOW PLACEMENT     #######################
# RandomPlacement prevents user interaction while placing windows:
#RandomPlacement

# SmartPlacement makes new windows pop-up in blank regions of screen 
# if possible, or falls back to random or interactive placement.
Style "*" SmartPlacement

# With SmartPlacement, windows will normally place themselves over icons. 
# Uncomment this to change that.
#StubbornPlacement

# NoPPosition instructs fvwm to ignore the PPosition field in window 
# geometry hints. Emacs annoyingly sets PPosition to (0,0)!
Style "*" NoPPosition

###########################################################################
# Set up the virtual desktop and pager

#set the desk top size in units of physical screen size
DeskTopSize 2x2

# and the reduction scale used for the panner/pager
#! DeskTopScale 32

##########################################################################
# Module path and paths to the icons
#
# ModulePath is a colon-separated list, just like regular unix PATH
ModulePath /home/nc0378/X11R6/lib/X11/fvwm2 
PixmapPath /depot/x11r6/lib/X11/twm/images:/home/nc0465/.icons
IconPath   /home/nc0465:/home/nc0465/.icons

############################################################################
# Set the decoration styles and window options
# Order is important!!!!
# If compatible styles are set for a single window in multiple Style
# commands, then the styles are ORed together. If conflicting styles
# are set, the last one specified is used.

# These commands should command before any menus or functions are defined,
# and before the internal pager is started.

# change the default width.
Style "*" BorderWidth 5, HandleWidth 5, Icon unknown1.xpm, RandomPlacement
Style "Fvwm*"      NoTitle, NoHandles, Sticky, WindowListSkip,BorderWidth 0
#Style "Fvwm Pager" StaysOnTop
#Style "FvwmPager"  StaysOnTop
#Style "FvwmBanner" StaysOnTop
Style "FvwmButtons"  NoTitle, NoHandles, Sticky, WindowListSkip,BorderWidth 0
Style "*lock"      NoTitle, NoHandles, Sticky, WindowListSkip
Style "xbiff"      NoTitle,            Sticky, WindowListSkip
Style "xterm"      	StartsOnDesk 0, Icon xterm.xpm
Style "xv"		StartsOnDesk 1
Style "xcalc"      Icon xcalc.xpm
Style "xbiff"      Icon mail1.xpm
Style "xman"	   Icon xman.xpm
Style "xvgr"	   Icon graphs.xpm
Style "xmag"	   Icon mag_glass.xpm
Style "xgraph"	   Icon graphs.xpm
Style "xcmap"		WindowListSkip
Style "FvwmButtons"  Icon toolbox.xpm
Style "Netscape"	StartsOnDesk 1
Style "xmeter"		NoTitle, NoHandles, WindowListSkip, BorderWidth 0, StaysOnTop, StartsOnDesk 0
Style "hotlog"		WindowListSkip, StaysOnTop, StartsOnDesk 0
Style "pinglog"		WindowListSkip, StaysOnTop, StartsOnDesk 0
Style "irc"        Icon xirc.xpm, StartsOnDesk 0
Style "netcom*"		StartsOnDesk 0
Style "office*"		StartsOnDesk 0
Style "ix"		Icon rterm.xpm, StartsOnDesk 0
Style "yp"		Icon rterm.xpm, StartsOnDesk 0
Style "Netcom*"		StartsOnDesk 2

# Change the Maximize and iconify buttons to up and down triangles.

#ButtonStyle : 2 4 50x35@1 65x65@0 35x65@0 50x35@1
#ButtonStyle : 4 4 50x65@1 35x35@1 65x35@1 50x65@0

#############################################################################

# Stuff to do at start-up

AddToFunc "InitFunction" "I" Exec xv -root -quit /home/nc0465/html/pics/10.jpg 

#AddToFunc "RestartFunction" 

Module FvwmButtons
############################################################################
# Now define some handy complex functions

# This one moves and then raises the window if you drag the mouse,
# only raises the window if you click,  or does a RaiseLower if you double 
# click
AddToFunc "Move-or-Raise" "M" Move
+              "M" Raise
+              "C" Raise
+              "D" RaiseLower

# This one moves and then lowers the window if you drag the mouse,
# only lowers the window if you click,  or does a RaiseLower if you double 
# click
AddToFunc "Move-or-Lower" "M" Move
+              "M" Lower
+              "C" Lower

# This one resizes and then raises the window if you drag the mouse,
# only raises the window if you click,  or does a RaiseLower if you double 
# click
AddToFunc "Resize-or-Raise" "M" Resize
+              "M" Raise
+              "C" Raise

AddToFunc "Move-or-Iconify" "M" Move
+              "C" Iconify

AddToFunc "crap" "I" Desk 0 0
+              "I" GoToPage 1,0
+              "I" Exec exec xterm -sb -sl 2000 -T pinglog -g 198x23+0-364 -e pl &
+              "I" Exec xm &

##############################################################################
#now define the menus - defer bindings until later

# This defines the most common window operations
AddToMenu "Window" "Move" Function Move-or-Raise
+              "Resize" Function Resize-or-Raise
+              "Raise" Raise
+              "Lower" Lower
+              "(De)Iconify" Iconify
+              "(Un)Stick" Stick
+              "(Un)Maximize" Maximize 0 85
+              "" Nop
+              "Destroy" Destroy
+              "Close" Close
+              "" Nop
+              "Identify" Module FvwmIdent
+              "ScrollBar" Module FvwmScroll 2 2

# This menu will fire up some very common utilities
AddToMenu "Utilities" "Utilities" Title
+              "xcalc" Exec exec xcalc &
+              "Xman" Exec exec xman &
+              "crap" Function crap
+              "" Nop
+              "Window" PopUp Window
+              "Refresh Screen" Refresh
+              "" Nop
+              "Restart" Restart fvwm
+              "Exit Fvwm" Quit

AddToMenu "Office" "office" Exec exec xterm -T office -sb -sl 2000 -e telnet office &
+              "office3" Exec exec xterm -T office3 -sb -sl 2000 -e telnet office3 &
+              "office4" Exec exec xterm -T office4 -sb -sl 2000 -e telnet office4 &

AddToMenu "Hosts" "netcom1" Exec exec xterm -T netcom1 -sb -sl 2000 -e telnet netcom1 &
+              "netcom2" Exec exec xterm -T netcom2 -sb -sl 2000 -e telnet netcom2 &
+              "netcom3" Exec exec xterm -T netcom3 -sb -sl 2000 -e telnet netcom3 &
+              "netcom4" Exec exec xterm -T netcom4 -sb -sl 2000 -e telnet netcom4 &
+              "netcom5" Exec exec xterm -T netcom5 -sb -sl 2000 -e telnet netcom5 &
+              "netcom6" Exec exec xterm -T netcom6 -sb -sl 2000 -e telnet netcom6 &
+              "netcom7" Exec exec xterm -T netcom7 -sb -sl 2000 -e telnet netcom7 &
+              "netcom8" Exec exec xterm -T netcom8 -sb -sl 2000 -e telnet netcom8 &
+              "netcom9" Exec exec xterm -T netcom9 -sb -sl 2000 -e telnet netcom9 &
+              "netcom10" Exec exec xterm -T netcom10 -sb -sl 2000 -e telnet netcom10 &
+              "netcom11" Exec exec xterm -T netcom11 -sb -sl 2000 -e telnet netcom11 &
+              "netcom12" Exec exec xterm -T netcom12 -sb -sl 2000 -e telnet netcom12 &
+              "netcom13" Exec exec xterm -T netcom13 -sb -sl 2000 -e telnet netcom13 &
+              "netcom14" Exec exec xterm -T netcom14 -sb -sl 2000 -e telnet netcom14 &
+              "netcom15" Exec exec xterm -T netcom15 -sb -sl 2000 -e telnet netcom15 &
+              "netcom16" Exec exec xterm -T netcom16 -sb -sl 2000 -e telnet netcom16 &
+              "netcom17" Exec exec xterm -T netcom17 -sb -sl 2000 -e telnet netcom17 &
+              "netcom18" Exec exec xterm -T netcom18 -sb -sl 2000 -e telnet netcom18 &
+              "netcom19" Exec exec xterm -T netcom19 -sb -sl 2000 -e telnet netcom19 &
+              "netcom20" Exec exec xterm -T netcom20 -sb -sl 2000 -e telnet netcom20 &
+              "netcom21" Exec exec xterm -T netcom21 -sb -sl 2000 -e telnet netcom21 &
+              "netcom22" Exec exec xterm -T netcom22 -sb -sl 2000 -e telnet netcom22 &
+              "netcom23" Exec exec xterm -T netcom23 -sb -sl 2000 -e telnet netcom23 &

AddToMenu "Logins" "Office" Title
+              "yp" Exec exec xterm -T yp -sb -sl 2000 -e telnet yp &
+              "ix" Exec exec xterm -T ix -sb -sl 2000 -e telnet ixoffice 3 &
+              "hosts" PopUp Hosts
+	       "office" PopUp Office

AddToFunc "Menu-or-Close" "M" PopUp Window
+              "C" Close

#     Button	Context Modifi 	Function
Mouse 1		R   	A Menu "Utilities" Nop
Mouse 2		R    	A	Module FvwmWinList transient
Mouse 3		R    	A Menu "Logins" Nop

# Now the title bar buttons
# Any button in the left title-bar button gives the window ops menu
# Any button in the right title-bar button Iconifies the window
# Any button in the rightmost title-bar button maximizes
# Note the use of "Mouse 0" for AnyButton.

#     Button	Context Modifi 	Function
Mouse 1		1    	A	Function "Menu-or-Close"
Mouse 2		1	A	Module FvwmIdent
Mouse 3		1	A	Destroy
Mouse 1		2    	A     	Maximize 0 85
Mouse 2		2	A	Maximize 0 100
Mouse 3		2	A	Maximize 100 100
Mouse 1		4    	A     	Iconify
Mouse 2		4	A	Module FvwmScroll 4 4
Mouse 3		4	A	Module FvwmScroll 2 2

# Now the rest of the frame
# Here I invoke my complex functions for Move-or-lower, Move-or-raise,
# and Resize-or-Raise. 
# Button 1 in the corner pieces, with any modifiers, gives resize or raise
Mouse 1		F	A	Function "Resize-or-Raise"
# Button 1 in the title, sides, or icon, w/ any modifiers, gives move or raise
Mouse 1		TS	A	Function "Move-or-Raise"

Mouse 1		I	A	Function "Move-or-Iconify"
Mouse 3		I	A	Close

# Button 2 in the corners, sides, or title-bar gives the window ops menu
Mouse 2		FST	A Menu "Window" Nop
# Button 3 anywhere in the decoration (except the title-bar buttons)
# does a raise-lower
Mouse 3		TSF	A	RaiseLower

# Button 3 in the window, with the Modifier-1 key (usually alt or diamond)
# gives Raise-Lower. Used to use control here, but that interferes with xterm 
#Mouse 3         W       M       RaiseLower

############################################################################
# Now some keyboard shortcuts.

Key Left	R	A	Scroll -100 0
Key Right	R	A	Scroll +100 +0
Key Up		R	A	Scroll +0   -100
Key Down	R	A	Scroll +0   +100

Key Left	A	C	Scroll -100 +0
Key Right	A	C	Scroll +100 +0
Key Up		A	C	Scroll +0   -100
Key Down	A	C	Scroll +0   +100

Key Left	A	S	Scroll -10 +0
Key Right	A	S	Scroll +10 +0
Key Up		A	S	Scroll +0 -10
Key Down	A	S	Scroll +0 +0

Key Next	A	A	CirculateUp
Key Prior	A	A	CirculateDown

# press shift arrow + control anywhere, and move the pointer by 1% of a page
#Key Left	A	SC	CursorMove -1 0
#Key Right	A	SC	CursorMove +1 +0
#Key Up		A	SC	CursorMove +0   -1
#Key Down	A	SC	CursorMove +0   +1

# press shift arrow + meta key, and move the pointer by 1/10 of a page
#Key Left	A	SM	CursorMove -10 +0
#Key Right	A	SM	CursorMove +10 +0
#Key Up		A	SM	CursorMove +0   -10
#Key Down	A	SM	CursorMove +0   +10

# Keyboard accelerators
#Key F1		A	M	Popup "Utilities"
#Key F2		A	M	Popup "Window"
#Key F3		A	M	Module "WindowList" FvwmWinList 
#Key F4		A	M	Iconify
#Key F5		A	M	Move
#Key F6		A	M	Resize
#Key F7		A	M	CirculateUp
#Key F8		A	M	CirculateDown

#Page Up/Dapge Down keys are used to scroll by one desktop page
# in any context, press page up/down + control
# in root context, just pressing page up/down is OK
# 
# I prefer the non-wrapping scroll. These are for example purposes only
#Key Next	A       C       Scroll 100000 0
#Key Next	R       N       Scroll 100000 0  
#Key Prior	A       C       Scroll -100000 0
#Key Prior	R       N       Scroll -100000 0

############################################################################
############################################################################
#Definitions used by the modules

###################### GoodStuff button-bar ################################
# Colors
*FvwmButtonsFore Black
*FvwmButtonsBack #908090

# Font
*FvwmButtonsFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
# Geometry - really likes to pick its own size, but giving a position is OK
*FvwmButtonsGeometry -1-1

# Layout: specify rows or columns, not both
*FvwmButtonsRows 1

# Define the buttons to use.....
*FvwmButtons	die		hand.xpm	Exec "kill" kill -9 -1
*FvwmButtons	Kill		opus.xpm    Destroy
*FvwmButtons	xterm		knot.xpm		Exec "xterm" xterm -sb -sl 2000 
*FvwmButtons	Pine		panic.xpm		Exec "Pine" xterm -T Pine -e pine -i &
*FvwmButtons	irc		lips.xpm	Exec "irc" xterm -T irc -sb -sl 2000 -e irc -S & 
*FvwmButtons	Netscape	worm.xpm	Exec "Netscape" netscape -install &
*FvwmButtons 	xv		ball.xpm	Exec "xv" xv & 
*FvwmButtons(3x1) - 		NULL		SwallowModule Exec "FvwmPager" FvwmPager 0 2
#*GoodStuff	Paging  	clamp.xpm   	TogglePage

######################### No Clutter ########################################
# I only wrote NoClutter as a simple test case, but maybe some big sites like
# universities really have usage problems (too many open windows)....
# Time delays are in seconds.
*FvwmNoClutter 3600 Iconify 1
*FvwmNoClutter 86400 Delete
*FvwmNoCLutter 172800 Destroy

########################## Window-Identifier ###############################
# Just choose colors and a fonts
*FvwmIdentBack MidnightBlue
*FvwmIdentFore Yellow
*FvwmIdentFont -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*

########################### Pager #########################################
*FvwmPagerBack #908090
*FvwmPagerFore #484048
*FvwmPagerFont -adobe-helvetica-bold-r-*-*-8-*-*-*-*-*-*-*
#*FvwmPagerFont none
*FvwmPagerHilight #cab3ca
*FvwmPagerGeometry -1500-1500
*FvwmPagerLabel 0 office 
*FvwmPagerLabel 1 stuff
*FvwmPagerLabel 2 personal
*FvwmPagerSmallFont 5x7

##########################FvwmWinList##################################
*FvwmWinListBack #908090
*FvwmWinListFore Black
*FvwmWinListFont -adobe-helvetica-bold-r-*-*-10-*-*-*-*-*-*-*
*FvwmWinListAction Click1 Iconify -1,Focus
*FvwmWinListAction Click2 Iconify
*FvwmWinListAction Click3 Module "FvwmIdent" FvwmIdent
*FvwmWinListUseSkipList
*FvwmWinListGeometry -1+0
#!WARNING: Keyword "" not handled yet
                                      
#Set the foreground, background and stipple color and font for menus
MenuStyle   #008080 #600080 SlateGrey -adobe-helvetica-medium-r-*-*-12-*-*-*-*-*-*-* fvwm

End File.

-- 
+---------------------------------------------------------------------+
|The shadows of life cover the sunlight of the soul, and block out the| 
|radiance that all have within them, leaving only darkness behind.    |
+-----------------------------+---------------------+-----------------+
[email-masked] | [email-masked] | [email-masked] |
+-----------------------------+---------------------+-----------------+

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Richard Lister <[email-masked]>
Date: Tue, 21 May 1996 09:48:59 +0100

On Mon, 20 May 1996 23:23:24 -0400 (EDT)
Jamie <[email-masked]> 
> but for the life of me I can't find the error.

Hi Jamie

Aha, you're swallowing the pager. I'm going to assume you're using 2.0.42
because this happened to a lot of my users upgrading from 2.0.39. 

> *FvwmButtons(3x1) - 		NULL		SwallowModule Exec "FvwmPager" FvwmPager 0 2

You have to change 'SwallowModule Exec' to 'Swallow' here:

*FvwmButtons(3x1) -     whatever Swallow "Fvwm Pager" FvwmPager 0 2

Ric

 ~~~~~~~~~~~~~~ Richard J. Lister    [email-masked] ~~~~~~~~~~~~~~~~
            Research Assistant, Neural Computing Research Group
                  Aston University, Birmingham B4 7ET, UK
 ~~~~~~~~~~~~~~~~~ http://www.ncrg.aston.ac.uk/~listerrj/ ~~~~~~~~~~~~~~~~~~
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].