Subject: FVWM: Silent fail!

From: [email-masked] (David Kennedy)
Date: Wed, 1 May 1996 14:13:01 +0100

[Discussion snipped of why Fvwm now dies on me with an error:
ld.so.1: /home7/dcjk/bin/fvwm: fatal: libXpm.so.4.8: can't open file: errno=2
Any help welcomed.]

Dan reckoned LD_LIBRARY_PATH might need tweaked.

I thought of LD_LIBRARY_PATH and attempted to make doubly sure that it
is set like this: (from my .xinitrc, it should already be set)
-----
setenv LD_LIBRARY_PATH ${LD_LIBRARY_PATH}:${HOME}/lib
				^^^ This is the kludge line for the xpm libs.
 
if [ "$OW_WINDOW_MANAGER" ]; then       # Alternate Window Manager	<-- Defined as fvwm
    xsetroot -def                           # Clear root window		    Usual method of
    $OW_WINDOW_MANAGER & wmpid=$!           # Start Alt Window Manager      running it here.
    dsdm &                                  # OpenLook Drop Site Database
    unset OW_WINDOW_MANAGER
else
    sleep 15 & pid=$!                   # OpenLook Window Manager
    olwm -syncpid $pid & wmpid=$!
    wait $pid                           # Pause until olwm inits
fi
----

Unless I have made a mistake with the syntax here this pretty much rules out
a problem with LD_LIBRARY_PATH does it not? I'm puzzled!
-- 
David Kennedy, Dept. of Pure & Applied Physics, Queen's University of Belfast
-----------------------------------------------------------------------------
Email: [email-masked] | URL: http://star.pst.qub.ac.uk/~dcjk/

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Wed, 01 May 1996 09:21:17 -0400

----------
> a problem with LD_LIBRARY_PATH does it not? I'm puzzled!

Since you are on Solaris, when in doubt,  use truss!  Start fvwm2 like
this:

truss fvwm2 2>/var/tmp/fvwm.truss

Then search the resulting /var/tmp/fvwm.truss for "xpm".  It should be
clear where fvwm2 is looking for the shared object.

--
Dan Espen                                    Phone: (908) 699-5570
[email-masked]
444 Hoes Lane  Room RRC 1C-214
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Stefan 'Stetson' Skoglund" <[email-masked]>
Date: Thu, 2 May 1996 09:46:25 +0200

ldd fvwm should tell you where ld.so finds the shared
libraries. I personally try to stay away from
LD_LIBRARY_PATH. Less surprises that way when newbies
tries to run program i have installed...
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].