Subject: FVWM: FvwmForm bug

From: Jens-U H Petersen <[email-masked]>
Date: Wed, 1 May 96 17:38:26 JST

I think I have found a bug in FvwmForm.

In the man page it says:

---- Start of included text -----------------------8<--- cut here -------------
     $(name)         If name corresponds to a text  input  field,
                     the result is the user's input string.  Spe-
                     cial chars such as ", ', and  will  be  pre-
                     ceded by a backslash.

                     If name corresponds to a choice, the  result
                     is  the value of the choice (as specified in
                     *FvwmFormChoice) if the choice is  selected.
                     If the choice is not selected, the result is
                     a blank string.

---- End of included text -------------------------8<--- and here -------------

but in fact (in my experience) $(name) expands to its value
whether it is set or not!

Also why is it not possible to use the same name (with different
values of course) for more than one choice.  It would be very
natural and useful.

If anyone is interested I can send you my Xrsh form (now
working!), which allows you to choose a programme and host to run
it on with just 2 mouse clicks. :-)

Jens
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Ian MacKinnon)
Date: Wed, 1 May 1996 09:48:36 +0100

> it on with just 2 mouse clicks. :-)

Yes Please.

                       \|/
                      (o o)
+==================oOO-(_)-OOo==========================+
|If you don't care where you are, you can't be lost     |
|                                                       |
|_______________________________________________________|
| Ian MacKinnon             [email-masked]|
| (44) 171 293 1413                                     |
|_______________________________________________________|
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jens-U H Petersen <[email-masked]>
Date: Wed, 1 May 96 18:06:38 JST

Here you go.  As it is, it assumes you have `xrsh' from X contrib
(I guess the old `xon' would be good enough in many cases) and
that you are parsing your .fvwm2rc with `m4'.  If you're not
using `m4' and you don't want to, then just replace "HOSTMAP" by
its definition everywhere....  The `m4' parsing would be
completely unnecessary here, if $(name) worked as documented. :-(

Enjoy and do send me any improvements you make.

Jens

ps Of course you have to bind the form to something, right?  I
have it on mouse-3:

	Mouse 3		R    	A       Module FvwmForm Xrsh

---- Start of included text -----------------------8<--- cut here -------------
*XrshWarpPointer
*XrshFont         *helvetica*m*r*n*14*
*XrshButtonFont   *helvetica*m*o*n*14*
*XrshInputFont    *cour*m*r*n*14*
*XrshFore         Black
*XrshBack         Light Gray
*XrshItemFore          Wheat
*XrshItemBack          Gray50
# begin items
*XrshLine         center
*XrshText         "xrsh on remote host"
*XrshLine         expand
#*XrshText         "Host:"
*XrshSelection    Host single
*XrshChoice       clove clove on "clove"
*XrshChoice       cumin cumin off "cumin"
*XrshChoice       local local off "localhost"
*XrshChoice       parsley parsley off "parsley"
*XrshChoice       ginger ginger off "ginger"
*XrshChoice       pepper pepper off "pepper"
*XrshLine         expand
*XrshButton       quit "emacs" e
define(HOSTMAP,`$(clove?clove)$(cumin?cumin)$(parsley?parsley)$(ginger?ginger)$(pepper?pepper)')
*XrshCommand      Exec  $(local!xrsh HOSTMAP) emacs
*XrshButton       quit "mule" m
*XrshCommand      Exec  $(local!xrsh HOSTMAP) mule
*XrshButton       quit "xterm" x
*XrshCommand      Exec  $(local!xrsh HOSTMAP) xterm -ls -sb -sl 200 -j -fn a14
*XrshButton       quit "netscape" n
*XrshCommand      Exec $(local!xrsh HOSTMAP) netscape -install
*XrshButton       quit "Cancel" ^[
# *XrshCommand      Nop
*XrshCommand      Next [Xrsh] Iconify
*XrshButton       quit "Quit X" L
*XrshCommand      Module FvwmForm QuitVerify
---- End of included text -------------------------8<--- and here -------------
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Stephen Wray <[email-masked]>
Date: Wed, 1 May 1996 21:23:05 +1200 (NZST)

-----BEGIN PGP SIGNED MESSAGE-----

Not *totally* related to the preceding comments... but I've noticed that
on a 16 bpp and 32 bpp display, the FvwmForms come out in black-and-white,
with no shading of gray scale.

Has anyone else noticed this?

- -- 
- ---
I used to think that my brain was the most wonderful organ in my body.

Then I realised who had been telling me this...
- ----------------------------------------------------------------------
Stephen Wray <[email-masked]>

---

From: Dave Goldberg <[email-masked]>
Date: Wed, 01 May 1996 10:01:07 -0400

That happens if your colormap gets filled up.  One kluge workaround is
to start an FvwmForm window (and keep it around) to allocate those
colors before starting any other apps.  I actually do that because I
use an FvwmForm as a replacement for FvwmTalk, and discovered that it
fixed my loss of FvwmForm color problem by accident :-)

This, of course, assumes that all your FvwmForms use the same set of
colors.

Dave Goldberg
Post: The Mitre Corporation\MS B305\202 Burlington Rd.\Bedford, MA 01730
Phone: 617-271-3887
Email: [email-masked]

---

From: Juri Pakaste <[email-masked]>
Date: 01 May 1996 17:04:10 +0300

> Has anyone else noticed this?

Yes. It would be nice to see this fixed.

-- 
// Juri Pakaste
// [email-masked]

---

From: Stephen Wray <[email-masked]>
Date: Thu, 2 May 1996 08:59:29 +1200 (NZST)

-----BEGIN PGP SIGNED MESSAGE-----

>>>>> "Dave" == Dave Goldberg <[email-masked]> writes:

 Dave> That happens if your colormap gets filled up.  One kluge workaround is
 Dave> to start an FvwmForm window (and keep it around) to allocate those
 Dave> colors before starting any other apps.  I actually do that because I
 Dave> use an FvwmForm as a replacement for FvwmTalk, and discovered that it
 Dave> fixed my loss of FvwmForm color problem by accident :-)

At 16 and 32 bits per pixel I doubt *VERY* much that I am running out of
colors.

Since neither netscape, gimp nor xv have any problems finding thousands
or millions of colors, I must assume that the problem is with FvwmForms.

- -- 
- ---

---

From: Dave Goldberg <[email-masked]>
Date: Wed, 01 May 1996 17:05:53 -0400

> At 16 and 32 bits per pixel I doubt *VERY* much that I am running
> out of colors.

yipes!  I clearly didn't read the original message closely enough.
I'm stuck with 8bit and that was definitely my problem.

Sorry,

Dave Goldberg