Subject: FVWM: Why does fvwm reset the root window on restart ?

From: [email-masked] (Albrecht Kadlec)
Date: Tue, 7 May 96 11:27:57 +0200

I'd like to keep my background on restart.
Any reason, why fvwm2 sets the background to black and then to this grey
pattern? 

It happens after fvwm starts up, and I don't think it's from a system
startup script. (searched through all of them, I think.)

Usually a user sets his own background on startup, so this flickering is
annoying. 

We could have a default in the initfunction, and maybe even in the 
"missing .fvwm2rc defaults" section, but if a .fvwm2rc exits I'd leave it
to the user.

albrecht, on a slow sun IPC.

fvwm2.0.42
sunos 4.1.3
-- 
Is anybody list'nin?  Oh, there's no reply at all...	-- Genesis
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Niles <[email-masked]>
Date: Tue, 7 May 1996 08:32:54 -0500

> Date: Tue, 7 May 96 11:27:57 +0200
> From: [email-masked] (Albrecht Kadlec)
> X-Attribution: A
> Reply-To: [email-masked] (Albrecht Kadlec)
> Sender: [email-masked]
> X-Majordomo: 1.92
> Precedence: list
> 
> 

Remove the following line from InitFunction and RestartFunction.

+                         "I" exec xsetroot -mod 2 2 -fg \#554055 -bg \#705070

It is in the default .fvwm2rc.  If you copied it over, you probably have
this line.

Dan Niles
[email-masked]

---

From: [email-masked] (Albrecht Kadlec)
Date: Tue, 7 May 96 16:46:42 +0200

>>>>> Dan Niles writes:
D> Remove the following line from InitFunction and RestartFunction.

D> +                         "I" exec xsetroot -mod 2 2 -fg \#554055 -bg \#705070

D> It is in the default .fvwm2rc.  If you copied it over, you probably have
D> this line.

sorry I forgot to mention:

AddToFunc "RestartFunction"
+	"I"	Module	FvwmButtons
+	"I"	Module	FvwmAuto 500
+	"I"	Exec	exec nice -20 xv -root -random -noqcheck -ncols 100 -max -smooth -quit public_html/Pictures/*/*/* &
# -wait 300 -wloop | -quit 	-maxpect -best24 +loadclear -rmode 5
# apollo's don't like -viewonly :-( but -quit should be enough
#	"I"	Exec	exec xsetroot -solid "#266294" &

so I don't have any xsetroot alive.

ok, I waded through the xv docs again, and now added +noresetroot !!!!
That was the b/w shaded background which was displayed for a short time.

sorry for bothering you,
albrecht
-- 
We used to walk down by the river, she loved to watch the sun go down
We used to walk along the river, and dream our way out of this town ...
							-- Richard Marx
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].