Subject: Re: FVWM: Icons / Icon Colors (was Re: Splitting the Fvwm Package)

From: <[email-masked]> (Charles Hines)
Date: Wed, 17 Apr 1996 12:08:47 -0400

>>>>> "eli" == e  <eli> writes:

ch> Also, I'm contemplating pulling out a lot of the icons into a separate
ch> tar file, and leaving just some "essential" ones (which would be the
ch> only ones that the sample rc file would use).  I might do the same

>> I don't think that it's worth the effort.  A zipped tar file of 600
>> kB is not very large nowadays.  Many other freeware packages suffer

eli>    This brings up several points I wanted to discuss. First of all,
eli> the icons subdirectory is a real mish-mash of pixmaps. k.xpm and k2.xpm
eli> are two PICTURES of somebody's kid. Not exactly useful as icons.

Those are pictures of Rob Nation's child.  One (k2) used to be used
for FvwmBanner.  They are not useful as icons, no, but I haven't had
the heart to remove them.  Perhaps now is the time.

eli> Also, there are a number of duplicate icons (rbomb, bomb; rterm,
eli> xterm) and xpms that I don't think should be in there
eli> (doom*,xboing,xjewel,etc).

The dups should probably be cleaned up, yes, and some of those others
removed.  I've been thinking about doing this for some time, just
haven't bothered yet.

eli>    I'm in the midst of integrating all of the semi-useful icons from
eli> the fvwm distribution with my own collection, which is currently broken up
eli> into 5 directories: mini, small, medium, large, and misc. mini has all the
eli> 14x14 xpms, small has the 32x32s, medium has 48x48, and large has 64x64.
eli> misc gets all of the leftovers, mostly 32x48 (?!).
eli>    Does anyone want to argue for saving the 16x16 xpms? My thought
eli> is that 14x14 works for menus and buttons, 32x32 works in FvwmButtons,
eli> and the larger xpms are suitable for icons.

The 16x16 might also be useful as titlebar buttons, depending on the
size of the font you use in the titlebar.

eli>    Chuck -- if I do this, do you want to replace the current icons
eli> directory with it? It looks as though the result will still be smaller
eli> than the existing icons distribution.

I would certainly like to see the result and I might perhaps replace
the current icons directory with it, yes.

eli>    Also, I took a look at the mini.* pixmaps last night. README.mini
eli> says they use a total of 14 colors. This is no longer the case, but it
eli> could easily be.

The README.mini is from the initial mini xpms contributed, which some
others have been contributed since then by other people.

eli> I looked through them all, and there are 10 common colors: blue,
eli> cyan, magenta, red, orange, yellow, green, black, gray, and white
eli> and 17 uncommon colors. I can EASILY fix the files to use the
eli> same set of colors, but I'd like to add a FEW more to the set of
eli> 10 common colors.  What I need to know is how many.
eli>    Is 14 colors good? Should that INCLUDE black and white? Do people
eli> care what I do? :-) I definatly want to add 2 more shades of
eli> gray, but I haven't decided which. I'd also like gold (between
eli> yellow and orange), a darker green, a better shade of red, and
eli> another blue.
eli>    Adding those brings the total color set to 16, 14 w/o black & white.
eli> I think this would bring the mini pixmaps back into line with the
eli> original intention of a unified colorset. And, at least 11 of the
eli> colors (maybe more) match colors mentioned in colormap.xpm

I've been meaning to reduce the colors of all the xpms to a limited
amount.  I was thinking that 32 might not be bad.  It's not too large
a number, but should be able to contain enough of the standard colors
to enable the xpms to still look good.

I have two programs contributed by list members to reduce the number
of colors, and have had discussions of this type before.  An idea for
a reduced colormap is in the file utils/xpm-reduced-rgb.txt,
contributed by Dan Espen.  His xpm color reduce program is in there as
well.  I know he spoke with Romano Giannetti who wrote another color
reduction program 'pixy' which I have here.  I meant to put it (or at
least a reference to it) in the last release, but forgot.  I believe
it can be found at:

          ftp://sirio.iet.unipi.it/pub/romano/pixy3.2.tar.gz

He includes some sample colormaps as well in his distribution,
both 16 and 32 colors.  I imagine that they'll be pretty close to what
would be good...

So, I was going to get to this eventually, but if you're feeling
ambitious, go ahead.

eli>    And finally, I plan to clean up some of the uglier pictures in
eli> an effort to make them look nicer.

This might be subjective, but lets see what you come up with.

eli> Originally, I thought that pixmaps in menus and buttons would be
eli> silly, but they have the potential to look really good, if the
eli> pixmaps themselves look good.
eli>    I guess that what I want to know is whether there is any sort of
eli> legacy associated with the pixmaps in the icons directory that says they
eli> shouldn't change?

The only thing I would like is for them to use actual named colors
instead of #rrggbb type specifications.

Chuck

*******************************************************************************
Charles K. Hines <[email-masked]>
IBM Logic Synthesis developer [BooleDozer (TM)]
Martial Arts Instructor [Modern Arnis, Presas Style Filipino Martial Arts]

IBM Internal email:                        "Go back to sleep, Chuck.  You're
  [email-masked],              just havin' a nightmare--of course,
  HINESC at FISHKILL, HINESC at FSHVMFK1    we are still in Hell." Gary Larson
*******************************************************************************
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Martin Kraemer <[email-masked]>
Date: Thu, 18 Apr 1996 11:26:41 +0200 (MET DST)

Charles Hines wrote...
> instead of #rrggbb type specifications.
I don't know about X11R6, but between X11R4 and X11R5 the list of named
colors changed significantly. (I know because here at work I run fvwm on
X11R4).

Here's a context diff showing the differences (+ -> only in X11R5,
- -> only in X11R4); you can see that most of the "numbered" color shades
(xxxx1, xxxx2 etc.) are not available in X11R4. It would be nice if we
could settle on a set of named colors which are available on all X
versions ;-)

    Martin

> diff -u -b /var/tmp/x*txt
--- /var/tmp/x11r4-rgb.txt	Thu Apr 18 11:20:20 1996
+++ /var/tmp/x11r5-rgb.txt	Thu Apr 18 11:20:15 1996
@@ -1,67 +1,359 @@
+AliceBlue
+AntiqueWhite
+AntiqueWhite1
+AntiqueWhite2
+AntiqueWhite3
+AntiqueWhite4
+BlanchedAlmond
 BlueViolet
 CadetBlue
+CadetBlue1
+CadetBlue2
+CadetBlue3
+CadetBlue4
 CornflowerBlue
+DarkGoldenrod
+DarkGoldenrod1
+DarkGoldenrod2
+DarkGoldenrod3
+DarkGoldenrod4
 DarkGreen
+DarkKhaki
 DarkOliveGreen
+DarkOliveGreen1
+DarkOliveGreen2
+DarkOliveGreen3
+DarkOliveGreen4
+DarkOrange
+DarkOrange1
+DarkOrange2
+DarkOrange3
+DarkOrange4
 DarkOrchid
+DarkOrchid1
+DarkOrchid2
+DarkOrchid3
+DarkOrchid4
+DarkSalmon
+DarkSeaGreen
+DarkSeaGreen1
+DarkSeaGreen2
+DarkSeaGreen3
+DarkSeaGreen4
 DarkSlateBlue
 DarkSlateGray
+DarkSlateGray1
+DarkSlateGray2
+DarkSlateGray3
+DarkSlateGray4
 DarkSlateGrey
 DarkTurquoise
+DarkViolet
+DeepPink
+DeepPink1
+DeepPink2
+DeepPink3
+DeepPink4
+DeepSkyBlue
+DeepSkyBlue1
+DeepSkyBlue2
+DeepSkyBlue3
+DeepSkyBlue4
 DimGray
 DimGrey
+DodgerBlue
+DodgerBlue1
+DodgerBlue2
+DodgerBlue3
+DodgerBlue4
+FloralWhite
 ForestGreen
+GhostWhite
 GreenYellow
+HotPink
+HotPink1
+HotPink2
+HotPink3
+HotPink4
 IndianRed
+IndianRed1
+IndianRed2
+IndianRed3
+IndianRed4
+LavenderBlush
+LavenderBlush1
+LavenderBlush2
+LavenderBlush3
+LavenderBlush4
+LawnGreen
+LemonChiffon
+LemonChiffon1
+LemonChiffon2
+LemonChiffon3
+LemonChiffon4
 LightBlue
+LightBlue1
+LightBlue2
+LightBlue3
+LightBlue4
+LightCoral
+LightCyan
+LightCyan1
+LightCyan2
+LightCyan3
+LightCyan4
+LightGoldenrod
+LightGoldenrod1
+LightGoldenrod2
+LightGoldenrod3
+LightGoldenrod4
+LightGoldenrodYellow
 LightGray
 LightGrey
+LightPink
+LightPink1
+LightPink2
+LightPink3
+LightPink4
+LightSalmon
+LightSalmon1
+LightSalmon2
+LightSalmon3
+LightSalmon4
+LightSeaGreen
+LightSkyBlue
+LightSkyBlue1
+LightSkyBlue2
+LightSkyBlue3
+LightSkyBlue4
+LightSlateBlue
+LightSlateGray
+LightSlateGrey
 LightSteelBlue
+LightSteelBlue1
+LightSteelBlue2
+LightSteelBlue3
+LightSteelBlue4
+LightYellow
+LightYellow1
+LightYellow2
+LightYellow3
+LightYellow4
 LimeGreen
 MediumAquamarine
 MediumBlue
-MediumForestGreen
-MediumGoldenrod
 MediumOrchid
+MediumOrchid1
+MediumOrchid2
+MediumOrchid3
+MediumOrchid4
+MediumPurple
+MediumPurple1
+MediumPurple2
+MediumPurple3
+MediumPurple4
 MediumSeaGreen
 MediumSlateBlue
 MediumSpringGreen
 MediumTurquoise
 MediumVioletRed
 MidnightBlue
+MintCream
+MistyRose
+MistyRose1
+MistyRose2
+MistyRose3
+MistyRose4
+NavajoWhite
+NavajoWhite1
+NavajoWhite2
+NavajoWhite3
+NavajoWhite4
 NavyBlue
+OldLace
+OliveDrab
+OliveDrab1
+OliveDrab2
+OliveDrab3
+OliveDrab4
 OrangeRed
+OrangeRed1
+OrangeRed2
+OrangeRed3
+OrangeRed4
+PaleGoldenrod
 PaleGreen
+PaleGreen1
+PaleGreen2
+PaleGreen3
+PaleGreen4
+PaleTurquoise
+PaleTurquoise1
+PaleTurquoise2
+PaleTurquoise3
+PaleTurquoise4
+PaleVioletRed
+PaleVioletRed1
+PaleVioletRed2
+PaleVioletRed3
+PaleVioletRed4
+PapayaWhip
+PeachPuff
+PeachPuff1
+PeachPuff2
+PeachPuff3
+PeachPuff4
+PowderBlue
+RosyBrown
+RosyBrown1
+RosyBrown2
+RosyBrown3
+RosyBrown4
+RoyalBlue
+RoyalBlue1
+RoyalBlue2
+RoyalBlue3
+RoyalBlue4
+SaddleBrown
 SandyBrown
 SeaGreen
+SeaGreen1
+SeaGreen2
+SeaGreen3
+SeaGreen4
 SkyBlue
+SkyBlue1
+SkyBlue2
+SkyBlue3
+SkyBlue4
 SlateBlue
+SlateBlue1
+SlateBlue2
+SlateBlue3
+SlateBlue4
+SlateGray
+SlateGray1
+SlateGray2
+SlateGray3
+SlateGray4
+SlateGrey
 SpringGreen
+SpringGreen1
+SpringGreen2
+SpringGreen3
+SpringGreen4
 SteelBlue
+SteelBlue1
+SteelBlue2
+SteelBlue3
+SteelBlue4
 VioletRed
+VioletRed1
+VioletRed2
+VioletRed3
+VioletRed4
+WhiteSmoke
 YellowGreen
+alice blue
+antique white
 aquamarine
+aquamarine1
+aquamarine2
+aquamarine3
+aquamarine4
+azure
+azure1
+azure2
+azure3
+azure4
+beige
+bisque
+bisque1
+bisque2
+bisque3
+bisque4
 black
+blanched almond
 blue
 blue violet
+blue1
+blue2
+blue3
+blue4
 brown
+brown1
+brown2
+brown3
+brown4
+burlywood
+burlywood1
+burlywood2
+burlywood3
+burlywood4
 cadet blue
+chartreuse
+chartreuse1
+chartreuse2
+chartreuse3
+chartreuse4
+chocolate
+chocolate1
+chocolate2
+chocolate3
+chocolate4
 coral
+coral1
+coral2
+coral3
+coral4
 cornflower blue
+cornsilk
+cornsilk1
+cornsilk2
+cornsilk3
+cornsilk4
 cyan
+cyan1
+cyan2
+cyan3
+cyan4
+dark goldenrod
 dark green
+dark khaki
 dark olive green
+dark orange
 dark orchid
+dark salmon
+dark sea green
 dark slate blue
 dark slate gray
 dark slate grey
 dark turquoise
+dark violet
+deep pink
+deep sky blue
 dim gray
 dim grey
+dodger blue
 firebrick
+firebrick1
+firebrick2
+firebrick3
+firebrick4
+floral white
 forest green
+gainsboro
+ghost white
 gold
+gold1
+gold2
+gold3
+gold4
 goldenrod
+goldenrod1
+goldenrod2
+goldenrod3
+goldenrod4
 gray
 gray0
 gray1
@@ -166,6 +458,10 @@
 gray99
 green
 green yellow
+green1
+green2
+green3
+green4
 grey
 grey0
 grey1
@@ -268,49 +564,175 @@
 grey97
 grey98
 grey99
+honeydew
+honeydew1
+honeydew2
+honeydew3
+honeydew4
+hot pink
 indian red
+ivory
+ivory1
+ivory2
+ivory3
+ivory4
 khaki
+khaki1
+khaki2
+khaki3
+khaki4
+lavender
+lavender blush
+lawn green
+lemon chiffon
 light blue
+light coral
+light cyan
+light goldenrod
+light goldenrod yellow
 light gray
 light grey
+light pink
+light salmon
+light sea green
+light sky blue
+light slate blue
+light slate gray
+light slate grey
 light steel blue
+light yellow
 lime green
+linen
 magenta
+magenta1
+magenta2
+magenta3
+magenta4
 maroon
+maroon1
+maroon2
+maroon3
+maroon4
 medium aquamarine
 medium blue
-medium forest green
-medium goldenrod
 medium orchid
+medium purple
 medium sea green
 medium slate blue
 medium spring green
 medium turquoise
 medium violet red
 midnight blue
+mint cream
+misty rose
+moccasin
+navajo white
 navy
 navy blue
+old lace
+olive drab
 orange
 orange red
+orange1
+orange2
+orange3
+orange4
 orchid
+orchid1
+orchid2
+orchid3
+orchid4
+pale goldenrod
 pale green
+pale turquoise
+pale violet red
+papaya whip
+peach puff
+peru
 pink
+pink1
+pink2
+pink3
+pink4
 plum
+plum1
+plum2
+plum3
+plum4
+powder blue
+purple
+purple1
+purple2
+purple3
+purple4
 red
+red1
+red2
+red3
+red4
+rosy brown
+royal blue
+saddle brown
 salmon
+salmon1
+salmon2
+salmon3
+salmon4
 sandy brown
 sea green
+seashell
+seashell1
+seashell2
+seashell3
+seashell4
 sienna
+sienna1
+sienna2
+sienna3
+sienna4
 sky blue
 slate blue
+slate gray
+slate grey
+snow
+snow1
+snow2
+snow3
+snow4
 spring green
 steel blue
 tan
+tan1
+tan2
+tan3
+tan4
 thistle
+thistle1
+thistle2
+thistle3
+thistle4
+tomato
+tomato1
+tomato2
+tomato3
+tomato4
 turquoise
+turquoise1
+turquoise2
+turquoise3
+turquoise4
 violet
 violet red
 wheat
+wheat1
+wheat2
+wheat3
+wheat4
 white
+white smoke
 yellow
 yellow green
+yellow1
+yellow2
+yellow3
+yellow4

-- 
| S I E M E N S |   [email-masked]   |      Siemens Nixdorf
| ------------- |   Voice: +49-89-636-46021     |  Informationssysteme AG
| N I X D O R F |   FAX:   +49-89-636-44994     |   81730 Munich, Germany
~~~~~~~~~~~~~~~~My opinions only, of course; pgp key available on request
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].