Subject: FVWM: FvwmTalk emulation with FvwmForm

From: Dave Goldberg <[email-masked]>
Date: Wed, 03 Apr 1996 10:30:14 -0500

I seem to recall a mention that FvwmTalk was being rewritten to
provide a better interface/functionality, but in the meantime, I've
been playing with the following FvwmForms that do the job pretty
nicely.  Maybe others could use this as well.  MyTalk is a one shot
deal, intended to be called from a menu, while MyFvwmTalk is designed
to hang around.  Pity there's no way to do inheritance for things like
this, though I could probably do something with m4.

Dave Goldberg
Post: The Mitre Corporation\MS B305\202 Burlington Rd.\Bedford, MA 01730
Phone: 617-271-3887
Email: [email-masked]
# MyTalk Form
*MyTalkWarpPointer
*MyTalkFont *helvetica*m*r*n*14*
*MyTalkButtonFont *helvetica*m*o*n*14*
*MyTalkInputFont *cour*m*r*n*14*
*MyTalkFore Red
*MyTalkBack Gray
*MyTalkItemFore Blue
*MyTalkItemBack Gray
*MyTalkLine center
*MyTalkText "Fvwm Function"
*MyTalkInput Func 40 ""
*MyTalkLine expand
*MyTalkButton quit "Run" ^M
*MyTalkCommand $(Func)
*MyTalkButton restart "Clear" ^R
*MyTalkButton quit "Cancel" ^C
*MyTalkCommand Nop

# MyFvwmTalk Form
*MyFvwmTalkWarpPointer
*MyFvwmTalkFont *helvetica*m*r*n*14*
*MyFvwmTalkButtonFont *helvetica*m*o*n*14*
*MyFvwmTalkInputFont *cour*m*r*n*14*
*MyFvwmTalkFore Red
*MyFvwmTalkBack Gray
*MyFvwmTalkItemFore Blue
*MyFvwmTalkItemBack Gray
*MyFvwmTalkLine center
*MyFvwmTalkText "Fvwm Function"
*MyFvwmTalkInput Func 40 ""
*MyFvwmTalkLine expand
*MyFvwmTalkButton restart "Run" ^M
*MyFvwmTalkCommand $(Func)
*MyFvwmTalkButton restart "Clear" ^R
*MyFvwmTalkCommand Nop
*MyFvwmTalkButton restart "Iconify" ^Z
*MyFvwmTalkCommand Next [MyFvwmTalk] Iconify
*MyFvwmTalkButton quit "Quit" ^C
*MyFvwmTalkCommand Nop

---

From: <[email-masked]> (Charles Hines)
Date: Wed, 3 Apr 1996 10:54:20 -0500

>>>>> "Dave" == Dave Goldberg <[email-masked]> writes:

Dave> I seem to recall a mention that FvwmTalk was being rewritten to
Dave> provide a better interface/functionality,

I had originally intended to enhance FvwmTalk's capabilities, but then
Toshi Isogai mailed me a new module called FvwmConsole which is
implemented differently, but basically takes care of many of the
improvements that I wanted to make.

I intend on having it be in the next beta release, which will appear
as soon as I clean up a few more things.  Work and various other
things have obliterated my free time lately, so it's taking longer
than originally intended...

Dave> but in the meantime, I've been playing with the following
Dave> FvwmForms that do the job pretty nicely.  Maybe others could use
Dave> this as well.  MyTalk is a one shot deal, intended to be called
Dave> from a menu, while MyFvwmTalk is designed to hang around.

Hey, cool idea!  I'll include these in the updated sample rc file, if
you don't mind.

Dave> Pity there's no way to do inheritance for things like this,
Dave> though I could probably do something with m4.

Quite possibly.

Chuck

*******************************************************************************
Charles K. Hines <[email-masked]>
IBM Logic Synthesis developer [BooleDozer (TM)]
Martial Arts Instructor [Modern Arnis, Presas Style Filipino Martial Arts]

IBM Internal email:                        "Go back to sleep, Chuck.  You're
  [email-masked],              just havin' a nightmare--of course,
  HINESC at FISHKILL, HINESC at FSHVMFK1    we are still in Hell." Gary Larson
*******************************************************************************
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].