Subject: FVWM: sample.fvwmrc Imakefile logic error Bug and Fix

From: Keith Carter <[email-masked]>
Date: Wed, 24 Apr 1996 20:26:28 -0400

A logic error in the sample.fvwmrc Imakefile causes the sample makefile
to be included even if you say "NO" to the option  i.e.

#define InstallSample NO 

sample.fvwmrc/Imakefile was

#ifdef InstallSample
InstallNonExecFile(system.fvwmrc,$(FVWMDIR))
#endif

which if InstallSample was  YES or NO would install the sample

and should be:

#if InstallSample == YES
InstallNonExecFile(system.fvwmrc,$(FVWMDIR))
#endif

-- 
Keith Carter
Email : [email-masked]
Work  : 212-902-9180
Beeper: 917-506-8942

"An open mind sees more than open eyes", [kbc] Feb  6, 1996
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: <[email-masked]> (Charles Hines)
Date: Thu, 25 Apr 1996 10:25:03 -0400

>>>>> "Keith" == Keith Carter <[email-masked]> writes:

Keith> A logic error in the sample.fvwmrc Imakefile causes the sample makefile
Keith> to be included even if you say "NO" to the option  i.e.

Keith> #define InstallSample NO

Keith> sample.fvwmrc/Imakefile was

Keith> #ifdef InstallSample
Keith> InstallNonExecFile(system.fvwmrc,$(FVWMDIR))
Keith> #endif

Keith> which if InstallSample was  YES or NO would install the sample

Keith> and should be:

Keith> #if InstallSample == YES
Keith> InstallNonExecFile(system.fvwmrc,$(FVWMDIR))
Keith> #endif

Thanks, fixed for next release.

Chuck