Subject: Re: FVWM: style: Start Maximized ?? Start AnyFunction?????

From: Sergios <[email-masked]>
Date: Tue, 30 Apr 1996 19:58:09 +0300

>my 2.0.41 man page says:
>	StartIconic/StartNormal
>
>I'd like StartMaximized (but with the arguments, since I always want my
>buttonbar with console and pager visible.)
>

StartMaximized would be excellent. Netscape ie. has this bad habit of
ignoring shamelesly the geometry specification and always start bigger
horizontaly than my desk. If I move netscapes window and press the maximize
button it resizes itself nicely. of course netscape sucks. but the function
would be nice....
------------------------------------------------------------------------
Life is a fatal disease, the end result is always death.

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tim Smithers <[email-masked]>
Date: Wed, 01 May 1996 09:42:33 +1000

>>>>> "ch" == chuck hines <[email-masked]> writes:

    ch> Well, my suggestion is a little bit more to type, but it
    ch> eliminates confusion.  If you see:

Agreed.  I would vote for more explicit syntax.

I don't actually use the beta version, I use one of the
old 1.23 releases. 

But the actual writing of the fvwmrc is not a big deal.
The use of any syntax which is more explicit, if a little
more verbose is to be commended. 

Having to try and figure out how fvwm might parse a command
or having to come back 6 months later to change a configuration
and having no idea what the hell it was doing really outweigh the
extra time taken to code the command in the first place.

I would also vote for the more explicit syntax. It is crystal clear
if not as concise as the other version.

	-mouse

-- 
Tim Smithers.
DMouse Pty. Ltd.
ph: 019 910 195
e-mail: [email-masked]

( Perfection is a hobby many pursue,
         but few have a chance of success )
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].