Subject: Re: FVWM: Compiling 2.0.42

From: [email-masked] (David Kennedy)
Date: Tue, 30 Apr 1996 17:11:02 +0100

Kai said:
>  >>>>> On Tue, 30 Apr 1996 14:30:38 +0100,
>  >>>>> [email-masked] (David Kennedy) said:
>  
>    David> The error seems to be in the fvwmlib.h file, did I miss a
>    David> patch or simple fix while I was away for a week?
>  
>  There is the problem of 2.0.42 linking the global libfvwm before the
>  local (in ".").  You might want to switch the two -L arguments in the
>  Makefile or remove (rename?) the global libfvwm.

Well, I have deleted my old libfvwm, but it makes no difference.
As for swapping the -L arguements, could you be a little more precise?

(I'm haven't a lot of free time to 'experiment' with it today, might as well
get a  definitive answer before recompiling!)

I had a glance at the makefile but wasn't sure:
	(a) What makefile are we talking about? The top level one, the one in /libs,
		all of them??
	(b) What line should I be changing, and what should I change it to?
		I had a quick look but it wasn't clear

Sorry if these are SQs! I'm not sure how the linkage affects this, it looks like
it just doesn't find some libraries, it doesn't get as far as linking (I think!).

The error is shown below again: (Solaris 2.5)
-----

making all in ./libs...
gcc -g -Wall  -c  CopyString.c
In file included from CopyString.c:4:
fvwmlib.h:3: X11/Xlib.h: No such file or directory
fvwmlib.h:4: X11/Xutil.h: No such file or directory
*** Error code 1
make: Fatal error: Command failed for target `CopyString.o'
Current working directory /scratch7/dcjk/fvwm-stuff/fvwm-new-mailtool/fvwm-2.0.42/libs
*** Error code 1
make: Fatal error: Command failed for target `all'
-- 
David Kennedy, Dept. of Pure & Applied Physics, Queen's University of Belfast
-----------------------------------------------------------------------------
Email: [email-masked] | URL: http://star.pst.qub.ac.uk/~dcjk/

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: <[email-masked]> (Charles Hines)
Date: Tue, 30 Apr 1996 14:28:54 -0400

>>>>> "David" == David Kennedy <[email-masked]> writes:

David> making all in ./libs...
David> gcc -g -Wall  -c  CopyString.c
David> In file included from CopyString.c:4:
David> fvwmlib.h:3: X11/Xlib.h: No such file or directory
David> fvwmlib.h:4: X11/Xutil.h: No such file or directory

>> Makefile or remove (rename?) the global libfvwm.

David> Well, I have deleted my old libfvwm, but it makes no
David> difference.  As for swapping the -L arguements, could you be a
David> little more precise?

This problem has nothing to do with linking.  gcc isn't finding
include files properly.  The X11 headers are usually found in
/usr/include/X11, and most compilers have this as a default search
location, I believe.  But you might want to find out exactly where
your X11 headers are and add an explicit '-I/usr/include' or wherever
the X11 header directory is to your cflags.  You can do this without
rerunning Imake:

  make CDEBUGFLAGS='-g -Wall -I/usr/include'

Chuck