Subject: Re: FVWM: Icons disappearing

From: [email-masked] (Chris Bagwell)
Date: Thu, 25 Apr 96 11:38:19 CDT

> > > > I've had a similar problem in the past where anytime I start or restart fvw
> > > m
> > > > some of my icons would go to 0,0 before they pop into the proper position.
> > > > If there's a window at 0,0 covering them, they don't move into place until
> > > > they're exposed.
> > > >
> > > > Perhaps that's where your icons went?
> > > >
> > >
> > > Yup, that is it!  It seems to be related to the problem the other person had
> > > with thier icon box not working.  It seems that fvwm2 always put icons at 0,0
> > > until something happens.  I have an app that I start iconified at a specific
> > > location.  It starts at 0,0 until I expose it.
> > 
> > I guess that  explains what I  observed.  I start "cm" (Sun's calendar
> > manager) iconified.   During a restart it gets  stuck  at 0,0 unless I
> > click on   it.   Putting an    icon-title on  the icon    "fixes"  it.
> > Ie. something has to happen to an iconified  window in order for it to
> > take its correct position  during  start or restart, including  things
> > like putting a title on the icon.
 
> When I first switched to fvwm2, the first app that I ran into this problem
> with was also "cm".  Coincidence, huh?
> 

Actually, the problem is there with all Openwin programs that specify the location
of the icon.  I click on the icon and it pops to its correct location.  This
is in v2.0.41c.  I saw some mention in 42 about it accepting Openwin hints
like it does mwm.  I wonder if this option would fix the problem?

Chris

----------
 Chris Bagwell				|     Alcatel Network Systems
 [email-masked]		|        Richardson, Texas
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Thu, 25 Apr 1996 12:58:14 -0400

"Chris Bagwell" <[email-masked]> writes:

> Actually, the problem is there  with all Openwin programs that specify
> the location of the icon.    I click on the icon   and it pops to  its
> correct  location.   This is in  v2.0.41c.  I  saw some  mention in 42
> about it accepting Openwin hints  like it does mwm.   I wonder if this
> option would fix the problem?
> 

Just tried with 'Style "*" OLDecor' and fvwm 2.0.42.

That does not fix the problem.

--
Dan Espen                                    Phone: (908) 699-5570
[email-masked]
444 Hoes Lane  Room RRC 1C-214
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].