Subject: FVWM: building fvwm-2.0.42 under Sunos 4.1

From: Jens-U H Petersen <[email-masked]>
Date: Fri, 19 Apr 96 18:25:44 JST

I am trying to build version 2.0.42 Sunos 4.1.3 and X11R5 (I had
the same trouble under SunOs 4.1.4 and X11R6).  (I already have a
working fvwm-2.0.41, which I built here without trouble.)

After

	 xmkmf ; make Makefiles

which don't give any problems apparently, I do "make" and get the
output below.

I don't know to do now.  Can someone please tell what I need to
do to build this latest version on my sunos?  (I really want to
try the latest stuff!)

Thank you,

Jens

---- Start of included text -----------------------8<--- cut here -------------
making all in ./libs...
gcc -g -Wall  -target sun4 -c  CatString3.c
gcc -g -Wall  -target sun4 -c  CopyString.c
gcc -g -Wall  -target sun4 -c  GetFdWidth.c
gcc -g -Wall  -target sun4 -c  GetFont.c
GetFont.c: In function `GetFontOrFixed':
GetFont.c:21: warning: implicit declaration of function `fprintf'
gcc -g -Wall  -target sun4 -c  GetLine.c
GetLine.c: In function `GetConfigLine':
GetLine.c:55: warning: control reaches end of non-void function
gcc -g -Wall  -target sun4 -c  Picture.c
Picture.c: In function `LoadPicture':
Picture.c:53: warning: unused variable `i'
gcc -g -Wall  -target sun4 -c  ReadPacket.c
ReadPacket.c: In function `ReadFvwmPacket':
ReadPacket.c:29: warning: implicit declaration of function `read'
gcc -g -Wall  -target sun4 -c  SendInfo.c
SendInfo.c: In function `SendInfo':
SendInfo.c:16: warning: implicit declaration of function `write'
gcc -g -Wall  -target sun4 -c  SendText.c
SendText.c: In function `SendText':
SendText.c:14: warning: implicit declaration of function `write'
gcc -g -Wall  -target sun4 -c  SetMask.c
gcc -g -Wall  -target sun4 -c  envvar.c
gcc -g -Wall  -target sun4 -c  findIconFile.c
gcc -g -Wall  -target sun4 -c  hostname.c
hostname.c: In function `mygethostname':
hostname.c:13: warning: implicit declaration of function `strncpy'
hostname.c:14: warning: control reaches end of non-void function
gcc -g -Wall  -target sun4 -c  mygetostype.c
gcc -g -Wall  -target sun4 -c  mystrcasecmp.c
gcc -g -Wall  -target sun4 -c  safemalloc.c
safemalloc.c: In function `safemalloc':
safemalloc.c:21: warning: implicit declaration of function `fprintf'
gcc -g -Wall  -target sun4 -c  sleep.c
sleep.c: In function `sleep_a_little':
sleep.c:21: warning: implicit declaration of function `select'
gcc -g -Wall  -target sun4 -c  strncmp.c
gcc -g -Wall  -target sun4 -c  wild.c
rm -f libfvwm2.a
ar clq libfvwm2.a  CatString3.o  CopyString.o  GetFdWidth.o  GetFont.o  GetLine.o  Picture.o  ReadPacket.o  SendInfo.o  SendText.o  SetMask.o  envvar.o  findIconFile.o  hostname.o  mygetostype.o  mystrcasecmp.o  safemalloc.o  sleep.o  strncmp.o  wild.o
ranlib libfvwm2.a
making all in ./fvwm...
gcc -g -Wall  -target sun4 -c  add_window.c
add_window.c: In function `AddWindow':
add_window.c:186: warning: implicit declaration of function `GetOlHints'
gcc -g -Wall  -target sun4 -c  bindings.c
bindings.c: In function `ParseMouseEntry':
bindings.c:86: warning: implicit declaration of function `sscanf'
bindings.c: In function `find_context':
bindings.c:260: warning: implicit declaration of function `tolower'
gcc -g -Wall  -target sun4 -c  borders.c
rm -f builtins.o
gcc -c -g -Wall  -DFVWM_ICONDIR=\"/home/petersen/lib/X11/pixmaps\:/usr/local/X11R6/include/X11/bitmaps\:/usr/local/X11R6/include/X11/pixmaps\"  -DFVWMDIR=\"/home/petersen/lib/X11/fvwm-2.0.42\"  -DFVWMRC=\".fvwm2rc\" builtins.c
builtins.c: In function `exec_function':
builtins.c:666: warning: implicit declaration of function `strerror'
builtins.c: In function `ButtonStyle':
builtins.c:1451: warning: implicit declaration of function `sscanf'
builtins.c: In function `Circulate':
builtins.c:1661: warning: `return' with no value, in function returning non-void
builtins.c:1679: warning: `return' with no value, in function returning non-void
builtins.c: In function `module_zapper':
builtins.c:1813: warning: implicit declaration of function `KillModuleByName'
gcc -g -Wall  -target sun4 -c  colormaps.c
gcc -g -Wall  -target sun4 -c  colors.c
gcc -g -Wall  -target sun4 -c  complex.c
complex.c: In function `ComplexFunction':
complex.c:148: warning: implicit declaration of function `tolower'
complex.c: In function `expand':
complex.c:298: warning: unsigned int format, Window arg (arg 3)
gcc -g -Wall  -target sun4 -c  decorations.c
gcc -g -Wall  -target sun4 -c  events.c
events.c: In function `My_XNextEvent':
events.c:1379: warning: implicit declaration of function `bzero'
events.c:1422: warning: implicit declaration of function `select'
gcc -g -Wall  -target sun4 -c  focus.c
gcc -g -Wall  -target sun4 -c  functions.c
rm -f fvwm.o
gcc -c -g -Wall  -DFVWM_ICONDIR=\"/home/petersen/lib/X11/pixmaps\:/usr/local/X11R6/include/X11/bitmaps\:/usr/local/X11R6/include/X11/pixmaps\"  -DFVWMDIR=\"/home/petersen/lib/X11/fvwm-2.0.42\"  -DFVWMRC=\".fvwm2rc\" fvwm.c
fvwm.c: In function `main':
fvwm.c:265: warning: implicit declaration of function `putenv'
fvwm.c: In function `CatchFatal':
fvwm.c:1081: warning: control reaches end of non-void function
fvwm.c: In function `usage':
fvwm.c:1117: warning: implicit declaration of function `fprintf'
fvwm.c: At top level:
fvwm.c:94: warning: `s_g_bits' defined but not used
gcc -g -Wall  -target sun4 -c  icons.c
gcc -g -Wall  -target sun4 -c  menus.c
menus.c: In function `menuShortcuts':
menus.c:547: warning: implicit declaration of function `tolower'
menus.c: In function `PopUpMenu':
menus.c:738: warning: implicit declaration of function `ButtonPosition'
gcc -g -Wall  -target sun4 -c  misc.c
misc.c: In function `GetTwoArguments':
misc.c:429: warning: implicit declaration of function `sscanf'
misc.c: In function `GetOneArgument':
misc.c:463: warning: int format, long int arg (arg 3)
misc.c:463: warning: too few arguments for format
misc.c: In function `fvwm_msg':
misc.c:888: warning: implicit declaration of function `fprintf'
misc.c:889: warning: implicit declaration of function `vfprintf'
misc.c:863: warning: unused variable `error'
gcc -g -Wall  -target sun4 -c  module.c
module.c: In function `executeModule':
module.c:247: warning: implicit declaration of function `perror'
gcc -g -Wall  -target sun4 -c  move.c
gcc -g -Wall  -target sun4 -c  placement.c
rm -f read.o
gcc -c -g -Wall  -DFVWM_ICONDIR=\"/home/petersen/lib/X11/pixmaps\:/usr/local/X11R6/include/X11/bitmaps\:/usr/local/X11R6/include/X11/pixmaps\"  -DFVWMDIR=\"/home/petersen/lib/X11/fvwm-2.0.42\"  -DFVWMRC=\".fvwm2rc\" read.c
read.c: In function `ReadFile':
read.c:125: warning: implicit declaration of function `fclose'
gcc -g -Wall  -target sun4 -c  resize.c
gcc -g -Wall  -target sun4 -c  style.c
style.c: In function `ProcessNewStyle':
style.c:70: warning: implicit declaration of function `tolower'
style.c:105: warning: implicit declaration of function `sscanf'
gcc -g -Wall  -target sun4 -c  virtual.c
gcc -g -Wall  -target sun4 -c  windows.c
windows.c: In function `do_windowList':
windows.c:130: warning: long int format, pointer arg (arg 3)
rm -f fvwm2
gcc -o fvwm2 add_window.o  bindings.o  borders.o  builtins.o  colormaps.o  colors.o  complex.o  decorations.o  events.o  focus.o  functions.o  fvwm.o  icons.o  menus.o  misc.o  module.o  move.o  placement.o  read.o  resize.o  style.o  virtual.o  windows.o -O -pipe  -L/usr/local/X11R5/lib -L../libs -lfvwm2 -L/home/petersen/lib -lXpm  -lXext -lX11   
collect2: ld returned 2 exit status
ld: Undefined symbol 
   _strerror 
*** Error code 1
make: Fatal error: Command failed for target `fvwm2'
Current working directory /tmp_mnt/home/petersen/src/fvwm-2.0.42/fvwm
*** Error code 1
make: Fatal error: Command failed for target `all'
---- End of included text -------------------------8<--- and here -------------
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: <[email-masked]> (Charles Hines)
Date: Fri, 19 Apr 1996 09:11:34 -0400

>>>>> "Jens" == Jens-U H Petersen <[email-masked]> writes:

Jens> I am trying to build version 2.0.42 Sunos 4.1.3 and X11R5 (I had
Jens> the same trouble under SunOs 4.1.4 and X11R6).  (I already have a
Jens> working fvwm-2.0.41, which I built here without trouble.)

Jens> After

Jens>    xmkmf ; make Makefiles

Jens> which don't give any problems apparently, I do "make" and get the
Jens> output below.

Jens> I don't know to do now.  Can someone please tell what I need to
Jens> do to build this latest version on my sunos?  (I really want to
Jens> try the latest stuff!)

Jens> gcc -o fvwm2 add_window.o  bindings.o  borders.o  builtins.o  colormaps.o  colors.o  complex.o  decorations.o  events.o  focus.o  functions.o  fvwm.o  icons.o  menus.o  misc.o  module.o  move.o  placement.o  read.o  resize.o  style.o  virtual.o  windows.o -O -pipe  -L/usr/local/X11R5/lib -L../libs -lfvwm2 -L/home/petersen/lib -lXpm  -lXext -lX11
Jens> collect2: ld returned 2 exit status
Jens> ld: Undefined symbol
Jens>    _strerror

Ok, for anyone having problems w/ strerror being undefined (SunOS
4.1.X users), here is a definition which should do it for you (just
put it in builtins.c).  I'll put this on the official web site as
well, and a variant will appear in the next beta release.

Chuck

======================================================================
char *strerror(int num)
{
  extern int sys_nerr;
  extern char *sys_errlist[];

  if (num >= 0 && num < sys_nerr)
    return(sys_errlist[errnum]);
  else
    return "Unknown error number";
}

---

From: Stefano Brozzi <[email-masked]>
Date: Fri, 19 Apr 1996 15:39:20 +0200

> well, and a variant will appear in the next beta release.
  
   well,
  quite obvious error in this def:

char *strerror(int num)
 {
   extern int sys_nerr;
 
   if (num >= 0 && num < sys_nerr)
     return(sys_errlist[num]);       /* num instead of errnum */
   else
     return "Unknown error number";
 }

  Stefano