Subject: Re: "Re: FVWM: focus and pointer"

From: Wes Hodges <[email-masked]>
Date: Thu, 18 Apr 1996 14:29:16 -0400

eli (e.) burke wrote:
> 
> >    Sergios> I just installed fvwm 2.0.41. is it possible to bring a
> >    Sergios> window to top (focus) without the mouse cursor moving to
> >    Sergios> the top left corner of the window?

>         It is nice that you keep bringing this up each time somebody
> asks about Focus, but what this poster would really like (and me too! :)
> is for Focus not to mess with the mouse at all, or at least have that
> be an option in some way.
> 
> -Eli
> 

Key Tab         A       MS       Prev [CurrentDesk CurrentScreen] Focus
Key Tab         A       M      Next [CurrentDesk CurrentScreen] Focus
Key Tab         A       CS       Prev [*] Focus
Key Tab         A       C      Next [*] Focus

The top two circulate windows on the current screen, while the bottom two
circulate between all windows.

You can use the circulateskip style option on any windows that you, do not
want to have focus on. (ie. FvwmButtons etc...)

I use this to change the FOCUS without touching the mouse.
You would have to make sure not to use the focus follows mouse,
for this to work properly.

--
Wes Hodges - [email-masked]
Picture Network International 
703-807-2731
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: <[email-masked]> (Charles Hines)
Date: Thu, 18 Apr 1996 15:35:23 -0400

>>>>> "Wes" == Wes Hodges <[email-masked]> writes:

>> be an option in some way.

Wes> Key Tab         A       MS       Prev [CurrentDesk CurrentScreen] Focus
Wes> Key Tab         A       M      Next [CurrentDesk CurrentScreen] Focus
Wes> Key Tab         A       CS       Prev [*] Focus
Wes> Key Tab         A       C      Next [*] Focus

Wes> The top two circulate windows on the current screen, while the bottom two
Wes> circulate between all windows.

Wes> You can use the circulateskip style option on any windows that you, do not
Wes> want to have focus on. (ie. FvwmButtons etc...)

Wes> I use this to change the FOCUS without touching the mouse.
Wes> You would have to make sure not to use the focus follows mouse,
Wes> for this to work properly.

This looks like a good spot for me to make a small comment regarding
all of the Focus related questions lately...

Those bindings above WILL work with ANY focus style.  When Focus-ing
on MouseFocus and SloppyFocus windows, the cursor will be warped to
those windows (the subject of many other notes...) but the cursor
won't warp to ClickToFocus windows.

Now, the Focus behavour could stand with some modifications, as people
have pointed out.  I will be considering the suggested patches for the
next beta release.

Chuck