Subject: FVWM: The F in "fvwm" (joke)

From: Paolo "Bussola" Marchiori <[email-masked]>
Date: Thu, 18 Apr 1996 10:01:16 METDST

a-hem...

|21|[9:58]tic[~]>ls -l fvwm-2.0.42.tar 
-rw-r--r--   1 pm524301 student  2682880 Apr 15 21:35 fvwm-2.0.42.tar
                                 ^^^^^^^
As we say in Italy: "STAMINKIA!"

FVWM=Fat Virtual Window Manager?

'bye everybody.
--
______________________________________________________________________
        N       message by Paolo Marchiori aka Bussola
        ^       Computer Science dept - Milano University
        |       http://www.dsi.unimi.it/Users/Students/000008
   W <--O--> E  e-mail: [email-masked]
        |       PGP available via finger
        V       Join me on the first italian MOO: LITTLE ITALY
        S       -=> telnet little.usr.dsi.unimi.it:4444 <=-
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Ian MacKinnon)
Date: Thu, 18 Apr 1996 09:06:11 +0100

> FVWM=Fat Virtual Window Manager?

Eh ?

ll fvwm-2.0.42.tar.gz 
-rw-rw-r--   1 imac     dhs3      576551 Apr 16 07:49 fvwm-2.0.42.tar.gz

FVWM != Fat Virtual Window Manager

                       \|/
                      (o o)
+==================oOO-(_)-OOo==========================+
|If you don't care where you are, you can't be lost     |
|                                                       |
|_______________________________________________________|
| Ian MacKinnon             [email-masked]|
| (44) 171 293 1413                                     |
|_______________________________________________________|
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Martin Kraemer <[email-masked]>
Date: Thu, 18 Apr 1996 10:19:58 +0200 (MET DST)

Ian MacKinnon wrote,...
> FVWM != Fat Virtual Window Manager

 F   UID   PID  PPID CP PRI NI   SZ  RSS    WCHAN S TT        TIME COMMAND
10 20001   650   631  0  73 20  569  478 d0203010 S ?         0:07 /usr/bin/X11/mwm 
				^^^
10  2800  1524  1481  0  73 20  275  197 d01de95c S ?         0:09 /home/martin/fvwm-2/fvwm2 -f /home/martin/fvwm-2/FvwmM4 -m4-squote { -m4-equote
				^^^
ha! half of what mwm eats.

    Martin
-- 
| S I E M E N S |   [email-masked]   |      Siemens Nixdorf
| ------------- |   Voice: +49-89-636-46021     |  Informationssysteme AG
| N I X D O R F |   FAX:   +49-89-636-44994     |   81730 Munich, Germany
~~~~~~~~~~~~~~~~My opinions only, of course; pgp key available on request
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Rob Windsor <[email-masked]>
Date: Thu, 18 Apr 1996 01:17:24 -0700

> FVWM != Fat Virtual Window Manager

Well....

punk$ ll f*
-rw-r--r--  1 windsor  src    576551 Apr 15 13:35 fvwm-2.0.42.tar.gz
-rw-r--r--  1 windsor  users   23447 Nov 24 18:31 fwtk.patch
punk$ cp fvwm-2.0.42.tar.gz /tmp/windsor
punk$ cd /tmp/windsor
punk$ ll
total 581
-rw-r--r--  1 windsor  wheel  576551 Apr 18 01:10 fvwm-2.0.42.tar.gz
punk$ gunzip fvwm-2.0.42.tar.gz 
punk$ ll
total 2637
-rw-r--r--  1 windsor  wheel  2682880 Apr 18 01:10 fvwm-2.0.42.tar

But, that's not the 'size that counts'.  Anything that is near as portable
as fvwm will have it's share of #ifdef'd code that isn't usable for
a particular arch/os.

This is what is important:

punk$ cd /usr/local/install
punk$ ll fvwm-2.0.{39,40,41}/bin/fvwm
-rwxr-xr-x  1 windsor  src  126976 Dec 10 02:46 fvwm-2.0.39/bin/fvwm
-rwxr-xr-x  1 windsor  src  135168 Feb 27 06:02 fvwm-2.0.40/bin/fvwm
-rwxr-xr-x  1 windsor  src  135168 Feb 27 06:07 fvwm-2.0.41/bin/fvwm
punk$ file fvwm-2.0.{39,40,41}/bin/fvwm
fvwm-2.0.39/bin/fvwm: NetBSD/i386 demand paged dynamically linked executable
fvwm-2.0.40/bin/fvwm: NetBSD/i386 demand paged dynamically linked executable
fvwm-2.0.41/bin/fvwm: NetBSD/i386 demand paged dynamically linked executable
punk$ ll `which twm`
-rwxr-xr-x  1 root  bin  155648 Jan  6 23:34 /usr/X11R6/bin/twm
punk$ file `which twm`
/usr/X11R6/bin/twm: NetBSD/i386 demand paged dynamically linked executable

So..

Ain't nuttin' wrong here.  It's still smaller than twm, which I fully
appreciate.

-- Rob
----------------------------------------
Internet: [email-masked]      Life: [email-masked]
"Da Web": http://pobox.com/~windsor/

"Ain't much distance 'tween a pat on the back and a kick in the pants."
    -- David Lee Roth (1990), `The Dogtown Shuffle'
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Paolo "Bussola" Marchiori <[email-masked]>
Date: Thu, 18 Apr 1996 10:22:03 METDST

|  > -rw-r--r--   1 pm524301 student  2682880 Apr 15 21:35 fvwm-2.0.42.tar
| -rw-rw-r--   1 imac     dhs3      576551 Apr 16 07:49 fvwm-2.0.42.tar.gz

Your ll is about the gzipped file, mine is about the tarred-nongzipped...

Of course FVWM is great, but it became very very fat from 1.XX to 2.XX !

---

From: [email-masked] (Ian MacKinnon)
Date: Thu, 18 Apr 1996 09:24:42 +0100

> Your ll is about the gzipped file, mine is about the tarred-nongzipped...
 Yes OK as soon as I had hit send I realised the suffiz was .z Oops
Anywat fvwm is great

                       \|/
                      (o o)