Subject: FVWM: deiconification of windows without an icon

From: Austin Donnelly <[email-masked]>
Date: Fri, 19 Apr 96 16:18 BST

In fvwm-2.0.42, if you deiconify a window without an icon associated
with it, it appeared behind all other windows, but is entered in
fvwm's idea of things as the top-most window.

This can be demostrated by 'raise-or-lower'ing it.

To see this:

1) Iconify a window that doesn't have an icon specified.
     -> iconised window is now just a small recangle of text
2) deiconify it.
     -> window comes back, but displayed at the bottom stacking order
        on screen
3) raise-or-lower the window.
     -> nothing happens, since fvwm thinks the window is at the top,
        so it sends it to the bottom (it's already at the bottom).
4) raise-or-lower the window again.
     -> now comes to the front for the first time.

Austin
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Alexander Sorg <[email-masked]>
Date: Fri, 19 Apr 1996 11:37:00 -0400

> fvwm's idea of things as the top-most window.

yes! that's it. i also got this behaviour from time to time but
thought that i had misconfigured something. now that you mention it
i realize that it always happens with my (iconless) emacs windows.
i use to have a lot of them around and icons would use too much room.

i would really like to see that fixed.

-- 
       alex