Subject: FVWM: X11R5 NO GOOD??

From: [email-masked]
Date: Sat, 6 Apr 1996 19:14:07 +0200

Hello out there!

	I am trying to install the latest version of FVWM (version
2.xx) at our institute here in Oslo. I am having great problems with
the color Icons - I can't "HasXpm"!
1.	I have installed XpmLibs as instructed in Fvwm.tmpl.
2.	I can compile the window manager without problems
3.	When I try to run it I get 
4.	7546: /mn/vega/u1/bards/bin/fvwm2: /sbin/loader: Fatal Error: cannot map libXpm.so
5.	No more is hear from fvwm2

	Does this imply that the X11R5/lib file libXpm.so is not usable and
that such a file from X11R6/lib is needed?? If so where can I get
these files? Worse, does this mean that there is something wrong with
my loader?

	Sorry that I cannot be more specific but I am a bit puzzled :|

Cheerio just now, 

			Bard
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jason L Tibbitts III <[email-masked]>
Date: 06 Apr 1996 15:11:57 -0500

>>>>> "B" == bard saadatnejad <[email-masked]> writes:

B> 7546: /mn/vega/u1/bards/bin/fvwm2: /sbin/loader: Fatal Error: cannot map libXpm.so

This is an error from the dynamic loader on your system.  In other words,
it's an OS problem, not an FVWM problem.  Since you don't say what OS
you're using it's kind of difficult to tell you anything more.

You might try making sure that libXpm is in the path searched by the loader
($LD_LIBRARY_PATH on some systems) and that the link cache is up to date if
it's required on your system.

 - J<

---

From: Paul Lange <[email-masked]>
Date: Sat, 06 Apr 1996 22:39:10 -0600

> 4.      7546: /mn/vega/u1/bards/bin/fvwm2: /sbin/loader: Fatal Error: cannot

Yes, the loader is having a problem trying to find libXpm.so.  It may compile
fine, but that is probably because you compiled with the 
option, "-L/path/to/libXpm.so".  This is fine for compiling, but when fvwm
is executed, the loader doesn't know where to look anymore.

As mentioned before, you can fix this by setting the environment variable,
LD_LIBRARY_PATH to the location of the file, -or-, and better yet, you can
send a flag to the loader to create a path record in the executable so it
knows where to look.  On the system I am on (Digital Unix), that flag is
-rpath <path>, on others it may be different.  If you think multiple people
might be using the fvwm that you compile, this would be a better fix, that
way everybody who uses it doesn't have to set their LD_LIBRARY_PATH's.

And a word of warning to everybody on Digital Unix.  It appears that vendor
supplied loader does not allow for a space between -rpath and its argument.
Also, there is no compiler option to send a flag to the loader.  Thus, the
compiler cannot handle the space, and thinks the argument to -rpath an object
file.  As of yet, I haven't found a good workaround, other than to change
Makefiles so that the loader is called separately, or to make until it breaks,
run the load line by hand, and make again.  If anybody knows of a solution to
this, I would be more than happy to know it.
--

Paul Lange              5 Paul vs Data 0              [email-masked]
---------------------------------------------------------------------------
"Blest is the nation whose silent course of happiness furnishes nothing for
 history to say.  This is what I ambition for my own country."
		- Thomas Jefferson to Comte Diodati, 1807
---------------------------------------------------------------------------
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Mon, 15 Apr 1996 19:03:37 +0200

Paul Lange writes:
------->   > 4.      7546: /mn/vega/u1/bards/bin/fvwm2: /sbin/loader: Fatal Error: cannot
------->   >		 map libXpm.so
------->   
------->   Yes, the loader is having a problem trying to find libXpm.so.  It may compile
------->   fine, but that is probably because you compiled with the 
------->   option, "-L/path/to/libXpm.so".  This is fine for compiling, but when fvwm
------->   is executed, the loader doesn't know where to look anymore.
------->   
------->   As mentioned before, you can fix this by setting the environment variable,
------->   LD_LIBRARY_PATH to the location of the file, -or-, and better yet, you can
------->   send a flag to the loader to create a path record in the executable so it
------->   knows where to look.  On the system I am on (Digital Unix), that flag is
------->   -rpath <path>, on others it may be different.  If you think multiple people
------->   might be using the fvwm that you compile, this would be a better fix, that
------->   way everybody who uses it doesn't have to set their LD_LIBRARY_PATH's.
------->   
------->   And a word of warning to everybody on Digital Unix.  It appears that vendor
------->   supplied loader does not allow for a space between -rpath and its argument.
------->   Also, there is no compiler option to send a flag to the loader.  Thus, the
------->   compiler cannot handle the space, and thinks the argument to -rpath an object
------->   file.  As of yet, I haven't found a good workaround, other than to change
------->   Makefiles so that the loader is called separately, or to make until it breaks,
------->   run the load line by hand, and make again.  If anybody knows of a solution to
------->   this, I would be more than happy to know it.
------->   --
------->   
------->   Paul Lange              5 Paul vs Data 0              [email-masked]
------->   ---------------------------------------------------------------------------
------->   "Blest is the nation whose silent course of happiness furnishes nothing for
------->    history to say.  This is what I ambition for my own country."
------->   		- Thomas Jefferson to Comte Diodati, 1807
------->   ---------------------------------------------------------------------------
	Dear Paul!
	Thanks very much for your e-mail and the advice on how to
spoon feed the loader - it worked like a charm. I did, however, use the
pedestrian solution and simply defined the "LD_LIBRARY_PATH"
variable. I would like to make use of the more elegant solution which
you suggest (using the -rpath flag) but, I am not sure where this
should go. Can you help? I am also running fvwm on Digital Unix.

	Cheerio just now,
			
				Bard