Subject: FVWM: Compiling 2.0.42

From: [email-masked] (David Kennedy)
Date: Tue, 30 Apr 1996 14:30:38 +0100

I'm having trouble compiling the new release of fvwm, the error I get is shown
below. I don't think that there is anything wrong with my setup, I have compiled
and used Fvwm for a long time now.
The error seems to be in the fvwmlib.h file, did I miss a patch or simple fix while
I was away for a week?

The libraries and so on *are* all there, why aren't they picked up on by Imake
when they were before? Solaris 2.5, usual setup, nothing strange.

Thanks for any help.
---------

> make
making all in ./libs...
gcc -g -Wall  -c  CatString3.c
gcc -g -Wall  -c  CopyString.c
In file included from CopyString.c:4:
fvwmlib.h:3: X11/Xlib.h: No such file or directory
fvwmlib.h:4: X11/Xutil.h: No such file or directory
*** Error code 1
make: Fatal error: Command failed for target `CopyString.o'
Current working directory /scratch7/dcjk/fvwm-stuff/fvwm-new-mailtool/fvwm-2.0.42/libs
*** Error code 1
make: Fatal error: Command failed for target `all'
-- 
David Kennedy, Dept. of Pure & Applied Physics, Queen's University of Belfast
-----------------------------------------------------------------------------
Email: [email-masked] | URL: http://star.pst.qub.ac.uk/~dcjk/

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Kai Grossjohann <[email-masked]>
Date: 30 Apr 1996 16:27:09 +0200

>>>>> On Tue, 30 Apr 1996 14:30:38 +0100,
>>>>> [email-masked] (David Kennedy) said:

  David> The error seems to be in the fvwmlib.h file, did I miss a
  David> patch or simple fix while I was away for a week?

There is the problem of 2.0.42 linking the global libfvwm before the
local (in ".").  You might want to switch the two -L arguments in the
Makefile or remove (rename?) the global libfvwm.

Does this do it?
kai
-- 
Gleep!