Subject: FVWM: problems installing

From: gbrown@[email-masked] (Geoffrey Brown (CSC))
Date: Thu, 7 Mar 1996 14:27:08 -0500 (EST)

Dear List:

  I'm having a problem running MakeMakefiles...I believe that my problem
is implementation specific, but I am looking for a clue, if anyone could
point me in the right direction...

  My symptoms look like that which follows:

Making Makefile in modules/FvwmIconBox
mv Makefile Makefile.bak
imake -DUseInstalled -I/usr/lib/X11/config
makedepend -D__alpha  -D__osf__ -I -I/usr/include -s "# DO NOT DELETE" --   -I.
-I../../libs    -DDEC -DR5_XLIB -DSMT  -DFUNCPROTO=3 -DSHAPE -DXPM  -- FvwmIconB
ox.c icons.c
makedepend: warning:  icons.c: cannot find include file "X11/xpm.h"
        not in X11/xpm.h
        not in -I/usr/include/X11/xpm.h
        not in ./X11/xpm.h
        not in ../../libs/X11/xpm.h
        not in /usr/include/X1

  I get many more 'warnings' reporting that the xpm.h file is not found
where the Makefile expects.  Is there a way that I can specify the path 
to the xpm.h file?

  Thanks in advance,

  Geoff
  [email-masked]
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: <[email-masked]> (Charles Hines)
Date: Thu, 7 Mar 1996 18:32:18 -0500

>>>>> "GB" == Geoffrey Brown (CSC) <gbrown@[email-masked]> writes:

GB> Dear List:
GB>   I'm having a problem running MakeMakefiles...I believe that my problem
GB> is implementation specific, but I am looking for a clue, if anyone could
GB> point me in the right direction...
....
GB>   I get many more 'warnings' reporting that the xpm.h file is not found
GB> where the Makefile expects.  Is there a way that I can specify the path
GB> to the xpm.h file?

RTFM.  Make sure you have XPM available locally, and there are vars
you can set in the Fvwm.tmpl to point to it.  If you don't know what
Fvwm.tmpl is, grab the latest version (2.0.41) or look for the same
vars in configure.h/makefile.h.

Chuck