Subject: FVWM: Popups on buttons.

From: [email-masked] (David Kennedy)
Date: Wed, 20 Mar 1996 19:20:20 GMT

I am using the latest version of Jarl's buttons and have a quick question,
in my main button bar I wondered if I can popup a menu from a button, so
I put a line like this in my .buttonsrc file:
	(Title Test,     Icon Terminal.xpm,         Action Popup Utilities)

Where Utilities is my main menu in the .fvwmrc file.

I get this error in my console:
	fvwm: No such menu

So, must I:
	(a) define utilities in the .buttonsrc file and duplicate stuff?
	or	
	(b) set my buttons in the main .fvwmrc file? Messy.
	or
	(c) do something obvious after a reply from this list?

-- 
David Kennedy, Dept. of Pure & Applied Physics, Queen's University of Belfast
-----------------------------------------------------------------------------
Email: [email-masked] | URL: http://star.pst.qub.ac.uk/~dcjk/

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jarl Totland <[email-masked]>
Date: Wed, 20 Mar 1996 20:27:29 +0000 (WET)

Hello,

> I am using the latest version of Jarl's buttons and have a quick question,
You mean you got 200396 to work? Hurra! :-)

> 	(Title Test,     Icon Terminal.xpm,         Action Popup Utilities)
Humm, according to the syntax, Action takes only one argument, in this case
it thinks its action should be 'Popup'. You should quote it like 
 Action 'Popup Utilities'.

Hope this helps.

> 	(c) do something obvious after a reply from this list?
:-)

Vyrdsamt,
-Jarl