Subject: FVWM: FvwmButtons - the Bug is dead!

From: [email-masked]
Date: Tue, 12 Mar 1996 12:21:54 +0100 (MET)

Here I am again...

Alan:
> I think I'm going to cry.  :`{
> 
> I can't get it to work.  I applied all of Jarl's patches on my home
> Linux box and it didn't do anything.

Brandon:
> > I think I'm going to cry.  :`{
>
> Me too.

Rich:
> They end with 'Creating windows...', and I don't get the
> 'OK' after it.  Also, an xclock is created, but nothing

While working through the code, failing to find the problem, I got a mail
from Romano Giannetti, basically telling me he found these two references
to the variable xname only:
  XTextProperty xname;
  XFree(xname.value);
What can I say? Patched version will be out in half an hour.

Well, thanks a lot to Romano for tracing down the bugger, I hope this will
be the end to major problems with FvwmButtons for now.. until I make another
typo or absentminded modification. Somebody stop me. :-)

Rich:
>   FvwmButtons-110396b.tar must be installed on top of
> FvwmButtons-110396.tar; it is missing Fvwm.tmpl.  After
> that, compiling went well.
Ehm, Fvwm.tmpl is not a part of FvwmButtons... apart from the sample
config file there are now different files in the two versions... Am I
missing something here?

Vyrdsamt,
-Jarl

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Rich Derr <[email-masked]>
Date: Wed, 13 Mar 1996 01:15:13 -0600 (CST)

> config file there are now different files in the two versions... Am I
   I had first tried 110396 at work, and I got the message
about 110396b while I was at home.  It turns out I was only
on fvwm-2.0.40 at home.  I've upgraded, patched, and am now
running 120396 here at home, and it's fine.  I doubt I'll
have any troule at work, either.

   fvwm-popup.patch so far has my vote for best improvement,
although I haven't begun to play.
--RD
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].