Subject: Re: FVWM: 2.0.41 patch: OpenLook support

From: [email-masked] (David Kennedy)
Date: Mon, 4 Mar 1996 00:08:20 GMT

I have just recompiled fvwm-2.0.41 with the OpenLook support
patch from Andrew Taylor.

Making and installing fvwm is now much easier, especially for a 
non root user, no more mucking around looking for DESTDIR in
Makefiles etc. Much better.

This second observation has more to do with the patch -
Sun's MailTool still doesn't work properly! 
When mail arrives in an empty inbox (as is usual) the
new mail, when clicked on, comes up in an icon, not as
a window. This does not happen the first time.

Mmm, not sure that that sentence is very clear, I know
this is a well known problem but still...here's a 
summary:

Log in
Start mailtool
Mail arrives
Open mailtool, double click on mail
	Read Message pops up. Fine.
	Scrap or save mail.
	Click 'Done'
New Mail arrives
Open mailtool, double clock on mail
	Read Message pane appears as an icon.
	Very irritating.
Mailtool continues to (not) work in this manner.

The appearance of textedit icons and others is much improved but a patch
or module to handle mailtool's behaviour and/or push-pins would be 
superb for the majority of Sun users.

Any help appreciated, failing that I might have to succumb to using another
X mailer, and I haven't found a decent one yet.

-- 
David Kennedy, Dept. of Pure & Applied Physics, Queen's University of Belfast
-----------------------------------------------------------------------------
Email: [email-masked] | URL: http://star.pst.qub.ac.uk/~dcjk/

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Todd Fries)
Date: Sat, 16 Mar 1996 20:26:22 -0600 (CST)

> superb for the majority of Sun users.

What I have found useful is to use an 'X' ed button which works very much like
the push-pins you're accustomed to.

ButtonStyle 3 13 26x29@1 34x21@1 50x35@1 70x21@1 79x29@1 63x48@0 79x65@1 70x75@0 50x61@0 34x75@0 26x65@0 44x48@1 26x29@0
....
AddToFunc "Close"
+ "C" Delete
+ "D" Destroy
....
#     Button	Context Modifi 	Function 
....
Mouse 0         3       A       Function Close

Oh, and while I'm giving 'tips' here is something to pattern
what (IMHO) would be a very useful 'example .fvwmrc' setup
would be like:

(I have a subdir, .fvwm under which .fvwm/funcs resides,
 along with mouse, keyboard, sytle, menus, paths, etc..,
 so that I can chage the file, and re-read it to be
 close to run-time-configurable)

---~/.fvwm/funcs-------

[removal of other functions]

DestroyMenu Styles
AddToMenu "Styles"
+ "Color" PopUp Color
+ "Buttons" PopUp Buttons
+ "Font(Window)" PopUp font_window
+ "Windows" PopUp Windows
+ "95list" Module /etc/X11/bowman/FvwmWinList
+ "recapture" recapture

DestroyMenu Windows
AddToMenu Windows
+ "rxvt - NoTitle" Style "rxvt" NoTitle
+ "     - Title"   Style "rxvt" Title

DestroyMenu font_window
AddToMenu font_window
+ "adobe" WindowFont -adobe-helvetica-bold-r-normal--0-100-75-100-*-90-*-1
+ "lucid" WindowFont -*-lucidatypewriter-medium-r-*-*-12-*-*-*-*-*-*-*
+ "helv"  WindowFont -*-helvetica-medium-r-*-*-12-*-*-*-*-*-*-*
+ "5x7"   WindowFont 5x7
+ "fixed" WindowFont fixed

DestroyMenu Buttons
AddToMenu Buttons
+ "1.?"            ButtonStyle 1 5 25x61@0 75x61@0 25x39@0 75x39@1 25x61@1
+ "2.?"            ButtonStyle 2 5 25x75@0 75x75@0 25x25@0 75x25@1 25x75@1
+ "2.Small up Tri" ButtonStyle 2 4 50x35@1 65x65@0 35x65@0 50x35@1
+ "2.Large up Tri" ButtonStyle 2 4 50x25@1 75x75@0 25x75@0 50x25@1
+ "2.Big Box"      ButtonStyle 2 5 25x25@1 25x75@1 75x75@0 75x25@0 25x25@1
+ "2.Tall box"     ButtonStyle 2 5 40x25@1 60x25@1 60x75@0 40x75@0 40x25@1
+ "2.Up Arrow"     ButtonStyle 2 8 40x80@1 40x50@1 20x50@1 50x20@1 80x50@0 60x50@0 60x80@0 40x80@0
+ "2.twm"          ButtonStyle 2 14 0x0@1 0x20@1 20x20@0 20x0@0 0x0@1 0x25@1 25x25@1 25x0@1 55x0@1 55x55@0 0x55@0 0x60@1 60x60@1 60x0@1
+ "3.X"            ButtonStyle 3 13 26x29@1 34x21@1 50x35@1 70x21@1 79x29@1 63x48@0 79x65@1 70x75@0 50x61@0 34x75@0 26x65@0 44x48@1 26x29@0
+ "4.?"            ButtonStyle 4 5 39x61@0 61x61@0 39x39@0 61x39@1 39x61@1
+ "4.Small dn Tri" ButtonStyle 4 4 50x65@1 35x35@1 65x35@1 50x65@0
+ "4.Large dn Tri" ButtonStyle 4 4 50x75@1 25x25@1 75x25@1 50x75@0
+ "4.Little Box"   ButtonStyle 4 5 40x40@1 60x40@1 60x60@0 40x60@0 40x40@1
+ "4.dot"          ButtonStyle 4 5 45x45@1 55x45@1 55x55@0 45x55@0 45x45@1
# 'three hashes' for sticky/non sticky
#ButtonStyle 4 12 10x23@0 90x23@0 90x28@0 10x28@1 10x48@1 90x48@0 90x53@0 10x53@1 10x71@2 90x72@0 90x77@0 10x77@1

DestroyMenu Color
AddToMenu Color
+ "Green" Function Green
+ "Mono" Function Mono
+ "Pale bg" Function Pale_BG
+ "test" Function test
DestroyMenu test
AddToFunc test
+ "I" xsetroot -solid
+ "I" Color a/b
+ "I" hilightcolor a b
+ "I" recapture
DestroyMenu test
AddToFunc test
+ "I" xsetroot -solid "#266294"
+ "I" HilightColor Black #5f9ea0
+ "I" Style "*" Color Black/#d3d3d3
+ "I" recapture
DestroyMenu Pale_BG
AddToFunc Pale_BG
+ "I" Exec xsetroot -solid "#bfa498"
+ "I" Style "*" Color Black/#60a0c0
+ "I" hilightcolor black #5f9ea0
+ "I" recapture
DestroyMenu Green
AddToFunc "Green"
+ "I" Exec xsetroot -solid darkgreen
+ "I" Style "*" Color black/lightseagreen
+ "I" hilightcolor black limegreen
+ "I" recapture
DestroyMenu Mono
AddToFunc "Mono"
+ "I" Exec xsetroot -solid black
+ "I" Style "*" color white/black
+ "I" hilightcolor black white
+ "I" recapture

-- 
Todd [email-masked]
http://www.umr.edu/~tfries
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].