Subject: FVWM: Grounded Menu ??

From: "Eric F. Kahler ([email-masked])" <[email-masked]>
Date: Mon, 04 Mar 1996 11:54:16 -0500

Hi,

I was wondering if it is possible to have popup menus gounded to a certain 
area of the screen?  I like to call up my Utilities menu via the keyboard, and 
it would be nice to know where it's going to popup without having to find the 
mouse pointer.

Thanks,
Eric.

-- 
From:  Eric Kahler.
[email-masked] 
http://mars.superlink.net/ekahler/index.html           

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Mon, 04 Mar 1996 12:20:30 -0500

----------
"Eric F. Kahler ([email-masked])" <[email-masked]> writ
> it would be nice to know where it's going to popup without having to find the

Interesting idea, this works:

Key F25      A N Popupat Window-Ops

AddToFunc Popupat "I" CursorMove -1000 -1000
+	          "I" Popup Window-Ops

The cursor move  values are expressed in percent  of pages.  by  Using
-1000, -1000 I am trying to get to the upper left  side of the screen.
A quick test showed me, that it doesn't seem to cross pages they way I
would have thought it  would.  If you  didn't want to  go to 0,0,  you
could move to -1000, -1000, and then move from there.

I imagine something like this could stop working in a future release.

--
Dan Espen                                    Phone: (908) 699-5570
[email-masked]
444 Hoes Lane  Room RRC 1C-214
Piscataway, NJ 08854
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Eric F. Kahler ([email-masked])" <[email-masked]>
Date: Mon, 04 Mar 1996 14:35:21 -0500

> could move to -1000, -1000, and then move from there.

Dan,

Thank you. . . once again.  

The only time this causes a problem is when my mouse pointer is on the edge of 
my desktop -- then it moves me to the next desktop, and then pops up the menu. 
 So far I've had to *try* to create this behavior. . . so I'll take my chances.

Thanks again.
Eric.