Subject: FVWM: Re: [2.0.41] small fixes patch

From: まつしたまこと <[email-masked]>
Date: Sat, 02 Mar 1996 21:59:41 +0900

matusita> Here is a small patch for fvwm-2.0.41 to fix following
matusita> problems. Most of these are already reported to this list.

Oops... I've missed. Here is a right patch. I forget to include the
change of sample.fvwmrc/Imakefile.

- -
Makoto `MAR_kun' MATSUSHITA

--- Fvwm.tmpl.dist	Mon Feb 19 04:27:22 1996
+++ Fvwm.tmpl	Sat Mar  2 21:33:43 1996
@@ -165,11 +165,11 @@
 */
 
 #ifdef RenameFVWM2
-#define FvwmName        fvwm2
-#define FvwmRc          .fvwm2rc
+#define FvwmName fvwm2
+#define FvwmRc .fvwm2rc
 #else
-#define FvwmName        fvwm
-#define FvwmRc          .fvwmrc
+#define FvwmName fvwm
+#define FvwmRc .fvwmrc
 #endif /* RenameFVWM2 */

--- fvwm/placement.c.dist	Tue Apr 25 03:14:08 1995
+++ fvwm/placement.c	Sat Mar  2 21:21:51 1996
@@ -40,7 +40,7 @@
 	  test_window = Scr.FvwmRoot.next;
 	  while((test_window != (FvwmWindow *)0)&&(loc_ok == True))
 	    {	
-	      if(test_window->Desk == Scr.CurrentDesk)
+	      if((test_window->flags & STICKY) || (test_window->Desk == t->Desk))
 		{
 		  if(!(test_window->flags & ICONIFIED)&&(test_window != t))
 		    {
--- modules/FvwmForm/FvwmForm.c.dist	Fri Feb 16 22:59:47 1996
+++ modules/FvwmForm/FvwmForm.c	Sat Mar  2 21:27:57 1996
@@ -181,7 +181,7 @@
 static int N = 8;
 
 /* copy a string until '\0', or up to n chars, and delete trailing spaces */
-char *CopyString (char *cp, int n)
+char *CopyStringN (char *cp, int n)
 {
   char *dp, *bp;
   if (n == 0)
@@ -310,31 +310,31 @@
     else if (strncmp(cp, "Fore", 4) == 0) {
       cp += 4;
       while (isspace(*cp)) cp++;
-      color_names[c_fore] = CopyString(cp, 0);
+      color_names[c_fore] = CopyStringN(cp, 0);
       fprintf(fp_err, "ColorFore: %s\n", color_names[c_fore]);
       continue;
     } else if (strncmp(cp, "Back", 4) == 0) {
       cp += 4;
       while (isspace(*cp)) cp++;
-      color_names[c_back] = CopyString(cp, 0);
+      color_names[c_back] = CopyStringN(cp, 0);
       fprintf(fp_err, "ColorBack: %s\n", color_names[c_back]);
       continue;
     } else if (strncmp(cp, "ItemFore", 8) == 0) {
       cp += 8;
       while (isspace(*cp)) cp++;
-      color_names[c_itemfore] = CopyString(cp, 0);
+      color_names[c_itemfore] = CopyStringN(cp, 0);
       fprintf(fp_err, "ColorItemFore: %s\n", color_names[c_itemfore]);
       continue;
     } else if (strncmp(cp, "ItemBack", 8) == 0) {
       cp += 8;
       while (isspace(*cp)) cp++;
-      color_names[c_itemback] = CopyString(cp, 0);
+      color_names[c_itemback] = CopyStringN(cp, 0);
       fprintf(fp_err, "ColorItemBack: %s\n", color_names[c_itemback]);
       continue;
     } else if (strncmp(cp, "Font", 4) == 0) {
       cp += 4;
       while (isspace(*cp)) cp++;
-      font_names[f_text] = CopyString(cp, 0);
+      font_names[f_text] = CopyStringN(cp, 0);
       fprintf(fp_err, "Font: %s\n", font_names[f_text]);
       xfs[f_text] = GetFontOrFixed(dpy, font_names[f_text]);
       fonts[f_text] = xfs[f_text]->fid;
@@ -342,7 +342,7 @@
     } else if (strncmp(cp, "ButtonFont", 10) == 0) {
       cp += 10;
       while (isspace(*cp)) cp++;
-      font_names[f_button] = CopyString(cp, 0);
+      font_names[f_button] = CopyStringN(cp, 0);
       fprintf(fp_err, "ButtonFont: %s\n", font_names[f_button]);
       xfs[f_button] = GetFontOrFixed(dpy, font_names[f_button]);
       fonts[f_button] = xfs[f_button]->fid;
@@ -350,7 +350,7 @@
     } else if (strncmp(cp, "InputFont", 9) == 0) {
       cp += 9;
       while (isspace(*cp)) cp++;
-      font_names[f_input] = CopyString(cp, 0);
+      font_names[f_input] = CopyStringN(cp, 0);
       fprintf(fp_err, "InputFont: %s\n", font_names[f_input]);
       xfs[f_input] = GetFontOrFixed(dpy, font_names[f_input]);
       fonts[f_input] = xfs[f_input]->fid;
@@ -510,7 +510,7 @@
       cp += 7;
       while (isspace(*cp)) cp++;
       cur_button->button.commands[cur_button->button.n++] =
-	CopyString(cp, 0);
+	CopyStringN(cp, 0);
     }
   }  /* end of switch() */
   /* get the geometry right */
@@ -1525,7 +1525,7 @@
   scr_depth = DefaultDepth(dpy, screen);
   d_cmap = DefaultColormap(dpy, screen);
 
-  ReadConfig(argv[3]);
+  ReadConfig();
 
   GetColors();
 
--- sample.fvwmrc/Imakefile.dist	Sat Mar  2 21:55:29 1996
+++ sample.fvwmrc/Imakefile	Sat Mar  2 20:43:24 1996
@@ -8,5 +8,5 @@
 NullMake()
 
 #ifdef InstallSample
-InstallNonExecFile(system.fvwmrc,$(FVWMDIR))
+InstallNonExecFile(system.fvwmrc,$(FVWMDIR)/FvwmRc)
 #endif
--- sample.fvwmrc/system.fvwmrc.dist	Mon Feb 19 12:18:51 1996
+++ sample.fvwmrc/system.fvwmrc	Sat Mar  2 20:54:48 1996
@@ -194,7 +194,6 @@
 +			"IconBox"	Module	FvwmIconBox
 +			"Banner"	Module	FvwmBanner
 +			"Talk"  	Module	FvwmTalk
-+			"Prompt"	Module	FvwmPrompt "hello" raise
 
 AddToMenu Quit-Verify 	"Really Quit Fvwm?" Title	
 +		      	"Yes, Really Quit"  Quit	
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Tudor Hulubei <[email-masked]>
Date: Thu, 7 Mar 1996 23:22:38 +0200

Hello,

I was wondering if it is possible to have sticky icons that will go
(when restored) back to the screen were they used to stay berfore
being minimized.

Regards,
Tudor

P.S.

Please reply to [email-masked] as I am no longer on the fvwm
mailing list.