Subject: FVWM: button style collection

From: "N. Dan Zou" <[email-masked]>
Date: Fri, 8 Mar 1996 15:13:14 -0800 (PST)

Doing something besides complaining for a change.  Here's a list of 
button styles I've collected from various sources, some come with the 
fvwm source distribution, some I lifted from the dotfile generator, and 
some I created myself by modifying existing ones.

### buttons styles ###
# large up triangle
#ButtonStyle * 4 50x25@1 75x75@0 25x75@0 50x25@1
# large down triangle
#ButtonStyle * 4 50x75@1 25x25@1 75x25@1 50x75@0
# small up triangle
#ButtonStyle * 4 50x35@1 65x65@0 35x65@0 50x35@1
# small down triangle
#ButtonStyle * 4 50x65@1 35x35@1 65x35@1 50x65@0
# the normal big box []
#ButtonStyle * 5 25x25@1 25x75@1 75x75@0 75x25@0 25x25@1
# tall box, looks like ||
#ButtonStyle * 5 40x25@1 60x25@1 60x75@0 40x75@0 40x25@1
# the normal little box .
#ButtonStyle * 5 40x40@1 60x40@1 60x60@0 40x60@0 40x40@1
# very small dot .
#ButtonStyle * 5 45x45@1 55x45@1 55x55@0 45x55@0 45x45@1
# big box crossed by an arrow to a little box, good for iconify
#ButtonStyle * 14 20x20@1 20x70@1 70x70@0 70x20@0 20x20@1 60x60@0 60x50@0 60x60@0 50x60@0 60x60@0 60x80@0 80x80@0 80x60@0 60x60@0
# a nested _| button
#ButtonStyle * 13 10x0@1 80x0@1 80x10@1 80x80@0 0x80@0 0x60@1 10x65@1 70x65@0 70x0@0 55x0@1 55x10@1 55x55@0 10x55@0
# another nested _| (better)
#ButtonStyle * 14 0x0@1 0x20@1 20x20@0 20x0@0 0x0@1 0x25@1 25x25@1 25x0@1 55x0@1 55x55@0 0x55@0 0x60@1 60x60@1 60x0@1
# a / arrow button
#ButtonStyle * 11 80x15@1 45x15@1 55x25@1 25x55@1 15x45@1 15x80@1 50x80@0 40x70@0 70x40@0 80x50@0 80x15@0
# a \ arrow button
#ButtonStyle * 12 55x15@0 45x25@0 75x55@0 85x45@0 85x80@0 50x80@0 60x70@1 30x40@1 20x50@1 20x15@1 55x15@1 55x15@0
#          ^
# vertical | arrow
#          v
#ButtonStyle * 12 50x10@1 25x35@1 40x35@1 40x60@1 25x60@1 50x85@1 75x60@0 60x60@0 60x35@0 75x35@0 50x10@0 50x10@1
# horizontal <-> arrow
#ButtonStyle * 12 10x50@1 35x25@1 35x40@1 65x40@1 65x25@1 90x50@1 65x75@0 65x60@0 35x60@0 35x75@0 10x50@0 10x50@1
#       ^
# an up | arrow
#ButtonStyle * 8 40x80@1 40x50@1 20x50@1 50x20@1 80x50@0 60x50@0 60x80@0 40x80@0
# an down | arrow
#         v
#ButtonStyle * 8 40x20@1 40x50@1 20x50@1 50x80@1 80x50@0 60x50@0 60x20@0 40x20@1
# a left <- arrow
#ButtonStyle * 8 80x40@1 50x40@1 50x20@1 20x50@1 50x80@0 50x60@0 80x60@0 80x40@0
# a right -> arrow
#ButtonStyle * 8 20x40@1 50x40@1 50x20@1 80x50@1 50x80@0 50x60@0 20x60@0 20x40@1
# an X button
#ButtonStyle * 17 20x20@1 30x20@1 50x40@1 70x20@1 80x20@1 80x30@0 60x50@0 80x70@1 80x80@0 70x80@0 50x60@0 30x80@0 20x80@0 20x70@0 40x50@1 20x30@0 20x20@1
# same as the above X, with the lower right leg "squeezed" to give a
# more free-form feel
#ButtonStyle * 16 20x20@1 30x20@1 50x40@1 70x20@1 80x20@1 80x30@0 60x50@0 80x80@0 70x80@0 50x60@0 30x80@0 20x80@0 20x70@0 40x50@1 20x30@0 20x20@1
# an X, plainer-looking
#ButtonStyle * 13 26x29@1 34x21@1 50x35@1 70x21@1 79x29@1 63x48@0 79x65@1 70x75@0 50x61@0 34x75@0 26x65@0 44x48@1 26x29@0
# 4 horizontal bars
#ButtonStyle * 12 10x23@0 90x23@0 90x28@0 10x28@1 10x47@1 90x47@0 90x52@0 10x52@1 10x70@2 90x70@0 90x76@0 10x76@1
# multiple-stacked window
#ButtonStyle * 16 60x40@1 60x80@0 15x80@0 15x40@1 60x40@1 40x40@1 40x25@1 75x25@1 75x60@0 60x60@0 75x60@0 75x40@0 85x40@0 85x15@0 60x15@1 60x25@1

--
N. Dan Zou                           650 Castro Street, Suite 270
Systems Engineer                     Mountain View, California 94041
Stanford Management Group, Inc.      Phone: +1 (415) 903-9591
#include <std/disclaimer.h>          Fax:   +1 (415) 903-9378

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Sean Kelly <[email-masked]>
Date: Fri, 8 Mar 1996 16:44:02 -0700

And here's my lightning bolt, good for close/delete/destroy:

   ButtonStyle 5 7 70x15@0 30x55@1 50x55@0 40x85@1 80x45@0 60x45@1 70x15@0

-- 
Sean Kelly                          
NOAA Forecast Systems Laboratory    [email-masked]
Boulder Colorado USA                http://www-sdd.fsl.noaa.gov/~kelly/
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "N. Dan Zou" <[email-masked]>
Date: Fri, 8 Mar 1996 16:53:01 -0800 (PST)

>    ButtonStyle 5 7 70x15@0 30x55@1 50x55@0 40x85@1 80x45@0 60x45@1 70x15@0

Thanks Sean, actualy I was using a different light bolt, but I forgot to
include it in my last message.  Here it is:

# big lighting bolt 
#ButtonStyle * 8 35x15@1 20x50@1 40x50@0 30x80@1 75x40@0 50x40@1 75x15@0 35x15@1