Subject: FVWM: Caps lock and modifiers

From: [email-masked] (Graeme McCaffery)
Date: Wed, 13 Mar 1996 14:32:17 GMT

I must first admit to being mistified but the alt and diamond keys on the sun keyboard

I'm using a sun with solaris 2.4 

I tried the lines:

xmodmap -e 'clear lock'
xmodmap -e 'add Mod2 Caps_Lock'

the first line worked but the second gives me the message

xmodmap:  commandline:0:  bad add modifier keysym list (empty)
xmodmap:  1 errors encountered, aborting.

secondly how could I bind every thing so that fvwm doesn't interfere with motif applications?

Also is it possible to specify a set geometry that you want FvwmTalk to default to and to always start at no matter how crowded the screen is?

Graeme

p.s. has anyone provided the resize routine for xpm yet?
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Jarl Totland <[email-masked]>
Date: Wed, 13 Mar 1996 15:49:30 +0100 (MET)

> xmodmap:  1 errors encountered, aborting.
Sorry, can't help you there..

> Also is it possible to specify a set geometry that you want FvwmTalk to default to and to always start at no matter how crowded the screen is?
Ouch, long line, aborting..
This is not possible... unless you swallow it in a button :-)
    FvwmButtons FvwmTalk .talkinbuttonrc
  where .talkinbuttonrc is
    Geometry 300x30-0-0
    (Frame 0 Swallow "FvwmTalk" FvwmTalk)
Actually, I have been looking at FvwmTalk, tidying up its behaviour somewhat.
Perhaps I can put in checking .fvwmrc for a geometry line? 

Vyrdsamt,
-Jarl

---

From: <[email-masked]> (Charles Hines)
Date: Wed, 13 Mar 1996 10:03:59 -0500

>>>>> "Jarl" == Jarl Totland <[email-masked]> writes:

Jarl> Graeme McCaffery:
>> Also is it possible to specify a set geometry that you want
>> FvwmTalk to default to and to always start at no matter how crowded
>> the screen is?

Jarl> Ouch, long line, aborting..
Jarl> This is not possible... unless you swallow it in a button :-)
Jarl>     FvwmButtons FvwmTalk .talkinbuttonrc
Jarl>   where .talkinbuttonrc is
Jarl>     Geometry 300x30-0-0
Jarl>     (Frame 0 Swallow "FvwmTalk" FvwmTalk)

Jarl> Actually, I have been looking at FvwmTalk, tidying up its
Jarl> behaviour somewhat.  Perhaps I can put in checking .fvwmrc for a
Jarl> geometry line?

Just so you all know, I have a new module here called FvwmConsole
(written by Toshi Isogai) which is basically a replacement for
FvwmTalk (taking care of some of the FvwmTalk related things on the
TO-DO list as well).

It's got editing and history capabilities, and runs under an XTerm.

I'm still playing with it and plan to put it in the next release.
So I don't know if you want to bother working on FvwmTalk.

Chuck

*******************************************************************************
Charles K. Hines <[email-masked]>
IBM Logic Synthesis developer [BooleDozer (TM)]
Martial Arts Instructor [Modern Arnis, Presas Style Filipino Martial Arts]

IBM Internal email:                        "Go back to sleep, Chuck.  You're
  [email-masked],              just havin' a nightmare--of course,
  HINESC at FISHKILL, HINESC at FSHVMFK1    we are still in Hell." Gary Larson
*******************************************************************************
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Paul D. Smith" <[email-masked]>
Date: Wed, 13 Mar 96 10:20:51 EST

%% Regarding FVWM: Caps lock and modifiers;
%% [email-masked] (Graeme McCaffery) writes:

    gm> I must first admit to being mistified but the alt and diamond
    gm> keys on the sun keyboard I'm using a sun with solaris 2.4

Before venturing into the frozen wasteland of xmodmap, I suggest getting
the excellent ATV called xkeycaps, by Jamie Zawinski.  It will navigate
you safely through the pitfalls.  Get it from:

  ftp://ftp.x.org/contrib/

somewhere.  Have fun!

-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 Senior Software Engineer                                   Bay Networks, Inc.
-----------------------------------------------==<http://www.baynetworks.com/>-
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
     These are my opinions--Bay Networks takes no responsibility for them.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].