Subject: FVWM: trouble w/new FvwmButtons

From: Rich Derr <[email-masked]>
Date: Mon, 11 Mar 1996 08:25:01 -0600 (CST)

The first of Jarl's new FvwmButtons I tried was 080396,
and now I've tried 110396 with the three fvwm patches he
has on his page.  With either version, if I attempt to use
an icon, I get an X error (BadDrawable, I think).  If I
attempt to use a title, I get no error, but FvwmButtons
doesn't run.

   With 080396, this configuration:

*FvwmButtons(2x1 Swallow "FvwmPager" 'Module FvwmPager 0 1')

worked.  (Well, if another button had a Size option
specified, that worked.)  With 110396, that doesn't work.

   I suppose I'll re-install the basic fvwm-2.0.41 sometime
today so I can do some work, but I'm wondering what's going
on.  Unfortunately I have no X11 programming experience, so
I can't help too much.

   This is all with the Xfree86 3.1.2 Mach8 server on
Linux 1.3.69, libc 5.0.9.
--RD
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Mon, 11 Mar 1996 21:06:49 +0100 (MET)

> attempt to use a title, I get no error, but FvwmButtons

*sigh* How come there can be so many problems with a simple little
program like this?? Anyway, as usual I was unable to reproduce the
problem properly. And as usual there is a new release.

The new release has lots of debugging output turned on during 
startup, and there is a sample buttonrc which can be used for
testing. There is even instructions on how to install this separate
from the old FvwmButtons, which probably is a good idea seeing
that it simply will not work for some of you.

> today so I can do some work, but I'm wondering what's going
Hope I haven't made any problems for you, but hey - it's not even in
the beta yet :-)

And again, thanks to all of you who try out FvwmButtons and tell
me what happens. Now, if only some more of you who get it working
can send me small "I did it!" mails, things would get a little
cozier around here :-)

I asked Chuck for this to get in the next fvwm beta, so please: let's
hurry get that one last bug out of there before he decides its too
risky..

Vyrdsamt,
-Jarl

---

From: Rich Derr <[email-masked]>
Date: Mon, 11 Mar 1996 22:29:42 -0600 (CST)

> that it simply will not work for some of you.
   FvwmButtons-110396b.tar must be installed on top of
FvwmButtons-110396.tar; it is missing Fvwm.tmpl.  After
that, compiling went well.

> Hope I haven't made any problems for you, but hey - it's not even in
   I knew there was a reason I bound some menus to the left
mouse button in the root window.  :-)  I know what working
with software in development is like.

> hurry get that one last bug out of there before he decides its too
   OK, here's the report, testing with the included sample:
after making a minor change -- changing jball.xpm to one I
had -- the startup messages look fine, as far as they go.
They end with 'Creating windows...', and I don't get the
'OK' after it.  Also, an xclock is created, but nothing
further happens.

   I've tried removing the lines that swallow other programs
and get the same results, well, except for an xclock showing
up.  Also, FvwmButtons is eating all the CPU it can while
it's hanging.

   If a trace would really help, I can see if I can get it
to dump core in the morning.  Or, maybe that's enough.  Good
luck.  Even though I don't need any of the improvements, I'd 
like to see it work.
--RD
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].