Subject: FVWM: General Question

From: Jonathan Watson <[email-masked]>
Date: Fri, 1 Mar 1996 13:53:38 -0500 (EST)

This is somthing I have been curious about for some time and finally 
decided to ask:
	What purposes do the M4 & CPP pre-processor modules serve?? Since 
I have never used them and don't know anyone who does I haven't been able 
to ask....What do they allow you to do that can't be done w/o them??
	TIA...
		Jon Watson
*-------------------------------------------*-------------------------------*
| The MITRE Corporation			    | Northeastern University       |
| D086 Advanced Systems - Signal Processing | Boston,  Mass., USA.	    |
| Bedford, Mass., USA.		  	    | College of Engineering (EE)   |
|        [email-masked]	 	    |    [email-masked]  |
*-------------------------------------------*-------------------------------*

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: "Carl A. Adams" <[email-masked]>
Date: Fri, 01 Mar 1996 14:47:39 -0500

> Date: Fri, 1 Mar 1996 13:53:38 -0500 (EST)
> From: Jonathan Watson <[email-masked]>
> 

The ablility to do cool stuff as shown below. You could also 
use it to have the same file behave differently on different 
machines (with #ifdef's), #include different colors based on the 
day of the week, or whatever else you can think of.

from my .xsession:

if [ -x $FVWM2 ]
then
  WM=$FVWM2
  $FVWM2 -f "FvwmCpp -Cppopt -I${HOME}/include -Cppopt -DHOME=${HOME} -Cppopt -DMYNAME=${SHORT_MACHINE_NAME} .fvwm2rc" > /dev/console 2>&1 &
  .
  .
  .

and in my .fvwm2rc:

/********************************************************************************
 *                        General Environment                                   *
 ********************************************************************************/

/* Defines and Includes */
#include <X11/mycolors.h>
#define IMAGEPATH HOME/lib/Images
#define DEFAULT_STYLE BorderWidth 5, HandleWidth 5, NoIcon, SmartPlacement, NoPPosition, MWMFunctions, HintOverride, MWMDecor, Color OFF_WHITE_1/DK_GREY, IconBox 1 1 70 -1
#define CONTROL_STYLE NoTitle, NoHandles, Sticky, BorderWidth 3, HandleWidth 3
#define INFO_STYLE NoHandles, Sticky
#define FVWM_STYLE NoTitle, NoHandles, Sticky, WindowListSkip, BorderWidth 0, HandleWidth 0, Icon fvwm.xpm

/* Locations */
ModulePath /usr/contrib/fvwm2/lib
PixmapPath IMAGEPATH/Icons/Apps:IMAGEPATH/Icons/Characters:IMAGEPATH/Icons/Fantasy:/usr/contrib/fvwm2/lib/pixmaps:/usr/X11R5/include/X11/bitmaps
IconPath   IMAGEPATH/Icons/Apps:IMAGEPATH/Icons/Characters:IMAGEPATH/Icons/Fantasy:/usr/contrib/fvwm2/lib/pixmaps:/usr/X11R5/include/X11/bitmaps

[ etc. ]

   --- Carl

---

From: Steve Passe <[email-masked]>
Date: Sun, 03 Mar 1996 12:50:16 -0700

Hi,

>	What purposes do the M4 & CPP pre-processor modules serve?? Since 

I use m4 extensively in my .fvwmrc files.  By keying on `hostname` I can use
the same file for multiple machines.  This is useful for NFS mounted
filesystems as all machines will use the same rc file.  I use m4 macros
to run unix commands, using the results for various things such as 
retrieving my logname, etc.

--
Steve Passe		| powered by
[email-masked]	|            FreeBSD