Subject: Re: FVWM: menu placement, FvwmButtons button placement

From: Alexander Sorg <[email-masked]>
Date: Thu, 22 Feb 1996 13:48:31 -0500 (EST)

Chris Taylor wrote:
> 
> My first question concerns the way FVWM draws menus near the right edge 
of the
> display. I use FVWM-style menus -- submenus appear just as the pointer 
touches
> a menu entry. Normally, a submenu appears to the right of its parent. 
At the
> right edge of the display, however, things get crowded; the submenu appears
> directly on top of its parent. This can be a problem, especially when, 
as in my
> setup, there exist more than two levels of submenus. Could FVWM be 
changed so
> that, at the right edge of the display, a submenu appears to the left 
of its
> parent?

i don't like to see this changed as well. 
another approach could be to make submenues only pop up if you are
on the arrow on the right side of the menu entry.
of course it would be nice if you could choose the different behaviours.

> My second question addresses a long-existing problem: the method by 
...

try this setup to get the xclock to the end of the buttonbar:
 
 *FvwmButtonsFore        DEFAULT_FOREGROUND
 *FvwmButtonsBack        DEFAULT_BACKGROUND
 *FvwmButtonsGeometry    650x40+0-0
 *FvwmButtonsRows        2
 *FvwmButtonsFont        DEFAULT_TITLE_FONT
 *FvwmButtons(1x2)       FVWM    xlogo16.xpm     menu main-menu
 *FvwmButtons(5x2)       -       -       swallow "xloadFvwm" exec xload 
-name xloadFvwm &
 *FvwmButtons            Main            -       desk 0 0
 *FvwmButtons            WebSrv          -       desk 0 1
 *FvwmButtons            Browse1         -       desk 0 2
 *FvwmButtons            Browse2         -       desk 0 3
 *FvwmButtons            Notes           -       desk 0 4
 *FvwmButtons            Post-Its        -       desk 0 5
 *FvwmButtons(1x2)       -       -       swallow "xclockFvwm" exec xclock 
-name xclockFvwm &
 *FvwmButtons            WebLog          -       desk 0 6
 *FvwmButtons            PrxyLog         -       desk 0 7
 *FvwmButtons            Misc1           -       desk 0 8
 *FvwmButtons            Misc2           -       desk 0 9
 *FvwmButtons            Misc3           -       desk 0 10
 *FvwmButtons            Mail            -       desk 0 11
 
       alex     

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Rich Derr <[email-masked]>
Date: Thu, 22 Feb 1996 13:24:10 -0600 (CST)

> of course it would be nice if you could choose the different behaviours.
   But that is how it works ... at least for me.  I have set
MenuStyle ... fvwm and get what you describe.  I tried MenuStyle
... mwm and submenus started popping up immediately.  I moved it
back because I don't like that, either.

> try this setup to get the xclock to the end of the buttonbar:
   I don't have that specific problem, but back in some version
1.2xy GoodStuff was putting buttons wherever it liked with no
regard to order.  The stock 2.0.41 FvwmButtons is doing much
better.  So far I prefer having large buttons activate pop-ups
to having more, smaller buttons, but if I change my mind I'll
remember these hints.

   (Unrelated:  since I don't send much to the list, I'll stick
in here a second for the StickyOnDesk -- or whatever,
StickyOnPage might be better -- style option on the TO-DO list.
I'd love to have an IRC window follow me almost everywhere, but
not to the pages where Netscape or XV are running.  A way to
fiddle with Z-order when starting programs would help, too.
Since I don't have time to do these things, even though I'd
like to, I'll be quiet now.  Go 2.1.0!)
--RD
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Alexander Sorg <[email-masked]>
Date: Thu, 22 Feb 1996 15:07:03 -0500

> back because I don't like that, either.

i see...
this would be nice to have in the manpage. maybe there are 
other "interesting" features that come with the menustyle that 
should be mentioned. i just looked it up and it only
says that
# The style option  is  either  "fvwm"  or  "mwm",  which
#          changes the appearance of the menu.

hopefull, i'm not too demanding chuck

       alex

---

From: <[email-masked]> (Charles Hines)
Date: Thu, 22 Feb 1996 20:56:01 -0500

>>>>> "AS" == Alexander Sorg <[email-masked]> writes:

AS> i see...
AS> this would be nice to have in the manpage. maybe there are
AS> other "interesting" features that come with the menustyle that
AS> should be mentioned. i just looked it up and it only
AS> says that
AS> # The style option  is  either  "fvwm"  or  "mwm",  which
AS> #          changes the appearance of the menu.

AS> hopefull, i'm not too demanding chuck

Well, I'll see about expanding that for the next release.

Chuck