Subject: FVWM: Error output on restart

From: [email-masked] (Drew Lebauer)
Date: Fri, 16 Feb 1996 13:01:03 -0700 (MST)

I've just switched over to 2.0.40 (from 1.23something) on an RS6000, AIX3.2.5.
Every time I use restart to restart fvwm I get the output below (I noticed
this under 1.23 also).  Can you tell me what I can do to fix it?

 X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  25 (X_SendEvent)
  Resource id in failed request:  0x2000002
  Serial number of failed request:  2447
  Current serial number in output stream:  2448
X Error of failed request:  BadDrawable (invalid Pixmap or Window parameter)
  Major opcode of failed request:  69 (X_FillPoly)
  Resource id in failed request:  0x1800001
  Serial number of failed request:  442
  Current serial number in output stream:  445

 *=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*
 |       Drew Lebauer                 |      Phone: (303) 689-1416           |
 |       Rapid Systems Developer      |      Fax:   (303) 689-1399           |
 |       Evolving Systems, Inc.       |      Internet: [email-masked]      |
 *=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*=*
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: <[email-masked]> (Charles Hines)
Date: Fri, 16 Feb 1996 16:10:59 -0500

>>>>> "Drew" == Drew Lebauer <[email-masked]> writes:

Drew> I've just switched over to 2.0.40 (from 1.23something) on an
Drew> RS6000, AIX3.2.5.  Every time I use restart to restart fvwm I
Drew> get the output below (I noticed this under 1.23 also).  Can you
Drew> tell me what I can do to fix it?

Drew>  X Error of failed request:  BadWindow (invalid Window parameter)
Drew>   Major opcode of failed request:  25 (X_SendEvent)
Drew>   Resource id in failed request:  0x2000002
Drew>   Serial number of failed request:  2447
Drew>   Current serial number in output stream:  2448
Drew> X Error of failed request:  BadDrawable (invalid Pixmap or Window parameter)
Drew>   Major opcode of failed request:  69 (X_FillPoly)
Drew>   Resource id in failed request:  0x1800001
Drew>   Serial number of failed request:  442
Drew>   Current serial number in output stream:  445

As a guess, you're probably running FvwmButtons that has swallowed
some programs, right?  If so, you'll probably see these same messages
if you just kill FvwmButtons.

If this is the problem, I wouldn't really worry about it, since there
may not be a lot you can do about it.

Chuck