Subject: FVWM: Another silly question...

From: 4-String <[email-masked]>
Date: Fri, 2 Feb 1996 15:29:05 -0400 (AST)

Is there a way to get you icons to go to a different part of the screen 
when you minimize an application? (i.e. instead of at the bottom left of 
the screen ... usualy under a window!! :( ) I've tried to get the 
FvwmIconBox & FvwmIconMan both to work but neither seem to want work for 
me. The IconBox comes up and when I minimize something it does't go into 
the box and the IconMan doesn't even come up for me. Thanks.

+-----------------------------------------+---------------------------+
| Shane [4-String] Spinney                | "Life is what happens to  |
| BSc(CS) at University of New Brunswick  |  you while you're busy    |
| Fredericton, NB, Canada                 |  making other plans."     |
| [email-masked] , [email-masked]         |             - John Lennon |
+-----------------------------------------+---------------------------+

--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: tim werner <[email-masked]>
Date: Mon, 5 Feb 1996 09:24:14 -0500

>Date: Fri, 2 Feb 1996 15:29:05 -0400 (AST)
>From: 4-String <[email-masked]>

>when you minimize an application?

[email-masked] sent me what I believe is a fairly cogent
explanation.  Once you have your iconboxes defined (see below), you can
specify which type of app goes into which iconbox thusly (e.g.):

  Style "*"           DecorateTransient,IconBox 0 0 -1 70
  Style "XTerm"       IconBox 0 -70 -1 -1

With these specifications, xterm icons go into iconbox {0 -70 -1 -1},
and all other icons go into iconbox {0 0 -1 70}.  For me, this puts most
of the icons along the top, and xterms go in along the bottom, both from
left to right.

hth,
tw

========================================================================
Basically you define the upper left corner and the lower right
corner of the iconbox.

Iconbox 100 200 300 400

The upper left corner is 100 pixels in from the left side of the
screen, 200 pixels down from the top of the screen. The lower
right corner is 300 pixels in from the left side of the screen,
400 pixels down from the top of the screen.

+-------------------+
|                   |
|                   |
|  A-----+          |
|  |     |          |
|  +-----B          |
|                   |
|                   |
|                   |
+-------------------+

A @ 100,200
B @ 300,400

Assume a screen size of 1024x768.

Iconbox 0 0 50 -1
Iconbox 50 -51 -1 -1

A--+----------------+
|  |                |
|  |                |
|  |                |
|  |                |
|  |                |
|  |                |
|  C----------------+
|  |                |
+--B----------------D

A @ 0,0
B @ 50,767 (768 + (-1))
C @ 50,717 (768 + (-51))
D @ 1023,767 (1024 + (-1), 768 + (-1)) == bottom right corner of the screen.

This would define the two regions you desire.
========================================================================