Subject: Re: FVWM: Moving from desktop to desktop...

From: Robert Tarrall <[email-masked]>
Date: Thu, 08 Feb 1996 13:16:54 -0700

tevis_jim wrote:
-> Is there an easy way to set up keys to take me directly to a mapped
-> desktop without having to be in the root window (or the virtual
-> desktop).  I used to have my 9-key numeric keypad mapped to my 3x3
-> virtual desktop using tvtwm (running Solaris 2.5), and it was nice
-> not having to move my pointer off my active windows before using 
-> navigating with the keypad (like with olvwm).   Any suggestions
-> are greatly appreciated!

That's pretty damn snazzy, if I do say so myself.  I liked that one
enough to figure out how to do it... :-)

In my .fvwm2rc, I put:
#    Key name    Context    Modifiers   Action
#    ---------   -------    ---------   ------------
Key KP_Home       A           N        GoToPage 0 0
Key KP_Up         A           N        GoToPage 1 0
Key KP_Prior      A           N        GoToPage 2 0
Key KP_Left       A           N        GoToPage 0 1
Key KP_Begin      A           N        GoToPage 1 1

etc.  This works for me, on an SGI... you might need to change the key names
but other than that it should work.

			-Robert Tarrall.-
			Unix System/Network Admin
			Laboratory for Computational Dynamics
			CU - Boulder
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Robert Tarrall <[email-masked]>
Date: Thu, 08 Feb 1996 14:10:20 -0700

tevis_jim wrote:
-> Thanks Curt/Robert...I'll try that.  What's the difference between
-> A and N in the Modifiers field for this definition?

A is "any", N is "none".  These affect whether or not shift, control,
and meta change the key binding.  If you use "A" then, for example,
<shift>+(whatever) will have the same effect as (whatever) by itself.

You can also specifically refer to:
 S shift
 M meta
 C control
RTFM on fvwm for more info; look for the section on "Key" and "Mouse"
bindings.

			-Robert Tarrall.-