Subject: Re: FVWM: Changing the xterm title bar label

From: [email-masked] (Christopher Wolf)
Date: Thu, 8 Feb 96 10:11:37 CST

>From Mark Valery:
> 
> 
> How do I go about changing the label on an existing xterm titlebar
> from within that xterm?
> I'm running 2.0p38
> 

To change the titlebar or icon, echo one of the following strings within
the xterm in question:

"{ESC}]0;<text>{CTRL-G}"      -  Changes the Icon Name and Titlebar
"{ESC}]1;<text>{CTRL-G}"      -  Changes the Icon Name ONLY
"{ESC}]2;<text>{CTRL-G}"      -  Changes the Titlebar ONLY

Of course, {ESC} is the control character, \033 or Control-V then ESC, and
{CTRL-G} is Control-V then Control-G.

-Wolf
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mark Valery <[email-masked]>
Date: Fri, 9 Feb 1996 16:47:22 -0500

Thanks again to everyone's help for the title bar. 
The updating became automatic as soon as started running 2.0.40.

The 2.0.40 compile on SunOS 4.1.4 with gcc 2.6.3 worked
without a single problem. Thanks to all the code writers.

-----------------------------------------------------------------------
Mark Valery                        |  Internet: [email-masked]
Unitrode Integrated Circuits Corp. |  Fax     : (US) 603-429-8564
Merrimack, NH  USA                 |  Voice   : (US) 603-429-8923 (day)