Subject: FVWM: mouse buttonstyle specification in fvwm1 1.22t

From: "Ken Ore" <[email-masked]>
Date: Fri, 16 Feb 1996 09:46:09 -0600

Hello, all!

	Hope someone can answer this question.  The following lines worked
in fvwm1 version 1.24:

ButtonStyle 2 16 20x20@1 30x20@1 50x40@1 70x20@1 80x20@1 80x30@0 60x50@0
80x80@0 70x80@0 50x60@0 30x80@0 20x80@0 20x70@0 40x50@1 20x30@0 20x20@1
ButtonStyle 4 4 50x35@1 65x65@0 35x65@0 50x35@1
ButtonStyle 6 4 50x65@1 35x35@1 65x35@1 50x65@0

	which allowed me to define a down, up, and X button style on my
windows.  However, I am running fvwm1 version1.22t at work, and when I use
these same lines, I see in my fvwm.console window:

fvwm: Bad button style in line ButtonStyle 2 16 20x20@1 30x20@1 50x40@1 70x20@1
80x20@1 80x30@0 60x50@0 80x80@0 70x80@0 50x60@0 30x80@0 20x80@0 20x70@0 40x50@1
20x30@0 20x20@1

fvwm: Bad button style in line ButtonStyle 4 4 50x35@1 65x65@0 35x65@0 50x35@1

fvwm: Bad button style in line ButtonStyle 6 4 50x65@1 35x35@1 65x35@1 50x65@0

Anyone know how I can do this?  I'd really like to get this to work.  I
appreciate your time.

	--Ken

-- 
 + Ken Ore ~ [email-masked]     		
 | Motorola European Cellular Subscriber Division		
 | 600 N. US Hwy 45, Libertyville, Illinois 60048 USA
 + Work: 847-523-7116
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: <[email-masked]> (Charles Hines)
Date: Fri, 16 Feb 1996 11:08:40 -0500

>>>>> "Ken" == Ken Ore <[email-masked]> writes:

Ken> fvwm: Bad button style in line ButtonStyle 6 4 50x65@1 35x35@1 65x35@1 50x65@0

Ken> Anyone know how I can do this?  I'd really like to get this to work.  I
Ken> appreciate your time.

That ButtonStyle extension was added to 1.xx with version 1.23, I
believe.  So, your best bet is to compile 1.24r for use at work too,
since that will never work with 1.22t.

Chuck