Subject: FVWM: Fvwm 2.0.41

From: Richard Guay <[email-masked]>
Date: Tue, 20 Feb 1996 08:04:09 -0500

Hi,

I just downloaded the latest version and tried to compile it.  All I get 
when I try to make the makefiles is "make: Fatal error in reader: Makefile, 
line 229: unexpected end of line seen".  I tried to comment out the line, 
but it still failed.  Any suggestions?

Richard A. Guay
[email-masked]
http://www.asicint.com

--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Albrecht Kadlec)
Date: Fri, 23 Feb 96 12:26:28 +0100

>>>>> Richard Guay writes:

R> Hi,
R> I just downloaded the latest version and tried to compile it.  All I get 
R> when I try to make the makefiles is "make: Fatal error in reader: Makefile, 
R> line 229: unexpected end of line seen".  I tried to comment out the line, 
R> but it still failed.  Any suggestions?

did you get any answers yet?

I got:
imake -DUseInstalled -I/XTech/lib/X11/config
make: Fatal error in reader: Makefile, line 231: Unexpected end of line seen

this is the line:
XCOMM Template file for Fvwm

I commented out the XCOMM lines from Fvwm.tmpl.

this did more: But I got:
make: Fatal error in reader: Makefile, line 265: Unexpected end of line seen
Current working directory /home/vta_host/albrecht/fvwm-2.0.41/sample.fvwmrc

this looks as follows:
vvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvv
all::
	@echo "make in $(CURRENT_DIR) done"

InstallNonExecFile(system.fvwmrc,$(FVWMDIR))

###########################################################################
# common rules for all Makefiles - do not edit
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

this obviously comes from the imakefile:

#ifdef InstallSample
InstallNonExecFile(system.fvwmrc,$(FVWMDIR))
#endif

setting to InstallSample to NO doesn't help since it's an ifdef.
Commenting it out doesn't help either, since there is an 
#ifndef InstallSample
#define InstallSample NO
further down in Fvwm.tmpl 

So I put out the 
InstallNonExecFile(system.fvwmrc,$(FVWMDIR))
from the Imakefile.

that helped.
Question: 
	Bug in our imake configuration -
		where does this InstallNonExecFile come from?
	Bug in imakefile (ifdef)?

now 'make' worked smooth.

only when I said make install.man, it didn't take the configured path
FvwmManPath but MANDIR:

InstallManPage(program,$(MANDIR))

I changed all instanced of MANDIR to MANPATH.

questions: do I need to have our imake configuration upgraded to handle
XCOMM, InstallNonExecFile or are these bugs.

did I do the right things?
or are there other fixes?

albrecht
-- 
"Research" showed that initial estimates of time and cost were, on
average, out by a factor of Pi.			-- unknown
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Chris Rode <[email-masked]>
Date: Fri, 23 Feb 1996 08:08:30 CST

[email-masked] writes:

} questions: do I need to have our imake configuration upgraded to handle
} XCOMM, InstallNonExecFile or are these bugs.
} 
} did I do the right things?
} or are there other fixes?

i don't know, but i got the same things you did when i first attempted
to build 2.0.41, and the same fixes helped me...i got this under Ultrix
4.3, OSF/1 3.2, and IRIX 5.3...

--chris.

--
chris rode - [email-masked]                -- Help Room Consultant
http://www.public.iastate.edu/~crode/         -- 138 Durham Center, 294-1314
"why don't we just have a stupidity    depeche mode, erasure, moby, new order,
 tax? just tax the stupid people!"     pet shop boys and recoil rock my world.
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Martin Kraemer <[email-masked]>
Date: Fri, 23 Feb 1996 15:40:13 +0100 (MET)

Albrecht Kadlec wrote, ...

> InstallNonExecFile(system.fvwmrc,$(FVWMDIR))

Some time ago, I used to get similar errors in other Imake configurations.
The reason herefore was that, in X11R4 and before, neither XCOMM nor InstallNonExecFile()
used to be defined in imake's config/ files.
Here's what I added (and have since been imake'ing happily fvwm as well as
numerous other imake'ed packages):

______in /usr/lib/X11/config/Imake.tmpl, I added:_____
/*
 * InstallNonExecFile - generate rules to install a data file using any special
 * install flags
 */
#ifndef InstallNonExecFile
#define InstallNonExecFile(file,dest)                                   @@\
install:: file								@@\
	$(INSTALL) -c $(INSTDATFLAGS) file dest
#endif /* InstallNonExecFile */

#ifndef XCOMM
#define XCOMM   #
#ifndef /* XCOMM */

#ifndef MakeDir
#define MakeDir(dir)    @[ -d dir ] || mkdir -p -m 755 dir
#endif /* MakeDir */

#ifndef InstallNamedNonExec
#define InstallNamedNonExec(what,as,where) InstallNonExec(what,where/as)
#endif /* InstallNamedNonExec */
__________________________________________________
That should do it, I think.

    Martin
--
| S I E M E N S |   [email-masked]   |       Siemens Nixdorf
| ------------- |   Voice: +49-89-636-46021     |   Informationssysteme AG
| N I X D O R F |   FAX:   +49-89-636-44994     |    81730 Munich, Germany
~~~~~~~~~~~~~~~~ My opinions only, of course; pgp key available on request
--
Visit the official FVWM web page at <URL:http://www.hpc.uh.edu/fvwm/>.
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].