Subject: FVWM: Moving from desktop to desktop...

From: [email-masked] (tevis_jim)
Date: Thu, 8 Feb 1996 11:51:02 -0800 (PST)

Hello,

Is there an easy way to set up keys to take me directly to a mapped
desktop without having to be in the root window (or the virtual
desktop).  I used to have my 9-key numeric keypad mapped to my 3x3
virtual desktop using tvtwm (running Solaris 2.5), and it was nice
not having to move my pointer off my active windows before using 
navigating with the keypad (like with olvwm).   Any suggestions
are greatly appreciated!

Thanks,
Jim
-- 
      +------------------------------------------------------------+
      |  Jim Tevis                  e-mail   : [email-masked]|
      |  UNIX System Support        Phone    : (408)285-5843       |
      |  Cupertino Campus           Helpdesk : (408)285-5553       |
      +------------------------------------------------------------+
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Curt Tilmes <[email-masked]>
Date: Thu, 08 Feb 1996 15:37:17 -0500

> navigating with the keypad (like with olvwm).   Any suggestions

I map my numeric keypad to a 3x3 virtual desktop like this:

Key KP_1        A       A       GotoPage 0 2
Key KP_2        A       A       GotoPage 1 2
Key KP_3        A       A       GotoPage 2 2
Key KP_4        A       A       GotoPage 0 1
Key KP_5        A       A       GotoPage 1 1
Key KP_6        A       A       GotoPage 2 1
Key KP_7        A       A       GotoPage 0 0
Key KP_8        A       A       GotoPage 1 0
Key KP_9        A       A       GotoPage 2 0

Curt

---

From: [email-masked] (tevis_jim)
Date: Thu, 8 Feb 1996 12:53:30 -0800 (PST)

Thanks Curt/Robert...I'll try that.  What's the difference between
A and N in the Modifiers field for this definition?

Thanks,
Jim

>> That's pretty damn snazzy, if I do say so myself.  I liked that one
>> enough to figure out how to do it... :-)
>> 
>> In my .fvwm2rc, I put:
>> #    Key name    Context    Modifiers   Action
>> #    ---------   -------    ---------   ------------
>> Key KP_Home       A           N        GoToPage 0 0
>> Key KP_Up         A           N        GoToPage 1 0
>> Key KP_Prior      A           N        GoToPage 2 0
>> Key KP_Left       A           N        GoToPage 0 1
>> Key KP_Begin      A           N        GoToPage 1 1
>> 
>> etc.  This works for me, on an SGI... you might need to change the key names
>> but other than that it should work.
>>
>>                        -Robert Tarrall.-
>>                        Unix System/Network Admin
>>                        Laboratory for Computational Dynamics
>>                        CU - Boulder