Subject: FVWM: Key bindings on restart

From: [email-masked] (David Kennedy)
Date: Fri, 9 Feb 1996 22:59:45 GMT

Hi,
I've just noticed something strange, my key bindings to jump between screens
doesn't work after I restart fvwm! (fvwm-2-4.0, on a Solaris 2.4 machine).

My (rather short) list of bindings looks thusly:
Key Left        R       N       Scroll -100 0
Key Right       R       N       Scroll 100 0
Key Up          R       N       Scroll 0 -100
Key Down        R       N       Scroll 0 100
Key q           FITDWS     M       Close
Key q           FITDWS     M3      Close
Key w           FITDWS     M       Iconify 
Key w           FITDWS     M3      Iconify
Mouse 1 R       A       Menu Utilities Nop
Mouse 2 R       A       Menu Window-Ops Nop
Mouse 3 R       A       WindowList
Mouse 0 1       A       Menu Window-Ops2 Close
Mouse 0 2       A       Maximize
Mouse 0 4       A       Iconify

The <>-Q and <>-W etc all work fine, its just my arrow keys that are
rendered impotent by a restart. Any ideas?
-- 
David Kennedy, Dept. of Pure & Applied Physics, Queen's University of Belfast
-----------------------------------------------------------------------------
Email: [email-masked] | URL: http://star.pst.qub.ac.uk/~dcjk/

--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dave Goldberg <[email-masked]>
Date: Mon, 12 Feb 1996 09:44:21 -0500

Perhaps unlikely, but I got bit by it so I'll ask: Do you have a call
to xmodmap in your init/restart functions?  If so, get it out of the
restart function.  Some of the xmodmap mappings can end up acting like
toggles which might mess up your arrow keys or modifiers.  I got bit
by this once.  If I restarted fvwm the swapping of CONTROL and
CAPSLOCK got switched back and my mapping for MOD2 got lost.  I've
sinced put the call to xmodmap directly in my .xsession file.
Dave Goldberg
Post: The Mitre Corporation\MS B020\202 Burlington Rd.\Bedford, MA 01730
Phone: 617-271-3887
Domain: [email-masked]  UUCP: {your neighborhood}!linus!mdf!dsg