Subject: FVWM: IconBox??

From: 4-String <[email-masked]>
Date: Fri, 19 Jan 1996 08:22:42 -0400 (AST)

I just switched to fvwm 2.0.38 and I've been trying to get the 
FvwmIconBox to work. Everytime I start it up I all I get is the icon box 
but no icons in it. Is there something I'm doing wrong??
this is my module definition for the iconbox.

# Module FvwmIconBox
*FvwmIconBoxSortIcons
*FvwmIconBoxPlacement Top Left
*FvwmIconBoxGeometry 1x5+1038-69
*FvwmIconBoxIconBack    black
*FvwmIconBoxIconHiFore  white
*FvwmIconBoxIconHiBack  LightSkyBlue
*FvwmIconBoxBack        DarkViolet
*FvwmIconBoxMouse       1       Click           RaiseLower
*FvwmIconBoxMouse       1       DoubleClick     Iconify
*FvwmIconBoxMouse       2       Click           Iconify -1, Focus
*FvwmIconBoxMouse       3       Click           Module "FvwmIdent" FvwmIdent
*FvwmIconBoxKey         r       RaiseLower
*FvwmIconBoxKey         space   Iconify
*FvwmIconBoxKey         d       Close
# FvwmIconBox built-in functions
*FvwmIconBoxKey         n       Next
*FvwmIconBoxKey         p       Prev
*FvwmIconBoxKey         h       Left
*FvwmIconBoxKey         j       Down
*FvwmIconBoxKey         k       Up
*FvwmIconBoxKey         l       Right
*FvwmIconBox            "*"             unknown1.xpm
*FvwmIconBox            "Fvwm*"         -
*FvwmIconBox            "FvwmFileMgr"   folder2.xpm
*FvwmIconBox            "rxvt"          term.xpm
*FvwmIconBox            "xterm"         xterm.xpm
*FvwmIconBox            "editres"       editres.xpm
*FvwmIconBox            "xman"          xman.xpm
*FvwmIconBox            "xbiff"         mail1.xpm
*FvwmIconBox            "xmh"           mail1.xpm
*FvwmIconBox            "xcalc"         xcalc.xpm
*FvwmIconBox            "GoodStuff"     toolbox.xpm
*FvwmIconBoxMouse       1       Click           RaiseLower
*FvwmIconBoxMouse       1       DoubleClick     Iconify
*FvwmIconBoxMouse       2       Click           Iconify -1, Focus
*FvwmIconBoxMouse       3       Click           Module "FvwmIdent" FvwmIdent
*FvwmIconBoxKey         r       RaiseLower
*FvwmIconBoxKey         space   Iconify
*FvwmIconBoxKey         d       Close
# FvwmIconBox built-in functions
*FvwmIconBoxKey         n       Next
*FvwmIconBoxKey         p       Prev
*FvwmIconBoxKey         h       Left
*FvwmIconBoxKey         j       Down
*FvwmIconBoxKey         k       Up
*FvwmIconBoxKey         l       Right

Any Help would be appreciate.

+-----------------------------------------+---------------------------+
| Shane [4-String] Spinney                |                           |
| BSc(CS) at University of New Brunswick  | COFFEE.EXE Missing -      |
| Fredericton, NB, Canada                 | Insert Cup and Press Any  |
| [email-masked] , [email-masked]         | Key                       |
+---------------------<<--<<<-- The information went data way --------+

--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked]
Date: Fri, 19 Jan 1996 23:43:07 +1100 (EST)

> this is my module definition for the iconbox.

You need to set, in the main part of your .fvwm2rc, all apps to have
no icon. ie:

Style "*" NoIcon

FvwmIconBox will only have icons for apps that have no desktop icon.

--
    ______________________________________________________________________
   /                 _                                 _                  \
  /                 ( \          Ben Buxton           / )                  \
 |        ___________\ \                             / /___________         |
 |       (_)_________   \___       _\\///_       ___/   _________(_)        |  
 |           (______        \     (' o-o ')     /        ______)            |
 |             (____      __ \+------(_)------+/ __      ____)              |
 |               (_______/  \_| Todays quote: |_/  \_______)                |
 |             My PC is a     |       '       |   Gbb ovt?? Gbb onq....     |
 |           Micro$oft Free   +---------------+                             |
 |                Zone          ooO/     \Ooo                               |
 |                 ___   __      __     __    ___                           |
 |       /    /   | _ |    /  | |  \   /  \  |   | |\  /|     /\   |   |    |
 |      /__  /__  ||_|/   /   | |__/ O |     |   | | \/ | O  /__\  |   |    |
  \    /__/ /__/  |___   /__  | |      \__/  |___| |    |   /    \ \___/   /
   \______________________________________________________________________/
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].