Subject: FVWM: Help a FVWM newcomer...

From: "Thomas J. Downey Jr" <[email-masked]>
Date: Tue, 30 Jan 1996 15:49:46 -0600

Hi all,

I'm trying to get fvwm version 2 working. I'm on a sun sparc, SunOS 4.1.
When I run fvwm, I get the following error:
	ld.so: libX11.so.4: not found

I have a libX11.so.4.3, so I made a symbolic link to libX11.so.4, but
still got the same error. I don't know much about this stuff. Is it
looking in the wrong directory for the library?

Any help is appreciated.

Thanks,
Tom

-----------------------------------------------------------------
Tom Downey
PARTEK Inc. 5988 Mid Rivers Mall Dr.  St. Charles, MO 63304
voice: (314)926-2329,  fax: (314)441-6881,  email: [email-masked]
-----------------------------------------------------------------
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Micah_Anderson <[email-masked]>
Date: Tue, 30 Jan 1996 15:08:47 -0800 (PST)

Simple answer: loadlib

Explanitory answer:

Under SunOS, the location of shared libraries is stored in a cache file 
called /etc/ld.so.cache. The cache fileneeds to be rebuilt whenever a 
shared library is added to the system. If you get an error like: ld.so: 
libX11.so.4.20: no found the shared library cache needs to be updated. 
runnind the ldconfig command (as root) should fix your problem. 
Rebooting also works since ldconfig is run from /etc/rc.local at boot 
time (or it ought to be...)

Micah

On Tue, 30 Jan 1996, Thomas J. Downey Jr wrote:

> Date: Tue, 30 Jan 1996 15:49:46 -0600
> From: Thomas J. Downey Jr <[email-masked]>
> To: [email-masked]
> Subject: FVWM: Help a FVWM newcomer...
> 
> 
> Hi all,
> 

------
 Micah Anderson			 WOLFE Internet Access, L.L.C.
 Email: [email-masked]		 2001 Sixth Avenue, Suite 2328 
 Phone: (206) 812-4000 x138      Seattle, WA  98121  USA 
 Pager: (206) 996-2763           Fax: (206) 443-9446

---

From: [email-masked] (Todd Fries)
Date: Wed, 31 Jan 1996 21:27:16 +73800 (CST)

> time (or it ought to be...)

ok.  You can do this.  You can also, as a non-root user, set an environment
variable 'LD_LIBRARY_PATH' to any paths that should be searched for
libraries.

-- 
Todd [email-masked]
http://www.cs.umr.edu/~tfries
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].