Subject: FVWM: Error on fvwm2.0.40

From: [email-masked] (Paulo Berardi)
Date: Wed, 10 Jan 1996 13:17:17 -0300 (GMT-3:00)

Hi,
I am buildin the fvwm version 2.0.40 and have an error when
linking.
Can You help me to undestand what's wrong:

>make
..........................

rm -f fvwm2
gcc -o fvwm2 -O2 -m486 -ansi     -L/usr/X11R6/lib add_window.o
bindings.o     borders.o        builtins.o      colormaps.o
colors.o        complex.o      decorations.o    events.o
focus.o         functions.o     fvwm.o  icons.omenus.o
misc.o  module.o        move.o  placement.o     read.o  resize.o
   style.o         virtual.o       windows.o -lXpm  -lXExExt -lXext
   -lX11 ../libs/libfvwm2.a
   GetFont.o(.text+0x8f): undefined reference to `XLoadQueryFont'
   GetFont.o(.text+0xb3): undefined reference to `XLoadQueryFont'

----------------------------------

Thank you
-- 
Paulo Cesar Berardi
Fundacao Centro Tecnologico Para Informatica
Instituto de Automacao - Departamento Controle Processos
Rodovia D. Pedro I Km. 143,6
13081-970 Campinas SP - Brasil
Tel. +55 (0)192-401011 Ramal 123 -  Fax +50 (0)192-402029
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Oreos <[email-masked]>
Date: Wed, 10 Jan 1996 12:23:24 -0500 (EST)

is there any way to use bitmaps as custom title bar icons?
or are we just limited to ButtonSytle + coordinates?

thx
james

---

From: Mark Powell <[email-masked]>
Date: Wed, 10 Jan 1996 16:56:18 GMT

> Date: Wed, 10 Jan 1996 13:17:17 -0300 (GMT-3:00)
> From: [email-masked] (Paulo Berardi)
> 
> Hi,

This is due to the order of libraries. Either give the command manually
or edit the Makefile to be like this:

gcc -o fvwm2 -O2 -m486 -ansi     -L/usr/X11R6/lib <... object files...> \
        ../libs/libfvwm2.a -lXpm  -lXExExt -lXext -lX11

-- 
Mark Powell, Senior Software Engineer <[email-masked]>
Primagraphics Limited, Graphics Court, Melbourn Science Park,
Melbourn, Royston, Herts SG8 6EJ, England. Tel. +44 1763 262041
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: <[email-masked]> (Charles Hines)
Date: Wed, 10 Jan 1996 16:28:47 -0500

>>>>> "james" == Oreos  <[email-masked]> writes:

james> is there any way to use bitmaps as custom title bar icons?

Not currently, no.

james> or are we just limited to ButtonSytle + coordinates?

For the time being, yes.

Chuck

*******************************************************************************
Charles K. Hines <[email-masked]>
IBM Logic Synthesis developer [BooleDozer (TM)]
Martial Arts Instructor [Modern Arnis, Presas Style Filipino Martial Arts]

IBM Internal email:                        "Go back to sleep, Chuck.  You're
  [email-masked],              just havin' a nightmare--of course,
  HINESC at FISHKILL, HINESC at FSHVMFK1    we are still in Hell." Gary Larson
*******************************************************************************
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].