Subject: Re: FVWM: More newbie ?'s

From: Robert Tarrall <[email-masked]>
Date: Tue, 30 Jan 1996 18:43:53 -0700

"Thomas J. Downey Jr" wrote:
-> The problem was the the LD_LIBRARY_PATH was not set until i ran openwin.
-> I set it in my .cshrc and got past that problem. 
-> 
-> Now I get:
-> 
-> fvwm: can't open display :0
-> 
-> I checked the documentation and FAQ and there is no entry for 
-> "now that I've compiled fvwm, how do I run it?"

(looking at the following after I wrote it, I realize I made several
assumptions about your local setup that may be incorrect.  If so, let
me know...)

When you start OpenWindows with the "openwin" command you usually get
the "olwm" window manager, which is started from /usr/openwin/lib/Xinitrc.
Something that might work would be to copy that file to ~/.xinitrc and
change the three lines that start olwm:
   sleep 15 & pid=$!                       # OpenLook Window Manager
   olwm -syncpid $pid &
   wait $pid                               # Pause until olwm inits
to a line that starts fvwm instead:
   fvwm &
I think you need to make .xinitrc executable ("chmod 0700 ~/.xinitrc")
though I'm not certain... this is all based on my old setup from back in
the Dark Ages when I too was stuck with OpenWindows (spit).

It may be helpful to start OpenWindows with a command like
   openwin >& openwin-errs
so you can look at the file "openwin-errs" if things go wrong and you'll
at least have some idea what the error messages are.

Something else that might help would be to see if anyone else where you
work has startup files (.xinitrc, .openwin-init, etc) that you can use
as a starting point.  That's what a lot of us do... I think there are
probably only about 12 original .xinitrc files in the world... :-)

			-Robert Tarrall.-
			Unix System/Network Admin
			Laboratory for Computational Dynamics
			CU - Boulder
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Robert Tarrall <[email-masked]>
Date: Wed, 31 Jan 1996 14:16:05 -0700

"Thomas J. Downey Jr" wrote:
-> Now that I've got fvwm working on the Sun, I'm trying to get it to compile
-> on a coworker's SGI running Irix 4.0.5:
-> [...]
-> /usr/bin/ld:
-> Undefined:
-> XLoadQueryFont
-> *** Error code 1

Hmmm... isn't this in the FAQ yet?  It ought to be... happens on
all sorts of platforms including IRIX 4-6 and Linux.

The fix is to change the ordering of the libraries in the cc command,
so that ../libs/libfvwm.a comes before -lX11.

			-Robert Tarrall.-

---

From: "Paul D. Smith" <[email-masked]>
Date: Wed, 31 Jan 96 16:48:56 EST

Shouldn't libfvwm come before all other libraries on _every_
architecture?  That just seems like a bug in the Imakefile or whatever.

Seems like it ought to come before libXpm, as well... in short, it
should be the very first library.

-------------------------------------------------------------------------------
 Paul D. Smith <[email-masked]>         Network Management Development
 Senior Software Engineer                                   Bay Networks, Inc.
-----------------------------------------------==<http://www.baynetworks.com/>-
 "Please remain calm...I may be mad, but I am a professional." --Mad Scientist
-------------------------------------------------------------------------------
     These are my opinions--Bay Networks takes no responsibility for them.
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: <[email-masked]> (Charles Hines)
Date: Wed, 31 Jan 1996 17:32:32 -0500

>>>>> "Thomas" == "Thomas J. Downey Jr" wrote:
Thomas> Now that I've got fvwm working on the Sun, I'm trying to get
Thomas> it to compile on a coworker's SGI running Irix 4.0.5:
Thomas> [...]
Thomas> /usr/bin/ld:
Thomas> Undefined:
Thomas> XLoadQueryFont
Thomas> *** Error code 1

>>>>> "Robert" == Robert Tarrall <[email-masked]> writes:

Robert> Hmmm... isn't this in the FAQ yet?  It ought to be... happens on
Robert> all sorts of platforms including IRIX 4-6 and Linux.

I didn't put it in the FAQ, because (as I've posted several times)
it'll be fixed in the next release, and since the FAQ is in the
release, that wouldn't do a lot of good.  It's just taking me a bit
longer than anticipated to get that next release out.

As I also said earlier today, I'm setting up an official FVWM WWW page
and in the future I'll put "temporary" things like this in there.

>>>>> "Greg" == Greg Krasnow <[email-masked]> writes:

Greg> Ok.. here is a patch to makefile.h which will correct the
Greg> problem when compiling fvwm2 under Linux.

Greg> I will put the patch onto a ftp site since this seems to be
Greg> requested often.

I wouldn't bother, since it will be fixed in the next version (soon)
and we'll still have to point people to the patch, which is small
enough that we might as well just post that.

Chuck

---

From: <[email-masked]> (Charles Hines)
Date: Wed, 31 Jan 1996 17:35:15 -0500

>>>>> "Paul" == Paul D Smith <[email-masked]> writes:

Paul> Shouldn't libfvwm come before all other libraries on _every_
Paul> architecture?  That just seems like a bug in the Imakefile or
Paul> whatever.

Paul> Seems like it ought to come before libXpm, as well... in short,
Paul> it should be the very first library.

Basically Yes and Yes.  The fix will be in the next version.

Chuck

ps - for those who haven't seen it yet:

--------------->8 'XLoadQuery-patch' cut here 8<---------------
*** makefile.h.orig     Wed Oct 18 20:10:19 1995
--- makefile.h  Thu Dec 21 12:07:26 1995
***************
*** 58,70 ****

  #ifdef AlphaArchitecture
! LOCAL_LIBRARIES = XPM_LIBRARIES $(ADD_LIB) $(XLIB) -ldnet_stub -L$(FVWM_SRCDIR)/libs -l$(LIB)
  #else
  #ifdef HPArchitecture
! LOCAL_LIBRARIES = XPM_LIBRARIES $(ADD_LIB) $(XLIB) -lV3 -L$(FVWM_SRCDIR)/libs -l$(LIB)
  #else
  #ifdef i386SVR4Architecture
! LOCAL_LIBRARIES = XPM_LIBRARIES $(ADD_LIB) $(XLIB) -lnsl -lsocket -L$(FVWM_SRCDIR)/libs -l$(LIB)
  #else
! LOCAL_LIBRARIES = XPM_LIBRARIES $(ADD_LIB) $(XLIB) $(FVWM_SRCDIR)/libs/lib$(LIB).a
  #endif /* i386SVR4Architecture */
  #endif /* HPArchitecture */
--- 58,70 ----

  #ifdef AlphaArchitecture
! LOCAL_LIBRARIES = -L$(FVWM_SRCDIR)/libs -l$(LIB) XPM_LIBRARIES $(ADD_LIB) $(XLIB) -ldnet_stub
  #else
  #ifdef HPArchitecture
! LOCAL_LIBRARIES = -L$(FVWM_SRCDIR)/libs -l$(LIB) XPM_LIBRARIES $(ADD_LIB) $(XLIB) -lV3
  #else
  #ifdef i386SVR4Architecture
! LOCAL_LIBRARIES = -L$(FVWM_SRCDIR)/libs -l$(LIB) XPM_LIBRARIES $(ADD_LIB) $(XLIB) -lnsl -lsocket
  #else
! LOCAL_LIBRARIES = $(FVWM_SRCDIR)/libs/lib$(LIB).a XPM_LIBRARIES $(ADD_LIB) $(XLIB)
  #endif /* i386SVR4Architecture */
  #endif /* HPArchitecture */
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].