Subject: Re: FVWM: An Openwin feature I miss (window resizing)

From: Robert Tarrall <[email-masked]>
Date: Wed, 31 Jan 1996 12:56:57 -0700

Richard Guay wrote:
-> Uh...it is not the normal behavior on my version.  I would be very intereste
-> d in setting up this capability.  Please post the solution!

I have this in my .fvwmrc:

#	Button	Context	Mods	Function
Mouse	1	FS	A	Function "Resize-or-Raise"

And this in my .fvwm2rc:

Mouse	1	FS	A	Resize-or-Raise

If you're only able to resize when grabbing the corners I suspect
your line says "F" where mine says "FS".  I think I added the "S" to mine
when I was making it work the way SGI's "4Dwm" works...

			-Robert Tarrall.-
			Unix System/Network Admin
			Laboratory for Computational Dynamics
			CU - Boulder
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Gregory Margo <[email-masked]>
Date: Wed, 31 Jan 1996 17:45:54 -0800 (PST)

Thank you to all who replied.  I should have realized this was one of
those things that fvwm is already so good at.  I had my mouse bound
to "move-or-raise" like this:
Mouse  1        TS      A       Move-or-Raise

So I switched it to invoke resizing with the shift key held:
Mouse   1       T       A       Move-or-Raise
Mouse   1       S       N       Move-or-Raise
Mouse   1       S       C       Move-or-Raise
Mouse   1       S       M       Move-or-Raise
Mouse   1       S       S       Resize-or-Raise

------------------------
I found another problem in this process.  Why does this work:
Mouse   1       S       N       Move-or-Raise
Mouse   1       S       C       Move-or-Raise
Mouse   1       S       M       Move-or-Raise

But this does not work:
Mouse   1       S       NCM     Move-or-Raise

gm
+++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++
Gregory H. Margo                 No free speech restrictions on the Internet!
[email-masked]