Subject: FVWM: Need button styles

From: Laurie Kramer <[email-masked]>
Date: Fri, 26 Jan 1996 12:32:39 -0500 (EST)

Hi,

I just downloaded and built fvwm yesterday (it's great!) and am having
trouble making buttons look 3-D.  Specifically I need a button for "Close"
and "Resize".  I found an "X" button but (ok, I'm picky) it's a little too
bold. 

Thanks,

Laurie Kramer
Genome Database
[email-masked]
http://info.gdb.org/~laurie

--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: michael shiplett <[email-masked]>
Date: Fri, 26 Jan 1996 13:42:36 -0500

Here's what I use for resize. It's a shadowed approximation of the twm
nested squares resize icon. NB: it's from fvwm 1.x. I don't know (yet)
if button styles changed in version 2.

ButtonStyle : 2 14 0x0@1 0x20@1 20x20@0 20x0@0 0x0@1 0x25@1 25x25@1
	25x0@1 55x0@1 55x55@0 0x55@0 0x60@1 60x60@1 60x0@1

michael

---

From: <[email-masked]> (Charles Hines)
Date: Fri, 26 Jan 1996 16:37:01 -0500

>>>>> "michael" == michael shiplett <[email-masked]> writes:

michael> Here's what I use for resize. It's a shadowed approximation of the twm
michael> nested squares resize icon. NB: it's from fvwm 1.x. I don't know (yet)
michael> if button styles changed in version 2.

michael> ButtonStyle : 2 14 0x0@1 0x20@1 20x20@0 20x0@0 0x0@1 0x25@1 25x25@1
michael>        25x0@1 55x0@1 55x55@0 0x55@0 0x60@1 60x60@1 60x0@1

Just remove the ':' and the syntax is correct for fvwm2.  Here are a
few that I've collected from people who've posted them or created
myself (the unimaginitive ones):

# up triangle
ButtonStyle 2 4 50x35@1 65x65@0 35x65@0 50x35@1
# down triangle
ButtonStyle 4 4 50x65@1 35x35@1 65x35@1 50x65@0
# big box
ButtonStyle 2 5 25x25@1 25x75@1 75x75@0 75x25@0 25x25@1
# little box
ButtonStyle 8 5 40x40@1 60x40@1 60x60@0 40x60@0 40x40@1
# tall box
ButtonStyle 6 5 40x25@1 60x25@1 60x75@0 40x75@0 40x25@1
# dot
ButtonStyle 4 5 45x45@1 55x45@1 55x55@0 45x55@0 45x45@1
# an up arrow:
ButtonStyle 2 8 40x80@1 40x50@1 20x50@1 50x20@1 80x50@0 60x50@0 60x80@0 40x80@0
# an X
ButtonStyle 3 13 26x29@1 34x21@1 50x35@1 70x21@1 79x29@1 63x48@0 79x65@1 70x75@0 50x61@0 34x75@0 26x65@0 44x48@1 26x29@0
#
# big box crossed by an arrow to a little box, good for iconify
ButtonStyle 4 14 20x20@1 20x70@1 70x70@0 70x20@0 20x20@1 60x60@0 60x50@0 60x60@0 50x60@0 60x60@0 60x80@0 80x80@0 80x60@0 60x60@0

Chuck

*******************************************************************************
Charles K. Hines <[email-masked]>
IBM Logic Synthesis developer [BooleDozer (TM)]
Martial Arts Instructor [Modern Arnis, Presas Style Filipino Martial Arts]

IBM Internal email:                        "Go back to sleep, Chuck.  You're
  [email-masked],              just havin' a nightmare--of course,
  HINESC at FISHKILL, HINESC at FSHVMFK1    we are still in Hell." Gary Larson
*******************************************************************************
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].