Subject: FVWM: Problem compiling fvwm2.0.40 under Linux/XFree86 3.1.1

From: Greg Krasnow <[email-masked]>
Date: Mon, 15 Jan 1996 00:18:59 -0800 (PST)

I was curious as to what the changes were in fvwm2 over fvwm1.x so I am trying to install fvwm2.0.40 on my system.  I am
currently running Linux1.2.13 with XFree86 3.1.1 and using gcc 2.6.3.  Everything compiles fine except for the main fvwm2
module where I am getting the following message in the link stage:

gcc -o fvwm2 -O2 -m486 -ansi     -L/usr/X11R6/lib add_window.o  bindings.o      borders.o       builtins.o      colormaps.o
colors.o    complex.o       decorations.o   events.o        focus.o         functions.o     fvwm.o  icons.o         menus.o
    misc.o      module.o        move.o  placement.o     read.o  resize.o        style.o         virtual.o       windows.o -lXpm
 -lXExExt -lXext -lX11 ../libs/libfvwm2.a
GetFont.o(.text+0x8f): undefined reference to `XLoadQueryFont'
GetFont.o(.text+0xb3): undefined reference to `XLoadQueryFont'
make: *** [fvwm2] Error 1

I did an nm on libX11.a and found that it does indeed have a symbol for XLoadQueryFont in its index.  I left configure.h to be
the default values except I set MODALITY_IS_EVIL.  I just wanted to know if anyone else had a similar problem.  Thanks.

coredump:/usr/X11R6/lib# nm --print-armap libX11.a | grep XLoadQueryFont
_XLoadQueryFont in Font.o
00000000 T _XLoadQueryFont
         U _XLoadQueryFont
         U _XLoadQueryFont

- Greg

Gregory Krasnow			A university is what a college becomes when	
[email-masked]		the faculty loses interest in students.
						-- John Ciardi

--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mark Powell <[email-masked]>
Date: Mon, 15 Jan 1996 09:29:42 +0000 (GMT)

> Date: Mon, 15 Jan 1996 00:18:59 -0800 (PST)
> From: Greg Krasnow <[email-masked]>
...
> module where I am getting the following message in the link stage:
...
> make: *** [fvwm2] Error 1

This is a common problem. There is an error in the Makefile in ./fvwm -
the order of the libraries is wrong, libfvwm should be first:

gcc -o fvwm2 -O2 -m486 -ansi -L/usr/X11R6/lib   ...object files...\
 ../libs/libfvwm2.a -lXpm -lXExExt -lXext -lX11

-- 
Mark Powell, Senior Software Engineer <[email-masked]>
Primagraphics Limited, Graphics Court, Melbourn Science Park,
Melbourn, Royston, Herts SG8 6EJ, England. Tel. +44 1763 262041
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Robert Nation 885-9815)
Date: Mon, 15 Jan 96 08:54:57 EST

> -lXExExt -lXext -lX11 ../libs/libfvwm2.a

The linraries needs to eb in a different order:

should be:
> ../libs/libfvwm2.a -lXExExt -lXext -lX11