Subject: Re: FVWM: Help a FVWM newcomer...

From: "Thomas J. Downey Jr" <[email-masked]>
Date: Tue, 30 Jan 1996 18:16:38 -0600

I wrote:
> When I run fvwm, I get the following error:
> 	ld.so: libX11.so.4: not found

Micah_Anderson wrote:
> Under SunOS, the location of shared libraries is stored in a cache file 
> called /etc/ld.so.cache. The cache fileneeds to be rebuilt whenever a 
> shared library is added to the system. If you get an error like: ld.so: 
> libX11.so.4.20: no found the shared library cache needs to be updated. 

Robert Tarrall wrote:
> Sometimes "setenv LD_LIBRARY_PATH /usr/local/X11/lib" (or wherever
> the X11 library is living) helps too.  OpenWindows is obnoxious about
> playing with your LD_LIBRARY_PATH.

Thanks for the advice. Unfortunately neither of these helped.
I don't know what the Idconfig Micah wrote about is, unless he meant
"Ifconfig". The following command is in my /etc/rc.local file:
	ifconfig -a netmask + broadcast + > /dev/null

I tried issuing that command - no luck. I tried rebooting - no luck.

The LD_LIBRARY_PATH is set to /usr/openwin/lib:

ls -l /usr/openwin/lib/libX11.s*
lrwxrwxrwx  1 root           13 Jul 30  1995 libX11.sa -> libX11.sa.4.3
-r--r--r--  1 root          714 Jan 17  1994 libX11.sa.4.3
lrwxrwxrwx  1 root           13 Jul 30  1995 libX11.so -> libX11.so.4.3
lrwxrwxrwx  1 root           13 Jan 30 15:29 libX11.so.4 -> libX11.so.4.3
-r--r--r--  1 root       270336 Apr  1  1993 libX11.so.4.3

Is there an easy way to link libX11 in statically? I know that would make
fvwm bigger but as a last resort...

Thanks again,
Tom

-----------------------------------------------------------------
Tom Downey
PARTEK Inc. 5988 Mid Rivers Mall Dr.  St. Charles, MO 63304
voice: (314)926-2329,  fax: (314)441-6881,  email: [email-masked]
-----------------------------------------------------------------
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Micah_Anderson <[email-masked]>
Date: Tue, 30 Jan 1996 16:36:41 -0800 (PST)

> Date: Tue, 30 Jan 1996 18:16:38 -0600
> From: Thomas J. Downey Jr <[email-masked]>
> To: [email-masked]
> Subject: Re: FVWM: Help a FVWM newcomer...
> 
> 
> I wrote:

it is ldconfig (lowercase L as in lady) not Idconfig.... forgive me if I 
typed it wrong.

Micah

------
 Micah Anderson			 WOLFE Internet Access, L.L.C.
 Email: [email-masked]		 2001 Sixth Avenue, Suite 2328 
 Phone: (206) 812-4000 x138      Seattle, WA  98121  USA 
 Pager: (206) 996-2763           Fax: (206) 443-9446