Subject: FVWM: Compilation help.

From: [email-masked] (David Kennedy)
Date: Mon, 22 Jan 1996 15:14:57 GMT

(Apologies if this is a stupid question.)

I'm trying to compile FVWM2 (fvwm-2.0.40) on a Sun workstation (Solaris 2.4),
and am having a problem with it.

In configure.h I put:
/* What compiler over-ride's do you want. */
#define FVWM_COMPILER gcc -g -Wall 

to account for Sun's odd compiler.

However I'm getting this error:

making all in ./fvwm...
gcc -g -Wall -O -xF -DSYSV -DSVR4 -xF -Wa,-cg92  -I.  -I/home7/dcjk/lib -I/usr/openwin/include  -DSVR4 -DSYSV     -c  builtins.c
gcc: language F not recognized
builtins.c:999: parse error before `/'
builtins.c: In function `Circulate':
builtins.c:1465: warning: `return' with no value, in function returning non-void
builtins.c:1483: warning: `return' with no value, in function returning non-void
builtins.c: In function `module_zapper':
builtins.c:1617: warning: implicit declaration of function `KillModuleByName'
*** Error code 1
make: Fatal error: Command failed for target `builtins.o'
Current working directory /scratch7/dcjk/fvwm2/fvwm/fvwm
*** Error code 1
make: Fatal error: Command failed for target `all'

Anyone know what this means? I don't see anything wrong but then I never can with someone elses code!
According to the README's and stuff it should compile fine on a Solaris 2.4 machine.

The /home7/dcjk/lib/ mention above is where my Xpm stuff ended up by the way. Any help appreciated.

-- 
David Kennedy, Dept. of Pure & Applied Physics, Queen's University of Belfast
-----------------------------------------------------------------------------
Email: [email-masked] | URL: http://star.pst.qub.ac.uk/~dcjk/

--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mark Powell <[email-masked]>
Date: Mon, 22 Jan 1996 17:07:37 GMT

> Date: Mon, 22 Jan 1996 15:14:57 GMT
> From: [email-masked] (David Kennedy)
> 
> Anyone know what this means? I don't see anything wrong but then I
> never can with someone elses code!  According to the README's and
> stuff it should compile fine on a Solaris 2.4 machine.

This looks like all the extra flags that "Sun's odd compiler"
needs. They will have been provided by the imake configuration in
Solaris 2.4.

If you always want to use gcc, you can add the following line to
/usr/openwin/lib/config/site.def in the #ifdef BeforeVendorCF section:
        #define HasGcc2 YES

Alternatively, take a copy of the xmkmf script from /usr/openwin/bin and
add this to the imake command:
        -DHasGcc2

Hopefully, this will cause the gcc template to be used for your
Makefiles.

Also check that your definition of FVWM_MODULEDIR has quotes around it.

-- 
Mark Powell, Senior Software Engineer <[email-masked]>
Primagraphics Limited, Graphics Court, Melbourn Science Park,
Melbourn, Royston, Herts SG8 6EJ, England. Tel. +44 1763 262041
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Dan Espen <[email-masked]>
Date: Mon, 22 Jan 1996 13:01:24 -0500

Mark Powell <[email-masked]> writes:
> > gcc -g -Wall -O -xF -DSYSV -DSVR4 -xF -Wa,-cg92  -I.  -I/home7/dcjk/lib -I/
> usr/openwin/include  -DSVR4 -DSYSV     -c  builtins.c

That's usually not an error.   At least it is  a warning for me.  Look
further in the output.

--
Dan Espen                                    Phone: (908) 699-5570
[email-masked]
444 Hoes Lane  Room RRC 1C-214
Piscataway, NJ 08854
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mike Blatchley <[email-masked]>
Date: Mon, 22 Jan 1996 16:06:46 -0700 (MST)

> gcc: language F not recognized

Just a warning about unrecognized -xF option with gcc.  Not fatal.

> builtins.c:999: parse error before `/'

In configure.h, put double quotes around the directory name you are 
specifying for FVWM_MODULEDIR.  For example,

#define FVWM_MODULEDIR "/usr/local/lib/X11/fvwm"

Although this line is commented out in the default configure.h file, I would
suggest that quotes be added to this line in the fvwm distribution.  
Also, after I quoted this, it seems like I had problems with the 
'install' program on one of my computers---but, I can't remember for 
sure!!

> builtins.c:1617: warning: implicit declaration of function `KillModuleByName'

More warnings; not fatal.

Hope this helps.

Mike Blatchley
[email-masked]