Subject: FVWM: fvwm-2.0.40 build failed hpux9.05

From: [email-masked] (Neal Becker)
Date: Tue, 2 Jan 96 10:13:18 -0500 (EST)

fvwm-2.0.40 build failed hpux9.05.  Here's the problem:

gcc -o fvwm2  add_window.o  	bindings.o  	borders.o  	builtins.o  	colormaps.o  	colors.o  	complex.o  	decorations.o  	events.o  	focus.o  	functions.o  	fvwm.o  	icons.o  	menus.o  	misc.o  	module.o  	move.o  	placement.o  	read.o  	resize.o  	style.o  	virtual.o  	windows.o -g -O3    -L/usr/lib/X11R5 -L/usr/lib/Motif1.2 -lXpm  -lXext -lX11 -lV3 -L../libs -lfvwm2   
/bin/ld: Unsatisfied symbols:
   XLoadQueryFont (code)

Does anyone know the fix for this?
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mark Powell <[email-masked]>
Date: Tue, 2 Jan 1996 17:24:19 GMT

> Date: Tue, 02 Jan 1996 10:13:18 -0500 (EST)
> From: [email-masked] (Neal Becker)
> 

Edit the fvwm/Makefile to change the order of the libraries to this:
         -L../libs -lfvwm2 -lXpm  -lXext -lX11 -lV3

-- 
Mark Powell, Senior Software Engineer <[email-masked]>
Primagraphics Limited, Graphics Court, Melbourn Science Park,
Melbourn, Royston, Herts SG8 6EJ, England. Tel. +44 1763 262041
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].