Subject: FVWM: problems compiling version 2.0.40

From: [email-masked] (Andreas Kaempf)
Date: Tue, 2 Jan 1996 09:02:01 -0500

hi all....

i am trying to compile version 2.0.40 of fvwm... i am running in to a
ld error and was wondering if anyone has expersienced this problem...

i am compiling the sources using gcc version 2.7.0 and my os is
solaris 2.4... i also have xpm includes and libraries....

here is the error messages i get...

making all in ./modules/FvwmAudio...
make[1]: Entering directory `/home/akaempf/work/fvwm/modules/FvwmAudio'
gcc -O -DSYSV -DSVR4 -Wa,-cg92  -I.  -I/usr/openwin/include  -DSVR4 -DSYSV      -c FvwmAudio.c -o FvwmAudio.o
rm -f FvwmAudio
gcc -o FvwmAudio FvwmAudio.o -O -DSYSV -DSVR4 -Wa,-cg92   -L/usr/openwin/lib  -lXext -lX11 ../../libs/libfvwm2.a  -lsocket -lnsl 
ld: elf error: file ../../libs/libfvwm2.a: unable to locate archive symbol table: Request error: offset out of range 
ld: fatal: File processing errors.  No output written to FvwmAudio

thanks in advance...
andreas
-- 
	Sybase					Andreas Kaempf
	GSS Unix Administrator			617-564-7212
	77 South Bedford St. 5th Floor		3743229   SKYPAGE	
	Burlington, MA	01803			[email-masked]

--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Robert Nation 885-9815)
Date: Tue, 2 Jan 96 09:38:57 EST

>gcc -o FvwmAudio FvwmAudio.o -O -DSYSV -DSVR4 -Wa,-cg92   -L/usr/openwin/lib  -lXext -lX11 ../../libs/libfvwm2.a  -lsocket -lnsl 

-lX11 should appear after ../../libs/libfvwm2.a

Could be an Imake problem or an Imakefile error.
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].