Subject: FVWM: Simple Key Bindings.

From: [email-masked] (David Kennedy)
Date: Tue, 23 Jan 1996 17:27:55 GMT

[Thanks to anyone who offered advice on compiling Fvwm2, it was FVWM_MODULEDIR]

Having finally managed to get FVWM compiled I have a few (minor) problems adapting to it
from 'olvwm'.

I tried to set up key bindings to emulate diamond-w and diamond-q, which iconise
and close windows.

I added this to my .fvwmrc:

Key W      FST   M     Iconify +1

(the help says to use the keyname from /usr/include/X11/keysymdef.h, it doesn't
exist on our system, I used both the number and the name 'W' which appeared under
xmodmap -pke)

This doesn't work. How should it read?

I'm also having problems getting icons to settle in one place.
Style "*" 	IconBox +0 -20 +500 -0
This should be the bottom left corner yes? This is the only reference to IconBox left yet
icons just appear everywhere.

And lastly, and most importantly, does anyone have any idea why I can't use my arrow keys
in aplications like 'Knews' anymore? (I sorted out the SunDoom problem of not being able
to fire [Ctrl] and move [Arrow] keys at the same time. Some bindings are just no worth
it! ;-) )

-- 
David Kennedy, Dept. of Pure & Applied Physics, Queen's University of Belfast
-----------------------------------------------------------------------------
Email: [email-masked] | URL: http://star.pst.qub.ac.uk/~dcjk/

--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Mike Blatchley <[email-masked]>
Date: Tue, 23 Jan 1996 11:12:55 -0700 (MST)

> This doesn't work. How should it read?

I use diamond-q with the following two .fvwmrc key bindings.  The line 
with the 'M3' modifier is to catch the case when the NumLock key has 
been pressed (i.e. mod3).  To be noted are the lower case q's used in the 
definition; upper case won't work.
 
Key q       FTIWS       M      Close 
Key q       FTIWS       M3     Close

> icons just appear everywhere.

Yes, this should be lower left corner.  It does the same thing on my 
systems, but changing the '-0' to '-1' mysteriously makes it work!! Could 
be a bug?

> to fire [Ctrl] and move [Arrow] keys at the same time. Some bindings are just no 
> worth it! ;-) )

Hmmm, all arrow keys work fine in all my applications.  Check out the 
ICCCM COMPLIANCE section of the fvwm man page and the 'Lenience' style.  
I don't know anything about this one, but it may be related.  Or, are the 
arrow keys simply re-mapped to do something else??

Hope this helps.

Mike
======================================================================
      * email: [email-masked] -or- [email-masked] *
              * MIME Mail Reader * PGP Key Available *
======================================================================
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Frank Weis <[email-masked]>
Date: Wed, 24 Jan 1996 13:13:50 +0100 (MET)

> [Thanks to anyone who offered advice on compiling Fvwm2, it was FVWM_MODULEDIR]
I believe the dotrc conversion script makes some assumptions that can be 
quite confusing, regarding the location of awk, and stated above for 
FVWM_MODULEDIR. Maybe the script should ask for FVWM_MODULEDIR, or it 
could be fixed at compilation time.

> icons just appear everywhere.
I think your IconBox is too small (ie not high enough), and IconPlacement 
has a default when an icon can not be placed in the Box (generally 
because the Box is full) You might try -100 instead of -20.
I guess that fvwm tries to put icons topmost-leftmost into the iconbox, so
tuning the height of the box might be a bit trying when you put the box 
on the lower edge of your screen
Hope this helps
Frank
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].