Subject: Re: FVWM: Can't compile in Solaris 2.4

From: [email-masked] (Laurent Duperval)
Date: Fri, 1 Dec 1995 07:31:01 -0500

On Nov 30, Allan Poindexter writes:
> Subject: FVWM: Can't compile in Solaris 2.4
> Can anyone tell me what I am doing wrong here?
> 
> My make bombs out like this:
> 
> Undefined                       first referenced
>  symbol                             in file
> basename                            fvwm.o
> ld: fatal: Symbol referencing errors. No output written to fvwm2
> *** Error code 1

Yes.  You need to add the -lgen flag when linking.

-- 
Laurent Duperval, Systems Analyst       Grafnetix Systems Inc.
Tel: (514) 861-3389                     777, de la Commune Ouest
Fax: (514) 866-6206                     Suite 101, Montreal, Qc
[email-masked]                   Canada, H3C 1Y1
URL: http://www.grafnetix.COM  
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: <[email-masked]> (Charles Hines)
Date: Fri, 1 Dec 1995 08:49:37 -0500

>>>>> "Allan" == Allan Poindexter <[email-masked]> writes:

Allan> Can anyone tell me what I am doing wrong here?
Allan> My make bombs out like this:
....
Allan> Undefined                       first referenced
Allan>  symbol                             in file
Allan> basename                            fvwm.o

This is because I wasn't thinking when I put that in there...  Go into
fvwm.c and remove the basename reference and all will go well.

I've removed this for the next pl.  I'm not even certain why I put it
in there in the first place.

Chuck