Subject: FVWM: FvwmWinList and FvwmIconBox don't like popups

From: Allan Poindexter <[email-masked]>
Date: Wed, 20 Dec 1995 09:48:42 -0600

Does anyone know why the following mouse settings don't work for FvwmIconBox
(and similar settings don't work for FvwmWinList)?

*FvwmIconBoxMouse	1	Click		Iconify -1, Focus
*FvwmIconBoxMouse	2	Click		Iconify
*FvwmIconBoxMouse	3	Click		Popup "Window-Ops"
*FvwmIconBoxMouse	3	DoubleClick	RaiseLower

With these settings using mouse 3 crashes fvwm.

Here is Window-Ops def:

AddToMenu "Window-Ops" "Window Ops" Title
+		"&Move" Function Move-or-Raise
+		"&Resize" Function Resize-or-Raise
+		"R&aise" Raise
+		"&Lower" Lower
+		"(De)&Iconify" Iconify
+		"(Un)&Stick" Stick
+		"(Un)Ma&ximize" Function maximize_func
+		"" Nop
+		"Destroy" Destroy
+		"Delete" Delete
+		"" Nop
+		"Re&fresh Screen" Refresh
+		"Scroll&Bar" Module FvwmScroll 2 2

--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: <[email-masked]> (Charles Hines)
Date: Wed, 20 Dec 1995 13:02:18 -0500

>>>>> "Allan" == Allan Poindexter <[email-masked]> writes:

Allan> Does anyone know why the following mouse settings don't work
Allan> for FvwmIconBox (and similar settings don't work for
Allan> FvwmWinList)?

Allan> *FvwmIconBoxMouse        1       Click           Iconify -1, Focus
Allan> *FvwmIconBoxMouse        2       Click           Iconify
Allan> *FvwmIconBoxMouse        3       Click           Popup "Window-Ops"
Allan> *FvwmIconBoxMouse        3       DoubleClick     RaiseLower

Allan> With these settings using mouse 3 crashes fvwm.

Hm.  I wouldn't have expected a crash, but in general Modules don't
handle popups very well (happens on button release instead of button
press).

Chuck