Subject: FVWM: Problem with de-iconify'ng windows not being on top.

From: Rob Windsor <[email-masked]>
Date: Sat, 16 Dec 1995 01:51:31 -0800

Heyyo,

I sent a piece of e-mail awhile back about apps that de-iconify underneath
other xterms or apps.  I thought the problem might have been isolated to
the NetBSD/sparc (v1.1) setup, but it isn't.

I'm seeing the same problems under NetBSD/i386. (v1.1)

This is -very- annoying.  I'm currently working around the problem by
simply not iconify'ng anything.

I have a fairly vanilla setup, I can provide my .fvwmrc files upon request.

This is the same symptom that was fixed somewhere between 1.22q and 1.24r,
I can grab the 1.24r tarball and point to the reference in the ChangeLog.

I can help with some debugging if need be, I really need to see this fixed.

Otherwise, it's a perfect window manager (for me).  Keep up the good work.

-- Rob
----------------------------------------
Internet: [email-masked]      Life: [email-masked]
"Da Web": http://pobox.com/~windsor/

"Ain't much distance 'tween a pat on the back and a kick in the pants."
    -- David Lee Roth (1990), `The Dogtown Shuffle'
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: [email-masked] (Robert Nation 885-9815)
Date: Mon, 18 Dec 95 09:19:16 EST

I guess you're saying that when fvwm de-iconifies windows, it doesn't raise
them. This is deliberate, because you control it in your .fvwmrc file.

Instead of Iconify, use Iconify-Func:

AddToFunc Iconify-Func  "I" Iconify
+ 			  "I" Raise

Then it is not a problem.
--
To unsubscribe from the list, send "unsubscribe fvwm" in the body of a
message to [email-masked].
To report problems, send mail to [email-masked].

---

From: Rob Windsor <[email-masked]>
Date: Mon, 18 Dec 1995 06:26:46 -0800

> Then it is not a problem.

Woo-woo!  Cool!  (it works)

(Say, is this in the FAQ, and if not, could someone put it in, for others?)

-- Rob

---

From: <[email-masked]> (Charles Hines)
Date: Mon, 18 Dec 1995 14:38:50 -0500

>>>>> "Rob" == Rob Windsor <[email-masked]> writes:

>> Then it is not a problem.

Rob> Woo-woo!  Cool!  (it works)

Rob> (Say, is this in the FAQ, and if not, could someone put it in,
Rob> for others?)

I'll see that it gets put into the included .fvwmrc file, at least.
Perhaps the FAQ as well.

Chuck